%%phrase%%

O2S.Components.PDF4NET Send comments on this topic.
O2S.Components.PDF4NET Assembly

Namespaces

Namespace | Description
O2S.Components.PDF4NET |
O2S.Components.PDF4NET.Actions |
O2S.Components.PDF4NET.Annotations |
O2S.Components.PDF4NET.Forms |
O2S.Components.PDF4NET.Forms.XFA |
O2S.Components.PDF4NET.Functions |
O2S.Components.PDF4NET.Graphics |
O2S.Components.PDF4NET.Graphics.Barcodes |
O2S.Components.PDF4NET.Graphics.ColorSpaces |
O2S.Components.PDF4NET.Graphics.Fonts |
O2S.Components.PDF4NET.Graphics.Shapes |
O2S.Components.PDF4NET.Graphics.Shapes.Transparency |
O2S.Components.PDF4NET.PDFFile |
O2S.Components.PDF4NET.PDFFile.Resources |
O2S.Components.PDF4NET.Security |

© O2 Solutions 2003 - 2008. All Rights Reserved.


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%ItemTitle%%

O2S.Components.PDF4NET Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PageNumber | Defines the visual aspect of the page number when it is drawn on the page Supported by Compact .NET Edition.
PageNumberingRange | Defines a series of consecutive pages within the PDF document using the same numbering system Supported by Compact .NET Edition.
PageNumberingRangeCollection | Defines a collection of page numbering ranges.
PDFBaseObject | Represents the base class for all objects in a PDF file.
PDFBasicCanvas | Encapsulates a page's drawing surface. Supported by Compact .NET Edition.
PDFCanvas | Encapsulates a page's drawing surface. Supported by Compact .NET Edition.
PDFCMLogicalUnit | Defines the centimeter as a logical unit.
PDFDocument | Encapsulates the logic of a pdf document. Supported by Compact .NET Edition.
PDFDocumentAttachment | Defines a file embedded in a PDF document.
PDFDocumentAttachmentCollection | Defines a collection of document attachments displayed on a PDF page.
PDFDocumentInformation | Defines the document's general information. Supported by Compact .NET Edition.
PDFException | Defines the exceptions thrown by the PDF4NET library. Supported by Compact .NET Edition.
PDFInchLogicalUnit | Defines the inch as a logical unit.
PDFJavaScriptBlock | Defines a block of JavaScript code.
PDFJavaScriptCollection | Defines a collection of JavaScript blocks.
PDFLogicalUnitBase | Base class for all the classes that implement custom logical units.
PDFMetadataSchema | Defines a schema within the document's metadata Supported by Compact .NET Edition.
PDFMetadataSchemas | Defines a collection of metadata schemas.
PDFMMLogicalUnit | Defines the millimeter as a logical unit.
PDFObject | Base class for all objects within PDF hierarchy. Supported by Compact .NET Edition.
PDFOutline | Defines an outline in the outlines tree hierarchy Supported by Compact .NET Edition.
PDFOutlines | Defines a list of children outlines belonging to a parent outline. Supported by Compact .NET Edition.
PDFPage | Defines a page within the pdf document. Supported by Compact .NET Edition.
PDFPageBackground | Defines a background for a PDF page.
PDFPages | Defines a collection of pages. Supported by Compact .NET Edition.
PDFPageTemplate | Defines a common graphic pattern applied to a series of pages in the document. Supported by Compact .NET Edition.
PDFPageTransition | Defines the transition effects between pages of a document.
PDFParserException | Defines the exceptions thrown by the pdf parser.
PDFPointLogicalUnit | Defines the point (pdf unit) as a logical unit.
PDFViewerPreferences | Defines the viewer preferences for the document Supported by Compact .NET Edition.
SaveProgressEventArgs | Defines the arguments for SaveProgress event.

Delegates

Delegate | Description
PDFDocument.SaveProgressEventHandler | The delegate for SaveProgress event.

Enumerations

Enumeration | Description
ColorSpace | Specifies the available color representation modes in the pdf file Supported by Compact .NET Edition.
DisplayMode | Specifies how the document should be displayed when it is opened. Supported by Compact .NET Edition.
NumberingStyle | Specifies the available styles when setting up a page numbering range. Supported by Compact .NET Edition.
OutlineDisplay | Combination of styles when displaying the outline in the outline tree in the viewer Supported by Compact .NET Edition.
PageLayout | Specifies the page layout to be used when the document is opened. Supported by Compact .NET Edition.
PageOrientation | Specifies the possible orientations for a page Supported by Compact .NET Edition.
PageSize | Specifies the predefined page sizes. Supported by Compact .NET Edition.
PageTransitionEffect | Specifies the available transition modes between pages.
PDFVersion | Specifies the available PDF versions to save a PDF document.
TransitionAngleDirection | Specifies the available angles for the transition.
TransitionDimension | Specifies the available directions for transitions.
TransitionMotionDirection | Specifies the motion direction of the transition.
XAxisDirection | Specifies the available directions for the X axis of the page canvas.
YAxisDirection | Specifies the available directions for the Y axis of the page canvas.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PageNumber
O2S.Components.PDF4NET.PageNumberingRange
O2S.Components.PDF4NET.PageNumberingRangeCollection
O2S.Components.PDF4NET.PDFBasicCanvas
O2S.Components.PDF4NET.PDFCanvas
O2S.Components.PDF4NET.PDFDocument
O2S.Components.PDF4NET.PDFDocumentAttachment
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
O2S.Components.PDF4NET.PDFDocumentInformation
O2S.Components.PDF4NET.PDFJavaScriptBlock
O2S.Components.PDF4NET.PDFJavaScriptCollection
O2S.Components.PDF4NET.PDFMetadataSchema
O2S.Components.PDF4NET.PDFMetadataSchemas
O2S.Components.PDF4NET.PDFOutline
O2S.Components.PDF4NET.PDFOutlines
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFPageTemplate
O2S.Components.PDF4NET.PDFPageBackground
O2S.Components.PDF4NET.PDFPages
O2S.Components.PDF4NET.PDFPageTransition
O2S.Components.PDF4NET.PDFViewerPreferences
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFCMLogicalUnit
O2S.Components.PDF4NET.PDFInchLogicalUnit
O2S.Components.PDF4NET.PDFMMLogicalUnit
O2S.Components.PDF4NET.PDFPointLogicalUnit
System.EventArgs
O2S.Components.PDF4NET.SaveProgressEventArgs
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFParserException

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PageNumber Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PageNumber Class

Defines the visual aspect of the page number when it is drawn on the page

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageNumber
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
C#
public sealed class PageNumber : PDFObject
Delphi
public class PageNumber = class(PDFObject)sealed;
Managed Extensions for C++
public __gc __sealed class PageNumber : public PDFObject
C++/CLI
public ref class PageNumber sealed : public PDFObject

Remarks

This class works in conjunction with PageNumberingRange class. In order to have the page number automatically drawn on the page, at least one numberig range must be defined for the document and the page must be included in the interval defined by the numbering range.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PageNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PageNumber Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PageNumber Class

The following tables list the members exposed by PageNumber.

Public Constructors

 | Name | Description
Public Constructor | PageNumber Constructor | Initializes a new PageNumber object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to draw the page number. Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the page number. Supported by Compact .NET Edition.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the page number. Supported by Compact .NET Edition.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number. Supported by Compact .NET Edition.
Top

See Also

Reference

PageNumber Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageNumber Constructor
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : PageNumber Constructor

Initializes a new PageNumber object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageNumber()
C#
public PageNumber()
Delphi
public PageNumber();
Managed Extensions for C++
public: PageNumber();
C++/CLI
public:
PageNumber();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%% $$Properties$$

PageNumber Class Properties
[image]
O2S.Components.PDF4NET Namespace : PageNumber Class

For a list of all members of this type, see PageNumber members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to draw the page number. Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the page number. Supported by Compact .NET Edition.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the page number. Supported by Compact .NET Edition.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number. Supported by Compact .NET Edition.
Top

See Also

Reference

PageNumber Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : Align Property

Gets or sets the alignment of text used to draw the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Align As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As TextAlign

instance.Align = value

value = instance.Align
C#
public TextAlign Align {get; set;}
Delphi
public read-write property Align: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_Align();
public: __property void set_Align(
   TextAlign value
);
C++/CLI
public:
property TextAlign Align {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

A TextAlign enumeration member used to position the page number within the page.

Remarks

This property is used to position the page number within the page. Top and bottom alignments use VerticalOffset property to position the page number. Left and right alignments use HorizontalOffset property to position the page number. Middle and center alignments center the page number on vertical, respectivelly on horizontal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : Brush Property

Gets or sets the brush used to draw the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

a Brush object used to draw the page number.

Remarks

This Brush object is used to fill the interior of the text representing the page number. If this is null, then the text will be drawn unfilled. The default value of this property is a brush of black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : Font Property

Gets or sets the font used to draw the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the page number

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

HorizontalOffset Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : HorizontalOffset Property

Gets or sets the horizontal offset used to position the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property HorizontalOffset As Single
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As Single

instance.HorizontalOffset = value

value = instance.HorizontalOffset
C#
public float HorizontalOffset {get; set;}
Delphi
public read-write property HorizontalOffset: Single;
Managed Extensions for C++
public: __property float get_HorizontalOffset();
public: __property void set_HorizontalOffset(
   float value
);
C++/CLI
public:
property float HorizontalOffset {
   float get();
   void set (float value);
}

Return Value

a float value specifying the horizontal offset

Remarks

The horizontal offset is used when the page number is left or right aligned.

When the page number is left aligned, the horizontal offset represents the distance between the left margin of the page and the left corner of the rectangle bounding the page number.

When the page number is right aligned, the horizontal offset represents the distance between the right margin of the page and the right corner of the rectangle bounding the page number.

When the page number is center aligned on the horizontal, the horizontal offset is not used. The horizontal center of the bounding rectangle is positioned at half of page width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : Pen Property

Gets or sets the pen used to draw the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

a Pen object used to draw the page number.

Remarks

This Pen object is used to draw the border of the text representing the page number. If this is null, then the text will be drawn without border. The default value of this property is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

VerticalOffset Property
[image]
O2S.Components.PDF4NET Namespace > PageNumber Class : VerticalOffset Property

Gets or sets the vertical offset used to position the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property VerticalOffset As Single
Visual Basic (Usage) Copy Code
Dim instance As PageNumber
Dim value As Single

instance.VerticalOffset = value

value = instance.VerticalOffset
C#
public float VerticalOffset {get; set;}
Delphi
public read-write property VerticalOffset: Single;
Managed Extensions for C++
public: __property float get_VerticalOffset();
public: __property void set_VerticalOffset(
   float value
);
C++/CLI
public:
property float VerticalOffset {
   float get();
   void set (float value);
}

Return Value

a float value specifying the vertical offset

Remarks

The vertical offset is used when the page number is top or bottom aligned.

When the page number is top aligned, the vertical offset represents the distance between the top margin of the page and the top corner of the rectangle bounding the page number.

When the page number is bottom aligned, the vertical offset represents the distance between the bottom margin of the page and the bottom corner of the rectangle bounding the page number.

When the page number is middle aligned on the vertical, the vertical offset is not used. The vertical middle of the bounding rectangle is positioned at half of page height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumber Class
PageNumber Members


%%PageItemTitle%%

PageNumberingRange Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRange Class

Defines a series of consecutive pages within the PDF document using the same numbering system

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageNumberingRange
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
C#
public sealed class PageNumberingRange : PDFObject
Delphi
public class PageNumberingRange = class(PDFObject)sealed;
Managed Extensions for C++
public __gc __sealed class PageNumberingRange : public PDFObject
C++/CLI
public ref class PageNumberingRange sealed : public PDFObject

Remarks

A numbering range defines a set of consecutive pages that use the same numbering system. The range is considered to start from the page specified by StartPageIndex property and ends at the last page of the document. If multiple numbering ranges are defined, then a numbering range ends where the next numbering range starts. The numbering ranges of a document are ordered ascending by StartPageIndex property.

For example, a document has an introduction on first 3 pages, then it starts first chapter from the 4th page. A numbering range starting at index zero can be defined for the introduction using roman numerals, then a new numbering range can be defined starting at index 3 using arabic numerals. For this new range, the start page number can be set to 1, this being the first logical page, although it is the 4th physical page in the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PageNumberingRange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PageNumberingRange Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRange Class

The following tables list the members exposed by PageNumberingRange.

Public Constructors

 | Name | Description
Public Constructor | PageNumberingRange Constructor | Initializes a new PageNumberingRange object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object. Supported by Compact .NET Edition.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number. Supported by Compact .NET Edition.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts. Supported by Compact .NET Edition.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range. Supported by Compact .NET Edition.
Top

See Also

Reference

PageNumberingRange Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageNumberingRange Constructor
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : PageNumberingRange Constructor

Initializes a new PageNumberingRange object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange()
C#
public PageNumberingRange()
Delphi
public PageNumberingRange();
Managed Extensions for C++
public: PageNumberingRange();
C++/CLI
public:
PageNumberingRange();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%% $$Properties$$

PageNumberingRange Class Properties
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRange Class

For a list of all members of this type, see PageNumberingRange members.

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object. Supported by Compact .NET Edition.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number. Supported by Compact .NET Edition.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts. Supported by Compact .NET Edition.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range. Supported by Compact .NET Edition.
Top

See Also

Reference

PageNumberingRange Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

NumberingStyle Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : NumberingStyle Property

Gets or sets the visual style of the page numbers for this PageNumberingRange object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property NumberingStyle As NumberingStyle
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
Dim value As NumberingStyle

instance.NumberingStyle = value

value = instance.NumberingStyle
C#
public NumberingStyle NumberingStyle {get; set;}
Delphi
public read-write property NumberingStyle: NumberingStyle;
Managed Extensions for C++
public: __property NumberingStyle get_NumberingStyle();
public: __property void set_NumberingStyle(
   NumberingStyle value
);
C++/CLI
public:
property NumberingStyle NumberingStyle {
   NumberingStyle get();
   void set (NumberingStyle value);
}

Return Value

a NumberingStyle enumeration member specifying the numbering style for this PageNumberingRange object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%%

PageNumberPrefix Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : PageNumberPrefix Property

Gets or sets the prefix that will be appended in front of the page number.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageNumberPrefix As String
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
Dim value As String

instance.PageNumberPrefix = value

value = instance.PageNumberPrefix
C#
public string PageNumberPrefix {get; set;}
Delphi
public read-write property PageNumberPrefix: String;
Managed Extensions for C++
public: __property string* get_PageNumberPrefix();
public: __property void set_PageNumberPrefix(
   string* value
);
C++/CLI
public:
property String^ PageNumberPrefix {
   String^ get();
   void set (String^ value);
}

Return Value

a String value representing a prefix that is appended to all the page numbers in this range.

Remarks

This prefix is printed on the pages in the range before the page number. All pages in a range share the same prefix. This prefix is also visible in the Print dialog box of the PDF viewer, when specifing a range of pages to print.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%%

PageNumberSuffix Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : PageNumberSuffix Property

Gets or sets the suffix that will be appended at the end of the page number.

Syntax

Visual Basic (Declaration)
Public Property PageNumberSuffix As String
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
Dim value As String

instance.PageNumberSuffix = value

value = instance.PageNumberSuffix
C#
public string PageNumberSuffix {get; set;}
Delphi
public read-write property PageNumberSuffix: String;
Managed Extensions for C++
public: __property string* get_PageNumberSuffix();
public: __property void set_PageNumberSuffix(
   string* value
);
C++/CLI
public:
property String^ PageNumberSuffix {
   String^ get();
   void set (String^ value);
}

Return Value

a String value representing a suffix that is appended to all the page numbers in this range.

Remarks

This prefix is printed on the pages in the range after the page number. All pages in a range share the same suffix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%%

StartPageIndex Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : StartPageIndex Property

Gets or sets the start page where the numbering range starts.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property StartPageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
Dim value As Integer

instance.StartPageIndex = value

value = instance.StartPageIndex
C#
public int StartPageIndex {get; set;}
Delphi
public read-write property StartPageIndex: Integer;
Managed Extensions for C++
public: __property int get_StartPageIndex();
public: __property void set_StartPageIndex(
   int value
);
C++/CLI
public:
property int StartPageIndex {
   int get();
   void set (int value);
}

Return Value

an integer value specifying the zero based index of the page where the numbering range starts. The index is considered within the pages collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%%

StartPageNumber Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRange Class : StartPageNumber Property

Gets or sets the page number the numbering of the pages starts for this range.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property StartPageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRange
Dim value As Integer

instance.StartPageNumber = value

value = instance.StartPageNumber
C#
public int StartPageNumber {get; set;}
Delphi
public read-write property StartPageNumber: Integer;
Managed Extensions for C++
public: __property int get_StartPageNumber();
public: __property void set_StartPageNumber(
   int value
);
C++/CLI
public:
property int StartPageNumber {
   int get();
   void set (int value);
}

Return Value

an integer value specifying the start page number for this PageNumberingRange object.

Remarks

This property specifies the page number that will be printed on the first page in this range. The other pages will be numbered consecutively, starting from this value. It represents a logical page number and it is related to the specific content of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRange Class
PageNumberingRange Members


%%PageItemTitle%%

PageNumberingRangeCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRangeCollection Class

Defines a collection of page numbering ranges.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PageNumberingRangeCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class PageNumberingRangeCollection : PDFObject
Delphi
public class PageNumberingRangeCollection = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PageNumberingRangeCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PageNumberingRangeCollection sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PageNumberingRangeCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PageNumberingRangeCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRangeCollection Class

The following tables list the members exposed by PageNumberingRangeCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of page numbering ranges in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the page numbering range at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a page numbering range to the collection at the end of the collection.
Public Method | Clear | Clear the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the page numbering range from the collection.
Public Method | RemoveAt | Removes the page numbering range at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PageNumberingRangeCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRangeCollection Class

For a list of all members of this type, see PageNumberingRangeCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a page numbering range to the collection at the end of the collection.
Public Method | Clear | Clear the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the page numbering range from the collection.
Public Method | RemoveAt | Removes the page numbering range at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Add Method

pageNumberingRange
a PageNumberingRange object to be added to the collection
Adds a page numbering range to the collection at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal pageNumberingRange As PageNumberingRange _
)
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim pageNumberingRange As PageNumberingRange

instance.Add(pageNumberingRange)
C#
public void Add(
   PageNumberingRange pageNumberingRange
)
Delphi
public procedure Add(
    pageNumberingRange: PageNumberingRange
);
Managed Extensions for C++
public: void Add(
   PageNumberingRange* pageNumberingRange
)
C++/CLI
public:
void Add(
   PageNumberingRange^ pageNumberingRange
)

Parameters

pageNumberingRange
a PageNumberingRange object to be added to the collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Clear Method

Clear the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

This method removes all page numbering ranges from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Remove Method

pageNumberingRange
The page numbering range to be removed.
Removes the page numbering range from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal pageNumberingRange As PageNumberingRange _
)
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim pageNumberingRange As PageNumberingRange

instance.Remove(pageNumberingRange)
C#
public void Remove(
   PageNumberingRange pageNumberingRange
)
Delphi
public procedure Remove(
    pageNumberingRange: PageNumberingRange
);
Managed Extensions for C++
public: void Remove(
   PageNumberingRange* pageNumberingRange
)
C++/CLI
public:
void Remove(
   PageNumberingRange^ pageNumberingRange
)

Parameters

pageNumberingRange
The page numbering range to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : RemoveAt Method

index
the index where to remove the page numbering range.
Removes the page numbering range at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
the index where to remove the page numbering range.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of pnrList in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%% $$Properties$$

PageNumberingRangeCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PageNumberingRangeCollection Class

For a list of all members of this type, see PageNumberingRangeCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of page numbering ranges in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the page numbering range at the specified index (zero based index).
Top

See Also

Reference

PageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Count Property

Returns the number of page numbering ranges in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PageNumberingRangeCollection Class : Item Property

index
Gets the page numbering range at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PageNumberingRange
Visual Basic (Usage) Copy Code
Dim instance As PageNumberingRangeCollection
Dim index As Integer
Dim value As PageNumberingRange

value = instance.Item(index)
C#
public PageNumberingRange this[
   int index
]; {get;}
Delphi
public  this: : PageNumberingRange;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PageNumberingRange* get_Item(
   int index
);
C++/CLI
public:
property PageNumberingRange^ default [int] {
   PageNumberingRange^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of pnrList in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageNumberingRangeCollection Class
PageNumberingRangeCollection Members


%%PageItemTitle%%

PDFBaseObject Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFBaseObject Class

Represents the base class for all objects in a PDF file.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseObject
C#
public abstract class PDFBaseObject
Delphi
public class PDFBaseObject abstract;
Managed Extensions for C++
public __gc abstract class PDFBaseObject
C++/CLI
public ref class PDFBaseObject abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFViewerPreferences
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseObject Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBaseObject Class Members
[image]
O2S.Components.PDF4NET Namespace : PDFBaseObject Class

The following tables list the members exposed by PDFBaseObject.

Public Constructors

 | Name | Description
Public Constructor | PDFBaseObject Constructor | Initializes a new PDFBaseObject object.
Top

See Also

Reference

PDFBaseObject Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFBaseObject Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFBaseObject Class : PDFBaseObject Constructor

Initializes a new PDFBaseObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseObject()
C#
public PDFBaseObject()
Delphi
public PDFBaseObject();
Managed Extensions for C++
public: PDFBaseObject();
C++/CLI
public:
PDFBaseObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseObject Class
PDFBaseObject Members


%%PageItemTitle%%

PDFBasicCanvas Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFBasicCanvas Class

Encapsulates a page's drawing surface.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFBasicCanvas
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
C#
public class PDFBasicCanvas : PDFObject
Delphi
public class PDFBasicCanvas = class(PDFObject)
Managed Extensions for C++
public __gc class PDFBasicCanvas : public PDFObject
C++/CLI
public ref class PDFBasicCanvas : public PDFObject

Remarks

This class is mainly used for creating the content of the document. All the drawing functions are exposed by this class. It can not be created directly, it is accessible through the Canvas property of PDFPage object.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFBasicCanvas
O2S.Components.PDF4NET.PDFCanvas

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBasicCanvas Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFBasicCanvas Class

The following tables list the members exposed by PDFBasicCanvas.

Public Methods

 | Name | Description
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawArc2 | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawEllipse2 | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. Supported by Compact .NET Edition.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPie2 | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. Supported by Compact .NET Edition.
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRectangle2 | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. Supported by Compact .NET Edition.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | ResetClipRegion | Resets the current clipping region to whole page.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetClipRegion | Sets a clipping region on page's canvas.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Top

See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFBasicCanvas Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFBasicCanvas Class

For a list of all members of this type, see PDFBasicCanvas members.

Public Methods

 | Name | Description
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawArc2 | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawEllipse2 | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. Supported by Compact .NET Edition.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPie2 | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. Supported by Compact .NET Edition.
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRectangle2 | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. Supported by Compact .NET Edition.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Public Method | ResetClipRegion | Resets the current clipping region to whole page.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetClipRegion | Sets a clipping region on page's canvas.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Top

See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

DrawArc Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawArc Method

Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Overload List

Overload | Description
DrawArc(PDFPen,Single,Single,Single,Single,Single) | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
DrawArc(PDFPen,RectangleF,Single,Single) | Draws an arc representing a portion of an circle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawArc(PDFPen,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawArc Method : DrawArc(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the arc.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawArc( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawArc(pen, top, left, width, startAngle, sweepAngle)
C#
public void DrawArc(
   PDFPen pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawArc(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawArc(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawArc(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawArc(PDFPen,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawArc Method : DrawArc(PDFPen,RectangleF,Single,Single) Method

pen
a PDFPen object used to draw the border of the arc.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawArc( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawArc(pen, rect, startAngle, sweepAngle)
C#
public void DrawArc(
   PDFPen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawArc(
    pen: PDFPen;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawArc(
   PDFPen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawArc(
   PDFPen^ pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawArc2 Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawArc2 Method

Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawArc2(PDFPen,Single,Single,Single,Single,Single) | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
DrawArc2(PDFPen,Single,Single,Single,Single,Single,Single) | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawArc2(PDFPen,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawArc2 Method : DrawArc2(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawArc2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawArc2(pen, left, top, width, startAngle, sweepAngle)
C#
public void DrawArc2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawArc2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawArc2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawArc2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawArc2(PDFPen,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawArc2 Method : DrawArc2(PDFPen,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawArc2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawArc2(pen, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawArc2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawArc2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawArc2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawArc2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawBarcode Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawBarcode Method

Draws the barcode on the canvas.

Overload List

Overload | Description
DrawBarcode(PDFBarcode) | Draws the barcode on the canvas.
DrawBarcode(PDFBarcode,Single,Single) | Draws the barcode on the canvas at the specified position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawBarcode(PDFBarcode) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode) Method

barcode
A PDFBarcode descendant object.
Draws the barcode on the canvas.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBarcode( _
   ByVal barcode As PDFBarcode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode

instance.DrawBarcode(barcode)
C#
public void DrawBarcode(
   PDFBarcode barcode
)
Delphi
public procedure DrawBarcode(
    barcode: PDFBarcode
);
Managed Extensions for C++
public: void DrawBarcode(
   PDFBarcode* barcode
)
C++/CLI
public:
void DrawBarcode(
   PDFBarcode^ barcode
)

Parameters

barcode
A PDFBarcode descendant object.

Remarks

This method draws the given barcode on the canvas. The position of the barcode is given by the barcode's properties PDFBarcode.Left, PDFBarcode.Top, PDFBarcode.Width and PDFBarcode.Height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawBarcode(PDFBarcode,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode,Single,Single) Method

barcode
A PDFBarcode descendant object.
left
The X coordinate of the top left corner of barcode's bounding rectangle.
top
The Y coordinate of the top left corner of barcode's bounding rectangle.
Draws the barcode on the canvas at the specified position.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBarcode( _
   ByVal barcode As PDFBarcode, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode
Dim left As Single
Dim top As Single

instance.DrawBarcode(barcode, left, top)
C#
public void DrawBarcode(
   PDFBarcode barcode,
   float left,
   float top
)
Delphi
public procedure DrawBarcode(
    barcode: PDFBarcode;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: void DrawBarcode(
   PDFBarcode* barcode,
   float left,
   float top
)
C++/CLI
public:
void DrawBarcode(
   PDFBarcode^ barcode,
   float left,
   float top
)

Parameters

barcode
A PDFBarcode descendant object.
left
The X coordinate of the top left corner of barcode's bounding rectangle.
top
The Y coordinate of the top left corner of barcode's bounding rectangle.

Remarks

This method draws the given barcode on the canvas. The barcode's properties PDFBarcode.Left, PDFBarcode.Top, PDFBarcode.Width and PDFBarcode.Height are ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawBezier Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawBezier Method

Draws a Bezier spline specified by four pairs of coordinates.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawBezier(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single) | Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
DrawBezier(PDFPen,PointF,PointF,PointF,PointF) | Draws a Bezier spline specified by four PointF structures.
DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) | Draws a Bezier spline specified by four PDFPoint objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawBezier(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the Bezier spline.
x1
the x coordinate of the first control point.
y1
the y coordinate of the first control point.
x2
the x coordinate of the second control point.
y2
the y coordinate of the second control point.
x3
the x coordinate of the third control point.
y3
the y coordinate of the third control point.
x4
the x coordinate of the fourth control point.
y4
the y coordinate of the fourth control point.
Draws a Bezier spline specified by four pairs of coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal x3 As Single, _
   ByVal y3 As Single, _
   ByVal x4 As Single, _
   ByVal y4 As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Single
Dim y1 As Single
Dim x2 As Single
Dim y2 As Single
Dim x3 As Single
Dim y3 As Single
Dim x4 As Single
Dim y4 As Single

instance.DrawBezier(pen, x1, y1, x2, y2, x3, y3, x4, y4)
C#
public void DrawBezier(
   PDFPen pen,
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
)
Delphi
public procedure DrawBezier(
    pen: PDFPen;
    x1: Single;
    y1: Single;
    x2: Single;
    y2: Single;
    x3: Single;
    y3: Single;
    x4: Single;
    y4: Single
);
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
x1
the x coordinate of the first control point.
y1
the y coordinate of the first control point.
x2
the x coordinate of the second control point.
y2
the y coordinate of the second control point.
x3
the x coordinate of the third control point.
y3
the y coordinate of the third control point.
x4
the x coordinate of the fourth control point.
y4
the y coordinate of the fourth control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Draws a Bezier spline specified by four PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF, _
   ByVal pt3 As PointF, _
   ByVal pt4 As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF
Dim pt3 As PointF
Dim pt4 As PointF

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
C#
public void DrawBezier(
   PDFPen pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
Delphi
public procedure DrawBezier(
    pen: PDFPen;
    pt1: PointF;
    pt2: PointF;
    pt3: PointF;
    pt4: PointF
);
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Draws a Bezier spline specified by four PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint, _
   ByVal pt3 As PDFPoint, _
   ByVal pt4 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint
Dim pt3 As PDFPoint
Dim pt4 As PDFPoint

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
C#
public void DrawBezier(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2,
   PDFPoint pt3,
   PDFPoint pt4
)
Delphi
public procedure DrawBezier(
    pen: PDFPen;
    pt1: PDFPoint;
    pt2: PDFPoint;
    pt3: PDFPoint;
    pt4: PDFPoint
);
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2,
   PDFPoint* pt3,
   PDFPoint* pt4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2,
   PDFPoint^ pt3,
   PDFPoint^ pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawChord Method

Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.

Overload List

Overload | Description
DrawChord(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.
DrawChord(PDFPen,Single,Single,Single,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.
DrawChord(PDFPen,RectangleF,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.
DrawChord(PDFBrush,Single,Single,Single,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.
DrawChord(PDFBrush,RectangleF,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.
DrawChord(PDFPen,PDFBrush,RectangleF,Single,Single) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawChord(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(pen, brush, left, top, width, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord(PDFPen,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(pen, left, top, width, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord(PDFPen,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,RectangleF,Single,Single) Method

pen
a PDFPen object used to draw the border of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(pen, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    pen: PDFPen;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord(PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the chord.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(brush, left, top, width, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord(PDFBrush,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,RectangleF,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(brush, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawChord(PDFPen,PDFBrush,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,RectangleF,Single,Single) Method

pen
a PDFPen object used to draw the border of the chord.
brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawChord(pen, brush, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawChord(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawEllipse Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Overload | Description
DrawEllipse(PDFPen,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.
DrawEllipse(PDFBrush,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.
DrawEllipse(PDFPen,PDFBrush,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawEllipse(PDFPen,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse(pen, top, left, width, height)
C#
public void DrawEllipse(
   PDFPen pen,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawEllipse(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse(PDFPen,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,RectangleF) Method

pen
a PDFPen object used to draw the border of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawEllipse(pen, rect)
C#
public void DrawEllipse(
   PDFPen pen,
   RectangleF rect
)
Delphi
public procedure DrawEllipse(
    pen: PDFPen;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse(PDFBrush,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse(brush, top, left, width, height)
C#
public void DrawEllipse(
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawEllipse(
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse(
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse(PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,RectangleF) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(brush, rect)
C#
public void DrawEllipse(
   PDFBrush brush,
   RectangleF rect
)
Delphi
public procedure DrawEllipse(
    brush: PDFBrush;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse(PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse(pen, brush, top, left, width, height)
C#
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawEllipse(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse(PDFPen,PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,RectangleF) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(pen, brush, rect)
C#
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
Delphi
public procedure DrawEllipse(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse2 Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawEllipse2 Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawEllipse2(PDFPen,PDFBrush,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. Supported by Compact .NET Edition.
DrawEllipse2(PDFPen,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse2(PDFBrush,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawEllipse2(PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse2 Method : DrawEllipse2(PDFPen,PDFBrush,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse2( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse2(pen, brush, left, top, width, height)
C#
public void DrawEllipse2(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawEllipse2(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse2(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse2(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse2(PDFPen,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse2 Method : DrawEllipse2(PDFPen,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse2(pen, left, top, width, height)
C#
public void DrawEllipse2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawEllipse2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawEllipse2(PDFBrush,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawEllipse2 Method : DrawEllipse2(PDFBrush,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse2( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawEllipse2(brush, left, top, width, height)
C#
public void DrawEllipse2(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawEllipse2(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawEllipse2(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawEllipse2(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawFormXObject Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawFormXObject Method

Draws a form XObject specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawFormXObject(PDFFormXObject,Single,Single,Single,Single) | Draws a form XObject specified by a pair of coordinates, a width and a height.
DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,ContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.
DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single,ContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawFormXObject(PDFFormXObject,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Single,Single,Single,Single) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawFormXObject(formXObject, left, top, width, height)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawFormXObject(
    formXObject: PDFFormXObject;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   float left,
   float top,
   float width,
   float height
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn graphic block are set by the corresponding parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawFormXObject(formXObject, left, top, width, height, orientation)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawFormXObject(
    formXObject: PDFFormXObject;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,ContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,ContentMirroring) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal contentMirroring As ContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim contentMirroring As ContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, contentMirroring)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   float left,
   float top,
   float width,
   float height,
   ContentMirroring contentMirroring
)
Delphi
public procedure DrawFormXObject(
    formXObject: PDFFormXObject;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    contentMirroring: ContentMirroring
);
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   float left,
   float top,
   float width,
   float height,
   ContentMirroring contentMirroring
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   float left,
   float top,
   float width,
   float height,
   ContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The content is mirrored according to contentMirroring parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single,ContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Single,Single,Single,Single,Single,ContentMirroring) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal contentMirroring As ContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim contentMirroring As ContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, orientation, contentMirroring)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   ContentMirroring contentMirroring
)
Delphi
public procedure DrawFormXObject(
    formXObject: PDFFormXObject;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    contentMirroring: ContentMirroring
);
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   ContentMirroring contentMirroring
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   ContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter. The content is mirrored according to contentMirroring parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLText Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawHTMLText Method

Draws a line of text specified by a string and a pair of coordinates.

Overload List

Overload | Description
DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign,Hashtable) | Draws a line of text specified by a string and a pair of coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single

instance.DrawHTMLText(text, font, pen, brush, x, y)
C#
public void DrawHTMLText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y
)
Delphi
public procedure DrawHTMLText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single
);
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.

Remarks

The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation)
C#
public void DrawHTMLText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation
)
Delphi
public procedure DrawHTMLText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single
Dim align As TextAlign

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation, align)
C#
public void DrawHTMLText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
Delphi
public procedure DrawHTMLText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single;
    align: TextAlign
);
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign,Hashtable) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign,Hashtable) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
fontsCollection
a Hashtable object storing the external fonts used by the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign, _
   ByVal fontsCollection As Hashtable _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single
Dim align As TextAlign
Dim fontsCollection As Hashtable

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation, align, fontsCollection)
C#
public void DrawHTMLText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation,
   TextAlign align,
   Hashtable fontsCollection
)
Delphi
public procedure DrawHTMLText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single;
    align: TextAlign;
    fontsCollection: Hashtable
);
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation,
   TextAlign align,
   Hashtable* fontsCollection
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation,
   TextAlign align,
   Hashtable^ fontsCollection
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
fontsCollection
a Hashtable object storing the external fonts used by the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLTextBox Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawHTMLTextBox Method

Draws a text specified by a string, a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32,Hashtable) | Draws a text specified by a string, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawHTMLTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions
)
Delphi
public procedure DrawHTMLTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions
);
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
Delphi
public procedure DrawHTMLTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions;
    startDisplayFrom: Integer
);
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32,Hashtable) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32,Hashtable) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
fontsCollection
a collection of external fonts used by the HTML formatted text.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer, _
   ByVal fontsCollection As Hashtable _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer
Dim fontsCollection As Hashtable

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions, startDisplayFrom, fontsCollection)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom,
   Hashtable fontsCollection
)
Delphi
public procedure DrawHTMLTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions;
    startDisplayFrom: Integer;
    fontsCollection: Hashtable
);
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom,
   Hashtable* fontsCollection
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom,
   Hashtable^ fontsCollection
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
fontsCollection
a collection of external fonts used by the HTML formatted text.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawImage Method

Draws an image specified by a file name, a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio) | Draws an image specified by a file name, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
DrawImage(String,Single,Single,Single,Single) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Single,Single,Single,Single,Single) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single,Single) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single,Single) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) | Draws an image specified by an Image object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Single,Single,Single,Single) | Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.
DrawImage(Byte[],Int32,Int32,Single,Single,Single,Single,Single,KeepAspectRatio) | Draws an image specified by a byte array, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim value As Single

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio)
C#
public float DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
Delphi
public function DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio
): Single;
Managed Extensions for C++
public: float DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
C++/CLI
public:
float DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Based on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawImage(fileName, left, top, width, height)
C#
public void DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single,Single) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawImage(fileName, left, top, width, height, orientation)
C#
public void DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim value As Single

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, imageQuality)
C#
public float DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
Delphi
public function DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64
): Single;
Managed Extensions for C++
public: float DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
C++/CLI
public:
float DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim value As Single

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame)
C#
public float DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
Delphi
public function DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer
): Single;
Managed Extensions for C++
public: float DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
C++/CLI
public:
float DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer, _
   ByVal compression As ImageCompression _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim compression As ImageCompression
Dim value As Single

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame, compression)
C#
public float DrawImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
Delphi
public function DrawImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer;
    compression: ImageCompression
): Single;
Managed Extensions for C++
public: float DrawImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
C++/CLI
public:
float DrawImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawImage(imageStream, left, top, width, height)
C#
public void DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single,Single) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawImage(imageStream, left, top, width, height, orientation)
C#
public void DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim value As Single

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio)
C#
public float DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
Delphi
public function DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio
): Single;
Managed Extensions for C++
public: float DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
C++/CLI
public:
float DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Based on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim value As Single

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, imageQuality)
C#
public float DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
Delphi
public function DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64
): Single;
Managed Extensions for C++
public: float DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
C++/CLI
public:
float DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim value As Single

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame)
C#
public float DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
Delphi
public function DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer
): Single;
Managed Extensions for C++
public: float DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
C++/CLI
public:
float DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer, _
   ByVal compression As ImageCompression _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim compression As ImageCompression
Dim value As Single

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame, compression)
C#
public float DrawImage(
   Stream imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
Delphi
public function DrawImage(
    imageStream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer;
    compression: ImageCompression
): Single;
Managed Extensions for C++
public: float DrawImage(
   Stream* imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
C++/CLI
public:
float DrawImage(
   Stream^ imageStream,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawImage(image, left, top, width, height)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,Single) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawImage(image, left, top, width, height, orientation)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim value As Single

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio)
C#
public float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
Delphi
public function DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio
): Single;
Managed Extensions for C++
public: float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
C++/CLI
public:
float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Based on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim value As Single

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, imageQuality)
C#
public float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
Delphi
public function DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64
): Single;
Managed Extensions for C++
public: float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)
C++/CLI
public:
float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim value As Single

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame)
C#
public float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
Delphi
public function DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer
): Single;
Managed Extensions for C++
public: float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)
C++/CLI
public:
float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,Single,KeepAspectRatio,Int64,Int32,ImageCompression) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by an Image object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio, _
   ByVal imageQuality As Long, _
   ByVal activeFrame As Integer, _
   ByVal compression As ImageCompression _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim imageQuality As Long
Dim activeFrame As Integer
Dim compression As ImageCompression
Dim value As Single

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, imageQuality, activeFrame, compression)
C#
public float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
Delphi
public function DrawImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio;
    imageQuality: Int64;
    activeFrame: Integer;
    compression: ImageCompression
): Single;
Managed Extensions for C++
public: float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)
C++/CLI
public:
float DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio,
   long imageQuality,
   int activeFrame,
   ImageCompression compression
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
imageQuality
the quality of the compressed image.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The ImageQuality parameter specifies the level of jpeg compression to be applied on the image saved to pdf file. A higher value means high quality but low compression, a lower value means low quality but high compression. The values accepted by this parameter vary from 1 to 100. The value of this parameter is ignored when a jpeg image is used.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(PDFImage,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Single,Single,Single,Single) Method

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim value As Single

value = instance.DrawImage(image, left, top, width, height)
C#
public float DrawImage(
   PDFImage image,
   float left,
   float top,
   float width,
   float height
)
Delphi
public function DrawImage(
    image: PDFImage;
    left: Single;
    top: Single;
    width: Single;
    height: Single
): Single;
Managed Extensions for C++
public: float DrawImage(
   PDFImage* image,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
float DrawImage(
   PDFImage^ image,
   float left,
   float top,
   float width,
   float height
)

Parameters

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio, or -1 if KeepNone or KeepBoth aspect ratio modes have been specified on the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Based on the KeepAspectRatio parameter or the PDFImage object, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawImage(Byte[],Int32,Int32,Single,Single,Single,Single,Single,KeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Byte[],Int32,Int32,Single,Single,Single,Single,Single,KeepAspectRatio) Method

ccittImage
a byte array storing the CCITT G4 encoded image data.
pixelWidth
the width of the source image in pixels.
pixelHeight
the height of the source image in pixels.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a byte array, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal ccittImage() As Byte, _
   ByVal pixelWidth As Integer, _
   ByVal pixelHeight As Integer, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim ccittImage() As Byte
Dim pixelWidth As Integer
Dim pixelHeight As Integer
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio
Dim value As Single

value = instance.DrawImage(ccittImage, pixelWidth, pixelHeight, left, top, width, height, orientation, keepAspectRatio)
C#
public float DrawImage(
   byte[] ccittImage,
   int pixelWidth,
   int pixelHeight,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
Delphi
public function DrawImage(
    ccittImage: Bytearray of;
    pixelWidth: Integer;
    pixelHeight: Integer;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio
): Single;
Managed Extensions for C++
public: float DrawImage(
   byte[]* ccittImage,
   int pixelWidth,
   int pixelHeight,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
C++/CLI
public:
float DrawImage(
   array<byte>^ ccittImage,
   int pixelWidth,
   int pixelHeight,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)

Parameters

ccittImage
a byte array storing the CCITT G4 encoded image data.
pixelWidth
the width of the source image in pixels.
pixelHeight
the height of the source image in pixels.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an CCITT G4 encoded image on the canvas. It allows to provide directly the CCITT G4 encoded data, so no further encoding is performed by the library.
The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawLine Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawLine Method

Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawLine(PDFPen,Single,Single,Single,Single) | Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
DrawLine(PDFPen,PointF,PointF) | Draws a line connecting two points specified by PointF structures using the specified pen.
DrawLine(PDFPen,PDFPoint,PDFPoint) | Draws a line connecting two points specified by Point structures using the specified pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawLine(PDFPen,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the line.
x1
x coordinate of the beginning of the line.
y1
y coordinate of the beginning of the line.
x2
x coordinate of the end of the line.
y2
y coordinate of the end of the line.
Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Single
Dim y1 As Single
Dim x2 As Single
Dim y2 As Single

instance.DrawLine(pen, x1, y1, x2, y2)
C#
public void DrawLine(
   PDFPen pen,
   float x1,
   float y1,
   float x2,
   float y2
)
Delphi
public procedure DrawLine(
    pen: PDFPen;
    x1: Single;
    y1: Single;
    x2: Single;
    y2: Single
);
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   float x1,
   float y1,
   float x2,
   float y2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

pen
a PDFPen object used to draw the line.
x1
x coordinate of the beginning of the line.
y1
y coordinate of the beginning of the line.
x2
x coordinate of the end of the line.
y2
y coordinate of the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawLine(PDFPen,PointF,PointF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PointF,PointF) Method

pen
a PDFPen object used to draw the line.
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.
Draws a line connecting two points specified by PointF structures using the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF

instance.DrawLine(pen, pt1, pt2)
C#
public void DrawLine(
   PDFPen pen,
   PointF pt1,
   PointF pt2
)
Delphi
public procedure DrawLine(
    pen: PDFPen;
    pt1: PointF;
    pt2: PointF
);
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   PointF pt1,
   PointF pt2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawLine(PDFPen,PDFPoint,PDFPoint) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PDFPoint,PDFPoint) Method

pen
a PDFPen object used to draw the line.
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.
Draws a line connecting two points specified by Point structures using the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint

instance.DrawLine(pen, pt1, pt2)
C#
public void DrawLine(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2
)
Delphi
public procedure DrawLine(
    pen: PDFPen;
    pt1: PDFPoint;
    pt2: PDFPoint
);
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawLines Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawLines Method

Draws a series of line segments that connect an array of PointF structures.

Overload List

Overload | Description
DrawLines(PDFPen,PointF[]) | Draws a series of line segments that connect an array of PointF structures.
DrawLines(PDFPen,PDFPoint[]) | Draws a series of line segments that connect an array of PDFPoint objects. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawLines(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PointF[]) Method

pen
a PDFPen object used to draw the lines.
points
an array of PointF structures specifying the coordinates of the lines.
Draws a series of line segments that connect an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawLines(pen, points)
C#
public void DrawLines(
   PDFPen pen,
   PointF[] points
)
Delphi
public procedure DrawLines(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawLines(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawLines(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of PointF structures specifying the coordinates of the lines.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawLines(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PDFPoint[]) Method

pen
a PDFPen object used to draw the lines.
points
an array of PDFPoint objects specifying the coordinates of the lines.
Draws a series of line segments that connect an array of PDFPoint objects.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawLines(pen, points)
C#
public void DrawLines(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public procedure DrawLines(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawLines(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawLines(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of PDFPoint objects specifying the coordinates of the lines.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPath Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPath Method

Draws a PDFPath object with the specified pen.

Overload List

Overload | Description
DrawPath(PDFPen,PDFPath) | Draws a PDFPath object with the specified pen.
DrawPath(PDFBrush,PDFPath) | Draws a PDFPath object with the specified brush.
DrawPath(PDFPen,PDFBrush,PDFPath) | Draws a PDFPath object with the specified pen and brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPath(PDFPen,PDFPath) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFPath) Method

pen
A PDFPen object used to stroke the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim path As PDFPath

instance.DrawPath(pen, path)
C#
public void DrawPath(
   PDFPen pen,
   PDFPath path
)
Delphi
public procedure DrawPath(
    pen: PDFPen;
    path: PDFPath
);
Managed Extensions for C++
public: void DrawPath(
   PDFPen* pen,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFPen^ pen,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPath(PDFBrush,PDFPath) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFBrush,PDFPath) Method

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(brush, path)
C#
public void DrawPath(
   PDFBrush brush,
   PDFPath path
)
Delphi
public procedure DrawPath(
    brush: PDFBrush;
    path: PDFPath
);
Managed Extensions for C++
public: void DrawPath(
   PDFBrush* brush,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPath(PDFPen,PDFBrush,PDFPath) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFBrush,PDFPath) Method

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified pen and brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(pen, brush, path)
C#
public void DrawPath(
   PDFPen pen,
   PDFBrush brush,
   PDFPath path
)
Delphi
public procedure DrawPath(
    pen: PDFPen;
    brush: PDFBrush;
    path: PDFPath
);
Managed Extensions for C++
public: void DrawPath(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFPen^ pen,
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPie Method

Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Overload List

Overload | Description
DrawPie(PDFPen,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,RectangleF,Single,Single) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.
DrawPie(PDFBrush,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFBrush,RectangleF,Single,Single) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.
DrawPie(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,PDFBrush,RectangleF,Single,Single) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPie(PDFPen,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(pen, top, left, width, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie(PDFPen,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,RectangleF,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(pen, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    pen: PDFPen;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie(PDFBrush,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(brush, top, left, width, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFBrush brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie(PDFBrush,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,RectangleF,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(brush, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(pen, brush, top, left, width, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
top
the y coordinate of the top left corner of the bounding rectangle.
left
the x coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie(PDFPen,PDFBrush,RectangleF,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,RectangleF,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie(pen, brush, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie2 Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPie2 Method

Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition.
DrawPie2(PDFPen,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie2(PDFBrush,Single,Single,Single,Single,Single) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie2 Method : DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie2( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie2(pen, brush, left, top, width, startAngle, sweepAngle)
C#
public void DrawPie2(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie2(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie2(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie2(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie2 Method : DrawPie2(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie2( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie2(pen, brush, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawPie2(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie2(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie2(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie2(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie2(PDFPen,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie2 Method : DrawPie2(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie2(pen, left, top, width, startAngle, sweepAngle)
C#
public void DrawPie2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPie2(PDFBrush,Single,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPie2 Method : DrawPie2(PDFBrush,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie2( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim startAngle As Single
Dim sweepAngle As Single

instance.DrawPie2(brush, left, top, width, startAngle, sweepAngle)
C#
public void DrawPie2(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
Delphi
public procedure DrawPie2(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: void DrawPie2(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
void DrawPie2(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float startAngle,
   float sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyBezier Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPolyBezier Method

Draws a series of connected curves defined by an array of PointF structures.

Overload List

Overload | Description
DrawPolyBezier(PDFPen,PointF[]) | Draws a series of connected curves defined by an array of PointF structures.
DrawPolyBezier(PDFPen,PDFPoint[]) | Draws a series of connected curves defined by an array of PDFPoint objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPolyBezier(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PointF[]) Method

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyBezier(pen, points)
C#
public void DrawPolyBezier(
   PDFPen pen,
   PointF[] points
)
Delphi
public procedure DrawPolyBezier(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolyBezier(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyBezier(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PDFPoint[]) Method

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyBezier(pen, points)
C#
public void DrawPolyBezier(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public procedure DrawPolyBezier(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolyBezier(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPolygon Method

Draws a polygon defined by an array of PDFPoint objects.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects. Supported by Compact .NET Edition.
DrawPolygon(PDFPen,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(pen, brush, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public procedure DrawPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Remarks

This function draws a polygon defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PointF[]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolygon(pen, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PointF[] points
)
Delphi
public procedure DrawPolygon(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon(PDFBrush,PointF[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PointF[]) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(brush, points)
C#
public void DrawPolygon(
   PDFBrush brush,
   PointF[] points
)
Delphi
public procedure DrawPolygon(
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon(PDFPen,PDFBrush,PointF[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PointF[]) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(pen, brush, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Delphi
public procedure DrawPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Remarks

This function draws a polygon defined by an array of PointF structures. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFPoint[]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolygon(pen, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public procedure DrawPolygon(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolygon(PDFBrush,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PDFPoint[]) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(brush, points)
C#
public void DrawPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public procedure DrawPolygon(
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawPolyPolygon Method

Draws a series of closed polygons, each one defined by an array of PDFPoint objects.

Overload List

Overload | Description
DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
DrawPolyPolygon(PDFPen,PointF[][]) | Draws a series of closed polygons, each one defined by an array of PointF objects.
DrawPolyPolygon(PDFBrush,PointF[][]) | Draws a series of closed polygons, each one defined by an array of PointF structures.
DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) | Draws a series of closed polygons defined by an array of PointF structures.
DrawPolyPolygon(PDFPen,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.
DrawPolyPolygon(PDFBrush,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, brush, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public procedure DrawPolyPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon(PDFPen,PointF[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PointF[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
points
an array of PointF array specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PointF objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyPolygon(pen, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PointF[] points
)
Delphi
public procedure DrawPolyPolygon(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
points
an array of PointF array specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon(PDFBrush,PointF[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PointF[][]) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(brush, points)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PointF[] points
)
Delphi
public procedure DrawPolyPolygon(
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The interior of the polygons is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
Draws a series of closed polygons defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(pen, brush, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Delphi
public procedure DrawPolyPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon(PDFPen,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFPoint[][]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public procedure DrawPolyPolygon(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawPolyPolygon(PDFBrush,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PDFPoint[][]) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(brush, points)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public procedure DrawPolyPolygon(
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The polygons' interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawRectangle Method

Draws a rectangle specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawRectangle(PDFPen,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,RectangleF,Single) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFBrush,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFBrush,RectangleF,Single) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,PDFBrush,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,RectangleF,Single) | Draws a rectangle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawRectangle(PDFPen,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle(pen, top, left, width, height)
C#
public void DrawRectangle(
   PDFPen pen,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle(pen, top, left, width, height, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float height,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF) Method

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawRectangle(pen, rect)
C#
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,RectangleF,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim orientation As Single

instance.DrawRectangle(pen, rect, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect,
   float orientation
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a rectangle specified by a RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFBrush,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle(brush, top, left, width, height)
C#
public void DrawRectangle(
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawRectangle(
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle(brush, top, left, width, height, orientation)
C#
public void DrawRectangle(
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle(
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(brush, rect)
C#
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect
)
Delphi
public procedure DrawRectangle(
    brush: PDFBrush;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFBrush,RectangleF,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Single

instance.DrawRectangle(brush, rect, orientation)
C#
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect,
   float orientation
)
Delphi
public procedure DrawRectangle(
    brush: PDFBrush;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect,
   float orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle(pen, brush, top, left, width, height)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle(pen, brush, top, left, width, height, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(pen, brush, rect)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle(PDFPen,PDFBrush,RectangleF,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Single

instance.DrawRectangle(pen, brush, rect, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float orientation
)
Delphi
public procedure DrawRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2 Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawRectangle2 Method

Draws a rectangle specified by a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
DrawRectangle2(PDFPen,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle2(PDFPen,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle2(PDFBrush,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle2(PDFBrush,Single,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single) | Draws a rectangle specified by a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle2(pen, brush, left, top, width, height, orientation)
C#
public void DrawRectangle2(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle2(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle2(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2(PDFPen,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFPen,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle2(pen, left, top, width, height)
C#
public void DrawRectangle2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawRectangle2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2(PDFPen,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFPen,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle2(pen, left, top, width, height, orientation)
C#
public void DrawRectangle2(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle2(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle2(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2(PDFBrush,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFBrush,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle2(brush, left, top, width, height)
C#
public void DrawRectangle2(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawRectangle2(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle2(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2(PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFBrush,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawRectangle2(brush, left, top, width, height, orientation)
C#
public void DrawRectangle2(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawRectangle2(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawRectangle2(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRectangle2 Method : DrawRectangle2(PDFPen,PDFBrush,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle2( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawRectangle2(pen, brush, left, top, width, height)
C#
public void DrawRectangle2(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawRectangle2(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawRectangle2(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawRectangle2(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

This method has been introduced to provide consistency with the whole library, regarding the order of parameters for rectangular objects: left, top, width, height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawRoundRectangle Method

Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single,Single) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
Delphi
public procedure DrawRoundRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single
Dim orientation As Single

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
Delphi
public procedure DrawRoundRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
Delphi
public procedure DrawRoundRectangle(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function strokes the rectangle with the given PDFPen object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Single,Single,Single,Single,Single,Single,Single) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single
Dim orientation As Single

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
Delphi
public procedure DrawRoundRectangle(
    pen: PDFPen;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function strokes the rectangle with the given PDFPen object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
Delphi
public procedure DrawRoundRectangle(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function fill the interior of the rectangle with the given PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Single,Single,Single,Single,Single,Single,Single) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single
Dim orientation As Single

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
Delphi
public procedure DrawRoundRectangle(
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function fill the interior of the rectangle with the given PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawText Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawText Method

Draws a line of text specified by a string and a pair of coordinates.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) | Draws a line of text specified by a string and a pair of coordinates. Supported by Compact .NET Edition.
DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) | Draws a line of text specified by a string and a pair of coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single
Dim align As TextAlign

instance.DrawText(text, font, pen, brush, x, y, orientation, align)
C#
public void DrawText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
Delphi
public procedure DrawText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single;
    align: TextAlign
);
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single

instance.DrawText(text, font, pen, brush, x, y)
C#
public void DrawText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y
)
Delphi
public procedure DrawText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single
);
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single

instance.DrawText(text, font, pen, brush, x, y, orientation)
C#
public void DrawText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation
)
Delphi
public procedure DrawText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : DrawTextBox Method

Draws a text specified by a string, a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single) | Draws a text specified by a string, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The formatting of the text is controlled by the textFormatOptions parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawTextBox(text, font, pen, brush, left, top, width, height)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim align As TextAlign

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    align: TextAlign
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign, _
   ByVal clipText As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim align As TextAlign
Dim clipText As Boolean

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    align: TextAlign;
    clipText: Boolean
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
lineSpacing
a float value specifying additional space between wrapped lines of text.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign, _
   ByVal clipText As Boolean, _
   ByVal lineSpacing As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim align As TextAlign
Dim clipText As Boolean
Dim lineSpacing As Single

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText, lineSpacing)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText,
   float lineSpacing
)
Delphi
public procedure DrawTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    align: TextAlign;
    clipText: Boolean;
    lineSpacing: Single
);
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText,
   float lineSpacing
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clipText,
   float lineSpacing
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
lineSpacing
a float value specifying additional space between wrapped lines of text.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter. The space between lines of text is increased with the value specified by the lineSpacing parameter. If this value is negative, then the lines pf text are drawn closer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


%%PageItemTitle%%

ResetClipRegion Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : ResetClipRegion Method

Resets the current clipping region to whole page.

Syntax

Visual Basic (Declaration)
Public Sub ResetClipRegion()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas

instance.ResetClipRegion()
C#
public void ResetClipRegion()
Delphi
public procedure ResetClipRegion();
Managed Extensions for C++
public: void ResetClipRegion();
C++/CLI
public:
void ResetClipRegion();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetAxesDirection Method
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetAxesDirection Method

xAxisDirection
A XAxisDirection enumeration member specifying the new direction of the X axis.
yAxisDirection
A YAxisDirection enumeration member specifying the new direction of the Y axis.
Sets the new directions for the axes of the coordinate system.

Syntax

Visual Basic (Declaration)
Public Sub SetAxesDirection( _
   ByVal xAxisDirection As XAxisDirection, _
   ByVal yAxisDirection As YAxisDirection _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim xAxisDirection As XAxisDirection
Dim yAxisDirection As YAxisDirection

instance.SetAxesDirection(xAxisDirection, yAxisDirection)
C#
public void SetAxesDirection(
   XAxisDirection xAxisDirection,
   YAxisDirection yAxisDirection
)
Delphi
public procedure SetAxesDirection(
    xAxisDirection: XAxisDirection;
    yAxisDirection: YAxisDirection
);
Managed Extensions for C++
public: void SetAxesDirection(
   XAxisDirection xAxisDirection,
   YAxisDirection yAxisDirection
)
C++/CLI
public:
void SetAxesDirection(
   XAxisDirection xAxisDirection,
   YAxisDirection yAxisDirection
)

Parameters

xAxisDirection
A XAxisDirection enumeration member specifying the new direction of the X axis.
yAxisDirection
A YAxisDirection enumeration member specifying the new direction of the Y axis.

Example

The following example sets the direction of the Y axis to be from bottom to top. It also sets the origin of the coordinate system to bottom left corner of the page (this is the default coordinate system used by pdf files). The sample assumes the current origin of the coordinate system is at top left corner of the page.
C# Copy Code
...
page.Canvas.SetOrigin( 0, page.Height );
page.Canvas.SetAxesDirection( XAxisDirection.LeftToRight, YAxisDirection.BottomToTop );
// the default pdf coordinate system is now in place
...

Remarks

This method changes the direction of the axes of the coordinate system. The default directions are: top to bottom for the Y axis and left to right for the X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetBlendMode Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetBlendMode Method

blendMode
A BlendMode enumeration member specifying how colors are combined.
Sets the blending mode for the subsequent drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetBlendMode( _
   ByVal blendMode As BlendMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim blendMode As BlendMode

instance.SetBlendMode(blendMode)
C#
public void SetBlendMode(
   BlendMode blendMode
)
Delphi
public procedure SetBlendMode(
    blendMode: BlendMode
);
Managed Extensions for C++
public: void SetBlendMode(
   BlendMode blendMode
)
C++/CLI
public:
void SetBlendMode(
   BlendMode blendMode
)

Parameters

blendMode
A BlendMode enumeration member specifying how colors are combined.

Remarks

A blend mode specifies how backdrop color combine with source color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetClipRegion Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetClipRegion Method

clipGraphic
the graphic object whose contour will define the clipping region.
Sets a clipping region on page's canvas.

Syntax

Visual Basic (Declaration)
Public Sub SetClipRegion( _
   ByVal clipGraphic As PDFGraphic _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim clipGraphic As PDFGraphic

instance.SetClipRegion(clipGraphic)
C#
public void SetClipRegion(
   PDFGraphic clipGraphic
)
Delphi
public procedure SetClipRegion(
    clipGraphic: PDFGraphic
);
Managed Extensions for C++
public: void SetClipRegion(
   PDFGraphic* clipGraphic
)
C++/CLI
public:
void SetClipRegion(
   PDFGraphic^ clipGraphic
)

Parameters

clipGraphic
the graphic object whose contour will define the clipping region.

Exceptions

Exception | Description
InvalidOperationException | thrown when a clipping region is already active.
ArgumentException | thrown when a not support graphic object us used as parameter.

Remarks

The graphic object that defines the clipping region must be a closed shape. The following shapes are supported for defining a clipping region: PDFRectangle, PDFRoundRectangle, PDFPolygon, PDFPie, PDFEllipse, PDFPath.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetLogicalUnit Method
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetLogicalUnit Method

logicalUnit
a PDFLogicalUnitBase descendant specifying the new logical unit.
Sets the logical unit for the drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetLogicalUnit( _
   ByVal logicalUnit As PDFLogicalUnitBase _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim logicalUnit As PDFLogicalUnitBase

instance.SetLogicalUnit(logicalUnit)
C#
public void SetLogicalUnit(
   PDFLogicalUnitBase logicalUnit
)
Delphi
public procedure SetLogicalUnit(
    logicalUnit: PDFLogicalUnitBase
);
Managed Extensions for C++
public: void SetLogicalUnit(
   PDFLogicalUnitBase* logicalUnit
)
C++/CLI
public:
void SetLogicalUnit(
   PDFLogicalUnitBase^ logicalUnit
)

Parameters

logicalUnit
a PDFLogicalUnitBase descendant specifying the new logical unit.

Example

The following example show how to draw different objects on the page using different logical units to position them.
C# Copy Code
...
PDFPen pen = new PDFPen( new PDFColor( 255, 0, 0 ), 1 );
PDFDocument doc = new PDFDocument( );
PDFPage page = doc.AddPage( );
page.LogicalUnit = new PDFMMLogicalUnit( );
// the following drawing operation uses the millimeter
// as a logical unit to draw the line. The milimeter
// was defined as default logical unit for the page.
page.Canvas.DrawLine( pen, 10, 10, 100, 100 );

page.Canvas.SetLogicalUnit( new PDFPointLogicalUnit( ) );
// the following drawing operation uses the point, as requested above,
// to draw the line.
page.Canvas.DrawLine( pen, 20, 10, 110, 100 );
...

Remarks

The default logical unit used to position graphic objects on the page is given by the LogicalUnit property of the PDFPage object. During the drawing operations, the logical unit can be changed in order to achieve desired functionality. In this way, some objects can be positioned on the page using one logical unit, while other objects can be positioned using another logical unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetOrigin Method
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetOrigin Method

newXAxisOrigin
The X coordinate of the origin.
newYAxisOrigin
The Y coordinate of the origin.
Sets the new point of origin for the coordinate system.

Syntax

Visual Basic (Declaration)
Public Sub SetOrigin( _
   ByVal newXAxisOrigin As Single, _
   ByVal newYAxisOrigin As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim newXAxisOrigin As Single
Dim newYAxisOrigin As Single

instance.SetOrigin(newXAxisOrigin, newYAxisOrigin)
C#
public void SetOrigin(
   float newXAxisOrigin,
   float newYAxisOrigin
)
Delphi
public procedure SetOrigin(
    newXAxisOrigin: Single;
    newYAxisOrigin: Single
);
Managed Extensions for C++
public: void SetOrigin(
   float newXAxisOrigin,
   float newYAxisOrigin
)
C++/CLI
public:
void SetOrigin(
   float newXAxisOrigin,
   float newYAxisOrigin
)

Parameters

newXAxisOrigin
The X coordinate of the origin.
newYAxisOrigin
The Y coordinate of the origin.

Example

The following example sets the origin of the coordinate system at 100mm from the left margin of the page and at 100mm from the top margin of the page. The example assumes the current origin is set at the top left corner of the page. The direction of the axes is left untouched, from top to bottom and from left to right.
C# Copy Code
...
page.Canvas.SetLogicalUnit( new PDFMMLogicalUnit( ) );
page.Canvas.SetOrigin( 100, 100 );
...

Remarks

This method moves the origin of the coordinate system to the new position. The new position is always given relative to the current origin. The values specifying the new origin are given in logical units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetOverprint Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetOverprint Method

overprint
a value indicating whether overprint is enabled or not.
Sets the overprint for the subsequent drawing (stroke and fill) operations.

Syntax

Visual Basic (Declaration)
Public Sub SetOverprint( _
   ByVal overprint As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim overprint As Boolean

instance.SetOverprint(overprint)
C#
public void SetOverprint(
   bool overprint
)
Delphi
public procedure SetOverprint(
    overprint: Boolean
);
Managed Extensions for C++
public: void SetOverprint(
   bool overprint
)
C++/CLI
public:
void SetOverprint(
   bool overprint
)

Parameters

overprint
a value indicating whether overprint is enabled or not.

Remarks

If true, the overprint is enabled for subsequent drawing (stroke and fill) operations.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

SetTransparency Method
[image]
O2S.Components.PDF4NET Namespace > PDFBasicCanvas Class : SetTransparency Method

transparency
a float value specifying the transparency level.
Sets the transparency level for the subsequent drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetTransparency( _
   ByVal transparency As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim transparency As Single

instance.SetTransparency(transparency)
C#
public void SetTransparency(
   float transparency
)
Delphi
public procedure SetTransparency(
    transparency: Single
);
Managed Extensions for C++
public: void SetTransparency(
   float transparency
)
C++/CLI
public:
void SetTransparency(
   float transparency
)

Parameters

transparency
a float value specifying the transparency level.

Remarks

The transparency level can take any value between 0 and 100. 100 means full transparency (100), 0 means opaque transparency).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

PDFCanvas Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFCanvas Class

Encapsulates a page's drawing surface.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFCanvas
   Inherits PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
C#
public sealed class PDFCanvas : PDFBasicCanvas
Delphi
public class PDFCanvas = class(PDFBasicCanvas)sealed;
Managed Extensions for C++
public __gc __sealed class PDFCanvas : public PDFBasicCanvas
C++/CLI
public ref class PDFCanvas sealed : public PDFBasicCanvas

Remarks

This class is mainly used for creating the content of the document. All the drawing functions are exposed by this class. It can not be created directly, it is accessible through the Canvas property of PDFPage object.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFBasicCanvas
O2S.Components.PDF4NET.PDFCanvas

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCanvas Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFCanvas Class

The following tables list the members exposed by PDFCanvas.

Public Properties

 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new PDFGraphic object to be drawn on page's canvas. Supported by Compact .NET Edition.
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawArc2 | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawAreaDocLink | Overloaded. Draws a rectangle as a link to another page within the document. Supported by Compact .NET Edition.
Public Method | DrawAreaFileLink | Overloaded. Draws a rectangle as a link to an external file. Supported by Compact .NET Edition.
Public Method | DrawAreaRemoteDocLink | Overloaded. Draws a rectangle as a link to another pdf document. Supported by Compact .NET Edition.
Public Method | DrawAreaWebLink | Overloaded. Defines a rectangular area on the page as a link to a web location. Supported by Compact .NET Edition.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse2 | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawMetafile | Overloaded. Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen. (Inherited from PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawPie2 | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle2 | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawTextDocLink | Draws a line of text as a link to another page within the document. Supported by Compact .NET Edition.
Public Method | DrawTextFileLink | Draws a line of text as a link to an external file. Supported by Compact .NET Edition.
Public Method | DrawTextRemoteDocLink | Overloaded. Draws a line of text as a link to another pdf document. Supported by Compact .NET Edition.
Public Method | DrawTextWebLink | Draws a line of text as a link to a web location. Supported by Compact .NET Edition.
Public Method | ResetClipRegion | Resets the current clipping region to whole page. (Inherited from PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetClipRegion | Sets a clipping region on page's canvas. (Inherited from PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFCanvas Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new PDFGraphic object to be drawn on page's canvas. Supported by Compact .NET Edition.
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawArc2 | Overloaded. Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawAreaDocLink | Overloaded. Draws a rectangle as a link to another page within the document. Supported by Compact .NET Edition.
Public Method | DrawAreaFileLink | Overloaded. Draws a rectangle as a link to an external file. Supported by Compact .NET Edition.
Public Method | DrawAreaRemoteDocLink | Overloaded. Draws a rectangle as a link to another pdf document. Supported by Compact .NET Edition.
Public Method | DrawAreaWebLink | Overloaded. Defines a rectangular area on the page as a link to a web location. Supported by Compact .NET Edition.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse2 | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawMetafile | Overloaded. Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen. (Inherited from PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawPie2 | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle2 | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawTextDocLink | Draws a line of text as a link to another page within the document. Supported by Compact .NET Edition.
Public Method | DrawTextFileLink | Draws a line of text as a link to an external file. Supported by Compact .NET Edition.
Public Method | DrawTextRemoteDocLink | Overloaded. Draws a line of text as a link to another pdf document. Supported by Compact .NET Edition.
Public Method | DrawTextWebLink | Draws a line of text as a link to a web location. Supported by Compact .NET Edition.
Public Method | ResetClipRegion | Resets the current clipping region to whole page. (Inherited from PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetClipRegion | Sets a clipping region on page's canvas. (Inherited from PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : Add Method

graphic
the graphic object to be added to the canvas.
Adds a new PDFGraphic object to be drawn on page's canvas.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal graphic As PDFGraphic _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim graphic As PDFGraphic

instance.Add(graphic)
C#
public void Add(
   PDFGraphic graphic
)
Delphi
public procedure Add(
    graphic: PDFGraphic
);
Managed Extensions for C++
public: void Add(
   PDFGraphic* graphic
)
C++/CLI
public:
void Add(
   PDFGraphic^ graphic
)

Parameters

graphic
the graphic object to be added to the canvas.

Remarks

The graphic objects are drawn in the order they were previously added to the canvas. This means that the first added object will be drawn at the bottom, and the last object will be drawn on top of all objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawAreaDocLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawAreaDocLink Method

Draws a rectangle as a link to another page within the document.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawAreaDocLink(PDFPage,Single,Single,Single,Single,Single,PDFPen) | Draws a rectangle as a link to another page within the document. Supported by Compact .NET Edition.
DrawAreaDocLink(PDFPage,Single,RectangleF,PDFPen) | Draws a rectangle as a link to another page within the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawAreaDocLink(PDFPage,Single,Single,Single,Single,Single,PDFPen) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaDocLink Method : DrawAreaDocLink(PDFPage,Single,Single,Single,Single,Single,PDFPen) Method

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
left
the x coordinate of the rectangular area.
top
the y coordinate of the rectangular area.
width
the width of the rectangular area.
height
the height of the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to another page within the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaDocLink( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

instance.DrawAreaDocLink(destinationPage, topDestination, left, top, width, height, borderPen)
C#
public void DrawAreaDocLink(
   PDFPage destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaDocLink(
   PDFPage* destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
left
the x coordinate of the rectangular area.
top
the y coordinate of the rectangular area.
width
the width of the rectangular area.
height
the height of the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaDocLink(PDFPage,Single,RectangleF,PDFPen) Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaDocLink Method : DrawAreaDocLink(PDFPage,Single,RectangleF,PDFPen) Method

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
rect
a RectangleF structure specifying the link area.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to another page within the document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaDocLink( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim rect As RectangleF
Dim borderPen As PDFPen

instance.DrawAreaDocLink(destinationPage, topDestination, rect, borderPen)
C#
public void DrawAreaDocLink(
   PDFPage destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaDocLink(
   PDFPage* destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
rect
a RectangleF structure specifying the link area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaFileLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawAreaFileLink Method

Draws a rectangle as a link to an external file.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawAreaFileLink(String,Single,Single,Single,Single,PDFPen) | Draws a rectangle as a link to an external file. Supported by Compact .NET Edition.
DrawAreaFileLink(String,RectangleF,PDFPen) | Draws a rectangle as a link to another pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawAreaFileLink(String,Single,Single,Single,Single,PDFPen) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaFileLink Method : DrawAreaFileLink(String,Single,Single,Single,Single,PDFPen) Method

filePath
a file path to the external file.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to an external file.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaFileLink( _
   ByVal filePath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim filePath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

instance.DrawAreaFileLink(filePath, left, top, width, height, borderPen)
C#
public void DrawAreaFileLink(
   string filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaFileLink(
    filePath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaFileLink(
   string* filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaFileLink(
   String^ filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

filePath
a file path to the external file.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaFileLink(String,RectangleF,PDFPen) Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaFileLink Method : DrawAreaFileLink(String,RectangleF,PDFPen) Method

filePath
a file path to the external file.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaFileLink( _
   ByVal filePath As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim filePath As String
Dim rect As RectangleF
Dim borderPen As PDFPen

instance.DrawAreaFileLink(filePath, rect, borderPen)
C#
public void DrawAreaFileLink(
   string filePath,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaFileLink(
    filePath: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaFileLink(
   string* filePath,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaFileLink(
   String^ filePath,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

filePath
a file path to the external file.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaRemoteDocLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawAreaRemoteDocLink Method

Draws a rectangle as a link to another pdf document.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen) | Draws a rectangle as a link to another pdf document. Supported by Compact .NET Edition.
DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean) | Draws a rectangle as a link to another pdf document.
DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean,Int32) | Draws a rectangle as a link to another pdf document.
DrawAreaRemoteDocLink(String,RectangleF,PDFPen) | Draws a rectangle as a link to another pdf document.
DrawAreaRemoteDocLink(String,RectangleF,PDFPen,Boolean,Int32) | Draws a rectangle as a link to another pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaRemoteDocLink Method : DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen) Method

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to another pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

instance.DrawAreaRemoteDocLink(documentPath, left, top, width, height, borderPen)
C#
public void DrawAreaRemoteDocLink(
   string documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaRemoteDocLink(
    documentPath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaRemoteDocLink(
   string* documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaRemoteDocLink(
   String^ documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaRemoteDocLink Method : DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean) Method

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
Draws a rectangle as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen, _
   ByVal openInNewWindow As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen
Dim openInNewWindow As Boolean

instance.DrawAreaRemoteDocLink(documentPath, left, top, width, height, borderPen, openInNewWindow)
C#
public void DrawAreaRemoteDocLink(
   string documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen,
   bool openInNewWindow
)
Delphi
public procedure DrawAreaRemoteDocLink(
    documentPath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen;
    openInNewWindow: Boolean
);
Managed Extensions for C++
public: void DrawAreaRemoteDocLink(
   string* documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen,
   bool openInNewWindow
)
C++/CLI
public:
void DrawAreaRemoteDocLink(
   String^ documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen,
   bool openInNewWindow
)

Parameters

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaRemoteDocLink Method : DrawAreaRemoteDocLink(String,Single,Single,Single,Single,PDFPen,Boolean,Int32) Method

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.
Draws a rectangle as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen, _
   ByVal openInNewWindow As Boolean, _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen
Dim openInNewWindow As Boolean
Dim pageNumber As Integer

instance.DrawAreaRemoteDocLink(documentPath, left, top, width, height, borderPen, openInNewWindow, pageNumber)
C#
public void DrawAreaRemoteDocLink(
   string documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen,
   bool openInNewWindow,
   int pageNumber
)
Delphi
public procedure DrawAreaRemoteDocLink(
    documentPath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen;
    openInNewWindow: Boolean;
    pageNumber: Integer
);
Managed Extensions for C++
public: void DrawAreaRemoteDocLink(
   string* documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen,
   bool openInNewWindow,
   int pageNumber
)
C++/CLI
public:
void DrawAreaRemoteDocLink(
   String^ documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen,
   bool openInNewWindow,
   int pageNumber
)

Parameters

documentPath
a file path to the destination document.
left
the x coordinate of the rectangle.
top
the y coordinate of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaRemoteDocLink(String,RectangleF,PDFPen) Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaRemoteDocLink Method : DrawAreaRemoteDocLink(String,RectangleF,PDFPen) Method

documentPath
a file path to the destination document.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a rectangle as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim rect As RectangleF
Dim borderPen As PDFPen

instance.DrawAreaRemoteDocLink(documentPath, rect, borderPen)
C#
public void DrawAreaRemoteDocLink(
   string documentPath,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaRemoteDocLink(
    documentPath: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaRemoteDocLink(
   string* documentPath,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaRemoteDocLink(
   String^ documentPath,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

documentPath
a file path to the destination document.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaRemoteDocLink(String,RectangleF,PDFPen,Boolean,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaRemoteDocLink Method : DrawAreaRemoteDocLink(String,RectangleF,PDFPen,Boolean,Int32) Method

documentPath
a file path to the destination document.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.
Draws a rectangle as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen, _
   ByVal openInNewWindow As Boolean, _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim rect As RectangleF
Dim borderPen As PDFPen
Dim openInNewWindow As Boolean
Dim pageNumber As Integer

instance.DrawAreaRemoteDocLink(documentPath, rect, borderPen, openInNewWindow, pageNumber)
C#
public void DrawAreaRemoteDocLink(
   string documentPath,
   RectangleF rect,
   PDFPen borderPen,
   bool openInNewWindow,
   int pageNumber
)
Delphi
public procedure DrawAreaRemoteDocLink(
    documentPath: String;
    rect: RectangleF;
    borderPen: PDFPen;
    openInNewWindow: Boolean;
    pageNumber: Integer
);
Managed Extensions for C++
public: void DrawAreaRemoteDocLink(
   string* documentPath,
   RectangleF rect,
   PDFPen* borderPen,
   bool openInNewWindow,
   int pageNumber
)
C++/CLI
public:
void DrawAreaRemoteDocLink(
   String^ documentPath,
   RectangleF rect,
   PDFPen^ borderPen,
   bool openInNewWindow,
   int pageNumber
)

Parameters

documentPath
a file path to the destination document.
rect
a RectangleF structures defining the link area.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaWebLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawAreaWebLink Method

Defines a rectangular area on the page as a link to a web location.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawAreaWebLink(String,Single,Single,Single,Single,PDFPen) | Defines a rectangular area on the page as a link to a web location. Supported by Compact .NET Edition.
DrawAreaWebLink(String,RectangleF,PDFPen) | Defines a rectangular area on the page as a link to a web location.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawAreaWebLink(String,Single,Single,Single,Single,PDFPen) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaWebLink Method : DrawAreaWebLink(String,Single,Single,Single,Single,PDFPen) Method

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
left
the x coordinate of the rectangular area.
top
the y coordinate of the rectangular area.
width
the width of the rectangular area.
height
the height of the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.
Defines a rectangular area on the page as a link to a web location.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaWebLink( _
   ByVal url As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim url As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

instance.DrawAreaWebLink(url, left, top, width, height, borderPen)
C#
public void DrawAreaWebLink(
   string url,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaWebLink(
    url: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaWebLink(
   string* url,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaWebLink(
   String^ url,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
left
the x coordinate of the rectangular area.
top
the y coordinate of the rectangular area.
width
the width of the rectangular area.
height
the height of the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawAreaWebLink(String,RectangleF,PDFPen) Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawAreaWebLink Method : DrawAreaWebLink(String,RectangleF,PDFPen) Method

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
rect
a RectangleF structure defining the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.
Defines a rectangular area on the page as a link to a web location.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawAreaWebLink( _
   ByVal url As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim url As String
Dim rect As RectangleF
Dim borderPen As PDFPen

instance.DrawAreaWebLink(url, rect, borderPen)
C#
public void DrawAreaWebLink(
   string url,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public procedure DrawAreaWebLink(
    url: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawAreaWebLink(
   string* url,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawAreaWebLink(
   String^ url,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
rect
a RectangleF structure defining the rectangular area.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawImportedContent Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawImportedContent Method

Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Single,Single,Single,Single,Single) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height and an orietation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim importedContent As PDFImportedContent
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawImportedContent(importedContent, left, top, width, height)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawImportedContent(
    importedContent: PDFImportedContent;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   float left,
   float top,
   float width,
   float height
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.

Remarks

This function is used to draw the content of an imported page on current page canvas. The content is scaled to fit the given width and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawImportedContent(PDFImportedContent,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Single,Single,Single,Single,Single) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height and an orietation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim importedContent As PDFImportedContent
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawImportedContent(importedContent, left, top, width, height, orientation)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawImportedContent(
    importedContent: PDFImportedContent;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.

Remarks

This function is used to draw the content of an imported page on current page canvas. The content is scaled to fit the given width and height. The imported content is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawMetafile Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawMetafile Method

Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawMetafile(PDFMetafile,Single,Single,Single,Single) | Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.
DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single) | Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.
DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single,KeepAspectRatio) | Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawMetafile(PDFMetafile,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawMetafile Method : DrawMetafile(PDFMetafile,Single,Single,Single,Single) Method

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.
Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawMetafile( _
   ByVal metafile As PDFMetafile, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim metafile As PDFMetafile
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.DrawMetafile(metafile, left, top, width, height)
C#
public void DrawMetafile(
   PDFMetafile metafile,
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure DrawMetafile(
    metafile: PDFMetafile;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void DrawMetafile(
   PDFMetafile* metafile,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void DrawMetafile(
   PDFMetafile^ metafile,
   float left,
   float top,
   float width,
   float height
)

Parameters

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.

Remarks

This function is used to draw a metafile on the canvas. The metafile content is scaled to the rectangle specified by (left, top, width, height) parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawMetafile Method : DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single) Method

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.
orientation
The orientation, in degrees, of the metafile when it is placed on the page.
Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawMetafile( _
   ByVal metafile As PDFMetafile, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim metafile As PDFMetafile
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

instance.DrawMetafile(metafile, left, top, width, height, orientation)
C#
public void DrawMetafile(
   PDFMetafile metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public procedure DrawMetafile(
    metafile: PDFMetafile;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: void DrawMetafile(
   PDFMetafile* metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
void DrawMetafile(
   PDFMetafile^ metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.
orientation
The orientation, in degrees, of the metafile when it is placed on the page.

Remarks

This function is used to draw a metafile on the canvas. The metafile content is scaled to the rectangle specified by (left, top, width, height) parameters. The metafile is rotated around (left, top) corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single,KeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawMetafile Method : DrawMetafile(PDFMetafile,Single,Single,Single,Single,Single,KeepAspectRatio) Method

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.
orientation
The orientation, in degrees, of the metafile when it is placed on the page.
keepAspectRatio
A KeepAspectRatio enumeration member specifying how the original aspect ratio of the metafile should be handled.
Draws an enhanced windows metafile specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawMetafile( _
   ByVal metafile As PDFMetafile, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal keepAspectRatio As KeepAspectRatio _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim metafile As PDFMetafile
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim keepAspectRatio As KeepAspectRatio

instance.DrawMetafile(metafile, left, top, width, height, orientation, keepAspectRatio)
C#
public void DrawMetafile(
   PDFMetafile metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
Delphi
public procedure DrawMetafile(
    metafile: PDFMetafile;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    keepAspectRatio: KeepAspectRatio
);
Managed Extensions for C++
public: void DrawMetafile(
   PDFMetafile* metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)
C++/CLI
public:
void DrawMetafile(
   PDFMetafile^ metafile,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   KeepAspectRatio keepAspectRatio
)

Parameters

metafile
The PDFMetafile object to be drawn.
left
The x coordinate of the top left corner of the metafile when it is placed on the page.
top
The y coordinate of the top left corner of the metafile when it is placed on the page.
width
The width of the metafile when it is placed on the page.
height
The height of the metafile when it is placed on the page.
orientation
The orientation, in degrees, of the metafile when it is placed on the page.
keepAspectRatio
A KeepAspectRatio enumeration member specifying how the original aspect ratio of the metafile should be handled.

Remarks

This function is used to draw a metafile on the canvas. The metafile content is scaled to the rectangle specified by (left, top, width, height) parameters. The metafile is rotated around (left, top) corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawTextDocLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawTextDocLink Method

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a line of text as a link to another page within the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub DrawTextDocLink( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

instance.DrawTextDocLink(destinationPage, topDestination, text, font, pen, brush, x, y, align, borderPen)
C#
public void DrawTextDocLink(
   PDFPage destinationPage,
   float topDestination,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public procedure DrawTextDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawTextDocLink(
   PDFPage* destinationPage,
   float topDestination,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawTextDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object specifying the destination of the link.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawTextFileLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawTextFileLink Method

filePath
a file path to the external file.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a line of text as a link to an external file.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub DrawTextFileLink( _
   ByVal filePath As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim filePath As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

instance.DrawTextFileLink(filePath, text, font, pen, brush, x, y, align, borderPen)
C#
public void DrawTextFileLink(
   string filePath,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public procedure DrawTextFileLink(
    filePath: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawTextFileLink(
   string* filePath,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawTextFileLink(
   String^ filePath,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

filePath
a file path to the external file.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawTextRemoteDocLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawTextRemoteDocLink Method

Draws a line of text as a link to another pdf document.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) | Draws a line of text as a link to another pdf document. Supported by Compact .NET Edition.
DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen,Boolean,Int32) | Draws a line of text as a link to another pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawTextRemoteDocLink Method : DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) Method

documentPath
a file path to the destination document.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a line of text as a link to another pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

instance.DrawTextRemoteDocLink(documentPath, text, font, pen, brush, x, y, align, borderPen)
C#
public void DrawTextRemoteDocLink(
   string documentPath,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public procedure DrawTextRemoteDocLink(
    documentPath: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawTextRemoteDocLink(
   string* documentPath,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawTextRemoteDocLink(
   String^ documentPath,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

documentPath
a file path to the destination document.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen,Boolean,Int32) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class > DrawTextRemoteDocLink Method : DrawTextRemoteDocLink(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen,Boolean,Int32) Method

documentPath
a file path to the destination document.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.
Draws a line of text as a link to another pdf document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextRemoteDocLink( _
   ByVal documentPath As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen, _
   ByVal openInNewWindow As Boolean, _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim documentPath As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen
Dim openInNewWindow As Boolean
Dim pageNumber As Integer

instance.DrawTextRemoteDocLink(documentPath, text, font, pen, brush, x, y, align, borderPen, openInNewWindow, pageNumber)
C#
public void DrawTextRemoteDocLink(
   string documentPath,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen,
   bool openInNewWindow,
   int pageNumber
)
Delphi
public procedure DrawTextRemoteDocLink(
    documentPath: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen;
    openInNewWindow: Boolean;
    pageNumber: Integer
);
Managed Extensions for C++
public: void DrawTextRemoteDocLink(
   string* documentPath,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen,
   bool openInNewWindow,
   int pageNumber
)
C++/CLI
public:
void DrawTextRemoteDocLink(
   String^ documentPath,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen,
   bool openInNewWindow,
   int pageNumber
)

Parameters

documentPath
a file path to the destination document.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
openInNewWindow
True if the destination document should open in a new window.
pageNumber
The number of destination page in remote document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members
Overload List


%%PageItemTitle%%

DrawTextWebLink Method
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : DrawTextWebLink Method

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.
Draws a line of text as a link to a web location.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub DrawTextWebLink( _
   ByVal url As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim url As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

instance.DrawTextWebLink(url, text, font, pen, brush, x, y, align, borderPen)
C#
public void DrawTextWebLink(
   string url,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public procedure DrawTextWebLink(
    url: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: void DrawTextWebLink(
   string* url,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
void DrawTextWebLink(
   String^ url,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

url
a string value specifying the destination of the link, as a HTTP/HTTPS URL.
text
the text that will represent the link.
font
a PDFFont object used to represent the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the interior of the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
a TextAlign enumeration member specifying the aligment of the text relative to the printing point.
borderPen
the PDFPen object used to draw the border width of the link area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%% $$Properties$$

PDFCanvas Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Properties

 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Layers Property
[image]
O2S.Components.PDF4NET Namespace > PDFCanvas Class : Layers Property

Gets the collection of layers available for this canvas.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As PDFLayers
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim value As PDFLayers

value = instance.Layers
C#
public PDFLayers Layers {get;}
Delphi
public read-only property Layers: PDFLayers;
Managed Extensions for C++
public: __property PDFLayers* get_Layers();
C++/CLI
public:
property PDFLayers^ Layers {
   PDFLayers^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

PDFCMLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFCMLogicalUnit Class

Defines the centimeter as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFCMLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
C#
public class PDFCMLogicalUnit : PDFLogicalUnitBase
Delphi
public class PDFCMLogicalUnit = class(PDFLogicalUnitBase)
Managed Extensions for C++
public __gc class PDFCMLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFCMLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the centimeter as a logical unit. The mapping between logical unit and pdf unit is 28.34646-to-1, one logical unit equals to 28.34646 pdf units. The mapping functions return the value given as parameter multiplied by 28.34646.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFCMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCMLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFCMLogicalUnit Class

The following tables list the members exposed by PDFCMLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFCMLogicalUnit Constructor | Initializes a new PDFCMLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFCMLogicalUnit Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFCMLogicalUnit Class : PDFCMLogicalUnit Constructor

Initializes a new PDFCMLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit()
C#
public PDFCMLogicalUnit()
Delphi
public PDFCMLogicalUnit();
Managed Extensions for C++
public: PDFCMLogicalUnit();
C++/CLI
public:
PDFCMLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFCMLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFCMLogicalUnit Class

For a list of all members of this type, see PDFCMLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET Namespace > PDFCMLogicalUnit Class : ToPDFUnitX Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitX(unit)
C#
public override float ToPDFUnitX(
   float unit
)
Delphi
public function ToPDFUnitX(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitX(
   float unit
) override
C++/CLI
public:
float ToPDFUnitX(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


%%PageItemTitle%%

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET Namespace > PDFCMLogicalUnit Class : ToPDFUnitY Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitY(unit)
C#
public override float ToPDFUnitY(
   float unit
)
Delphi
public function ToPDFUnitY(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitY(
   float unit
) override
C++/CLI
public:
float ToPDFUnitY(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


%%PageItemTitle%%

PDFDocument Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

Encapsulates the logic of a pdf document.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDocument
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
C#
public class PDFDocument : PDFObject
Delphi
public class PDFDocument = class(PDFObject)
Managed Extensions for C++
public __gc class PDFDocument : public PDFObject
C++/CLI
public ref class PDFDocument : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFDocument

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocument Class Members
See Also Properties Methods Events
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

The following tables list the members exposed by PDFDocument.

Public Constructors

 | Name | Description
Public Constructor | PDFDocument Constructor | Overloaded. Initializes a new PDFDocument object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | ColorSpace | Gets or sets the color representation in the pdf document. Supported by Compact .NET Edition.
Public Property | DocumentInformation | Gets the document information for this document. Supported by Compact .NET Edition.
Public Property | Fields | Gets the list of fields within the PDF document.
Public Property | Form | Gets the e-form associated with this document.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | MetadataSchemas | Gets the metadata schemas collection for this PDFDocument object. Supported by Compact .NET Edition.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | Outlines | Gets the collection of document's top level outlines Supported by Compact .NET Edition.
Public Property | PageHeight | Gets or sets the default page height. Supported by Compact .NET Edition.
Public Property | PageLogicalUnit | Gets or sets the default logical unit for positioning the graphic objects in the pages of the pdf document.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object. Supported by Compact .NET Edition.
Public Property | PageNumberingRanges | Gets the collection of page numbering ranges defined for this document.
Public Property | PageOrientation | Gets or sets the default page orientation. Supported by Compact .NET Edition.
Public Property | Pages | Gets the document's collection of pages. Supported by Compact .NET Edition.
Public Property | PageSize | Gets or sets the default page size. Supported by Compact .NET Edition.
Public Property | PageTemplate | Gets or sets the default template for document's pages. Supported by Compact .NET Edition.
Public Property | PageTransition | Gets or sets the default transition effects for the document.
Public Property | PageWidth | Gets or sets the default page width. Supported by Compact .NET Edition.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document. Supported by Compact .NET Edition.
Public Property | UseCompression | Gets or sets whether to enable compression in the document.
Public Property | ViewerPreferences | Gets the viewer preferences for the document. Supported by Compact .NET Edition.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top

Public Methods

 | Name | Description
Public Method | AddNumberingRange | Adds a new page numbering range to this PDFDocument object. Supported by Compact .NET Edition.
Public Method | AddPage | Overloaded. Adds the given page at the end of the document. Supported by Compact .NET Edition.
Public Method | Dispose | Clears all resources used by the PDF document.
Public Method | FlattenFormFields | Overloaded. Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | InsertPage | Overloaded. Inserts a page at the given index in the document. Supported by Compact .NET Edition.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SaveToFile | Saves the document to the given file. Supported by Compact .NET Edition.
Public Method | SaveToStream | Saves the document to the given stream. Supported by Compact .NET Edition.
Top

Public Events

 | Name | Description
Public Event | SaveProgress | Gets or sets the method to be executed when this event is raised.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocument Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFDocument Constructor

Initializes a new PDFDocument object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFDocument Constructor() | Initializes a new PDFDocument object. Supported by Compact .NET Edition.
PDFDocument Constructor(Stream) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocument Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor()

Initializes a new PDFDocument object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument()
C#
public PDFDocument()
Delphi
public PDFDocument();
Managed Extensions for C++
public: PDFDocument();
C++/CLI
public:
PDFDocument();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(Stream)
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream)

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFDocument(stream)
C#
public PDFDocument(
   Stream stream
)
Delphi
public PDFDocument(
    stream: Stream
);
Managed Extensions for C++
public: PDFDocument(
   Stream* stream
)
C++/CLI
public:
PDFDocument(
   Stream^ stream
)

Parameters

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.

Exceptions

Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(Stream,Byte[])
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream,Byte[])

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal password() As Byte _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim password() As Byte

Dim instance As PDFDocument(stream, password)
C#
public PDFDocument(
   Stream stream,
   byte[] password
)
Delphi
public PDFDocument(
    stream: Stream;
    password: Bytearray of
);
Managed Extensions for C++
public: PDFDocument(
   Stream* stream,
   byte[]* password
)
C++/CLI
public:
PDFDocument(
   Stream^ stream,
   array<byte>^ password
)

Parameters

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import or the given password is invalid.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(String)
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String)

pdfFile
path to pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pdfFile As String _
)
Visual Basic (Usage) Copy Code
Dim pdfFile As String

Dim instance As PDFDocument(pdfFile)
C#
public PDFDocument(
   string pdfFile
)
Delphi
public PDFDocument(
    pdfFile: String
);
Managed Extensions for C++
public: PDFDocument(
   string* pdfFile
)
C++/CLI
public:
PDFDocument(
   String^ pdfFile
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.

Exceptions

Exception | Description
PDFParserException | thrown when the input file can not be parsed for import.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(String,Byte[])
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String,Byte[])

pdfFile
path to pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pdfFile As String, _
   ByVal password() As Byte _
)
Visual Basic (Usage) Copy Code
Dim pdfFile As String
Dim password() As Byte

Dim instance As PDFDocument(pdfFile, password)
C#
public PDFDocument(
   string pdfFile,
   byte[] password
)
Delphi
public PDFDocument(
    pdfFile: String;
    password: Bytearray of
);
Managed Extensions for C++
public: PDFDocument(
   string* pdfFile,
   byte[]* password
)
C++/CLI
public:
PDFDocument(
   String^ pdfFile,
   array<byte>^ password
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input file can not be parsed for import or the given password is invalid.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFDocument Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Methods

 | Name | Description
Public Method | AddNumberingRange | Adds a new page numbering range to this PDFDocument object. Supported by Compact .NET Edition.
Public Method | AddPage | Overloaded. Adds the given page at the end of the document. Supported by Compact .NET Edition.
Public Method | Dispose | Clears all resources used by the PDF document.
Public Method | FlattenFormFields | Overloaded. Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | InsertPage | Overloaded. Inserts a page at the given index in the document. Supported by Compact .NET Edition.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SaveToFile | Saves the document to the given file. Supported by Compact .NET Edition.
Public Method | SaveToStream | Saves the document to the given stream. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

AddNumberingRange Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AddNumberingRange Method

pageNumberingRange
a PageNumberingRange object specifying a new numbering range to be applied to document's pages.
Adds a new page numbering range to this PDFDocument object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub AddNumberingRange( _
   ByVal pageNumberingRange As PageNumberingRange _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim pageNumberingRange As PageNumberingRange

instance.AddNumberingRange(pageNumberingRange)
C#
public void AddNumberingRange(
   PageNumberingRange pageNumberingRange
)
Delphi
public procedure AddNumberingRange(
    pageNumberingRange: PageNumberingRange
);
Managed Extensions for C++
public: void AddNumberingRange(
   PageNumberingRange* pageNumberingRange
)
C++/CLI
public:
void AddNumberingRange(
   PageNumberingRange^ pageNumberingRange
)

Parameters

pageNumberingRange
a PageNumberingRange object specifying a new numbering range to be applied to document's pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

AddPage Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AddPage Method

Adds the given page at the end of the document.

Supported by Compact .NET Edition.

Overload List

Overload | Description
AddPage(PDFPage) | Adds the given page at the end of the document. Supported by Compact .NET Edition.
AddPage() | Creates a new page and adds it as the last page of the document Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

AddPage(PDFPage) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > AddPage Method : AddPage(PDFPage) Method

page
a PDFPage object to be added as the last page of the document.
Adds the given page at the end of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddPage( _
   ByVal page As PDFPage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim page As PDFPage

instance.AddPage(page)
C#
public void AddPage(
   PDFPage page
)
Delphi
public procedure AddPage(
    page: PDFPage
);
Managed Extensions for C++
public: void AddPage(
   PDFPage* page
)
C++/CLI
public:
void AddPage(
   PDFPage^ page
)

Parameters

page
a PDFPage object to be added as the last page of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

AddPage() Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > AddPage Method : AddPage() Method

Creates a new page and adds it as the last page of the document

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function AddPage() As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPage

value = instance.AddPage()
C#
public PDFPage AddPage()
Delphi
public function AddPage(): PDFPage;
Managed Extensions for C++
public: PDFPage* AddPage();
C++/CLI
public:
PDFPage^ AddPage();

Return Value

a PDFPage object representing the newly added page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

Dispose Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Dispose Method

Clears all resources used by the PDF document.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Remarks

After this method has been called, the PDFDocument object is no longer valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

FlattenFormFields Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : FlattenFormFields Method

Flattens all the fields in the PDF form, making the PDF file uneditable.

Overload List

Overload | Description
FlattenFormFields() | Flattens all the fields in the PDF form, making the PDF file uneditable.
FlattenFormFields(Boolean,Boolean,Boolean,Boolean) | Flattens all the fields in the PDF form, making the PDF file uneditable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

FlattenFormFields() Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > FlattenFormFields Method : FlattenFormFields() Method

Flattens all the fields in the PDF form, making the PDF file uneditable.

Syntax

Visual Basic (Declaration)
Overloads Public Sub FlattenFormFields()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument

instance.FlattenFormFields()
C#
public void FlattenFormFields()
Delphi
public procedure FlattenFormFields();
Managed Extensions for C++
public: void FlattenFormFields();
C++/CLI
public:
void FlattenFormFields();

Remarks

This action is ireversible. Once the form fields have been flattened, they can no longer be edited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

FlattenFormFields(Boolean,Boolean,Boolean,Boolean) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > FlattenFormFields Method : FlattenFormFields(Boolean,Boolean,Boolean,Boolean) Method

includeVisible
True if visible fields should be flattened.
includeHidden
True if hidden fields should be flattened.
includeVisibleNonPrintable
True if visible but nonprintable fields should be flattened.
includeHiddenPrintable
True if hidden but printable fields should be flattened.
Flattens all the fields in the PDF form, making the PDF file uneditable.

Syntax

Visual Basic (Declaration)
Overloads Public Sub FlattenFormFields( _
   ByVal includeVisible As Boolean, _
   ByVal includeHidden As Boolean, _
   ByVal includeVisibleNonPrintable As Boolean, _
   ByVal includeHiddenPrintable As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim includeVisible As Boolean
Dim includeHidden As Boolean
Dim includeVisibleNonPrintable As Boolean
Dim includeHiddenPrintable As Boolean

instance.FlattenFormFields(includeVisible, includeHidden, includeVisibleNonPrintable, includeHiddenPrintable)
C#
public void FlattenFormFields(
   bool includeVisible,
   bool includeHidden,
   bool includeVisibleNonPrintable,
   bool includeHiddenPrintable
)
Delphi
public procedure FlattenFormFields(
    includeVisible: Boolean;
    includeHidden: Boolean;
    includeVisibleNonPrintable: Boolean;
    includeHiddenPrintable: Boolean
);
Managed Extensions for C++
public: void FlattenFormFields(
   bool includeVisible,
   bool includeHidden,
   bool includeVisibleNonPrintable,
   bool includeHiddenPrintable
)
C++/CLI
public:
void FlattenFormFields(
   bool includeVisible,
   bool includeHidden,
   bool includeVisibleNonPrintable,
   bool includeHiddenPrintable
)

Parameters

includeVisible
True if visible fields should be flattened.
includeHidden
True if hidden fields should be flattened.
includeVisibleNonPrintable
True if visible but nonprintable fields should be flattened.
includeHiddenPrintable
True if hidden but printable fields should be flattened.

Remarks

This action is ireversible. Once the form fields have been flattened, they can no longer be edited.
The fields that are not flattened are removed from the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

GetPDFAsByteArray Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : GetPDFAsByteArray Method

Gets the pdf file as a byte array.

Syntax

Visual Basic (Declaration)
Public Function GetPDFAsByteArray() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value() As Byte

value = instance.GetPDFAsByteArray()
C#
public byte[] GetPDFAsByteArray()
Delphi
public function GetPDFAsByteArray(): array of Byte;
Managed Extensions for C++
public: byte[]* GetPDFAsByteArray();
C++/CLI
public:
array<byte>^ GetPDFAsByteArray();

Return Value

a byte array storing the pdf file.

Remarks

This method retrives the pdf file as an array of bytes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

InsertPage Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : InsertPage Method

Inserts a page at the given index in the document.

Supported by Compact .NET Edition.

Overload List

Overload | Description
InsertPage(Int32,PDFPage) | Inserts a page at the given index in the document. Supported by Compact .NET Edition.
InsertPage(Int32) | Creates a new page and inserts it at the given index in the document. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

InsertPage(Int32,PDFPage) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > InsertPage Method : InsertPage(Int32,PDFPage) Method

index
The zero-based index at which page should be inserted.
page
a PDFPage object to be inserted.
Inserts a page at the given index in the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub InsertPage( _
   ByVal index As Integer, _
   ByVal page As PDFPage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim index As Integer
Dim page As PDFPage

instance.InsertPage(index, page)
C#
public void InsertPage(
   int index,
   PDFPage page
)
Delphi
public procedure InsertPage(
    index: Integer;
    page: PDFPage
);
Managed Extensions for C++
public: void InsertPage(
   int index,
   PDFPage* page
)
C++/CLI
public:
void InsertPage(
   int index,
   PDFPage^ page
)

Parameters

index
The zero-based index at which page should be inserted.
page
a PDFPage object to be inserted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

InsertPage(Int32) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > InsertPage Method : InsertPage(Int32) Method

index
The zero-based index at which the new page should be inserted.
Creates a new page and inserts it at the given index in the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function InsertPage( _
   ByVal index As Integer _
) As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim index As Integer
Dim value As PDFPage

value = instance.InsertPage(index)
C#
public PDFPage InsertPage(
   int index
)
Delphi
public function InsertPage(
    index: Integer
): PDFPage;
Managed Extensions for C++
public: PDFPage* InsertPage(
   int index
)
C++/CLI
public:
PDFPage^ InsertPage(
   int index
)

Parameters

index
The zero-based index at which the new page should be inserted.

Return Value

a PDFPage object representing the new page.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

Save Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Save Method

Saves the PDF document to a file.

Overload List

Overload | Description
Save(String) | Saves the PDF document to a file.
Save(String,Boolean) | Saves the PDF document to a file.
Save(Stream) | Saves the PDF document to a stream.
Save(Stream,Boolean) | Saves the PDF document to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Save(String) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String) Method

fileName
The path to the file where the PDF document will be saved.
Saves the PDF document to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String

instance.Save(fileName)
C#
public void Save(
   string fileName
)
Delphi
public procedure Save(
    fileName: String
);
Managed Extensions for C++
public: void Save(
   string* fileName
)
C++/CLI
public:
void Save(
   String^ fileName
)

Parameters

fileName
The path to the file where the PDF document will be saved.

Remarks

If the file already exists, it will be overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

Save(String,Boolean) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String,Boolean) Method

fileName
The path to the file where the PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String, _
   ByVal saveForFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String
Dim saveForFastWebView As Boolean

instance.Save(fileName, saveForFastWebView)
C#
public void Save(
   string fileName,
   bool saveForFastWebView
)
Delphi
public procedure Save(
    fileName: String;
    saveForFastWebView: Boolean
);
Managed Extensions for C++
public: void Save(
   string* fileName,
   bool saveForFastWebView
)
C++/CLI
public:
void Save(
   String^ fileName,
   bool saveForFastWebView
)

Parameters

fileName
The path to the file where the PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).

Remarks

If the file already exists, it will be overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

Save(Stream) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream) Method

stream
The stream object where PDF document will be saved.
Saves the PDF document to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Delphi
public procedure Save(
    stream: Stream
);
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The stream object where PDF document will be saved.

Remarks

The stream needs to be created prior saving the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

Save(Stream,Boolean) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream,Boolean) Method

stream
The stream object where PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal saveForFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream
Dim saveForFastWebView As Boolean

instance.Save(stream, saveForFastWebView)
C#
public void Save(
   Stream stream,
   bool saveForFastWebView
)
Delphi
public procedure Save(
    stream: Stream;
    saveForFastWebView: Boolean
);
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool saveForFastWebView
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool saveForFastWebView
)

Parameters

stream
The stream object where PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).

Remarks

The stream needs to be created prior saving the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

SaveToFile Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SaveToFile Method

fileName
the name of the file where the document will be saved.
Saves the document to the given file.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub SaveToFile( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String

instance.SaveToFile(fileName)
C#
public void SaveToFile(
   string fileName
)
Delphi
public procedure SaveToFile(
    fileName: String
);
Managed Extensions for C++
public: void SaveToFile(
   string* fileName
)
C++/CLI
public:
void SaveToFile(
   String^ fileName
)

Parameters

fileName
the name of the file where the document will be saved.

Exceptions

Exception | Description
PDFException | thrown when the pdf file can not be built.

Remarks

If the file exists, it is overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

SaveToStream Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SaveToStream Method

outputStream
a Stream object where the document will be saved.
Saves the document to the given stream.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub SaveToStream( _
   ByVal outputStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim outputStream As Stream

instance.SaveToStream(outputStream)
C#
public void SaveToStream(
   Stream outputStream
)
Delphi
public procedure SaveToStream(
    outputStream: Stream
);
Managed Extensions for C++
public: void SaveToStream(
   Stream* outputStream
)
C++/CLI
public:
void SaveToStream(
   Stream^ outputStream
)

Parameters

outputStream
a Stream object where the document will be saved.

Exceptions

Exception | Description
PDFException | thrown when the pdf file can not be built.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Properties$$

PDFDocument Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Properties

 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | ColorSpace | Gets or sets the color representation in the pdf document. Supported by Compact .NET Edition.
Public Property | DocumentInformation | Gets the document information for this document. Supported by Compact .NET Edition.
Public Property | Fields | Gets the list of fields within the PDF document.
Public Property | Form | Gets the e-form associated with this document.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | MetadataSchemas | Gets the metadata schemas collection for this PDFDocument object. Supported by Compact .NET Edition.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | Outlines | Gets the collection of document's top level outlines Supported by Compact .NET Edition.
Public Property | PageHeight | Gets or sets the default page height. Supported by Compact .NET Edition.
Public Property | PageLogicalUnit | Gets or sets the default logical unit for positioning the graphic objects in the pages of the pdf document.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object. Supported by Compact .NET Edition.
Public Property | PageNumberingRanges | Gets the collection of page numbering ranges defined for this document.
Public Property | PageOrientation | Gets or sets the default page orientation. Supported by Compact .NET Edition.
Public Property | Pages | Gets the document's collection of pages. Supported by Compact .NET Edition.
Public Property | PageSize | Gets or sets the default page size. Supported by Compact .NET Edition.
Public Property | PageTemplate | Gets or sets the default template for document's pages. Supported by Compact .NET Edition.
Public Property | PageTransition | Gets or sets the default transition effects for the document.
Public Property | PageWidth | Gets or sets the default page width. Supported by Compact .NET Edition.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document. Supported by Compact .NET Edition.
Public Property | UseCompression | Gets or sets whether to enable compression in the document.
Public Property | ViewerPreferences | Gets the viewer preferences for the document. Supported by Compact .NET Edition.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

AfterPrintAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterPrintAction Property

Gets or sets the javascript action to execute after the document is printed.

Syntax

Visual Basic (Declaration)
Public Property AfterPrintAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterPrintAction = value

value = instance.AfterPrintAction
C#
public PDFJavaScriptAction AfterPrintAction {get; set;}
Delphi
public read-write property AfterPrintAction: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_AfterPrintAction();
public: __property void set_AfterPrintAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ AfterPrintAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed after the document is printed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

AfterSaveAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterSaveAction Property

Gets or sets the javascript action to execute after the document is saved.

Syntax

Visual Basic (Declaration)
Public Property AfterSaveAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterSaveAction = value

value = instance.AfterSaveAction
C#
public PDFJavaScriptAction AfterSaveAction {get; set;}
Delphi
public read-write property AfterSaveAction: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_AfterSaveAction();
public: __property void set_AfterSaveAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ AfterSaveAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed after the document is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Attachments Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Attachments Property

Gets the list of file attachments embedded in this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attachments As PDFDocumentAttachmentCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDocumentAttachmentCollection

value = instance.Attachments
C#
public PDFDocumentAttachmentCollection Attachments {get;}
Delphi
public read-only property Attachments: PDFDocumentAttachmentCollection;
Managed Extensions for C++
public: __property PDFDocumentAttachmentCollection* get_Attachments();
C++/CLI
public:
property PDFDocumentAttachmentCollection^ Attachments {
   PDFDocumentAttachmentCollection^ get();
}

Return Value

PDFDocumentAttachmentCollection object specifying the list of document attachments.

Remarks

When a PDF file is imported into a PDFDocument object, this collection is populated automatically with the attachments in the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

BeforeCloseAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeCloseAction Property

Gets or sets the javascript action to execute before the document is closed.

Syntax

Visual Basic (Declaration)
Public Property BeforeCloseAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeCloseAction = value

value = instance.BeforeCloseAction
C#
public PDFJavaScriptAction BeforeCloseAction {get; set;}
Delphi
public read-write property BeforeCloseAction: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforeCloseAction();
public: __property void set_BeforeCloseAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforeCloseAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is closed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

BeforePrintAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforePrintAction Property

Gets or sets the javascript action to execute before the document is printed.

Syntax

Visual Basic (Declaration)
Public Property BeforePrintAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforePrintAction = value

value = instance.BeforePrintAction
C#
public PDFJavaScriptAction BeforePrintAction {get; set;}
Delphi
public read-write property BeforePrintAction: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforePrintAction();
public: __property void set_BeforePrintAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforePrintAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is printed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

BeforeSaveAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeSaveAction Property

Gets or sets the javascript action to execute before the document is saved.

Syntax

Visual Basic (Declaration)
Public Property BeforeSaveAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeSaveAction = value

value = instance.BeforeSaveAction
C#
public PDFJavaScriptAction BeforeSaveAction {get; set;}
Delphi
public read-write property BeforeSaveAction: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforeSaveAction();
public: __property void set_BeforeSaveAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforeSaveAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

ColorSpace Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : ColorSpace Property

Gets or sets the color representation in the pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As ColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As ColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public ColorSpace ColorSpace {get; set;}
Delphi
public read-write property ColorSpace: ColorSpace;
Managed Extensions for C++
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
C++/CLI
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (ColorSpace value);
}

Return Value

A ColorSpace enumeration member specifying how the color should be represented in the final pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

DocumentInformation Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : DocumentInformation Property

Gets the document information for this document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DocumentInformation As PDFDocumentInformation
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDocumentInformation

value = instance.DocumentInformation
C#
public PDFDocumentInformation DocumentInformation {get;}
Delphi
public read-only property DocumentInformation: PDFDocumentInformation;
Managed Extensions for C++
public: __property PDFDocumentInformation* get_DocumentInformation();
C++/CLI
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
}

Return Value

A PDFDocumentInformation object specifying general document information.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Fields Property

Gets the list of fields within the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As PDFFields
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFFields

value = instance.Fields
C#
public PDFFields Fields {get;}
Delphi
public read-only property Fields: PDFFields;
Managed Extensions for C++
public: __property PDFFields* get_Fields();
C++/CLI
public:
property PDFFields^ Fields {
   PDFFields^ get();
}

Return Value

A PDFFields object storing the fields in the PDF file.

Remarks

This property is deprecated. Fields should be used instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Form Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Form Property

Gets the e-form associated with this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Form As PDFForm
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFForm

value = instance.Form
C#
public PDFForm Form {get;}
Delphi
public read-only property Form: PDFForm;
Managed Extensions for C++
public: __property PDFForm* get_Form();
C++/CLI
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

JavaScripts Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : JavaScripts Property

Gets the list of global JavaScript actions associated with this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JavaScripts As PDFJavaScriptCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptCollection

value = instance.JavaScripts
C#
public PDFJavaScriptCollection JavaScripts {get;}
Delphi
public read-only property JavaScripts: PDFJavaScriptCollection;
Managed Extensions for C++
public: __property PDFJavaScriptCollection* get_JavaScripts();
C++/CLI
public:
property PDFJavaScriptCollection^ JavaScripts {
   PDFJavaScriptCollection^ get();
}

Return Value

PDFJavaScriptCollection object specifying the list of global JavaScript actions.

Remarks

The document level JavaScript actions are stored in a key-value pair format. The key is a user defined name, while the value is the actual Javascript code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

MetadataSchemas Property
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : MetadataSchemas Property

Gets the metadata schemas collection for this PDFDocument object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataSchemas As PDFMetadataSchemas
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFMetadataSchemas

value = instance.MetadataSchemas
C#
public PDFMetadataSchemas MetadataSchemas {get;}
Delphi
public read-only property MetadataSchemas: PDFMetadataSchemas;
Managed Extensions for C++
public: __property PDFMetadataSchemas* get_MetadataSchemas();
C++/CLI
public:
property PDFMetadataSchemas^ MetadataSchemas {
   PDFMetadataSchemas^ get();
}

Return Value

A PDFMetadataSchemas object specifying the collection of metadata schemas.

Example

The following example shows how to set several custom properties for a document:
C# Copy Code
...
PDFDocument doc = new PDFDocument( );

PDFMetadataSchema schema = new PDFMetadataSchema( );
schema.Name = "http://ns.o2sol.com/schema/pdf/1.4/";
schema.NamespacePrefix = "o2s";

// set Company attribute
schema["Company"] = "O2 Solutions";
// set Website attribute
schema["Website"] = "http://www.o2sol.com/";

// Add schema to the document
doc.MetadataSchemas.Add( schema );
...

Remarks

Metadata schemas are used to define custom properties for a document. Related properties can be grouped into a schema and several schemas can be attached to a document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

OpenAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : OpenAction Property

Gets or sets the action to execute when the document is opened.

Syntax

Visual Basic (Declaration)
Public Property OpenAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
C#
public PDFAction OpenAction {get; set;}
Delphi
public read-write property OpenAction: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when documents opens in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Outlines Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Outlines Property

Gets the collection of document's top level outlines

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outlines As PDFOutlines
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFOutlines

value = instance.Outlines
C#
public PDFOutlines Outlines {get;}
Delphi
public read-only property Outlines: PDFOutlines;
Managed Extensions for C++
public: __property PDFOutlines* get_Outlines();
C++/CLI
public:
property PDFOutlines^ Outlines {
   PDFOutlines^ get();
}

Return Value

A PDFOutlines object specifying the document's top level outlines.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageHeight Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageHeight Property

Gets or sets the default page height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As Single

instance.PageHeight = value

value = instance.PageHeight
C#
public float PageHeight {get; set;}
Delphi
public read-write property PageHeight: Single;
Managed Extensions for C++
public: __property float get_PageHeight();
public: __property void set_PageHeight(
   float value
);
C++/CLI
public:
property float PageHeight {
   float get();
   void set (float value);
}

Return Value

A float value specifying the default height of document's pages.

Remarks

When a page is added to the document, it inherits the default page height unless another page height has been set on the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageLogicalUnit Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageLogicalUnit Property

Gets or sets the default logical unit for positioning the graphic objects in the pages of the pdf document.

Syntax

Visual Basic (Declaration)
Public Property PageLogicalUnit As PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFLogicalUnitBase

instance.PageLogicalUnit = value

value = instance.PageLogicalUnit
C#
public PDFLogicalUnitBase PageLogicalUnit {get; set;}
Delphi
public read-write property PageLogicalUnit: PDFLogicalUnitBase;
Managed Extensions for C++
public: __property PDFLogicalUnitBase* get_PageLogicalUnit();
public: __property void set_PageLogicalUnit(
   PDFLogicalUnitBase* value
);
C++/CLI
public:
property PDFLogicalUnitBase^ PageLogicalUnit {
   PDFLogicalUnitBase^ get();
   void set (PDFLogicalUnitBase^ value);
}

Return Value

A PDFLogicalUnitBase descendant specifying logical unit used for positioning the graphic objects in the pages of the pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageNumber Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumber Property

Gets or sets the default page number visual aspect for this PDFDocument object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As PageNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PageNumber

instance.PageNumber = value

value = instance.PageNumber
C#
public PageNumber PageNumber {get; set;}
Delphi
public read-write property PageNumber: PageNumber;
Managed Extensions for C++
public: __property PageNumber* get_PageNumber();
public: __property void set_PageNumber(
   PageNumber* value
);
C++/CLI
public:
property PageNumber^ PageNumber {
   PageNumber^ get();
   void set (PageNumber^ value);
}

Return Value

A PageNumber object specifying the default visual appearance of the printed page numbers.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageNumberingRanges Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumberingRanges Property

Gets the collection of page numbering ranges defined for this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumberingRanges As PageNumberingRangeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PageNumberingRangeCollection

value = instance.PageNumberingRanges
C#
public PageNumberingRangeCollection PageNumberingRanges {get;}
Delphi
public read-only property PageNumberingRanges: PageNumberingRangeCollection;
Managed Extensions for C++
public: __property PageNumberingRangeCollection* get_PageNumberingRanges();
C++/CLI
public:
property PageNumberingRangeCollection^ PageNumberingRanges {
   PageNumberingRangeCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageOrientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageOrientation Property

Gets or sets the default page orientation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageOrientation As PageOrientation
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PageOrientation

instance.PageOrientation = value

value = instance.PageOrientation
C#
public PageOrientation PageOrientation {get; set;}
Delphi
public read-write property PageOrientation: PageOrientation;
Managed Extensions for C++
public: __property PageOrientation get_PageOrientation();
public: __property void set_PageOrientation(
   PageOrientation value
);
C++/CLI
public:
property PageOrientation PageOrientation {
   PageOrientation get();
   void set (PageOrientation value);
}

Return Value

A PageOrientation enumeration member specifying the default orientation for document's pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

Pages Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Pages Property

Gets the document's collection of pages.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PDFPages
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPages

value = instance.Pages
C#
public PDFPages Pages {get;}
Delphi
public read-only property Pages: PDFPages;
Managed Extensions for C++
public: __property PDFPages* get_Pages();
C++/CLI
public:
property PDFPages^ Pages {
   PDFPages^ get();
}

Return Value

A PDFPages object containing the list of document's pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageSize Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageSize Property

Gets or sets the default page size.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageSize As PageSize
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PageSize

instance.PageSize = value

value = instance.PageSize
C#
public PageSize PageSize {get; set;}
Delphi
public read-write property PageSize: PageSize;
Managed Extensions for C++
public: __property PageSize get_PageSize();
public: __property void set_PageSize(
   PageSize value
);
C++/CLI
public:
property PageSize PageSize {
   PageSize get();
   void set (PageSize value);
}

Return Value

A PageSize enumeration member specifying the default size for document's pages.

Remarks

When a page is added to the document, it inherits the default size unless another size has been set on the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageTemplate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageTemplate Property

Gets or sets the default template for document's pages.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageTemplate As PDFPageTemplate
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageTemplate

instance.PageTemplate = value

value = instance.PageTemplate
C#
public PDFPageTemplate PageTemplate {get; set;}
Delphi
public read-write property PageTemplate: PDFPageTemplate;
Managed Extensions for C++
public: __property PDFPageTemplate* get_PageTemplate();
public: __property void set_PageTemplate(
   PDFPageTemplate* value
);
C++/CLI
public:
property PDFPageTemplate^ PageTemplate {
   PDFPageTemplate^ get();
   void set (PDFPageTemplate^ value);
}

Return Value

A PDFPageTemplate object specifying the default template to be drawn on document's pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageTransition Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageTransition Property

Gets or sets the default transition effects for the document.

Syntax

Visual Basic (Declaration)
Public Property PageTransition As PDFPageTransition
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageTransition

instance.PageTransition = value

value = instance.PageTransition
C#
public PDFPageTransition PageTransition {get; set;}
Delphi
public read-write property PageTransition: PDFPageTransition;
Managed Extensions for C++
public: __property PDFPageTransition* get_PageTransition();
public: __property void set_PageTransition(
   PDFPageTransition* value
);
C++/CLI
public:
property PDFPageTransition^ PageTransition {
   PDFPageTransition^ get();
   void set (PDFPageTransition^ value);
}

Return Value

A PDFPageTransition object specifying the default transition effects when going from one page to the next in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PageWidth Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageWidth Property

Gets or sets the default page width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As Single

instance.PageWidth = value

value = instance.PageWidth
C#
public float PageWidth {get; set;}
Delphi
public read-write property PageWidth: Single;
Managed Extensions for C++
public: __property float get_PageWidth();
public: __property void set_PageWidth(
   float value
);
C++/CLI
public:
property float PageWidth {
   float get();
   void set (float value);
}

Return Value

A float value specifying the default width of document's pages.

Remarks

When a page is added to the document, it inherits the default page width unless another page width has been set on the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFVersion Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFVersion Property

Gets or sets the PDF version of this PDFDocument object.

Syntax

Visual Basic (Declaration)
Public Property PDFVersion As PDFVersion
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFVersion

instance.PDFVersion = value

value = instance.PDFVersion
C#
public PDFVersion PDFVersion {get; set;}
Delphi
public read-write property PDFVersion: PDFVersion;
Managed Extensions for C++
public: __property PDFVersion get_PDFVersion();
public: __property void set_PDFVersion(
   PDFVersion value
);
C++/CLI
public:
property PDFVersion PDFVersion {
   PDFVersion get();
   void set (PDFVersion value);
}

Return Value

A PDFVersion enumeration member specifying the PDF version of this PDFDocument object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

SecurityManager Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SecurityManager Property

Gets or sets the security manager for this pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property SecurityManager As PDFSecurityManager
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFSecurityManager

instance.SecurityManager = value

value = instance.SecurityManager
C#
public PDFSecurityManager SecurityManager {get; set;}
Delphi
public read-write property SecurityManager: PDFSecurityManager;
Managed Extensions for C++
public: __property PDFSecurityManager* get_SecurityManager();
public: __property void set_SecurityManager(
   PDFSecurityManager* value
);
C++/CLI
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
   void set (PDFSecurityManager^ value);
}

Return Value

A PDFSecurityManager object specifying the security manager for this pdf document.

Remarks

Set this property to a valid security manager object to enforce security settings (document encryption, passwords, access rights), on the pdf document. When this property is null, no security is applied on the resulted pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

UseCompression Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : UseCompression Property

Gets or sets whether to enable compression in the document.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As Boolean

instance.UseCompression = value

value = instance.UseCompression
C#
public bool UseCompression {get; set;}
Delphi
public read-write property UseCompression: Boolean;
Managed Extensions for C++
public: __property bool get_UseCompression();
public: __property void set_UseCompression(
   bool value
);
C++/CLI
public:
property bool UseCompression {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying whether to compress or not the document content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

ViewerPreferences Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : ViewerPreferences Property

Gets the viewer preferences for the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ViewerPreferences As PDFViewerPreferences
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFViewerPreferences

value = instance.ViewerPreferences
C#
public PDFViewerPreferences ViewerPreferences {get;}
Delphi
public read-only property ViewerPreferences: PDFViewerPreferences;
Managed Extensions for C++
public: __property PDFViewerPreferences* get_ViewerPreferences();
C++/CLI
public:
property PDFViewerPreferences^ ViewerPreferences {
   PDFViewerPreferences^ get();
}

Return Value

A PDFViewerPreferences object used to set the viewer preferences for this document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

XFAForm Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : XFAForm Property

Gets the XFA form associated with this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XFAForm As XFAForm
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As XFAForm

value = instance.XFAForm
C#
public XFAForm XFAForm {get;}
Delphi
public read-only property XFAForm: XFAForm;
Managed Extensions for C++
public: __property XFAForm* get_XFAForm();
C++/CLI
public:
property XFAForm^ XFAForm {
   XFAForm^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Events$$

PDFDocument Class Events
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Events

 | Name | Description
Public Event | SaveProgress | Gets or sets the method to be executed when this event is raised.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

SaveProgress Event
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SaveProgress Event

Gets or sets the method to be executed when this event is raised.

Syntax

Visual Basic (Declaration)
Public Event SaveProgress() As PDFDocument.SaveProgressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim handler As PDFDocument.SaveProgressEventHandler

AddHandler instance.SaveProgress, handler
C#
public event PDFDocument.SaveProgressEventHandler SaveProgress()
Delphi
public event SaveProgress: PDFDocument.SaveProgressEventHandler;
Managed Extensions for C++
public: __event PDFDocument.SaveProgressEventHandler* SaveProgress();
C++/CLI
public:
event PDFDocument.SaveProgressEventHandler^ SaveProgress();

Event Data

The event handler receives an argument of type SaveProgressEventArgs containing data related to this event. The following SaveProgressEventArgs properties provide information specific to this event.

Property | Description
Progress | Gets the progress of the document save operation.

Remarks

This event allows to monitor the progress of saving a PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocumentAttachment Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

Defines a file embedded in a PDF document.

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentAttachment
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
C#
public class PDFDocumentAttachment : PDFObject
Delphi
public class PDFDocumentAttachment = class(PDFObject)
Managed Extensions for C++
public __gc class PDFDocumentAttachment : public PDFObject
C++/CLI
public ref class PDFDocumentAttachment : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFDocumentAttachment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentAttachment Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

The following tables list the members exposed by PDFDocumentAttachment.

Public Constructors

 | Name | Description
Public Constructor | PDFDocumentAttachment Constructor | Overloaded. Initializes a new PDFDocumentAttachment object.
Top

Public Properties

 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Top

See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentAttachment Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : PDFDocumentAttachment Constructor

Initializes a new PDFDocumentAttachment object.

Overload List

Overload | Description
PDFDocumentAttachment Constructor() | Initializes a new PDFDocumentAttachment object.
PDFDocumentAttachment Constructor(Byte[]) | Initializes a new PDFDocumentAttachment object with the given content.
PDFDocumentAttachment Constructor(String) | Initializes a new PDFDocumentAttachment object with the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

PDFDocumentAttachment Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor()

Initializes a new PDFDocumentAttachment object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment()
C#
public PDFDocumentAttachment()
Delphi
public PDFDocumentAttachment();
Managed Extensions for C++
public: PDFDocumentAttachment();
C++/CLI
public:
PDFDocumentAttachment();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%%

PDFDocumentAttachment Constructor(Byte[])
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(Byte[])

fileData
The binary content to embed in the PDF file.
Initializes a new PDFDocumentAttachment object with the given content.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim fileData() As Byte

Dim instance As PDFDocumentAttachment(fileData)
C#
public PDFDocumentAttachment(
   byte[] fileData
)
Delphi
public PDFDocumentAttachment(
    fileData: Bytearray of
);
Managed Extensions for C++
public: PDFDocumentAttachment(
   byte[]* fileData
)
C++/CLI
public:
PDFDocumentAttachment(
   array<byte>^ fileData
)

Parameters

fileData
The binary content to embed in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%%

PDFDocumentAttachment Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(String)

fileName
The name of the file to embed.
Initializes a new PDFDocumentAttachment object with the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFDocumentAttachment(fileName)
C#
public PDFDocumentAttachment(
   string fileName
)
Delphi
public PDFDocumentAttachment(
    fileName: String
);
Managed Extensions for C++
public: PDFDocumentAttachment(
   string* fileName
)
C++/CLI
public:
PDFDocumentAttachment(
   String^ fileName
)

Parameters

fileName
The name of the file to embed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFDocumentAttachment Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

For a list of all members of this type, see PDFDocumentAttachment members.

Public Properties

 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Top

See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

CreationDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : CreationDate Property

Gets or sets the creation date and time of the attachment.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Delphi
public read-write property CreationDate: DateTime;
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the attachment was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

Description Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Description Property

Gets or sets the attachment description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Delphi
public read-write property Description: String;
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying an optional description associated with this attachment.

Remarks

The description is used to provide the user with more information about the embedded attachment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

FileData Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileData Property

Gets or sets the file data for this embedded file.

Syntax

Visual Basic (Declaration)
Public Property FileData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value() As Byte

instance.FileData = value

value = instance.FileData
C#
public byte[] FileData {get; set;}
Delphi
public read-write property FileData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_FileData();
public: __property void set_FileData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ FileData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the content to embed.

Remarks

If both FileName and FileData are set, FileData will be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

FileName Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileName Property

Gets or sets the name of file to embed.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Delphi
public read-write property FileName: String;
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

A string specifying the file to embed.

Remarks

If both FileName and FileData are set, FileData will be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

MimeType Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : MimeType Property

Gets or sets the MIME type of the file to embed.

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.MimeType = value

value = instance.MimeType
C#
public string MimeType {get; set;}
Delphi
public read-write property MimeType: String;
Managed Extensions for C++
public: __property string* get_MimeType();
public: __property void set_MimeType(
   string* value
);
C++/CLI
public:
property String^ MimeType {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the MIME type of the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

ModifyDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : ModifyDate Property

Gets or sets the modify date and time of the attachment.

Syntax

Visual Basic (Declaration)
Public Property ModifyDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
C#
public DateTime ModifyDate {get; set;}
Delphi
public read-write property ModifyDate: DateTime;
Managed Extensions for C++
public: __property DateTime get_ModifyDate();
public: __property void set_ModifyDate(
   DateTime value
);
C++/CLI
public:
property DateTime ModifyDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the attachment was modified.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

PDFDocumentAttachmentCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

Defines a collection of document attachments displayed on a PDF page.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFDocumentAttachmentCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFDocumentAttachmentCollection : PDFObject
Delphi
public class PDFDocumentAttachmentCollection = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFDocumentAttachmentCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFDocumentAttachmentCollection sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentAttachmentCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

The following tables list the members exposed by PDFDocumentAttachmentCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of document attachments in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the document attachment at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an document attachment at the end of the collection.
Public Method | Clear | Clear the document attachments collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts a document attachment at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the document attachment from the collection.
Public Method | RemoveAt | Removes the document attachment at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFDocumentAttachmentCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an document attachment at the end of the collection.
Public Method | Clear | Clear the document attachments collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts a document attachment at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the document attachment from the collection.
Public Method | RemoveAt | Removes the document attachment at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Add Method

attachment
a PDFDocumentAttachment object to be added to the collection
Adds an document attachment at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal attachment As PDFDocumentAttachment _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim attachment As PDFDocumentAttachment

instance.Add(attachment)
C#
public void Add(
   PDFDocumentAttachment attachment
)
Delphi
public procedure Add(
    attachment: PDFDocumentAttachment
);
Managed Extensions for C++
public: void Add(
   PDFDocumentAttachment* attachment
)
C++/CLI
public:
void Add(
   PDFDocumentAttachment^ attachment
)

Parameters

attachment
a PDFDocumentAttachment object to be added to the collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Clear Method

Clear the document attachments collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

This method removes all document attachments from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Insert Method

index
the index where to insert the document attachment.
attachment
a PDFDocumentAttachment object to be added to the collection
Inserts a document attachment at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal attachment As PDFDocumentAttachment _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim index As Integer
Dim attachment As PDFDocumentAttachment

instance.Insert(index, attachment)
C#
public void Insert(
   int index,
   PDFDocumentAttachment attachment
)
Delphi
public procedure Insert(
    index: Integer;
    attachment: PDFDocumentAttachment
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFDocumentAttachment* attachment
)
C++/CLI
public:
void Insert(
   int index,
   PDFDocumentAttachment^ attachment
)

Parameters

index
the index where to insert the document attachment.
attachment
a PDFDocumentAttachment object to be added to the collection

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of document attachments in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Remove Method

attachment
The document attachment to be removed.
Removes the document attachment from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal attachment As PDFDocumentAttachment _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim attachment As PDFDocumentAttachment

instance.Remove(attachment)
C#
public void Remove(
   PDFDocumentAttachment attachment
)
Delphi
public procedure Remove(
    attachment: PDFDocumentAttachment
);
Managed Extensions for C++
public: void Remove(
   PDFDocumentAttachment* attachment
)
C++/CLI
public:
void Remove(
   PDFDocumentAttachment^ attachment
)

Parameters

attachment
The document attachment to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : RemoveAt Method

index
the index where to remove the document attachment.
Removes the document attachment at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
the index where to remove the document attachment.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of document attachments in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%% $$Properties$$

PDFDocumentAttachmentCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of document attachments in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the document attachment at the specified index (zero based index).
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Count Property

Returns the number of document attachments in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachmentCollection Class : Item Property

index
Gets the document attachment at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFDocumentAttachment
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
Dim index As Integer
Dim value As PDFDocumentAttachment

value = instance.Item(index)
C#
public PDFDocumentAttachment this[
   int index
]; {get;}
Delphi
public  this: : PDFDocumentAttachment;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFDocumentAttachment* get_Item(
   int index
);
C++/CLI
public:
property PDFDocumentAttachment^ default [int] {
   PDFDocumentAttachment^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Class
PDFDocumentAttachmentCollection Members


%%PageItemTitle%%

PDFDocumentInformation Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

Defines the document's general information.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentInformation
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
C#
public class PDFDocumentInformation : PDFObject
Delphi
public class PDFDocumentInformation = class(PDFObject)
Managed Extensions for C++
public __gc class PDFDocumentInformation : public PDFObject
C++/CLI
public ref class PDFDocumentInformation : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFDocumentInformation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentInformation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

The following tables list the members exposed by PDFDocumentInformation.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the document Supported by Compact .NET Edition.
Public Property | CreationDate | Gets or sets the creation date of the document.
Public Property | Creator | Gets or sets the creator of the document. Supported by Compact .NET Edition.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Keywords | Gets or sets keywords for the document. Supported by Compact .NET Edition.
Public Property | ModDate | Gets or sets the modification date of the document.
Public Property | Producer | Gets the producer of the document. Supported by Compact .NET Edition.
Public Property | Subject | Gets or sets the subject of the document. Supported by Compact .NET Edition.
Public Property | Title | Gets or sets the title of the document. Supported by Compact .NET Edition.
Public Property | XMPMetadata | Gets the XMP metadata stored in the PDF document.
Top

See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFDocumentInformation Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

For a list of all members of this type, see PDFDocumentInformation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the document Supported by Compact .NET Edition.
Public Property | CreationDate | Gets or sets the creation date of the document.
Public Property | Creator | Gets or sets the creator of the document. Supported by Compact .NET Edition.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Keywords | Gets or sets keywords for the document. Supported by Compact .NET Edition.
Public Property | ModDate | Gets or sets the modification date of the document.
Public Property | Producer | Gets the producer of the document. Supported by Compact .NET Edition.
Public Property | Subject | Gets or sets the subject of the document. Supported by Compact .NET Edition.
Public Property | Title | Gets or sets the title of the document. Supported by Compact .NET Edition.
Public Property | XMPMetadata | Gets the XMP metadata stored in the PDF document.
Top

See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Author Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Author Property

Gets or sets the author of the document

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Delphi
public read-write property Author: String;
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the author of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

CreationDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CreationDate Property

Gets or sets the creation date of the document.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Delphi
public read-write property CreationDate: DateTime;
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date when the document has been created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

Creator Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Creator Property

Gets or sets the creator of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Creator As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Creator = value

value = instance.Creator
C#
public string Creator {get; set;}
Delphi
public read-write property Creator: String;
Managed Extensions for C++
public: __property string* get_Creator();
public: __property void set_Creator(
   string* value
);
C++/CLI
public:
property String^ Creator {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the creator of the document.

Remarks

Usually, this property contains the name of the application creating the pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

CustomProperties Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CustomProperties Property

Gets the collection of custom properties of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As Hashtable

value = instance.CustomProperties
C#
public Hashtable CustomProperties {get;}
Delphi
public read-only property CustomProperties: Hashtable;
Managed Extensions for C++
public: __property Hashtable* get_CustomProperties();
C++/CLI
public:
property Hashtable^ CustomProperties {
   Hashtable^ get();
}

Return Value

a Hashtable object storing the document's custom properties.

Remarks

The properties in this collection are stored in the DocumentInformation dictionary as custom keys.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

Keywords Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Keywords Property

Gets or sets keywords for the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Keywords As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Keywords = value

value = instance.Keywords
C#
public string Keywords {get; set;}
Delphi
public read-write property Keywords: String;
Managed Extensions for C++
public: __property string* get_Keywords();
public: __property void set_Keywords(
   string* value
);
C++/CLI
public:
property String^ Keywords {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a list of keyworks for the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

ModDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : ModDate Property

Gets or sets the modification date of the document.

Syntax

Visual Basic (Declaration)
Public Property ModDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As Date

instance.ModDate = value

value = instance.ModDate
C#
public DateTime ModDate {get; set;}
Delphi
public read-write property ModDate: DateTime;
Managed Extensions for C++
public: __property DateTime get_ModDate();
public: __property void set_ModDate(
   DateTime value
);
C++/CLI
public:
property DateTime ModDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date when the document was modified.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

Producer Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Producer Property

Gets the producer of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Producer As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

value = instance.Producer
C#
public string Producer {get;}
Delphi
public read-only property Producer: String;
Managed Extensions for C++
public: __property string* get_Producer();
C++/CLI
public:
property String^ Producer {
   String^ get();
}

Return Value

A string value specifying the producer of the document. It is readonly and has the default value: PDF4NET.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

Subject Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Subject Property

Gets or sets the subject of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Delphi
public read-write property Subject: String;
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the subject of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

Title Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Title Property

Gets or sets the title of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Delphi
public read-write property Title: String;
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the title of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

XMPMetadata Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : XMPMetadata Property

Gets the XMP metadata stored in the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XMPMetadata As XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As XmlDocument

value = instance.XMPMetadata
C#
public XmlDocument XMPMetadata {get;}
Delphi
public read-only property XMPMetadata: XmlDocument;
Managed Extensions for C++
public: __property XmlDocument get_XMPMetadata();
C++/CLI
public:
property XmlDocument XMPMetadata {
   XmlDocument get();
}

Return Value

a XmlDocument object storing the XML metadata.

Remarks

This property has a value only for an imported PDF document, if the PDF document includes XMP metadata.
For a newly created document, this property is always null and it can not be set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

PDFException Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

Defines the exceptions thrown by the PDF4NET library.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As PDFException
C#
public class PDFException : ApplicationException
Delphi
public class PDFException = class(ApplicationException)
Managed Extensions for C++
public __gc class PDFException : public ApplicationException
C++/CLI
public ref class PDFException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

The following tables list the members exposed by PDFException.

Public Constructors

 | Name | Description
Public Constructor | PDFException Constructor | Overloaded. Initializes a new PDFException object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFException Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFException Class : PDFException Constructor

Initializes a new PDFException object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFException Constructor(String) | Initializes a new PDFException object. Supported by Compact .NET Edition.
PDFException Constructor(String,Exception) | Initializes a new PDFException object. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members


%%PageItemTitle%%

PDFException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String)

message
The message that describes the exception.
Initializes a new PDFException object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As PDFException(message)
C#
public PDFException(
   string message
)
Delphi
public PDFException(
    message: String
);
Managed Extensions for C++
public: PDFException(
   string* message
)
C++/CLI
public:
PDFException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new PDFException object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As PDFException(message, innerException)
C#
public PDFException(
   string message,
   Exception innerException
)
Delphi
public PDFException(
    message: String;
    innerException: Exception
);
Managed Extensions for C++
public: PDFException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
PDFException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFInchLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFInchLogicalUnit Class

Defines the inch as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFInchLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
C#
public class PDFInchLogicalUnit : PDFLogicalUnitBase
Delphi
public class PDFInchLogicalUnit = class(PDFLogicalUnitBase)
Managed Extensions for C++
public __gc class PDFInchLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFInchLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the inch as a logical unit. The mapping between logical unit and pdf unit is 72-to-1, one logical unit equals to 72 pdf units. The mapping functions return the value given as parameter multiplied by 72.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFInchLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFInchLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFInchLogicalUnit Class

The following tables list the members exposed by PDFInchLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFInchLogicalUnit Constructor | Initializes a new PDFInchLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFInchLogicalUnit Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFInchLogicalUnit Class : PDFInchLogicalUnit Constructor

Initializes a new PDFInchLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit()
C#
public PDFInchLogicalUnit()
Delphi
public PDFInchLogicalUnit();
Managed Extensions for C++
public: PDFInchLogicalUnit();
C++/CLI
public:
PDFInchLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFInchLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFInchLogicalUnit Class

For a list of all members of this type, see PDFInchLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET Namespace > PDFInchLogicalUnit Class : ToPDFUnitX Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitX(unit)
C#
public override float ToPDFUnitX(
   float unit
)
Delphi
public function ToPDFUnitX(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitX(
   float unit
) override
C++/CLI
public:
float ToPDFUnitX(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


%%PageItemTitle%%

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET Namespace > PDFInchLogicalUnit Class : ToPDFUnitY Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitY(unit)
C#
public override float ToPDFUnitY(
   float unit
)
Delphi
public function ToPDFUnitY(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitY(
   float unit
) override
C++/CLI
public:
float ToPDFUnitY(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


%%PageItemTitle%%

PDFJavaScriptBlock Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptBlock Class

Defines a block of JavaScript code.

Syntax

Visual Basic (Declaration)
Public Class PDFJavaScriptBlock
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptBlock
C#
public class PDFJavaScriptBlock : PDFObject
Delphi
public class PDFJavaScriptBlock = class(PDFObject)
Managed Extensions for C++
public __gc class PDFJavaScriptBlock : public PDFObject
C++/CLI
public ref class PDFJavaScriptBlock : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFJavaScriptBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptBlock Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptBlock Class

The following tables list the members exposed by PDFJavaScriptBlock.

Public Constructors

 | Name | Description
Public Constructor | PDFJavaScriptBlock Constructor | Overloaded. Initializes a new PDFJavaScriptBlock object.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of this JavaScript block.
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top

Public Methods

 | Name | Description
Public Method | CompareTo | Compares 2 streams by their name
Top

See Also

Reference

PDFJavaScriptBlock Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFJavaScriptBlock Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class : PDFJavaScriptBlock Constructor

Initializes a new PDFJavaScriptBlock object.

Overload List

Overload | Description
PDFJavaScriptBlock Constructor() | Initializes a new PDFJavaScriptBlock object.
PDFJavaScriptBlock Constructor(String) | Initializes a new PDFJavaScriptBlock object.
PDFJavaScriptBlock Constructor(String,String) | Initializes a new PDFJavaScriptBlock object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members


%%PageItemTitle%%

PDFJavaScriptBlock Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class > PDFJavaScriptBlock Constructor : PDFJavaScriptBlock Constructor()

Initializes a new PDFJavaScriptBlock object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptBlock()
C#
public PDFJavaScriptBlock()
Delphi
public PDFJavaScriptBlock();
Managed Extensions for C++
public: PDFJavaScriptBlock();
C++/CLI
public:
PDFJavaScriptBlock();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members
Overload List


%%PageItemTitle%%

PDFJavaScriptBlock Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class > PDFJavaScriptBlock Constructor : PDFJavaScriptBlock Constructor(String)

javaScript
The JavaScript code to be included in the block.
Initializes a new PDFJavaScriptBlock object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal javaScript As String _
)
Visual Basic (Usage) Copy Code
Dim javaScript As String

Dim instance As PDFJavaScriptBlock(javaScript)
C#
public PDFJavaScriptBlock(
   string javaScript
)
Delphi
public PDFJavaScriptBlock(
    javaScript: String
);
Managed Extensions for C++
public: PDFJavaScriptBlock(
   string* javaScript
)
C++/CLI
public:
PDFJavaScriptBlock(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code to be included in the block.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members
Overload List


%%PageItemTitle%%

PDFJavaScriptBlock Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class > PDFJavaScriptBlock Constructor : PDFJavaScriptBlock Constructor(String,String)

name
The name of this JavaScript block.
javaScript
The JavaScript code to be included in the block.
Initializes a new PDFJavaScriptBlock object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal javaScript As String _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim javaScript As String

Dim instance As PDFJavaScriptBlock(name, javaScript)
C#
public PDFJavaScriptBlock(
   string name,
   string javaScript
)
Delphi
public PDFJavaScriptBlock(
    name: String;
    javaScript: String
);
Managed Extensions for C++
public: PDFJavaScriptBlock(
   string* name,
   string* javaScript
)
C++/CLI
public:
PDFJavaScriptBlock(
   String^ name,
   String^ javaScript
)

Parameters

name
The name of this JavaScript block.
javaScript
The JavaScript code to be included in the block.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFJavaScriptBlock Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptBlock Class

For a list of all members of this type, see PDFJavaScriptBlock members.

Public Methods

 | Name | Description
Public Method | CompareTo | Compares 2 streams by their name
Top

See Also

Reference

PDFJavaScriptBlock Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

CompareTo Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class : CompareTo Method

obj
Compares 2 streams by their name

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptBlock
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
C#
public int CompareTo(
   object obj
)
Delphi
public function CompareTo(
    obj: TObject
): Integer;
Managed Extensions for C++
public: int CompareTo(
   Object* obj
)
C++/CLI
public:
int CompareTo(
   Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members


%%PageItemTitle%% $$Properties$$

PDFJavaScriptBlock Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptBlock Class

For a list of all members of this type, see PDFJavaScriptBlock members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of this JavaScript block.
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top

See Also

Reference

PDFJavaScriptBlock Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class : Name Property

Gets or sets the name of this JavaScript block.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptBlock
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of this JavaScript block.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members


%%PageItemTitle%%

Script Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptBlock Class : Script Property

Gets or sets the javascript code to be included in the block.

Syntax

Visual Basic (Declaration)
Public Property Script As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptBlock
Dim value As String

instance.Script = value

value = instance.Script
C#
public string Script {get; set;}
Delphi
public read-write property Script: String;
Managed Extensions for C++
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
C++/CLI
public:
property String^ Script {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing valid javascript code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptBlock Class
PDFJavaScriptBlock Members


%%PageItemTitle%%

PDFJavaScriptCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

Defines a collection of JavaScript blocks.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFJavaScriptCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFJavaScriptCollection : PDFObject
Delphi
public class PDFJavaScriptCollection = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFJavaScriptCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFJavaScriptCollection sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFJavaScriptCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

The following tables list the members exposed by PDFJavaScriptCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the Javascript code associated with the given name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | Clears all JavaScript actions from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Overloaded. Removes a JavaScript action from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFJavaScriptCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | Clears all JavaScript actions from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Overloaded. Removes a JavaScript action from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Add Method

Adds a new JavaScript action to the collection.

Overload List

Overload | Description
Add(String) | Adds a new JavaScript action to the collection.
Add(PDFJavaScriptBlock) | Adds a new JavaScript action to the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Add(String) Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Add Method : Add(String) Method

javaScript
The JavaScript code.
Adds a new JavaScript action to the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal javaScript As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim javaScript As String

instance.Add(javaScript)
C#
public void Add(
   string javaScript
)
Delphi
public procedure Add(
    javaScript: String
);
Managed Extensions for C++
public: void Add(
   string* javaScript
)
C++/CLI
public:
void Add(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code.

Remarks

This method adds an unnamed PDFJavaScriptBlock to the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

Add(PDFJavaScriptBlock) Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Add Method : Add(PDFJavaScriptBlock) Method

javaScript
The JavaScript code.
Adds a new JavaScript action to the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal javaScript As PDFJavaScriptBlock _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim javaScript As PDFJavaScriptBlock

instance.Add(javaScript)
C#
public void Add(
   PDFJavaScriptBlock javaScript
)
Delphi
public procedure Add(
    javaScript: PDFJavaScriptBlock
);
Managed Extensions for C++
public: void Add(
   PDFJavaScriptBlock* javaScript
)
C++/CLI
public:
void Add(
   PDFJavaScriptBlock^ javaScript
)

Parameters

javaScript
The JavaScript code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Clear Method

Clears all JavaScript actions from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Remove Method

Removes a JavaScript action from the collection.

Overload List

Overload | Description
Remove(String) | Removes a JavaScript action from the collection.
Remove(PDFJavaScriptBlock) | Removes a JavaScript block from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Remove(String) Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Remove Method : Remove(String) Method

name
The name of the action to remove.
Removes a JavaScript action from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim name As String

instance.Remove(name)
C#
public void Remove(
   string name
)
Delphi
public procedure Remove(
    name: String
);
Managed Extensions for C++
public: void Remove(
   string* name
)
C++/CLI
public:
void Remove(
   String^ name
)

Parameters

name
The name of the action to remove.

Remarks

This method remove the first occurence of the Javascript action with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

Remove(PDFJavaScriptBlock) Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Remove Method : Remove(PDFJavaScriptBlock) Method

javaScript
The JavaScript block to remove.
Removes a JavaScript block from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal javaScript As PDFJavaScriptBlock _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim javaScript As PDFJavaScriptBlock

instance.Remove(javaScript)
C#
public void Remove(
   PDFJavaScriptBlock javaScript
)
Delphi
public procedure Remove(
    javaScript: PDFJavaScriptBlock
);
Managed Extensions for C++
public: void Remove(
   PDFJavaScriptBlock* javaScript
)
C++/CLI
public:
void Remove(
   PDFJavaScriptBlock^ javaScript
)

Parameters

javaScript
The JavaScript block to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%% $$Properties$$

PDFJavaScriptCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the Javascript code associated with the given name.
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Item Property

Gets the Javascript code associated with the given name.

Overload List

Overload | Description
Item(String) | Gets the Javascript code associated with the given name.
Item(Int32) | Gets the Javascript block at the given index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Item Property : Item(String) Property

name
Gets the Javascript code associated with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim name As String
Dim value As String

value = instance.Item(name)
C#
public string Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): String;
Managed Extensions for C++
public: __property string* get_Item(
   string* name
);
C++/CLI
public:
property String^ Item {
   String^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Item Property : Item(Int32) Property

index
Gets the Javascript block at the given index.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As PDFJavaScriptBlock
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim index As Integer
Dim value As PDFJavaScriptBlock

value = instance.Item(index)
C#
public PDFJavaScriptBlock Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): PDFJavaScriptBlock;
Managed Extensions for C++
public: __property PDFJavaScriptBlock* get_Item(
   int index
);
C++/CLI
public:
property PDFJavaScriptBlock^ Item {
   PDFJavaScriptBlock^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
Argu |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

PDFLogicalUnitBase Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFLogicalUnitBase Class

Base class for all the classes that implement custom logical units.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
C#
public abstract class PDFLogicalUnitBase
Delphi
public class PDFLogicalUnitBase abstract;
Managed Extensions for C++
public __gc abstract class PDFLogicalUnitBase
C++/CLI
public ref class PDFLogicalUnitBase abstract

Remarks

This class is the base class for implementing user defined logical units. All classes that represent a custom defined logical unit must implement two methods: ToPDFUnitX( float unit ) and ToPDFUnitY( float unit ). These 2 methods need to define the mapping between the logical unit and measure unit used by pdf files, which is the point (1/72 inches). These 2 methods allow to define custom mappings between logical unit and pdf unit (point) for each axis. The mapping between the logical unit and the pdf unit shows how many pdf units correspond to a logical unit.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFPointLogicalUnit
O2S.Components.PDF4NET.PDFMMLogicalUnit
O2S.Components.PDF4NET.PDFInchLogicalUnit
O2S.Components.PDF4NET.PDFCMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFLogicalUnitBase Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFLogicalUnitBase Class

The following tables list the members exposed by PDFLogicalUnitBase.

Public Constructors

 | Name | Description
Public Constructor | PDFLogicalUnitBase Constructor | Initializes a new PDFLogicalUnitBase object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFLogicalUnitBase Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFLogicalUnitBase Class : PDFLogicalUnitBase Constructor

Initializes a new PDFLogicalUnitBase object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase()
C#
public PDFLogicalUnitBase()
Delphi
public PDFLogicalUnitBase();
Managed Extensions for C++
public: PDFLogicalUnitBase();
C++/CLI
public:
PDFLogicalUnitBase();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


%%PageItemTitle%% $$Methods$$

PDFLogicalUnitBase Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFLogicalUnitBase Class

For a list of all members of this type, see PDFLogicalUnitBase members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET Namespace > PDFLogicalUnitBase Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Public Overridable Function ToPDFUnitX( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitX(unit)
C#
public virtual float ToPDFUnitX(
   float unit
)
Delphi
public function ToPDFUnitX(
    unit: Single
): Single; virtual;
Managed Extensions for C++
public: virtual float ToPDFUnitX(
   float unit
)
C++/CLI
public:
virtual float ToPDFUnitX(
   float unit
)

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


%%PageItemTitle%%

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET Namespace > PDFLogicalUnitBase Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Public Overridable Function ToPDFUnitY( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitY(unit)
C#
public virtual float ToPDFUnitY(
   float unit
)
Delphi
public function ToPDFUnitY(
    unit: Single
): Single; virtual;
Managed Extensions for C++
public: virtual float ToPDFUnitY(
   float unit
)
C++/CLI
public:
virtual float ToPDFUnitY(
   float unit
)

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


%%PageItemTitle%%

PDFMetadataSchema Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

Defines a schema within the document's metadata

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFMetadataSchema
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFMetadataSchema : PDFObject
Delphi
public class PDFMetadataSchema = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFMetadataSchema : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFMetadataSchema sealed : public PDFObject

Remarks

A document's metadata consists of several schemas. A schema groups several properties. Each schema has a name and a namespace prefix.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFMetadataSchema

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMetadataSchema Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

The following tables list the members exposed by PDFMetadataSchema.

Public Constructors

 | Name | Description
Public Constructor | PDFMetadataSchema Constructor | Initializes a new PDFMetadataSchema object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value of a property. Supported by Compact .NET Edition.
Public Property | Name | Gets or sets schema's name. Supported by Compact .NET Edition.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix. Supported by Compact .NET Edition.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top

See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFMetadataSchema Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : PDFMetadataSchema Constructor

Initializes a new PDFMetadataSchema object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema()
C#
public PDFMetadataSchema()
Delphi
public PDFMetadataSchema();
Managed Extensions for C++
public: PDFMetadataSchema();
C++/CLI
public:
PDFMetadataSchema();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%% $$Properties$$

PDFMetadataSchema Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

For a list of all members of this type, see PDFMetadataSchema members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value of a property. Supported by Compact .NET Edition.
Public Property | Name | Gets or sets schema's name. Supported by Compact .NET Edition.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix. Supported by Compact .NET Edition.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top

See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Item Property
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Item Property

propertyName
Gets or sets the value of a property.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal propertyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim propertyName As String
Dim value As String

instance.Item(propertyName) = value

value = instance.Item(propertyName)
C#
public string this[
   string propertyName
]; {get; set;}
Delphi
public  this: : String;[
    propertyName: String
]; read-write
Managed Extensions for C++
public: __property string* get_Item(
   string* propertyName
);
public: __property void set_Item(
   string* propertyName,
   string* value
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^ propertyName);
   void set (String^ propertyName, String^ value);
}

Parameters

propertyName

Return Value

A string value representing the value of the property. The name of the property is used to set or get its value.

Example

The following example set the "Company" property to the value "O2 Solutions" (in the sample below, schema is considered to be an instance of PDFMetadataSchema class):
C# Copy Code
...
schema["Company"] = "O2 Solutions";
...

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Name Property

Gets or sets schema's name.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A unique string value representing the name of the schema. Usually, this name looks like an URL, but it is a simple identifier. It serves to uniquely identify the schema.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

NamespacePrefix Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : NamespacePrefix Property

Gets or sets schema's namespace prefix.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property NamespacePrefix As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As String

instance.NamespacePrefix = value

value = instance.NamespacePrefix
C#
public string NamespacePrefix {get; set;}
Delphi
public read-write property NamespacePrefix: String;
Managed Extensions for C++
public: __property string* get_NamespacePrefix();
public: __property void set_NamespacePrefix(
   string* value
);
C++/CLI
public:
property String^ NamespacePrefix {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the namespace prefix for this PDFMetadataSchema object. It is a short abbreviation for the full schema name. It follows the rules of XML namespaces. This namespace prefix has the local scope of the xmlns attribute that declares it (in the XML representation of the schema).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

Properties Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Properties Property

Gets the hashtable storing the properties in this schema.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As Hashtable

value = instance.Properties
C#
public Hashtable Properties {get;}
Delphi
public read-only property Properties: Hashtable;
Managed Extensions for C++
public: __property Hashtable* get_Properties();
C++/CLI
public:
property Hashtable^ Properties {
   Hashtable^ get();
}

Return Value

A Hashtable object storing the schema's properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

StoreSchemaInDocInfo Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : StoreSchemaInDocInfo Property

Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.

Syntax

Visual Basic (Declaration)
Public Property StoreSchemaInDocInfo As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As Boolean

instance.StoreSchemaInDocInfo = value

value = instance.StoreSchemaInDocInfo
C#
public bool StoreSchemaInDocInfo {get; set;}
Delphi
public read-write property StoreSchemaInDocInfo: Boolean;
Managed Extensions for C++
public: __property bool get_StoreSchemaInDocInfo();
public: __property void set_StoreSchemaInDocInfo(
   bool value
);
C++/CLI
public:
property bool StoreSchemaInDocInfo {
   bool get();
   void set (bool value);
}

Return Value

If true, the properties in this schema are stored also in Document Information dictionary. Default: false

Remarks

When schema's properties are stored in the Document Information dictionary, the property name is the key and its value is stored as a string value in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

PDFMetadataSchemas Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemas Class

Defines a collection of metadata schemas.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFMetadataSchemas
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFMetadataSchemas : PDFObject
Delphi
public class PDFMetadataSchemas = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFMetadataSchemas : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFMetadataSchemas sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFMetadataSchemas

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMetadataSchemas Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemas Class

The following tables list the members exposed by PDFMetadataSchemas.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of schemas in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the schema at the specified index (zero based index)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified schema at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Overloaded. Inserts a schema in the collection at the specified index.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the first occurence of the given schema from collection.
Public Method | RemoveAt | Removes the schema at the specified index of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFMetadataSchemas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFMetadataSchemas Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemas Class

For a list of all members of this type, see PDFMetadataSchemas members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified schema at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Overloaded. Inserts a schema in the collection at the specified index.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the first occurence of the given schema from collection.
Public Method | RemoveAt | Removes the schema at the specified index of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFMetadataSchemas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Add Method

Adds the specified schema at the end of the collection.

Overload List

Overload | Description
Add(PDFMetadataSchema) | Adds the specified schema at the end of the collection.
Add() | Creates a new schema and adds it at the end of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Add(PDFMetadataSchema) Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class > Add Method : Add(PDFMetadataSchema) Method

schema
a PDFMetadataSchema object representing the schema to be added.
Adds the specified schema at the end of the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal schema As PDFMetadataSchema _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim schema As PDFMetadataSchema

instance.Add(schema)
C#
public void Add(
   PDFMetadataSchema schema
)
Delphi
public procedure Add(
    schema: PDFMetadataSchema
);
Managed Extensions for C++
public: void Add(
   PDFMetadataSchema* schema
)
C++/CLI
public:
void Add(
   PDFMetadataSchema^ schema
)

Parameters

schema
a PDFMetadataSchema object representing the schema to be added.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members
Overload List


%%PageItemTitle%%

Add() Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class > Add Method : Add() Method

Creates a new schema and adds it at the end of the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add() As PDFMetadataSchema
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim value As PDFMetadataSchema

value = instance.Add()
C#
public PDFMetadataSchema Add()
Delphi
public function Add(): PDFMetadataSchema;
Managed Extensions for C++
public: PDFMetadataSchema* Add();
C++/CLI
public:
PDFMetadataSchema^ Add();

Return Value

a PDFMetadataSchema object representing the new schema.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members
Overload List


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Insert Method

Inserts a schema in the collection at the specified index.

Overload List

Overload | Description
Insert(Int32,PDFMetadataSchema) | Inserts a schema in the collection at the specified index.
Insert(Int32) | Creates a new schema and inserts it at the specified index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Insert(Int32,PDFMetadataSchema) Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class > Insert Method : Insert(Int32,PDFMetadataSchema) Method

index
The zero-based index at which schema should be inserted.
schema
a PDFMetadataSchema object to be inserted.
Inserts a schema in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Insert( _
   ByVal index As Integer, _
   ByVal schema As PDFMetadataSchema _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim index As Integer
Dim schema As PDFMetadataSchema

instance.Insert(index, schema)
C#
public void Insert(
   int index,
   PDFMetadataSchema schema
)
Delphi
public procedure Insert(
    index: Integer;
    schema: PDFMetadataSchema
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFMetadataSchema* schema
)
C++/CLI
public:
void Insert(
   int index,
   PDFMetadataSchema^ schema
)

Parameters

index
The zero-based index at which schema should be inserted.
schema
a PDFMetadataSchema object to be inserted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members
Overload List


%%PageItemTitle%%

Insert(Int32) Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class > Insert Method : Insert(Int32) Method

index
The zero-based index at which the new schema should be inserted.
Creates a new schema and inserts it at the specified index.

Syntax

Visual Basic (Declaration)
Overloads Public Function Insert( _
   ByVal index As Integer _
) As PDFMetadataSchema
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim index As Integer
Dim value As PDFMetadataSchema

value = instance.Insert(index)
C#
public PDFMetadataSchema Insert(
   int index
)
Delphi
public function Insert(
    index: Integer
): PDFMetadataSchema;
Managed Extensions for C++
public: PDFMetadataSchema* Insert(
   int index
)
C++/CLI
public:
PDFMetadataSchema^ Insert(
   int index
)

Parameters

index
The zero-based index at which the new schema should be inserted.

Return Value

a PDFMetadataSchema object representing the new schema.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members
Overload List


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Remove Method

schema
The PDFMetadataSchema object to be removed from collection.
Removes the first occurence of the given schema from collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal schema As PDFMetadataSchema _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim schema As PDFMetadataSchema

instance.Remove(schema)
C#
public void Remove(
   PDFMetadataSchema schema
)
Delphi
public procedure Remove(
    schema: PDFMetadataSchema
);
Managed Extensions for C++
public: void Remove(
   PDFMetadataSchema* schema
)
C++/CLI
public:
void Remove(
   PDFMetadataSchema^ schema
)

Parameters

schema
The PDFMetadataSchema object to be removed from collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : RemoveAt Method

index
The zero-based index of the schema to remove.
Removes the schema at the specified index of the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the schema to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%% $$Properties$$

PDFMetadataSchemas Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemas Class

For a list of all members of this type, see PDFMetadataSchemas members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of schemas in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the schema at the specified index (zero based index)
Top

See Also

Reference

PDFMetadataSchemas Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Count Property

Returns the number of schemas in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchemas Class : Item Property

index
Get the schema at the specified index (zero based index)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDFMetadataSchema
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemas
Dim index As Integer
Dim value As PDFMetadataSchema

instance.Item(index) = value

value = instance.Item(index)
C#
public PDFMetadataSchema this[
   int index
]; {get; set;}
Delphi
public  this: : PDFMetadataSchema;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDFMetadataSchema* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDFMetadataSchema* value
);
C++/CLI
public:
property PDFMetadataSchema^ default [int] {
   PDFMetadataSchema^ get(int index);
   void set (int index, PDFMetadataSchema^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemas Class
PDFMetadataSchemas Members


%%PageItemTitle%%

PDFMMLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFMMLogicalUnit Class

Defines the millimeter as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFMMLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
C#
public class PDFMMLogicalUnit : PDFLogicalUnitBase
Delphi
public class PDFMMLogicalUnit = class(PDFLogicalUnitBase)
Managed Extensions for C++
public __gc class PDFMMLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFMMLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the millimeter as a logical unit. The mapping between logical unit and pdf unit is 2.834646-to-1, one logical unit equals to 2.834646 pdf units. The mapping functions return the value given as parameter multiplied by 2.834646.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFMMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMMLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMMLogicalUnit Class

The following tables list the members exposed by PDFMMLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFMMLogicalUnit Constructor | Initializes a new PDFMMLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFMMLogicalUnit Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFMMLogicalUnit Class : PDFMMLogicalUnit Constructor

Initializes a new PDFMMLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit()
C#
public PDFMMLogicalUnit()
Delphi
public PDFMMLogicalUnit();
Managed Extensions for C++
public: PDFMMLogicalUnit();
C++/CLI
public:
PDFMMLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFMMLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMMLogicalUnit Class

For a list of all members of this type, see PDFMMLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET Namespace > PDFMMLogicalUnit Class : ToPDFUnitX Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitX(unit)
C#
public override float ToPDFUnitX(
   float unit
)
Delphi
public function ToPDFUnitX(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitX(
   float unit
) override
C++/CLI
public:
float ToPDFUnitX(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


%%PageItemTitle%%

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET Namespace > PDFMMLogicalUnit Class : ToPDFUnitY Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitY(unit)
C#
public override float ToPDFUnitY(
   float unit
)
Delphi
public function ToPDFUnitY(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitY(
   float unit
) override
C++/CLI
public:
float ToPDFUnitY(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


%%PageItemTitle%%

PDFObject Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFObject Class

Base class for all objects within PDF hierarchy.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFObject
   Inherits PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFObject
C#
public abstract class PDFObject : PDFBaseObject
Delphi
public class PDFObject = class(PDFBaseObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFObject : public PDFBaseObject
C++/CLI
public ref class PDFObject abstract : public PDFBaseObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Security.PDFSecurityManager
O2S.Components.PDF4NET.Security.PDFDigitalSignature
O2S.Components.PDF4NET.PDFPageTransition
O2S.Components.PDF4NET.PDFPages
O2S.Components.PDF4NET.PDFPageBackground
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFOutlines
O2S.Components.PDF4NET.PDFOutline
O2S.Components.PDF4NET.PDFMetadataSchemas
O2S.Components.PDF4NET.PDFMetadataSchema
O2S.Components.PDF4NET.PDFJavaScriptCollection
O2S.Components.PDF4NET.PDFJavaScriptBlock
O2S.Components.PDF4NET.PDFDocumentInformation
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
O2S.Components.PDF4NET.PDFDocumentAttachment
O2S.Components.PDF4NET.PDFDocument
O2S.Components.PDF4NET.PDFBasicCanvas
O2S.Components.PDF4NET.PageNumberingRangeCollection
O2S.Components.PDF4NET.PageNumberingRange
O2S.Components.PDF4NET.PageNumber
O2S.Components.PDF4NET.Graphics.PDFLayers
O2S.Components.PDF4NET.Graphics.PDFLayer
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Functions.PDFFunctions
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection
O2S.Components.PDF4NET.Forms.PDFWidgetActions
O2S.Components.PDF4NET.Forms.PDFRadioButtonItemCollection
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.PDFForm
O2S.Components.PDF4NET.Forms.PDFFields
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFFieldActions
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Annotations.PDFAnnotations
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Actions.PDFAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFObject Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFObject Class Members
[image]
O2S.Components.PDF4NET Namespace : PDFObject Class

The following tables list the members exposed by PDFObject.

Public Constructors

 | Name | Description
Public Constructor | PDFObject Constructor | Initializes a new PDFObject object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFObject Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFObject Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFObject Class : PDFObject Constructor

Initializes a new PDFObject object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFObject()
C#
public PDFObject()
Delphi
public PDFObject();
Managed Extensions for C++
public: PDFObject();
C++/CLI
public:
PDFObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFObject Class
PDFObject Members


%%PageItemTitle%%

PDFOutline Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFOutline Class

Defines an outline in the outlines tree hierarchy

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFOutline
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
C#
public sealed class PDFOutline : PDFObject
Delphi
public class PDFOutline = class(PDFObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFOutline : public PDFObject
C++/CLI
public ref class PDFOutline sealed : public PDFObject

Remarks

An outline is also called a bookmark. The PDF specification calls them outlines, but the Adobe Acrobat uses the term Bookmarks in the user interface. An outline represents a node in the outlines tree displayed in the viewer.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFOutline

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFOutline Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFOutline Class

The following tables list the members exposed by PDFOutline.

Public Constructors

 | Name | Description
Public Constructor | PDFOutline Constructor | Overloaded. Initializes a new PDFOutline object.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when this bookmark is selected.
Public Property | Color | Gets or sets the color of the outline. Supported by Compact .NET Edition.
Public Property | DestinationPage | Gets or sets the destination page of the outline. Supported by Compact .NET Edition.
Public Property | Display | Gets or sets the font style. Supported by Compact .NET Edition.
Public Property | Expanded | Gets or sets the initial display of the outline. Supported by Compact .NET Edition.
Public Property | Outlines | Gets the children outlines. Supported by Compact .NET Edition.
Public Property | Parent | Gets the parent outline of this PDFOutline object. Supported by Compact .NET Edition.
Public Property | Title | Gets or sets the title of the outline. Supported by Compact .NET Edition.
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFOutline Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutline Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : PDFOutline Constructor

Initializes a new PDFOutline object.

Overload List

Overload | Description
PDFOutline Constructor() | Initializes a new PDFOutline object.
PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFAction) | Initializes a new PDFOutline object specifying a title and an action.
PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single) | Initializes a new PDFOutline object specifying a title and a destination. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

PDFOutline Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class > PDFOutline Constructor : PDFOutline Constructor()

Initializes a new PDFOutline object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline()
C#
public PDFOutline()
Delphi
public PDFOutline();
Managed Extensions for C++
public: PDFOutline();
C++/CLI
public:
PDFOutline();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members
Overload List


%%PageItemTitle%%

PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFAction)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class > PDFOutline Constructor : PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFAction)

title
the title of the outline that will be displayed in outlines tree in the viewer.
outlineColor
the color used to draw the outline title in the tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
action
a PDFAction object specifying an action to be executed when this outline is selected.
Initializes a new PDFOutline object specifying a title and an action.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal title As String, _
   ByVal outlineColor As PDFColor, _
   ByVal expanded As Boolean, _
   ByVal display As OutlineDisplay, _
   ByVal action As PDFAction _
)
Visual Basic (Usage) Copy Code
Dim title As String
Dim outlineColor As PDFColor
Dim expanded As Boolean
Dim display As OutlineDisplay
Dim action As PDFAction

Dim instance As PDFOutline(title, outlineColor, expanded, display, action)
C#
public PDFOutline(
   string title,
   PDFColor outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction action
)
Delphi
public PDFOutline(
    title: String;
    outlineColor: PDFColor;
    expanded: Boolean;
    display: OutlineDisplay;
    action: PDFAction
);
Managed Extensions for C++
public: PDFOutline(
   string* title,
   PDFColor* outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction* action
)
C++/CLI
public:
PDFOutline(
   String^ title,
   PDFColor^ outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction^ action
)

Parameters

title
the title of the outline that will be displayed in outlines tree in the viewer.
outlineColor
the color used to draw the outline title in the tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
action
a PDFAction object specifying an action to be executed when this outline is selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members
Overload List


%%PageItemTitle%%

PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class > PDFOutline Constructor : PDFOutline Constructor(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single)

title
the title of the outline that will be displayed in outlines tree in the viewer.
outlineColor
the color used to draw the outline title in the tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
destinationPage
a PDFPage object representing the destination of the outline.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the outline.
Initializes a new PDFOutline object specifying a title and a destination.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal title As String, _
   ByVal outlineColor As PDFColor, _
   ByVal expanded As Boolean, _
   ByVal display As OutlineDisplay, _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single _
)
Visual Basic (Usage) Copy Code
Dim title As String
Dim outlineColor As PDFColor
Dim expanded As Boolean
Dim display As OutlineDisplay
Dim destinationPage As PDFPage
Dim topDestination As Single

Dim instance As PDFOutline(title, outlineColor, expanded, display, destinationPage, topDestination)
C#
public PDFOutline(
   string title,
   PDFColor outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage destinationPage,
   float topDestination
)
Delphi
public PDFOutline(
    title: String;
    outlineColor: PDFColor;
    expanded: Boolean;
    display: OutlineDisplay;
    destinationPage: PDFPage;
    topDestination: Single
);
Managed Extensions for C++
public: PDFOutline(
   string* title,
   PDFColor* outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage* destinationPage,
   float topDestination
)
C++/CLI
public:
PDFOutline(
   String^ title,
   PDFColor^ outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage^ destinationPage,
   float topDestination
)

Parameters

title
the title of the outline that will be displayed in outlines tree in the viewer.
outlineColor
the color used to draw the outline title in the tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
destinationPage
a PDFPage object representing the destination of the outline.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the outline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFOutline Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFOutline Class

For a list of all members of this type, see PDFOutline members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when this bookmark is selected.
Public Property | Color | Gets or sets the color of the outline. Supported by Compact .NET Edition.
Public Property | DestinationPage | Gets or sets the destination page of the outline. Supported by Compact .NET Edition.
Public Property | Display | Gets or sets the font style. Supported by Compact .NET Edition.
Public Property | Expanded | Gets or sets the initial display of the outline. Supported by Compact .NET Edition.
Public Property | Outlines | Gets the children outlines. Supported by Compact .NET Edition.
Public Property | Parent | Gets the parent outline of this PDFOutline object. Supported by Compact .NET Edition.
Public Property | Title | Gets or sets the title of the outline. Supported by Compact .NET Edition.
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFOutline Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Action Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Action Property

Gets or sets the action to be executed when this bookmark is selected.

Syntax

Visual Basic (Declaration)
Public Property Action As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As PDFAction

instance.Action = value

value = instance.Action
C#
public PDFAction Action {get; set;}
Delphi
public read-write property Action: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant object specifying the action to be executed when this bookmark is selected.

Remarks

If this bookmark has set both DestinationPage and Action properties, then the DestinationPage property will be considered when building the bookmark's destination.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Color Property

Gets or sets the color of the outline.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public PDFColor Color {get; set;}
Delphi
public read-write property Color: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color used to display the outline title in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

DestinationPage Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : DestinationPage Property

Gets or sets the destination page of the outline.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DestinationPage As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As PDFPage

instance.DestinationPage = value

value = instance.DestinationPage
C#
public PDFPage DestinationPage {get; set;}
Delphi
public read-write property DestinationPage: PDFPage;
Managed Extensions for C++
public: __property PDFPage* get_DestinationPage();
public: __property void set_DestinationPage(
   PDFPage* value
);
C++/CLI
public:
property PDFPage^ DestinationPage {
   PDFPage^ get();
   void set (PDFPage^ value);
}

Return Value

a PDFPage object representing the destination of the outline. It must be a page within the same document.

Remarks

If this bookmark has set both DestinationPage and Action properties, then the DestinationPage property will be considered when building the bookmark's destination.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Display Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Display Property

Gets or sets the font style.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Display As OutlineDisplay
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As OutlineDisplay

instance.Display = value

value = instance.Display
C#
public OutlineDisplay Display {get; set;}
Delphi
public read-write property Display: OutlineDisplay;
Managed Extensions for C++
public: __property OutlineDisplay get_Display();
public: __property void set_Display(
   OutlineDisplay value
);
C++/CLI
public:
property OutlineDisplay Display {
   OutlineDisplay get();
   void set (OutlineDisplay value);
}

Return Value

A combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title in the outlines tree.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Expanded Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Expanded Property

Gets or sets the initial display of the outline.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Expanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
C#
public bool Expanded {get; set;}
Delphi
public read-write property Expanded: Boolean;
Managed Extensions for C++
public: __property bool get_Expanded();
public: __property void set_Expanded(
   bool value
);
C++/CLI
public:
property bool Expanded {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying whether the outline should be displayed expanded or collapsed when the document is initially open in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Outlines Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Outlines Property

Gets the children outlines.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outlines As PDFOutlines
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As PDFOutlines

value = instance.Outlines
C#
public PDFOutlines Outlines {get;}
Delphi
public read-only property Outlines: PDFOutlines;
Managed Extensions for C++
public: __property PDFOutlines* get_Outlines();
C++/CLI
public:
property PDFOutlines^ Outlines {
   PDFOutlines^ get();
}

Return Value

A PDFOutlines object representing the collection of the direct descendent outlines.

Remarks

Each outline holds an outlines collection, that represent the direct children of the outline object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Parent Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Parent Property

Gets the parent outline of this PDFOutline object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Parent As PDFOutline
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As PDFOutline

instance.Parent = value

value = instance.Parent
C#
public PDFOutline Parent {get; set;}
Delphi
public read-write property Parent: PDFOutline;
Managed Extensions for C++
public: __property PDFOutline* get_Parent();
public: __property void set_Parent(
   PDFOutline* value
);
C++/CLI
public:
property PDFOutline^ Parent {
   PDFOutline^ get();
   void set (PDFOutline^ value);
}

Return Value

A PDFOutline object specifying the parent of this outline object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

Title Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : Title Property

Gets or sets the title of the outline.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Delphi
public read-write property Title: String;
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the title of the outline. This title is displayed in the viewer in the outlines tree.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

TopDestination Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutline Class : TopDestination Property

Gets or sets the vertical position of the destination page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TopDestination As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFOutline
Dim value As Single

instance.TopDestination = value

value = instance.TopDestination
C#
public float TopDestination {get; set;}
Delphi
public read-write property TopDestination: Single;
Managed Extensions for C++
public: __property float get_TopDestination();
public: __property void set_TopDestination(
   float value
);
C++/CLI
public:
property float TopDestination {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the destination page when it is displayed in the viewer as the result of using the outline.

Remarks

When the destination page is displayed as the result of using the outline, the y coordinate of the page is positioned at the top of the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutline Class
PDFOutline Members


%%PageItemTitle%%

PDFOutlines Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFOutlines Class

Defines a list of children outlines belonging to a parent outline.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFOutlines
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFOutlines : PDFObject
Delphi
public class PDFOutlines = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFOutlines : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFOutlines sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFOutlines

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFOutlines Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFOutlines Class

The following tables list the members exposed by PDFOutlines.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of outlines in the collection Supported by Compact .NET Edition.
Public Property | Current | Gets the current element in the collection. Supported by Compact .NET Edition.
Public Property | Item | Get the outline at the specified index. Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new outline at the end of the collection. Supported by Compact .NET Edition.
Public Method | Clear | Removes all outlines from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection. Supported by Compact .NET Edition.
Public Method | IndexOf | Gets the index of the outline in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection. Supported by Compact .NET Edition.
Public Method | Remove | Removes the outline from the collection.
Public Method | RemoveAt | Removes the outline at the index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFOutlines Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFOutlines Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFOutlines Class

For a list of all members of this type, see PDFOutlines members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new outline at the end of the collection. Supported by Compact .NET Edition.
Public Method | Clear | Removes all outlines from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection. Supported by Compact .NET Edition.
Public Method | IndexOf | Gets the index of the outline in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection. Supported by Compact .NET Edition.
Public Method | Remove | Removes the outline from the collection.
Public Method | RemoveAt | Removes the outline at the index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFOutlines Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Add Method

Adds a new outline at the end of the collection.

Supported by Compact .NET Edition.

Overload List

Overload | Description
Add(PDFOutline) | Adds a new outline at the end of the collection. Supported by Compact .NET Edition.
Add(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single) | Creates a new outline and adds it at the end of the collection. Supported by Compact .NET Edition.
Add(String,PDFColor,Boolean,OutlineDisplay,PDFAction) | Creates a new outline and adds it at the end of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

Add(PDFOutline) Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class > Add Method : Add(PDFOutline) Method

outline
a PDFOutline object to be added to the collection.
Adds a new outline at the end of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal outline As PDFOutline _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim outline As PDFOutline

instance.Add(outline)
C#
public void Add(
   PDFOutline outline
)
Delphi
public procedure Add(
    outline: PDFOutline
);
Managed Extensions for C++
public: void Add(
   PDFOutline* outline
)
C++/CLI
public:
void Add(
   PDFOutline^ outline
)

Parameters

outline
a PDFOutline object to be added to the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members
Overload List


%%PageItemTitle%%

Add(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class > Add Method : Add(String,PDFColor,Boolean,OutlineDisplay,PDFPage,Single) Method

title
the title of the outline
outlineColor
a PDFColor object specifying the color used to draw the outline in the outline tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
destinationPage
a PDFPage object representing the destination of the outline.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the outline.
Creates a new outline and adds it at the end of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal title As String, _
   ByVal outlineColor As PDFColor, _
   ByVal expanded As Boolean, _
   ByVal display As OutlineDisplay, _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single _
) As PDFOutline
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim title As String
Dim outlineColor As PDFColor
Dim expanded As Boolean
Dim display As OutlineDisplay
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim value As PDFOutline

value = instance.Add(title, outlineColor, expanded, display, destinationPage, topDestination)
C#
public PDFOutline Add(
   string title,
   PDFColor outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage destinationPage,
   float topDestination
)
Delphi
public function Add(
    title: String;
    outlineColor: PDFColor;
    expanded: Boolean;
    display: OutlineDisplay;
    destinationPage: PDFPage;
    topDestination: Single
): PDFOutline;
Managed Extensions for C++
public: PDFOutline* Add(
   string* title,
   PDFColor* outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage* destinationPage,
   float topDestination
)
C++/CLI
public:
PDFOutline^ Add(
   String^ title,
   PDFColor^ outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFPage^ destinationPage,
   float topDestination
)

Parameters

title
the title of the outline
outlineColor
a PDFColor object specifying the color used to draw the outline in the outline tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
destinationPage
a PDFPage object representing the destination of the outline.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the outline.

Return Value

a PDFOutline object representing the newly created outline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members
Overload List


%%PageItemTitle%%

Add(String,PDFColor,Boolean,OutlineDisplay,PDFAction) Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class > Add Method : Add(String,PDFColor,Boolean,OutlineDisplay,PDFAction) Method

title
the title of the outline
outlineColor
a PDFColor object specifying the color used to draw the outline in the outline tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
action
a PDFAction object specifying the action to be executed when this outline is selected.
Creates a new outline and adds it at the end of the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal title As String, _
   ByVal outlineColor As PDFColor, _
   ByVal expanded As Boolean, _
   ByVal display As OutlineDisplay, _
   ByVal action As PDFAction _
) As PDFOutline
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim title As String
Dim outlineColor As PDFColor
Dim expanded As Boolean
Dim display As OutlineDisplay
Dim action As PDFAction
Dim value As PDFOutline

value = instance.Add(title, outlineColor, expanded, display, action)
C#
public PDFOutline Add(
   string title,
   PDFColor outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction action
)
Delphi
public function Add(
    title: String;
    outlineColor: PDFColor;
    expanded: Boolean;
    display: OutlineDisplay;
    action: PDFAction
): PDFOutline;
Managed Extensions for C++
public: PDFOutline* Add(
   string* title,
   PDFColor* outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction* action
)
C++/CLI
public:
PDFOutline^ Add(
   String^ title,
   PDFColor^ outlineColor,
   bool expanded,
   OutlineDisplay display,
   PDFAction^ action
)

Parameters

title
the title of the outline
outlineColor
a PDFColor object specifying the color used to draw the outline in the outline tree.
expanded
specifies whether the outline should be displayed expanded or collapsed the tree when the document is open.
display
a combination of OutlineDisplay enumeration members, specifying the font style used to draw the outline title.
action
a PDFAction object specifying the action to be executed when this outline is selected.

Return Value

a PDFOutline object representing the newly created outline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Clear Method

Removes all outlines from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : IndexOf Method

outline
The outline that is looked for.
Gets the index of the outline in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal outline As PDFOutline _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim outline As PDFOutline
Dim value As Integer

value = instance.IndexOf(outline)
C#
public int IndexOf(
   PDFOutline outline
)
Delphi
public function IndexOf(
    outline: PDFOutline
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDFOutline* outline
)
C++/CLI
public:
int IndexOf(
   PDFOutline^ outline
)

Parameters

outline
The outline that is looked for.

Return Value

The index of the outline in the collection, or -1 if the outline does not exist in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Remove Method

outline
The outline to remove.
Removes the outline from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal outline As PDFOutline _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim outline As PDFOutline

instance.Remove(outline)
C#
public void Remove(
   PDFOutline outline
)
Delphi
public procedure Remove(
    outline: PDFOutline
);
Managed Extensions for C++
public: void Remove(
   PDFOutline* outline
)
C++/CLI
public:
void Remove(
   PDFOutline^ outline
)

Parameters

outline
The outline to remove.

Remarks

This method removes the outline from the collection along with all its children.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : RemoveAt Method

index
Removes the outline at the index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when the index is less than zero or greater than or equal to Count.

Remarks

This method removes the outline from the collection along with all its children.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%% $$Properties$$

PDFOutlines Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFOutlines Class

For a list of all members of this type, see PDFOutlines members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of outlines in the collection Supported by Compact .NET Edition.
Public Property | Current | Gets the current element in the collection. Supported by Compact .NET Edition.
Public Property | Item | Get the outline at the specified index. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFOutlines Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Count Property

Gets the number of outlines in the collection

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Return Value

An integer value specifying the number of outlines in collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Current Property

Gets the current element in the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFOutlines Class : Item Property

index
Get the outline at the specified index.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDFOutline
Visual Basic (Usage) Copy Code
Dim instance As PDFOutlines
Dim index As Integer
Dim value As PDFOutline

instance.Item(index) = value

value = instance.Item(index)
C#
public PDFOutline this[
   int index
]; {get; set;}
Delphi
public  this: : PDFOutline;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDFOutline* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDFOutline* value
);
C++/CLI
public:
property PDFOutline^ default [int] {
   PDFOutline^ get(int index);
   void set (int index, PDFOutline^ value);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when the index is less than zero or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFOutlines Class
PDFOutlines Members


%%PageItemTitle%%

PDFPage Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

Defines a page within the pdf document.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPage
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
C#
public class PDFPage : PDFObject
Delphi
public class PDFPage = class(PDFObject)
Managed Extensions for C++
public __gc class PDFPage : public PDFObject
C++/CLI
public ref class PDFPage : public PDFObject

Remarks

This class is used to create new pages in a pdf document. The pages can be created in any order. The position of the page in the PDFDocument.Pages collection gives the position of the page within the final pdf file. The content of the page is mainly created using the Canvas property of the page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFPageTemplate
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

The following tables list the members exposed by PDFPage.

Public Constructors

 | Name | Description
Public Constructor | PDFPage Constructor | Initializes a new PDFPage object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page.
Public Property | ApplyTemplate | Gets of sets the template usage. Supported by Compact .NET Edition.
Public Property | Background | Gets or sets the background of the page.
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition.
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed.
Public Property | CustomProperties | Gets the collection of custom properties of the page.
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition.
Public Property | Fields | Gets the list of fields included in this page.
Public Property | Height | Gets or sets the page height. Supported by Compact .NET Edition.
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. Supported by Compact .NET Edition.
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened.
Public Property | Orientation | Gets or sets the page orientation. Supported by Compact .NET Edition.
Public Property | Size | Gets or sets the page size. Supported by Compact .NET Edition.
Public Property | Template | Gets of sets the template to be printed on the page. Supported by Compact .NET Edition.
Public Property | Transition | Gets of sets the presentation effect of the page.
Public Property | Width | Gets or sets the page width. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPage Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : PDFPage Constructor

Initializes a new PDFPage object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPage()
C#
public PDFPage()
Delphi
public PDFPage();
Managed Extensions for C++
public: PDFPage();
C++/CLI
public:
PDFPage();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%% $$Properties$$

PDFPage Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page.
Public Property | ApplyTemplate | Gets of sets the template usage. Supported by Compact .NET Edition.
Public Property | Background | Gets or sets the background of the page.
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition.
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed.
Public Property | CustomProperties | Gets the collection of custom properties of the page.
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition.
Public Property | Fields | Gets the list of fields included in this page.
Public Property | Height | Gets or sets the page height. Supported by Compact .NET Edition.
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. Supported by Compact .NET Edition.
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened.
Public Property | Orientation | Gets or sets the page orientation. Supported by Compact .NET Edition.
Public Property | Size | Gets or sets the page size. Supported by Compact .NET Edition.
Public Property | Template | Gets of sets the template to be printed on the page. Supported by Compact .NET Edition.
Public Property | Transition | Gets of sets the presentation effect of the page.
Public Property | Width | Gets or sets the page width. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Annotations Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Annotations Property

Gets the list of annotations included in this page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Annotations As PDFAnnotations
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAnnotations

value = instance.Annotations
C#
public PDFAnnotations Annotations {get;}
Delphi
public read-only property Annotations: PDFAnnotations;
Managed Extensions for C++
public: __property PDFAnnotations* get_Annotations();
C++/CLI
public:
property PDFAnnotations^ Annotations {
   PDFAnnotations^ get();
}

Return Value

A PDFAnnotations object storing the annotations in the PDF file that are displayed on this page.

Remarks

This collection is read-only and it is populated when the PDFDocument object this page belongs to is created based on an external PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

ApplyTemplate Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : ApplyTemplate Property

Gets of sets the template usage.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property ApplyTemplate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Boolean

instance.ApplyTemplate = value

value = instance.ApplyTemplate
C#
public bool ApplyTemplate {get; set;}
Delphi
public read-write property ApplyTemplate: Boolean;
Managed Extensions for C++
public: __property bool get_ApplyTemplate();
public: __property void set_ApplyTemplate(
   bool value
);
C++/CLI
public:
property bool ApplyTemplate {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying whether the template should be applied on this page or not.

Remarks

The template printing on the page can be disabled by setting the property to false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Background Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Background Property

Gets or sets the background of the page.

Syntax

Visual Basic (Declaration)
Public Property Background As PDFPageBackground
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageBackground

instance.Background = value

value = instance.Background
C#
public PDFPageBackground Background {get; set;}
Delphi
public read-write property Background: PDFPageBackground;
Managed Extensions for C++
public: __property PDFPageBackground* get_Background();
public: __property void set_Background(
   PDFPageBackground* value
);
C++/CLI
public:
property PDFPageBackground^ Background {
   PDFPageBackground^ get();
   void set (PDFPageBackground^ value);
}

Return Value

A PDFPageBackground object specifying the background of the page.

Remarks

The background is drawn always first on the page and the rest of page content appears on top of it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Canvas Property

Gets the canvas of the page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFCanvas

value = instance.Canvas
C#
public PDFCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFCanvas;
Managed Extensions for C++
public: __property PDFCanvas* get_Canvas();
C++/CLI
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Return Value

A PDFCanvas object specifying the drawing surface of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

CloseAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : CloseAction Property

Gets or sets the javascript action to execute when the page is closed.

Syntax

Visual Basic (Declaration)
Public Property CloseAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAction

instance.CloseAction = value

value = instance.CloseAction
C#
public PDFAction CloseAction {get; set;}
Delphi
public read-write property CloseAction: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_CloseAction();
public: __property void set_CloseAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ CloseAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction object specifying the action to be executed when the page is closed.

Remarks

A page is closed when the user navigates to the next or previous page or follows a link or an annotation. This action applies to the page being closed and it is executed before any other page is opened.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

CustomProperties Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : CustomProperties Property

Gets the collection of custom properties of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Hashtable

value = instance.CustomProperties
C#
public Hashtable CustomProperties {get;}
Delphi
public read-only property CustomProperties: Hashtable;
Managed Extensions for C++
public: __property Hashtable* get_CustomProperties();
C++/CLI
public:
property Hashtable^ CustomProperties {
   Hashtable^ get();
}

Return Value

a Hashtable object storing the page's custom properties.

Remarks

The properties in this collection are stored in the page dictionary as custom keys.
If the keys and/or the values in the collection are not strings, an exception is raised when the document is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Document Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Document Property

Gets the owner document of the page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PDFDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFDocument

value = instance.Document
C#
public PDFDocument Document {get;}
Delphi
public read-only property Document: PDFDocument;
Managed Extensions for C++
public: __property PDFDocument* get_Document();
C++/CLI
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Return Value

A PDFDocument object specifying the document the page belongs to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Fields Property

Gets the list of fields included in this page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As PDFFields
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFFields

value = instance.Fields
C#
public PDFFields Fields {get;}
Delphi
public read-only property Fields: PDFFields;
Managed Extensions for C++
public: __property PDFFields* get_Fields();
C++/CLI
public:
property PDFFields^ Fields {
   PDFFields^ get();
}

Return Value

A PDFFields object storing the fields in the PDF file that are displayed on this page.

Remarks

This collection is read-only and it is populated when the PDFDocument object this page belongs to is created based on an external PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Height Property

Gets or sets the page height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of the page, in logical units. The default value of this property is inherited from the document.

Remarks

In a pdf document, each page can have its own height by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

LogicalUnit Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : LogicalUnit Property

Gets or sets the logical unit for positioning the graphic objects in the page.

Syntax

Visual Basic (Declaration)
Public Property LogicalUnit As PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFLogicalUnitBase

instance.LogicalUnit = value

value = instance.LogicalUnit
C#
public PDFLogicalUnitBase LogicalUnit {get; set;}
Delphi
public read-write property LogicalUnit: PDFLogicalUnitBase;
Managed Extensions for C++
public: __property PDFLogicalUnitBase* get_LogicalUnit();
public: __property void set_LogicalUnit(
   PDFLogicalUnitBase* value
);
C++/CLI
public:
property PDFLogicalUnitBase^ LogicalUnit {
   PDFLogicalUnitBase^ get();
   void set (PDFLogicalUnitBase^ value);
}

Return Value

A PDFLogicalUnitBase descendant specifying logical unit used for positioning the graphic objects in the page.

Remarks

When a page is added to a document, it inherits this value from the document. If you want to set another logical unit for this page, set this property after the page has been added to the document (this applies when the page has been created using an explicit allocation, ex: PDFPage page = new PDFPage( );

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Number Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Number Property

Gets or sets the page number visual aspect for this PDFPage object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Number As PageNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PageNumber

instance.Number = value

value = instance.Number
C#
public PageNumber Number {get; set;}
Delphi
public read-write property Number: PageNumber;
Managed Extensions for C++
public: __property PageNumber* get_Number();
public: __property void set_Number(
   PageNumber* value
);
C++/CLI
public:
property PageNumber^ Number {
   PageNumber^ get();
   void set (PageNumber^ value);
}

Remarks

Each page can specify its own appearance for the page number by setting this property to the desired page number object. The default value for this property is the one defined for the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

OpenAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : OpenAction Property

Gets or sets the javascript action to execute when the page is opened.

Syntax

Visual Basic (Declaration)
Public Property OpenAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
C#
public PDFAction OpenAction {get; set;}
Delphi
public read-write property OpenAction: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction object specifying the action to be executed when the page is opened.

Remarks

A page is opened when the user navigates to it from the next or previous page or via a link or an annotation. This action is independent of any action that may be defined by the PDFDocument.OpenAction property and it is executed after such an action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Orientation Property

Gets or sets the page orientation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PageOrientation

instance.Orientation = value

value = instance.Orientation
C#
public PageOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: PageOrientation;
Managed Extensions for C++
public: __property PageOrientation get_Orientation();
public: __property void set_Orientation(
   PageOrientation value
);
C++/CLI
public:
property PageOrientation Orientation {
   PageOrientation get();
   void set (PageOrientation value);
}

Return Value

A PageOrientation enumeration member specifying the orientation of the page, portrait or landscape.

Remarks

In a pdf document each page can have its own orientation, by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Size Property

Gets or sets the page size.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Size As PageSize
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PageSize

instance.Size = value

value = instance.Size
C#
public PageSize Size {get; set;}
Delphi
public read-write property Size: PageSize;
Managed Extensions for C++
public: __property PageSize get_Size();
public: __property void set_Size(
   PageSize value
);
C++/CLI
public:
property PageSize Size {
   PageSize get();
   void set (PageSize value);
}

Return Value

A PageSize enumeration member specifying the page dimensions.

Remarks

Setting this property, the Width and Height properties are automatically set to the right value. But, setting the Width or the Height does not set this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Template Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Template Property

Gets of sets the template to be printed on the page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Template As PDFPageTemplate
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageTemplate

instance.Template = value

value = instance.Template
C#
public PDFPageTemplate Template {get; set;}
Delphi
public read-write property Template: PDFPageTemplate;
Managed Extensions for C++
public: __property PDFPageTemplate* get_Template();
public: __property void set_Template(
   PDFPageTemplate* value
);
C++/CLI
public:
property PDFPageTemplate^ Template {
   PDFPageTemplate^ get();
   void set (PDFPageTemplate^ value);
}

Return Value

A PDFPageTemplate object specifying the template to be printed on the page.

Remarks

Common content can be applied to multiple pages using a template. A template specifies content that will be printed under the regular content of the page. The default value of the property is the one defined on the document, but multiple templates can be defined and applied to specific pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Transition Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Transition Property

Gets of sets the presentation effect of the page.

Syntax

Visual Basic (Declaration)
Public Property Transition As PDFPageTransition
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageTransition

instance.Transition = value

value = instance.Transition
C#
public PDFPageTransition Transition {get; set;}
Delphi
public read-write property Transition: PDFPageTransition;
Managed Extensions for C++
public: __property PDFPageTransition* get_Transition();
public: __property void set_Transition(
   PDFPageTransition* value
);
C++/CLI
public:
property PDFPageTransition^ Transition {
   PDFPageTransition^ get();
   void set (PDFPageTransition^ value);
}

Return Value

A PDFPageTransition object specifying the visual effect when displaying the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Width Property

Gets or sets the page width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the page, in logical units. The default value of this property is inherited from the document.

Remarks

In a pdf document, each page can have its own width by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

PDFPageBackground Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

Defines a background for a PDF page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageBackground
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
C#
public class PDFPageBackground : PDFObject
Delphi
public class PDFPageBackground = class(PDFObject)
Managed Extensions for C++
public __gc class PDFPageBackground : public PDFObject
C++/CLI
public ref class PDFPageBackground : public PDFObject

Remarks

The page background is displayed under actual page content.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPageBackground

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageBackground Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

The following tables list the members exposed by PDFPageBackground.

Public Constructors

 | Name | Description
Public Constructor | PDFPageBackground Constructor | Overloaded. Initializes a new PDFPageBackground object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the page background.
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of the page background.
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of the page background.
Top

See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageBackground Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : PDFPageBackground Constructor

Initializes a new PDFPageBackground object.

Overload List

Overload | Description
PDFPageBackground Constructor() | Initializes a new PDFPageBackground object.
PDFPageBackground Constructor(PDFImportedContent) | Initializes a new PDFPageBackground object with the content of an existing PDF page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

PDFPageBackground Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor()

Initializes a new PDFPageBackground object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground()
C#
public PDFPageBackground()
Delphi
public PDFPageBackground();
Managed Extensions for C++
public: PDFPageBackground();
C++/CLI
public:
PDFPageBackground();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


%%PageItemTitle%%

PDFPageBackground Constructor(PDFImportedContent)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor(PDFImportedContent)

importedContent
The content of an existing PDF page
Initializes a new PDFPageBackground object with the content of an existing PDF page.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
Visual Basic (Usage) Copy Code
Dim importedContent As PDFImportedContent

Dim instance As PDFPageBackground(importedContent)
C#
public PDFPageBackground(
   PDFImportedContent importedContent
)
Delphi
public PDFPageBackground(
    importedContent: PDFImportedContent
);
Managed Extensions for C++
public: PDFPageBackground(
   PDFImportedContent* importedContent
)
C++/CLI
public:
PDFPageBackground(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
The content of an existing PDF page

Remarks

This constructor initializes the page background with the content of another PDF page. All the new content that is added to the background is drawn on top of imported content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPageBackground Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

For a list of all members of this type, see PDFPageBackground members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the page background.
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of the page background.
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of the page background.
Top

See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Canvas Property

Gets the canvas of the page background.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public PDFBasicCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFBasicCanvas;
Managed Extensions for C++
public: __property PDFBasicCanvas* get_Canvas();
C++/CLI
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Return Value

A PDFBasicCanvas object specifying the canvas of the page background.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Display Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Display Property

Gets or sets a value indicating whether the page background is displayed on the screen.

Syntax

Visual Basic (Declaration)
Public Property Display As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Boolean

instance.Display = value

value = instance.Display
C#
public bool Display {get; set;}
Delphi
public read-write property Display: Boolean;
Managed Extensions for C++
public: __property bool get_Display();
public: __property void set_Display(
   bool value
);
C++/CLI
public:
property bool Display {
   bool get();
   void set (bool value);
}

Return Value

True if the page background is displayed on the screen, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Height Property

Gets or sets the height of the page background.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of the page background.

Remarks

When the background is drawn on the page, it is scaled to fit the Location rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Location Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Location Property

Gets or sets the location on the page where the background is drawn.

Syntax

Visual Basic (Declaration)
Public Property Location As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As RectangleF

instance.Location = value

value = instance.Location
C#
public RectangleF Location {get; set;}
Delphi
public read-write property Location: RectangleF;
Managed Extensions for C++
public: __property RectangleF get_Location();
public: __property void set_Location(
   RectangleF value
);
C++/CLI
public:
property RectangleF Location {
   RectangleF get();
   void set (RectangleF value);
}

Return Value

A RectangleF object specifying the location on the page where the background is drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Opacity Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Opacity Property

Gets or sets the opacity of the page background.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}
Delphi
public read-write property Opacity: Single;
Managed Extensions for C++
public: __property float get_Opacity();
public: __property void set_Opacity(
   float value
);
C++/CLI
public:
property float Opacity {
   float get();
   void set (float value);
}

Return Value

A float value representing the opacity of the page background.

Remarks

This property controls the transparency level of the page background. 0 means full transparency, 100 means full opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Orientation Property

Gets or sets the rotation angle of the page background.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

A float value specifying the rotation angle of the page background.

Remarks

The page background is rotated around the top left corner of the Location rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Print Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Print Property

Gets or sets a value indicating whether the page background is printed when the document is printed.

Syntax

Visual Basic (Declaration)
Public Property Print As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Boolean

instance.Print = value

value = instance.Print
C#
public bool Print {get; set;}
Delphi
public read-write property Print: Boolean;
Managed Extensions for C++
public: __property bool get_Print();
public: __property void set_Print(
   bool value
);
C++/CLI
public:
property bool Print {
   bool get();
   void set (bool value);
}

Return Value

True if the page background is printed when the document is printed, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Width Property

Gets or sets the width of the page background.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the page background.

Remarks

When the background is drawn on the page, it is scaled to fit the Location rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

PDFPages Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPages Class

Defines a collection of pages.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFPages
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFPages : PDFObject
Delphi
public class PDFPages = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFPages : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFPages sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPages

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPages Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPages Class

The following tables list the members exposed by PDFPages.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of pages in the collection Supported by Compact .NET Edition.
Public Property | Current | Gets the current element in the collection. Supported by Compact .NET Edition.
Public Property | Item | Get the page at the specified index (zero based index) Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified page at the end of the collection. Supported by Compact .NET Edition.
Public Method | Clear | Removes all pages from the document.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection. Supported by Compact .NET Edition.
Public Method | IndexOf | Searches for the specified PDFPage and returns the zero-based index of the first occurrence within the entire collection.
Public Method | Insert | Overloaded. Inserts a page in the collection at the specified index. Supported by Compact .NET Edition.
Public Method | MoveNext | Advances the enumerator to the next element of the collection. Supported by Compact .NET Edition.
Public Method | Remove | Removes the first occurence of the given page from collection. Supported by Compact .NET Edition.
Public Method | RemoveAt | Removes the page at the specified index of the collection. Supported by Compact .NET Edition.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPages Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFPages Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPages Class

For a list of all members of this type, see PDFPages members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified page at the end of the collection. Supported by Compact .NET Edition.
Public Method | Clear | Removes all pages from the document.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection. Supported by Compact .NET Edition.
Public Method | IndexOf | Searches for the specified PDFPage and returns the zero-based index of the first occurrence within the entire collection.
Public Method | Insert | Overloaded. Inserts a page in the collection at the specified index. Supported by Compact .NET Edition.
Public Method | MoveNext | Advances the enumerator to the next element of the collection. Supported by Compact .NET Edition.
Public Method | Remove | Removes the first occurence of the given page from collection. Supported by Compact .NET Edition.
Public Method | RemoveAt | Removes the page at the specified index of the collection. Supported by Compact .NET Edition.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPages Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Add Method

Adds the specified page at the end of the collection.

Supported by Compact .NET Edition.

Overload List

Overload | Description
Add(PDFPage) | Adds the specified page at the end of the collection. Supported by Compact .NET Edition.
Add() | Creates a new page then adds it at the end of the collection. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Add(PDFPage) Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class > Add Method : Add(PDFPage) Method

page
a PDFPage object representing the page to be added.
Adds the specified page at the end of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal page As PDFPage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim page As PDFPage

instance.Add(page)
C#
public void Add(
   PDFPage page
)
Delphi
public procedure Add(
    page: PDFPage
);
Managed Extensions for C++
public: void Add(
   PDFPage* page
)
C++/CLI
public:
void Add(
   PDFPage^ page
)

Parameters

page
a PDFPage object representing the page to be added.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members
Overload List


%%PageItemTitle%%

Add() Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class > Add Method : Add() Method

Creates a new page then adds it at the end of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add() As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim value As PDFPage

value = instance.Add()
C#
public PDFPage Add()
Delphi
public function Add(): PDFPage;
Managed Extensions for C++
public: PDFPage* Add();
C++/CLI
public:
PDFPage^ Add();

Return Value

a PDFPage object representing the new page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Clear Method

Removes all pages from the document.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFPages

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : IndexOf Method

page
The PDFPage to locate in the collection.
Searches for the specified PDFPage and returns the zero-based index of the first occurrence within the entire collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal page As PDFPage _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim page As PDFPage
Dim value As Integer

value = instance.IndexOf(page)
C#
public int IndexOf(
   PDFPage page
)
Delphi
public function IndexOf(
    page: PDFPage
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDFPage* page
)
C++/CLI
public:
int IndexOf(
   PDFPage^ page
)

Parameters

page
The PDFPage to locate in the collection.

Return Value

The zero-based index of the first occurrence of PDFPage within the entire collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Insert Method

Inserts a page in the collection at the specified index.

Supported by Compact .NET Edition.

Overload List

Overload | Description
Insert(Int32,PDFPage) | Inserts a page in the collection at the specified index. Supported by Compact .NET Edition.
Insert(Int32) | Creates a new page and inserts it at the specified index. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Insert(Int32,PDFPage) Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class > Insert Method : Insert(Int32,PDFPage) Method

index
The zero-based index at which page should be inserted.
page
a PDFPage object to be inserted.
Inserts a page in the collection at the specified index.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Insert( _
   ByVal index As Integer, _
   ByVal page As PDFPage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim index As Integer
Dim page As PDFPage

instance.Insert(index, page)
C#
public void Insert(
   int index,
   PDFPage page
)
Delphi
public procedure Insert(
    index: Integer;
    page: PDFPage
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFPage* page
)
C++/CLI
public:
void Insert(
   int index,
   PDFPage^ page
)

Parameters

index
The zero-based index at which page should be inserted.
page
a PDFPage object to be inserted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members
Overload List


%%PageItemTitle%%

Insert(Int32) Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class > Insert Method : Insert(Int32) Method

index
The zero-based index at which the new page should be inserted.
Creates a new page and inserts it at the specified index.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Function Insert( _
   ByVal index As Integer _
) As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim index As Integer
Dim value As PDFPage

value = instance.Insert(index)
C#
public PDFPage Insert(
   int index
)
Delphi
public function Insert(
    index: Integer
): PDFPage;
Managed Extensions for C++
public: PDFPage* Insert(
   int index
)
C++/CLI
public:
PDFPage^ Insert(
   int index
)

Parameters

index
The zero-based index at which the new page should be inserted.

Return Value

a PDFPage object representing the new page.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members
Overload List


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Remove Method

page
The PDFPage object to be removed from collection.
Removes the first occurence of the given page from collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal page As PDFPage _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim page As PDFPage
Dim value As Boolean

value = instance.Remove(page)
C#
public bool Remove(
   PDFPage page
)
Delphi
public function Remove(
    page: PDFPage
): Boolean;
Managed Extensions for C++
public: bool Remove(
   PDFPage* page
)
C++/CLI
public:
bool Remove(
   PDFPage^ page
)

Parameters

page
The PDFPage object to be removed from collection.

Return Value

true if the page has been removed succesfully, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : RemoveAt Method

index
The zero-based index of the page to remove.
Removes the page at the specified index of the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the page to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFPages

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%% $$Properties$$

PDFPages Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPages Class

For a list of all members of this type, see PDFPages members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of pages in the collection Supported by Compact .NET Edition.
Public Property | Current | Gets the current element in the collection. Supported by Compact .NET Edition.
Public Property | Item | Get the page at the specified index (zero based index) Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPages Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Count Property

Returns the number of pages in the collection

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Current Property

Gets the current element in the collection.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFPages Class : Item Property

Index
Get the page at the specified index (zero based index)

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal Index As Integer _
) As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFPages
Dim Index As Integer
Dim value As PDFPage

instance.Item(Index) = value

value = instance.Item(Index)
C#
public PDFPage this[
   int Index
]; {get; set;}
Delphi
public  this: : PDFPage;[
    Index: Integer
]; read-write
Managed Extensions for C++
public: __property PDFPage* get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   PDFPage* value
);
C++/CLI
public:
property PDFPage^ default [int] {
   PDFPage^ get(int Index);
   void set (int Index, PDFPage^ value);
}

Parameters

Index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPages Class
PDFPages Members


%%PageItemTitle%%

PDFPageTemplate Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageTemplate Class

Defines a common graphic pattern applied to a series of pages in the document.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageTemplate
   Inherits PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTemplate
C#
public class PDFPageTemplate : PDFPage
Delphi
public class PDFPageTemplate = class(PDFPage)
Managed Extensions for C++
public __gc class PDFPageTemplate : public PDFPage
C++/CLI
public ref class PDFPageTemplate : public PDFPage

Remarks

This class is used to define common content to be printed on one or more pages of the document. The content of the template is created by drawing on its canvas. Also, a page from an external PDF document can be used as source for template content.

When applying a template on a page, its content is placed under the actual content of the page.

Applying a common template to all the pages in the document can be done by setting the PDFDocument.PageTemplate property. Individual templates can be applied to a series of pages by setting the PDFPage.Template property for those pages.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFPageTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTemplate Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageTemplate Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageTemplate Class

The following tables list the members exposed by PDFPageTemplate.

Public Constructors

 | Name | Description
Public Constructor | PDFPageTemplate Constructor | Overloaded. Initializes a new PDFPageTemplate object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page. (Inherited from PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from PDFPage)
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition. (Inherited from PDFPage)
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed. (Inherited from PDFPage)
Public Property | CustomProperties | Gets the collection of custom properties of the page. (Inherited from PDFPage)
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition. (Inherited from PDFPage)
Public Property | Fields | Gets the list of fields included in this page. (Inherited from PDFPage)
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page. (Inherited from PDFPage)
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened. (Inherited from PDFPage)
Top

See Also

Reference

PDFPageTemplate Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageTemplate Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageTemplate Class : PDFPageTemplate Constructor

Initializes a new PDFPageTemplate object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFPageTemplate Constructor() | Initializes a new PDFPageTemplate object. Supported by Compact .NET Edition.
PDFPageTemplate Constructor(String,Int32,Single,Single,Single,Single) | Initializes a new PDFPageTemplate object with a content of a PDF page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTemplate Class
PDFPageTemplate Members


%%PageItemTitle%%

PDFPageTemplate Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageTemplate Class > PDFPageTemplate Constructor : PDFPageTemplate Constructor()

Initializes a new PDFPageTemplate object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTemplate()
C#
public PDFPageTemplate()
Delphi
public PDFPageTemplate();
Managed Extensions for C++
public: PDFPageTemplate();
C++/CLI
public:
PDFPageTemplate();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTemplate Class
PDFPageTemplate Members
Overload List


%%PageItemTitle%%

PDFPageTemplate Constructor(String,Int32,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageTemplate Class > PDFPageTemplate Constructor : PDFPageTemplate Constructor(String,Int32,Single,Single,Single,Single)

fileName
The full path to the PDF file that will be used as the source for the template content.
pageNumber
The number of the page whose content will be used as template content.
left
top
width
height
Initializes a new PDFPageTemplate object with a content of a PDF page.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal pageNumber As Integer, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim pageNumber As Integer
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

Dim instance As PDFPageTemplate(fileName, pageNumber, left, top, width, height)
C#
public PDFPageTemplate(
   string fileName,
   int pageNumber,
   float left,
   float top,
   float width,
   float height
)
Delphi
public PDFPageTemplate(
    fileName: String;
    pageNumber: Integer;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: PDFPageTemplate(
   string* fileName,
   int pageNumber,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
PDFPageTemplate(
   String^ fileName,
   int pageNumber,
   float left,
   float top,
   float width,
   float height
)

Parameters

fileName
The full path to the PDF file that will be used as the source for the template content.
pageNumber
The number of the page whose content will be used as template content.
left
top
width
height

Remarks

The page number is zero based.
When creating a template from a PDF page, all pages in the document where the template will be applied must have the same size. The templateWidth and templateHeight specify the rectangle where the PDF page content will be placed. Usually, there parameters match the size of the pages in the final PDF file, but this is not required. For example, a template created from a PDF page can be drawn only on a part of a page, within the rectangle specified by (left, top, width, height) parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTemplate Class
PDFPageTemplate Members
Overload List


%%PageItemTitle%%

PDFPageTransition Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageTransition Class

Defines the transition effects between pages of a document.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPageTransition
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
C#
public sealed class PDFPageTransition : PDFObject
Delphi
public class PDFPageTransition = class(PDFObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFPageTransition : public PDFObject
C++/CLI
public ref class PDFPageTransition sealed : public PDFObject

Remarks

This class encapsulates the presentation features available in pdf files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPageTransition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageTransition Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageTransition Class

The following tables list the members exposed by PDFPageTransition.

Public Constructors

 | Name | Description
Public Constructor | PDFPageTransition Constructor | Initializes a new PDFPageTransition object.
Top

Public Properties

 | Name | Description
Public Property | Effect | Gets or sets the page transition effect.
Public Property | PageDuration | Gets or sets the page display duration.
Public Property | TransitionAngleDirection | Gets or sets the angle direction the transition takes place.
Public Property | TransitionDimension | Gets or sets the dimension the transition takes place.
Public Property | TransitionDuration | Gets or sets the transition effect duration.
Public Property | TransitionMotionDirection | Gets or sets the motion direction the transition takes place.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation.
Top

See Also

Reference

PDFPageTransition Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageTransition Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : PDFPageTransition Constructor

Initializes a new PDFPageTransition object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition()
C#
public PDFPageTransition()
Delphi
public PDFPageTransition();
Managed Extensions for C++
public: PDFPageTransition();
C++/CLI
public:
PDFPageTransition();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%% $$Methods$$

PDFPageTransition Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageTransition Class

For a list of all members of this type, see PDFPageTransition members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation.
Top

See Also

Reference

PDFPageTransition Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

a string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%% $$Properties$$

PDFPageTransition Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageTransition Class

For a list of all members of this type, see PDFPageTransition members.

Public Properties

 | Name | Description
Public Property | Effect | Gets or sets the page transition effect.
Public Property | PageDuration | Gets or sets the page display duration.
Public Property | TransitionAngleDirection | Gets or sets the angle direction the transition takes place.
Public Property | TransitionDimension | Gets or sets the dimension the transition takes place.
Public Property | TransitionDuration | Gets or sets the transition effect duration.
Public Property | TransitionMotionDirection | Gets or sets the motion direction the transition takes place.
Top

See Also

Reference

PDFPageTransition Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Effect Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : Effect Property

Gets or sets the page transition effect.

Syntax

Visual Basic (Declaration)
Public Property Effect As PageTransitionEffect
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As PageTransitionEffect

instance.Effect = value

value = instance.Effect
C#
public PageTransitionEffect Effect {get; set;}
Delphi
public read-write property Effect: PageTransitionEffect;
Managed Extensions for C++
public: __property PageTransitionEffect get_Effect();
public: __property void set_Effect(
   PageTransitionEffect value
);
C++/CLI
public:
property PageTransitionEffect Effect {
   PageTransitionEffect get();
   void set (PageTransitionEffect value);
}

Return Value

A PageTransitionEffect enumeration member specifying the transition effect between consecutive pages.

Remarks

This property has a meaning only if the TransitionDuration is greater then 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

PageDuration Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : PageDuration Property

Gets or sets the page display duration.

Syntax

Visual Basic (Declaration)
Public Property PageDuration As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As Single

instance.PageDuration = value

value = instance.PageDuration
C#
public float PageDuration {get; set;}
Delphi
public read-write property PageDuration: Single;
Managed Extensions for C++
public: __property float get_PageDuration();
public: __property void set_PageDuration(
   float value
);
C++/CLI
public:
property float PageDuration {
   float get();
   void set (float value);
}

Return Value

A float value specifying, in seconds, how long a page will be displayed untill the transition to the next page starts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

TransitionAngleDirection Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : TransitionAngleDirection Property

Gets or sets the angle direction the transition takes place.

Syntax

Visual Basic (Declaration)
Public Property TransitionAngleDirection As TransitionAngleDirection
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As TransitionAngleDirection

instance.TransitionAngleDirection = value

value = instance.TransitionAngleDirection
C#
public TransitionAngleDirection TransitionAngleDirection {get; set;}
Delphi
public read-write property TransitionAngleDirection: TransitionAngleDirection;
Managed Extensions for C++
public: __property TransitionAngleDirection get_TransitionAngleDirection();
public: __property void set_TransitionAngleDirection(
   TransitionAngleDirection value
);
C++/CLI
public:
property TransitionAngleDirection TransitionAngleDirection {
   TransitionAngleDirection get();
   void set (TransitionAngleDirection value);
}

Return Value

A TransitionAngleDirection enumeration member specifying the angle of the direction the transition takes place.

Remarks

This property is used only by Wipe and Glitter transitions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

TransitionDimension Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : TransitionDimension Property

Gets or sets the dimension the transition takes place.

Syntax

Visual Basic (Declaration)
Public Property TransitionDimension As TransitionDimension
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As TransitionDimension

instance.TransitionDimension = value

value = instance.TransitionDimension
C#
public TransitionDimension TransitionDimension {get; set;}
Delphi
public read-write property TransitionDimension: TransitionDimension;
Managed Extensions for C++
public: __property TransitionDimension get_TransitionDimension();
public: __property void set_TransitionDimension(
   TransitionDimension value
);
C++/CLI
public:
property TransitionDimension TransitionDimension {
   TransitionDimension get();
   void set (TransitionDimension value);
}

Return Value

A TransitionDimension enumeration member specifying the dimension the transition takes place.

Remarks

This property is used only by Split and Blinds transition effects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

TransitionDuration Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : TransitionDuration Property

Gets or sets the transition effect duration.

Syntax

Visual Basic (Declaration)
Public Property TransitionDuration As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As Single

instance.TransitionDuration = value

value = instance.TransitionDuration
C#
public float TransitionDuration {get; set;}
Delphi
public read-write property TransitionDuration: Single;
Managed Extensions for C++
public: __property float get_TransitionDuration();
public: __property void set_TransitionDuration(
   float value
);
C++/CLI
public:
property float TransitionDuration {
   float get();
   void set (float value);
}

Return Value

A float value specifying, in seconds, how much it takes to advance from one page to the next one.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

TransitionMotionDirection Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageTransition Class : TransitionMotionDirection Property

Gets or sets the motion direction the transition takes place.

Syntax

Visual Basic (Declaration)
Public Property TransitionMotionDirection As TransitionMotionDirection
Visual Basic (Usage) Copy Code
Dim instance As PDFPageTransition
Dim value As TransitionMotionDirection

instance.TransitionMotionDirection = value

value = instance.TransitionMotionDirection
C#
public TransitionMotionDirection TransitionMotionDirection {get; set;}
Delphi
public read-write property TransitionMotionDirection: TransitionMotionDirection;
Managed Extensions for C++
public: __property TransitionMotionDirection get_TransitionMotionDirection();
public: __property void set_TransitionMotionDirection(
   TransitionMotionDirection value
);
C++/CLI
public:
property TransitionMotionDirection TransitionMotionDirection {
   TransitionMotionDirection get();
   void set (TransitionMotionDirection value);
}

Return Value

A TransitionMotionDirection enumeration member specifying the motion direction of the transition effect.

Remarks

This property is used only by Split and Box transitions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageTransition Class
PDFPageTransition Members


%%PageItemTitle%%

PDFParserException Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFParserException Class

Defines the exceptions thrown by the pdf parser.

Syntax

Visual Basic (Declaration)
Public Class PDFParserException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As PDFParserException
C#
public class PDFParserException : ApplicationException
Delphi
public class PDFParserException = class(ApplicationException)
Managed Extensions for C++
public __gc class PDFParserException : public ApplicationException
C++/CLI
public ref class PDFParserException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFParserException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFParserException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFParserException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFParserException Class

The following tables list the members exposed by PDFParserException.

Public Constructors

 | Name | Description
Public Constructor | PDFParserException Constructor | Overloaded. Initializes a new PDFParserException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFParserException Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFParserException Class : PDFParserException Constructor

Initializes a new PDFParserException object.

Overload List

Overload | Description
PDFParserException Constructor(String) | Initializes a new PDFParserException object.
PDFParserException Constructor(String,Exception) | Initializes a new PDFParserException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFParserException Class
PDFParserException Members


%%PageItemTitle%%

PDFParserException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFParserException Class > PDFParserException Constructor : PDFParserException Constructor(String)

message
The message that describes the exception.
Initializes a new PDFParserException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As PDFParserException(message)
C#
public PDFParserException(
   string message
)
Delphi
public PDFParserException(
    message: String
);
Managed Extensions for C++
public: PDFParserException(
   string* message
)
C++/CLI
public:
PDFParserException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFParserException Class
PDFParserException Members
Overload List


%%PageItemTitle%%

PDFParserException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFParserException Class > PDFParserException Constructor : PDFParserException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new PDFParserException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As PDFParserException(message, innerException)
C#
public PDFParserException(
   string message,
   Exception innerException
)
Delphi
public PDFParserException(
    message: String;
    innerException: Exception
);
Managed Extensions for C++
public: PDFParserException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
PDFParserException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFParserException Class
PDFParserException Members
Overload List


%%PageItemTitle%%

PDFPointLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPointLogicalUnit Class

Defines the point (pdf unit) as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFPointLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
C#
public class PDFPointLogicalUnit : PDFLogicalUnitBase
Delphi
public class PDFPointLogicalUnit = class(PDFLogicalUnitBase)
Managed Extensions for C++
public __gc class PDFPointLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFPointLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the point as a logical unit. The mapping between logical unit and pdf unit is one-to-one, one logical unit equals to one pdf unit. The mapping functions simply return the value given as parameter.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFLogicalUnitBase
O2S.Components.PDF4NET.PDFPointLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPointLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPointLogicalUnit Class

The following tables list the members exposed by PDFPointLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFPointLogicalUnit Constructor | Initializes a new PDFPointLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPointLogicalUnit Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPointLogicalUnit Class : PDFPointLogicalUnit Constructor

Initializes a new PDFPointLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit()
C#
public PDFPointLogicalUnit()
Delphi
public PDFPointLogicalUnit();
Managed Extensions for C++
public: PDFPointLogicalUnit();
C++/CLI
public:
PDFPointLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFPointLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPointLogicalUnit Class

For a list of all members of this type, see PDFPointLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden.
Public Method | ToPDFUnitY | Overridden.
Top

See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET Namespace > PDFPointLogicalUnit Class : ToPDFUnitX Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitX(unit)
C#
public override float ToPDFUnitX(
   float unit
)
Delphi
public function ToPDFUnitX(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitX(
   float unit
) override
C++/CLI
public:
float ToPDFUnitX(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


%%PageItemTitle%%

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET Namespace > PDFPointLogicalUnit Class : ToPDFUnitY Method

unit

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Single _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
Dim unit As Single
Dim value As Single

value = instance.ToPDFUnitY(unit)
C#
public override float ToPDFUnitY(
   float unit
)
Delphi
public function ToPDFUnitY(
    unit: Single
): Single; override;
Managed Extensions for C++
public: float ToPDFUnitY(
   float unit
) override
C++/CLI
public:
float ToPDFUnitY(
   float unit
) override

Parameters

unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


%%PageItemTitle%%

PDFViewerPreferences Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

Defines the viewer preferences for the document

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFViewerPreferences
   Inherits PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
C#
public class PDFViewerPreferences : PDFBaseObject
Delphi
public class PDFViewerPreferences = class(PDFBaseObject)
Managed Extensions for C++
public __gc class PDFViewerPreferences : public PDFBaseObject
C++/CLI
public ref class PDFViewerPreferences : public PDFBaseObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFViewerPreferences

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFViewerPreferences Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

The following tables list the members exposed by PDFViewerPreferences.

Public Properties

 | Name | Description
Public Property | CenterWindow | Gets of sets the viewer position. Supported by Compact .NET Edition.
Public Property | DisplayDocTitle | Gets of sets display of document's title in the viewer Supported by Compact .NET Edition.
Public Property | DisplayMode | Gets or sets how the document should be displayed when it is opened. Supported by Compact .NET Edition.
Public Property | FitWindow | Gets of sets the size of the viewer. Supported by Compact .NET Edition.
Public Property | HideMenubar | Gets of sets the menubar visibility in the viewer Supported by Compact .NET Edition.
Public Property | HideToolbar | Gets of sets the toolbar visibility in the viewer Supported by Compact .NET Edition.
Public Property | HideWindowUI | Gets of sets the UI visibility in the viewer Supported by Compact .NET Edition.
Public Property | IsPageLayoutDefault | Gets or sets a value indicating whether the page leyout has a default value or not.
Public Property | PageLayout | Gets of sets the page layout used when the document is opened. Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFViewerPreferences Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

For a list of all members of this type, see PDFViewerPreferences members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : ToString Method

Converts the object to its string representation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

a string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%% $$Properties$$

PDFViewerPreferences Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

For a list of all members of this type, see PDFViewerPreferences members.

Public Properties

 | Name | Description
Public Property | CenterWindow | Gets of sets the viewer position. Supported by Compact .NET Edition.
Public Property | DisplayDocTitle | Gets of sets display of document's title in the viewer Supported by Compact .NET Edition.
Public Property | DisplayMode | Gets or sets how the document should be displayed when it is opened. Supported by Compact .NET Edition.
Public Property | FitWindow | Gets of sets the size of the viewer. Supported by Compact .NET Edition.
Public Property | HideMenubar | Gets of sets the menubar visibility in the viewer Supported by Compact .NET Edition.
Public Property | HideToolbar | Gets of sets the toolbar visibility in the viewer Supported by Compact .NET Edition.
Public Property | HideWindowUI | Gets of sets the UI visibility in the viewer Supported by Compact .NET Edition.
Public Property | IsPageLayoutDefault | Gets or sets a value indicating whether the page leyout has a default value or not.
Public Property | PageLayout | Gets of sets the page layout used when the document is opened. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

CenterWindow Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : CenterWindow Property

Gets of sets the viewer position.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property CenterWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.CenterWindow = value

value = instance.CenterWindow
C#
public bool CenterWindow {get; set;}
Delphi
public read-write property CenterWindow: Boolean;
Managed Extensions for C++
public: __property bool get_CenterWindow();
public: __property void set_CenterWindow(
   bool value
);
C++/CLI
public:
property bool CenterWindow {
   bool get();
   void set (bool value);
}

Return Value

a boolean value specifying whether to position document's window in the center of the screen. The default value is: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

DisplayDocTitle Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : DisplayDocTitle Property

Gets of sets display of document's title in the viewer

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DisplayDocTitle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.DisplayDocTitle = value

value = instance.DisplayDocTitle
C#
public bool DisplayDocTitle {get; set;}
Delphi
public read-write property DisplayDocTitle: Boolean;
Managed Extensions for C++
public: __property bool get_DisplayDocTitle();
public: __property void set_DisplayDocTitle(
   bool value
);
C++/CLI
public:
property bool DisplayDocTitle {
   bool get();
   void set (bool value);
}

Return Value

a boolean value spacifying whether the viewer should display the document title of the file name in its title bar. The default value is: false (display file name).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

DisplayMode Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : DisplayMode Property

Gets or sets how the document should be displayed when it is opened.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public DisplayMode DisplayMode {get; set;}
Delphi
public read-write property DisplayMode: DisplayMode;
Managed Extensions for C++
public: __property DisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   DisplayMode value
);
C++/CLI
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (DisplayMode value);
}

Return Value

A DisplayMode enumeration member specifying how the document should be displayed when it is opened.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

FitWindow Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : FitWindow Property

Gets of sets the size of the viewer.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FitWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.FitWindow = value

value = instance.FitWindow
C#
public bool FitWindow {get; set;}
Delphi
public read-write property FitWindow: Boolean;
Managed Extensions for C++
public: __property bool get_FitWindow();
public: __property void set_FitWindow(
   bool value
);
C++/CLI
public:
property bool FitWindow {
   bool get();
   void set (bool value);
}

Return Value

a boolean value specifying whether to resize document's window to fit the size of the first displayed page. The default value is: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

HideMenubar Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideMenubar Property

Gets of sets the menubar visibility in the viewer

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property HideMenubar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideMenubar = value

value = instance.HideMenubar
C#
public bool HideMenubar {get; set;}
Delphi
public read-write property HideMenubar: Boolean;
Managed Extensions for C++
public: __property bool get_HideMenubar();
public: __property void set_HideMenubar(
   bool value
);
C++/CLI
public:
property bool HideMenubar {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying the menubar visibility.

Remarks

When this is set to true, opening the file in the viewer tells the viewer to hide its menubar. The default value is: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

HideToolbar Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideToolbar Property

Gets of sets the toolbar visibility in the viewer

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property HideToolbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideToolbar = value

value = instance.HideToolbar
C#
public bool HideToolbar {get; set;}
Delphi
public read-write property HideToolbar: Boolean;
Managed Extensions for C++
public: __property bool get_HideToolbar();
public: __property void set_HideToolbar(
   bool value
);
C++/CLI
public:
property bool HideToolbar {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying the toolbar visibility.

Remarks

When this is set to true, opening the file in the viewer tells the viewer to hide its toolbar. The default value is: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

HideWindowUI Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideWindowUI Property

Gets of sets the UI visibility in the viewer

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideWindowUI = value

value = instance.HideWindowUI
C#
public bool HideWindowUI {get; set;}
Delphi
public read-write property HideWindowUI: Boolean;
Managed Extensions for C++
public: __property bool get_HideWindowUI();
public: __property void set_HideWindowUI(
   bool value
);
C++/CLI
public:
property bool HideWindowUI {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying the UI visibility.

Remarks

When this is set to true, opening the file in the viewer tells the viewer to hide its user interface. The default value is: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

IsPageLayoutDefault Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : IsPageLayoutDefault Property

Gets or sets a value indicating whether the page leyout has a default value or not.

Syntax

Visual Basic (Declaration)
Public Property IsPageLayoutDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.IsPageLayoutDefault = value

value = instance.IsPageLayoutDefault
C#
public bool IsPageLayoutDefault {get; set;}
Delphi
public read-write property IsPageLayoutDefault: Boolean;
Managed Extensions for C++
public: __property bool get_IsPageLayoutDefault();
public: __property void set_IsPageLayoutDefault(
   bool value
);
C++/CLI
public:
property bool IsPageLayoutDefault {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

PageLayout Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PageLayout Property

Gets of sets the page layout used when the document is opened.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property PageLayout As PageLayout
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As PageLayout

instance.PageLayout = value

value = instance.PageLayout
C#
public PageLayout PageLayout {get; set;}
Delphi
public read-write property PageLayout: PageLayout;
Managed Extensions for C++
public: __property PageLayout get_PageLayout();
public: __property void set_PageLayout(
   PageLayout value
);
C++/CLI
public:
property PageLayout PageLayout {
   PageLayout get();
   void set (PageLayout value);
}

Return Value

A PageLayout enumeration member specifying the page layout to be used when the document is opened.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

SaveProgressEventArgs Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : SaveProgressEventArgs Class

Defines the arguments for SaveProgress event.

Syntax

Visual Basic (Declaration)
Public Class SaveProgressEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As SaveProgressEventArgs
C#
public class SaveProgressEventArgs : EventArgs
Delphi
public class SaveProgressEventArgs = class(EventArgs)
Managed Extensions for C++
public __gc class SaveProgressEventArgs : public EventArgs
C++/CLI
public ref class SaveProgressEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDF4NET.SaveProgressEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SaveProgressEventArgs Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

SaveProgressEventArgs Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : SaveProgressEventArgs Class

The following tables list the members exposed by SaveProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SaveProgressEventArgs Constructor | Initializes a new SaveProgressEventArgs object.
Top

Public Properties

 | Name | Description
Public Property | Progress | Gets the progress of the document save operation.
Top

See Also

Reference

SaveProgressEventArgs Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

SaveProgressEventArgs Constructor
[image]
O2S.Components.PDF4NET Namespace > SaveProgressEventArgs Class : SaveProgressEventArgs Constructor

progress
A percent specifying how much of the document has been saved.
Initializes a new SaveProgressEventArgs object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal progress As Single _
)
Visual Basic (Usage) Copy Code
Dim progress As Single

Dim instance As SaveProgressEventArgs(progress)
C#
public SaveProgressEventArgs(
   float progress
)
Delphi
public SaveProgressEventArgs(
    progress: Single
);
Managed Extensions for C++
public: SaveProgressEventArgs(
   float progress
)
C++/CLI
public:
SaveProgressEventArgs(
   float progress
)

Parameters

progress
A percent specifying how much of the document has been saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SaveProgressEventArgs Class
SaveProgressEventArgs Members


%%PageItemTitle%% $$Properties$$

SaveProgressEventArgs Class Properties
[image]
O2S.Components.PDF4NET Namespace : SaveProgressEventArgs Class

For a list of all members of this type, see SaveProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | Progress | Gets the progress of the document save operation.
Top

See Also

Reference

SaveProgressEventArgs Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

Progress Property
[image]
O2S.Components.PDF4NET Namespace > SaveProgressEventArgs Class : Progress Property

Gets the progress of the document save operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Progress As Single
Visual Basic (Usage) Copy Code
Dim instance As SaveProgressEventArgs
Dim value As Single

value = instance.Progress
C#
public float Progress {get;}
Delphi
public read-only property Progress: Single;
Managed Extensions for C++
public: __property float get_Progress();
C++/CLI
public:
property float Progress {
   float get();
}

Return Value

A percent specifying how much of the document has been saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SaveProgressEventArgs Class
SaveProgressEventArgs Members


%%PageItemTitle%%

ColorSpace Enumeration
[image]
O2S.Components.PDF4NET Namespace : ColorSpace Enumeration

Specifies the available color representation modes in the pdf file

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum ColorSpace
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ColorSpace
C#
public enum ColorSpace : Enum
Delphi
public enum ColorSpace = class(Enum)
Managed Extensions for C++
__value public enum ColorSpace : public Enum
C++/CLI
public enum class ColorSpace : public Enum

Members

Member | Description
RGB | RGB representation of color. Used when primary display destination of the pdf file is the screen. Supported by Compact .NET Edition.
CMYK | CMYK representation of color. Used when primary display destination of the pdf file is the printer. Supported by Compact .NET Edition.
Grayscale | Grayscale representation of color. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.ColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

DisplayMode Enumeration
[image]
O2S.Components.PDF4NET Namespace : DisplayMode Enumeration

Specifies how the document should be displayed when it is opened.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum DisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayMode
C#
public enum DisplayMode : Enum
Delphi
public enum DisplayMode = class(Enum)
Managed Extensions for C++
__value public enum DisplayMode : public Enum
C++/CLI
public enum class DisplayMode : public Enum

Members

Member | Description
DisplayNone | Neither document outline, nor images thumbnails are visible .
DisplayOutlines | The document outline is visible when the document is opened.
DisplayThumbs | The thumbnail images are visible when the document is opened.
DisplayFullScreen | Displays the document in full screen, with no menu bar, window controls, or any other window visible.
DisplayOC | Optional content panel visible.
DisplayAttachments | Attachments panel visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.DisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

NumberingStyle Enumeration
[image]
O2S.Components.PDF4NET Namespace : NumberingStyle Enumeration

Specifies the available styles when setting up a page numbering range.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum NumberingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As NumberingStyle
C#
public enum NumberingStyle : Enum
Delphi
public enum NumberingStyle = class(Enum)
Managed Extensions for C++
__value public enum NumberingStyle : public Enum
C++/CLI
public enum class NumberingStyle : public Enum

Members

Member | Description
UpperCaseRoman | The numbering style uses uppercase roman numerals Supported by Compact .NET Edition.
LowerCaseRoman | The numbering style uses lowercase roman numerals Supported by Compact .NET Edition.
UpperCaseLetter | Upper case letters are used for page numbers.
LowerCaseLetter | Lower case letters are used for page numbers.
Arabic | The numbering style uses arabic numerals Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.NumberingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

OutlineDisplay Enumeration
[image]
O2S.Components.PDF4NET Namespace : OutlineDisplay Enumeration

Combination of styles when displaying the outline in the outline tree in the viewer

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum OutlineDisplay
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As OutlineDisplay
C#
[FlagsAttribute()]
public enum OutlineDisplay : Enum
Delphi
public enum OutlineDisplay = class(Enum)
Managed Extensions for C++
[FlagsAttribute()]
__value public enum OutlineDisplay : public Enum
C++/CLI
[FlagsAttribute()]
public enum class OutlineDisplay : public Enum

Members

Member | Description
Regular | The outline is displayed using a regular font. Supported by Compact .NET Edition.
Italic | The outline is displayed using an intalic font. Supported by Compact .NET Edition.
Bold | The outline is displayed using a bold font. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.OutlineDisplay

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageLayout Enumeration
[image]
O2S.Components.PDF4NET Namespace : PageLayout Enumeration

Specifies the page layout to be used when the document is opened.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum PageLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PageLayout
C#
public enum PageLayout : Enum
Delphi
public enum PageLayout = class(Enum)
Managed Extensions for C++
__value public enum PageLayout : public Enum
C++/CLI
public enum class PageLayout : public Enum

Members

Member | Description
SinglePage | Display one page at a time.
OneColumn | Display the pages in one column.
TwoColumnLeft | Display the pages in two columns, with odd numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageLayout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageOrientation Enumeration
[image]
O2S.Components.PDF4NET Namespace : PageOrientation Enumeration

Specifies the possible orientations for a page

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum PageOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PageOrientation
C#
public enum PageOrientation : Enum
Delphi
public enum PageOrientation = class(Enum)
Managed Extensions for C++
__value public enum PageOrientation : public Enum
C++/CLI
public enum class PageOrientation : public Enum

Members

Member | Description
Portrait | Portrait orientation.
Landscape | Landscape orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageOrientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageSize Enumeration
[image]
O2S.Components.PDF4NET Namespace : PageSize Enumeration

Specifies the predefined page sizes.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum PageSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PageSize
C#
public enum PageSize : Enum
Delphi
public enum PageSize = class(Enum)
Managed Extensions for C++
__value public enum PageSize : public Enum
C++/CLI
public enum class PageSize : public Enum

Members

Member | Description
A0 | A0 page size (2380 points x 3368 points).
A1 | A1 page size (1684 points x 2380 points).
A2 | A2 page size (1190 points x 1684 points).
A3 | A3 page size (842 points x 1190 points).
A4 | A4 page size (595 points x 842 points).
A5 | A5 page size (420 points x 595 points).
B4 | B4 page size (729 points x 1032 points).
B5 | B4 page size (516 points x 729 points).
Letter | Letter page size (612 points x 792 points).
Legal | Legal page size (612 points x 1008 points).
Tabloid | Tabloid page size (792 points x 1024 points).
Ledger | Ledger page size (1224 points x 792 points).
Statement | Statement page size (396 points x 612 points).
Executive | Executive page size (540 points x 720 points).
Folio | Folio page size (612 points x 936 points).
Quarto | Quarto page size (610 points x 780 points).
Size10x14 | 10x14 page size (720 points x 1008 points).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PageTransitionEffect Enumeration
[image]
O2S.Components.PDF4NET Namespace : PageTransitionEffect Enumeration

Specifies the available transition modes between pages.

Syntax

Visual Basic (Declaration)
Public Enum PageTransitionEffect
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PageTransitionEffect
C#
public enum PageTransitionEffect : Enum
Delphi
public enum PageTransitionEffect = class(Enum)
Managed Extensions for C++
__value public enum PageTransitionEffect : public Enum
C++/CLI
public enum class PageTransitionEffect : public Enum

Members

Member | Description
Split | Split transition effect.
Blinds | Blinds transition effect.
Box | Box transition effect.
Wipe | Wipe transition effect.
Dissolve | Dissolve transition effect.
Glitter | Glitter transition effect.
NoEffect | No effect when advancing to next page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageTransitionEffect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFVersion Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFVersion Enumeration

Specifies the available PDF versions to save a PDF document.

Syntax

Visual Basic (Declaration)
Public Enum PDFVersion
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFVersion
C#
public enum PDFVersion : Enum
Delphi
public enum PDFVersion = class(Enum)
Managed Extensions for C++
__value public enum PDFVersion : public Enum
C++/CLI
public enum class PDFVersion : public Enum

Members

Member | Description
Version13 | PDF 1.3 - Adobe Acrobat 4
Version14 | PDF 1.4 - Adobe Acrobat 5
Version15 | PDF 1.5 - Adobe Acrobat 6
Version16 | PDF 1.6 - Adobe Acrobat 7

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

TransitionAngleDirection Enumeration
[image]
O2S.Components.PDF4NET Namespace : TransitionAngleDirection Enumeration

Specifies the available angles for the transition.

Syntax

Visual Basic (Declaration)
Public Enum TransitionAngleDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransitionAngleDirection
C#
public enum TransitionAngleDirection : Enum
Delphi
public enum TransitionAngleDirection = class(Enum)
Managed Extensions for C++
__value public enum TransitionAngleDirection : public Enum
C++/CLI
public enum class TransitionAngleDirection : public Enum

Members

Member | Description
A0 | 0 degrees.
A90 | 90 degrees.
A180 | 180 degrees.
A270 | 270 degrees.
A315 | 315 degrees.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.TransitionAngleDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

TransitionDimension Enumeration
[image]
O2S.Components.PDF4NET Namespace : TransitionDimension Enumeration

Specifies the available directions for transitions.

Syntax

Visual Basic (Declaration)
Public Enum TransitionDimension
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransitionDimension
C#
public enum TransitionDimension : Enum
Delphi
public enum TransitionDimension = class(Enum)
Managed Extensions for C++
__value public enum TransitionDimension : public Enum
C++/CLI
public enum class TransitionDimension : public Enum

Members

Member | Description
Horizontal | The transition effect is going on horizontal.
Vertical | The transition effect is going on vertical.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.TransitionDimension

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

TransitionMotionDirection Enumeration
[image]
O2S.Components.PDF4NET Namespace : TransitionMotionDirection Enumeration

Specifies the motion direction of the transition.

Syntax

Visual Basic (Declaration)
Public Enum TransitionMotionDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransitionMotionDirection
C#
public enum TransitionMotionDirection : Enum
Delphi
public enum TransitionMotionDirection = class(Enum)
Managed Extensions for C++
__value public enum TransitionMotionDirection : public Enum
C++/CLI
public enum class TransitionMotionDirection : public Enum

Members

Member | Description
Inward | From the border of the page to the center.
Outward | From the center of the page to the border.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.TransitionMotionDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

XAxisDirection Enumeration
[image]
O2S.Components.PDF4NET Namespace : XAxisDirection Enumeration

Specifies the available directions for the X axis of the page canvas.

Syntax

Visual Basic (Declaration)
Public Enum XAxisDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XAxisDirection
C#
public enum XAxisDirection : Enum
Delphi
public enum XAxisDirection = class(Enum)
Managed Extensions for C++
__value public enum XAxisDirection : public Enum
C++/CLI
public enum class XAxisDirection : public Enum

Members

Member | Description
LeftToRight | The X axis is oriented from left to right. The values on X axis grow from left to right. This is the default direction used by PDF4NET library.
RightToLeft | The X axis is oriented from right to left. The values on X axis grow from right to left.

Remarks

The X axis directions are used when positioning the graphic objects in the page canvas' coordinate system. The RightToLeft direction has no connection with RightToLeft reading and text writting used by some languages.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.XAxisDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

YAxisDirection Enumeration
[image]
O2S.Components.PDF4NET Namespace : YAxisDirection Enumeration

Specifies the available directions for the Y axis of the page canvas.

Syntax

Visual Basic (Declaration)
Public Enum YAxisDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As YAxisDirection
C#
public enum YAxisDirection : Enum
Delphi
public enum YAxisDirection = class(Enum)
Managed Extensions for C++
__value public enum YAxisDirection : public Enum
C++/CLI
public enum class YAxisDirection : public Enum

Members

Member | Description
TopToBottom | The Y axis is oriented from top to bottom. The values on Y axis grow from top to bottom. This is the default direction used by PDF4NET library.
BottomToTop | The Y axis is oriented from bottom to top. The values on Y axis grow from bottom to top.

Remarks

The Y axis directions are used when positioning the graphic objects in the page canvas' coordinate system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.YAxisDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocument.SaveProgressEventHandler Delegate
[image]
O2S.Components.PDF4NET Namespace : PDFDocument.SaveProgressEventHandler Delegate

sender
args
The delegate for SaveProgress event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PDFDocument.SaveProgressEventHandler( _
   ByVal sender As Object, _
   ByVal args As SaveProgressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New SaveProgressEventHandler(AddressOf HandlerMethod)
C#
public delegate void PDFDocument.SaveProgressEventHandler(
   object sender,
   SaveProgressEventArgs args
)
Delphi
public delegate PDFDocument.SaveProgressEventHandler(
    sender: TObject;
    args: SaveProgressEventArgs
);
Managed Extensions for C++
public: __gc __delegate void PDFDocument.SaveProgressEventHandler(
   Object* sender,
   SaveProgressEventArgs* args
)
C++/CLI
public delegate void PDFDocument.SaveProgressEventHandler(
   Object^ sender,
   SaveProgressEventArgs^ args
)

Parameters

sender
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Actions Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFAction | This is the base class for all PDF actions
PDFGoToAction | This class represents a PDF Go-To action.
PDFHideAction | Defines a PDF hide action.
PDFJavaScriptAction | This class represents a PDF Javascript action.
PDFLaunchAction | This class represents a PDF Launch action.
PDFNamedAction | This class represents a PDF Named action.
PDFRemoteGoToAction | This class represents a PDF Remote Go-To action.
PDFResetFormAction | Defines a SubmitForm action.
PDFSubmitFormAction | Defines a SubmitForm action.
PDFURIAction | This class represents a PDF URI action.

Enumerations

Enumeration | Description
MagnificationMode | Specifies the available magnification modes when a page is displayed.
NamedAction | Specifies the available named actions supported by the viewer.
SubmitDataFormat | Specifies the available data formats for submitting the form data.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Actions Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFURIAction

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

This is the base class for all PDF actions

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFAction
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFAction
C#
public abstract class PDFAction : PDFObject
Delphi
public class PDFAction = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFAction : public PDFObject
C++/CLI
public ref class PDFAction abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFURIAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

The following tables list the members exposed by PDFAction.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Top

See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Properties$$

PDFAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

For a list of all members of this type, see PDFAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Top

See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

Actions Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFAction Class : Actions Property

Gets the list of actions to be performed after this one.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As PDFAction
Dim value As ArrayList

value = instance.Actions
C#
public ArrayList Actions {get;}
Delphi
public read-only property Actions: ArrayList;
Managed Extensions for C++
public: __property ArrayList* get_Actions();
C++/CLI
public:
property ArrayList^ Actions {
   ArrayList^ get();
}

Return Value

An ArrayList object storing the actions to be performed after current action (this one) has been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAction Class
PDFAction Members


%%PageItemTitle%%

PDFGoToAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

This class represents a PDF Go-To action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGoToAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
C#
public class PDFGoToAction : PDFAction
Delphi
public class PDFGoToAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFGoToAction : public PDFAction
C++/CLI
public ref class PDFGoToAction : public PDFAction

Remarks

This type of action allows a user to navigate to a specific page in the current document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFGoToAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

The following tables list the members exposed by PDFGoToAction.

Public Constructors

 | Name | Description
Public Constructor | PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode for destination page.
Public Property | Page | Gets or sets the destination page for this action.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor

Initializes a new PDFGoToAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction()
C#
public PDFGoToAction()
Delphi
public PDFGoToAction();
Managed Extensions for C++
public: PDFGoToAction();
C++/CLI
public:
PDFGoToAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFGoToAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

For a list of all members of this type, see PDFGoToAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode for destination page.
Public Property | Page | Gets or sets the destination page for this action.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

Bottom Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Bottom Property

Gets or sets the bottom coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As Single

instance.Bottom = value

value = instance.Bottom
C#
public float Bottom {get; set;}
Delphi
public read-write property Bottom: Single;
Managed Extensions for C++
public: __property float get_Bottom();
public: __property void set_Bottom(
   float value
);
C++/CLI
public:
property float Bottom {
   float get();
   void set (float value);
}

Return Value

A float value specifying the bottom coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. It is relative to the top of the page.
This value is used by the following magnification modes: MagnificationMode.FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Left Property

Gets or sets the left coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

A float value specifying the left coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the left margin of the page, 0 value meaning that the page will be displayed starting from its left margin.
A -1 value for this property means that the current left coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: MagnificationMode.XYZ, MagnificationMode.FitV, MagnificationMode.FitR, MagnificationMode.FitBV

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

MagnificationMode Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : MagnificationMode Property

Gets or sets the magnification mode for destination page.

Syntax

Visual Basic (Declaration)
Public Property MagnificationMode As MagnificationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As MagnificationMode

instance.MagnificationMode = value

value = instance.MagnificationMode
C#
public MagnificationMode MagnificationMode {get; set;}
Delphi
public read-write property MagnificationMode: MagnificationMode;
Managed Extensions for C++
public: __property MagnificationMode get_MagnificationMode();
public: __property void set_MagnificationMode(
   MagnificationMode value
);
C++/CLI
public:
property MagnificationMode MagnificationMode {
   MagnificationMode get();
   void set (MagnificationMode value);
}

Return Value

A MagnificationMode enumeration member specifying the magnification mode for the page when it opens in the viewer as a result of executing this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

Page Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Page Property

Gets or sets the destination page for this action.

Syntax

Visual Basic (Declaration)
Public Property Page As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As PDFPage

instance.Page = value

value = instance.Page
C#
public PDFPage Page {get; set;}
Delphi
public read-write property Page: PDFPage;
Managed Extensions for C++
public: __property PDFPage* get_Page();
public: __property void set_Page(
   PDFPage* value
);
C++/CLI
public:
property PDFPage^ Page {
   PDFPage^ get();
   void set (PDFPage^ value);
}

Return Value

A PDFPage object specifying the page to be displayed when this action is executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

Right Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Right Property

Gets or sets the right coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As Single

instance.Right = value

value = instance.Right
C#
public float Right {get; set;}
Delphi
public read-write property Right: Single;
Managed Extensions for C++
public: __property float get_Right();
public: __property void set_Right(
   float value
);
C++/CLI
public:
property float Right {
   float get();
   void set (float value);
}

Return Value

A float value specifying the right coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate.
This value is used by the following magnification modes: MagnificationMode.FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Top Property

Gets or sets the top coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

A float value specifying the top coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the top of the page, 0 value meaning that the top of the page will be displayed.
A -1 value for this property means that the current top coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: MagnificationMode.XYZ, MagnificationMode.FitH, MagnificationMode.FitR, MagnificationMode.FitBH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

Zoom Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Zoom Property

Gets or sets the zoom factor to be used when the page is displayed.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As Single

instance.Zoom = value

value = instance.Zoom
C#
public float Zoom {get; set;}
Delphi
public read-write property Zoom: Single;
Managed Extensions for C++
public: __property float get_Zoom();
public: __property void set_Zoom(
   float value
);
C++/CLI
public:
property float Zoom {
   float get();
   void set (float value);
}

Return Value

A float value specifying the zoom factor to be used when the page is displayed.

Remarks

When the destination page of this action is displayed, it will be magnified using the zoom factor specified by this property. This value is used only in conjunction with MagnificationMode.XYZ magnification mode ( see MagnificationMode enumeration) and it is given as percents (100 means 100% zoom).
A 0 value for this property means that the current zoom factor used by the viewer will not be changed when displaying the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

PDFHideAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

Defines a PDF hide action.

Syntax

Visual Basic (Declaration)
Public Class PDFHideAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
C#
public class PDFHideAction : PDFAction
Delphi
public class PDFHideAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFHideAction : public PDFAction
C++/CLI
public ref class PDFHideAction : public PDFAction

Remarks

This action allows a user to hide or show a form field.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFHideAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFHideAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

The following tables list the members exposed by PDFHideAction.

Public Constructors

 | Name | Description
Public Constructor | PDFHideAction Constructor | Initializes a new PDFHideAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top

See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFHideAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor

Initializes a new PDFHideAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction()
C#
public PDFHideAction()
Delphi
public PDFHideAction();
Managed Extensions for C++
public: PDFHideAction();
C++/CLI
public:
PDFHideAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%% $$Properties$$

PDFHideAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

For a list of all members of this type, see PDFHideAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top

See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

FieldName Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : FieldName Property

Gets or sets the name of the field that is affected by this action.

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
Dim value As String

instance.FieldName = value

value = instance.FieldName
C#
public string FieldName {get; set;}
Delphi
public read-write property FieldName: String;
Managed Extensions for C++
public: __property string* get_FieldName();
public: __property void set_FieldName(
   string* value
);
C++/CLI
public:
property String^ FieldName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of the field that is affected by this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%%

Hide Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : Hide Property

Gets or sets a value indicating whether the specified form field should be hidden or shown.

Syntax

Visual Basic (Declaration)
Public Property Hide As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
Dim value As Boolean

instance.Hide = value

value = instance.Hide
C#
public bool Hide {get; set;}
Delphi
public read-write property Hide: Boolean;
Managed Extensions for C++
public: __property bool get_Hide();
public: __property void set_Hide(
   bool value
);
C++/CLI
public:
property bool Hide {
   bool get();
   void set (bool value);
}

Return Value

True if the form field should be hidden, false if the form field should be shown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%%

PDFJavaScriptAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

This class represents a PDF Javascript action.

Syntax

Visual Basic (Declaration)
Public Class PDFJavaScriptAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction
C#
public class PDFJavaScriptAction : PDFAction
Delphi
public class PDFJavaScriptAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFJavaScriptAction : public PDFAction
C++/CLI
public ref class PDFJavaScriptAction : public PDFAction

Remarks

This type of action allows a user to execute Javascript code within the viewer.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

The following tables list the members exposed by PDFJavaScriptAction.

Public Constructors

 | Name | Description
Public Constructor | PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top

See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFJavaScriptAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor

Initializes a new PDFJavaScriptAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction()
C#
public PDFJavaScriptAction()
Delphi
public PDFJavaScriptAction();
Managed Extensions for C++
public: PDFJavaScriptAction();
C++/CLI
public:
PDFJavaScriptAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%% $$Properties$$

PDFJavaScriptAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

For a list of all members of this type, see PDFJavaScriptAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top

See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

Script Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : Script Property

Gets or sets the javascript code to be executed when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property Script As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction
Dim value As String

instance.Script = value

value = instance.Script
C#
public string Script {get; set;}
Delphi
public read-write property Script: String;
Managed Extensions for C++
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
C++/CLI
public:
property String^ Script {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing valid javascript code to be executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%%

PDFLaunchAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

This class represents a PDF Launch action.

Syntax

Visual Basic (Declaration)
Public Class PDFLaunchAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
C#
public class PDFLaunchAction : PDFAction
Delphi
public class PDFLaunchAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFLaunchAction : public PDFAction
C++/CLI
public ref class PDFLaunchAction : public PDFAction

Remarks

This type of action allows a user to launch an application or to open a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFLaunchAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

The following tables list the members exposed by PDFLaunchAction.

Public Constructors

 | Name | Description
Public Constructor | PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | File | Gets or sets the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top

See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFLaunchAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor

Initializes a new PDFLaunchAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction()
C#
public PDFLaunchAction()
Delphi
public PDFLaunchAction();
Managed Extensions for C++
public: PDFLaunchAction();
C++/CLI
public:
PDFLaunchAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%% $$Properties$$

PDFLaunchAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

For a list of all members of this type, see PDFLaunchAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | File | Gets or sets the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top

See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

File Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : File Property

Gets or sets the file to be launched by this action.

Syntax

Visual Basic (Declaration)
Public Property File As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As String

instance.File = value

value = instance.File
C#
public string File {get; set;}
Delphi
public read-write property File: String;
Managed Extensions for C++
public: __property string* get_File();
public: __property void set_File(
   string* value
);
C++/CLI
public:
property String^ File {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the full path to the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

NewWindow Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : NewWindow Property

Gets or sets whether the remote document opens in current window or in a new window.

Syntax

Visual Basic (Declaration)
Public Property NewWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
C#
public bool NewWindow {get; set;}
Delphi
public read-write property NewWindow: Boolean;
Managed Extensions for C++
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
C++/CLI
public:
property bool NewWindow {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.

Remarks

If the file is not a pdf document, this property is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

Parameters Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : Parameters Property

Gets or sets a parameter string to be passed to the launched application.

Syntax

Visual Basic (Declaration)
Public Property Parameters As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As String

instance.Parameters = value

value = instance.Parameters
C#
public string Parameters {get; set;}
Delphi
public read-write property Parameters: String;
Managed Extensions for C++
public: __property string* get_Parameters();
public: __property void set_Parameters(
   string* value
);
C++/CLI
public:
property String^ Parameters {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the the list of parameters to be passed to the launched application

Remarks

This property matches the string of parameters as if they were passed to the application in the command line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

PDFNamedAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

This class represents a PDF Named action.

Syntax

Visual Basic (Declaration)
Public Class PDFNamedAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction
C#
public class PDFNamedAction : PDFAction
Delphi
public class PDFNamedAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFNamedAction : public PDFAction
C++/CLI
public ref class PDFNamedAction : public PDFAction

Remarks

This type of action allows a user to navigate to specific pages in the document or to print the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFNamedAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFNamedAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

The following tables list the members exposed by PDFNamedAction.

Public Constructors

 | Name | Description
Public Constructor | PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top

See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFNamedAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor

Initializes a new PDFNamedAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction()
C#
public PDFNamedAction()
Delphi
public PDFNamedAction();
Managed Extensions for C++
public: PDFNamedAction();
C++/CLI
public:
PDFNamedAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%% $$Properties$$

PDFNamedAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

For a list of all members of this type, see PDFNamedAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top

See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

NamedAction Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : NamedAction Property

Gets or sets the named action to be executed when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property NamedAction As NamedAction
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction
Dim value As NamedAction

instance.NamedAction = value

value = instance.NamedAction
C#
public NamedAction NamedAction {get; set;}
Delphi
public read-write property NamedAction: NamedAction;
Managed Extensions for C++
public: __property NamedAction get_NamedAction();
public: __property void set_NamedAction(
   NamedAction value
);
C++/CLI
public:
property NamedAction NamedAction {
   NamedAction get();
   void set (NamedAction value);
}

Return Value

An NamedAction enumeration member specifying the action to be executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%%

PDFRemoteGoToAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

This class represents a PDF Remote Go-To action.

Syntax

Visual Basic (Declaration)
Public Class PDFRemoteGoToAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
C#
public class PDFRemoteGoToAction : PDFAction
Delphi
public class PDFRemoteGoToAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFRemoteGoToAction : public PDFAction
C++/CLI
public ref class PDFRemoteGoToAction : public PDFAction

Remarks

This type of action allows a user to navigate to a specific page in an external pdf document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFRemoteGoToAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

The following tables list the members exposed by PDFRemoteGoToAction.

Public Constructors

 | Name | Description
Public Constructor | PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode for destination page.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | PageNumber | Gets or sets the destination page number (in the remote document) for this action.
Public Property | RemoteFile | Gets or sets the remote file for this action.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFRemoteGoToAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor

Initializes a new PDFRemoteGoToAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction()
C#
public PDFRemoteGoToAction()
Delphi
public PDFRemoteGoToAction();
Managed Extensions for C++
public: PDFRemoteGoToAction();
C++/CLI
public:
PDFRemoteGoToAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFRemoteGoToAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

For a list of all members of this type, see PDFRemoteGoToAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode for destination page.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | PageNumber | Gets or sets the destination page number (in the remote document) for this action.
Public Property | RemoteFile | Gets or sets the remote file for this action.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

Bottom Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Bottom Property

Gets or sets the bottom coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Single

instance.Bottom = value

value = instance.Bottom
C#
public float Bottom {get; set;}
Delphi
public read-write property Bottom: Single;
Managed Extensions for C++
public: __property float get_Bottom();
public: __property void set_Bottom(
   float value
);
C++/CLI
public:
property float Bottom {
   float get();
   void set (float value);
}

Return Value

A float value specifying the bottom coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. It is relative to the bottom of the page.
This value is used by the following magnification modes: MagnificationMode.FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Left Property

Gets or sets the left coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

A float value specifying the left coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the left margin of the page, 0 value meaning that the page will be displayed starting from its left margin.
A -1 value for this property means that the current left coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: MagnificationMode.XYZ, MagnificationMode.FitV, MagnificationMode.FitR, MagnificationMode.FitBV

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

MagnificationMode Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : MagnificationMode Property

Gets or sets the magnification mode for destination page.

Syntax

Visual Basic (Declaration)
Public Property MagnificationMode As MagnificationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As MagnificationMode

instance.MagnificationMode = value

value = instance.MagnificationMode
C#
public MagnificationMode MagnificationMode {get; set;}
Delphi
public read-write property MagnificationMode: MagnificationMode;
Managed Extensions for C++
public: __property MagnificationMode get_MagnificationMode();
public: __property void set_MagnificationMode(
   MagnificationMode value
);
C++/CLI
public:
property MagnificationMode MagnificationMode {
   MagnificationMode get();
   void set (MagnificationMode value);
}

Return Value

A MagnificationMode enumeration member specifying the magnification mode for the page when it opens in the viewer as a result of executing this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

NewWindow Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : NewWindow Property

Gets or sets whether the remote document opens in current window or in a new window.

Syntax

Visual Basic (Declaration)
Public Property NewWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
C#
public bool NewWindow {get; set;}
Delphi
public read-write property NewWindow: Boolean;
Managed Extensions for C++
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
C++/CLI
public:
property bool NewWindow {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

PageNumber Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : PageNumber Property

Gets or sets the destination page number (in the remote document) for this action.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Delphi
public read-write property PageNumber: Integer;
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (int value);
}

Return Value

An int value specifying the page to be displayed when this action is executed.

Remarks

This value is 0 based, first page in the document is 0, the second page is 1, and so on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

RemoteFile Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : RemoteFile Property

Gets or sets the remote file for this action.

Syntax

Visual Basic (Declaration)
Public Property RemoteFile As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As String

instance.RemoteFile = value

value = instance.RemoteFile
C#
public string RemoteFile {get; set;}
Delphi
public read-write property RemoteFile: String;
Managed Extensions for C++
public: __property string* get_RemoteFile();
public: __property void set_RemoteFile(
   string* value
);
C++/CLI
public:
property String^ RemoteFile {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the full path to the remote pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

Right Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Right Property

Gets or sets the right coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Single

instance.Right = value

value = instance.Right
C#
public float Right {get; set;}
Delphi
public read-write property Right: Single;
Managed Extensions for C++
public: __property float get_Right();
public: __property void set_Right(
   float value
);
C++/CLI
public:
property float Right {
   float get();
   void set (float value);
}

Return Value

A float value specifying the right coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate.
This value is used by the following magnification modes: MagnificationMode.FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Top Property

Gets or sets the top coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

A float value specifying the top coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the bottom of the page, 0 value meaning that the bottom of the page will be displayed.
A -1 value for this property means that the current top coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: MagnificationMode.XYZ, MagnificationMode.FitH, MagnificationMode.FitR, MagnificationMode.FitBH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

Zoom Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Zoom Property

Gets or sets the zoom factor to be used when the page is displayed.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Single

instance.Zoom = value

value = instance.Zoom
C#
public float Zoom {get; set;}
Delphi
public read-write property Zoom: Single;
Managed Extensions for C++
public: __property float get_Zoom();
public: __property void set_Zoom(
   float value
);
C++/CLI
public:
property float Zoom {
   float get();
   void set (float value);
}

Return Value

A float value specifying the zoom factor to be used when the page is displayed.

Remarks

When the destination page of this action is displayed, it will be magnified using the zoom factor specified by this property. This value is used only in conjunction with MagnificationMode.XYZ magnification mode ( see MagnificationMode enumeration) and it is given as percents (100 means 100% zoom).
A 0 value for this property means that the current zoom factor used by the viewer will not be changed when displaying the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

PDFResetFormAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

Defines a SubmitForm action.

Syntax

Visual Basic (Declaration)
Public Class PDFResetFormAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
C#
public class PDFResetFormAction : PDFAction
Delphi
public class PDFResetFormAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFResetFormAction : public PDFAction
C++/CLI
public ref class PDFResetFormAction : public PDFAction

Remarks

This action allows a user to reset the form fields to their default values.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFResetFormAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

The following tables list the members exposed by PDFResetFormAction.

Public Constructors

 | Name | Description
Public Constructor | PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top

See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFResetFormAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor

Initializes a new PDFResetFormAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction()
C#
public PDFResetFormAction()
Delphi
public PDFResetFormAction();
Managed Extensions for C++
public: PDFResetFormAction();
C++/CLI
public:
PDFResetFormAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%% $$Properties$$

PDFResetFormAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

For a list of all members of this type, see PDFResetFormAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top

See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : Fields Property

Gets or sets the list of fields affected by this action.

Syntax

Visual Basic (Declaration)
Public Property Fields As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
Dim value As StringCollection

instance.Fields = value

value = instance.Fields
C#
public StringCollection Fields {get; set;}
Delphi
public read-write property Fields: StringCollection;
Managed Extensions for C++
public: __property StringCollection get_Fields();
public: __property void set_Fields(
   StringCollection value
);
C++/CLI
public:
property StringCollection Fields {
   StringCollection get();
   void set (StringCollection value);
}

Return Value

A StringCollection object specifying the list of fields affected by this action.

Remarks

The ResetFields property controls how the fields in this collection are reset.
If ResetFields property is true, only the fields in this collection will be reset.
If ResetFields property is false, the fields in this collection are not reset and only the remaining form fields are reset.
If the collection is null or empty, then all the form fields are reset and the ResetFields property is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%%

ResetFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : ResetFields Property

Gets or sets a value indicating whether the fields in Fields collection should be reset or not.

Syntax

Visual Basic (Declaration)
Public Property ResetFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
Dim value As Boolean

instance.ResetFields = value

value = instance.ResetFields
C#
public bool ResetFields {get; set;}
Delphi
public read-write property ResetFields: Boolean;
Managed Extensions for C++
public: __property bool get_ResetFields();
public: __property void set_ResetFields(
   bool value
);
C++/CLI
public:
property bool ResetFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields in Fields collection should be reset, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%%

PDFSubmitFormAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

Defines a SubmitForm action.

Syntax

Visual Basic (Declaration)
Public Class PDFSubmitFormAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
C#
public class PDFSubmitFormAction : PDFAction
Delphi
public class PDFSubmitFormAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFSubmitFormAction : public PDFAction
C++/CLI
public ref class PDFSubmitFormAction : public PDFAction

Remarks

This action allows a user to submit the form data to a specified URL.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFSubmitFormAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

The following tables list the members exposed by PDFSubmitFormAction.

Public Constructors

 | Name | Description
Public Constructor | PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top

See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFSubmitFormAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor

Initializes a new PDFSubmitFormAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction()
C#
public PDFSubmitFormAction()
Delphi
public PDFSubmitFormAction();
Managed Extensions for C++
public: PDFSubmitFormAction();
C++/CLI
public:
PDFSubmitFormAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%% $$Properties$$

PDFSubmitFormAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

For a list of all members of this type, see PDFSubmitFormAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top

See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

DataFormat Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : DataFormat Property

Gets or sets the format of the data being submitted.

Syntax

Visual Basic (Declaration)
Public Property DataFormat As SubmitDataFormat
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As SubmitDataFormat

instance.DataFormat = value

value = instance.DataFormat
C#
public SubmitDataFormat DataFormat {get; set;}
Delphi
public read-write property DataFormat: SubmitDataFormat;
Managed Extensions for C++
public: __property SubmitDataFormat get_DataFormat();
public: __property void set_DataFormat(
   SubmitDataFormat value
);
C++/CLI
public:
property SubmitDataFormat DataFormat {
   SubmitDataFormat get();
   void set (SubmitDataFormat value);
}

Return Value

A SubmitDataFormat enumeration member specifying the format of the data being submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

EmbedForm Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : EmbedForm Property

Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property EmbedForm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.EmbedForm = value

value = instance.EmbedForm
C#
public bool EmbedForm {get; set;}
Delphi
public read-write property EmbedForm: Boolean;
Managed Extensions for C++
public: __property bool get_EmbedForm();
public: __property void set_EmbedForm(
   bool value
);
C++/CLI
public:
property bool EmbedForm {
   bool get();
   void set (bool value);
}

Return Value

True if the PDF document is embedded in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

ExcludeNonUserAnnotations Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : ExcludeNonUserAnnotations Property

Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.

Syntax

Visual Basic (Declaration)
Public Property ExcludeNonUserAnnotations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.ExcludeNonUserAnnotations = value

value = instance.ExcludeNonUserAnnotations
C#
public bool ExcludeNonUserAnnotations {get; set;}
Delphi
public read-write property ExcludeNonUserAnnotations: Boolean;
Managed Extensions for C++
public: __property bool get_ExcludeNonUserAnnotations();
public: __property void set_ExcludeNonUserAnnotations(
   bool value
);
C++/CLI
public:
property bool ExcludeNonUserAnnotations {
   bool get();
   void set (bool value);
}

Return Value

True if only the annotations whose author is the current user should be submitted, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF and IncludeAnnotations property is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Fields Property

Gets or sets the list of fields affected by this action.

Syntax

Visual Basic (Declaration)
Public Property Fields As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As StringCollection

instance.Fields = value

value = instance.Fields
C#
public StringCollection Fields {get; set;}
Delphi
public read-write property Fields: StringCollection;
Managed Extensions for C++
public: __property StringCollection get_Fields();
public: __property void set_Fields(
   StringCollection value
);
C++/CLI
public:
property StringCollection Fields {
   StringCollection get();
   void set (StringCollection value);
}

Return Value

A StringCollection object specifying the list of fields affected by this action.

Remarks

The SubmitFields property controls how the fields in this collection are submitted to the specified URL.
If SubmitFields property is true, only the fields in this collection will be submitted.
If SubmitFields property is false, the fields in this collection will not be submitted and only the remaining form fields will be submitted.
If the collection is null or empty, then all the form fields are submitted and the SubmitFields property is ignored.
In any of the situations above, the fields with NoExport property set to true will not be submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

IncludeAnnotations Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAnnotations Property

Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property IncludeAnnotations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAnnotations = value

value = instance.IncludeAnnotations
C#
public bool IncludeAnnotations {get; set;}
Delphi
public read-write property IncludeAnnotations: Boolean;
Managed Extensions for C++
public: __property bool get_IncludeAnnotations();
public: __property void set_IncludeAnnotations(
   bool value
);
C++/CLI
public:
property bool IncludeAnnotations {
   bool get();
   void set (bool value);
}

Return Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

IncludeAppendSaves Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAppendSaves Property

Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property IncludeAppendSaves As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAppendSaves = value

value = instance.IncludeAppendSaves
C#
public bool IncludeAppendSaves {get; set;}
Delphi
public read-write property IncludeAppendSaves: Boolean;
Managed Extensions for C++
public: __property bool get_IncludeAppendSaves();
public: __property void set_IncludeAppendSaves(
   bool value
);
C++/CLI
public:
property bool IncludeAppendSaves {
   bool get();
   void set (bool value);
}

Return Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

IncludeNoValueFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeNoValueFields Property

Gets or sets a value indicating whether the fields with no value should be submitted.

Syntax

Visual Basic (Declaration)
Public Property IncludeNoValueFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeNoValueFields = value

value = instance.IncludeNoValueFields
C#
public bool IncludeNoValueFields {get; set;}
Delphi
public read-write property IncludeNoValueFields: Boolean;
Managed Extensions for C++
public: __property bool get_IncludeNoValueFields();
public: __property void set_IncludeNoValueFields(
   bool value
);
C++/CLI
public:
property bool IncludeNoValueFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields with no value should be submitted, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

SubmitCoordinates Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitCoordinates Property

Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.

Syntax

Visual Basic (Declaration)
Public Property SubmitCoordinates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitCoordinates = value

value = instance.SubmitCoordinates
C#
public bool SubmitCoordinates {get; set;}
Delphi
public read-write property SubmitCoordinates: Boolean;
Managed Extensions for C++
public: __property bool get_SubmitCoordinates();
public: __property void set_SubmitCoordinates(
   bool value
);
C++/CLI
public:
property bool SubmitCoordinates {
   bool get();
   void set (bool value);
}

Return Value

True if the coordinates of the mouse click that caused the submit form action should be transmitted as part of form data, otherwise false. Default is false.

Remarks

This property has meaning only if DataFormat property is HTML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

SubmitFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitFields Property

Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.

Syntax

Visual Basic (Declaration)
Public Property SubmitFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitFields = value

value = instance.SubmitFields
C#
public bool SubmitFields {get; set;}
Delphi
public read-write property SubmitFields: Boolean;
Managed Extensions for C++
public: __property bool get_SubmitFields();
public: __property void set_SubmitFields(
   bool value
);
C++/CLI
public:
property bool SubmitFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields in Fields collection should be submitted, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

Url Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Url Property

Gets or sets the URL for submitting the form data.

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Delphi
public read-write property Url: String;
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the URL where the form data should be submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

UseCanonicalDateTimeFormat Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseCanonicalDateTimeFormat Property

Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.

Syntax

Visual Basic (Declaration)
Public Property UseCanonicalDateTimeFormat As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseCanonicalDateTimeFormat = value

value = instance.UseCanonicalDateTimeFormat
C#
public bool UseCanonicalDateTimeFormat {get; set;}
Delphi
public read-write property UseCanonicalDateTimeFormat: Boolean;
Managed Extensions for C++
public: __property bool get_UseCanonicalDateTimeFormat();
public: __property void set_UseCanonicalDateTimeFormat(
   bool value
);
C++/CLI
public:
property bool UseCanonicalDateTimeFormat {
   bool get();
   void set (bool value);
}

Return Value

True if the the field values representing dates should be submitted using PDF date/time format. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

UseHttpGet Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseHttpGet Property

Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.

Syntax

Visual Basic (Declaration)
Public Property UseHttpGet As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseHttpGet = value

value = instance.UseHttpGet
C#
public bool UseHttpGet {get; set;}
Delphi
public read-write property UseHttpGet: Boolean;
Managed Extensions for C++
public: __property bool get_UseHttpGet();
public: __property void set_UseHttpGet(
   bool value
);
C++/CLI
public:
property bool UseHttpGet {
   bool get();
   void set (bool value);
}

Return Value

True if the field names and values should be submitted using HTTP GET method. If false, the field names and values are submitted using HTTP POST method. Default is false.

Remarks

This property has meaning only if DataFormat property is HTML or PDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

PDFURIAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

This class represents a PDF URI action.

Syntax

Visual Basic (Declaration)
Public Class PDFURIAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction
C#
public class PDFURIAction : PDFAction
Delphi
public class PDFURIAction = class(PDFAction)
Managed Extensions for C++
public __gc class PDFURIAction : public PDFAction
C++/CLI
public ref class PDFURIAction : public PDFAction

Remarks

This type of action allows a user to go to a resource on the Internet, tipically a hypertext link.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFURIAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFURIAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

The following tables list the members exposed by PDFURIAction.

Public Constructors

 | Name | Description
Public Constructor | PDFURIAction Constructor | Initializes a new PDFURIAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top

See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFURIAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : PDFURIAction Constructor

Initializes a new PDFURIAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction()
C#
public PDFURIAction()
Delphi
public PDFURIAction();
Managed Extensions for C++
public: PDFURIAction();
C++/CLI
public:
PDFURIAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Class
PDFURIAction Members


%%PageItemTitle%% $$Properties$$

PDFURIAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

For a list of all members of this type, see PDFURIAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top

See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

URI Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : URI Property

Gets or sets the uri to be resolved when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property URI As String
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction
Dim value As String

instance.URI = value

value = instance.URI
C#
public string URI {get; set;}
Delphi
public read-write property URI: String;
Managed Extensions for C++
public: __property string* get_URI();
public: __property void set_URI(
   string* value
);
C++/CLI
public:
property String^ URI {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the full URI for the internet resource.

Remarks

The value of this property is usually a HTTP url, like below:

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Class
PDFURIAction Members


%%PageItemTitle%%

MagnificationMode Enumeration
[image]
O2S.Components.PDF4NET.Actions Namespace : MagnificationMode Enumeration

Specifies the available magnification modes when a page is displayed.

Syntax

Visual Basic (Declaration)
Public Enum MagnificationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MagnificationMode
C#
public enum MagnificationMode : Enum
Delphi
public enum MagnificationMode = class(Enum)
Managed Extensions for C++
__value public enum MagnificationMode : public Enum
C++/CLI
public enum class MagnificationMode : public Enum

Members

Member | Description
XYZ | Display the page with the coordinates (left, top) positioned at the top-left corner of the window and the contents of the page magnified by the factor zoom.
Fit | Display the page with its contents magnified just enough to fit the entire page within the window both horizontally and vertically. If the required horizontal and vertical magnification factors are different, use the smaller of the two, centering the page within the window in the other dimension.
FitH | Display the page with the vertical coordinate top positioned at the top edge of the window and the contents of the page magnified just enough to fit the entire width of the page within the window.
FitV | Display the page with the horizontal coordinate left positioned at the left edge of the window and the contents of the page magnified just enough to fit the entire height of the page within the window.
FitR | Display the page with its contents magnified just enough to fit the rectangle specified by the coordinates left, bottom, right, and top entirely within the window both horizontally and vertically. If the required horizontal and vertical magnification factors are different, use the smaller of the two, centering the rectangle within the window in the other dimension.
FitB | Display the page with its contents magnified just enough to fit its bounding box entirely within the window both horizontally and vertically. If the required horizontal and vertical magnification factors are different, use the smaller of the two, centering the bounding box within the window in the other dimension.
FitBH | Display the page designated by page, with the vertical coordinate top positioned at the top edge of the window and the contents of the page magnified just enough to fit the entire width of its bounding box within the window.
FitBV | Display the page designated by page, with the horizontal coordinate left positioned at the left edge of the window and the contents of the page magnified just enough to fit the entire height of its bounding box within the window.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.MagnificationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

NamedAction Enumeration
[image]
O2S.Components.PDF4NET.Actions Namespace : NamedAction Enumeration

Specifies the available named actions supported by the viewer.

Syntax

Visual Basic (Declaration)
Public Enum NamedAction
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As NamedAction
C#
public enum NamedAction : Enum
Delphi
public enum NamedAction = class(Enum)
Managed Extensions for C++
__value public enum NamedAction : public Enum
C++/CLI
public enum class NamedAction : public Enum

Members

Member | Description
NextPage | Go to next page in the document.
PrevPage | Go to previous page in the document.
FirstPage | Go to first page in the document.
LastPage | Go to last page in the document.
Print | Print the document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.NamedAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

SubmitDataFormat Enumeration
[image]
O2S.Components.PDF4NET.Actions Namespace : SubmitDataFormat Enumeration

Specifies the available data formats for submitting the form data.

Syntax

Visual Basic (Declaration)
Public Enum SubmitDataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SubmitDataFormat
C#
public enum SubmitDataFormat : Enum
Delphi
public enum SubmitDataFormat = class(Enum)
Managed Extensions for C++
__value public enum SubmitDataFormat : public Enum
C++/CLI
public enum class SubmitDataFormat : public Enum

Members

Member | Description
HTML | The field names and values are submitted in HTML Form format.
FDF | The field names and values are submitted in FDF format.
XFDF | The field names and values are submitted in XFDF format.
PDF | The entire PDF file is submitted.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.SubmitDataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Annotations Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDF3DActivation | Defines how the annotation is activated and deactivated.
PDF3DAnimation | Defines the lighting to apply to 3D artwork.
PDF3DAnnotation | Defines a 3D annotation.
PDF3DBackground | Defines the background appearance for 3D artwork.
PDF3DCrossSection | Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
PDF3DCrossSectionCollection | Defines a collection of PDF3DCrossSection objects.
PDF3DEntity | Defines the base class for all 3D related classes.
PDF3DLightingScheme | Defines the lighting to apply to 3D artwork.
PDF3DNode | Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
PDF3DNodeCollection | Defines a collection of PDF3DNode objects.
PDF3DProjection | Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
PDF3DRenderMode | Defines the style in which the 3D artwork is rendered.
PDF3DStream | Defines the stream that contains the 3D artwork.
PDF3DView | Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
PDF3DViewCollection | Defines a collection of PDF3DView objects.
PDFAnnotation | Defines an annotation in a PDF file.
PDFAnnotationBorder | This class defines the appearance of an annotation's border.
PDFAnnotations | Defines a collection of annotations displayed on a PDF page.
PDFBaseMarkupAnnotation | Defines the base class for all markup type annotations.
PDFCircleAnnotation | Defines a circle annotation on a page.
PDFFileAttachmentAnnotation | Defines a file attachment annotation in a PDF file.
PDFFreeTextAnnotation | Defines a free text annotation on a page.
PDFLineAnnotation | Defines a line annotation on a page.
PDFLinkAnnotation | Defines a link annotation.
PDFMarkupAnnotation | Defines a markup annotation on a page.
PDFMovieAnnotation | Defines a movie annotation in a PDF file.
PDFRubberStampAnnotation | Defines a rubber stamp annotation on a page.
PDFSquareAnnotation | Defines a square annotation on a page.
PDFTextAnnotation | Defines a text annotation on a page.

Enumerations

Enumeration | Description
AnnotationFlags | Specifies the available flags for an annotation.
BorderStyle | Specifies the available styles for an annotation's border.
FileAttachmentAnnotationIcon | Specifies the available icons for a file atachment annotation when the annotation is closed.
LineEndingStyle | Specifies the available line ending styles to be used when drawing a line annotation.
LinkHighlightMode | Specifies the available highlighting modes for a link annotation.
MarkupStyle | Specifies the available markup styles to be used when drawing a markup annotation.
MovieType | Specifies the available movie types to be included in a PDF document.
PDF3DActivationMode | Specifies the available modes for activating a 3D annotation.
PDF3DActivationState | Specifies the available states upon activation of the 3D annotation.
PDF3DAnimationType | Specifies the available styles for applying light to 3D artwork.
PDF3DDeactivationMode | Specifies the available modes for activating a 3D annotation.
PDF3DDeactivationState | Specifies the available states upon deactivation of the 3D annotation.
PDF3DLightingStyle | Specifies the available styles for applying light to 3D artwork.
PDF3DProjectionClipStyle | Specifies the available styles for the projection clipping.
PDF3DProjectionOrthoScaleMode | Specifies the available scaling modes for orthographic projections.
PDF3DProjectionType | Specifies the available types for the projection of 3D artwork.
PDF3DRenderStyle | Specifies the available styles for rendering the 3D artwork.
RubberStampAnnotationIcon | Specifies the available icons for a rubber stamp annotation when the annotation is closed.
TextAnnotationIcon | Specifies the available icons for a text annotation when the annotation is closed.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Annotations Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DView
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFCircleAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquareAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Annotations.PDFAnnotations
System.Collections.CollectionBase
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDF3DActivation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

Defines how the annotation is activated and deactivated.

Syntax

Visual Basic (Declaration)
Public Class PDF3DActivation
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
C#
public class PDF3DActivation : PDF3DEntity
Delphi
public class PDF3DActivation = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DActivation : public PDF3DEntity
C++/CLI
public ref class PDF3DActivation : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DActivation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

The following tables list the members exposed by PDF3DActivation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DActivation Constructor | Initializes a new PDF3DActivation object.
Top

Public Properties

 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top

See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DActivation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : PDF3DActivation Constructor

Initializes a new PDF3DActivation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation()
C#
public PDF3DActivation()
Delphi
public PDF3DActivation();
Managed Extensions for C++
public: PDF3DActivation();
C++/CLI
public:
PDF3DActivation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%% $$Properties$$

PDF3DActivation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

For a list of all members of this type, see PDF3DActivation members.

Public Properties

 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top

See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

ActivationMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationMode Property

Gets or sets the activation mode for the annotation.

Syntax

Visual Basic (Declaration)
Public Property ActivationMode As PDF3DActivationMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DActivationMode

instance.ActivationMode = value

value = instance.ActivationMode
C#
public PDF3DActivationMode ActivationMode {get; set;}
Delphi
public read-write property ActivationMode: PDF3DActivationMode;
Managed Extensions for C++
public: __property PDF3DActivationMode get_ActivationMode();
public: __property void set_ActivationMode(
   PDF3DActivationMode value
);
C++/CLI
public:
property PDF3DActivationMode ActivationMode {
   PDF3DActivationMode get();
   void set (PDF3DActivationMode value);
}

Return Value

A PDF3DActivationMode enumeration member specifying the circumstances under which the annotation should be activated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

ActivationState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationState Property

Gets or sets the activation state for the annotation.

Syntax

Visual Basic (Declaration)
Public Property ActivationState As PDF3DActivationState
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DActivationState

instance.ActivationState = value

value = instance.ActivationState
C#
public PDF3DActivationState ActivationState {get; set;}
Delphi
public read-write property ActivationState: PDF3DActivationState;
Managed Extensions for C++
public: __property PDF3DActivationState get_ActivationState();
public: __property void set_ActivationState(
   PDF3DActivationState value
);
C++/CLI
public:
property PDF3DActivationState ActivationState {
   PDF3DActivationState get();
   void set (PDF3DActivationState value);
}

Return Value

A PDF3DActivationState enumeration member specifying the state of the artwork instance upon activation of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

DeactivationMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationMode Property

Gets or sets the deactivation mode for the annotation.

Syntax

Visual Basic (Declaration)
Public Property DeactivationMode As PDF3DDeactivationMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationMode

instance.DeactivationMode = value

value = instance.DeactivationMode
C#
public PDF3DDeactivationMode DeactivationMode {get; set;}
Delphi
public read-write property DeactivationMode: PDF3DDeactivationMode;
Managed Extensions for C++
public: __property PDF3DDeactivationMode get_DeactivationMode();
public: __property void set_DeactivationMode(
   PDF3DDeactivationMode value
);
C++/CLI
public:
property PDF3DDeactivationMode DeactivationMode {
   PDF3DDeactivationMode get();
   void set (PDF3DDeactivationMode value);
}

Return Value

A PDF3DDeactivationMode enumeration member specifying the circumstances under which the annotation should be deactivated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

DeactivationState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationState Property

Gets or sets the deactivation state for the annotation.

Syntax

Visual Basic (Declaration)
Public Property DeactivationState As PDF3DDeactivationState
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationState

instance.DeactivationState = value

value = instance.DeactivationState
C#
public PDF3DDeactivationState DeactivationState {get; set;}
Delphi
public read-write property DeactivationState: PDF3DDeactivationState;
Managed Extensions for C++
public: __property PDF3DDeactivationState get_DeactivationState();
public: __property void set_DeactivationState(
   PDF3DDeactivationState value
);
C++/CLI
public:
property PDF3DDeactivationState DeactivationState {
   PDF3DDeactivationState get();
   void set (PDF3DDeactivationState value);
}

Return Value

A PDF3DDeactivationState enumeration member specifying the state of the artwork instance upon deactivation of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

ShowToolbar Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowToolbar Property

Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.

Syntax

Visual Basic (Declaration)
Public Property ShowToolbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowToolbar = value

value = instance.ShowToolbar
C#
public bool ShowToolbar {get; set;}
Delphi
public read-write property ShowToolbar: Boolean;
Managed Extensions for C++
public: __property bool get_ShowToolbar();
public: __property void set_ShowToolbar(
   bool value
);
C++/CLI
public:
property bool ShowToolbar {
   bool get();
   void set (bool value);
}

Return Value

If true, a toolbar should be displayed by default when the annotation is activated and given focus. If false, a toolbar should not be displayed by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

ShowUI Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowUI Property

Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.

Syntax

Visual Basic (Declaration)
Public Property ShowUI As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowUI = value

value = instance.ShowUI
C#
public bool ShowUI {get; set;}
Delphi
public read-write property ShowUI: Boolean;
Managed Extensions for C++
public: __property bool get_ShowUI();
public: __property void set_ShowUI(
   bool value
);
C++/CLI
public:
property bool ShowUI {
   bool get();
   void set (bool value);
}

Return Value

If true, the user interface should be made visible when the annotation is activated. If false, the user interface should not be made visible by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

PDF3DAnimation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

Defines the lighting to apply to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Class PDF3DAnimation
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
C#
public class PDF3DAnimation : PDF3DEntity
Delphi
public class PDF3DAnimation = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DAnimation : public PDF3DEntity
C++/CLI
public ref class PDF3DAnimation : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DAnimation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DAnimation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

The following tables list the members exposed by PDF3DAnimation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DAnimation Constructor | Overloaded. Initializes a new PDF3DAnimation object.
Top

Public Properties

 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top

See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnimation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PDF3DAnimation Constructor

Initializes a new PDF3DAnimation object.

Overload List

Overload | Description
PDF3DAnimation Constructor() | Initializes a new PDF3DAnimation object.
PDF3DAnimation Constructor(PDF3DAnimationType) | Initializes a new PDF3DAnimation object with a new type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

PDF3DAnimation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor()

Initializes a new PDF3DAnimation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation()
C#
public PDF3DAnimation()
Delphi
public PDF3DAnimation();
Managed Extensions for C++
public: PDF3DAnimation();
C++/CLI
public:
PDF3DAnimation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


%%PageItemTitle%%

PDF3DAnimation Constructor(PDF3DAnimationType)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor(PDF3DAnimationType)

type
Initializes a new PDF3DAnimation object with a new type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As PDF3DAnimationType _
)
Visual Basic (Usage) Copy Code
Dim type As PDF3DAnimationType

Dim instance As PDF3DAnimation(type)
C#
public PDF3DAnimation(
   PDF3DAnimationType type
)
Delphi
public PDF3DAnimation(
    type: PDF3DAnimationType
);
Managed Extensions for C++
public: PDF3DAnimation(
   PDF3DAnimationType type
)
C++/CLI
public:
PDF3DAnimation(
   PDF3DAnimationType type
)

Parameters

type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DAnimation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

For a list of all members of this type, see PDF3DAnimation members.

Public Properties

 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top

See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PlayCount Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PlayCount Property

Gets or sets the play count.

Syntax

Visual Basic (Declaration)
Public Property PlayCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As Integer

instance.PlayCount = value

value = instance.PlayCount
C#
public int PlayCount {get; set;}
Delphi
public read-write property PlayCount: Integer;
Managed Extensions for C++
public: __property int get_PlayCount();
public: __property void set_PlayCount(
   int value
);
C++/CLI
public:
property int PlayCount {
   int get();
   void set (int value);
}

Return Value

An integer specifying the play count for this animation.

Remarks

A non-negative integer represents the number of times the animation is played. A negative integer indicates that the animation is infinitely repeated. This value is ignored for animation types of PDF3DAnimationType.None.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

TimeMultiplier Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : TimeMultiplier Property

Gets or sets the time multiplier for the animation.

Syntax

Visual Basic (Declaration)
Public Property TimeMultiplier As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As Single

instance.TimeMultiplier = value

value = instance.TimeMultiplier
C#
public float TimeMultiplier {get; set;}
Delphi
public read-write property TimeMultiplier: Single;
Managed Extensions for C++
public: __property float get_TimeMultiplier();
public: __property void set_TimeMultiplier(
   float value
);
C++/CLI
public:
property float TimeMultiplier {
   float get();
   void set (float value);
}

Return Value

A positive number specifying the time multiplier to be used when running the animation.

Remarks

A value greater than one shortens the time it takes to play the animation, or effectively speeds up the animation. This value is ignored for animation types of PDF3DAnimationType.None.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

Type Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : Type Property

Gets or sets the animation type.

Syntax

Visual Basic (Declaration)
Public Property Type As PDF3DAnimationType
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As PDF3DAnimationType

instance.Type = value

value = instance.Type
C#
public PDF3DAnimationType Type {get; set;}
Delphi
public read-write property Type: PDF3DAnimationType;
Managed Extensions for C++
public: __property PDF3DAnimationType get_Type();
public: __property void set_Type(
   PDF3DAnimationType value
);
C++/CLI
public:
property PDF3DAnimationType Type {
   PDF3DAnimationType get();
   void set (PDF3DAnimationType value);
}

Return Value

A PDF3DAnimationType enumeration member specifying the animation type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

PDF3DAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

Defines a 3D annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
C#
public class PDF3DAnnotation : PDFAnnotation
Delphi
public class PDF3DAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDF3DAnnotation : public PDFAnnotation
C++/CLI
public ref class PDF3DAnnotation : public PDFAnnotation

Remarks

3D annotations allow to include 3D artwork in PDF files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

The following tables list the members exposed by PDF3DAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DAnnotation Constructor | Initializes a new PDF3DAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : PDF3DAnnotation Constructor

Initializes a new PDF3DAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation()
C#
public PDF3DAnnotation()
Delphi
public PDF3DAnnotation();
Managed Extensions for C++
public: PDF3DAnnotation();
C++/CLI
public:
PDF3DAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%% $$Properties$$

PDF3DAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

For a list of all members of this type, see PDF3DAnnotation members.

Public Properties

 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Activation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Activation Property

Gets or sets the activation options for the annotation.

Syntax

Visual Basic (Declaration)
Public Property Activation As PDF3DActivation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDF3DActivation

instance.Activation = value

value = instance.Activation
C#
public PDF3DActivation Activation {get; set;}
Delphi
public read-write property Activation: PDF3DActivation;
Managed Extensions for C++
public: __property PDF3DActivation* get_Activation();
public: __property void set_Activation(
   PDF3DActivation* value
);
C++/CLI
public:
property PDF3DActivation^ Activation {
   PDF3DActivation^ get();
   void set (PDF3DActivation^ value);
}

Return Value

A PDF3DActivation object specifying the activation options for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%%

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Public Property Appearance As PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDFFormXObject

instance.Appearance = value

value = instance.Appearance
C#
public PDFFormXObject Appearance {get; set;}
Delphi
public read-write property Appearance: PDFFormXObject;
Managed Extensions for C++
public: __property PDFFormXObject* get_Appearance();
public: __property void set_Appearance(
   PDFFormXObject* value
);
C++/CLI
public:
property PDFFormXObject^ Appearance {
   PDFFormXObject^ get();
   void set (PDFFormXObject^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying the visual appearance of the 3D annotation.

Remarks

The annotation appearance is displayed when the annotation is deactivated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%%

Stream Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Stream Property

Gets or sets the 3D stream associated with the annotation.

Syntax

Visual Basic (Declaration)
Public Property Stream As PDF3DStream
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDF3DStream

instance.Stream = value

value = instance.Stream
C#
public PDF3DStream Stream {get; set;}
Delphi
public read-write property Stream: PDF3DStream;
Managed Extensions for C++
public: __property PDF3DStream* get_Stream();
public: __property void set_Stream(
   PDF3DStream* value
);
C++/CLI
public:
property PDF3DStream^ Stream {
   PDF3DStream^ get();
   void set (PDF3DStream^ value);
}

Return Value

A PDF3DStream object specifying the stream containing the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%%

PDF3DBackground Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

Defines the background appearance for 3D artwork.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DBackground
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
C#
public class PDF3DBackground : PDF3DEntity
Delphi
public class PDF3DBackground = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DBackground : public PDF3DEntity
C++/CLI
public ref class PDF3DBackground : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DBackground

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DBackground Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

The following tables list the members exposed by PDF3DBackground.

Public Constructors

 | Name | Description
Public Constructor | PDF3DBackground Constructor | Overloaded. Initializes a new PDF3DBackground object.
Top

Public Properties

 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top

See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DBackground Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : PDF3DBackground Constructor

Initializes a new PDF3DBackground object.

Overload List

Overload | Description
PDF3DBackground Constructor() | Initializes a new PDF3DBackground object.
PDF3DBackground Constructor(PDFColor) | Initializes a new PDF3DBackground object with a new color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


%%PageItemTitle%%

PDF3DBackground Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor()

Initializes a new PDF3DBackground object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground()
C#
public PDF3DBackground()
Delphi
public PDF3DBackground();
Managed Extensions for C++
public: PDF3DBackground();
C++/CLI
public:
PDF3DBackground();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


%%PageItemTitle%%

PDF3DBackground Constructor(PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor(PDFColor)

color
The background color.
Initializes a new PDF3DBackground object with a new color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFColor

Dim instance As PDF3DBackground(color)
C#
public PDF3DBackground(
   PDFColor color
)
Delphi
public PDF3DBackground(
    color: PDFColor
);
Managed Extensions for C++
public: PDF3DBackground(
   PDFColor* color
)
C++/CLI
public:
PDF3DBackground(
   PDFColor^ color
)

Parameters

color
The background color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DBackground Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

For a list of all members of this type, see PDF3DBackground members.

Public Properties

 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top

See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

ApplyToEntireAnnotation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : ApplyToEntireAnnotation Property

Gets or sets a value indicating how the background is applied.

Syntax

Visual Basic (Declaration)
Public Property ApplyToEntireAnnotation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
Dim value As Boolean

instance.ApplyToEntireAnnotation = value

value = instance.ApplyToEntireAnnotation
C#
public bool ApplyToEntireAnnotation {get; set;}
Delphi
public read-write property ApplyToEntireAnnotation: Boolean;
Managed Extensions for C++
public: __property bool get_ApplyToEntireAnnotation();
public: __property void set_ApplyToEntireAnnotation(
   bool value
);
C++/CLI
public:
property bool ApplyToEntireAnnotation {
   bool get();
   void set (bool value);
}

Return Value

True if the background is applied to entire annotation, false if the background is applied to annotation's 3D view box only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : Color Property

Gets or sets the background color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public PDFColor Color {get; set;}
Delphi
public read-write property Color: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the background color for the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


%%PageItemTitle%%

PDF3DCrossSection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DCrossSection
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
C#
public class PDF3DCrossSection : PDF3DEntity
Delphi
public class PDF3DCrossSection = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DCrossSection : public PDF3DEntity
C++/CLI
public ref class PDF3DCrossSection : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DCrossSection Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

The following tables list the members exposed by PDF3DCrossSection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DCrossSection Constructor | Initializes a new PDF3DCrossSection object.
Top

Public Properties

 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top

See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DCrossSection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : PDF3DCrossSection Constructor

Initializes a new PDF3DCrossSection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection()
C#
public PDF3DCrossSection()
Delphi
public PDF3DCrossSection();
Managed Extensions for C++
public: PDF3DCrossSection();
C++/CLI
public:
PDF3DCrossSection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%% $$Properties$$

PDF3DCrossSection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

For a list of all members of this type, see PDF3DCrossSection members.

Public Properties

 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top

See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Center Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Center Property

Gets or sets the center of the cutting plane.

Syntax

Visual Basic (Declaration)
Public Property Center As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value() As Single

instance.Center = value

value = instance.Center
C#
public float[] Center {get; set;}
Delphi
public read-write property Center: array of Single;
Managed Extensions for C++
public: __property float[]* get_Center();
public: __property void set_Center(
   float[]* value
);
C++/CLI
public:
property array<float>^ Center {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A three element array specifying the center of rotation on the cutting plane in world space coordinates.

Remarks

If the array has more than 3 elements, only the first 3 will be considered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Color Property

Gets or sets the cutting plane color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public PDFColor Color {get; set;}
Delphi
public read-write property Color: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of the cutting plane.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

IntersectionColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionColor Property

Gets or sets the intersection color.

Syntax

Visual Basic (Declaration)
Public Property IntersectionColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As PDFColor

instance.IntersectionColor = value

value = instance.IntersectionColor
C#
public PDFColor IntersectionColor {get; set;}
Delphi
public read-write property IntersectionColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_IntersectionColor();
public: __property void set_IntersectionColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ IntersectionColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of the the intersection of cutting plane with 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

IntersectionIsVisible Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionIsVisible Property

Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.

Syntax

Visual Basic (Declaration)
Public Property IntersectionIsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As Boolean

instance.IntersectionIsVisible = value

value = instance.IntersectionIsVisible
C#
public bool IntersectionIsVisible {get; set;}
Delphi
public read-write property IntersectionIsVisible: Boolean;
Managed Extensions for C++
public: __property bool get_IntersectionIsVisible();
public: __property void set_IntersectionIsVisible(
   bool value
);
C++/CLI
public:
property bool IntersectionIsVisible {
   bool get();
   void set (bool value);
}

Return Value

True if the intersection of cutting plane with 3D artwork is visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Opacity Property

Gets or sets the cutting plane opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}
Delphi
public read-write property Opacity: Single;
Managed Extensions for C++
public: __property float get_Opacity();
public: __property void set_Opacity(
   float value
);
C++/CLI
public:
property float Opacity {
   float get();
   void set (float value);
}

Return Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Orientation Property

Gets or sets the orientation of the cutting plane.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Object()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value() As Object

instance.Orientation = value

value = instance.Orientation
C#
public object[] Orientation {get; set;}
Delphi
public read-write property Orientation: array of TObject;
Managed Extensions for C++
public: __property Object*[]* get_Orientation();
public: __property void set_Orientation(
   Object*[]* value
);
C++/CLI
public:
property array<Object^>^ Orientation {
   array<Object^>^ get();
   void set (Object^array<value>^ value);
}

Return Value

A three-element array specifying the orientation of the cutting plane in world space, where each value represents the orientation in relation to the X, Y, and Z axes, respectively.

Remarks

If the array has more than 3 elements, only the first 3 will be considered.
Exactly one of the values must be null, indicating an initial state of the cutting plane that is perpendicular to the corresponding axis and clipping all geometry on the positive side of that axis. The other two values must be numbers indicating the rotation of the plane, in degrees, around their corresponding axes. The order in which these rotations are applied should match the order in which the values appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

PDF3DCrossSectionCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

Defines a collection of PDF3DCrossSection objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDF3DCrossSectionCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
C#
[DefaultMemberAttribute("Item")]
public class PDF3DCrossSectionCollection : CollectionBase
Delphi
public class PDF3DCrossSectionCollection = class(CollectionBase)
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDF3DCrossSectionCollection : public CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDF3DCrossSectionCollection : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DCrossSectionCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

The following tables list the members exposed by PDF3DCrossSectionCollection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DCrossSectionCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DCrossSection object at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DCrossSectionCollection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : PDF3DCrossSectionCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection()
C#
public PDF3DCrossSectionCollection()
Delphi
public PDF3DCrossSectionCollection();
Managed Extensions for C++
public: PDF3DCrossSectionCollection();
C++/CLI
public:
PDF3DCrossSectionCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%% $$Methods$$

PDF3DCrossSectionCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : Add Method

value
The element to add.
Adds a new element to collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As PDF3DCrossSection _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim value As PDF3DCrossSection
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   PDF3DCrossSection value
)
Delphi
public function Add(
    value: PDF3DCrossSection
): Integer;
Managed Extensions for C++
public: int Add(
   PDF3DCrossSection* value
)
C++/CLI
public:
int Add(
   PDF3DCrossSection^ value
)

Parameters

value
The element to add.

Return Value

Position of the element in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%%

Contains Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : Contains Method

value
The element to search for.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As PDF3DCrossSection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim value As PDF3DCrossSection
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   PDF3DCrossSection value
)
Delphi
public function Contains(
    value: PDF3DCrossSection
): Boolean;
Managed Extensions for C++
public: bool Contains(
   PDF3DCrossSection* value
)
C++/CLI
public:
bool Contains(
   PDF3DCrossSection^ value
)

Parameters

value
The element to search for.

Return Value

True if the element exists in the collection, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : IndexOf Method

value
Element to search.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As PDF3DCrossSection _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim value As PDF3DCrossSection
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   PDF3DCrossSection value
)
Delphi
public function IndexOf(
    value: PDF3DCrossSection
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDF3DCrossSection* value
)
C++/CLI
public:
int IndexOf(
   PDF3DCrossSection^ value
)

Parameters

value
Element to search.

Return Value

Index of the element in the collection, if exists, or -1 if the element does not exist in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : Insert Method

index
Index where to insert the element.
value
Element to insert in the collection.
Inserts an element in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As PDF3DCrossSection _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim index As Integer
Dim value As PDF3DCrossSection

instance.Insert(index, value)
C#
public void Insert(
   int index,
   PDF3DCrossSection value
)
Delphi
public procedure Insert(
    index: Integer;
    value: PDF3DCrossSection
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDF3DCrossSection* value
)
C++/CLI
public:
void Insert(
   int index,
   PDF3DCrossSection^ value
)

Parameters

index
Index where to insert the element.
value
Element to insert in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : Remove Method

value
The element to remove.
Removes the element from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As PDF3DCrossSection _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim value As PDF3DCrossSection

instance.Remove(value)
C#
public void Remove(
   PDF3DCrossSection value
)
Delphi
public procedure Remove(
    value: PDF3DCrossSection
);
Managed Extensions for C++
public: void Remove(
   PDF3DCrossSection* value
)
C++/CLI
public:
void Remove(
   PDF3DCrossSection^ value
)

Parameters

value
The element to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%% $$Properties$$

PDF3DCrossSectionCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DCrossSection object at the specified index.
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSectionCollection Class : Item Property

index
Gets or sets the PDF3DCrossSection object at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDF3DCrossSection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
Dim index As Integer
Dim value As PDF3DCrossSection

instance.Item(index) = value

value = instance.Item(index)
C#
public PDF3DCrossSection this[
   int index
]; {get; set;}
Delphi
public  this: : PDF3DCrossSection;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDF3DCrossSection* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDF3DCrossSection* value
);
C++/CLI
public:
property PDF3DCrossSection^ default [int] {
   PDF3DCrossSection^ get(int index);
   void set (int index, PDF3DCrossSection^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Class
PDF3DCrossSectionCollection Members


%%PageItemTitle%%

PDF3DEntity Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class

Defines the base class for all 3D related classes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDF3DEntity
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDF3DEntity
C#
public abstract class PDF3DEntity : PDFObject
Delphi
public class PDF3DEntity = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDF3DEntity : public PDFObject
C++/CLI
public ref class PDF3DEntity abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DView
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DActivation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DEntity Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DEntity Class Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class

The following tables list the members exposed by PDF3DEntity.

Public Constructors

 | Name | Description
Public Constructor | PDF3DEntity Constructor | Initializes a new PDF3DEntity object.
Top

See Also

Reference

PDF3DEntity Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DEntity Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DEntity Class : PDF3DEntity Constructor

Initializes a new PDF3DEntity object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DEntity()
C#
public PDF3DEntity()
Delphi
public PDF3DEntity();
Managed Extensions for C++
public: PDF3DEntity();
C++/CLI
public:
PDF3DEntity();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DEntity Class
PDF3DEntity Members


%%PageItemTitle%%

PDF3DLightingScheme Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

Defines the lighting to apply to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Class PDF3DLightingScheme
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme
C#
public class PDF3DLightingScheme : PDF3DEntity
Delphi
public class PDF3DLightingScheme = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DLightingScheme : public PDF3DEntity
C++/CLI
public ref class PDF3DLightingScheme : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DLightingScheme Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

The following tables list the members exposed by PDF3DLightingScheme.

Public Constructors

 | Name | Description
Public Constructor | PDF3DLightingScheme Constructor | Overloaded. Initializes a new PDF3DLightingScheme object.
Top

Public Properties

 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top

See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DLightingScheme Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : PDF3DLightingScheme Constructor

Initializes a new PDF3DLightingScheme object.

Overload List

Overload | Description
PDF3DLightingScheme Constructor() | Initializes a new PDF3DLightingScheme object.
PDF3DLightingScheme Constructor(PDF3DLightingStyle) | Initializes a new PDF3DLightingScheme object with a new lighting style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


%%PageItemTitle%%

PDF3DLightingScheme Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor()

Initializes a new PDF3DLightingScheme object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme()
C#
public PDF3DLightingScheme()
Delphi
public PDF3DLightingScheme();
Managed Extensions for C++
public: PDF3DLightingScheme();
C++/CLI
public:
PDF3DLightingScheme();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


%%PageItemTitle%%

PDF3DLightingScheme Constructor(PDF3DLightingStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor(PDF3DLightingStyle)

style
The lighting style.
Initializes a new PDF3DLightingScheme object with a new lighting style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As PDF3DLightingStyle _
)
Visual Basic (Usage) Copy Code
Dim style As PDF3DLightingStyle

Dim instance As PDF3DLightingScheme(style)
C#
public PDF3DLightingScheme(
   PDF3DLightingStyle style
)
Delphi
public PDF3DLightingScheme(
    style: PDF3DLightingStyle
);
Managed Extensions for C++
public: PDF3DLightingScheme(
   PDF3DLightingStyle style
)
C++/CLI
public:
PDF3DLightingScheme(
   PDF3DLightingStyle style
)

Parameters

style
The lighting style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DLightingScheme Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

For a list of all members of this type, see PDF3DLightingScheme members.

Public Properties

 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top

See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Style Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : Style Property

Gets or sets the style for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Style As PDF3DLightingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme
Dim value As PDF3DLightingStyle

instance.Style = value

value = instance.Style
C#
public PDF3DLightingStyle Style {get; set;}
Delphi
public read-write property Style: PDF3DLightingStyle;
Managed Extensions for C++
public: __property PDF3DLightingStyle get_Style();
public: __property void set_Style(
   PDF3DLightingStyle value
);
C++/CLI
public:
property PDF3DLightingStyle Style {
   PDF3DLightingStyle get();
   void set (PDF3DLightingStyle value);
}

Return Value

A PDF3DLightingStyle enumeration member specifying the style for applying light to 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


%%PageItemTitle%%

PDF3DNode Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.

Syntax

Visual Basic (Declaration)
Public Class PDF3DNode
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
C#
public class PDF3DNode : PDF3DEntity
Delphi
public class PDF3DNode = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DNode : public PDF3DEntity
C++/CLI
public ref class PDF3DNode : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DNode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DNode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

The following tables list the members exposed by PDF3DNode.

Public Constructors

 | Name | Description
Public Constructor | PDF3DNode Constructor | Initializes a new PDF3DNode object.
Top

Public Properties

 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top

See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DNode Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : PDF3DNode Constructor

Initializes a new PDF3DNode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode()
C#
public PDF3DNode()
Delphi
public PDF3DNode();
Managed Extensions for C++
public: PDF3DNode();
C++/CLI
public:
PDF3DNode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%% $$Properties$$

PDF3DNode Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

For a list of all members of this type, see PDF3DNode members.

Public Properties

 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top

See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Matrix Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Matrix Property

Gets or sets the 3D transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property Matrix As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value() As Single

instance.Matrix = value

value = instance.Matrix
C#
public float[] Matrix {get; set;}
Delphi
public read-write property Matrix: array of Single;
Managed Extensions for C++
public: __property float[]* get_Matrix();
public: __property void set_Matrix(
   float[]* value
);
C++/CLI
public:
property array<float>^ Matrix {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A 12-element 3D transformation matrix that specifies the position and orientation of this node, relative to its parent, in world coordinates.

Remarks

If the array has more than 12 elements, only the first 12 will be considered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Name Property

Gets or sets the node name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the 3D node (in the 3D content stream) being described by this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Opacity Property

Gets or sets the cutting plane opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}
Delphi
public read-write property Opacity: Single;
Managed Extensions for C++
public: __property float get_Opacity();
public: __property void set_Opacity(
   float value
);
C++/CLI
public:
property float Opacity {
   float get();
   void set (float value);
}

Return Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

Visible Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Visible Property

Gets or sets a value indicating whether the node is visible or not.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Delphi
public read-write property Visible: Boolean;
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Return Value

True if the node is visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

PDF3DNodeCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

Defines a collection of PDF3DNode objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDF3DNodeCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
C#
[DefaultMemberAttribute("Item")]
public class PDF3DNodeCollection : CollectionBase
Delphi
public class PDF3DNodeCollection = class(CollectionBase)
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDF3DNodeCollection : public CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDF3DNodeCollection : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DNodeCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

The following tables list the members exposed by PDF3DNodeCollection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DNodeCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DNode object at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DNodeCollection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : PDF3DNodeCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection()
C#
public PDF3DNodeCollection()
Delphi
public PDF3DNodeCollection();
Managed Extensions for C++
public: PDF3DNodeCollection();
C++/CLI
public:
PDF3DNodeCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%% $$Methods$$

PDF3DNodeCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : Add Method

value
The element to add.
Adds a new element to collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As PDF3DNode _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim value As PDF3DNode
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   PDF3DNode value
)
Delphi
public function Add(
    value: PDF3DNode
): Integer;
Managed Extensions for C++
public: int Add(
   PDF3DNode* value
)
C++/CLI
public:
int Add(
   PDF3DNode^ value
)

Parameters

value
The element to add.

Return Value

Position of the element in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%%

Contains Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : Contains Method

value
The element to search for.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As PDF3DNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim value As PDF3DNode
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   PDF3DNode value
)
Delphi
public function Contains(
    value: PDF3DNode
): Boolean;
Managed Extensions for C++
public: bool Contains(
   PDF3DNode* value
)
C++/CLI
public:
bool Contains(
   PDF3DNode^ value
)

Parameters

value
The element to search for.

Return Value

True if the element exists in the collection, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : IndexOf Method

value
Element to search.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As PDF3DNode _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim value As PDF3DNode
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   PDF3DNode value
)
Delphi
public function IndexOf(
    value: PDF3DNode
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDF3DNode* value
)
C++/CLI
public:
int IndexOf(
   PDF3DNode^ value
)

Parameters

value
Element to search.

Return Value

Index of the element in the collection, if exists, or -1 if the element does not exist in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : Insert Method

index
Index where to insert the element.
value
Element to insert in the collection.
Inserts an element in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As PDF3DNode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim index As Integer
Dim value As PDF3DNode

instance.Insert(index, value)
C#
public void Insert(
   int index,
   PDF3DNode value
)
Delphi
public procedure Insert(
    index: Integer;
    value: PDF3DNode
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDF3DNode* value
)
C++/CLI
public:
void Insert(
   int index,
   PDF3DNode^ value
)

Parameters

index
Index where to insert the element.
value
Element to insert in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : Remove Method

value
The element to remove.
Removes the element from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As PDF3DNode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim value As PDF3DNode

instance.Remove(value)
C#
public void Remove(
   PDF3DNode value
)
Delphi
public procedure Remove(
    value: PDF3DNode
);
Managed Extensions for C++
public: void Remove(
   PDF3DNode* value
)
C++/CLI
public:
void Remove(
   PDF3DNode^ value
)

Parameters

value
The element to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%% $$Properties$$

PDF3DNodeCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DNode object at the specified index.
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNodeCollection Class : Item Property

index
Gets or sets the PDF3DNode object at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDF3DNode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
Dim index As Integer
Dim value As PDF3DNode

instance.Item(index) = value

value = instance.Item(index)
C#
public PDF3DNode this[
   int index
]; {get; set;}
Delphi
public  this: : PDF3DNode;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDF3DNode* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDF3DNode* value
);
C++/CLI
public:
property PDF3DNode^ default [int] {
   PDF3DNode^ get(int index);
   void set (int index, PDF3DNode^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Class
PDF3DNodeCollection Members


%%PageItemTitle%%

PDF3DProjection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.

Syntax

Visual Basic (Declaration)
Public Class PDF3DProjection
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
C#
public class PDF3DProjection : PDF3DEntity
Delphi
public class PDF3DProjection = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DProjection : public PDF3DEntity
C++/CLI
public ref class PDF3DProjection : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DProjection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DProjection Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

The following tables list the members exposed by PDF3DProjection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DProjection Constructor | Overloaded. Initializes a new PDF3DProjection object.
Top

Public Properties

 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top

See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : PDF3DProjection Constructor

Initializes a new PDF3DProjection object.

Overload List

Overload | Description
PDF3DProjection Constructor() | Initializes a new PDF3DProjection object.
PDF3DProjection Constructor(PDF3DProjectionType) | Initializes a new PDF3DProjection object with the specified projection type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

PDF3DProjection Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor()

Initializes a new PDF3DProjection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection()
C#
public PDF3DProjection()
Delphi
public PDF3DProjection();
Managed Extensions for C++
public: PDF3DProjection();
C++/CLI
public:
PDF3DProjection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


%%PageItemTitle%%

PDF3DProjection Constructor(PDF3DProjectionType)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor(PDF3DProjectionType)

type
The projection with
Initializes a new PDF3DProjection object with the specified projection type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As PDF3DProjectionType _
)
Visual Basic (Usage) Copy Code
Dim type As PDF3DProjectionType

Dim instance As PDF3DProjection(type)
C#
public PDF3DProjection(
   PDF3DProjectionType type
)
Delphi
public PDF3DProjection(
    type: PDF3DProjectionType
);
Managed Extensions for C++
public: PDF3DProjection(
   PDF3DProjectionType type
)
C++/CLI
public:
PDF3DProjection(
   PDF3DProjectionType type
)

Parameters

type
The projection with

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DProjection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

For a list of all members of this type, see PDF3DProjection members.

Public Properties

 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top

See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

ClipStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : ClipStyle Property

Gets or sets the clipping style for the projection.

Syntax

Visual Basic (Declaration)
Public Property ClipStyle As PDF3DProjectionClipStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionClipStyle

instance.ClipStyle = value

value = instance.ClipStyle
C#
public PDF3DProjectionClipStyle ClipStyle {get; set;}
Delphi
public read-write property ClipStyle: PDF3DProjectionClipStyle;
Managed Extensions for C++
public: __property PDF3DProjectionClipStyle get_ClipStyle();
public: __property void set_ClipStyle(
   PDF3DProjectionClipStyle value
);
C++/CLI
public:
property PDF3DProjectionClipStyle ClipStyle {
   PDF3DProjectionClipStyle get();
   void set (PDF3DProjectionClipStyle value);
}

Return Value

A PDF3DProjectionClipStyle enumeration member specifying the clipping style for the projection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

FarClipDistance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FarClipDistance Property

Gets or sets the far clipping distance.

Syntax

Visual Basic (Declaration)
Public Property FarClipDistance As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Single

instance.FarClipDistance = value

value = instance.FarClipDistance
C#
public float FarClipDistance {get; set;}
Delphi
public read-write property FarClipDistance: Single;
Managed Extensions for C++
public: __property float get_FarClipDistance();
public: __property void set_FarClipDistance(
   float value
);
C++/CLI
public:
property float FarClipDistance {
   float get();
   void set (float value);
}

Return Value

The far clipping distance, expressed in the camera coordinate system.

Remarks

This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar.
A negative value for this property disables the far clipping.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

FieldOfView Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FieldOfView Property

Gets or sets the field of view.

Syntax

Visual Basic (Declaration)
Public Property FieldOfView As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Single

instance.FieldOfView = value

value = instance.FieldOfView
C#
public float FieldOfView {get; set;}
Delphi
public read-write property FieldOfView: Single;
Managed Extensions for C++
public: __property float get_FieldOfView();
public: __property void set_FieldOfView(
   float value
);
C++/CLI
public:
property float FieldOfView {
   float get();
   void set (float value);
}

Return Value

A number between 0 and 180, inclusive, specifying the field of view of the virtual camera, in degrees.

Remarks

This property has meaning only if Type is PDF3DProjectionType.Perspective.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

NearClipDistance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : NearClipDistance Property

Gets or sets the near clipping distance.

Syntax

Visual Basic (Declaration)
Public Property NearClipDistance As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Single

instance.NearClipDistance = value

value = instance.NearClipDistance
C#
public float NearClipDistance {get; set;}
Delphi
public read-write property NearClipDistance: Single;
Managed Extensions for C++
public: __property float get_NearClipDistance();
public: __property void set_NearClipDistance(
   float value
);
C++/CLI
public:
property float NearClipDistance {
   float get();
   void set (float value);
}

Return Value

The near clipping distance, expressed in the camera coordinate system.

Remarks

This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar or if Type is PDF3DProjectionType.Perspective.
This property must be non-negative for orthographic projections and greater than 0 for perspective projections.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

OrthoScaleMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : OrthoScaleMode Property

Gets or sets the scale mode for orthographic projections.

Syntax

Visual Basic (Declaration)
Public Property OrthoScaleMode As PDF3DProjectionOrthoScaleMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionOrthoScaleMode

instance.OrthoScaleMode = value

value = instance.OrthoScaleMode
C#
public PDF3DProjectionOrthoScaleMode OrthoScaleMode {get; set;}
Delphi
public read-write property OrthoScaleMode: PDF3DProjectionOrthoScaleMode;
Managed Extensions for C++
public: __property PDF3DProjectionOrthoScaleMode get_OrthoScaleMode();
public: __property void set_OrthoScaleMode(
   PDF3DProjectionOrthoScaleMode value
);
C++/CLI
public:
property PDF3DProjectionOrthoScaleMode OrthoScaleMode {
   PDF3DProjectionOrthoScaleMode get();
   void set (PDF3DProjectionOrthoScaleMode value);
}

Return Value

A PDF3DProjectionOrthoScaleMode enumeration member specifying a strategy for scaling to fit the near plane’s x and y coordinates onto the annotation’s target coordinate system.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

Scaling Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Scaling Property

Gets or sets the projection scaling.

Syntax

Visual Basic (Declaration)
Public Property Scaling As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Single

instance.Scaling = value

value = instance.Scaling
C#
public float Scaling {get; set;}
Delphi
public read-write property Scaling: Single;
Managed Extensions for C++
public: __property float get_Scaling();
public: __property void set_Scaling(
   float value
);
C++/CLI
public:
property float Scaling {
   float get();
   void set (float value);
}

Return Value

A positive number that specifies the scaling used when projecting the 3D artwork onto the annotation’s target coordinate system.

Remarks

This property has meaning only if Type is PDF3DProjectionType.Perspective.
A negative value for this property specifies default scaling for the projection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

Type Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Type Property

Gets or sets the type of the projection.

Syntax

Visual Basic (Declaration)
Public Property Type As PDF3DProjectionType
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionType

instance.Type = value

value = instance.Type
C#
public PDF3DProjectionType Type {get; set;}
Delphi
public read-write property Type: PDF3DProjectionType;
Managed Extensions for C++
public: __property PDF3DProjectionType get_Type();
public: __property void set_Type(
   PDF3DProjectionType value
);
C++/CLI
public:
property PDF3DProjectionType Type {
   PDF3DProjectionType get();
   void set (PDF3DProjectionType value);
}

Return Value

A PDF3DProjectionType enumeration member specifying the projection type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

PDF3DRenderMode Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

Defines the style in which the 3D artwork is rendered.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DRenderMode
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
C#
public class PDF3DRenderMode : PDF3DEntity
Delphi
public class PDF3DRenderMode = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DRenderMode : public PDF3DEntity
C++/CLI
public ref class PDF3DRenderMode : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DRenderMode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

The following tables list the members exposed by PDF3DRenderMode.

Public Constructors

 | Name | Description
Public Constructor | PDF3DRenderMode Constructor | Overloaded. Initializes a new PDF3DRenderMode object.
Top

Public Properties

 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top

See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DRenderMode Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : PDF3DRenderMode Constructor

Initializes a new PDF3DRenderMode object.

Overload List

Overload | Description
PDF3DRenderMode Constructor() | Initializes a new PDF3DRenderMode object.
PDF3DRenderMode Constructor(PDF3DRenderStyle) | Initializes a new PDF3DRenderMode object with a new render style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

PDF3DRenderMode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor()

Initializes a new PDF3DRenderMode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode()
C#
public PDF3DRenderMode()
Delphi
public PDF3DRenderMode();
Managed Extensions for C++
public: PDF3DRenderMode();
C++/CLI
public:
PDF3DRenderMode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


%%PageItemTitle%%

PDF3DRenderMode Constructor(PDF3DRenderStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor(PDF3DRenderStyle)

style
The rendering style.
Initializes a new PDF3DRenderMode object with a new render style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As PDF3DRenderStyle _
)
Visual Basic (Usage) Copy Code
Dim style As PDF3DRenderStyle

Dim instance As PDF3DRenderMode(style)
C#
public PDF3DRenderMode(
   PDF3DRenderStyle style
)
Delphi
public PDF3DRenderMode(
    style: PDF3DRenderStyle
);
Managed Extensions for C++
public: PDF3DRenderMode(
   PDF3DRenderStyle style
)
C++/CLI
public:
PDF3DRenderMode(
   PDF3DRenderStyle style
)

Parameters

style
The rendering style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DRenderMode Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

For a list of all members of this type, see PDF3DRenderMode members.

Public Properties

 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top

See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

AuxiliaryColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : AuxiliaryColor Property

Gets or sets the auxiliary color.

Syntax

Visual Basic (Declaration)
Public Property AuxiliaryColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDFColor

instance.AuxiliaryColor = value

value = instance.AuxiliaryColor
C#
public PDFColor AuxiliaryColor {get; set;}
Delphi
public read-write property AuxiliaryColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_AuxiliaryColor();
public: __property void set_AuxiliaryColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ AuxiliaryColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the auxiliary color to be used when rendering the 3D image.

Remarks

Auxiliary color is used by some of the 3D render styles.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

CreaseValue Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : CreaseValue Property

Gets or sets the crease value.

Syntax

Visual Basic (Declaration)
Public Property CreaseValue As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As Single

instance.CreaseValue = value

value = instance.CreaseValue
C#
public float CreaseValue {get; set;}
Delphi
public read-write property CreaseValue: Single;
Managed Extensions for C++
public: __property float get_CreaseValue();
public: __property void set_CreaseValue(
   float value
);
C++/CLI
public:
property float CreaseValue {
   float get();
   void set (float value);
}

Return Value

A number specifying the angle to be used as the crease value to be used when determining silhouette edges.

Remarks

The crease value is specified in degrees, from 0 to 360.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

FaceColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : FaceColor Property

Gets or sets the face color.

Syntax

Visual Basic (Declaration)
Public Property FaceColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDFColor

instance.FaceColor = value

value = instance.FaceColor
C#
public PDFColor FaceColor {get; set;}
Delphi
public read-write property FaceColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_FaceColor();
public: __property void set_FaceColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ FaceColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the face color to be used when rendering the 3D image.

Remarks

Face color is used only by Illustration render style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Opacity Property

Gets or sets the rendering opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}
Delphi
public read-write property Opacity: Single;
Managed Extensions for C++
public: __property float get_Opacity();
public: __property void set_Opacity(
   float value
);
C++/CLI
public:
property float Opacity {
   float get();
   void set (float value);
}

Return Value

A number specifying the opacity of the added transparency applied by some render modes.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

Style Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Style Property

Gets or sets the style for rendering the 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Style As PDF3DRenderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDF3DRenderStyle

instance.Style = value

value = instance.Style
C#
public PDF3DRenderStyle Style {get; set;}
Delphi
public read-write property Style: PDF3DRenderStyle;
Managed Extensions for C++
public: __property PDF3DRenderStyle get_Style();
public: __property void set_Style(
   PDF3DRenderStyle value
);
C++/CLI
public:
property PDF3DRenderStyle Style {
   PDF3DRenderStyle get();
   void set (PDF3DRenderStyle value);
}

Return Value

A PDF3DRenderStyle enumeration member specifying the style for rendering the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

PDF3DStream Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

Defines the stream that contains the 3D artwork.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DStream
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
C#
public class PDF3DStream : PDF3DEntity
Delphi
public class PDF3DStream = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DStream : public PDF3DEntity
C++/CLI
public ref class PDF3DStream : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DStream

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DStream Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

The following tables list the members exposed by PDF3DStream.

Public Constructors

 | Name | Description
Public Constructor | PDF3DStream Constructor | Initializes a new PDF3DStream object.
Top

Public Properties

 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top

See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DStream Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : PDF3DStream Constructor

Initializes a new PDF3DStream object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream()
C#
public PDF3DStream()
Delphi
public PDF3DStream();
Managed Extensions for C++
public: PDF3DStream();
C++/CLI
public:
PDF3DStream();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%% $$Properties$$

PDF3DStream Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

For a list of all members of this type, see PDF3DStream members.

Public Properties

 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top

See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Animation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Animation Property

Gets or sets the animation for this 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Animation As PDF3DAnimation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As PDF3DAnimation

instance.Animation = value

value = instance.Animation
C#
public PDF3DAnimation Animation {get; set;}
Delphi
public read-write property Animation: PDF3DAnimation;
Managed Extensions for C++
public: __property PDF3DAnimation* get_Animation();
public: __property void set_Animation(
   PDF3DAnimation* value
);
C++/CLI
public:
property PDF3DAnimation^ Animation {
   PDF3DAnimation^ get();
   void set (PDF3DAnimation^ value);
}

Return Value

A PDF3DAnimation object that defines the preferred method that viewer applications should use to drive keyframe animations present in this artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

Content Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Content Property

Gets or sets content of this stream.

Syntax

Visual Basic (Declaration)
Public Property Content As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value() As Byte

instance.Content = value

value = instance.Content
C#
public byte[] Content {get; set;}
Delphi
public read-write property Content: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_Content();
public: __property void set_Content(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Content {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that contains the 3D artwork in U3D format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

DefaultView Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : DefaultView Property

Gets or sets the default view.

Syntax

Visual Basic (Declaration)
Public Property DefaultView As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As Integer

instance.DefaultView = value

value = instance.DefaultView
C#
public int DefaultView {get; set;}
Delphi
public read-write property DefaultView: Integer;
Managed Extensions for C++
public: __property int get_DefaultView();
public: __property void set_DefaultView(
   int value
);
C++/CLI
public:
property int DefaultView {
   int get();
   void set (int value);
}

Return Value

Index in Views collection.

Remarks

If there are no views, this value is ignored. If the value is outside of the valid range, the first view is considered to be default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

OnInstantiate Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : OnInstantiate Property

Gets or sets the code to execute when the 3D artwork is instantiated.

Syntax

Visual Basic (Declaration)
Public Property OnInstantiate As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As String

instance.OnInstantiate = value

value = instance.OnInstantiate
C#
public string OnInstantiate {get; set;}
Delphi
public read-write property OnInstantiate: String;
Managed Extensions for C++
public: __property string* get_OnInstantiate();
public: __property void set_OnInstantiate(
   string* value
);
C++/CLI
public:
property String^ OnInstantiate {
   String^ get();
   void set (String^ value);
}

Return Value

Javascript code to be executed when the 3D artwork is instantiated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

Views Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Views Property

Gets the list of views for this 3D artwork.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Views As PDF3DViewCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As PDF3DViewCollection

value = instance.Views
C#
public PDF3DViewCollection Views {get;}
Delphi
public read-only property Views: PDF3DViewCollection;
Managed Extensions for C++
public: __property PDF3DViewCollection* get_Views();
C++/CLI
public:
property PDF3DViewCollection^ Views {
   PDF3DViewCollection^ get();
}

Return Value

A list of PDF3DViews objects available for this 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

PDF3DView Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

Defines the parameters to be applied to the virtual camera associated with a 3D annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DView
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
C#
public class PDF3DView : PDF3DEntity
Delphi
public class PDF3DView = class(PDF3DEntity)
Managed Extensions for C++
public __gc class PDF3DView : public PDF3DEntity
C++/CLI
public ref class PDF3DView : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DView Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

The following tables list the members exposed by PDF3DView.

Public Constructors

 | Name | Description
Public Constructor | PDF3DView Constructor | Initializes a new PDF3DView object.
Top

Public Properties

 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top

See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DView Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : PDF3DView Constructor

Initializes a new PDF3DView object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView()
C#
public PDF3DView()
Delphi
public PDF3DView();
Managed Extensions for C++
public: PDF3DView();
C++/CLI
public:
PDF3DView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%% $$Properties$$

PDF3DView Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

For a list of all members of this type, see PDF3DView members.

Public Properties

 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top

See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Background Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Background Property

Gets or sets the background for this view.

Syntax

Visual Basic (Declaration)
Public Property Background As PDF3DBackground
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DBackground

instance.Background = value

value = instance.Background
C#
public PDF3DBackground Background {get; set;}
Delphi
public read-write property Background: PDF3DBackground;
Managed Extensions for C++
public: __property PDF3DBackground* get_Background();
public: __property void set_Background(
   PDF3DBackground* value
);
C++/CLI
public:
property PDF3DBackground^ Background {
   PDF3DBackground^ get();
   void set (PDF3DBackground^ value);
}

Return Value

A PDF3DBackground object that defines the background over which the 3D artwork is to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

CameraToWorldMatrix Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CameraToWorldMatrix Property

Gets or sets the 3D transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property CameraToWorldMatrix As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value() As Single

instance.CameraToWorldMatrix = value

value = instance.CameraToWorldMatrix
C#
public float[] CameraToWorldMatrix {get; set;}
Delphi
public read-write property CameraToWorldMatrix: array of Single;
Managed Extensions for C++
public: __property float[]* get_CameraToWorldMatrix();
public: __property void set_CameraToWorldMatrix(
   float[]* value
);
C++/CLI
public:
property array<float>^ CameraToWorldMatrix {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A 12-element 3D transformation matrix that specifies a position and orientation of the camera in world coordinates.

Remarks

If the array has more than 12 elements, only the first 12 will be considered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

CenterOfOrbit Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CenterOfOrbit Property

Gets or sets the center of orbit for 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property CenterOfOrbit As Single
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As Single

instance.CenterOfOrbit = value

value = instance.CenterOfOrbit
C#
public float CenterOfOrbit {get; set;}
Delphi
public read-write property CenterOfOrbit: Single;
Managed Extensions for C++
public: __property float get_CenterOfOrbit();
public: __property void set_CenterOfOrbit(
   float value
);
C++/CLI
public:
property float CenterOfOrbit {
   float get();
   void set (float value);
}

Return Value

A non-negative number indicating a distance in the camera coordinate system along the z axis to the center of orbit for this view.

Remarks

If this value is negative, the viewer application must determine the center of orbit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

CrossSections Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CrossSections Property

Gets the list of cross sections for this view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CrossSections As PDF3DCrossSectionCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DCrossSectionCollection

value = instance.CrossSections
C#
public PDF3DCrossSectionCollection CrossSections {get;}
Delphi
public read-only property CrossSections: PDF3DCrossSectionCollection;
Managed Extensions for C++
public: __property PDF3DCrossSectionCollection* get_CrossSections();
C++/CLI
public:
property PDF3DCrossSectionCollection^ CrossSections {
   PDF3DCrossSectionCollection^ get();
}

Return Value

A list of PDF3DCrossSection objects available for this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

ExternalName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ExternalName Property

Gets or sets the view's external name.

Syntax

Visual Basic (Declaration)
Public Property ExternalName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.ExternalName = value

value = instance.ExternalName
C#
public string ExternalName {get; set;}
Delphi
public read-write property ExternalName: String;
Managed Extensions for C++
public: __property string* get_ExternalName();
public: __property void set_ExternalName(
   string* value
);
C++/CLI
public:
property String^ ExternalName {
   String^ get();
   void set (String^ value);
}

Return Value

The external name of the view, suitable for presentation in a user interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

InternalName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : InternalName Property

Gets or sets the view's internal name.

Syntax

Visual Basic (Declaration)
Public Property InternalName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.InternalName = value

value = instance.InternalName
C#
public string InternalName {get; set;}
Delphi
public read-write property InternalName: String;
Managed Extensions for C++
public: __property string* get_InternalName();
public: __property void set_InternalName(
   string* value
);
C++/CLI
public:
property String^ InternalName {
   String^ get();
   void set (String^ value);
}

Return Value

The internal name of the view, used to refer to the view from other objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

LightingScheme Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : LightingScheme Property

Gets or sets the rendering mode for this view.

Syntax

Visual Basic (Declaration)
Public Property LightingScheme As PDF3DLightingScheme
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DLightingScheme

instance.LightingScheme = value

value = instance.LightingScheme
C#
public PDF3DLightingScheme LightingScheme {get; set;}
Delphi
public read-write property LightingScheme: PDF3DLightingScheme;
Managed Extensions for C++
public: __property PDF3DLightingScheme* get_LightingScheme();
public: __property void set_LightingScheme(
   PDF3DLightingScheme* value
);
C++/CLI
public:
property PDF3DLightingScheme^ LightingScheme {
   PDF3DLightingScheme^ get();
   void set (PDF3DLightingScheme^ value);
}

Return Value

A PDF3DLightingScheme object that specifies the lighting scheme to be used when rendering 3D artwork with this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

Nodes Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Nodes Property

Gets the list of 3D nodes for this view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nodes As PDF3DNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DNodeCollection

value = instance.Nodes
C#
public PDF3DNodeCollection Nodes {get;}
Delphi
public read-only property Nodes: PDF3DNodeCollection;
Managed Extensions for C++
public: __property PDF3DNodeCollection* get_Nodes();
C++/CLI
public:
property PDF3DNodeCollection^ Nodes {
   PDF3DNodeCollection^ get();
}

Return Value

A list of PDF3DNode objects available for this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

Projection Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Projection Property

Gets or sets the projection for this view.

Syntax

Visual Basic (Declaration)
Public Property Projection As PDF3DProjection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DProjection

instance.Projection = value

value = instance.Projection
C#
public PDF3DProjection Projection {get; set;}
Delphi
public read-write property Projection: PDF3DProjection;
Managed Extensions for C++
public: __property PDF3DProjection* get_Projection();
public: __property void set_Projection(
   PDF3DProjection* value
);
C++/CLI
public:
property PDF3DProjection^ Projection {
   PDF3DProjection^ get();
   void set (PDF3DProjection^ value);
}

Return Value

A PDF3DProjection object that defines the projection of coordinates in the 3D artwork (already transformed into camera coordinates) onto the target coordinate system of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

RenderMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : RenderMode Property

Gets or sets the rendering mode for this view.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As PDF3DRenderMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DRenderMode

instance.RenderMode = value

value = instance.RenderMode
C#
public PDF3DRenderMode RenderMode {get; set;}
Delphi
public read-write property RenderMode: PDF3DRenderMode;
Managed Extensions for C++
public: __property PDF3DRenderMode* get_RenderMode();
public: __property void set_RenderMode(
   PDF3DRenderMode* value
);
C++/CLI
public:
property PDF3DRenderMode^ RenderMode {
   PDF3DRenderMode^ get();
   void set (PDF3DRenderMode^ value);
}

Return Value

A PDF3DRenderMode object that specifies the render mode to use when rendering 3D artwork with this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

ResetNodesState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ResetNodesState Property

Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.

Syntax

Visual Basic (Declaration)
Public Property ResetNodesState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As Boolean

instance.ResetNodesState = value

value = instance.ResetNodesState
C#
public bool ResetNodesState {get; set;}
Delphi
public read-write property ResetNodesState: Boolean;
Managed Extensions for C++
public: __property bool get_ResetNodesState();
public: __property void set_ResetNodesState(
   bool value
);
C++/CLI
public:
property bool ResetNodesState {
   bool get();
   void set (bool value);
}

Return Value

True if the artwork’s 3D node parameters are restored to their original states and then the dictionaries specified by the Nodes collection are applied.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

ViewNodeName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ViewNodeName Property

Gets or sets the name of the view node.

Syntax

Visual Basic (Declaration)
Public Property ViewNodeName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.ViewNodeName = value

value = instance.ViewNodeName
C#
public string ViewNodeName {get; set;}
Delphi
public read-write property ViewNodeName: String;
Managed Extensions for C++
public: __property string* get_ViewNodeName();
public: __property void set_ViewNodeName(
   string* value
);
C++/CLI
public:
property String^ ViewNodeName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of a view node in the 3D content stream.

Remarks

The view node in the content stream defines all the properties for viewing the 3D artwork. If both ViewNodeName and CameraToWorldMatrix are specified, then ViewNodeName takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

PDF3DViewCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

Defines a collection of PDF3DView objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDF3DViewCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
C#
[DefaultMemberAttribute("Item")]
public class PDF3DViewCollection : CollectionBase
Delphi
public class PDF3DViewCollection = class(CollectionBase)
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDF3DViewCollection : public CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDF3DViewCollection : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DViewCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

The following tables list the members exposed by PDF3DViewCollection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DViewCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DView object at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DViewCollection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : PDF3DViewCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection()
C#
public PDF3DViewCollection()
Delphi
public PDF3DViewCollection();
Managed Extensions for C++
public: PDF3DViewCollection();
C++/CLI
public:
PDF3DViewCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%% $$Methods$$

PDF3DViewCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new element to collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Searches the collection for the specified element.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified element.
Public Method | Insert | Inserts an element in the collection at the specified index.
Public Method | Remove | Removes the element from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : Add Method

value
The element to add.
Adds a new element to collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As PDF3DView _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim value As PDF3DView
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   PDF3DView value
)
Delphi
public function Add(
    value: PDF3DView
): Integer;
Managed Extensions for C++
public: int Add(
   PDF3DView* value
)
C++/CLI
public:
int Add(
   PDF3DView^ value
)

Parameters

value
The element to add.

Return Value

Position of the element in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%%

Contains Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : Contains Method

value
The element to search for.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As PDF3DView _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim value As PDF3DView
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   PDF3DView value
)
Delphi
public function Contains(
    value: PDF3DView
): Boolean;
Managed Extensions for C++
public: bool Contains(
   PDF3DView* value
)
C++/CLI
public:
bool Contains(
   PDF3DView^ value
)

Parameters

value
The element to search for.

Return Value

True if the element exists in the collection, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : IndexOf Method

value
Element to search.
Searches the collection for the specified element.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As PDF3DView _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim value As PDF3DView
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   PDF3DView value
)
Delphi
public function IndexOf(
    value: PDF3DView
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDF3DView* value
)
C++/CLI
public:
int IndexOf(
   PDF3DView^ value
)

Parameters

value
Element to search.

Return Value

Index of the element in the collection, if exists, or -1 if the element does not exist in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : Insert Method

index
Index where to insert the element.
value
Element to insert in the collection.
Inserts an element in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As PDF3DView _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim index As Integer
Dim value As PDF3DView

instance.Insert(index, value)
C#
public void Insert(
   int index,
   PDF3DView value
)
Delphi
public procedure Insert(
    index: Integer;
    value: PDF3DView
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDF3DView* value
)
C++/CLI
public:
void Insert(
   int index,
   PDF3DView^ value
)

Parameters

index
Index where to insert the element.
value
Element to insert in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : Remove Method

value
The element to remove.
Removes the element from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As PDF3DView _
)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim value As PDF3DView

instance.Remove(value)
C#
public void Remove(
   PDF3DView value
)
Delphi
public procedure Remove(
    value: PDF3DView
);
Managed Extensions for C++
public: void Remove(
   PDF3DView* value
)
C++/CLI
public:
void Remove(
   PDF3DView^ value
)

Parameters

value
The element to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%% $$Properties$$

PDF3DViewCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the PDF3DView object at the specified index.
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DViewCollection Class : Item Property

index
Gets or sets the PDF3DView object at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDF3DView
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
Dim index As Integer
Dim value As PDF3DView

instance.Item(index) = value

value = instance.Item(index)
C#
public PDF3DView this[
   int index
]; {get; set;}
Delphi
public  this: : PDF3DView;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDF3DView* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDF3DView* value
);
C++/CLI
public:
property PDF3DView^ default [int] {
   PDF3DView^ get(int index);
   void set (int index, PDF3DView^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Class
PDF3DViewCollection Members


%%PageItemTitle%%

PDFAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

Defines an annotation in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFAnnotation
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
C#
public abstract class PDFAnnotation : PDFObject
Delphi
public class PDFAnnotation = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFAnnotation : public PDFObject
C++/CLI
public ref class PDFAnnotation abstract : public PDFObject

Remarks

This is the base class for all annotations in a PDF file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFWidgetAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

The following tables list the members exposed by PDFAnnotation.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object.
Public Property | BorderColor | Gets or sets the color of this annotation's border.
Public Property | Caption | Gets or sets the caption of the annotation.
Public Property | Contents | Gets or sets the contents of the annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation.
Public Property | Height | Gets or sets the height of the annotation rectangle.
Public Property | ID | Gets or sets the id of the annotation.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle.
Public Property | Opacity | Gets or sets the opacity of the annotation.
Public Property | Position | Gets or sets the position of this annotation object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object.
Public Property | Size | Gets or sets the size of this annotation object.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle.
Public Property | Width | Gets or sets the width of the annotation rectangle.
Top

See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object.
Public Property | BorderColor | Gets or sets the color of this annotation's border.
Public Property | Caption | Gets or sets the caption of the annotation.
Public Property | Contents | Gets or sets the contents of the annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation.
Public Property | Height | Gets or sets the height of the annotation rectangle.
Public Property | ID | Gets or sets the id of the annotation.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle.
Public Property | Opacity | Gets or sets the opacity of the annotation.
Public Property | Position | Gets or sets the position of this annotation object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object.
Public Property | Size | Gets or sets the size of this annotation object.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle.
Public Property | Width | Gets or sets the width of the annotation rectangle.
Top

See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Border Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Border Property

Gets or sets the border of this PDFAnnotation object.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
C#
public PDFAnnotationBorder Border {get; set;}
Delphi
public read-write property Border: PDFAnnotationBorder;
Managed Extensions for C++
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
C++/CLI
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (PDFAnnotationBorder^ value);
}

Return Value

A PDFAnnotationBorder object specifying the border for this annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

BorderColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : BorderColor Property

Gets or sets the color of this annotation's border.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFColor

instance.BorderColor = value

value = instance.BorderColor
C#
public PDFColor BorderColor {get; set;}
Delphi
public read-write property BorderColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BorderColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of this annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Caption Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Caption Property

Gets or sets the caption of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public string Caption {get; set;}
Delphi
public read-write property Caption: String;
Managed Extensions for C++
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
C++/CLI
public:
property String^ Caption {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the caption of the annotation.

Remarks

This caption is displayed in the title bar of the annotation's pop-up window when open and active.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Contents Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Contents Property

Gets or sets the contents of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Contents As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
C#
public string Contents {get; set;}
Delphi
public read-write property Contents: String;
Managed Extensions for C++
public: __property string* get_Contents();
public: __property void set_Contents(
   string* value
);
C++/CLI
public:
property String^ Contents {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the contents of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Flags Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Flags Property

Gets or sets the flags associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property Flags As AnnotationFlags
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As AnnotationFlags

instance.Flags = value

value = instance.Flags
C#
public AnnotationFlags Flags {get; set;}
Delphi
public read-write property Flags: AnnotationFlags;
Managed Extensions for C++
public: __property AnnotationFlags get_Flags();
public: __property void set_Flags(
   AnnotationFlags value
);
C++/CLI
public:
property AnnotationFlags Flags {
   AnnotationFlags get();
   void set (AnnotationFlags value);
}

Return Value

One or more AnnotationFlags enumeration members specifying the flags for this annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Height Property

Gets or sets the height of the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

a float value representing the height of the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

ID Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : ID Property

Gets or sets the id of the annotation.

Syntax

Visual Basic (Declaration)
Public Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As String

instance.ID = value

value = instance.ID
C#
public string ID {get; set;}
Delphi
public read-write property ID: String;
Managed Extensions for C++
public: __property string* get_ID();
public: __property void set_ID(
   string* value
);
C++/CLI
public:
property String^ ID {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the id of the annotation.

Remarks

The annotation id is supposed to identify uniquely the annotation on the page. The PDF4NET library does not throw an exception if there are several annotations with the same id on the same page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

LastModified Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : LastModified Property

Gets or sets the date and time when the annotation was most recently modified.

Syntax

Visual Basic (Declaration)
Public Property LastModified As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Date

instance.LastModified = value

value = instance.LastModified
C#
public DateTime LastModified {get; set;}
Delphi
public read-write property LastModified: DateTime;
Managed Extensions for C++
public: __property DateTime get_LastModified();
public: __property void set_LastModified(
   DateTime value
);
C++/CLI
public:
property DateTime LastModified {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the annotation was most recently modified.

Remarks

When the annotation is created from code, this property is set to current date and time. When the annotation is imported from a PDF file, this property is loaded from the annotation. If the annotation does not include this information, this property will return MinValue. If the caption or the contents of an imported annotation are changed, this property is set to current date and time, otherwise it is not modified when the annotation is saved back to file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Left Property

Gets or sets the X coordinate of the top left corner of the annotation's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

a float value representing the X coordinate of the top left corner of the annotation's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Opacity Property

Gets or sets the opacity of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Single

instance.Opacity = value

value = instance.Opacity
C#
public float Opacity {get; set;}
Delphi
public read-write property Opacity: Single;
Managed Extensions for C++
public: __property float get_Opacity();
public: __property void set_Opacity(
   float value
);
C++/CLI
public:
property float Opacity {
   float get();
   void set (float value);
}

Return Value

a float value representing the opacity of the annotation.

Remarks

The opacity property is used to control the transparency level of the annotation's visual representation. 0 means full transparency, 100 means full opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Position Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Position Property

Gets or sets the position of this annotation object.

Syntax

Visual Basic (Declaration)
Public Property Position As PDFPoint
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFPoint

instance.Position = value

value = instance.Position
C#
public PDFPoint Position {get; set;}
Delphi
public read-write property Position: PDFPoint;
Managed Extensions for C++
public: __property PDFPoint* get_Position();
public: __property void set_Position(
   PDFPoint* value
);
C++/CLI
public:
property PDFPoint^ Position {
   PDFPoint^ get();
   void set (PDFPoint^ value);
}

Return Value

A PDFPoint object specifying the position of the annotation.

Remarks

This position is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Rectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Rectangle Property

Gets or sets the bounding rectangle of this annotation object.

Syntax

Visual Basic (Declaration)
Public Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As RectangleF

instance.Rectangle = value

value = instance.Rectangle
C#
public RectangleF Rectangle {get; set;}
Delphi
public read-write property Rectangle: RectangleF;
Managed Extensions for C++
public: __property RectangleF get_Rectangle();
public: __property void set_Rectangle(
   RectangleF value
);
C++/CLI
public:
property RectangleF Rectangle {
   RectangleF get();
   void set (RectangleF value);
}

Return Value

A RectangleF object specifying the position and size of the annotation.

Remarks

The bounding rectangle is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Size Property

Gets or sets the size of this annotation object.

Syntax

Visual Basic (Declaration)
Public Property Size As SizeF
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As SizeF

instance.Size = value

value = instance.Size
C#
public SizeF Size {get; set;}
Delphi
public read-write property Size: SizeF;
Managed Extensions for C++
public: __property SizeF get_Size();
public: __property void set_Size(
   SizeF value
);
C++/CLI
public:
property SizeF Size {
   SizeF get();
   void set (SizeF value);
}

Return Value

A SizeF object specifying the size of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Top Property

Gets or sets the Y coordinate of the top left corner of the annotation's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

a float value representing the Y coordinate of the top left corner of the annotation's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Width Property

Gets or sets the width of the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

a float value representing the width of the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

PDFAnnotationBorder Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

This class defines the appearance of an annotation's border.

Syntax

Visual Basic (Declaration)
Public Class PDFAnnotationBorder
   Inherits PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
C#
public class PDFAnnotationBorder : PDFBaseObject
Delphi
public class PDFAnnotationBorder = class(PDFBaseObject)
Managed Extensions for C++
public __gc class PDFAnnotationBorder : public PDFBaseObject
C++/CLI
public ref class PDFAnnotationBorder : public PDFBaseObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationBorder Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

The following tables list the members exposed by PDFAnnotationBorder.

Public Constructors

 | Name | Description
Public Constructor | PDFAnnotationBorder Constructor | Overloaded. Initializes a new PDFAnnotationBorder object.
Top

Public Properties

 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | Width | Gets or sets the width of annotation's border.
Top

See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationBorder Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : PDFAnnotationBorder Constructor

Initializes a new PDFAnnotationBorder object.

Overload List

Overload | Description
PDFAnnotationBorder Constructor() | Initializes a new PDFAnnotationBorder object.
PDFAnnotationBorder Constructor(Single,BorderStyle) | Initializes a new PDFAnnotationBorder object with the given width and style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

PDFAnnotationBorder Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor()

Initializes a new PDFAnnotationBorder object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder()
C#
public PDFAnnotationBorder()
Delphi
public PDFAnnotationBorder();
Managed Extensions for C++
public: PDFAnnotationBorder();
C++/CLI
public:
PDFAnnotationBorder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


%%PageItemTitle%%

PDFAnnotationBorder Constructor(Single,BorderStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor(Single,BorderStyle)

width
the width of annotation's border.
style
the style of annotation's border.
Initializes a new PDFAnnotationBorder object with the given width and style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal style As BorderStyle _
)
Visual Basic (Usage) Copy Code
Dim width As Single
Dim style As BorderStyle

Dim instance As PDFAnnotationBorder(width, style)
C#
public PDFAnnotationBorder(
   float width,
   BorderStyle style
)
Delphi
public PDFAnnotationBorder(
    width: Single;
    style: BorderStyle
);
Managed Extensions for C++
public: PDFAnnotationBorder(
   float width,
   BorderStyle style
)
C++/CLI
public:
PDFAnnotationBorder(
   float width,
   BorderStyle style
)

Parameters

width
the width of annotation's border.
style
the style of annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAnnotationBorder Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Properties

 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | Width | Gets or sets the width of annotation's border.
Top

See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

BorderStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : BorderStyle Property

Gets or sets the style of annotation's border.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: BorderStyle;
Managed Extensions for C++
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   BorderStyle value
);
C++/CLI
public:
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (BorderStyle value);
}

Return Value

A BorderStyle enumeration member specifying the style of the annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

DashPattern Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : DashPattern Property

Gets or sets an array of custom dashes and spaces.

Syntax

Visual Basic (Declaration)
Public Property DashPattern As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
Dim value() As Single

instance.DashPattern = value

value = instance.DashPattern
C#
public float[] DashPattern {get; set;}
Delphi
public read-write property DashPattern: array of Single;
Managed Extensions for C++
public: __property float[]* get_DashPattern();
public: __property void set_DashPattern(
   float[]* value
);
C++/CLI
public:
property array<float>^ DashPattern {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

An array of float values specifying custom dashes and spaces.

Remarks

This property is used only when BorderStyle property is BorderStyle.Dashed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : Width Property

Gets or sets the width of annotation's border.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

PDFAnnotations Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotations Class

Defines a collection of annotations displayed on a PDF page.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFAnnotations
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFAnnotations : PDFObject
Delphi
public class PDFAnnotations = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFAnnotations : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFAnnotations sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotations

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotations Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotations Class

The following tables list the members exposed by PDFAnnotations.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of annotations in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the annotation at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation at the end of the collection.
Public Method | Clear | Clear the annotations collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts an annotation at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the annotation from the collection.
Public Method | RemoveAt | Removes the annotation at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFAnnotations Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotations Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotations Class

For a list of all members of this type, see PDFAnnotations members.

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation at the end of the collection.
Public Method | Clear | Clear the annotations collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts an annotation at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the annotation from the collection.
Public Method | RemoveAt | Removes the annotation at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFAnnotations Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Add Method

annotation
a PDFAnnotation object to be added to the collection
Adds an annotation at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal annotation As PDFAnnotation _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim annotation As PDFAnnotation

instance.Add(annotation)
C#
public void Add(
   PDFAnnotation annotation
)
Delphi
public procedure Add(
    annotation: PDFAnnotation
);
Managed Extensions for C++
public: void Add(
   PDFAnnotation* annotation
)
C++/CLI
public:
void Add(
   PDFAnnotation^ annotation
)

Parameters

annotation
a PDFAnnotation object to be added to the collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Clear Method

Clear the annotations collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

This method removes all annotations from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Insert Method

index
the index where to insert the annotation.
annotation
a PDFAnnotation object to be added to the collection
Inserts an annotation at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal annotation As PDFAnnotation _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim index As Integer
Dim annotation As PDFAnnotation

instance.Insert(index, annotation)
C#
public void Insert(
   int index,
   PDFAnnotation annotation
)
Delphi
public procedure Insert(
    index: Integer;
    annotation: PDFAnnotation
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFAnnotation* annotation
)
C++/CLI
public:
void Insert(
   int index,
   PDFAnnotation^ annotation
)

Parameters

index
the index where to insert the annotation.
annotation
a PDFAnnotation object to be added to the collection

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of annotations in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Remove Method

annotation
The annotation to be removed.
Removes the annotation from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal annotation As PDFAnnotation _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim annotation As PDFAnnotation

instance.Remove(annotation)
C#
public void Remove(
   PDFAnnotation annotation
)
Delphi
public procedure Remove(
    annotation: PDFAnnotation
);
Managed Extensions for C++
public: void Remove(
   PDFAnnotation* annotation
)
C++/CLI
public:
void Remove(
   PDFAnnotation^ annotation
)

Parameters

annotation
The annotation to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : RemoveAt Method

index
the index where to remove the annotation.
Removes the annotation at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
the index where to remove the annotation.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of annotations in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%% $$Properties$$

PDFAnnotations Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotations Class

For a list of all members of this type, see PDFAnnotations members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of annotations in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the annotation at the specified index (zero based index).
Top

See Also

Reference

PDFAnnotations Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Count Property

Returns the number of annotations in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotations Class : Item Property

index
Gets the annotation at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotations
Dim index As Integer
Dim value As PDFAnnotation

value = instance.Item(index)
C#
public PDFAnnotation this[
   int index
]; {get;}
Delphi
public  this: : PDFAnnotation;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFAnnotation* get_Item(
   int index
);
C++/CLI
public:
property PDFAnnotation^ default [int] {
   PDFAnnotation^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of annotations in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotations Class
PDFAnnotations Members


%%PageItemTitle%%

PDFBaseMarkupAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

Defines the base class for all markup type annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBaseMarkupAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
C#
public abstract class PDFBaseMarkupAnnotation : PDFAnnotation
Delphi
public class PDFBaseMarkupAnnotation = class(PDFAnnotation)abstract;
Managed Extensions for C++
public __gc abstract class PDFBaseMarkupAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFBaseMarkupAnnotation abstract : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquareAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFCircleAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFBaseMarkupAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

The following tables list the members exposed by PDFBaseMarkupAnnotation.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation.
Public Property | Contents | Gets or sets the contents of the annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window.
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFBaseMarkupAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

For a list of all members of this type, see PDFBaseMarkupAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation.
Public Property | Contents | Gets or sets the contents of the annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window.
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Author Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Author Property

Gets or sets the author of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Delphi
public read-write property Author: String;
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the author of the annotation.

Remarks

By convention, all the annotation classes that inherit this class use the Caption property as the author of the annotation. Author and Caption properties will have always the same value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

Caption Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Caption Property

Gets or sets the caption of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public string Caption {get; set;}
Delphi
public read-write property Caption: String;
Managed Extensions for C++
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
C++/CLI
public:
property String^ Caption {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the caption of the annotation.

Remarks

By convention, all the annotation classes that inherit this class use the Caption property as the author of the annotation. Author and Caption properties will have always the same value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

Contents Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Contents Property

Gets or sets the contents of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Contents As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
C#
public string Contents {get; set;}
Delphi
public read-write property Contents: String;
Managed Extensions for C++
public: __property string* get_Contents();
public: __property void set_Contents(
   string* value
);
C++/CLI
public:
property String^ Contents {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the contents of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

PopupRectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : PopupRectangle Property

Gets or sets the rectangle of the popup window.

Syntax

Visual Basic (Declaration)
Public Property PopupRectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As RectangleF

instance.PopupRectangle = value

value = instance.PopupRectangle
C#
public RectangleF PopupRectangle {get; set;}
Delphi
public read-write property PopupRectangle: RectangleF;
Managed Extensions for C++
public: __property RectangleF get_PopupRectangle();
public: __property void set_PopupRectangle(
   RectangleF value
);
C++/CLI
public:
property RectangleF PopupRectangle {
   RectangleF get();
   void set (RectangleF value);
}

Return Value

A RectangleF object specifying the position and size of the popup window.

Remarks

The popup window is used to display the annotation's contents when the annotation is opened.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

Subject Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Subject Property

Gets or sets the subject of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Delphi
public read-write property Subject: String;
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the subject of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

PDFCircleAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFCircleAnnotation Class

Defines a circle annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCircleAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFCircleAnnotation
C#
public class PDFCircleAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFCircleAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFCircleAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFCircleAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFCircleAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCircleAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFCircleAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFCircleAnnotation Class

The following tables list the members exposed by PDFCircleAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFCircleAnnotation Constructor | Overloaded. Initializes a new PDFCircleAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the annotation's interior.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFCircleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFCircleAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFCircleAnnotation Class : PDFCircleAnnotation Constructor

Initializes a new PDFCircleAnnotation object.

Overload List

Overload | Description
PDFCircleAnnotation Constructor() | Initializes a new PDFCircleAnnotation object.
PDFCircleAnnotation Constructor(String,String) | Initializes a new PDFCircleAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCircleAnnotation Class
PDFCircleAnnotation Members


%%PageItemTitle%%

PDFCircleAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFCircleAnnotation Class > PDFCircleAnnotation Constructor : PDFCircleAnnotation Constructor()

Initializes a new PDFCircleAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCircleAnnotation()
C#
public PDFCircleAnnotation()
Delphi
public PDFCircleAnnotation();
Managed Extensions for C++
public: PDFCircleAnnotation();
C++/CLI
public:
PDFCircleAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCircleAnnotation Class
PDFCircleAnnotation Members
Overload List


%%PageItemTitle%%

PDFCircleAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFCircleAnnotation Class > PDFCircleAnnotation Constructor : PDFCircleAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFCircleAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFCircleAnnotation(caption, contents)
C#
public PDFCircleAnnotation(
   string caption,
   string contents
)
Delphi
public PDFCircleAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFCircleAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFCircleAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCircleAnnotation Class
PDFCircleAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCircleAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFCircleAnnotation Class

For a list of all members of this type, see PDFCircleAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the annotation's interior.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFCircleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

InteriorColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFCircleAnnotation Class : InteriorColor Property

Gets or sets the color to fill the annotation's interior.

Syntax

Visual Basic (Declaration)
Public Property InteriorColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCircleAnnotation
Dim value As PDFColor

instance.InteriorColor = value

value = instance.InteriorColor
C#
public PDFColor InteriorColor {get; set;}
Delphi
public read-write property InteriorColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ InteriorColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color to fill the annotation's interior.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCircleAnnotation Class
PDFCircleAnnotation Members


%%PageItemTitle%%

PDFFileAttachmentAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

Defines a file attachment annotation in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFileAttachmentAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
C#
public class PDFFileAttachmentAnnotation : PDFAnnotation
Delphi
public class PDFFileAttachmentAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDFFileAttachmentAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFFileAttachmentAnnotation : public PDFAnnotation

Remarks

A file attachment annotation allows to embed any external file in a PDF file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

The following tables list the members exposed by PDFFileAttachmentAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFFileAttachmentAnnotation Constructor | Overloaded. Initializes a new PDFFileAttachmentAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Compress | Gets or sets whether the embedded file should be compressed.
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the creation date and time of the file attachment.
Public Property | File | Gets or sets the file associated with this annotation.
Public Property | FileData | Gets or sets the file content associated with this annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : PDFFileAttachmentAnnotation Constructor

Initializes a new PDFFileAttachmentAnnotation object.

Overload List

Overload | Description
PDFFileAttachmentAnnotation Constructor() | Initializes a new PDFFileAttachmentAnnotation object.
PDFFileAttachmentAnnotation Constructor(String,String) | Initializes a new PDFFileAttachmentAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor()

Initializes a new PDFFileAttachmentAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation()
C#
public PDFFileAttachmentAnnotation()
Delphi
public PDFFileAttachmentAnnotation();
Managed Extensions for C++
public: PDFFileAttachmentAnnotation();
C++/CLI
public:
PDFFileAttachmentAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFFileAttachmentAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFFileAttachmentAnnotation(caption, contents)
C#
public PDFFileAttachmentAnnotation(
   string caption,
   string contents
)
Delphi
public PDFFileAttachmentAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFFileAttachmentAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFFileAttachmentAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Compress | Gets or sets whether the embedded file should be compressed.
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the creation date and time of the file attachment.
Public Property | File | Gets or sets the file associated with this annotation.
Public Property | FileData | Gets or sets the file content associated with this annotation.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Compress Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Compress Property

Gets or sets whether the embedded file should be compressed.

Syntax

Visual Basic (Declaration)
Public Property Compress As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As Boolean

instance.Compress = value

value = instance.Compress
C#
public bool Compress {get; set;}
Delphi
public read-write property Compress: Boolean;
Managed Extensions for C++
public: __property bool get_Compress();
public: __property void set_Compress(
   bool value
);
C++/CLI
public:
property bool Compress {
   bool get();
   void set (bool value);
}

Return Value

True if the embedded file should be compressed before embedding. Default: true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

CreationDate Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : CreationDate Property

Gets or sets the creation date and time of the file attachment.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Delphi
public read-write property CreationDate: DateTime;
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the file attachment was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

File Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : File Property

Gets or sets the file associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property File As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.File = value

value = instance.File
C#
public string File {get; set;}
Delphi
public read-write property File: String;
Managed Extensions for C++
public: __property string* get_File();
public: __property void set_File(
   string* value
);
C++/CLI
public:
property String^ File {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the full path to the file to be embedded in the PDF file.

Remarks

If both File and FileContent properties are set, the FileContent property takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

FileData Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : FileData Property

Gets or sets the file content associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property FileData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value() As Byte

instance.FileData = value

value = instance.FileData
C#
public byte[] FileData {get; set;}
Delphi
public read-write property FileData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_FileData();
public: __property void set_FileData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ FileData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the content of the annotation's embedded file.

Remarks

When a PDF file that contains file attachments is imported, this property returns the content of the embedded file.
If both File and FileContent properties are set, the FileContent property takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Icon Property

Gets or sets the annotation's icon.

Syntax

Visual Basic (Declaration)
Public Property Icon As FileAttachmentAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As FileAttachmentAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public FileAttachmentAnnotationIcon Icon {get; set;}
Delphi
public read-write property Icon: FileAttachmentAnnotationIcon;
Managed Extensions for C++
public: __property FileAttachmentAnnotationIcon get_Icon();
public: __property void set_Icon(
   FileAttachmentAnnotationIcon value
);
C++/CLI
public:
property FileAttachmentAnnotationIcon Icon {
   FileAttachmentAnnotationIcon get();
   void set (FileAttachmentAnnotationIcon value);
}

Return Value

A FileAttachmentAnnotationIcon enumeration member specifying the icon for the annotation when it is displayed in closed state.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

MimeType Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : MimeType Property

Gets or sets the MIME type of the file to embed.

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.MimeType = value

value = instance.MimeType
C#
public string MimeType {get; set;}
Delphi
public read-write property MimeType: String;
Managed Extensions for C++
public: __property string* get_MimeType();
public: __property void set_MimeType(
   string* value
);
C++/CLI
public:
property String^ MimeType {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the MIME type of the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

PDFFreeTextAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

Defines a free text annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFreeTextAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
C#
public class PDFFreeTextAnnotation : PDFAnnotation
Delphi
public class PDFFreeTextAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDFFreeTextAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFFreeTextAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFreeTextAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

The following tables list the members exposed by PDFFreeTextAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFFreeTextAnnotation Constructor | Overloaded. Initializes a new PDFFreeTextAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | FillColor | Gets or sets the color of this annotation's interior.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Font | Gets or sets the annotation's font.
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation.
Public Property | TextColor | Gets or sets the color of the annotation text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor

Initializes a new PDFFreeTextAnnotation object.

Overload List

Overload | Description
PDFFreeTextAnnotation Constructor() | Initializes a new PDFFreeTextAnnotation object.
PDFFreeTextAnnotation Constructor(String) | Initializes a new PDFFreeTextAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class > PDFFreeTextAnnotation Constructor : PDFFreeTextAnnotation Constructor()

Initializes a new PDFFreeTextAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation()
C#
public PDFFreeTextAnnotation()
Delphi
public PDFFreeTextAnnotation();
Managed Extensions for C++
public: PDFFreeTextAnnotation();
C++/CLI
public:
PDFFreeTextAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members
Overload List


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class > PDFFreeTextAnnotation Constructor : PDFFreeTextAnnotation Constructor(String)

contents
the content of the annotation.
Initializes a new PDFFreeTextAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim contents As String

Dim instance As PDFFreeTextAnnotation(contents)
C#
public PDFFreeTextAnnotation(
   string contents
)
Delphi
public PDFFreeTextAnnotation(
    contents: String
);
Managed Extensions for C++
public: PDFFreeTextAnnotation(
   string* contents
)
C++/CLI
public:
PDFFreeTextAnnotation(
   String^ contents
)

Parameters

contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFreeTextAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | FillColor | Gets or sets the color of this annotation's interior.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Font | Gets or sets the annotation's font.
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation.
Public Property | TextColor | Gets or sets the color of the annotation text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

FillColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : FillColor Property

Gets or sets the color of this annotation's interior.

Syntax

Visual Basic (Declaration)
Public Property FillColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As PDFColor

instance.FillColor = value

value = instance.FillColor
C#
public PDFColor FillColor {get; set;}
Delphi
public read-write property FillColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_FillColor();
public: __property void set_FillColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ FillColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of this annotation's interior.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Font Property

Gets or sets the annotation's font.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

A PDFFont object specifying the font used for displaying annotation's content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

Subject Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Subject Property

Gets or sets the subject of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Delphi
public read-write property Subject: String;
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the subject of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

TextColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : TextColor Property

Gets or sets the color of the annotation text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As PDFColor

instance.TextColor = value

value = instance.TextColor
C#
public PDFColor TextColor {get; set;}
Delphi
public read-write property TextColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_TextColor();
public: __property void set_TextColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ TextColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of the annotation text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

PDFLineAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

Defines a line annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLineAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
C#
public class PDFLineAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFLineAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFLineAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFLineAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLineAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

The following tables list the members exposed by PDFLineAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFLineAnnotation Constructor | Overloaded. Initializes a new PDFLineAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the interior of annotation's line endings.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : PDFLineAnnotation Constructor

Initializes a new PDFLineAnnotation object.

Overload List

Overload | Description
PDFLineAnnotation Constructor() | Initializes a new PDFLineAnnotation object.
PDFLineAnnotation Constructor(String,String) | Initializes a new PDFLineAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

PDFLineAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor()

Initializes a new PDFLineAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation()
C#
public PDFLineAnnotation()
Delphi
public PDFLineAnnotation();
Managed Extensions for C++
public: PDFLineAnnotation();
C++/CLI
public:
PDFLineAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


%%PageItemTitle%%

PDFLineAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFLineAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFLineAnnotation(caption, contents)
C#
public PDFLineAnnotation(
   string caption,
   string contents
)
Delphi
public PDFLineAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFLineAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFLineAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFLineAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the interior of annotation's line endings.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

BeginLineStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : BeginLineStyle Property

Gets or sets the style used for the beginning of the line.

Syntax

Visual Basic (Declaration)
Public Property BeginLineStyle As LineEndingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As LineEndingStyle

instance.BeginLineStyle = value

value = instance.BeginLineStyle
C#
public LineEndingStyle BeginLineStyle {get; set;}
Delphi
public read-write property BeginLineStyle: LineEndingStyle;
Managed Extensions for C++
public: __property LineEndingStyle get_BeginLineStyle();
public: __property void set_BeginLineStyle(
   LineEndingStyle value
);
C++/CLI
public:
property LineEndingStyle BeginLineStyle {
   LineEndingStyle get();
   void set (LineEndingStyle value);
}

Return Value

A LineEndingStyle enumeration member specifying the style for the beginning of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

EndLineStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : EndLineStyle Property

Gets or sets the style used for the end of the line.

Syntax

Visual Basic (Declaration)
Public Property EndLineStyle As LineEndingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As LineEndingStyle

instance.EndLineStyle = value

value = instance.EndLineStyle
C#
public LineEndingStyle EndLineStyle {get; set;}
Delphi
public read-write property EndLineStyle: LineEndingStyle;
Managed Extensions for C++
public: __property LineEndingStyle get_EndLineStyle();
public: __property void set_EndLineStyle(
   LineEndingStyle value
);
C++/CLI
public:
property LineEndingStyle EndLineStyle {
   LineEndingStyle get();
   void set (LineEndingStyle value);
}

Return Value

A LineEndingStyle enumeration member specifying the style for the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

InteriorColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : InteriorColor Property

Gets or sets the color to fill the interior of annotation's line endings.

Syntax

Visual Basic (Declaration)
Public Property InteriorColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFColor

instance.InteriorColor = value

value = instance.InteriorColor
C#
public PDFColor InteriorColor {get; set;}
Delphi
public read-write property InteriorColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ InteriorColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color to fill the interior of annotation's line endings.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

PDFLinkAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

Defines a link annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLinkAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
C#
public class PDFLinkAnnotation : PDFAnnotation
Delphi
public class PDFLinkAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDFLinkAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFLinkAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLinkAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

The following tables list the members exposed by PDFLinkAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the link's action.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor

Initializes a new PDFLinkAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation()
C#
public PDFLinkAnnotation()
Delphi
public PDFLinkAnnotation();
Managed Extensions for C++
public: PDFLinkAnnotation();
C++/CLI
public:
PDFLinkAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFLinkAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the link's action.
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Action Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Action Property

Gets or sets the link's action.

Syntax

Visual Basic (Declaration)
Public Property Action As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As PDFAction

instance.Action = value

value = instance.Action
C#
public PDFAction Action {get; set;}
Delphi
public read-write property Action: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the link is activated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%%

HighlightMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : HighlightMode Property

Gets or sets the highlighting mode of the link.

Syntax

Visual Basic (Declaration)
Public Property HighlightMode As LinkHighlightMode
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As LinkHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
public LinkHighlightMode HighlightMode {get; set;}
Delphi
public read-write property HighlightMode: LinkHighlightMode;
Managed Extensions for C++
public: __property LinkHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   LinkHighlightMode value
);
C++/CLI
public:
property LinkHighlightMode HighlightMode {
   LinkHighlightMode get();
   void set (LinkHighlightMode value);
}

Return Value

A LinkHighlightMode enumeration member specifying the highlighting mode for the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%%

PDFMarkupAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

Defines a markup annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMarkupAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
C#
public class PDFMarkupAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFMarkupAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFMarkupAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFMarkupAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFMarkupAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

The following tables list the members exposed by PDFMarkupAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFMarkupAnnotation Constructor | Overloaded. Initializes a new PDFMarkupAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MarkupStyle | Gets or sets the markup style for the markup annotation.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | QuadPoints | Gets or sets the points the define the markup annotation.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFMarkupAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : PDFMarkupAnnotation Constructor

Initializes a new PDFMarkupAnnotation object.

Overload List

Overload | Description
PDFMarkupAnnotation Constructor() | Initializes a new PDFMarkupAnnotation object.
PDFMarkupAnnotation Constructor(String,String) | Initializes a new PDFMarkupAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%PageItemTitle%%

PDFMarkupAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class > PDFMarkupAnnotation Constructor : PDFMarkupAnnotation Constructor()

Initializes a new PDFMarkupAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation()
C#
public PDFMarkupAnnotation()
Delphi
public PDFMarkupAnnotation();
Managed Extensions for C++
public: PDFMarkupAnnotation();
C++/CLI
public:
PDFMarkupAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members
Overload List


%%PageItemTitle%%

PDFMarkupAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class > PDFMarkupAnnotation Constructor : PDFMarkupAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFMarkupAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFMarkupAnnotation(caption, contents)
C#
public PDFMarkupAnnotation(
   string caption,
   string contents
)
Delphi
public PDFMarkupAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFMarkupAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFMarkupAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFMarkupAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MarkupStyle | Gets or sets the markup style for the markup annotation.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | QuadPoints | Gets or sets the points the define the markup annotation.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

MarkupStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : MarkupStyle Property

Gets or sets the markup style for the markup annotation.

Syntax

Visual Basic (Declaration)
Public Property MarkupStyle As MarkupStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value As MarkupStyle

instance.MarkupStyle = value

value = instance.MarkupStyle
C#
public MarkupStyle MarkupStyle {get; set;}
Delphi
public read-write property MarkupStyle: MarkupStyle;
Managed Extensions for C++
public: __property MarkupStyle get_MarkupStyle();
public: __property void set_MarkupStyle(
   MarkupStyle value
);
C++/CLI
public:
property MarkupStyle MarkupStyle {
   MarkupStyle get();
   void set (MarkupStyle value);
}

Return Value

A MarkupStyle enumeration member specifying the style of the markup annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%PageItemTitle%%

QuadPoints Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : QuadPoints Property

Gets or sets the points the define the markup annotation.

Syntax

Visual Basic (Declaration)
Public Property QuadPoints As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value() As Single

instance.QuadPoints = value

value = instance.QuadPoints
C#
public float[] QuadPoints {get; set;}
Delphi
public read-write property QuadPoints: array of Single;
Managed Extensions for C++
public: __property float[]* get_QuadPoints();
public: __property void set_QuadPoints(
   float[]* value
);
C++/CLI
public:
property array<float>^ QuadPoints {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

An array of points specifying the position of the markup annotation.

Remarks

The QuadPoints array must contain 8*n elements specifying the coordinates of n quadrilaterals. Each quadrilateral encompasses a word or group of continuous words in the text underlying the annotation. The coordinates for each quadrilateral are given in the order
x1 y1 x2 y2 x3 y3 x4 y4
specifying the quadrilateral's four vertices in counterclockwise order. The text is oriented with respect to the edge connecting points (x1,y1) and (x2,y2).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%PageItemTitle%%

PDFMovieAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

Defines a movie annotation in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMovieAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
C#
public class PDFMovieAnnotation : PDFAnnotation
Delphi
public class PDFMovieAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDFMovieAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFMovieAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFMovieAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

The following tables list the members exposed by PDFMovieAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFMovieAnnotation Constructor | Overloaded. Initializes a new PDFMovieAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFMovieAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : PDFMovieAnnotation Constructor

Initializes a new PDFMovieAnnotation object.

Overload List

Overload | Description
PDFMovieAnnotation Constructor() | Initializes a new PDFMovieAnnotation object.
PDFMovieAnnotation Constructor(String,MovieType,PDFImage) | Initializes a new PDFMovieAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

PDFMovieAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor()

Initializes a new PDFMovieAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation()
C#
public PDFMovieAnnotation()
Delphi
public PDFMovieAnnotation();
Managed Extensions for C++
public: PDFMovieAnnotation();
C++/CLI
public:
PDFMovieAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


%%PageItemTitle%%

PDFMovieAnnotation Constructor(String,MovieType,PDFImage)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor(String,MovieType,PDFImage)

movieFile
the movie file associated with this annotation object.
movieType
the type of the movie file.
poster
a static image to represent the annotation when the movie is not playing.
Initializes a new PDFMovieAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal movieFile As String, _
   ByVal movieType As MovieType, _
   ByVal poster As PDFImage _
)
Visual Basic (Usage) Copy Code
Dim movieFile As String
Dim movieType As MovieType
Dim poster As PDFImage

Dim instance As PDFMovieAnnotation(movieFile, movieType, poster)
C#
public PDFMovieAnnotation(
   string movieFile,
   MovieType movieType,
   PDFImage poster
)
Delphi
public PDFMovieAnnotation(
    movieFile: String;
    movieType: MovieType;
    poster: PDFImage
);
Managed Extensions for C++
public: PDFMovieAnnotation(
   string* movieFile,
   MovieType movieType,
   PDFImage* poster
)
C++/CLI
public:
PDFMovieAnnotation(
   String^ movieFile,
   MovieType movieType,
   PDFImage^ poster
)

Parameters

movieFile
the movie file associated with this annotation object.
movieType
the type of the movie file.
poster
a static image to represent the annotation when the movie is not playing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFMovieAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

For a list of all members of this type, see PDFMovieAnnotation members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Duration Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Duration Property

Gets or sets the duration of the movie clip.

Syntax

Visual Basic (Declaration)
Public Property Duration As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As Single

instance.Duration = value

value = instance.Duration
C#
public float Duration {get; set;}
Delphi
public read-write property Duration: Single;
Managed Extensions for C++
public: __property float get_Duration();
public: __property void set_Duration(
   float value
);
C++/CLI
public:
property float Duration {
   float get();
   void set (float value);
}

Return Value

A float value specifying the duration of the movie clip.

Remarks

If this property is -1, the actual movie duration is used for playing the movie. If this property is 0, the duration is infinity.
If the duration is greater than actual movie duration, when the movie ends, the player displays the last frame till the specified duration elapses. If the duration is lower than actual movie duration, the movie ends when the duration elapses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

MovieData Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieData Property

Gets or sets the movie content associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property MovieData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value() As Byte

instance.MovieData = value

value = instance.MovieData
C#
public byte[] MovieData {get; set;}
Delphi
public read-write property MovieData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_MovieData();
public: __property void set_MovieData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ MovieData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array value specifying the movie content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

MovieFile Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieFile Property

Gets or sets the movie file associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property MovieFile As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As String

instance.MovieFile = value

value = instance.MovieFile
C#
public string MovieFile {get; set;}
Delphi
public read-write property MovieFile: String;
Managed Extensions for C++
public: __property string* get_MovieFile();
public: __property void set_MovieFile(
   string* value
);
C++/CLI
public:
property String^ MovieFile {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the full path to the movie file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

MovieType Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieType Property

Gets or sets the MIME type of the movie file.

Syntax

Visual Basic (Declaration)
Public Property MovieType As MovieType
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As MovieType

instance.MovieType = value

value = instance.MovieType
C#
public MovieType MovieType {get; set;}
Delphi
public read-write property MovieType: MovieType;
Managed Extensions for C++
public: __property MovieType get_MovieType();
public: __property void set_MovieType(
   MovieType value
);
C++/CLI
public:
property MovieType MovieType {
   MovieType get();
   void set (MovieType value);
}

Return Value

A MovieType enumeration member specifying the MIME type of the movie file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

Poster Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Poster Property

Gets or sets the movie poster to be displayed on the page when the movie is not playing.

Syntax

Visual Basic (Declaration)
Public Property Poster As PDFImage
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As PDFImage

instance.Poster = value

value = instance.Poster
C#
public PDFImage Poster {get; set;}
Delphi
public read-write property Poster: PDFImage;
Managed Extensions for C++
public: __property PDFImage* get_Poster();
public: __property void set_Poster(
   PDFImage* value
);
C++/CLI
public:
property PDFImage^ Poster {
   PDFImage^ get();
   void set (PDFImage^ value);
}

Return Value

A string value specifying the movie poster to be displayed on the page when the movie is not playing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

ShowPlayerControls Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : ShowPlayerControls Property

Gets or sets whether player control interface should be displayed while playing the movie.

Syntax

Visual Basic (Declaration)
Public Property ShowPlayerControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As Boolean

instance.ShowPlayerControls = value

value = instance.ShowPlayerControls
C#
public bool ShowPlayerControls {get; set;}
Delphi
public read-write property ShowPlayerControls: Boolean;
Managed Extensions for C++
public: __property bool get_ShowPlayerControls();
public: __property void set_ShowPlayerControls(
   bool value
);
C++/CLI
public:
property bool ShowPlayerControls {
   bool get();
   void set (bool value);
}

Return Value

True if the player control interface should be displayed, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

PDFRubberStampAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

Defines a rubber stamp annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRubberStampAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
C#
public class PDFRubberStampAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFRubberStampAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation

Remarks

A rubber stamp annotation displays text or graphics intended to look as if they were stamped on the page with a rubber stamp.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFRubberStampAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

The following tables list the members exposed by PDFRubberStampAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFRubberStampAnnotation Constructor | Overloaded. Initializes a new PDFRubberStampAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : PDFRubberStampAnnotation Constructor

Initializes a new PDFRubberStampAnnotation object.

Overload List

Overload | Description
PDFRubberStampAnnotation Constructor() | Initializes a new PDFRubberStampAnnotation object.
PDFRubberStampAnnotation Constructor(String,String) | Initializes a new PDFRubberStampAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor()

Initializes a new PDFRubberStampAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation()
C#
public PDFRubberStampAnnotation()
Delphi
public PDFRubberStampAnnotation();
Managed Extensions for C++
public: PDFRubberStampAnnotation();
C++/CLI
public:
PDFRubberStampAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFRubberStampAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFRubberStampAnnotation(caption, contents)
C#
public PDFRubberStampAnnotation(
   string caption,
   string contents
)
Delphi
public PDFRubberStampAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFRubberStampAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFRubberStampAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFRubberStampAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

For a list of all members of this type, see PDFRubberStampAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : Icon Property

Gets or sets the annotation's icon.

Syntax

Visual Basic (Declaration)
Public Property Icon As RubberStampAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
Dim value As RubberStampAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public RubberStampAnnotationIcon Icon {get; set;}
Delphi
public read-write property Icon: RubberStampAnnotationIcon;
Managed Extensions for C++
public: __property RubberStampAnnotationIcon get_Icon();
public: __property void set_Icon(
   RubberStampAnnotationIcon value
);
C++/CLI
public:
property RubberStampAnnotationIcon Icon {
   RubberStampAnnotationIcon get();
   void set (RubberStampAnnotationIcon value);
}

Return Value

A RubberStampAnnotationIcon enumeration member specifying the icon for the annotation when it is displayed in closed state.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


%%PageItemTitle%%

PDFSquareAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquareAnnotation Class

Defines a square annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSquareAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFSquareAnnotation
C#
public class PDFSquareAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFSquareAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFSquareAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFSquareAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquareAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquareAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFSquareAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquareAnnotation Class

The following tables list the members exposed by PDFSquareAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFSquareAnnotation Constructor | Overloaded. Initializes a new PDFSquareAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the annotation's interior.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSquareAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFSquareAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquareAnnotation Class : PDFSquareAnnotation Constructor

Initializes a new PDFSquareAnnotation object.

Overload List

Overload | Description
PDFSquareAnnotation Constructor() | Initializes a new PDFSquareAnnotation object.
PDFSquareAnnotation Constructor(String,String) | Initializes a new PDFSquareAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquareAnnotation Class
PDFSquareAnnotation Members


%%PageItemTitle%%

PDFSquareAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquareAnnotation Class > PDFSquareAnnotation Constructor : PDFSquareAnnotation Constructor()

Initializes a new PDFSquareAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSquareAnnotation()
C#
public PDFSquareAnnotation()
Delphi
public PDFSquareAnnotation();
Managed Extensions for C++
public: PDFSquareAnnotation();
C++/CLI
public:
PDFSquareAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquareAnnotation Class
PDFSquareAnnotation Members
Overload List


%%PageItemTitle%%

PDFSquareAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquareAnnotation Class > PDFSquareAnnotation Constructor : PDFSquareAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFSquareAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFSquareAnnotation(caption, contents)
C#
public PDFSquareAnnotation(
   string caption,
   string contents
)
Delphi
public PDFSquareAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFSquareAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFSquareAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquareAnnotation Class
PDFSquareAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFSquareAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquareAnnotation Class

For a list of all members of this type, see PDFSquareAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | InteriorColor | Gets or sets the color to fill the annotation's interior.
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSquareAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

InteriorColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquareAnnotation Class : InteriorColor Property

Gets or sets the color to fill the annotation's interior.

Syntax

Visual Basic (Declaration)
Public Property InteriorColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFSquareAnnotation
Dim value As PDFColor

instance.InteriorColor = value

value = instance.InteriorColor
C#
public PDFColor InteriorColor {get; set;}
Delphi
public read-write property InteriorColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ InteriorColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color to fill the annotation's interior.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquareAnnotation Class
PDFSquareAnnotation Members


%%PageItemTitle%%

PDFTextAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

Defines a text annotation on a page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
C#
public class PDFTextAnnotation : PDFBaseMarkupAnnotation
Delphi
public class PDFTextAnnotation = class(PDFBaseMarkupAnnotation)
Managed Extensions for C++
public __gc class PDFTextAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFTextAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFTextAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

The following tables list the members exposed by PDFTextAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFTextAnnotation Constructor | Overloaded. Initializes a new PDFTextAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : PDFTextAnnotation Constructor

Initializes a new PDFTextAnnotation object.

Overload List

Overload | Description
PDFTextAnnotation Constructor() | Initializes a new PDFTextAnnotation object.
PDFTextAnnotation Constructor(String,String) | Initializes a new PDFTextAnnotation object with a caption and content for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

PDFTextAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor()

Initializes a new PDFTextAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation()
C#
public PDFTextAnnotation()
Delphi
public PDFTextAnnotation();
Managed Extensions for C++
public: PDFTextAnnotation();
C++/CLI
public:
PDFTextAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


%%PageItemTitle%%

PDFTextAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor(String,String)

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.
Initializes a new PDFTextAnnotation object with a caption and content for the annotation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String
Dim contents As String

Dim instance As PDFTextAnnotation(caption, contents)
C#
public PDFTextAnnotation(
   string caption,
   string contents
)
Delphi
public PDFTextAnnotation(
    caption: String;
    contents: String
);
Managed Extensions for C++
public: PDFTextAnnotation(
   string* caption,
   string* contents
)
C++/CLI
public:
PDFTextAnnotation(
   String^ caption,
   String^ contents
)

Parameters

caption
the caption of the annotation window when the annotation is open.
contents
the content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation's icon.
Public Property | ID | Gets or sets the id of the annotation. (Inherited from PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from PDFAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | PopupRectangle | Gets or sets the rectangle of the popup window. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the subject of the annotation. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Icon Property

Gets or sets the annotation's icon.

Syntax

Visual Basic (Declaration)
Public Property Icon As TextAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As TextAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public TextAnnotationIcon Icon {get; set;}
Delphi
public read-write property Icon: TextAnnotationIcon;
Managed Extensions for C++
public: __property TextAnnotationIcon get_Icon();
public: __property void set_Icon(
   TextAnnotationIcon value
);
C++/CLI
public:
property TextAnnotationIcon Icon {
   TextAnnotationIcon get();
   void set (TextAnnotationIcon value);
}

Return Value

A TextAnnotationIcon enumeration member specifying the icon for the annotation when it is displayed in closed state.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

Open Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Open Property

Gets or sets whether the annotation should initially be displayed open.

Syntax

Visual Basic (Declaration)
Public Property Open As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As Boolean

instance.Open = value

value = instance.Open
C#
public bool Open {get; set;}
Delphi
public read-write property Open: Boolean;
Managed Extensions for C++
public: __property bool get_Open();
public: __property void set_Open(
   bool value
);
C++/CLI
public:
property bool Open {
   bool get();
   void set (bool value);
}

Return Value

True if the annotation should initially be displayed open. Default: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

AnnotationFlags Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : AnnotationFlags Enumeration

Specifies the available flags for an annotation.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum AnnotationFlags
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AnnotationFlags
C#
[FlagsAttribute()]
public enum AnnotationFlags : Enum
Delphi
public enum AnnotationFlags = class(Enum)
Managed Extensions for C++
[FlagsAttribute()]
__value public enum AnnotationFlags : public Enum
C++/CLI
[FlagsAttribute()]
public enum class AnnotationFlags : public Enum

Members

Member | Description
Hidden | If set, do not display or print the annotation or allow it to interact with the user.
Print | If set, print the annotation when the page is printed. If clear, never print the annotation, regardless of whether it is displayed on the screen.
NoZoom | If set, do not scale the annotation's appearance to match the magnification of the page.
NoRotate | If set, do not rotate the annotation's appearance to match the rotation of the page.
NoView | If set, do not display the annotation on the screen or allow it to interact with the user. The annotation may be printed (depending on the Print flag), but should be considered hidden for the purposes of onscreen display and user interaction.
ReadOnly | If set, do not allow the annotation to interact with the user.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.AnnotationFlags

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

BorderStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : BorderStyle Enumeration

Specifies the available styles for an annotation's border.

Syntax

Visual Basic (Declaration)
Public Enum BorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
C#
public enum BorderStyle : Enum
Delphi
public enum BorderStyle = class(Enum)
Managed Extensions for C++
__value public enum BorderStyle : public Enum
C++/CLI
public enum class BorderStyle : public Enum

Members

Member | Description
Solid | A solid rectangle surrounding the annotation.
Dashed | A dashed rectangle surrounding the annotation.
Beveled | A simulated embossed rectangle that appears to be raised above the surface of the page.
Inset | A simulated engraved rectangle that appears to be recessed below the surface of the page.
Underline | A single line along the bottom of the annotation rectangle.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.BorderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

FileAttachmentAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : FileAttachmentAnnotationIcon Enumeration

Specifies the available icons for a file atachment annotation when the annotation is closed.

Syntax

Visual Basic (Declaration)
Public Enum FileAttachmentAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FileAttachmentAnnotationIcon
C#
public enum FileAttachmentAnnotationIcon : Enum
Delphi
public enum FileAttachmentAnnotationIcon = class(Enum)
Managed Extensions for C++
__value public enum FileAttachmentAnnotationIcon : public Enum
C++/CLI
public enum class FileAttachmentAnnotationIcon : public Enum

Members

Member | Description
None | No icon.
Graph | Graph icon.
Paperclip | Paper clip icon.
PushPin | Push pin icon.
Tag | Tag.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.FileAttachmentAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

LineEndingStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : LineEndingStyle Enumeration

Specifies the available line ending styles to be used when drawing a line annotation.

Syntax

Visual Basic (Declaration)
Public Enum LineEndingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LineEndingStyle
C#
public enum LineEndingStyle : Enum
Delphi
public enum LineEndingStyle = class(Enum)
Managed Extensions for C++
__value public enum LineEndingStyle : public Enum
C++/CLI
public enum class LineEndingStyle : public Enum

Members

Member | Description
Square | A square filled with annotation's interior color, if any.
Circle | A circle filled with annotation's interior color, if any.
Diamond | A diamond filled with annotation's interior color, if any.
OpenArrow | Two short lines meeting in an acute angle, forming a open arrow head.
ClosedArrow | Two short lines meeting in an acute angle as in the OpenArrow style, connected by a third line to form a triangular closed arrowhead filled with annotation's interior color, if any.
None | No line ending.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.LineEndingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

LinkHighlightMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : LinkHighlightMode Enumeration

Specifies the available highlighting modes for a link annotation.

Syntax

Visual Basic (Declaration)
Public Enum LinkHighlightMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LinkHighlightMode
C#
public enum LinkHighlightMode : Enum
Delphi
public enum LinkHighlightMode = class(Enum)
Managed Extensions for C++
__value public enum LinkHighlightMode : public Enum
C++/CLI
public enum class LinkHighlightMode : public Enum

Members

Member | Description
None | No highlighting, the link's appearance does not change when the link is activated.
Invert | Inverts the content of link's normal appearance.
Outline | Inverts the link's border.
Push | Displays the link's down appearance.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.LinkHighlightMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

MarkupStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : MarkupStyle Enumeration

Specifies the available markup styles to be used when drawing a markup annotation.

Syntax

Visual Basic (Declaration)
Public Enum MarkupStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MarkupStyle
C#
public enum MarkupStyle : Enum
Delphi
public enum MarkupStyle = class(Enum)
Managed Extensions for C++
__value public enum MarkupStyle : public Enum
C++/CLI
public enum class MarkupStyle : public Enum

Members

Member | Description
Highlight | Highlight markup.
Underline | Underline markup.
Squiggly | Squiggly markup.
StrikeOut | StrikeOut markup.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.MarkupStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

MovieType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : MovieType Enumeration

Specifies the available movie types to be included in a PDF document.

Syntax

Visual Basic (Declaration)
Public Enum MovieType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MovieType
C#
public enum MovieType : Enum
Delphi
public enum MovieType = class(Enum)
Managed Extensions for C++
__value public enum MovieType : public Enum
C++/CLI
public enum class MovieType : public Enum

Members

Member | Description
Video_Avi | A video file with video/avi MIME type.
Video_Flc | A video file with video/flc MIME type.
Video_Mp4 | A video file with video/mp4 MIME type.
Video_Mpg | A video file with video/mpg MIME type.
Video_Mpeg | A video file with video/mpeg MIME type.
Video_MsVideo | A video file with video/msvideo MIME type.
Video_QuickTime | A video file with video/quicktime MIME type.
Video_X_Dv | A video file with video/x-dv MIME type.
Video_X_Ivf | A video file with video/x-ivf MIME type.
Video_X_Mpeg | A video file with video/x-mpeg MIME type.
Video_X_Mpg | A video file with video/x-mpg MIME type.
Video_X_Ms_Asf | A video file with video/x-ms-asf MIME type.
Video_X_Ms_Asx | A video file with video/x-ms-asx MIME type.
Video_X_Ms_Wm | A video file with video/x-ms-wm MIME type.
Video_X_Ms_Wmp | A video file with video/x-ms-wmp MIME type.
Video_X_Ms_Wmv | A video file with video/x-ms-wmv MIME type.
Video_X_Ms_Wmx | A video file with video/x-ms-wmx MIME type.
Video_X_Ms_Wvx | A video file with video/x-ms-wvx MIME type.
Video_X_MsVideo | A video file with video/x-msvideo MIME type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.MovieType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DActivationMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationMode Enumeration

Specifies the available modes for activating a 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DActivationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivationMode
C#
public enum PDF3DActivationMode : Enum
Delphi
public enum PDF3DActivationMode = class(Enum)
Managed Extensions for C++
__value public enum PDF3DActivationMode : public Enum
C++/CLI
public enum class PDF3DActivationMode : public Enum

Members

Member | Description
PageOpen | The annotation should be activated as soon as the page containing the annotation is opened.
PageVisible | The annotation should be activated as soon as any part of the page containing the annotation becomes visible.
ExplicitActivation | The annotation should remain inactive until explicitly activated by a script or user action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DActivationState Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationState Enumeration

Specifies the available states upon activation of the 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DActivationState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivationState
C#
public enum PDF3DActivationState : Enum
Delphi
public enum PDF3DActivationState = class(Enum)
Managed Extensions for C++
__value public enum PDF3DActivationState : public Enum
C++/CLI
public enum class PDF3DActivationState : public Enum

Members

Member | Description
Instantiated | The artwork is instantiated, but real-time script-driven animations are disabled.
Live | Real-time script-driven animations are enabled if present; if not, the artwork is instantiated.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnimationType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimationType Enumeration

Specifies the available styles for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DAnimationType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimationType
C#
public enum PDF3DAnimationType : Enum
Delphi
public enum PDF3DAnimationType = class(Enum)
Managed Extensions for C++
__value public enum PDF3DAnimationType : public Enum
C++/CLI
public enum class PDF3DAnimationType : public Enum

Members

Member | Description
None | Animations are driven through alternate means, such as JavaScript.
Linear | Keyframe animations are driven linearly from beginning to end.
Oscillating | Keyframe animations should oscillate along their time range.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DAnimationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DDeactivationMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationMode Enumeration

Specifies the available modes for activating a 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DDeactivationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DDeactivationMode
C#
public enum PDF3DDeactivationMode : Enum
Delphi
public enum PDF3DDeactivationMode = class(Enum)
Managed Extensions for C++
__value public enum PDF3DDeactivationMode : public Enum
C++/CLI
public enum class PDF3DDeactivationMode : public Enum

Members

Member | Description
PageClose | The annotation should be deactivated as soon as the page is closed.
PageInvisible | The annotation should be deactivated as soon as the page containing the annotation becomes invisible.
ExplicitDeactivation | The annotation should remain active until explicitly deactivated by a script or user action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DDeactivationState Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationState Enumeration

Specifies the available states upon deactivation of the 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DDeactivationState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DDeactivationState
C#
public enum PDF3DDeactivationState : Enum
Delphi
public enum PDF3DDeactivationState = class(Enum)
Managed Extensions for C++
__value public enum PDF3DDeactivationState : public Enum
C++/CLI
public enum class PDF3DDeactivationState : public Enum

Members

Member | Description
Uninstantiated | The artwork is uninstantiated.
Instantiated | The artwork remains instantiated.
Live | The artwork remains live.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DLightingStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingStyle Enumeration

Specifies the available styles for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DLightingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingStyle
C#
public enum PDF3DLightingStyle : Enum
Delphi
public enum PDF3DLightingStyle = class(Enum)
Managed Extensions for C++
__value public enum PDF3DLightingStyle : public Enum
C++/CLI
public enum class PDF3DLightingStyle : public Enum

Members

Member | Description
Artwork | Lights as specified in the 3D artwork.
None | No lights are used.
White | Three blue-grey infinite lights, no ambient term.
Day | Three light-grey infinite lights, no ambient term.
Night | One yellow, one aqua, and one blue infinite light, no ambient term.
Hard | Three grey infinite lights, moderate ambient term.
Primary | One red, one green, and one blue infinite light, no ambient term.
Blue | Three blue infinite lights, no ambient term.
Red | Three red infinite lights, no ambient term.
Cube | Six grey infinite lights aligned with the major axes, no ambient term.
CAD | Three grey infinite lights and one light attached to the camera, no ambient term.
Headlamp | Single infinite light attached to the camera, low ambient term.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DLightingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionClipStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionClipStyle Enumeration

Specifies the available styles for the projection clipping.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionClipStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionClipStyle
C#
public enum PDF3DProjectionClipStyle : Enum
Delphi
public enum PDF3DProjectionClipStyle = class(Enum)
Managed Extensions for C++
__value public enum PDF3DProjectionClipStyle : public Enum
C++/CLI
public enum class PDF3DProjectionClipStyle : public Enum

Members

Member | Description
ExplicitNearFar | Explicit near/far.
AutomaticNearFar | Automatic near/far.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionClipStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionOrthoScaleMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionOrthoScaleMode Enumeration

Specifies the available scaling modes for orthographic projections.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionOrthoScaleMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionOrthoScaleMode
C#
public enum PDF3DProjectionOrthoScaleMode : Enum
Delphi
public enum PDF3DProjectionOrthoScaleMode = class(Enum)
Managed Extensions for C++
__value public enum PDF3DProjectionOrthoScaleMode : public Enum
C++/CLI
public enum class PDF3DProjectionOrthoScaleMode : public Enum

Members

Member | Description
Width | Fit width.
Height | Fit height.
Min | Fit min between width and height.
Max | Fit max between width and height.
Absolute | No scaling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionOrthoScaleMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionType Enumeration

Specifies the available types for the projection of 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionType
C#
public enum PDF3DProjectionType : Enum
Delphi
public enum PDF3DProjectionType = class(Enum)
Managed Extensions for C++
__value public enum PDF3DProjectionType : public Enum
C++/CLI
public enum class PDF3DProjectionType : public Enum

Members

Member | Description
Orthographic | Orthographic projection.
Perspective | Perspective projection.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DRenderStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderStyle Enumeration

Specifies the available styles for rendering the 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DRenderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderStyle
C#
public enum PDF3DRenderStyle : Enum
Delphi
public enum PDF3DRenderStyle = class(Enum)
Managed Extensions for C++
__value public enum PDF3DRenderStyle : public Enum
C++/CLI
public enum class PDF3DRenderStyle : public Enum

Members

Member | Description
Solid | Displays textured and lit geometric shapes. The auxiliary color is ignored.
SolidWireframe | Displays textured and lit geometric shapes (triangles) with single color edges on top of them. The color of these edges is determined by the auxiliary color.
Transparent | Displays textured and lit geometric shapes (triangles) with an added level of transparency. The auxiliary color is ignored.
TransparentWireframe | Displays textured and lit geometric shapes (triangles) with an added level of transparency, with single color opaque edges on top of it. The color of these edges is determined by the auxiliary color.
BoundingBox | Displays the bounding box edges of each node. The color of the bounding box edges is determined by the auxiliary color.
TransparentBoundingBox | Displays bounding boxes faces of each node with an added level of transparency. The color of the bounding box faces is determined by the face color.
TransparentBoundingBoxOutline | Displays bounding boxes edges and faces of each node with an added level of transparency. The color of the bounding box edges is determined by the auxiliary color. The color of the bounding boxes faces is determined by the face color.
Wireframe | Displays only edges in a single color. The color of these edges is determined by the auxiliary color.
ShadedWireframe | Displays only edges and applies lighting. The auxiliary color is ignored.
HiddenWireframe | Displays edges in a single color, though removes back-facing and obscured edges. The color of these edges is determined by the auxiliary color.
Vertices | Displays only vertices in a single color. The color of these points is determined by the auxiliary color.
ShadedVertices | Displays only vertices, though uses their vertex color and applies lighting. The auxiliary color is ignored.
Illustration | Displays silhouette edges with surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color, and the color of the surfaces is determined by the face color.
SolidOutline | Displays silhouette edges with lit and textured surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color.
ShadedIllustration | Displays silhouette edges with lit and textured surfaces and an additional emissive term to remove poorly lit areas of the artwork. The color of these edges is determined by the auxiliary color.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DRenderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

RubberStampAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : RubberStampAnnotationIcon Enumeration

Specifies the available icons for a rubber stamp annotation when the annotation is closed.

Syntax

Visual Basic (Declaration)
Public Enum RubberStampAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RubberStampAnnotationIcon
C#
public enum RubberStampAnnotationIcon : Enum
Delphi
public enum RubberStampAnnotationIcon = class(Enum)
Managed Extensions for C++
__value public enum RubberStampAnnotationIcon : public Enum
C++/CLI
public enum class RubberStampAnnotationIcon : public Enum

Members

Member | Description
Approved | Approved icon.
AsIs | AsIs icon.
Confidential | Confidential icon.
Departmental | Departmental icon.
Draft | Draft icon.
Experimental | Experimental icon.
Expired | Expired icon.
Final | Final icon.
ForComment | For comment icon.
ForPublicRelease | For public release icon.
NotApproved | Not approved icon.
NotForPublicRelease | Not for public release icon.
Sold | Sold icon.
SBRejected | Rejected icon.
SHAccepted | Checkmark icon.
SHInitialHere | Initial here icon.
SHSignHere | Sign here icon.
SHWitness | Witness icon.
TopSecret | Top secret icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.RubberStampAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

TextAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : TextAnnotationIcon Enumeration

Specifies the available icons for a text annotation when the annotation is closed.

Syntax

Visual Basic (Declaration)
Public Enum TextAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextAnnotationIcon
C#
public enum TextAnnotationIcon : Enum
Delphi
public enum TextAnnotationIcon = class(Enum)
Managed Extensions for C++
__value public enum TextAnnotationIcon : public Enum
C++/CLI
public enum class TextAnnotationIcon : public Enum

Members

Member | Description
Check | Check icon.
Circle | Circle icon.
Comment | Comment icon.
Cross | Cross icon.
Help | Help icon.
Insert | Insert icon.
Key | Key icon.
NewParagraph | New paragraph icon.
Note | Note icon.
Paragraph | Paragraph icon.
RightArrow | Right arrow icon.
RightPointer | Right pointer icon.
Star | Star icon.
UpArrow | Up arrow icon.
UpLeftArrow | Up left arrow icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.TextAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Forms Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
FDFField | Defines a field in a FDF document.
FDFFieldCollection | Defines a collection of fields in a FDF document.
FDFFile | Represents a FDF file on disk.
PDFCheckBoxAppearance | Defines the appearance of a check box field.
PDFCheckBoxField | Defines a check box in the PDF file.
PDFDropDownListField | Defines a drop down list field for user input in the PDF file.
PDFField | Defines a field in a PDF form.
PDFFieldActions | Defines the actions to be performed as response to field events.
PDFFieldAppearance | Defines the visual appearance of a form field.
PDFFieldBorder | Defines the visual aspect of the border for a field created from code.
PDFFieldImportError | Represents an error that happened during the import of a FDF/XFDF/XML file.
PDFFieldInfo | This class defines extended properties for a PDF form field.
PDFFields | Defines a collection of fields in a PDF document.
PDFForm | Defines an e-form in a PDF document.
PDFListBoxField | Defines a scrollable list box field for user input in the PDF file.
PDFListField | Base class for all list type fields.
PDFListItem | Defines an item in a list.
PDFListItemCollection | Defines a collection of items in a list.
PDFPushbuttonAppearance | Defines the appearance of a push button field.
PDFPushbuttonField | Defines a pushbutton in the PDF file.
PDFRadioButtonAppearance | Defines the appearance of a radiobutton.
PDFRadioButtonItem | Defines a single radio button in a PDFRadioButtonListField object.
PDFRadioButtonItemCollection | Defines a collection of radio button items.
PDFRadioButtonListField | Defines a list of exclusive radio buttons in the PDF file.
PDFSignatureAppearance | Defines the appearance of a signature field.
PDFSignatureField | Defines a signature field for digitally signing the PDF file.
PDFTextBoxField | Defines a text box field for user input in the PDF file.
PDFWidgetActions | Defines the actions to be performed as response to field widget events.
PDFWidgetAnnotation | Defines the widget annotation corresponding to a form field.
XFDFField | Defines a field in a XFDF document.
XFDFFieldCollection | Defines a collection of fields in a XFDF document.
XFDFFile | Represents a XFDF file on disk.

Enumerations

Enumeration | Description
DataFormat | Specifies the available formats for data import/export for AcroForms.
ExportDataOptions | Specifies the available export options for PDF forms.
FieldBorderStyle | Specifies the available styles for a field's border.
FieldRemoveOptions | Specifies the available options for removing a field from a PDF form.
FieldRenameOptions | Specifies the available options for renaming a field in a PDF form.
FieldTextAlign | Specifies the available alignments for text in a text box field.
FieldVisibilityStatus | Specifies the available visibility states for a field.
HighlightMode | Specifies the available highlighting modes for a button.
IconLayoutMode | Specifies the available modes for displaying the icon on a pushbutton.
SymbolStyle | Specifies the available style for a check box.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Forms Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFFieldCollection
O2S.Components.PDF4NET.Forms.FDFFile
O2S.Components.PDF4NET.Forms.PDFFieldBorder
O2S.Components.PDF4NET.Forms.PDFFieldImportError
O2S.Components.PDF4NET.Forms.PDFFieldInfo
O2S.Components.PDF4NET.Forms.PDFListItem
O2S.Components.PDF4NET.Forms.XFDFField
O2S.Components.PDF4NET.Forms.XFDFFieldCollection
O2S.Components.PDF4NET.Forms.XFDFFile
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.Forms.FDFField
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFWidgetAnnotation
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField
O2S.Components.PDF4NET.Forms.PDFListBoxField
O2S.Components.PDF4NET.Forms.PDFPushbuttonField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFTextBoxField
O2S.Components.PDF4NET.Forms.PDFFieldActions
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFCheckBoxAppearance
O2S.Components.PDF4NET.Forms.PDFPushbuttonAppearance
O2S.Components.PDF4NET.Forms.PDFRadioButtonAppearance
O2S.Components.PDF4NET.Forms.PDFSignatureAppearance
O2S.Components.PDF4NET.Forms.PDFFields
O2S.Components.PDF4NET.Forms.PDFForm
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.PDFRadioButtonItemCollection
O2S.Components.PDF4NET.Forms.PDFWidgetActions

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

FDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

Defines a field in a FDF document.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FDFField
   Inherits PDFImportedObject
Visual Basic (Usage) Copy Code
Dim instance As FDFField
C#
public sealed class FDFField : PDFImportedObject
Delphi
public class FDFField = class(PDFImportedObject)sealed;
Managed Extensions for C++
public __gc __sealed class FDFField : public PDFImportedObject
C++/CLI
public ref class FDFField sealed : public PDFImportedObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.Forms.FDFField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

The following tables list the members exposed by FDFField.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

FDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

For a list of all members of this type, see FDFField members.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Name Property

Gets the field name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As FDFField
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the FDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Class
FDFField Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Value Property

Gets the field value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As FDFField
Dim value As String

value = instance.Value
C#
public string Value {get;}
Delphi
public read-only property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
C++/CLI
public:
property String^ Value {
   String^ get();
}

Return Value

A string value specifying the value of the FDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Class
FDFField Members


%%PageItemTitle%%

FDFFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

Defines a collection of fields in a FDF document.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class FDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class FDFFieldCollection
Delphi
public class FDFFieldCollection sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class FDFFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class FDFFieldCollection sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

The following tables list the members exposed by FDFFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the field in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

FDFFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the field in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : IndexOf Method

field
The field to locate in the collection.
Returns the zero-based index of the first occurrence of the field in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal field As FDFField _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim field As FDFField
Dim value As Integer

value = instance.IndexOf(field)
C#
public int IndexOf(
   FDFField field
)
Delphi
public function IndexOf(
    field: FDFField
): Integer;
Managed Extensions for C++
public: int IndexOf(
   FDFField* field
)
C++/CLI
public:
int IndexOf(
   FDFField^ field
)

Parameters

field
The field to locate in the collection.

Return Value

The zero-based index of the first occurrence of the field within the entire collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%% $$Properties$$

FDFFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : Count Property

Returns the number of fields in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class : Item Property

Gets the field at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Gets the field with the specified name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class > Item Property : Item(Int32) Property

index
Gets the field at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As FDFField
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim index As Integer
Dim value As FDFField

value = instance.Item(index)
C#
public FDFField Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): FDFField;
Managed Extensions for C++
public: __property FDFField* get_Item(
   int index
);
C++/CLI
public:
property FDFField^ Item {
   FDFField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when index is less than zero or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFieldCollection Class > Item Property : Item(String) Property

name
Gets the field with the specified name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As FDFField
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
Dim name As String
Dim value As FDFField

value = instance.Item(name)
C#
public FDFField Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): FDFField;
Managed Extensions for C++
public: __property FDFField* get_Item(
   string* name
);
C++/CLI
public:
property FDFField^ Item {
   FDFField^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Class
FDFFieldCollection Members
Overload List


%%PageItemTitle%%

FDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

Represents a FDF file on disk.

Syntax

Visual Basic (Declaration)
Public Class FDFFile
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
C#
public class FDFFile
Delphi
public class FDFFile
Managed Extensions for C++
public __gc class FDFFile
C++/CLI
public ref class FDFFile

Remarks

This class defines an existing FDF file. Its methods allows to import/export data from/to FDF files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

The following tables list the members exposed by FDFFile.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | IsRepaired | Gets whether the PDF file was repaired or not before it has been loaded.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

FDFFile Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Close Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As FDFFile

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

FromFile Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromFile Method

fileName
the full path to a FDF file used as source for this FDFFile object.
Creates a FDFFile object from the given FDF file.

Syntax

Visual Basic (Declaration)
Public Shared Function FromFile( _
   ByVal fileName As String _
) As FDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As FDFFile

value = FDFFile.FromFile(fileName)
C#
public static FDFFile FromFile(
   string fileName
)
Delphi
public function FromFile(
    fileName: String
): FDFFile; static;
Managed Extensions for C++
public: static FDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static FDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a FDF file used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

FromStream Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromStream Method

stream
the stream object used as source for this FDFFile object.
Creates a FDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As FDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As FDFFile

value = FDFFile.FromStream(stream)
C#
public static FDFFile FromStream(
   Stream stream
)
Delphi
public function FromStream(
    stream: Stream
): FDFFile; static;
Managed Extensions for C++
public: static FDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static FDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given stream object.

Remarks

The stream must contain a valid FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%% $$Properties$$

FDFFile Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | IsRepaired | Gets whether the PDF file was repaired or not before it has been loaded.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Fields Property

Gets the list of fields in the FDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
Dim value As FDFFieldCollection

value = instance.Fields
C#
public FDFFieldCollection Fields {get;}
Delphi
public read-only property Fields: FDFFieldCollection;
Managed Extensions for C++
public: __property FDFFieldCollection* get_Fields();
C++/CLI
public:
property FDFFieldCollection^ Fields {
   FDFFieldCollection^ get();
}

Return Value

A FDFFieldCollection object specifying the list of fields in the FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

IsRepaired Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : IsRepaired Property

Gets whether the PDF file was repaired or not before it has been loaded.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRepaired As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
Dim value As Boolean

value = instance.IsRepaired
C#
public bool IsRepaired {get;}
Delphi
public read-only property IsRepaired: Boolean;
Managed Extensions for C++
public: __property bool get_IsRepaired();
C++/CLI
public:
property bool IsRepaired {
   bool get();
}

Return Value

True if the file has been repaired before it has been loaded, false otherwise.

Remarks

The file is repaired in memory, the original file on disk is not affected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

PDFFileName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : PDFFileName Property

Gets the name of the PDF file the FDF file was exported from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFFileName As String
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
Dim value As String

value = instance.PDFFileName
C#
public string PDFFileName {get;}
Delphi
public read-only property PDFFileName: String;
Managed Extensions for C++
public: __property string* get_PDFFileName();
C++/CLI
public:
property String^ PDFFileName {
   String^ get();
}

Return Value

A string value specifying the the name of the PDF file the FDF file was exported from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

PDFCheckBoxAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxAppearance Class

Defines the appearance of a check box field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCheckBoxAppearance
   Inherits PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxAppearance
C#
public class PDFCheckBoxAppearance : PDFFieldAppearance
Delphi
public class PDFCheckBoxAppearance = class(PDFFieldAppearance)
Managed Extensions for C++
public __gc class PDFCheckBoxAppearance : public PDFFieldAppearance
C++/CLI
public ref class PDFCheckBoxAppearance : public PDFFieldAppearance

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFCheckBoxAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxAppearance Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxAppearance Class

The following tables list the members exposed by PDFCheckBoxAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFCheckBoxAppearance Constructor | Initilizes a new PDFCheckBoxAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFCheckBoxAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxAppearance Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxAppearance Class : PDFCheckBoxAppearance Constructor

Initilizes a new PDFCheckBoxAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxAppearance()
C#
public PDFCheckBoxAppearance()
Delphi
public PDFCheckBoxAppearance();
Managed Extensions for C++
public: PDFCheckBoxAppearance();
C++/CLI
public:
PDFCheckBoxAppearance();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxAppearance Class
PDFCheckBoxAppearance Members


%%PageItemTitle%%

PDFCheckBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

Defines a check box in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCheckBoxField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
C#
public class PDFCheckBoxField : PDFField
Delphi
public class PDFCheckBoxField = class(PDFField)
Managed Extensions for C++
public __gc class PDFCheckBoxField : public PDFField
C++/CLI
public ref class PDFCheckBoxField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

The following tables list the members exposed by PDFCheckBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | Checked | Gets or sets whether the check box field is checked.
Public Property | CheckedDownAppearance | Gets the down checked visual appearance of this field.
Public Property | CheckedNormalAppearance | Gets the normal checked visual appearance of this field.
Public Property | CheckedRolloverAppearance | Gets the rollover checked visual appearance of this field.
Public Property | ExportValue | Gets or sets the export value of the field.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Style | Gets or sets the style of the check box.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | UncheckedDownAppearance | Gets the down unchecked visual appearance of this field.
Public Property | UncheckedNormalAppearance | Gets the normal unchecked visual appearance of this field.
Public Property | UncheckedRolloverAppearance | Gets the rollover unchecked visual appearance of this field.
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor

name
The name of this field object.
Initializes a new PDFCheckBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFCheckBoxField(name)
C#
public PDFCheckBoxField(
   string name
)
Delphi
public PDFCheckBoxField(
    name: String
);
Managed Extensions for C++
public: PDFCheckBoxField(
   string* name
)
C++/CLI
public:
PDFCheckBoxField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%% $$Properties$$

PDFCheckBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | Checked | Gets or sets whether the check box field is checked.
Public Property | CheckedDownAppearance | Gets the down checked visual appearance of this field.
Public Property | CheckedNormalAppearance | Gets the normal checked visual appearance of this field.
Public Property | CheckedRolloverAppearance | Gets the rollover checked visual appearance of this field.
Public Property | ExportValue | Gets or sets the export value of the field.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Style | Gets or sets the style of the check box.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | UncheckedDownAppearance | Gets the down unchecked visual appearance of this field.
Public Property | UncheckedNormalAppearance | Gets the normal unchecked visual appearance of this field.
Public Property | UncheckedRolloverAppearance | Gets the rollover unchecked visual appearance of this field.
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Checked Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : Checked Property

Gets or sets whether the check box field is checked.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Delphi
public read-write property Checked: Boolean;
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (bool value);
}

Return Value

True if the check box is checked, false otherwise.

Remarks

When there are multiple checkboxes with the same name, but with different export values, this property checks or unchecks the current checkbox appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

CheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : CheckedDownAppearance Property

Gets the down checked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property CheckedDownAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

instance.CheckedDownAppearance = value

value = instance.CheckedDownAppearance
C#
public PDFCheckBoxAppearance CheckedDownAppearance {get; set;}
Delphi
public read-write property CheckedDownAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_CheckedDownAppearance();
public: __property void set_CheckedDownAppearance(
   PDFCheckBoxAppearance* value
);
C++/CLI
public:
property PDFCheckBoxAppearance^ CheckedDownAppearance {
   PDFCheckBoxAppearance^ get();
   void set (PDFCheckBoxAppearance^ value);
}

Return Value

A PDFCheckBoxAppearance object specifying the down checked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

CheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : CheckedNormalAppearance Property

Gets the normal checked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckedNormalAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

value = instance.CheckedNormalAppearance
C#
public PDFCheckBoxAppearance CheckedNormalAppearance {get;}
Delphi
public read-only property CheckedNormalAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_CheckedNormalAppearance();
C++/CLI
public:
property PDFCheckBoxAppearance^ CheckedNormalAppearance {
   PDFCheckBoxAppearance^ get();
}

Return Value

A PDFCheckBoxAppearance object specifying the normal checked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

CheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : CheckedRolloverAppearance Property

Gets the rollover checked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property CheckedRolloverAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

instance.CheckedRolloverAppearance = value

value = instance.CheckedRolloverAppearance
C#
public PDFCheckBoxAppearance CheckedRolloverAppearance {get; set;}
Delphi
public read-write property CheckedRolloverAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_CheckedRolloverAppearance();
public: __property void set_CheckedRolloverAppearance(
   PDFCheckBoxAppearance* value
);
C++/CLI
public:
property PDFCheckBoxAppearance^ CheckedRolloverAppearance {
   PDFCheckBoxAppearance^ get();
   void set (PDFCheckBoxAppearance^ value);
}

Return Value

A PDFCheckBoxAppearance object specifying the rollover checked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

ExportValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : ExportValue Property

Gets or sets the export value of the field.

Syntax

Visual Basic (Declaration)
Public Property ExportValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As String

instance.ExportValue = value

value = instance.ExportValue
C#
public string ExportValue {get; set;}
Delphi
public read-write property ExportValue: String;
Managed Extensions for C++
public: __property string* get_ExportValue();
public: __property void set_ExportValue(
   string* value
);
C++/CLI
public:
property String^ ExportValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the export value of the field.

Remarks

When there are multiple checkboxes with the same name, but with different export values, this property gets or sets the export value for the current checkbox appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

Style Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : Style Property

Gets or sets the style of the check box.

Syntax

Visual Basic (Declaration)
Public Property Style As SymbolStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As SymbolStyle

instance.Style = value

value = instance.Style
C#
public SymbolStyle Style {get; set;}
Delphi
public read-write property Style: SymbolStyle;
Managed Extensions for C++
public: __property SymbolStyle get_Style();
public: __property void set_Style(
   SymbolStyle value
);
C++/CLI
public:
property SymbolStyle Style {
   SymbolStyle get();
   void set (SymbolStyle value);
}

Return Value

A SymbolStyle enumeration member specifying the style of the checkbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

UncheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : UncheckedDownAppearance Property

Gets the down unchecked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property UncheckedDownAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

instance.UncheckedDownAppearance = value

value = instance.UncheckedDownAppearance
C#
public PDFCheckBoxAppearance UncheckedDownAppearance {get; set;}
Delphi
public read-write property UncheckedDownAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_UncheckedDownAppearance();
public: __property void set_UncheckedDownAppearance(
   PDFCheckBoxAppearance* value
);
C++/CLI
public:
property PDFCheckBoxAppearance^ UncheckedDownAppearance {
   PDFCheckBoxAppearance^ get();
   void set (PDFCheckBoxAppearance^ value);
}

Return Value

A PDFCheckBoxAppearance object specifying the down unchecked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

UncheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : UncheckedNormalAppearance Property

Gets the normal unchecked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UncheckedNormalAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

value = instance.UncheckedNormalAppearance
C#
public PDFCheckBoxAppearance UncheckedNormalAppearance {get;}
Delphi
public read-only property UncheckedNormalAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_UncheckedNormalAppearance();
C++/CLI
public:
property PDFCheckBoxAppearance^ UncheckedNormalAppearance {
   PDFCheckBoxAppearance^ get();
}

Return Value

A PDFCheckBoxAppearance object specifying the normal checked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

UncheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : UncheckedRolloverAppearance Property

Gets the rollover unchecked visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property UncheckedRolloverAppearance As PDFCheckBoxAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As PDFCheckBoxAppearance

instance.UncheckedRolloverAppearance = value

value = instance.UncheckedRolloverAppearance
C#
public PDFCheckBoxAppearance UncheckedRolloverAppearance {get; set;}
Delphi
public read-write property UncheckedRolloverAppearance: PDFCheckBoxAppearance;
Managed Extensions for C++
public: __property PDFCheckBoxAppearance* get_UncheckedRolloverAppearance();
public: __property void set_UncheckedRolloverAppearance(
   PDFCheckBoxAppearance* value
);
C++/CLI
public:
property PDFCheckBoxAppearance^ UncheckedRolloverAppearance {
   PDFCheckBoxAppearance^ get();
   void set (PDFCheckBoxAppearance^ value);
}

Return Value

A PDFCheckBoxAppearance object specifying the rollover unchecked visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

PDFDropDownListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

Defines a drop down list field for user input in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDropDownListField
   Inherits PDFListField
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
C#
public class PDFDropDownListField : PDFListField
Delphi
public class PDFDropDownListField = class(PDFListField)
Managed Extensions for C++
public __gc class PDFDropDownListField : public PDFListField
C++/CLI
public ref class PDFDropDownListField : public PDFListField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFDropDownListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

The following tables list the members exposed by PDFDropDownListField.

Public Constructors

 | Name | Description
Public Constructor | PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor

name
The name of this field object.
Initializes a new PDFDropDownListField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFDropDownListField(name)
C#
public PDFDropDownListField(
   string name
)
Delphi
public PDFDropDownListField(
    name: String
);
Managed Extensions for C++
public: PDFDropDownListField(
   string* name
)
C++/CLI
public:
PDFDropDownListField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%% $$Properties$$

PDFDropDownListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : Appearance Property

Gets the visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As PDFFieldAppearance

value = instance.Appearance
C#
public PDFFieldAppearance Appearance {get;}
Delphi
public read-only property Appearance: PDFFieldAppearance;
Managed Extensions for C++
public: __property PDFFieldAppearance* get_Appearance();
C++/CLI
public:
property PDFFieldAppearance^ Appearance {
   PDFFieldAppearance^ get();
}

Return Value

A PDFFieldAppearance object specifying the visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

CheckSpelling Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : CheckSpelling Property

Gets or sets whether the field content should be checked for spelling erorrs.

Syntax

Visual Basic (Declaration)
Public Property CheckSpelling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
C#
public bool CheckSpelling {get; set;}
Delphi
public read-write property CheckSpelling: Boolean;
Managed Extensions for C++
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
C++/CLI
public:
property bool CheckSpelling {
   bool get();
   void set (bool value);
}

Return Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.

Remarks

The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code. This flag has meaning only if Edit is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

CommitOnSelChange Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : CommitOnSelChange Property

Gets or sets whether the selected item is commited as soon as the selection is made.

Syntax

Visual Basic (Declaration)
Public Property CommitOnSelChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.CommitOnSelChange = value

value = instance.CommitOnSelChange
C#
public bool CommitOnSelChange {get; set;}
Delphi
public read-write property CommitOnSelChange: Boolean;
Managed Extensions for C++
public: __property bool get_CommitOnSelChange();
public: __property void set_CommitOnSelChange(
   bool value
);
C++/CLI
public:
property bool CommitOnSelChange {
   bool get();
   void set (bool value);
}

Return Value

True if the selected item is commited as soon as the selection is made, false otherwise. Default is false.

Remarks

If set, the new value is committed as soon as a selection is made with the pointing device. This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

Edit Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : Edit Property

Gets or sets whether the user can enter text in the drop down list or not.

Syntax

Visual Basic (Declaration)
Public Property Edit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.Edit = value

value = instance.Edit
C#
public bool Edit {get; set;}
Delphi
public read-write property Edit: Boolean;
Managed Extensions for C++
public: __property bool get_Edit();
public: __property void set_Edit(
   bool value
);
C++/CLI
public:
property bool Edit {
   bool get();
   void set (bool value);
}

Return Value

True if the drop down list is editable, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

Sort Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : Sort Property

Gets or sets whether the items in the drop down list should be sorted alphabetically or not.

Syntax

Visual Basic (Declaration)
Public Property Sort As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
C#
public bool Sort {get; set;}
Delphi
public read-write property Sort: Boolean;
Managed Extensions for C++
public: __property bool get_Sort();
public: __property void set_Sort(
   bool value
);
C++/CLI
public:
property bool Sort {
   bool get();
   void set (bool value);
}

Return Value

True if the items are sorted, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

PDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

Defines a field in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFField
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFField
C#
public class PDFField : PDFObject
Delphi
public class PDFField = class(PDFObject)
Managed Extensions for C++
public __gc class PDFField : public PDFObject
C++/CLI
public ref class PDFField : public PDFObject

Remarks

This is the base class for all field types in a PDF form.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFTextBoxField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFPushbuttonField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

The following tables list the members exposed by PDFField.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events.
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field.
Public Property | FieldInfo | Gets additional information about the form field.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets the name of the field.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the tooltip of the field.
Public Property | Value | Gets or sets the value of the field.
Public Property | WidgetCount | Gets the number of field widgets.
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document.
Public Method | ActivateLastWidget | Activates the last field widget within the page or document.
Public Method | ActivateNextWidget | Activates the next field widget within the page or document.
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document.
Public Method | ActivateLastWidget | Activates the last field widget within the page or document.
Public Method | ActivateNextWidget | Activates the next field widget within the page or document.
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

ActivateFirstWidget Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ActivateFirstWidget Method

Activates the first field widget within the page or document.

Syntax

Visual Basic (Declaration)
Public Sub ActivateFirstWidget()
Visual Basic (Usage) Copy Code
Dim instance As PDFField

instance.ActivateFirstWidget()
C#
public void ActivateFirstWidget()
Delphi
public procedure ActivateFirstWidget();
Managed Extensions for C++
public: void ActivateFirstWidget();
C++/CLI
public:
void ActivateFirstWidget();

Remarks

A field can appear multiple times on a PDF page or in a PDF document. Each visible representation of the field is called widget. This method sets the first widget of the field as active. This means that the Appearance properties of the field will correspond to the first widget of the field within the page or document. First widget does not necessary mean that it is the first visible field widget on the page or document.
If the field reference was obtained using the Fields collection of a page, then this method activates the first field widget on the page. If the field reference was obtained using the Fields collection of the document, then this method activates the first field widget within the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

ActivateLastWidget Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ActivateLastWidget Method

Activates the last field widget within the page or document.

Syntax

Visual Basic (Declaration)
Public Sub ActivateLastWidget()
Visual Basic (Usage) Copy Code
Dim instance As PDFField

instance.ActivateLastWidget()
C#
public void ActivateLastWidget()
Delphi
public procedure ActivateLastWidget();
Managed Extensions for C++
public: void ActivateLastWidget();
C++/CLI
public:
void ActivateLastWidget();

Remarks

A field can appear multiple times on a PDF page or document. Each visible representation of the field is called widget. This method sets the last widget of the field as active. This means that the Appearance properties of the field will correspond to the last widget of the field within the page or document. Last widget does not necessary mean that it is the last visible field widget on the page or document.
If the field reference was obtained using the Fields collection of a page, then this method activates the last field widget on the page. If the field reference was obtained using the Fields collection of the document, then this method activates the last field widget within the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

ActivateNextWidget Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ActivateNextWidget Method

Activates the next field widget within the page or document.

Syntax

Visual Basic (Declaration)
Public Function ActivateNextWidget() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

value = instance.ActivateNextWidget()
C#
public bool ActivateNextWidget()
Delphi
public function ActivateNextWidget(): Boolean;
Managed Extensions for C++
public: bool ActivateNextWidget();
C++/CLI
public:
bool ActivateNextWidget();

Return Value

True if the next widget exists and can be activated, false otherwise.

Remarks

A field can appear multiple times on a PDF page or document. Each visible representation of the field is called widget. This method sets the next widget of the field (relative to current one) as active. This means that the Appearance properties of the field will correspond to the next appearance of the field within the page or document.
If the field reference was obtained using the Fields collection of a page, then this method activates the next field widget on the page. If the field reference was obtained using the Fields collection of the document, then this method activates the next field widget within the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

ActivatePreviousWidget Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ActivatePreviousWidget Method

Activates the previous field widget within the page.

Syntax

Visual Basic (Declaration)
Public Function ActivatePreviousWidget() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

value = instance.ActivatePreviousWidget()
C#
public bool ActivatePreviousWidget()
Delphi
public function ActivatePreviousWidget(): Boolean;
Managed Extensions for C++
public: bool ActivatePreviousWidget();
C++/CLI
public:
bool ActivatePreviousWidget();

Return Value

True if the previous widget exists and can be activated, false otherwise.

Remarks

A field can appear multiple times on a PDF page or document. Each visible representation of the field is called widget. This method sets the previous widget of the field (relative to current one) as active. This means that the Appearance properties of the field will correspond to the previous widget of the field within the page or document
. If the field reference was obtained using the Fields collection of a page, then this method activates the previous field widget on the page. If the field reference was obtained using the Fields collection of the document, then this method activates the previous field widget within the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%% $$Properties$$

PDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events.
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field.
Public Property | FieldInfo | Gets additional information about the form field.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets the name of the field.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the tooltip of the field.
Public Property | Value | Gets or sets the value of the field.
Public Property | WidgetCount | Gets the number of field widgets.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Actions Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Actions Property

Gets the actions to be performed by this field in response to field events.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As PDFFieldActions
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFFieldActions

value = instance.Actions
C#
public PDFFieldActions Actions {get;}
Delphi
public read-only property Actions: PDFFieldActions;
Managed Extensions for C++
public: __property PDFFieldActions* get_Actions();
C++/CLI
public:
property PDFFieldActions^ Actions {
   PDFFieldActions^ get();
}

Return Value

A PDFFieldActions object specifying the actions to be performed in response to field events.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Align Property

Gets or sets the text alignment in a field.

Syntax

Visual Basic (Declaration)
Public Property Align As FieldTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As FieldTextAlign

instance.Align = value

value = instance.Align
C#
public FieldTextAlign Align {get; set;}
Delphi
public read-write property Align: FieldTextAlign;
Managed Extensions for C++
public: __property FieldTextAlign get_Align();
public: __property void set_Align(
   FieldTextAlign value
);
C++/CLI
public:
property FieldTextAlign Align {
   FieldTextAlign get();
   void set (FieldTextAlign value);
}

Return Value

A FieldTextAlign enumeration member specifying the text alignment in a field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

CalcOrderIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : CalcOrderIndex Property

Gets or sets the calculation order for this field.

Syntax

Visual Basic (Declaration)
Public Property CalcOrderIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Integer

instance.CalcOrderIndex = value

value = instance.CalcOrderIndex
C#
public int CalcOrderIndex {get; set;}
Delphi
public read-write property CalcOrderIndex: Integer;
Managed Extensions for C++
public: __property int get_CalcOrderIndex();
public: __property void set_CalcOrderIndex(
   int value
);
C++/CLI
public:
property int CalcOrderIndex {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the calculation order for this field.

Remarks

This property applies only to fields that have a PDFFieldActions.Calculate action and it defines the order of calculating the fields. The field with the lowest order index is calculated first and the field with the highest order index is calculated last. Fields with 0 order index are not calculated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

FieldInfo Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : FieldInfo Property

Gets additional information about the form field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldInfo As PDFFieldInfo()
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value() As PDFFieldInfo

value = instance.FieldInfo
C#
public PDFFieldInfo[] FieldInfo {get;}
Delphi
public read-only property FieldInfo: array of PDFFieldInfo;
Managed Extensions for C++
public: __property PDFFieldInfo*[]* get_FieldInfo();
C++/CLI
public:
property array<PDFFieldInfo^>^ FieldInfo {
   array<PDFFieldInfo^>^ get();
}

Remarks

For fields with a single representation (textboxes, checkboxes, comboboxes and listboxes), this array has only one element, but for fields with multiple representations (radiobuttons), this array has an element for each radiobutton.
This property can be null if field extended info can not be read from the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

MappingName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : MappingName Property

Gets or sets the mapping name of the field.

Syntax

Visual Basic (Declaration)
Public Property MappingName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.MappingName = value

value = instance.MappingName
C#
public string MappingName {get; set;}
Delphi
public read-write property MappingName: String;
Managed Extensions for C++
public: __property string* get_MappingName();
public: __property void set_MappingName(
   string* value
);
C++/CLI
public:
property String^ MappingName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the mapping name of the field.

Remarks

The field's mapping name is used when exporting interactive form field data from the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Name Property

Gets the name of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the field.

Remarks

The name of the field is defined in the PDF file and it can not be changed.
A field can be located in the PDFDocument.Fields collection of PDFDocument class by its name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

NoExport Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : NoExport Property

Gets or sets a value indicating whether the field can be exported or not.

Syntax

Visual Basic (Declaration)
Public Property NoExport As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.NoExport = value

value = instance.NoExport
C#
public bool NoExport {get; set;}
Delphi
public read-write property NoExport: Boolean;
Managed Extensions for C++
public: __property bool get_NoExport();
public: __property void set_NoExport(
   bool value
);
C++/CLI
public:
property bool NoExport {
   bool get();
   void set (bool value);
}

Return Value

True if the field can not be exported, false otherwise. Default is false.

Remarks

If true, the field must not be exported by a submit-form action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

ReadOnly Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ReadOnly Property

Gets or sets a value indicating whether the field is read-only.

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: Boolean;
Managed Extensions for C++
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
public:
property bool ReadOnly {
   bool get();
   void set (bool value);
}

Return Value

True if the field is read-only, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

Required Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Required Property

Gets or sets a value indicating whether the field is required.

Syntax

Visual Basic (Declaration)
Public Property Required As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.Required = value

value = instance.Required
C#
public bool Required {get; set;}
Delphi
public read-write property Required: Boolean;
Managed Extensions for C++
public: __property bool get_Required();
public: __property void set_Required(
   bool value
);
C++/CLI
public:
property bool Required {
   bool get();
   void set (bool value);
}

Return Value

True if the field is required, false otherwise. Default is false.

Remarks

If true, the field must have a value when it is exported by a submit-form action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

Tooltip Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Tooltip Property

Gets or sets the tooltip of the field.

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public string Tooltip {get; set;}
Delphi
public read-write property Tooltip: String;
Managed Extensions for C++
public: __property string* get_Tooltip();
public: __property void set_Tooltip(
   string* value
);
C++/CLI
public:
property String^ Tooltip {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the tooltip of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Value Property

Gets or sets the value of the field.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Delphi
public read-write property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the field, formatted as string.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's specific set of values.

Remarks

This property gives access to the field value as a string. Specific field types give access to field value as a native type.
Fields with a fixed range of values (checkboxes, radiobuttons, listboxes and comboboxes) will throw an exception if the value does not exist in their set of values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

WidgetCount Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : WidgetCount Property

Gets the number of field widgets.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WidgetCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Integer

value = instance.WidgetCount
C#
public int WidgetCount {get;}
Delphi
public read-only property WidgetCount: Integer;
Managed Extensions for C++
public: __property int get_WidgetCount();
C++/CLI
public:
property int WidgetCount {
   int get();
}

Return Value

The number of field widgets.

Remarks

If the field reference was obtained from a page, then this property returns the number of field widgets at page level, otherwise it returns the number of field widgets at document level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

PDFFieldActions Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldActions Class

Defines the actions to be performed as response to field events.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldActions
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
C#
public class PDFFieldActions : PDFObject
Delphi
public class PDFFieldActions = class(PDFObject)
Managed Extensions for C++
public __gc class PDFFieldActions : public PDFObject
C++/CLI
public ref class PDFFieldActions : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldActions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldActions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldActions Class

The following tables list the members exposed by PDFFieldActions.

Public Properties

 | Name | Description
Public Property | Blur | Gets or sets the action to be executed when the field loses the input focus.
Public Property | Calculate | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Document | Gets or sets the document which contains the field with these actions.
Public Property | Focus | Gets or sets the action to be executed when the field receives the input focus.
Public Property | Format | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPress | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MouseDown | Gets or sets the action to be executed when the mouse button is pressed inside the field's area.
Public Property | MouseEnter | Gets or sets the action to be executed when the mouse cursor enters the field's area.
Public Property | MouseExit | Gets or sets the action to be executed when the mouse cursor leaves the field's area.
Public Property | MouseUp | Gets or sets the action to be executed when the mouse button is released inside the field's area.
Public Property | Validate | Gets or sets the JavaScript action to be executed for validating the field value.
Top

See Also

Reference

PDFFieldActions Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldActions Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldActions Class

For a list of all members of this type, see PDFFieldActions members.

Public Properties

 | Name | Description
Public Property | Blur | Gets or sets the action to be executed when the field loses the input focus.
Public Property | Calculate | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Document | Gets or sets the document which contains the field with these actions.
Public Property | Focus | Gets or sets the action to be executed when the field receives the input focus.
Public Property | Format | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPress | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MouseDown | Gets or sets the action to be executed when the mouse button is pressed inside the field's area.
Public Property | MouseEnter | Gets or sets the action to be executed when the mouse cursor enters the field's area.
Public Property | MouseExit | Gets or sets the action to be executed when the mouse cursor leaves the field's area.
Public Property | MouseUp | Gets or sets the action to be executed when the mouse button is released inside the field's area.
Public Property | Validate | Gets or sets the JavaScript action to be executed for validating the field value.
Top

See Also

Reference

PDFFieldActions Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Blur Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Blur Property

Gets or sets the action to be executed when the field loses the input focus.

Syntax

Visual Basic (Declaration)
Public Property Blur As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.Blur = value

value = instance.Blur
C#
public PDFAction Blur {get; set;}
Delphi
public read-write property Blur: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Blur();
public: __property void set_Blur(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Blur {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the field loses the input focus.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

Calculate Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Calculate Property

Gets or sets the JavaScript action to be executed for calculating the field value.

Syntax

Visual Basic (Declaration)
Public Property Calculate As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFJavaScriptAction

instance.Calculate = value

value = instance.Calculate
C#
public PDFJavaScriptAction Calculate {get; set;}
Delphi
public read-write property Calculate: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_Calculate();
public: __property void set_Calculate(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ Calculate {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for calculating the field value.

Remarks

This property specifies a JavaScript action to be performed to recalculate the value of this field when that of another field changes. The order in which the document’s fields are recalculated is defined by the PDFField.CalcOrderIndex property.
After setting this property, the PDFField.CalcOrderIndex property needs to be set to a value greater than 0.
This action has no meaning for PDFPushbuttonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

Document Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Document Property

Gets or sets the document which contains the field with these actions.

Syntax

Visual Basic (Declaration)
Public Property Document As PDFDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFDocument

instance.Document = value

value = instance.Document
C#
public PDFDocument Document {get; set;}
Delphi
public read-write property Document: PDFDocument;
Managed Extensions for C++
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
C++/CLI
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (PDFDocument^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

Focus Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Focus Property

Gets or sets the action to be executed when the field receives the input focus.

Syntax

Visual Basic (Declaration)
Public Property Focus As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.Focus = value

value = instance.Focus
C#
public PDFAction Focus {get; set;}
Delphi
public read-write property Focus: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Focus();
public: __property void set_Focus(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Focus {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the field receives the input focus.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

Format Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Format Property

Gets or sets the JavaScript action to be executed for formating the field value.

Syntax

Visual Basic (Declaration)
Public Property Format As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFJavaScriptAction

instance.Format = value

value = instance.Format
C#
public PDFJavaScriptAction Format {get; set;}
Delphi
public read-write property Format: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_Format();
public: __property void set_Format(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ Format {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for formating the field value.

Remarks

This property specifies a JavaScript action to be performed before the field is formatted to display its current value. This action can modify the field’s value before formatting.
This action has no meaning for PDFPushbuttonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

KeyPress Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : KeyPress Property

Gets or sets the JavaScript action to be executed when the user types a keystroke.

Syntax

Visual Basic (Declaration)
Public Property KeyPress As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFJavaScriptAction

instance.KeyPress = value

value = instance.KeyPress
C#
public PDFJavaScriptAction KeyPress {get; set;}
Delphi
public read-write property KeyPress: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_KeyPress();
public: __property void set_KeyPress(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ KeyPress {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed when the user types a keystroke.

Remarks

This property specifies a JavaScript action to be performed when the user types a keystroke into a text field or combo box or modifies the selection in a scrollable list box. This action can check the keystroke for validity and reject or modify it.
This action has no meaning for PDFPushbuttonField, PDFCheckBoxField and PDFRadioButtonListField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

MouseDown Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : MouseDown Property

Gets or sets the action to be executed when the mouse button is pressed inside the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseDown As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.MouseDown = value

value = instance.MouseDown
C#
public PDFAction MouseDown {get; set;}
Delphi
public read-write property MouseDown: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseDown();
public: __property void set_MouseDown(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseDown {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse button is pressed inside the field's area.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

MouseEnter Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : MouseEnter Property

Gets or sets the action to be executed when the mouse cursor enters the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseEnter As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.MouseEnter = value

value = instance.MouseEnter
C#
public PDFAction MouseEnter {get; set;}
Delphi
public read-write property MouseEnter: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseEnter();
public: __property void set_MouseEnter(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseEnter {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse enters the field's area.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

MouseExit Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : MouseExit Property

Gets or sets the action to be executed when the mouse cursor leaves the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseExit As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.MouseExit = value

value = instance.MouseExit
C#
public PDFAction MouseExit {get; set;}
Delphi
public read-write property MouseExit: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseExit();
public: __property void set_MouseExit(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseExit {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse leaves the field's area.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

MouseUp Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : MouseUp Property

Gets or sets the action to be executed when the mouse button is released inside the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseUp As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFAction

instance.MouseUp = value

value = instance.MouseUp
C#
public PDFAction MouseUp {get; set;}
Delphi
public read-write property MouseUp: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseUp();
public: __property void set_MouseUp(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseUp {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse button is released inside the field's area.

Remarks

When this action is set at field level, it is applied to all field widgets.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

Validate Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldActions Class : Validate Property

Gets or sets the JavaScript action to be executed for validating the field value.

Syntax

Visual Basic (Declaration)
Public Property Validate As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldActions
Dim value As PDFJavaScriptAction

instance.Validate = value

value = instance.Validate
C#
public PDFJavaScriptAction Validate {get; set;}
Delphi
public read-write property Validate: PDFJavaScriptAction;
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_Validate();
public: __property void set_Validate(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ Validate {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for validating the field value.

Remarks

This property specifies a JavaScript action to be performed when the field’s value is changed. This action can check the new value for validity.
This action has no meaning for PDFPushbuttonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldActions Class
PDFFieldActions Members


%%PageItemTitle%%

PDFFieldAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldAppearance Class

Defines the visual appearance of a form field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldAppearance
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
C#
public class PDFFieldAppearance : PDFObject
Delphi
public class PDFFieldAppearance = class(PDFObject)
Managed Extensions for C++
public __gc class PDFFieldAppearance : public PDFObject
C++/CLI
public ref class PDFFieldAppearance : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFSignatureAppearance
O2S.Components.PDF4NET.Forms.PDFRadioButtonAppearance
O2S.Components.PDF4NET.Forms.PDFPushbuttonAppearance
O2S.Components.PDF4NET.Forms.PDFCheckBoxAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldAppearance Class

The following tables list the members exposed by PDFFieldAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFFieldAppearance Constructor | Initializes a new PDFFieldAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events.
Public Property | Align | Gets or sets the text alignment in a text box.
Public Property | BackColor | Gets or sets the background color of the field.
Public Property | Border | Gets or sets the border of this field.
Public Property | Canvas | Gets the canvas of the form field.
Public Property | Font | Gets or sets the font used by this field.
Public Property | ForeColor | Gets or sets the foreground color of the field.
Public Property | Height | Gets or sets the height of the field rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle.
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content.
Public Property | Page | Gets the page that includes this field appearance.
Public Property | Position | Gets or sets the position of this field object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object.
Public Property | Rotation | Gets or sets the field rotation angle.
Public Property | Size | Gets or sets the size of this field object.
Public Property | TabOrderIndex | Gets or sets the tab order for this field.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field.
Public Property | Width | Gets or sets the width of the field rectangle.
Top

See Also

Reference

PDFFieldAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldAppearance Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : PDFFieldAppearance Constructor

Initializes a new PDFFieldAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance()
C#
public PDFFieldAppearance()
Delphi
public PDFFieldAppearance();
Managed Extensions for C++
public: PDFFieldAppearance();
C++/CLI
public:
PDFFieldAppearance();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%% $$Properties$$

PDFFieldAppearance Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldAppearance Class

For a list of all members of this type, see PDFFieldAppearance members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events.
Public Property | Align | Gets or sets the text alignment in a text box.
Public Property | BackColor | Gets or sets the background color of the field.
Public Property | Border | Gets or sets the border of this field.
Public Property | Canvas | Gets the canvas of the form field.
Public Property | Font | Gets or sets the font used by this field.
Public Property | ForeColor | Gets or sets the foreground color of the field.
Public Property | Height | Gets or sets the height of the field rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle.
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content.
Public Property | Page | Gets the page that includes this field appearance.
Public Property | Position | Gets or sets the position of this field object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object.
Public Property | Rotation | Gets or sets the field rotation angle.
Public Property | Size | Gets or sets the size of this field object.
Public Property | TabOrderIndex | Gets or sets the tab order for this field.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field.
Public Property | Width | Gets or sets the width of the field rectangle.
Top

See Also

Reference

PDFFieldAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Actions Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Actions Property

Gets the actions to be performed by this field widget in response to widget events.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As PDFWidgetActions
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFWidgetActions

value = instance.Actions
C#
public PDFWidgetActions Actions {get;}
Delphi
public read-only property Actions: PDFWidgetActions;
Managed Extensions for C++
public: __property PDFWidgetActions* get_Actions();
C++/CLI
public:
property PDFWidgetActions^ Actions {
   PDFWidgetActions^ get();
}

Return Value

A PDFWidgetActions object specifying the actions to be performed in response to widget events.

Remarks

This property is null if the appearance is not attached to a field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Align Property

Gets or sets the text alignment in a text box.

Syntax

Visual Basic (Declaration)
Public Property Align As FieldTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As FieldTextAlign

instance.Align = value

value = instance.Align
C#
public FieldTextAlign Align {get; set;}
Delphi
public read-write property Align: FieldTextAlign;
Managed Extensions for C++
public: __property FieldTextAlign get_Align();
public: __property void set_Align(
   FieldTextAlign value
);
C++/CLI
public:
property FieldTextAlign Align {
   FieldTextAlign get();
   void set (FieldTextAlign value);
}

Return Value

A FieldTextAlign enumeration member specifying the text alignment in a text box.

Remarks

This property is used only by PDFTextBoxField objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

BackColor Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : BackColor Property

Gets or sets the background color of the field.

Syntax

Visual Basic (Declaration)
Public Property BackColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
C#
public PDFColor BackColor {get; set;}
Delphi
public read-write property BackColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the background color of field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Border Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Border Property

Gets or sets the border of this field.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFFieldBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFFieldBorder

instance.Border = value

value = instance.Border
C#
public PDFFieldBorder Border {get; set;}
Delphi
public read-write property Border: PDFFieldBorder;
Managed Extensions for C++
public: __property PDFFieldBorder* get_Border();
public: __property void set_Border(
   PDFFieldBorder* value
);
C++/CLI
public:
property PDFFieldBorder^ Border {
   PDFFieldBorder^ get();
   void set (PDFFieldBorder^ value);
}

Return Value

A PDFFieldBorder object that describes the visual appearance of this field's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Canvas Property

Gets the canvas of the form field.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public virtual PDFBasicCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFBasicCanvas; virtual;
Managed Extensions for C++
public: __property virtual PDFBasicCanvas* get_Canvas();
C++/CLI
public:
virtual property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Return Value

A PDFBasicCanvas object representing the canvas of the form field.

Remarks

Using form field's canvas the appearance of the form field can be fully customized, beyond the standard properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Font Property

Gets or sets the font used by this field.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

A PDFFont object specifying the font used the draw the content of this field object.

Remarks

Any font type, PDF, TrueType, CJK or Adobe Type1 font, can be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

ForeColor Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : ForeColor Property

Gets or sets the foreground color of the field.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFColor

instance.ForeColor = value

value = instance.ForeColor
C#
public PDFColor ForeColor {get; set;}
Delphi
public read-write property ForeColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_ForeColor();
public: __property void set_ForeColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ ForeColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the foreground color of field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Height Property

Gets or sets the height of the field rectangle.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

a float value representing the height of the field rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Left Property

Gets or sets the X coordinate of the top left corner of the fields's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

A float value representing the X coordinate of the top left corner of the field's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

OverrideExistingAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : OverrideExistingAppearance Property

Gets or sets whether existing field appearance should be overriden with new content.

Syntax

Visual Basic (Declaration)
Public Property OverrideExistingAppearance As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Boolean

instance.OverrideExistingAppearance = value

value = instance.OverrideExistingAppearance
C#
public bool OverrideExistingAppearance {get; set;}
Delphi
public read-write property OverrideExistingAppearance: Boolean;
Managed Extensions for C++
public: __property bool get_OverrideExistingAppearance();
public: __property void set_OverrideExistingAppearance(
   bool value
);
C++/CLI
public:
property bool OverrideExistingAppearance {
   bool get();
   void set (bool value);
}

Return Value

True if existing appearance should be overriden, false otherwise.

Remarks

For newly created fields this property is true by default. For fields that are loaded from a PDF file and their appearance is defined in the PDF file, this property is false. Any changes to field's appearance are not save unless this property is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Page Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Page Property

Gets the page that includes this field appearance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFPage

value = instance.Page
C#
public PDFPage Page {get;}
Delphi
public read-only property Page: PDFPage;
Managed Extensions for C++
public: __property PDFPage* get_Page();
C++/CLI
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Return Value

A PDFPage object specifying the page on which this appearance is placed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Position Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Position Property

Gets or sets the position of this field object.

Syntax

Visual Basic (Declaration)
Public Property Position As PDFPoint
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As PDFPoint

instance.Position = value

value = instance.Position
C#
public PDFPoint Position {get; set;}
Delphi
public read-write property Position: PDFPoint;
Managed Extensions for C++
public: __property PDFPoint* get_Position();
public: __property void set_Position(
   PDFPoint* value
);
C++/CLI
public:
property PDFPoint^ Position {
   PDFPoint^ get();
   void set (PDFPoint^ value);
}

Return Value

A PDFPoint object specifying the position of the field.

Remarks

This position is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Rectangle Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Rectangle Property

Gets or sets the bounding rectangle of this field object.

Syntax

Visual Basic (Declaration)
Public Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As RectangleF

instance.Rectangle = value

value = instance.Rectangle
C#
public RectangleF Rectangle {get; set;}
Delphi
public read-write property Rectangle: RectangleF;
Managed Extensions for C++
public: __property RectangleF get_Rectangle();
public: __property void set_Rectangle(
   RectangleF value
);
C++/CLI
public:
property RectangleF Rectangle {
   RectangleF get();
   void set (RectangleF value);
}

Return Value

A RectangleF object specifying the position and size of the field.

Remarks

The bounding rectangle is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Rotation Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Rotation Property

Gets or sets the field rotation angle.

Syntax

Visual Basic (Declaration)
Public Property Rotation As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Integer

instance.Rotation = value

value = instance.Rotation
C#
public int Rotation {get; set;}
Delphi
public read-write property Rotation: Integer;
Managed Extensions for C++
public: __property int get_Rotation();
public: __property void set_Rotation(
   int value
);
C++/CLI
public:
property int Rotation {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the field's rotation angle.

Remarks

Only the following values are allowed for this property: 0, 90, 180, 270. If a different value is used, the new value is ignored and old property value is kept.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Size Property

Gets or sets the size of this field object.

Syntax

Visual Basic (Declaration)
Public Property Size As SizeF
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As SizeF

instance.Size = value

value = instance.Size
C#
public SizeF Size {get; set;}
Delphi
public read-write property Size: SizeF;
Managed Extensions for C++
public: __property SizeF get_Size();
public: __property void set_Size(
   SizeF value
);
C++/CLI
public:
property SizeF Size {
   SizeF get();
   void set (SizeF value);
}

Return Value

A SizeF object specifying the size of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

TabOrderIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : TabOrderIndex Property

Gets or sets the tab order for this field.

Syntax

Visual Basic (Declaration)
Public Property TabOrderIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Integer

instance.TabOrderIndex = value

value = instance.TabOrderIndex
C#
public int TabOrderIndex {get; set;}
Delphi
public read-write property TabOrderIndex: Integer;
Managed Extensions for C++
public: __property int get_TabOrderIndex();
public: __property void set_TabOrderIndex(
   int value
);
C++/CLI
public:
property int TabOrderIndex {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the tab order for the active field widget.

Remarks

The field widget with the lowest tab order index gets the focus first and the field widget with the highest tab order index gets the focus last. Field widgets with negative tab order index are assigned automatically with a tab order index when the file is saved and they are always placed at the end of the fields list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Top Property

Gets or sets the Y coordinate of the top left corner of the field's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

a float value representing the Y coordinate of the top left corner of the field's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

VisibilityStatus Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : VisibilityStatus Property

Gets or sets the visibility status of the field.

Syntax

Visual Basic (Declaration)
Public Property VisibilityStatus As FieldVisibilityStatus
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As FieldVisibilityStatus

instance.VisibilityStatus = value

value = instance.VisibilityStatus
C#
public FieldVisibilityStatus VisibilityStatus {get; set;}
Delphi
public read-write property VisibilityStatus: FieldVisibilityStatus;
Managed Extensions for C++
public: __property FieldVisibilityStatus get_VisibilityStatus();
public: __property void set_VisibilityStatus(
   FieldVisibilityStatus value
);
C++/CLI
public:
property FieldVisibilityStatus VisibilityStatus {
   FieldVisibilityStatus get();
   void set (FieldVisibilityStatus value);
}

Return Value

A FieldVisibilityStatus enumeration member specifying the visibility status of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldAppearance Class : Width Property

Gets or sets the width of the field rectangle.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldAppearance
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

a float value representing the width of the field rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldAppearance Class
PDFFieldAppearance Members


%%PageItemTitle%%

PDFFieldBorder Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldBorder Class

Defines the visual aspect of the border for a field created from code.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldBorder
C#
public class PDFFieldBorder
Delphi
public class PDFFieldBorder
Managed Extensions for C++
public __gc class PDFFieldBorder
C++/CLI
public ref class PDFFieldBorder

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFFieldBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldBorder Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldBorder Class

The following tables list the members exposed by PDFFieldBorder.

Public Constructors

 | Name | Description
Public Constructor | PDFFieldBorder Constructor | Overloaded. Initializes a new PDFFieldBorder object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of field's border.
Public Property | Style | Gets or sets the style of field's border.
Public Property | Width | Gets or sets the width of field's border.
Top

See Also

Reference

PDFFieldBorder Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldBorder Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class : PDFFieldBorder Constructor

Initializes a new PDFFieldBorder object.

Overload List

Overload | Description
PDFFieldBorder Constructor() | Initializes a new PDFFieldBorder object.
PDFFieldBorder Constructor(FieldBorderStyle,Single,PDFColor) | Initializes a new PDFFieldBorder object with the specified style, width and color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members


%%PageItemTitle%%

PDFFieldBorder Constructor()
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class > PDFFieldBorder Constructor : PDFFieldBorder Constructor()

Initializes a new PDFFieldBorder object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldBorder()
C#
public PDFFieldBorder()
Delphi
public PDFFieldBorder();
Managed Extensions for C++
public: PDFFieldBorder();
C++/CLI
public:
PDFFieldBorder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members
Overload List


%%PageItemTitle%%

PDFFieldBorder Constructor(FieldBorderStyle,Single,PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class > PDFFieldBorder Constructor : PDFFieldBorder Constructor(FieldBorderStyle,Single,PDFColor)

borderStyle
The style of the field border.
width
The width of the field border.
color
The color of the field border.
Initializes a new PDFFieldBorder object with the specified style, width and color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal borderStyle As FieldBorderStyle, _
   ByVal width As Single, _
   ByVal color As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim borderStyle As FieldBorderStyle
Dim width As Single
Dim color As PDFColor

Dim instance As PDFFieldBorder(borderStyle, width, color)
C#
public PDFFieldBorder(
   FieldBorderStyle borderStyle,
   float width,
   PDFColor color
)
Delphi
public PDFFieldBorder(
    borderStyle: FieldBorderStyle;
    width: Single;
    color: PDFColor
);
Managed Extensions for C++
public: PDFFieldBorder(
   FieldBorderStyle borderStyle,
   float width,
   PDFColor* color
)
C++/CLI
public:
PDFFieldBorder(
   FieldBorderStyle borderStyle,
   float width,
   PDFColor^ color
)

Parameters

borderStyle
The style of the field border.
width
The width of the field border.
color
The color of the field border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFieldBorder Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldBorder Class

For a list of all members of this type, see PDFFieldBorder members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of field's border.
Public Property | Style | Gets or sets the style of field's border.
Public Property | Width | Gets or sets the width of field's border.
Top

See Also

Reference

PDFFieldBorder Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class : Color Property

Gets or sets the color of field's border.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldBorder
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public PDFColor Color {get; set;}
Delphi
public read-write property Color: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the color of field's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members


%%PageItemTitle%%

Style Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class : Style Property

Gets or sets the style of field's border.

Syntax

Visual Basic (Declaration)
Public Property Style As FieldBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldBorder
Dim value As FieldBorderStyle

instance.Style = value

value = instance.Style
C#
public FieldBorderStyle Style {get; set;}
Delphi
public read-write property Style: FieldBorderStyle;
Managed Extensions for C++
public: __property FieldBorderStyle get_Style();
public: __property void set_Style(
   FieldBorderStyle value
);
C++/CLI
public:
property FieldBorderStyle Style {
   FieldBorderStyle get();
   void set (FieldBorderStyle value);
}

Return Value

A FieldBorderStyle enumeration member specifying the style of field's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldBorder Class : Width Property

Gets or sets the width of field's border.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldBorder
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of field's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldBorder Class
PDFFieldBorder Members


%%PageItemTitle%%

PDFFieldImportError Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

Represents an error that happened during the import of a FDF/XFDF/XML file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldImportError
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
C#
public class PDFFieldImportError
Delphi
public class PDFFieldImportError
Managed Extensions for C++
public __gc class PDFFieldImportError
C++/CLI
public ref class PDFFieldImportError

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFFieldImportError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldImportError Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

The following tables list the members exposed by PDFFieldImportError.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldImportError Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

For a list of all members of this type, see PDFFieldImportError members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Exception Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Exception Property

Gets the exception thrown by the field during the import.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Delphi
public read-only property Exception: Exception;
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Return Value

A Exception object with the details about the import error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


%%PageItemTitle%%

Field Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Field Property

Gets the field that generated the import error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
Dim value As PDFField

value = instance.Field
C#
public PDFField Field {get;}
Delphi
public read-only property Field: PDFField;
Managed Extensions for C++
public: __property PDFField* get_Field();
C++/CLI
public:
property PDFField^ Field {
   PDFField^ get();
}

Return Value

A PDFField object representing the field that generated the error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


%%PageItemTitle%%

PDFFieldInfo Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldInfo Class

This class defines extended properties for a PDF form field.

Syntax

Visual Basic (Declaration)
Public Class PDFFieldInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
C#
public class PDFFieldInfo
Delphi
public class PDFFieldInfo
Managed Extensions for C++
public __gc class PDFFieldInfo
C++/CLI
public ref class PDFFieldInfo

Remarks

This properties are read only and allow the user to retrieve additional information about the form field, such as: position, size, font, etc.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFFieldInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldInfo Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldInfo Class

The following tables list the members exposed by PDFFieldInfo.

Public Properties

 | Name | Description
Public Property | FontName | Gets the name of the font used by this field.
Public Property | FontSize | Gets the size of the font used by the field.
Public Property | Height | Gets the height of the field.
Public Property | Left | Gets the x coordinate of the top left corner of the field.
Public Property | Top | Gets the y coordinate of the top left corner of the field.
Public Property | Width | Gets the width of the field.
Top

See Also

Reference

PDFFieldInfo Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldInfo Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldInfo Class

For a list of all members of this type, see PDFFieldInfo members.

Public Properties

 | Name | Description
Public Property | FontName | Gets the name of the font used by this field.
Public Property | FontSize | Gets the size of the font used by the field.
Public Property | Height | Gets the height of the field.
Public Property | Left | Gets the x coordinate of the top left corner of the field.
Public Property | Top | Gets the y coordinate of the top left corner of the field.
Public Property | Width | Gets the width of the field.
Top

See Also

Reference

PDFFieldInfo Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FontName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : FontName Property

Gets the name of the font used by this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As String

value = instance.FontName
C#
public string FontName {get;}
Delphi
public read-only property FontName: String;
Managed Extensions for C++
public: __property string* get_FontName();
C++/CLI
public:
property String^ FontName {
   String^ get();
}

Return Value

A string value specifying the name of the font used by the field to create its appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

FontSize Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : FontSize Property

Gets the size of the font used by the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontSize As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As Single

value = instance.FontSize
C#
public float FontSize {get;}
Delphi
public read-only property FontSize: Single;
Managed Extensions for C++
public: __property float get_FontSize();
C++/CLI
public:
property float FontSize {
   float get();
}

Return Value

A float value specifying the size of the font used by this field to create its appearance.

Remarks

A zero value for this property means that the viewer application has to scale automatically the font in order to fit the field's content within the field area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : Height Property

Gets the height of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As Single

value = instance.Height
C#
public float Height {get;}
Delphi
public read-only property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
C++/CLI
public:
property float Height {
   float get();
}

Return Value

A float value specifying the height of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : Left Property

Gets the x coordinate of the top left corner of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As Single

value = instance.Left
C#
public float Left {get;}
Delphi
public read-only property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
C++/CLI
public:
property float Left {
   float get();
}

Return Value

A float value specifying the x coordinate of the top left corner of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : Top Property

Gets the y coordinate of the top left corner of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As Single

value = instance.Top
C#
public float Top {get;}
Delphi
public read-only property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
C++/CLI
public:
property float Top {
   float get();
}

Return Value

A float value specifying the y coordinate of the top left corner of the field. The y coordinate is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldInfo Class : Width Property

Gets the width of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldInfo
Dim value As Single

value = instance.Width
C#
public float Width {get;}
Delphi
public read-only property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
C++/CLI
public:
property float Width {
   float get();
}

Return Value

A float value specifying the width of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldInfo Class
PDFFieldInfo Members


%%PageItemTitle%%

PDFFields Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFields Class

Defines a collection of fields in a PDF document.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFFields
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFFields : PDFObject
Delphi
public class PDFFields = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFFields : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFFields sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFields

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFields Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFields Class

The following tables list the members exposed by PDFFields.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new field to the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Overloaded. Removes the field from the page or document.
Public Method | RenameField | Renames a field in the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFFields Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFFields Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFields Class

For a list of all members of this type, see PDFFields members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new field to the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Overloaded. Removes the field from the page or document.
Public Method | RenameField | Renames a field in the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFFields Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Add Method

field
The field to be added on the page.
Adds a new field to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal field As PDFField _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim field As PDFField

instance.Add(field)
C#
public void Add(
   PDFField field
)
Delphi
public procedure Add(
    field: PDFField
);
Managed Extensions for C++
public: void Add(
   PDFField* field
)
C++/CLI
public:
void Add(
   PDFField^ field
)

Parameters

field
The field to be added on the page.

Exceptions

Exception | Description
PDFException | Thrown when the field is added to the Fields collection of a PDFDocument object. or Thrown when the page is not included in a document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Remove Method

Removes the field from the page or document.

Overload List

Overload | Description
Remove(String) | Removes the field from the page or document.
Remove(String,FieldRemoveOptions) | Removes the field from the page or document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Remove(String) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class > Remove Method : Remove(String) Method

fieldName
The name of the field that will be removed.
Removes the field from the page or document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal fieldName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim fieldName As String

instance.Remove(fieldName)
C#
public void Remove(
   string fieldName
)
Delphi
public procedure Remove(
    fieldName: String
);
Managed Extensions for C++
public: void Remove(
   string* fieldName
)
C++/CLI
public:
void Remove(
   String^ fieldName
)

Parameters

fieldName
The name of the field that will be removed.

Exceptions

Exception | Description
ArgumentException | Thrown when the field with the given name does not exist.

Remarks

This method has different behaviors, depending whether it has been called at document or at page level.
If this method is called at document level (on document's Fields collection), then it removes the field completely from the document.
If this method is called at page level (on page's Fields collection), then the field is removed completely from the page. If the field appears also on other pages, those instances remain in the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members
Overload List


%%PageItemTitle%%

Remove(String,FieldRemoveOptions) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class > Remove Method : Remove(String,FieldRemoveOptions) Method

fieldName
The name of the field that will be removed.
removeOptions
Removes the field from the page or document.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal fieldName As String, _
   ByVal removeOptions As FieldRemoveOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim fieldName As String
Dim removeOptions As FieldRemoveOptions

instance.Remove(fieldName, removeOptions)
C#
public void Remove(
   string fieldName,
   FieldRemoveOptions removeOptions
)
Delphi
public procedure Remove(
    fieldName: String;
    removeOptions: FieldRemoveOptions
);
Managed Extensions for C++
public: void Remove(
   string* fieldName,
   FieldRemoveOptions removeOptions
)
C++/CLI
public:
void Remove(
   String^ fieldName,
   FieldRemoveOptions removeOptions
)

Parameters

fieldName
The name of the field that will be removed.
removeOptions

Exceptions

Exception | Description
ArgumentException | Thrown when the field with the given name does not exist.

Remarks

This method has different behaviors, depending whether it has been called at document or at page level.
If this method is called at document level (on document's Fields collection), then it removes the field completely from the document and the removeOptions parameter has no effect.
If this method is called at page level (on page's Fields collection), then if removeOptions parameter is FieldRemoveOptions.RemoveAllWidgets, then the field is removed completely from the page, otherwise only the active widget is removed. The removeOptions parameter has effect at page level only if the field has multiple widgets on the page (the field appears multiple times on the page). If the field appears only once on the page, the removeOptions parameter has the same effect, no matter what option is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members
Overload List


%%PageItemTitle%%

RenameField Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : RenameField Method

oldName
The old field name.
newName
The new field name.
renameOptions
Options that specify how the rename operation is handled.
Renames a field in the collection.

Syntax

Visual Basic (Declaration)
Public Sub RenameField( _
   ByVal oldName As String, _
   ByVal newName As String, _
   ByVal renameOptions As FieldRenameOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim oldName As String
Dim newName As String
Dim renameOptions As FieldRenameOptions

instance.RenameField(oldName, newName, renameOptions)
C#
public void RenameField(
   string oldName,
   string newName,
   FieldRenameOptions renameOptions
)
Delphi
public procedure RenameField(
    oldName: String;
    newName: String;
    renameOptions: FieldRenameOptions
);
Managed Extensions for C++
public: void RenameField(
   string* oldName,
   string* newName,
   FieldRenameOptions renameOptions
)
C++/CLI
public:
void RenameField(
   String^ oldName,
   String^ newName,
   FieldRenameOptions renameOptions
)

Parameters

oldName
The old field name.
newName
The new field name.
renameOptions
Options that specify how the rename operation is handled.

Exceptions

Exception | Description
ArgumentException | Thrown when the field with the oldName does not exist or when newName is empty or a null reference (Nothing in VB.NET).

Remarks

If the field has only one widget, then renameOptions parameter has no effect.
If the field has multiple widgets, then if renameOptions parameter is FieldRenameOptions.RenameActiveWidget, then the active field widget is renamed. if renameOptions parameter is FieldRenameOptions.RenameAllWidgets, then all field widgets at page or document level are renamed, based on the on owner of the Fields collection. If the owner of the Fields collection is the document, then all field widgets in the document are renamed. If the owner of the Fields collection is a page, then all field widgets on that page are renamed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFFields

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%% $$Properties$$

PDFFields Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFields Class

For a list of all members of this type, see PDFFields members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

See Also

Reference

PDFFields Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Count Property

Returns the number of fields in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class : Item Property

Gets the field at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Get the field with the specified name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class > Item Property : Item(Int32) Property

index
Gets the field at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim index As Integer
Dim value As PDFField

value = instance.Item(index)
C#
public PDFField Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): PDFField;
Managed Extensions for C++
public: __property PDFField* get_Item(
   int index
);
C++/CLI
public:
property PDFField^ Item {
   PDFField^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFields Class > Item Property : Item(String) Property

name
Get the field with the specified name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFields
Dim name As String
Dim value As PDFField

value = instance.Item(name)
C#
public PDFField Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): PDFField;
Managed Extensions for C++
public: __property PDFField* get_Item(
   string* name
);
C++/CLI
public:
property PDFField^ Item {
   PDFField^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFields Class
PDFFields Members
Overload List


%%PageItemTitle%%

PDFForm Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

Defines an e-form in a PDF document.

Syntax

Visual Basic (Declaration)
Public Class PDFForm
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
C#
public class PDFForm : PDFObject
Delphi
public class PDFForm = class(PDFObject)
Managed Extensions for C++
public __gc class PDFForm : public PDFObject
C++/CLI
public ref class PDFForm : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFForm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFForm Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

The following tables list the members exposed by PDFForm.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields within the PDF document.
Public Property | NeedAppearances | Gets or sets a value indicating whether field appearances need to be built by the PDF viewer application.
Public Property | ReadOnly | Gets or sets a value indicating whether the form is read-only.
Top

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormFields | Flattens all the fields in the AcroForm, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFForm Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormFields | Flattens all the fields in the AcroForm, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

ExportData Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ExportData Method

Exports the form data to a file.

Overload List

Overload | Description
ExportData(String,DataFormat,ExportDataOptions,String) | Exports the form data to a file.
ExportData(Stream,DataFormat,ExportDataOptions,String) | Exports the form data to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

ExportData(String,DataFormat,ExportDataOptions,String) Method
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(String,DataFormat,ExportDataOptions,String) Method

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.
Exports the form data to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As DataFormat, _
   ByVal options As ExportDataOptions, _
   ByVal pdfFileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim format As DataFormat
Dim options As ExportDataOptions
Dim pdfFileName As String

instance.ExportData(fileName, format, options, pdfFileName)
C#
public void ExportData(
   string fileName,
   DataFormat format,
   ExportDataOptions options,
   string pdfFileName
)
Delphi
public procedure ExportData(
    fileName: String;
    format: DataFormat;
    options: ExportDataOptions;
    pdfFileName: String
);
Managed Extensions for C++
public: void ExportData(
   string* fileName,
   DataFormat format,
   ExportDataOptions options,
   string* pdfFileName
)
C++/CLI
public:
void ExportData(
   String^ fileName,
   DataFormat format,
   ExportDataOptions options,
   String^ pdfFileName
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.

Remarks

The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ExportData(Stream,DataFormat,ExportDataOptions,String) Method
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(Stream,DataFormat,ExportDataOptions,String) Method

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
The name of the PDF file the data is exported from.
Exports the form data to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As DataFormat, _
   ByVal options As ExportDataOptions, _
   ByVal pdfFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim format As DataFormat
Dim options As ExportDataOptions
Dim pdfFilename As String

instance.ExportData(stream, format, options, pdfFilename)
C#
public void ExportData(
   Stream stream,
   DataFormat format,
   ExportDataOptions options,
   string pdfFilename
)
Delphi
public procedure ExportData(
    stream: Stream;
    format: DataFormat;
    options: ExportDataOptions;
    pdfFilename: String
);
Managed Extensions for C++
public: void ExportData(
   Stream* stream,
   DataFormat format,
   ExportDataOptions options,
   string* pdfFilename
)
C++/CLI
public:
void ExportData(
   Stream^ stream,
   DataFormat format,
   ExportDataOptions options,
   String^ pdfFilename
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
The name of the PDF file the data is exported from.

Remarks

The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

FlattenFormFields Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : FlattenFormFields Method

Flattens all the fields in the AcroForm, making the PDF file uneditable.

Syntax

Visual Basic (Declaration)
Public Sub FlattenFormFields()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm

instance.FlattenFormFields()
C#
public void FlattenFormFields()
Delphi
public procedure FlattenFormFields();
Managed Extensions for C++
public: void FlattenFormFields();
C++/CLI
public:
void FlattenFormFields();

Remarks

This action is ireversible. Once the form fields have been flattened, they can no longer be edited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

ImportData Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ImportData Method

Imports form data from an external file.

Overload List

Overload | Description
ImportData(String,DataFormat) | Imports form data from an external file.
ImportData(String,DataFormat,Boolean) | Imports form data from an external file.
ImportData(Stream,DataFormat) | Imports form data from an external file.
ImportData(Stream,DataFormat,Boolean) | Imports form data from an external file.
ImportData(FDFFile) | Imports form data from a FDF file.
ImportData(FDFFile,Boolean) | Imports form data from a FDF file.
ImportData(XFDFFile) | Imports form data from a XFDF file.
ImportData(XFDFFile,Boolean) | Imports form data from a XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

ImportData(String,DataFormat) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,DataFormat) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As DataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As DataFormat

instance.ImportData(fileName, dataFormat)
C#
public void ImportData(
   string fileName,
   DataFormat dataFormat
)
Delphi
public procedure ImportData(
    fileName: String;
    dataFormat: DataFormat
);
Managed Extensions for C++
public: void ImportData(
   string* fileName,
   DataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   String^ fileName,
   DataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.
PDFParserException | thrown when the input file can not be parsed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(String,DataFormat,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,DataFormat,Boolean) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As DataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As DataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fileName, dataFormat, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   string fileName,
   DataFormat dataFormat,
   bool continueImportOnError
)
Delphi
public function ImportData(
    fileName: String;
    dataFormat: DataFormat;
    continueImportOnError: Boolean
): array of PDFFieldImportError;
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   string* fileName,
   DataFormat dataFormat,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   String^ fileName,
   DataFormat dataFormat,
   bool continueImportOnError
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.
PDFParserException | thrown when the input file can not be parsed.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(Stream,DataFormat) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,DataFormat) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As DataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As DataFormat

instance.ImportData(stream, dataFormat)
C#
public void ImportData(
   Stream stream,
   DataFormat dataFormat
)
Delphi
public procedure ImportData(
    stream: Stream;
    dataFormat: DataFormat
);
Managed Extensions for C++
public: void ImportData(
   Stream* stream,
   DataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   Stream^ stream,
   DataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.
PDFParserException | Thrown when the input stream can not be parsed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(Stream,DataFormat,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,DataFormat,Boolean) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As DataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As DataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(stream, dataFormat, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   Stream stream,
   DataFormat dataFormat,
   bool continueImportOnError
)
Delphi
public function ImportData(
    stream: Stream;
    dataFormat: DataFormat;
    continueImportOnError: Boolean
): array of PDFFieldImportError;
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   Stream* stream,
   DataFormat dataFormat,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   Stream^ stream,
   DataFormat dataFormat,
   bool continueImportOnError
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.
PDFParserException | Thrown when the input stream can not be parsed.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(FDFFile) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile) Method

fdfFile
A FDFFile object that stores the form data.
Imports form data from a FDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fdfFile As FDFFile _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fdfFile As FDFFile

instance.ImportData(fdfFile)
C#
public void ImportData(
   FDFFile fdfFile
)
Delphi
public procedure ImportData(
    fdfFile: FDFFile
);
Managed Extensions for C++
public: void ImportData(
   FDFFile* fdfFile
)
C++/CLI
public:
void ImportData(
   FDFFile^ fdfFile
)

Parameters

fdfFile
A FDFFile object that stores the form data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(FDFFile,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile,Boolean) Method

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a FDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal fdfFile As FDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fdfFile As FDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fdfFile, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   FDFFile fdfFile,
   bool continueImportOnError
)
Delphi
public function ImportData(
    fdfFile: FDFFile;
    continueImportOnError: Boolean
): array of PDFFieldImportError;
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   FDFFile* fdfFile,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   FDFFile^ fdfFile,
   bool continueImportOnError
)

Parameters

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(XFDFFile) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile) Method

xfdfFile
A XFDFFile object that stores the form data.
Imports form data from a XFDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal xfdfFile As XFDFFile _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim xfdfFile As XFDFFile

instance.ImportData(xfdfFile)
C#
public void ImportData(
   XFDFFile xfdfFile
)
Delphi
public procedure ImportData(
    xfdfFile: XFDFFile
);
Managed Extensions for C++
public: void ImportData(
   XFDFFile* xfdfFile
)
C++/CLI
public:
void ImportData(
   XFDFFile^ xfdfFile
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%%

ImportData(XFDFFile,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile,Boolean) Method

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a XFDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal xfdfFile As XFDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim xfdfFile As XFDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(xfdfFile, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   XFDFFile xfdfFile,
   bool continueImportOnError
)
Delphi
public function ImportData(
    xfdfFile: XFDFFile;
    continueImportOnError: Boolean
): array of PDFFieldImportError;
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   XFDFFile* xfdfFile,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   XFDFFile^ xfdfFile,
   bool continueImportOnError
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFForm Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields within the PDF document.
Public Property | NeedAppearances | Gets or sets a value indicating whether field appearances need to be built by the PDF viewer application.
Public Property | ReadOnly | Gets or sets a value indicating whether the form is read-only.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : Fields Property

Gets the list of fields within the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As PDFFields
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim value As PDFFields

value = instance.Fields
C#
public PDFFields Fields {get;}
Delphi
public read-only property Fields: PDFFields;
Managed Extensions for C++
public: __property PDFFields* get_Fields();
C++/CLI
public:
property PDFFields^ Fields {
   PDFFields^ get();
}

Return Value

A PDFFields object storing the fields in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

NeedAppearances Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : NeedAppearances Property

Gets or sets a value indicating whether field appearances need to be built by the PDF viewer application.

Syntax

Visual Basic (Declaration)
Public Property NeedAppearances As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim value As Boolean

instance.NeedAppearances = value

value = instance.NeedAppearances
C#
public bool NeedAppearances {get; set;}
Delphi
public read-write property NeedAppearances: Boolean;
Managed Extensions for C++
public: __property bool get_NeedAppearances();
public: __property void set_NeedAppearances(
   bool value
);
C++/CLI
public:
property bool NeedAppearances {
   bool get();
   void set (bool value);
}

Return Value

True if the PDF viewer application needs to build the field appearances.

Remarks

This flag instructs the PDF viewer application to ignore the field appearances defined in the field and rebuild them from scratch when the PDF file is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

ReadOnly Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ReadOnly Property

Gets or sets a value indicating whether the form is read-only.

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: Boolean;
Managed Extensions for C++
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
public:
property bool ReadOnly {
   bool get();
   void set (bool value);
}

Return Value

True if the form is read-only, false otherwise. When this property is set, the ReadOnly property of all fields in the form is set to this value. A form is read only if all the fields in the form are read only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

PDFListBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

Defines a scrollable list box field for user input in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFListBoxField
   Inherits PDFListField
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxField
C#
public class PDFListBoxField : PDFListField
Delphi
public class PDFListBoxField = class(PDFListField)
Managed Extensions for C++
public __gc class PDFListBoxField : public PDFListField
C++/CLI
public ref class PDFListBoxField : public PDFListField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

The following tables list the members exposed by PDFListBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor

name
The name of this field object.
Initializes a new PDFListBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFListBoxField(name)
C#
public PDFListBoxField(
   string name
)
Delphi
public PDFListBoxField(
    name: String
);
Managed Extensions for C++
public: PDFListBoxField(
   string* name
)
C++/CLI
public:
PDFListBoxField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%% $$Properties$$

PDFListBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : Appearance Property

Gets the visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxField
Dim value As PDFFieldAppearance

value = instance.Appearance
C#
public PDFFieldAppearance Appearance {get;}
Delphi
public read-only property Appearance: PDFFieldAppearance;
Managed Extensions for C++
public: __property PDFFieldAppearance* get_Appearance();
C++/CLI
public:
property PDFFieldAppearance^ Appearance {
   PDFFieldAppearance^ get();
}

Return Value

A PDFFieldAppearance object specifying the visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%%

CommitOnSelChange Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : CommitOnSelChange Property

Gets or sets whether the selected item is commited as soon as the selection is made.

Syntax

Visual Basic (Declaration)
Public Property CommitOnSelChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxField
Dim value As Boolean

instance.CommitOnSelChange = value

value = instance.CommitOnSelChange
C#
public bool CommitOnSelChange {get; set;}
Delphi
public read-write property CommitOnSelChange: Boolean;
Managed Extensions for C++
public: __property bool get_CommitOnSelChange();
public: __property void set_CommitOnSelChange(
   bool value
);
C++/CLI
public:
property bool CommitOnSelChange {
   bool get();
   void set (bool value);
}

Return Value

True if the selected item is commited as soon as the selection is made, false otherwise. Default is false.

Remarks

If set, the new value is committed as soon as a selection is made with the pointing device. This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%%

Sort Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : Sort Property

Gets or sets whether the items in the drop down list should be sorted alphabetically or not.

Syntax

Visual Basic (Declaration)
Public Property Sort As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
C#
public bool Sort {get; set;}
Delphi
public read-write property Sort: Boolean;
Managed Extensions for C++
public: __property bool get_Sort();
public: __property void set_Sort(
   bool value
);
C++/CLI
public:
property bool Sort {
   bool get();
   void set (bool value);
}

Return Value

True if the items are sorted, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%%

PDFListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

Base class for all list type fields.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFListField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
C#
public abstract class PDFListField : PDFField
Delphi
public class PDFListField = class(PDFField)abstract;
Managed Extensions for C++
public __gc abstract class PDFListField : public PDFField
C++/CLI
public ref class PDFListField abstract : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFListBoxField
O2S.Components.PDF4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

The following tables list the members exposed by PDFListField.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Items Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : Items Property

Gets the collection of items in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As PDFListItemCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As PDFListItemCollection

value = instance.Items
C#
public PDFListItemCollection Items {get;}
Delphi
public read-only property Items: PDFListItemCollection;
Managed Extensions for C++
public: __property PDFListItemCollection* get_Items();
C++/CLI
public:
property PDFListItemCollection^ Items {
   PDFListItemCollection^ get();
}

Return Value

A PDFListItemCollection that represents the items within the list.

Remarks

Use this property to get the properties of items in the list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedIndex Property

Gets or sets the lowest ordinal index of the selected items in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Delphi
public read-write property SelectedIndex: Integer;
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.

Remarks

Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedItem Property

Gets or sets the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As PDFListItem
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As PDFListItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
public PDFListItem SelectedItem {get; set;}
Delphi
public read-write property SelectedItem: PDFListItem;
Managed Extensions for C++
public: __property PDFListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   PDFListItem* value
);
C++/CLI
public:
property PDFListItem^ SelectedItem {
   PDFListItem^ get();
   void set (PDFListItem^ value);
}

Return Value

A PDFListItem object specifying the first selected item.

Exceptions

Exception | Description
ArgumentOutOfRange | The item does not exist in the list.

Remarks

null (Nothing in VB.NET) means that no item is selected.
If the item does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedValue Property

Gets or sets the value of the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Delphi
public read-write property SelectedValue: String;
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

PDFListItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

Defines an item in a list.

Syntax

Visual Basic (Declaration)
Public Class PDFListItem
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
C#
public class PDFListItem
Delphi
public class PDFListItem
Managed Extensions for C++
public __gc class PDFListItem
C++/CLI
public ref class PDFListItem

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFListItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItem Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

The following tables list the members exposed by PDFListItem.

Public Constructors

 | Name | Description
Public Constructor | PDFListItem Constructor | Initialzies a new PDFListItem object.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListItem Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : PDFListItem Constructor

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.
Initialzies a new PDFListItem object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemName As String, _
   ByVal itemValue As String _
)
Visual Basic (Usage) Copy Code
Dim itemName As String
Dim itemValue As String

Dim instance As PDFListItem(itemName, itemValue)
C#
public PDFListItem(
   string itemName,
   string itemValue
)
Delphi
public PDFListItem(
    itemName: String;
    itemValue: String
);
Managed Extensions for C++
public: PDFListItem(
   string* itemName,
   string* itemValue
)
C++/CLI
public:
PDFListItem(
   String^ itemName,
   String^ itemValue
)

Parameters

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item value is null or empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Methods$$

PDFListItem Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Create Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Create Method

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.
Creates a new PDFListItem object.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal itemName As String, _
   ByVal itemValue As String _
) As PDFListItem
Visual Basic (Usage) Copy Code
Dim itemName As String
Dim itemValue As String
Dim value As PDFListItem

value = PDFListItem.Create(itemName, itemValue)
C#
public static PDFListItem Create(
   string itemName,
   string itemValue
)
Delphi
public function Create(
    itemName: String;
    itemValue: String
): PDFListItem; static;
Managed Extensions for C++
public: static PDFListItem* Create(
   string* itemName,
   string* itemValue
)
C++/CLI
public:
static PDFListItem^ Create(
   String^ itemName,
   String^ itemValue
)

Parameters

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.

Return Value

A PDFListItem object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Properties$$

PDFListItem Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Name Property

Gets or sets the name of the item.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the name of the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Value Property

Gets or sets the value of the item.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Delphi
public read-write property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the value of the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%%

PDFListItemCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

Defines a collection of items in a list.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFListItemCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFListItemCollection : PDFObject
Delphi
public class PDFListItemCollection = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFListItemCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFListItemCollection sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFListItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItemCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

The following tables list the members exposed by PDFListItemCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the item at the specified index (zero based index)
Top

Public Methods

 | Name | Description
Public Method | Add | Inserts an item at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets the index of the given item in the collection.
Public Method | Insert | Inserts an item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | Removes an item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListItemCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Inserts an item at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets the index of the given item in the collection.
Public Method | Insert | Inserts an item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | Removes an item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Add Method

item
a PDFListItem object to be added to collection.
Inserts an item at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As PDFListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim item As PDFListItem

instance.Add(item)
C#
public void Add(
   PDFListItem item
)
Delphi
public procedure Add(
    item: PDFListItem
);
Managed Extensions for C++
public: void Add(
   PDFListItem* item
)
C++/CLI
public:
void Add(
   PDFListItem^ item
)

Parameters

item
a PDFListItem object to be added to collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : IndexOf Method

item
A PDFListItem object whose index is requested.
Gets the index of the given item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As PDFListItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim item As PDFListItem
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   PDFListItem item
)
Delphi
public function IndexOf(
    item: PDFListItem
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDFListItem* item
)
C++/CLI
public:
int IndexOf(
   PDFListItem^ item
)

Parameters

item
A PDFListItem object whose index is requested.

Return Value

The index of the given item, -1 if the item does not exist.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Insert Method

index
The index where to insert the new item.
item
A PDFListItem object to be added to collection.
Inserts an item at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As PDFListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim index As Integer
Dim item As PDFListItem

instance.Insert(index, item)
C#
public void Insert(
   int index,
   PDFListItem item
)
Delphi
public procedure Insert(
    index: Integer;
    item: PDFListItem
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFListItem* item
)
C++/CLI
public:
void Insert(
   int index,
   PDFListItem^ item
)

Parameters

index
The index where to insert the new item.
item
A PDFListItem object to be added to collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Remove Method

item
The PDFListItem object to be removed from collection.
Removes an item from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As PDFListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim item As PDFListItem

instance.Remove(item)
C#
public void Remove(
   PDFListItem item
)
Delphi
public procedure Remove(
    item: PDFListItem
);
Managed Extensions for C++
public: void Remove(
   PDFListItem* item
)
C++/CLI
public:
void Remove(
   PDFListItem^ item
)

Parameters

item
The PDFListItem object to be removed from collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : RemoveAt Method

index
The index where to remove the item.
Removes an item at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index where to remove the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%% $$Properties$$

PDFListItemCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the item at the specified index (zero based index)
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItemCollection Class : Item Property

index
Gets the item at the specified index (zero based index)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFListItem
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
Dim index As Integer
Dim value As PDFListItem

value = instance.Item(index)
C#
public PDFListItem this[
   int index
]; {get;}
Delphi
public  this: : PDFListItem;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFListItem* get_Item(
   int index
);
C++/CLI
public:
property PDFListItem^ default [int] {
   PDFListItem^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Class
PDFListItemCollection Members


%%PageItemTitle%%

PDFPushbuttonAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonAppearance Class

Defines the appearance of a push button field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPushbuttonAppearance
   Inherits PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance
C#
public class PDFPushbuttonAppearance : PDFFieldAppearance
Delphi
public class PDFPushbuttonAppearance = class(PDFFieldAppearance)
Managed Extensions for C++
public __gc class PDFPushbuttonAppearance : public PDFFieldAppearance
C++/CLI
public ref class PDFPushbuttonAppearance : public PDFFieldAppearance

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFPushbuttonAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushbuttonAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonAppearance Class

The following tables list the members exposed by PDFPushbuttonAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFPushbuttonAppearance Constructor | Initilizes a new PDFPushbuttonAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Caption | Gets or sets the caption of the button.
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Icon | Gets or sets the icon of the button.
Public Property | IconLayout | Gets or sets the layout mode of button's icon.
Public Property | IconSize | Gets or sets the size of the displayed icon.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFPushbuttonAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushbuttonAppearance Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonAppearance Class : PDFPushbuttonAppearance Constructor

Initilizes a new PDFPushbuttonAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance()
C#
public PDFPushbuttonAppearance()
Delphi
public PDFPushbuttonAppearance();
Managed Extensions for C++
public: PDFPushbuttonAppearance();
C++/CLI
public:
PDFPushbuttonAppearance();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Class
PDFPushbuttonAppearance Members


%%PageItemTitle%% $$Properties$$

PDFPushbuttonAppearance Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonAppearance Class

For a list of all members of this type, see PDFPushbuttonAppearance members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Caption | Gets or sets the caption of the button.
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Icon | Gets or sets the icon of the button.
Public Property | IconLayout | Gets or sets the layout mode of button's icon.
Public Property | IconSize | Gets or sets the size of the displayed icon.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFPushbuttonAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Caption Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonAppearance Class : Caption Property

Gets or sets the caption of the button.

Syntax

Visual Basic (Declaration)
Public Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public string Caption {get; set;}
Delphi
public read-write property Caption: String;
Managed Extensions for C++
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
C++/CLI
public:
property String^ Caption {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the caption of the button.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Class
PDFPushbuttonAppearance Members


%%PageItemTitle%%

Icon Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonAppearance Class : Icon Property

Gets or sets the icon of the button.

Syntax

Visual Basic (Declaration)
Public Property Icon As PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance
Dim value As PDFFormXObject

instance.Icon = value

value = instance.Icon
C#
public PDFFormXObject Icon {get; set;}
Delphi
public read-write property Icon: PDFFormXObject;
Managed Extensions for C++
public: __property PDFFormXObject* get_Icon();
public: __property void set_Icon(
   PDFFormXObject* value
);
C++/CLI
public:
property PDFFormXObject^ Icon {
   PDFFormXObject^ get();
   void set (PDFFormXObject^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying the caption of the button.

Remarks

When this proeprty is set, the IconSize property is automatically set to icon's original size.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Class
PDFPushbuttonAppearance Members


%%PageItemTitle%%

IconLayout Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonAppearance Class : IconLayout Property

Gets or sets the layout mode of button's icon.

Syntax

Visual Basic (Declaration)
Public Property IconLayout As IconLayoutMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance
Dim value As IconLayoutMode

instance.IconLayout = value

value = instance.IconLayout
C#
public IconLayoutMode IconLayout {get; set;}
Delphi
public read-write property IconLayout: IconLayoutMode;
Managed Extensions for C++
public: __property IconLayoutMode get_IconLayout();
public: __property void set_IconLayout(
   IconLayoutMode value
);
C++/CLI
public:
property IconLayoutMode IconLayout {
   IconLayoutMode get();
   void set (IconLayoutMode value);
}

Return Value

A IconLayoutMode enumeration member specifying the layout mode for button's icon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Class
PDFPushbuttonAppearance Members


%%PageItemTitle%%

IconSize Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonAppearance Class : IconSize Property

Gets or sets the size of the displayed icon.

Syntax

Visual Basic (Declaration)
Public Property IconSize As SizeF
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonAppearance
Dim value As SizeF

instance.IconSize = value

value = instance.IconSize
C#
public SizeF IconSize {get; set;}
Delphi
public read-write property IconSize: SizeF;
Managed Extensions for C++
public: __property SizeF get_IconSize();
public: __property void set_IconSize(
   SizeF value
);
C++/CLI
public:
property SizeF IconSize {
   SizeF get();
   void set (SizeF value);
}

Return Value

A SizeF object specifying the size of the displayed icon.

Remarks

The icon is scaled to fit in the given size, it is not cut. If this property is (0,0), then the icon takes all available space.
Set this property always after the Icon property has been set, because when Icon property is set, it resets the values of this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonAppearance Class
PDFPushbuttonAppearance Members


%%PageItemTitle%%

PDFPushbuttonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonField Class

Defines a pushbutton in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPushbuttonField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonField
C#
public class PDFPushbuttonField : PDFField
Delphi
public class PDFPushbuttonField = class(PDFField)
Managed Extensions for C++
public __gc class PDFPushbuttonField : public PDFField
C++/CLI
public ref class PDFPushbuttonField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFPushbuttonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushbuttonField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonField Class

The following tables list the members exposed by PDFPushbuttonField.

Public Constructors

 | Name | Description
Public Constructor | PDFPushbuttonField Constructor | Initializes a new PDFPushbuttonField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | DownAppearance | Gets the down visual appearance of this field.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NormalAppearance | Gets the normal visual appearance of this field.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | RolloverAppearance | Gets the rollover visual appearance of this field.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFPushbuttonField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushbuttonField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonField Class : PDFPushbuttonField Constructor

name
The name of this field object.
Initializes a new PDFPushbuttonField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFPushbuttonField(name)
C#
public PDFPushbuttonField(
   string name
)
Delphi
public PDFPushbuttonField(
    name: String
);
Managed Extensions for C++
public: PDFPushbuttonField(
   string* name
)
C++/CLI
public:
PDFPushbuttonField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Class
PDFPushbuttonField Members


%%PageItemTitle%% $$Properties$$

PDFPushbuttonField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonField Class

For a list of all members of this type, see PDFPushbuttonField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | DownAppearance | Gets the down visual appearance of this field.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NormalAppearance | Gets the normal visual appearance of this field.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | RolloverAppearance | Gets the rollover visual appearance of this field.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFPushbuttonField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

DownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonField Class : DownAppearance Property

Gets the down visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property DownAppearance As PDFPushbuttonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonField
Dim value As PDFPushbuttonAppearance

instance.DownAppearance = value

value = instance.DownAppearance
C#
public PDFPushbuttonAppearance DownAppearance {get; set;}
Delphi
public read-write property DownAppearance: PDFPushbuttonAppearance;
Managed Extensions for C++
public: __property PDFPushbuttonAppearance* get_DownAppearance();
public: __property void set_DownAppearance(
   PDFPushbuttonAppearance* value
);
C++/CLI
public:
property PDFPushbuttonAppearance^ DownAppearance {
   PDFPushbuttonAppearance^ get();
   void set (PDFPushbuttonAppearance^ value);
}

Return Value

A PDFPushbuttonAppearance object specifying the down visual appearance of the field.

Remarks

The down appearance is the appearance that is displayed when the button is pressed.
The down appearance has effect only if the button highlight mode is HighlightMode.Push.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Class
PDFPushbuttonField Members


%%PageItemTitle%%

HighlightMode Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonField Class : HighlightMode Property

Gets or sets the highlighting mode of the button.

Syntax

Visual Basic (Declaration)
Public Property HighlightMode As HighlightMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonField
Dim value As HighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
public HighlightMode HighlightMode {get; set;}
Delphi
public read-write property HighlightMode: HighlightMode;
Managed Extensions for C++
public: __property HighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   HighlightMode value
);
C++/CLI
public:
property HighlightMode HighlightMode {
   HighlightMode get();
   void set (HighlightMode value);
}

Return Value

A HighlightMode enumeration member specifying the highlighting mode for the button.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Class
PDFPushbuttonField Members


%%PageItemTitle%%

NormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonField Class : NormalAppearance Property

Gets the normal visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NormalAppearance As PDFPushbuttonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonField
Dim value As PDFPushbuttonAppearance

value = instance.NormalAppearance
C#
public PDFPushbuttonAppearance NormalAppearance {get;}
Delphi
public read-only property NormalAppearance: PDFPushbuttonAppearance;
Managed Extensions for C++
public: __property PDFPushbuttonAppearance* get_NormalAppearance();
C++/CLI
public:
property PDFPushbuttonAppearance^ NormalAppearance {
   PDFPushbuttonAppearance^ get();
}

Return Value

A PDFPushbuttonAppearance object specifying the normal visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Class
PDFPushbuttonField Members


%%PageItemTitle%%

RolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushbuttonField Class : RolloverAppearance Property

Gets the rollover visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public Property RolloverAppearance As PDFPushbuttonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushbuttonField
Dim value As PDFPushbuttonAppearance

instance.RolloverAppearance = value

value = instance.RolloverAppearance
C#
public PDFPushbuttonAppearance RolloverAppearance {get; set;}
Delphi
public read-write property RolloverAppearance: PDFPushbuttonAppearance;
Managed Extensions for C++
public: __property PDFPushbuttonAppearance* get_RolloverAppearance();
public: __property void set_RolloverAppearance(
   PDFPushbuttonAppearance* value
);
C++/CLI
public:
property PDFPushbuttonAppearance^ RolloverAppearance {
   PDFPushbuttonAppearance^ get();
   void set (PDFPushbuttonAppearance^ value);
}

Return Value

A PDFPushbuttonAppearance object specifying the rollover visual appearance of the field.

Remarks

The rollover appearance is the appearance that is displayed when the mouse cursor is over the button.
The rollover appearance has effect only if the button highlight mode is HighlightMode.Push.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushbuttonField Class
PDFPushbuttonField Members


%%PageItemTitle%%

PDFRadioButtonAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonAppearance Class

Defines the appearance of a radiobutton.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRadioButtonAppearance
   Inherits PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonAppearance
C#
public class PDFRadioButtonAppearance : PDFFieldAppearance
Delphi
public class PDFRadioButtonAppearance = class(PDFFieldAppearance)
Managed Extensions for C++
public __gc class PDFRadioButtonAppearance : public PDFFieldAppearance
C++/CLI
public ref class PDFRadioButtonAppearance : public PDFFieldAppearance

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFRadioButtonAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonAppearance Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonAppearance Class

The following tables list the members exposed by PDFRadioButtonAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFRadioButtonAppearance Constructor | Initilizes a new PDFRadioButtonAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFRadioButtonAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonAppearance Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonAppearance Class : PDFRadioButtonAppearance Constructor

Initilizes a new PDFRadioButtonAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonAppearance()
C#
public PDFRadioButtonAppearance()
Delphi
public PDFRadioButtonAppearance();
Managed Extensions for C++
public: PDFRadioButtonAppearance();
C++/CLI
public:
PDFRadioButtonAppearance();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonAppearance Class
PDFRadioButtonAppearance Members


%%PageItemTitle%%

PDFRadioButtonItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

Defines a single radio button in a PDFRadioButtonListField object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRadioButtonItem
   Inherits PDFWidgetAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
C#
public class PDFRadioButtonItem : PDFWidgetAnnotation
Delphi
public class PDFRadioButtonItem = class(PDFWidgetAnnotation)
Managed Extensions for C++
public __gc class PDFRadioButtonItem : public PDFWidgetAnnotation
C++/CLI
public ref class PDFRadioButtonItem : public PDFWidgetAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFWidgetAnnotation
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonItem Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

The following tables list the members exposed by PDFRadioButtonItem.

Public Constructors

 | Name | Description
Public Constructor | PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Checked | Gets or sets whether the radio button is checked.
Public Property | CheckedDownAppearance | Gets the down checked visual appearance of this radio button item.
Public Property | CheckedNormalAppearance | Gets the normal checked visual appearance of this radio button item.
Public Property | CheckedRolloverAppearance | Gets the rollover checked visual appearance of this radio button item.
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page this radiobutton item is placed on.
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets the down unchecked visual appearance of this radio button item.
Public Property | UncheckedNormalAppearance | Gets the normal unchecked visual appearance of this radio button item.
Public Property | UncheckedRolloverAppearance | Gets the rollover unchecked visual appearance of this radio button item.
Public Property | Value | Gets or sets the export value of the radio button item.
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top

See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonItem Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor

Initializes a new PDFRadioButtonItem object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem()
C#
public PDFRadioButtonItem()
Delphi
public PDFRadioButtonItem();
Managed Extensions for C++
public: PDFRadioButtonItem();
C++/CLI
public:
PDFRadioButtonItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%% $$Properties$$

PDFRadioButtonItem Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this PDFAnnotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Checked | Gets or sets whether the radio button is checked.
Public Property | CheckedDownAppearance | Gets the down checked visual appearance of this radio button item.
Public Property | CheckedNormalAppearance | Gets the normal checked visual appearance of this radio button item.
Public Property | CheckedRolloverAppearance | Gets the rollover checked visual appearance of this radio button item.
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page this radiobutton item is placed on.
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets the down unchecked visual appearance of this radio button item.
Public Property | UncheckedNormalAppearance | Gets the normal unchecked visual appearance of this radio button item.
Public Property | UncheckedRolloverAppearance | Gets the rollover unchecked visual appearance of this radio button item.
Public Property | Value | Gets or sets the export value of the radio button item.
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top

See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Checked Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : Checked Property

Gets or sets whether the radio button is checked.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Delphi
public read-write property Checked: Boolean;
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (bool value);
}

Return Value

True if the radio button is checked, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

CheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : CheckedDownAppearance Property

Gets the down checked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public Property CheckedDownAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

instance.CheckedDownAppearance = value

value = instance.CheckedDownAppearance
C#
public PDFRadioButtonAppearance CheckedDownAppearance {get; set;}
Delphi
public read-write property CheckedDownAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_CheckedDownAppearance();
public: __property void set_CheckedDownAppearance(
   PDFRadioButtonAppearance* value
);
C++/CLI
public:
property PDFRadioButtonAppearance^ CheckedDownAppearance {
   PDFRadioButtonAppearance^ get();
   void set (PDFRadioButtonAppearance^ value);
}

Return Value

A PDFRadioButtonAppearance object specifying the down checked visual appearance of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

CheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : CheckedNormalAppearance Property

Gets the normal checked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckedNormalAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

value = instance.CheckedNormalAppearance
C#
public PDFRadioButtonAppearance CheckedNormalAppearance {get;}
Delphi
public read-only property CheckedNormalAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_CheckedNormalAppearance();
C++/CLI
public:
property PDFRadioButtonAppearance^ CheckedNormalAppearance {
   PDFRadioButtonAppearance^ get();
}

Return Value

A PDFRadioButtonAppearance object specifying the normal checked visual appearance of this radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

CheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : CheckedRolloverAppearance Property

Gets the rollover checked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public Property CheckedRolloverAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

instance.CheckedRolloverAppearance = value

value = instance.CheckedRolloverAppearance
C#
public PDFRadioButtonAppearance CheckedRolloverAppearance {get; set;}
Delphi
public read-write property CheckedRolloverAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_CheckedRolloverAppearance();
public: __property void set_CheckedRolloverAppearance(
   PDFRadioButtonAppearance* value
);
C++/CLI
public:
property PDFRadioButtonAppearance^ CheckedRolloverAppearance {
   PDFRadioButtonAppearance^ get();
   void set (PDFRadioButtonAppearance^ value);
}

Return Value

A PDFRadioButtonAppearance object specifying the rollover checked visual appearance of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

Page Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : Page Property

Gets the page this radiobutton item is placed on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFPage

value = instance.Page
C#
public PDFPage Page {get;}
Delphi
public read-only property Page: PDFPage;
Managed Extensions for C++
public: __property PDFPage* get_Page();
C++/CLI
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Return Value

A PDFPage object that specifies the page this radiobutton item appears on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

UncheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : UncheckedDownAppearance Property

Gets the down unchecked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public Property UncheckedDownAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

instance.UncheckedDownAppearance = value

value = instance.UncheckedDownAppearance
C#
public PDFRadioButtonAppearance UncheckedDownAppearance {get; set;}
Delphi
public read-write property UncheckedDownAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_UncheckedDownAppearance();
public: __property void set_UncheckedDownAppearance(
   PDFRadioButtonAppearance* value
);
C++/CLI
public:
property PDFRadioButtonAppearance^ UncheckedDownAppearance {
   PDFRadioButtonAppearance^ get();
   void set (PDFRadioButtonAppearance^ value);
}

Return Value

A PDFRadioButtonAppearance object specifying the down unchecked visual appearance of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

UncheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : UncheckedNormalAppearance Property

Gets the normal unchecked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UncheckedNormalAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

value = instance.UncheckedNormalAppearance
C#
public PDFRadioButtonAppearance UncheckedNormalAppearance {get;}
Delphi
public read-only property UncheckedNormalAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_UncheckedNormalAppearance();
C++/CLI
public:
property PDFRadioButtonAppearance^ UncheckedNormalAppearance {
   PDFRadioButtonAppearance^ get();
}

Return Value

A PDFRadioButtonAppearance object specifying the normal checked visual appearance of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

UncheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : UncheckedRolloverAppearance Property

Gets the rollover unchecked visual appearance of this radio button item.

Syntax

Visual Basic (Declaration)
Public Property UncheckedRolloverAppearance As PDFRadioButtonAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As PDFRadioButtonAppearance

instance.UncheckedRolloverAppearance = value

value = instance.UncheckedRolloverAppearance
C#
public PDFRadioButtonAppearance UncheckedRolloverAppearance {get; set;}
Delphi
public read-write property UncheckedRolloverAppearance: PDFRadioButtonAppearance;
Managed Extensions for C++
public: __property PDFRadioButtonAppearance* get_UncheckedRolloverAppearance();
public: __property void set_UncheckedRolloverAppearance(
   PDFRadioButtonAppearance* value
);
C++/CLI
public:
property PDFRadioButtonAppearance^ UncheckedRolloverAppearance {
   PDFRadioButtonAppearance^ get();
   void set (PDFRadioButtonAppearance^ value);
}

Return Value

A PDFRadioButtonAppearance object specifying the rollover unchecked visual appearance of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : Value Property

Gets or sets the export value of the radio button item.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Delphi
public read-write property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the export value of the radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

PDFRadioButtonItemCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItemCollection Class

Defines a collection of radio button items.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFRadioButtonItemCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
C#
[DefaultMemberAttribute("Item")]
public class PDFRadioButtonItemCollection : PDFObject
Delphi
public class PDFRadioButtonItemCollection = class(PDFObject)
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFRadioButtonItemCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFRadioButtonItemCollection : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFRadioButtonItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonItemCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItemCollection Class

The following tables list the members exposed by PDFRadioButtonItemCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button item at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Inserts a radio button item at the end of the collection.
Public Method | Clear | Removes all radio button items from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Locates the item in the collection.
Public Method | Insert | Inserts a radio button item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes a radio button item from the collection.
Public Method | RemoveAt | Removes a radio button item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFRadioButtonItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFRadioButtonItemCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItemCollection Class

For a list of all members of this type, see PDFRadioButtonItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Inserts a radio button item at the end of the collection.
Public Method | Clear | Removes all radio button items from the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Locates the item in the collection.
Public Method | Insert | Inserts a radio button item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes a radio button item from the collection.
Public Method | RemoveAt | Removes a radio button item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFRadioButtonItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Add Method

item
a PDFRadioButtonItem object to be added to collection.
Inserts a radio button item at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As PDFRadioButtonItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim item As PDFRadioButtonItem

instance.Add(item)
C#
public void Add(
   PDFRadioButtonItem item
)
Delphi
public procedure Add(
    item: PDFRadioButtonItem
);
Managed Extensions for C++
public: void Add(
   PDFRadioButtonItem* item
)
C++/CLI
public:
void Add(
   PDFRadioButtonItem^ item
)

Parameters

item
a PDFRadioButtonItem object to be added to collection.

Exceptions

Exception | Description
ArgumentNullException | Thrown when item is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Clear Method

Removes all radio button items from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : IndexOf Method

item
A PDFRadioButtonItem object to be located.
Locates the item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As PDFRadioButtonItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim item As PDFRadioButtonItem
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   PDFRadioButtonItem item
)
Delphi
public function IndexOf(
    item: PDFRadioButtonItem
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDFRadioButtonItem* item
)
C++/CLI
public:
int IndexOf(
   PDFRadioButtonItem^ item
)

Parameters

item
A PDFRadioButtonItem object to be located.

Return Value

The index of the given item, -1 if the item does not exist in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Insert Method

index
The index where to insert the new item.
item
A PDFRadioButtonItem object to be added to collection.
Inserts a radio button item at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As PDFRadioButtonItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim index As Integer
Dim item As PDFRadioButtonItem

instance.Insert(index, item)
C#
public void Insert(
   int index,
   PDFRadioButtonItem item
)
Delphi
public procedure Insert(
    index: Integer;
    item: PDFRadioButtonItem
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFRadioButtonItem* item
)
C++/CLI
public:
void Insert(
   int index,
   PDFRadioButtonItem^ item
)

Parameters

index
The index where to insert the new item.
item
A PDFRadioButtonItem object to be added to collection.

Exceptions

Exception | Description
ArgumentNullException | Thrown when item is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Remove Method

item
The PDFRadioButtonItem object to be removed from collection.
Removes a radio button item from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As PDFRadioButtonItem _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim item As PDFRadioButtonItem

instance.Remove(item)
C#
public void Remove(
   PDFRadioButtonItem item
)
Delphi
public procedure Remove(
    item: PDFRadioButtonItem
);
Managed Extensions for C++
public: void Remove(
   PDFRadioButtonItem* item
)
C++/CLI
public:
void Remove(
   PDFRadioButtonItem^ item
)

Parameters

item
The PDFRadioButtonItem object to be removed from collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : RemoveAt Method

index
The index where to remove the item.
Removes a radio button item at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index where to remove the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%% $$Properties$$

PDFRadioButtonItemCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItemCollection Class

For a list of all members of this type, see PDFRadioButtonItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button item at the specified index.
Top

See Also

Reference

PDFRadioButtonItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItemCollection Class : Item Property

index
Gets the radio button item at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFRadioButtonItem
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItemCollection
Dim index As Integer
Dim value As PDFRadioButtonItem

value = instance.Item(index)
C#
public PDFRadioButtonItem this[
   int index
]; {get;}
Delphi
public  this: : PDFRadioButtonItem;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFRadioButtonItem* get_Item(
   int index
);
C++/CLI
public:
property PDFRadioButtonItem^ default [int] {
   PDFRadioButtonItem^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItemCollection Class
PDFRadioButtonItemCollection Members


%%PageItemTitle%%

PDFRadioButtonListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

Defines a list of exclusive radio buttons in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRadioButtonListField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
C#
public class PDFRadioButtonListField : PDFField
Delphi
public class PDFRadioButtonListField = class(PDFField)
Managed Extensions for C++
public __gc class PDFRadioButtonListField : public PDFField
C++/CLI
public ref class PDFRadioButtonListField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

The following tables list the members exposed by PDFRadioButtonListField.

Public Constructors

 | Name | Description
Public Constructor | PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the list of radio button items that belong to this field.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button item in the list.
Public Property | SelectedItem | Gets or sets the selected radio button item in the list.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Style | Gets or sets the style of the radiobuttons in the list.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonListField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor

name
The name of this field object.
Initializes a new PDFRadioButtonListField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFRadioButtonListField(name)
C#
public PDFRadioButtonListField(
   string name
)
Delphi
public PDFRadioButtonListField(
    name: String
);
Managed Extensions for C++
public: PDFRadioButtonListField(
   string* name
)
C++/CLI
public:
PDFRadioButtonListField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%% $$Properties$$

PDFRadioButtonListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | Items | Gets the list of radio button items that belong to this field.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button item in the list.
Public Property | SelectedItem | Gets or sets the selected radio button item in the list.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Style | Gets or sets the style of the radiobuttons in the list.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Items Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : Items Property

Gets the list of radio button items that belong to this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As PDFRadioButtonItemCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As PDFRadioButtonItemCollection

value = instance.Items
C#
public PDFRadioButtonItemCollection Items {get;}
Delphi
public read-only property Items: PDFRadioButtonItemCollection;
Managed Extensions for C++
public: __property PDFRadioButtonItemCollection* get_Items();
C++/CLI
public:
property PDFRadioButtonItemCollection^ Items {
   PDFRadioButtonItemCollection^ get();
}

Return Value

A PDFRadioButtonItemCollection object specifying the list of items in this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

NoToggleToOff Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : NoToggleToOff Property

Gets or sets a value indicating whether a radiobutton should be selected all the time.

Syntax

Visual Basic (Declaration)
Public Property NoToggleToOff As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.NoToggleToOff = value

value = instance.NoToggleToOff
C#
public bool NoToggleToOff {get; set;}
Delphi
public read-write property NoToggleToOff: Boolean;
Managed Extensions for C++
public: __property bool get_NoToggleToOff();
public: __property void set_NoToggleToOff(
   bool value
);
C++/CLI
public:
property bool NoToggleToOff {
   bool get();
   void set (bool value);
}

Return Value

True if a radiobutton should be selected all the time, otherwise false. Default is true.

Remarks

If this property is true, clicking on currently selected radiobutton has no effect. If this property is false, clicking on currently selected radiobutton deselects it, leaving no radiobutton selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedIndex Property

Gets or sets the index of the checked radio button item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Delphi
public read-write property SelectedIndex: Integer;
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the checked radio button item in the list.

Remarks

-1 means that no radio button item is checked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedItem Property

Gets or sets the selected radio button item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As PDFRadioButtonItem
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As PDFRadioButtonItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
public PDFRadioButtonItem SelectedItem {get; set;}
Delphi
public read-write property SelectedItem: PDFRadioButtonItem;
Managed Extensions for C++
public: __property PDFRadioButtonItem* get_SelectedItem();
public: __property void set_SelectedItem(
   PDFRadioButtonItem* value
);
C++/CLI
public:
property PDFRadioButtonItem^ SelectedItem {
   PDFRadioButtonItem^ get();
   void set (PDFRadioButtonItem^ value);
}

Return Value

A PDFRadioButtonItem object specifying the selected item.

Exceptions

Exception | Description
ArgumentOutOfRange | The item does not exist in the list.

Remarks

null (Nothing in VB.NET) means that no radio button item is selected.
If the item does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedValue Property

Gets or sets the value of the selected radio button item .

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Delphi
public read-write property SelectedValue: String;
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

null (Nothing in VB.NET) or "Off" means that no radio button item is selected.
When setting the selected value, if the value does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

Style Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : Style Property

Gets or sets the style of the radiobuttons in the list.

Syntax

Visual Basic (Declaration)
Public Property Style As SymbolStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As SymbolStyle

instance.Style = value

value = instance.Style
C#
public SymbolStyle Style {get; set;}
Delphi
public read-write property Style: SymbolStyle;
Managed Extensions for C++
public: __property SymbolStyle get_Style();
public: __property void set_Style(
   SymbolStyle value
);
C++/CLI
public:
property SymbolStyle Style {
   SymbolStyle get();
   void set (SymbolStyle value);
}

Return Value

A SymbolStyle enumeration member specifying the style of the radio buttons.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

PDFSignatureAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureAppearance Class

Defines the appearance of a signature field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSignatureAppearance
   Inherits PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureAppearance
C#
public class PDFSignatureAppearance : PDFFieldAppearance
Delphi
public class PDFSignatureAppearance = class(PDFFieldAppearance)
Managed Extensions for C++
public __gc class PDFSignatureAppearance : public PDFFieldAppearance
C++/CLI
public ref class PDFSignatureAppearance : public PDFFieldAppearance

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFFieldAppearance
O2S.Components.PDF4NET.Forms.PDFSignatureAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureAppearance Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureAppearance Class

The following tables list the members exposed by PDFSignatureAppearance.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Overridden. Gets the canvas of the form field.
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFSignatureAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFSignatureAppearance Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureAppearance Class

For a list of all members of this type, see PDFSignatureAppearance members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Overridden. Gets the canvas of the form field.
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFSignatureAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureAppearance Class : Canvas Property

Gets the canvas of the form field.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureAppearance
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public override PDFBasicCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFBasicCanvas; override;
Managed Extensions for C++
public: __property PDFBasicCanvas* get_Canvas()override ;
C++/CLI
public:
property PDFBasicCanvas^ Canvas override {
   PDFBasicCanvas^ get();
}

Return Value

A PDFBasicCanvas object representing the canvas of the form field.

Remarks

Using form field's canvas the appearance of the form field can be fully customized, beyond the standard properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureAppearance Class
PDFSignatureAppearance Members


%%PageItemTitle%%

PDFSignatureField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

Defines a signature field for digitally signing the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSignatureField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
C#
public class PDFSignatureField : PDFField
Delphi
public class PDFSignatureField = class(PDFField)
Managed Extensions for C++
public __gc class PDFSignatureField : public PDFField
C++/CLI
public ref class PDFSignatureField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFSignatureField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

The following tables list the members exposed by PDFSignatureField.

Public Constructors

 | Name | Description
Public Constructor | PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor

name
The name of this field object.
Initializes a new PDFSignatureField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFSignatureField(name)
C#
public PDFSignatureField(
   string name
)
Delphi
public PDFSignatureField(
    name: String
);
Managed Extensions for C++
public: PDFSignatureField(
   string* name
)
C++/CLI
public:
PDFSignatureField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%% $$Properties$$

PDFSignatureField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the field. (Inherited from PDFField)
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : Appearance Property

Gets the visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
Dim value As PDFFieldAppearance

value = instance.Appearance
C#
public PDFFieldAppearance Appearance {get;}
Delphi
public read-only property Appearance: PDFFieldAppearance;
Managed Extensions for C++
public: __property PDFFieldAppearance* get_Appearance();
C++/CLI
public:
property PDFFieldAppearance^ Appearance {
   PDFFieldAppearance^ get();
}

Return Value

A PDFFieldAppearance object specifying the visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

Signature Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : Signature Property

Gets or sets the digital signature for signing the the field.

Syntax

Visual Basic (Declaration)
Public Property Signature As PDFDigitalSignature
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
Dim value As PDFDigitalSignature

instance.Signature = value

value = instance.Signature
C#
public PDFDigitalSignature Signature {get; set;}
Delphi
public read-write property Signature: PDFDigitalSignature;
Managed Extensions for C++
public: __property PDFDigitalSignature* get_Signature();
public: __property void set_Signature(
   PDFDigitalSignature* value
);
C++/CLI
public:
property PDFDigitalSignature^ Signature {
   PDFDigitalSignature^ get();
   void set (PDFDigitalSignature^ value);
}

Return Value

A O2S.Components.PDF4NET.Security.PDFDigitalSignature object specifying the digital signature for signing the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

PDFTextBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

Defines a text box field for user input in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextBoxField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
C#
public class PDFTextBoxField : PDFField
Delphi
public class PDFTextBoxField = class(PDFField)
Managed Extensions for C++
public __gc class PDFTextBoxField : public PDFField
C++/CLI
public ref class PDFTextBoxField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFTextBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

The following tables list the members exposed by PDFTextBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the default value of the text box.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text box.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the text in the text box.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the text box.
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor

name
The name of this field object.
Initializes a new PDFTextBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFTextBoxField(name)
C#
public PDFTextBoxField(
   string name
)
Delphi
public PDFTextBoxField(
    name: String
);
Managed Extensions for C++
public: PDFTextBoxField(
   string* name
)
C++/CLI
public:
PDFTextBoxField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%% $$Properties$$

PDFTextBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field in response to field events. (Inherited from PDFField)
Public Property | Align | Gets or sets the text alignment in a field. (Inherited from PDFField)
Public Property | Appearance | Gets the visual appearance of this field.
Public Property | CalcOrderIndex | Gets or sets the calculation order for this field. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the default value of the text box.
Public Property | FieldInfo | Gets additional information about the form field. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text box.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of the field. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the text in the text box.
Public Property | Tooltip | Gets or sets the tooltip of the field. (Inherited from PDFField)
Public Property | Value | Gets or sets the value of the text box.
Public Property | WidgetCount | Gets the number of field widgets. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Appearance Property

Gets the visual appearance of this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As PDFFieldAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As PDFFieldAppearance

value = instance.Appearance
C#
public PDFFieldAppearance Appearance {get;}
Delphi
public read-only property Appearance: PDFFieldAppearance;
Managed Extensions for C++
public: __property PDFFieldAppearance* get_Appearance();
C++/CLI
public:
property PDFFieldAppearance^ Appearance {
   PDFFieldAppearance^ get();
}

Return Value

A PDFFieldAppearance object specifying the visual appearance of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

CheckSpelling Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : CheckSpelling Property

Gets or sets a value indicating whether the field content should be checked for spelling erorrs.

Syntax

Visual Basic (Declaration)
Public Property CheckSpelling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
C#
public bool CheckSpelling {get; set;}
Delphi
public read-write property CheckSpelling: Boolean;
Managed Extensions for C++
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
C++/CLI
public:
property bool CheckSpelling {
   bool get();
   void set (bool value);
}

Return Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.

Remarks

The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

Comb Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Comb Property

Gets or sets a value indicating whether the field acts like a comb or not.

Syntax

Visual Basic (Declaration)
Public Property Comb As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Comb = value

value = instance.Comb
C#
public bool Comb {get; set;}
Delphi
public read-write property Comb: Boolean;
Managed Extensions for C++
public: __property bool get_Comb();
public: __property void set_Comb(
   bool value
);
C++/CLI
public:
property bool Comb {
   bool get();
   void set (bool value);
}

Return Value

True if the field acts like a comb, otherwise false. Default is false.

Remarks

If this property is true, the field is automatically divided into as many equally spaced positions, or combs, as the value of MaxLen property and the text is laid out into those combs.
When this property is set to true, the Multiline and Password properties are automatically set to false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

DefaultValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : DefaultValue Property

Gets or sets the default value of the text box.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As String

instance.DefaultValue = value

value = instance.DefaultValue
C#
public string DefaultValue {get; set;}
Delphi
public read-write property DefaultValue: String;
Managed Extensions for C++
public: __property string* get_DefaultValue();
public: __property void set_DefaultValue(
   string* value
);
C++/CLI
public:
property String^ DefaultValue {
   String^ get();
   void set (String^ value);
}

Return Value

The default text box value.

Remarks

This property specifies the value to be displayed in the textbox when the form is reset through a reset action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

MaxLen Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : MaxLen Property

Gets or sets the maximum number of characters that can be entered in the text box.

Syntax

Visual Basic (Declaration)
Public Property MaxLen As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Integer

instance.MaxLen = value

value = instance.MaxLen
C#
public int MaxLen {get; set;}
Delphi
public read-write property MaxLen: Integer;
Managed Extensions for C++
public: __property int get_MaxLen();
public: __property void set_MaxLen(
   int value
);
C++/CLI
public:
property int MaxLen {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the maximum number of characters that can be entered in the text box.

Remarks

If the value of this property is 0, then the length of this field is unlimited.
This property is also used when Comb property is true and it defines the number of comb positions. An exception is thrown when the PDF file is created if the Comb property is true and this property is 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

Multiline Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Multiline Property

Gets or sets a value indicating whether the field is multiline.

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
C#
public bool Multiline {get; set;}
Delphi
public read-write property Multiline: Boolean;
Managed Extensions for C++
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
C++/CLI
public:
property bool Multiline {
   bool get();
   void set (bool value);
}

Return Value

True if the field is multiline, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

Password Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Password Property

Gets or sets a value indicating whether the field is used for entering passwords.

Syntax

Visual Basic (Declaration)
Public Property Password As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Password = value

value = instance.Password
C#
public bool Password {get; set;}
Delphi
public read-write property Password: Boolean;
Managed Extensions for C++
public: __property bool get_Password();
public: __property void set_Password(
   bool value
);
C++/CLI
public:
property bool Password {
   bool get();
   void set (bool value);
}

Return Value

True if the field is a password field, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

ScrollLongText Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : ScrollLongText Property

Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.

Syntax

Visual Basic (Declaration)
Public Property ScrollLongText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.ScrollLongText = value

value = instance.ScrollLongText
C#
public bool ScrollLongText {get; set;}
Delphi
public read-write property ScrollLongText: Boolean;
Managed Extensions for C++
public: __property bool get_ScrollLongText();
public: __property void set_ScrollLongText(
   bool value
);
C++/CLI
public:
property bool ScrollLongText {
   bool get();
   void set (bool value);
}

Return Value

True if the field content can be scrolled, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Text Property

Gets or sets the text in the text box.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text displayed in the text box.

Remarks

This property specifies the content that is displayed in the text box when the text box does not have the focus. The Value property specifies that content that is edited in the text box. If this property is null (Nothing in VB.NET), then the content of Value property will be displayed in the text box. Use an empty string for this property if the text box should be displayed empty even if the Value property is set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Value Property

Gets or sets the value of the text box.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Delphi
public read-write property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text edited in the text box.

Remarks

This property specifies the content that is displayed in the text box when the text box has the focus. If this property is null (Nothing in VB.NET), then the content of Text property will be edited in the text box. Use an empty string for this property if the text box should be edited empty even if the Text property is set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

PDFWidgetActions Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetActions Class

Defines the actions to be performed as response to field widget events.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFWidgetActions
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
C#
public class PDFWidgetActions : PDFObject
Delphi
public class PDFWidgetActions = class(PDFObject)
Managed Extensions for C++
public __gc class PDFWidgetActions : public PDFObject
C++/CLI
public ref class PDFWidgetActions : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.PDFWidgetActions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFWidgetActions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetActions Class

The following tables list the members exposed by PDFWidgetActions.

Public Properties

 | Name | Description
Public Property | Blur | Gets or sets the action to be executed when the field loses the input focus.
Public Property | Document | Gets or sets the document which contains the field with these actions.
Public Property | Focus | Gets or sets the action to be executed when the field receives the input focus.
Public Property | MouseDown | Gets or sets the action to be executed when the mouse button is pressed inside the field's area.
Public Property | MouseEnter | Gets or sets the action to be executed when the mouse cursor enters the field's area.
Public Property | MouseExit | Gets or sets the action to be executed when the mouse cursor leaves the field's area.
Public Property | MouseUp | Gets or sets the action to be executed when the mouse button is released inside the field's area.
Top

See Also

Reference

PDFWidgetActions Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFWidgetActions Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetActions Class

For a list of all members of this type, see PDFWidgetActions members.

Public Properties

 | Name | Description
Public Property | Blur | Gets or sets the action to be executed when the field loses the input focus.
Public Property | Document | Gets or sets the document which contains the field with these actions.
Public Property | Focus | Gets or sets the action to be executed when the field receives the input focus.
Public Property | MouseDown | Gets or sets the action to be executed when the mouse button is pressed inside the field's area.
Public Property | MouseEnter | Gets or sets the action to be executed when the mouse cursor enters the field's area.
Public Property | MouseExit | Gets or sets the action to be executed when the mouse cursor leaves the field's area.
Public Property | MouseUp | Gets or sets the action to be executed when the mouse button is released inside the field's area.
Top

See Also

Reference

PDFWidgetActions Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Blur Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : Blur Property

Gets or sets the action to be executed when the field loses the input focus.

Syntax

Visual Basic (Declaration)
Public Property Blur As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.Blur = value

value = instance.Blur
C#
public PDFAction Blur {get; set;}
Delphi
public read-write property Blur: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Blur();
public: __property void set_Blur(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Blur {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the field loses the input focus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

Document Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : Document Property

Gets or sets the document which contains the field with these actions.

Syntax

Visual Basic (Declaration)
Public Property Document As PDFDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFDocument

instance.Document = value

value = instance.Document
C#
public PDFDocument Document {get; set;}
Delphi
public read-write property Document: PDFDocument;
Managed Extensions for C++
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
C++/CLI
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (PDFDocument^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

Focus Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : Focus Property

Gets or sets the action to be executed when the field receives the input focus.

Syntax

Visual Basic (Declaration)
Public Property Focus As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.Focus = value

value = instance.Focus
C#
public PDFAction Focus {get; set;}
Delphi
public read-write property Focus: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_Focus();
public: __property void set_Focus(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Focus {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the field receives the input focus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

MouseDown Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : MouseDown Property

Gets or sets the action to be executed when the mouse button is pressed inside the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseDown As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.MouseDown = value

value = instance.MouseDown
C#
public PDFAction MouseDown {get; set;}
Delphi
public read-write property MouseDown: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseDown();
public: __property void set_MouseDown(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseDown {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse button is pressed inside the field's area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

MouseEnter Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : MouseEnter Property

Gets or sets the action to be executed when the mouse cursor enters the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseEnter As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.MouseEnter = value

value = instance.MouseEnter
C#
public PDFAction MouseEnter {get; set;}
Delphi
public read-write property MouseEnter: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseEnter();
public: __property void set_MouseEnter(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseEnter {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse enters the field's area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

MouseExit Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : MouseExit Property

Gets or sets the action to be executed when the mouse cursor leaves the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseExit As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.MouseExit = value

value = instance.MouseExit
C#
public PDFAction MouseExit {get; set;}
Delphi
public read-write property MouseExit: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseExit();
public: __property void set_MouseExit(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseExit {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse leaves the field's area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

MouseUp Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFWidgetActions Class : MouseUp Property

Gets or sets the action to be executed when the mouse button is released inside the field's area.

Syntax

Visual Basic (Declaration)
Public Property MouseUp As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetActions
Dim value As PDFAction

instance.MouseUp = value

value = instance.MouseUp
C#
public PDFAction MouseUp {get; set;}
Delphi
public read-write property MouseUp: PDFAction;
Managed Extensions for C++
public: __property PDFAction* get_MouseUp();
public: __property void set_MouseUp(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseUp {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction descendant specifying the action to be executed when the mouse button is released inside the field's area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetActions Class
PDFWidgetActions Members


%%PageItemTitle%%

PDFWidgetAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetAnnotation Class

Defines the widget annotation corresponding to a form field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFWidgetAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFWidgetAnnotation
C#
public class PDFWidgetAnnotation : PDFAnnotation
Delphi
public class PDFWidgetAnnotation = class(PDFAnnotation)
Managed Extensions for C++
public __gc class PDFWidgetAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFWidgetAnnotation : public PDFAnnotation

Remarks

This class is used internally by the library.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFWidgetAnnotation
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFWidgetAnnotation Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFWidgetAnnotation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetAnnotation Class

The following tables list the members exposed by PDFWidgetAnnotation.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this field. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top

See Also

Reference

PDFWidgetAnnotation Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

XFDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

Defines a field in a XFDF document.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XFDFField
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
C#
public sealed class XFDFField
Delphi
public class XFDFField sealed;
Managed Extensions for C++
public __gc __sealed class XFDFField
C++/CLI
public ref class XFDFField sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

The following tables list the members exposed by XFDFField.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

For a list of all members of this type, see XFDFField members.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Name Property

Gets the field name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the XFDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Class
XFDFField Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Value Property

Gets the field value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
Dim value As String

value = instance.Value
C#
public string Value {get;}
Delphi
public read-only property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
C++/CLI
public:
property String^ Value {
   String^ get();
}

Return Value

A string value specifying the value of the XFDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Class
XFDFField Members


%%PageItemTitle%%

XFDFFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

Defines a collection of fields in a XFDF document.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class XFDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class XFDFFieldCollection
Delphi
public class XFDFFieldCollection sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class XFDFFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFDFFieldCollection sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

The following tables list the members exposed by XFDFFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the field in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

XFDFFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the field in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : IndexOf Method

field
The field to locate in the collection.
Returns the zero-based index of the first occurrence of the field in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal field As XFDFField _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim field As XFDFField
Dim value As Integer

value = instance.IndexOf(field)
C#
public int IndexOf(
   XFDFField field
)
Delphi
public function IndexOf(
    field: XFDFField
): Integer;
Managed Extensions for C++
public: int IndexOf(
   XFDFField* field
)
C++/CLI
public:
int IndexOf(
   XFDFField^ field
)

Parameters

field
The field to locate in the collection.

Return Value

The zero-based index of the first occurrence of the field within the entire collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%% $$Properties$$

XFDFFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of fields in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : Count Property

Returns the number of fields in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class : Item Property

Gets the field at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Gets the field with the specified name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class > Item Property : Item(Int32) Property

index
Gets the field at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFDFField
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim index As Integer
Dim value As XFDFField

value = instance.Item(index)
C#
public XFDFField Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFDFField;
Managed Extensions for C++
public: __property XFDFField* get_Item(
   int index
);
C++/CLI
public:
property XFDFField^ Item {
   XFDFField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when index is less than zero or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFieldCollection Class > Item Property : Item(String) Property

name
Gets the field with the specified name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFDFField
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
Dim name As String
Dim value As XFDFField

value = instance.Item(name)
C#
public XFDFField Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFDFField;
Managed Extensions for C++
public: __property XFDFField* get_Item(
   string* name
);
C++/CLI
public:
property XFDFField^ Item {
   XFDFField^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Class
XFDFFieldCollection Members
Overload List


%%PageItemTitle%%

XFDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

Represents a XFDF file on disk.

Syntax

Visual Basic (Declaration)
Public Class XFDFFile
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
C#
public class XFDFFile
Delphi
public class XFDFFile
Managed Extensions for C++
public __gc class XFDFFile
C++/CLI
public ref class XFDFFile

Remarks

This class defines an existing XFDF file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

The following tables list the members exposed by XFDFFile.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

XFDFFile Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Close Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

FromFile Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromFile Method

fileName
the full path to a XFDF file used as source for this XFDFFile object.
Creates a XFDFFile object from the given XFDF file.

Syntax

Visual Basic (Declaration)
Public Shared Function FromFile( _
   ByVal fileName As String _
) As XFDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As XFDFFile

value = XFDFFile.FromFile(fileName)
C#
public static XFDFFile FromFile(
   string fileName
)
Delphi
public function FromFile(
    fileName: String
): XFDFFile; static;
Managed Extensions for C++
public: static XFDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static XFDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a XFDF file used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

FromStream Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromStream Method

stream
the stream object used as source for this XFDFFile object.
Creates a XFDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As XFDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As XFDFFile

value = XFDFFile.FromStream(stream)
C#
public static XFDFFile FromStream(
   Stream stream
)
Delphi
public function FromStream(
    stream: Stream
): XFDFFile; static;
Managed Extensions for C++
public: static XFDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static XFDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given stream object.

Remarks

The stream must contain a valid XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%% $$Properties$$

XFDFFile Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Fields Property

Gets the list of fields in the XFDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As XFDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
Dim value As XFDFFieldCollection

value = instance.Fields
C#
public XFDFFieldCollection Fields {get;}
Delphi
public read-only property Fields: XFDFFieldCollection;
Managed Extensions for C++
public: __property XFDFFieldCollection* get_Fields();
C++/CLI
public:
property XFDFFieldCollection^ Fields {
   XFDFFieldCollection^ get();
}

Return Value

A XFDFFieldCollection object specifying the list of fields in the XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

PDFFileName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : PDFFileName Property

Gets the name of the PDF file the XFDF file was exported from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFFileName As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
Dim value As String

value = instance.PDFFileName
C#
public string PDFFileName {get;}
Delphi
public read-only property PDFFileName: String;
Managed Extensions for C++
public: __property string* get_PDFFileName();
C++/CLI
public:
property String^ PDFFileName {
   String^ get();
}

Return Value

A string value specifying the the name of the PDF file the XFDF file was exported from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

DataFormat Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : DataFormat Enumeration

Specifies the available formats for data import/export for AcroForms.

Syntax

Visual Basic (Declaration)
Public Enum DataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataFormat
C#
public enum DataFormat : Enum
Delphi
public enum DataFormat = class(Enum)
Managed Extensions for C++
__value public enum DataFormat : public Enum
C++/CLI
public enum class DataFormat : public Enum

Members

Member | Description
FDF | Form data is imported or exported in FDF format.
XFDF | Form data is imported or exported in XFDF format.
XML | Form data is imported or exported in XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.DataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

ExportDataOptions Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : ExportDataOptions Enumeration

Specifies the available export options for PDF forms.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum ExportDataOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ExportDataOptions
C#
[FlagsAttribute()]
public enum ExportDataOptions : Enum
Delphi
public enum ExportDataOptions = class(Enum)
Managed Extensions for C++
[FlagsAttribute()]
__value public enum ExportDataOptions : public Enum
C++/CLI
[FlagsAttribute()]
public enum class ExportDataOptions : public Enum

Members

Member | Description
FormData | Form data is exported from the PDF document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.ExportDataOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FieldBorderStyle Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : FieldBorderStyle Enumeration

Specifies the available styles for a field's border.

Syntax

Visual Basic (Declaration)
Public Enum FieldBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FieldBorderStyle
C#
public enum FieldBorderStyle : Enum
Delphi
public enum FieldBorderStyle = class(Enum)
Managed Extensions for C++
__value public enum FieldBorderStyle : public Enum
C++/CLI
public enum class FieldBorderStyle : public Enum

Members

Member | Description
Solid | Solid border.
Beveled | Beveled border.
Inset | Inset border.
Underlined | Underlined border.
Dashed | Dashed border.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.FieldBorderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FieldRemoveOptions Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : FieldRemoveOptions Enumeration

Specifies the available options for removing a field from a PDF form.

Syntax

Visual Basic (Declaration)
Public Enum FieldRemoveOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FieldRemoveOptions
C#
public enum FieldRemoveOptions : Enum
Delphi
public enum FieldRemoveOptions = class(Enum)
Managed Extensions for C++
__value public enum FieldRemoveOptions : public Enum
C++/CLI
public enum class FieldRemoveOptions : public Enum

Members

Member | Description
RemoveActiveWidget | Only the field's active widget is removed from the form.
RemoveAllWidgets | All field widgets are removed from the form.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.FieldRemoveOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FieldRenameOptions Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : FieldRenameOptions Enumeration

Specifies the available options for renaming a field in a PDF form.

Syntax

Visual Basic (Declaration)
Public Enum FieldRenameOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FieldRenameOptions
C#
public enum FieldRenameOptions : Enum
Delphi
public enum FieldRenameOptions = class(Enum)
Managed Extensions for C++
__value public enum FieldRenameOptions : public Enum
C++/CLI
public enum class FieldRenameOptions : public Enum

Members

Member | Description
RenameActiveWidget | Only the field's active widget is named in the form.
RenameAllWidgets | All field widgets are renamed in the form.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.FieldRenameOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FieldTextAlign Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : FieldTextAlign Enumeration

Specifies the available alignments for text in a text box field.

Syntax

Visual Basic (Declaration)
Public Enum FieldTextAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FieldTextAlign
C#
public enum FieldTextAlign : Enum
Delphi
public enum FieldTextAlign = class(Enum)
Managed Extensions for C++
__value public enum FieldTextAlign : public Enum
C++/CLI
public enum class FieldTextAlign : public Enum

Members

Member | Description
Left | The text is left aligned
Center | The text is center aligned
Right | The text is right aligned

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.FieldTextAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FieldVisibilityStatus Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : FieldVisibilityStatus Enumeration

Specifies the available visibility states for a field.

Syntax

Visual Basic (Declaration)
Public Enum FieldVisibilityStatus
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FieldVisibilityStatus
C#
public enum FieldVisibilityStatus : Enum
Delphi
public enum FieldVisibilityStatus = class(Enum)
Managed Extensions for C++
__value public enum FieldVisibilityStatus : public Enum
C++/CLI
public enum class FieldVisibilityStatus : public Enum

Members

Member | Description
Visible | The field is visible on the page.
Hidden | The field is not visible on the page.
VisibleNonPrintable | The field is visible on the page but it does not print.
HiddenPrintable | The field is not visible on the page but it prints.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.FieldVisibilityStatus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

HighlightMode Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : HighlightMode Enumeration

Specifies the available highlighting modes for a button.

Syntax

Visual Basic (Declaration)
Public Enum HighlightMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HighlightMode
C#
public enum HighlightMode : Enum
Delphi
public enum HighlightMode = class(Enum)
Managed Extensions for C++
__value public enum HighlightMode : public Enum
C++/CLI
public enum class HighlightMode : public Enum

Members

Member | Description
None | No highlighting, the button's appearance does not change when the button is pressed. Rollover and down button appearances are ignored.
Invert | Inverts the content of button's normal appearance. Rollover and down button appearances are ignored.
Outline | Inverts the button's border. Rollover and down button appearances are ignored.
Push | Displays the button's down appearance. Rollover appearance has also effect on this mode. When this mode is used, both rollover and down appearances must be constructed from code.

Remarks

The highlight mode defines how the button's down appearance is created when the button is pressed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.HighlightMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

IconLayoutMode Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : IconLayoutMode Enumeration

Specifies the available modes for displaying the icon on a pushbutton.

Syntax

Visual Basic (Declaration)
Public Enum IconLayoutMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As IconLayoutMode
C#
public enum IconLayoutMode : Enum
Delphi
public enum IconLayoutMode = class(Enum)
Managed Extensions for C++
__value public enum IconLayoutMode : public Enum
C++/CLI
public enum class IconLayoutMode : public Enum

Members

Member | Description
NoIcon | The icon is not displayed, only the caption is displayed.
IconOnly | Only the icon is displayed, the caption is not displayed.
IconTop | The caption is displayed below the icon.
IconBottom | The caption is displayed above the icon.
IconLeft | The icon is displayed to the left of the caption.
IconRight | The icon is displayed to the right of the caption.
IconOverlay | The caption is overlaid directly on the icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.IconLayoutMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

SymbolStyle Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : SymbolStyle Enumeration

Specifies the available style for a check box.

Syntax

Visual Basic (Declaration)
Public Enum SymbolStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SymbolStyle
C#
public enum SymbolStyle : Enum
Delphi
public enum SymbolStyle = class(Enum)
Managed Extensions for C++
__value public enum SymbolStyle : public Enum
C++/CLI
public enum class SymbolStyle : public Enum

Members

Member | Description
Custom | The appearance of the check box is created from code.
Check | A check mark is used for the checked state.
Circle | A circle is used for the checked state.
Cross | A cross is used for the checked state.
Cross2 | A cross is used for the checked state.
Cross3 | A cross is used for the checked state.
Diamond | A diamond symbol is used for the checked state.
Square | A square is used for the checked state.
Star | A star is used for the checked state.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.SymbolStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Forms.XFA Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
XFAArea | Defines a XFA area.
XFAAreaCollection | Defines a collection of XFA areas.
XFABarcodeField | Defines a XFA barcode field.
XFABasicContainer | Defines a basic XFA container.
XFAButtonField | Defines a XFA button field.
XFACheckButtonField | Defines a XFA check button field.
XFAChoiceListField | Defines a XFA choice list field.
XFADateTimeEditField | Defines a XFA date/time edit field.
XFAElement | Defines the base class for all elements in a XFA form.
XFAExtendedContainer | Defines an extended XFA container.
XFAField | Defines a XFA field.
XFAFieldCollection | Defines a collection of XFA fields.
XFAFieldImportError | Represents an error that happened during the import of a XML file.
XFAForm | Defines a document level XFA form.
XFAHttpSubmitButtonField | Defines a XFA button field that submits the form data to a server using HTTP protocol.
XFAImageEditField | Defines a XFA image edit field.
XFAListItem | Defines an item in a choice list.
XFAListItemCollection | Defines a collection of items in a list.
XFANumericEditField | Defines a XFA numeric edit field.
XFAPageArea | Defines a XFA page area.
XFAPageAreaCollection | Defines a collection of XFA page areas.
XFAPageSet | Defines a XFA page set.
XFAPageSetCollection | Defines a collection of XFA page sets.
XFAPasswordEditField | Defines a XFA password edit field.
XFARadioButtonField | Defines a XFA radio button field.
XFARadioButtonFieldCollection | Defines a collection of exclusive radio buttons.
XFARadioButtonListField | Defines a XFA radio buttons list field.
XFASubform | Defines a XFA subform.
XFASubformCollection | Defines a collection of XFA subforms.
XFATextEditField | Defines a XFA text edit field.

Enumerations

Enumeration | Description
XFABarcodeType | Specifies the available barcode types for displaying field content.
XFACheckButtonState | Specifies the available states for a checkbutton and radiobutton.
XFAChoiceListDisplayMode | Specifies the modes for presenting the drop down choice list in interactive applications.
XFAContentAccess | Specifies the access modes to the content of a container.
XFAContentType | Specifies the available types of content accepted by a XFA value.
XFAContentVisibility | Specifies the visibility of the content of a container.
XFADataFormat | Specifies the available formats for data import/export for XFA Forms.
XFAImageAspect | Specifies the available modes for scaling the image when it is displayed in the image edit field.
XFAImageStorageMode | Specifies the available modes for storing image content in an image edit field.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Forms.XFA Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFASubform
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet
O2S.Components.PDF4NET.Forms.XFA.XFAForm
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError
O2S.Components.PDF4NET.Forms.XFA.XFAListItem
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

XFAArea Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

Defines a XFA area.

Syntax

Visual Basic (Declaration)
Public Class XFAArea
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAArea
C#
public class XFAArea : XFAExtendedContainer
Delphi
public class XFAArea = class(XFAExtendedContainer)
Managed Extensions for C++
public __gc class XFAArea : public XFAExtendedContainer
C++/CLI
public ref class XFAArea : public XFAExtendedContainer

Remarks

A XFA area is a container representing a geographical grouping of other containers.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAArea Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

The following tables list the members exposed by XFAArea.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAAreaCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

Defines a collection of XFA areas.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAAreaCollection
Delphi
public class XFAAreaCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAAreaCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAAreaCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAAreaCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

The following tables list the members exposed by XFAAreaCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAAreaCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%% $$Properties$$

XFAAreaCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Item Property

Gets the area at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the area at the specified index (zero based index).
Item(String) | Gets the area with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(Int32) Property

index
Gets the area at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAArea
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim index As Integer
Dim value As XFAArea

value = instance.Item(index)
C#
public XFAArea Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFAArea;
Managed Extensions for C++
public: __property XFAArea* get_Item(
   int index
);
C++/CLI
public:
property XFAArea^ Item {
   XFAArea^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(String) Property

name
Gets the area with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAArea
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim name As String
Dim value As XFAArea

value = instance.Item(name)
C#
public XFAArea Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFAArea;
Managed Extensions for C++
public: __property XFAArea* get_Item(
   string* name
);
C++/CLI
public:
property XFAArea^ Item {
   XFAArea^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


%%PageItemTitle%%

XFABarcodeField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

Defines a XFA barcode field.

Syntax

Visual Basic (Declaration)
Public Class XFABarcodeField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
C#
public class XFABarcodeField : XFAField
Delphi
public class XFABarcodeField = class(XFAField)
Managed Extensions for C++
public __gc class XFABarcodeField : public XFAField
C++/CLI
public ref class XFABarcodeField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFABarcodeField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

The following tables list the members exposed by XFABarcodeField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFABarcodeField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

For a list of all members of this type, see XFABarcodeField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Data Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Data Property

Gets or sets the barcode data.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Delphi
public read-write property Data: String;
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text to be displayed as barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


%%PageItemTitle%%

Type Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Type Property

Gets the type of the barcode used by this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As XFABarcodeType
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
Dim value As XFABarcodeType

value = instance.Type
C#
public XFABarcodeType Type {get;}
Delphi
public read-only property Type: XFABarcodeType;
Managed Extensions for C++
public: __property XFABarcodeType get_Type();
C++/CLI
public:
property XFABarcodeType Type {
   XFABarcodeType get();
}

Return Value

A XFABarcodeType enumeration member specifying the type of the barcode used to represent the content of this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


%%PageItemTitle%%

XFABasicContainer Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

Defines a basic XFA container.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFABasicContainer
   Inherits XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
C#
public abstract class XFABasicContainer : XFAElement
Delphi
public class XFABasicContainer = class(XFAElement)abstract;
Managed Extensions for C++
public __gc abstract class XFABasicContainer : public XFAElement
C++/CLI
public ref class XFABasicContainer abstract : public XFAElement

Remarks

A basic XFA container is an element that can include only other basic containers.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFABasicContainer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

The following tables list the members exposed by XFABasicContainer.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top

See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFABasicContainer Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

For a list of all members of this type, see XFABasicContainer members.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top

See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

ID Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : ID Property

Gets the id of this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
Dim value As String

value = instance.ID
C#
public string ID {get;}
Delphi
public read-only property ID: String;
Managed Extensions for C++
public: __property string* get_ID();
C++/CLI
public:
property String^ ID {
   String^ get();
}

Return Value

A string value specifying the the container identifier.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : Name Property

Gets the name of this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the the container name.

Remarks

The name is used to locate the container inside the form hierarchy and it is relative to parent container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


%%PageItemTitle%%

XFAButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

Defines a XFA button field.

Syntax

Visual Basic (Declaration)
Public Class XFAButtonField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAButtonField
C#
public class XFAButtonField : XFAField
Delphi
public class XFAButtonField = class(XFAField)
Managed Extensions for C++
public __gc class XFAButtonField : public XFAField
C++/CLI
public ref class XFAButtonField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

The following tables list the members exposed by XFAButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFACheckButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

Defines a XFA check button field.

Syntax

Visual Basic (Declaration)
Public Class XFACheckButtonField
   Inherits XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonField
C#
public class XFACheckButtonField : XFARadioButtonField
Delphi
public class XFACheckButtonField = class(XFARadioButtonField)
Managed Extensions for C++
public __gc class XFACheckButtonField : public XFARadioButtonField
C++/CLI
public ref class XFACheckButtonField : public XFARadioButtonField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFACheckButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFACheckButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

The following tables list the members exposed by XFACheckButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFACheckButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

For a list of all members of this type, see XFACheckButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

AllowNeutral Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFACheckButtonField Class : AllowNeutral Property

Gets a value indicating whether the check button allows neutral state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowNeutral As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonField
Dim value As Boolean

value = instance.AllowNeutral
C#
public bool AllowNeutral {get;}
Delphi
public read-only property AllowNeutral: Boolean;
Managed Extensions for C++
public: __property bool get_AllowNeutral();
C++/CLI
public:
property bool AllowNeutral {
   bool get();
}

Return Value

True if the check button allows neutral state, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFACheckButtonField Class
XFACheckButtonField Members


%%PageItemTitle%%

XFAChoiceListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

Defines a XFA choice list field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFAChoiceListField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
C#
public class XFAChoiceListField : XFAField
Delphi
public class XFAChoiceListField = class(XFAField)
Managed Extensions for C++
public __gc class XFAChoiceListField : public XFAField
C++/CLI
public ref class XFAChoiceListField : public XFAField

Remarks

The field can be either a drop down list or a list box, depending on the DisplayMode property.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAChoiceListField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

The following tables list the members exposed by XFAChoiceListField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAChoiceListField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

For a list of all members of this type, see XFAChoiceListField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

DisplayMode Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : DisplayMode Property

Gets the display mode of the drop down choice list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayMode As XFAChoiceListDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAChoiceListDisplayMode

value = instance.DisplayMode
C#
public XFAChoiceListDisplayMode DisplayMode {get;}
Delphi
public read-only property DisplayMode: XFAChoiceListDisplayMode;
Managed Extensions for C++
public: __property XFAChoiceListDisplayMode get_DisplayMode();
C++/CLI
public:
property XFAChoiceListDisplayMode DisplayMode {
   XFAChoiceListDisplayMode get();
}

Return Value

A XFAChoiceListDisplayMode enumeration member specifying the display mode of the drop down choice list.

Remarks

If the value of this property is XFAChoiceListDisplayMode.Always or XFAChoiceListDisplayMode.Multiselect, then the choice list is presented as a list box in user interactive applications, otherwise it is presented as a drop down list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

Items Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : Items Property

Gets the collection of items in the choice list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As XFAListItemCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAListItemCollection

value = instance.Items
C#
public XFAListItemCollection Items {get;}
Delphi
public read-only property Items: XFAListItemCollection;
Managed Extensions for C++
public: __property XFAListItemCollection* get_Items();
C++/CLI
public:
property XFAListItemCollection^ Items {
   XFAListItemCollection^ get();
}

Return Value

A XFAListItemCollection that represents the items in the choice list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedIndex Property

Gets or sets the lowest ordinal index of the selected items in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Delphi
public read-write property SelectedIndex: Integer;
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.

Remarks

Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedItem Property

Gets or sets the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As XFAListItem
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAListItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
public XFAListItem SelectedItem {get; set;}
Delphi
public read-write property SelectedItem: XFAListItem;
Managed Extensions for C++
public: __property XFAListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   XFAListItem* value
);
C++/CLI
public:
property XFAListItem^ SelectedItem {
   XFAListItem^ get();
   void set (XFAListItem^ value);
}

Return Value

A XFAListItem object specifying the first selected item.

Remarks

If the item to select does not exist in the list, current selection is not changed.
If the item to select is null, then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedValue Property

Gets or sets the value of the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Delphi
public read-write property SelectedValue: String;
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

XFADateTimeEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

Defines a XFA date/time edit field.

Syntax

Visual Basic (Declaration)
Public Class XFADateTimeEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFADateTimeEditField
C#
public class XFADateTimeEditField : XFAField
Delphi
public class XFADateTimeEditField = class(XFAField)
Managed Extensions for C++
public __gc class XFADateTimeEditField : public XFAField
C++/CLI
public ref class XFADateTimeEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFADateTimeEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFADateTimeEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

The following tables list the members exposed by XFADateTimeEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFADateTimeEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

For a list of all members of this type, see XFADateTimeEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

DateTimeValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFADateTimeEditField Class : DateTimeValue Property

Gets or sets the date and time.

Syntax

Visual Basic (Declaration)
Public Property DateTimeValue As Date
Visual Basic (Usage) Copy Code
Dim instance As XFADateTimeEditField
Dim value As Date

instance.DateTimeValue = value

value = instance.DateTimeValue
C#
public DateTime DateTimeValue {get; set;}
Delphi
public read-write property DateTimeValue: DateTime;
Managed Extensions for C++
public: __property DateTime get_DateTimeValue();
public: __property void set_DateTimeValue(
   DateTime value
);
C++/CLI
public:
property DateTime DateTimeValue {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the value of the field.

Remarks

The value of this property is controlled by ValueType property.
When ValueType property is XFAContentType.Date, only the date part of the DateTime value is stored and the time part is set to 12:00:00 AM.
When ValueType property is XFAContentType.DateTime, the complete DateTime value is stored.
When ValueType property is XFAContentType.Time, only the time part of the DateTime value is stored and the date part is set to 01 January 0001.
This property returns 01 January 0001 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFADateTimeEditField Class
XFADateTimeEditField Members


%%PageItemTitle%%

XFAElement Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class

Defines the base class for all elements in a XFA form.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFAElement
C#
public abstract class XFAElement
Delphi
public class XFAElement abstract;
Managed Extensions for C++
public __gc abstract class XFAElement
C++/CLI
public ref class XFAElement abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFAForm
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAElement Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAElement Class Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class

The following tables list the members exposed by XFAElement.

See Also

Reference

XFAElement Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAExtendedContainer Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

Defines an extended XFA container.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFAExtendedContainer
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
C#
public abstract class XFAExtendedContainer : XFABasicContainer
Delphi
public class XFAExtendedContainer = class(XFABasicContainer)abstract;
Managed Extensions for C++
public __gc abstract class XFAExtendedContainer : public XFABasicContainer
C++/CLI
public ref class XFAExtendedContainer abstract : public XFABasicContainer

Remarks

An extended XFA container is an element that can include other containers, both basic and extended, such as subforms, areas and fields.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFASubform
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFAArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAExtendedContainer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

The following tables list the members exposed by XFAExtendedContainer.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top

See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAExtendedContainer Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

For a list of all members of this type, see XFAExtendedContainer members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top

See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Areas Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Areas Property

Gets the list of areas included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Areas As XFAAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFAAreaCollection

value = instance.Areas
C#
public XFAAreaCollection Areas {get;}
Delphi
public read-only property Areas: XFAAreaCollection;
Managed Extensions for C++
public: __property XFAAreaCollection* get_Areas();
C++/CLI
public:
property XFAAreaCollection^ Areas {
   XFAAreaCollection^ get();
}

Return Value

A XFAAreaCollection object specifying the list of areas included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


%%PageItemTitle%%

Fields Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Fields Property

Gets the list of fields included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As XFAFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFAFieldCollection

value = instance.Fields
C#
public XFAFieldCollection Fields {get;}
Delphi
public read-only property Fields: XFAFieldCollection;
Managed Extensions for C++
public: __property XFAFieldCollection* get_Fields();
C++/CLI
public:
property XFAFieldCollection^ Fields {
   XFAFieldCollection^ get();
}

Return Value

A XFAFieldCollection object specifying the list of fields included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


%%PageItemTitle%%

Subforms Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Subforms Property

Gets the list of subforms included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subforms As XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFASubformCollection

value = instance.Subforms
C#
public XFASubformCollection Subforms {get;}
Delphi
public read-only property Subforms: XFASubformCollection;
Managed Extensions for C++
public: __property XFASubformCollection* get_Subforms();
C++/CLI
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Return Value

A XFASubformCollection object specifying the list of subforms included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


%%PageItemTitle%%

XFAField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

Defines a XFA field.

Syntax

Visual Basic (Declaration)
Public Class XFAField
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAField
C#
public class XFAField : XFABasicContainer
Delphi
public class XFAField = class(XFABasicContainer)
Managed Extensions for C++
public __gc class XFAField : public XFABasicContainer
C++/CLI
public ref class XFAField : public XFABasicContainer

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

The following tables list the members exposed by XFAField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top

See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

For a list of all members of this type, see XFAField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top

See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Access Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Access Property

Gets or sets the access mode to field content.

Syntax

Visual Basic (Declaration)
Public Property Access As XFAContentAccess
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentAccess

instance.Access = value

value = instance.Access
C#
public XFAContentAccess Access {get; set;}
Delphi
public read-write property Access: XFAContentAccess;
Managed Extensions for C++
public: __property XFAContentAccess get_Access();
public: __property void set_Access(
   XFAContentAccess value
);
C++/CLI
public:
property XFAContentAccess Access {
   XFAContentAccess get();
   void set (XFAContentAccess value);
}

Return Value

A XFAContentAccess enumeration member specifying the allowed access mode for field content.

Remarks

If this property is XFAContentAccess.Protected or XFAContentAccess.ReadOnly, the field value can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

BindRef Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : BindRef Property

Gets the explicit data binding string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindRef As String
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As String

value = instance.BindRef
C#
public string BindRef {get;}
Delphi
public read-only property BindRef: String;
Managed Extensions for C++
public: __property string* get_BindRef();
C++/CLI
public:
property String^ BindRef {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Value Property

Gets or sets the value stored in this field.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}
Delphi
public read-write property Value: TObject;
Managed Extensions for C++
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
public:
property Object^ Value {
   Object^ get();
   void set (Object^ value);
}

Return Value

An object that boxes actual value.

Exceptions

Exception | Description
ArgumentException | Thrown when the provided value is not supported by the actual field type.
ArgumentOutOfRangeException | The value does not exist in field's specific set of values.

Remarks

The values accepted by this property depend on the actual field type. If the actual field does not support the provided value, an exception is raised.
If the field Access is Protected or ReadOnly, the Value can not be changed.
Fields with a fixed range of values (checkboxes, radiobutton lists and choice fields) will throw an exception if the value does not exist in their set of values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

ValueType Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : ValueType Property

Gets the type of value stored in this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As XFAContentType
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentType

value = instance.ValueType
C#
public XFAContentType ValueType {get;}
Delphi
public read-only property ValueType: XFAContentType;
Managed Extensions for C++
public: __property XFAContentType get_ValueType();
C++/CLI
public:
property XFAContentType ValueType {
   XFAContentType get();
}

Return Value

A XFAContentType enumeration member specifying the type of the value stored in this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

Visibility Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Visibility Property

Gets the visibility of the field content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visibility As XFAContentVisibility
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentVisibility

value = instance.Visibility
C#
public XFAContentVisibility Visibility {get;}
Delphi
public read-only property Visibility: XFAContentVisibility;
Managed Extensions for C++
public: __property XFAContentVisibility get_Visibility();
C++/CLI
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Return Value

A XFAContentVisibility enumeration member specifying the visibility for field content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

XFAFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

Defines a collection of XFA fields.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAFieldCollection
Delphi
public class XFAFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAFieldCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

The following tables list the members exposed by XFAFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%% $$Properties$$

XFAFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Item Property

Gets the field at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Gets the field with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(Int32) Property

index
Gets the field at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim index As Integer
Dim value As XFAField

value = instance.Item(index)
C#
public XFAField Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFAField;
Managed Extensions for C++
public: __property XFAField* get_Item(
   int index
);
C++/CLI
public:
property XFAField^ Item {
   XFAField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(String) Property

name
Gets the field with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim name As String
Dim value As XFAField

value = instance.Item(name)
C#
public XFAField Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFAField;
Managed Extensions for C++
public: __property XFAField* get_Item(
   string* name
);
C++/CLI
public:
property XFAField^ Item {
   XFAField^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


%%PageItemTitle%%

XFAFieldImportError Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

Represents an error that happened during the import of a XML file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFAFieldImportError
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
C#
public class XFAFieldImportError
Delphi
public class XFAFieldImportError
Managed Extensions for C++
public __gc class XFAFieldImportError
C++/CLI
public ref class XFAFieldImportError

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAFieldImportError Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

The following tables list the members exposed by XFAFieldImportError.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAFieldImportError Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

For a list of all members of this type, see XFAFieldImportError members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Exception Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Exception Property

Gets the exception thrown by the field during the import.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Delphi
public read-only property Exception: Exception;
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Return Value

A Exception object with the details about the import error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


%%PageItemTitle%%

Field Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Field Property

Gets the field that generated the import error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
Dim value As XFAField

value = instance.Field
C#
public XFAField Field {get;}
Delphi
public read-only property Field: XFAField;
Managed Extensions for C++
public: __property XFAField* get_Field();
C++/CLI
public:
property XFAField^ Field {
   XFAField^ get();
}

Return Value

A XFAField object representing the field that generated the error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


%%PageItemTitle%%

XFAForm Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

Defines a document level XFA form.

Syntax

Visual Basic (Declaration)
Public Class XFAForm
   Inherits XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
C#
public class XFAForm : XFAElement
Delphi
public class XFAForm = class(XFAElement)
Managed Extensions for C++
public __gc class XFAForm : public XFAElement
C++/CLI
public ref class XFAForm : public XFAElement

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFAForm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAForm Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

The following tables list the members exposed by XFAForm.

Public Properties

 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAForm Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

ExportData Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ExportData Method

Exports the form data to a file.

Overload List

Overload | Description
ExportData(String,XFADataFormat,ExportDataOptions) | Exports the form data to a file.
ExportData(Stream,XFADataFormat,ExportDataOptions) | Exports the form data to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


%%PageItemTitle%%

ExportData(String,XFADataFormat,ExportDataOptions) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(String,XFADataFormat,ExportDataOptions) Method

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Exports the form data to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As XFADataFormat, _
   ByVal options As ExportDataOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim fileName As String
Dim format As XFADataFormat
Dim options As ExportDataOptions

instance.ExportData(fileName, format, options)
C#
public void ExportData(
   string fileName,
   XFADataFormat format,
   ExportDataOptions options
)
Delphi
public procedure ExportData(
    fileName: String;
    format: XFADataFormat;
    options: ExportDataOptions
);
Managed Extensions for C++
public: void ExportData(
   string* fileName,
   XFADataFormat format,
   ExportDataOptions options
)
C++/CLI
public:
void ExportData(
   String^ fileName,
   XFADataFormat format,
   ExportDataOptions options
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


%%PageItemTitle%%

ExportData(Stream,XFADataFormat,ExportDataOptions) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(Stream,XFADataFormat,ExportDataOptions) Method

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Exports the form data to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As XFADataFormat, _
   ByVal options As ExportDataOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim stream As Stream
Dim format As XFADataFormat
Dim options As ExportDataOptions

instance.ExportData(stream, format, options)
C#
public void ExportData(
   Stream stream,
   XFADataFormat format,
   ExportDataOptions options
)
Delphi
public procedure ExportData(
    stream: Stream;
    format: XFADataFormat;
    options: ExportDataOptions
);
Managed Extensions for C++
public: void ExportData(
   Stream* stream,
   XFADataFormat format,
   ExportDataOptions options
)
C++/CLI
public:
void ExportData(
   Stream^ stream,
   XFADataFormat format,
   ExportDataOptions options
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


%%PageItemTitle%%

ImportData Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ImportData Method

Imports form data from an external file.

Overload List

Overload | Description
ImportData(String,XFADataFormat) | Imports form data from an external file.
ImportData(Stream,XFADataFormat) | Imports form data from an external file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


%%PageItemTitle%%

ImportData(String,XFADataFormat) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(String,XFADataFormat) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As XFADataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim fileName As String
Dim dataFormat As XFADataFormat

instance.ImportData(fileName, dataFormat)
C#
public void ImportData(
   string fileName,
   XFADataFormat dataFormat
)
Delphi
public procedure ImportData(
    fileName: String;
    dataFormat: XFADataFormat
);
Managed Extensions for C++
public: void ImportData(
   string* fileName,
   XFADataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   String^ fileName,
   XFADataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


%%PageItemTitle%%

ImportData(Stream,XFADataFormat) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(Stream,XFADataFormat) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As XFADataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim stream As Stream
Dim dataFormat As XFADataFormat

instance.ImportData(stream, dataFormat)
C#
public void ImportData(
   Stream stream,
   XFADataFormat dataFormat
)
Delphi
public procedure ImportData(
    stream: Stream;
    dataFormat: XFADataFormat
);
Managed Extensions for C++
public: void ImportData(
   Stream* stream,
   XFADataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   Stream^ stream,
   XFADataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


%%PageItemTitle%% $$Properties$$

XFAForm Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Properties

 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

ForceRendering Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ForceRendering Property

Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.

Syntax

Visual Basic (Declaration)
Public Property ForceRendering As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim value As Boolean

instance.ForceRendering = value

value = instance.ForceRendering
C#
public bool ForceRendering {get; set;}
Delphi
public read-write property ForceRendering: Boolean;
Managed Extensions for C++
public: __property bool get_ForceRendering();
public: __property void set_ForceRendering(
   bool value
);
C++/CLI
public:
property bool ForceRendering {
   bool get();
   void set (bool value);
}

Return Value

True if the XFA form should be regenerated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


%%PageItemTitle%%

Subforms Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : Subforms Property

Gets the list of subforms included in the form.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subforms As XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim value As XFASubformCollection

value = instance.Subforms
C#
public XFASubformCollection Subforms {get;}
Delphi
public read-only property Subforms: XFASubformCollection;
Managed Extensions for C++
public: __property XFASubformCollection* get_Subforms();
C++/CLI
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Return Value

A XFASubformCollection object specifying the list of subforms included in this form.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


%%PageItemTitle%%

XFAHttpSubmitButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

Defines a XFA button field that submits the form data to a server using HTTP protocol.

Syntax

Visual Basic (Declaration)
Public Class XFAHttpSubmitButtonField
   Inherits XFAButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFAHttpSubmitButtonField
C#
public class XFAHttpSubmitButtonField : XFAButtonField
Delphi
public class XFAHttpSubmitButtonField = class(XFAButtonField)
Managed Extensions for C++
public __gc class XFAHttpSubmitButtonField : public XFAButtonField
C++/CLI
public ref class XFAHttpSubmitButtonField : public XFAButtonField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAHttpSubmitButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAHttpSubmitButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

The following tables list the members exposed by XFAHttpSubmitButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAHttpSubmitButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

For a list of all members of this type, see XFAHttpSubmitButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Url Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAHttpSubmitButtonField Class : Url Property

Gets or sets the Url where the form data is submitted.

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As XFAHttpSubmitButtonField
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Delphi
public read-write property Url: String;
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^ value);
}

Remarks

A string value specifying the HTTP Url where the form data is submitted when the button is clicked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAHttpSubmitButtonField Class
XFAHttpSubmitButtonField Members


%%PageItemTitle%%

XFAImageEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

Defines a XFA image edit field.

Syntax

Visual Basic (Declaration)
Public Class XFAImageEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
C#
public class XFAImageEditField : XFAField
Delphi
public class XFAImageEditField = class(XFAField)
Managed Extensions for C++
public __gc class XFAImageEditField : public XFAField
C++/CLI
public ref class XFAImageEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAImageEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

The following tables list the members exposed by XFAImageEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAImageEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

For a list of all members of this type, see XFAImageEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

ContentType Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ContentType Property

Gets or sets the image content type.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As String

instance.ContentType = value

value = instance.ContentType
C#
public string ContentType {get; set;}
Delphi
public read-write property ContentType: String;
Managed Extensions for C++
public: __property string* get_ContentType();
public: __property void set_ContentType(
   string* value
);
C++/CLI
public:
property String^ ContentType {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the image content type.

Remarks

This property is the MIME-type of the image stored in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

ImageAspect Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageAspect Property

Gets the scaling mode for the image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageAspect As XFAImageAspect
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As XFAImageAspect

value = instance.ImageAspect
C#
public XFAImageAspect ImageAspect {get;}
Delphi
public read-only property ImageAspect: XFAImageAspect;
Managed Extensions for C++
public: __property XFAImageAspect get_ImageAspect();
C++/CLI
public:
property XFAImageAspect ImageAspect {
   XFAImageAspect get();
}

Return Value

A XFAImageAspect enumeration member specifying how the image is scaled when it is displayed in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

ImageData Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageData Property

Gets or sets the image data to be loaded in this field.

Syntax

Visual Basic (Declaration)
Public Property ImageData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value() As Byte

instance.ImageData = value

value = instance.ImageData
C#
public byte[] ImageData {get; set;}
Delphi
public read-write property ImageData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_ImageData();
public: __property void set_ImageData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ImageData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the image data to be loaded in this field.

Remarks

Only one of ImagePath or ImageData properties can be set. If this property is set, then ImagePath property is set to null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

ImagePath Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImagePath Property

Gets or sets the path to the image to be loaded in this field.

Syntax

Visual Basic (Declaration)
Public Property ImagePath As String
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
C#
public string ImagePath {get; set;}
Delphi
public read-write property ImagePath: String;
Managed Extensions for C++
public: __property string* get_ImagePath();
public: __property void set_ImagePath(
   string* value
);
C++/CLI
public:
property String^ ImagePath {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the path to the image to be loaded in this field.

Remarks

Only one of ImagePath or ImageData properties can be set. If this property is set, then ImageData property is set to null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

ImageStorageMode Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageStorageMode Property

Gets the mode the image is stored in this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageStorageMode As XFAImageStorageMode
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As XFAImageStorageMode

value = instance.ImageStorageMode
C#
public XFAImageStorageMode ImageStorageMode {get;}
Delphi
public read-only property ImageStorageMode: XFAImageStorageMode;
Managed Extensions for C++
public: __property XFAImageStorageMode get_ImageStorageMode();
C++/CLI
public:
property XFAImageStorageMode ImageStorageMode {
   XFAImageStorageMode get();
}

Return Value

A ImageStorageMode enumeration member specifying the mode the image is stored in this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

XFAListItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

Defines an item in a choice list.

Syntax

Visual Basic (Declaration)
Public Class XFAListItem
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
C#
public class XFAListItem
Delphi
public class XFAListItem
Managed Extensions for C++
public __gc class XFAListItem
C++/CLI
public ref class XFAListItem

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAListItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAListItem Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

The following tables list the members exposed by XFAListItem.

Public Constructors

 | Name | Description
Public Constructor | XFAListItem Constructor | Initializes a new XFAListItem object.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top

See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAListItem Constructor
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : XFAListItem Constructor

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.
Initializes a new XFAListItem object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemName As String, _
   ByVal itemValue As String _
)
Visual Basic (Usage) Copy Code
Dim itemName As String
Dim itemValue As String

Dim instance As XFAListItem(itemName, itemValue)
C#
public XFAListItem(
   string itemName,
   string itemValue
)
Delphi
public XFAListItem(
    itemName: String;
    itemValue: String
);
Managed Extensions for C++
public: XFAListItem(
   string* itemName,
   string* itemValue
)
C++/CLI
public:
XFAListItem(
   String^ itemName,
   String^ itemValue
)

Parameters

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item value is null or empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


%%PageItemTitle%% $$Properties$$

XFAListItem Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

For a list of all members of this type, see XFAListItem members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top

See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Name Property

Gets or sets the name of the list item.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the name of the list item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


%%PageItemTitle%%

Value Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Value Property

Gets or sets the value of the list item.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Delphi
public read-write property Value: String;
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the value of the list item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


%%PageItemTitle%%

XFAListItemCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

Defines a collection of items in a list.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class XFAListItemCollection
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class XFAListItemCollection : PDFObject
Delphi
public class XFAListItemCollection = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class XFAListItemCollection : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAListItemCollection sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAListItemCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

The following tables list the members exposed by XFAListItemCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the item at the specified index (zero based index)
Top

Public Methods

 | Name | Description
Public Method | Add | Inserts an item at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets the index of the given item in the collection.
Public Method | Insert | Inserts an item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | Removes an item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAListItemCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Inserts an item at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | IndexOf | Gets the index of the given item in the collection.
Public Method | Insert | Inserts an item at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes an item from the collection.
Public Method | RemoveAt | Removes an item at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Add Method

item
a XFAListItem object to be added to collection.
Inserts an item at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As XFAListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim item As XFAListItem

instance.Add(item)
C#
public void Add(
   XFAListItem item
)
Delphi
public procedure Add(
    item: XFAListItem
);
Managed Extensions for C++
public: void Add(
   XFAListItem* item
)
C++/CLI
public:
void Add(
   XFAListItem^ item
)

Parameters

item
a XFAListItem object to be added to collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : IndexOf Method

item
A XFAListItem object whose index is requested.
Gets the index of the given item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As XFAListItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim item As XFAListItem
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   XFAListItem item
)
Delphi
public function IndexOf(
    item: XFAListItem
): Integer;
Managed Extensions for C++
public: int IndexOf(
   XFAListItem* item
)
C++/CLI
public:
int IndexOf(
   XFAListItem^ item
)

Parameters

item
A XFAListItem object whose index is requested.

Return Value

The index of the given item, -1 if the item does not exist.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Insert Method

index
The index where to insert the new item.
item
A XFAListItem object to be added to collection.
Inserts an item at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As XFAListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim index As Integer
Dim item As XFAListItem

instance.Insert(index, item)
C#
public void Insert(
   int index,
   XFAListItem item
)
Delphi
public procedure Insert(
    index: Integer;
    item: XFAListItem
);
Managed Extensions for C++
public: void Insert(
   int index,
   XFAListItem* item
)
C++/CLI
public:
void Insert(
   int index,
   XFAListItem^ item
)

Parameters

index
The index where to insert the new item.
item
A XFAListItem object to be added to collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Remove Method

item
The XFAListItem object to be removed from collection.
Removes an item from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As XFAListItem _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim item As XFAListItem

instance.Remove(item)
C#
public void Remove(
   XFAListItem item
)
Delphi
public procedure Remove(
    item: XFAListItem
);
Managed Extensions for C++
public: void Remove(
   XFAListItem* item
)
C++/CLI
public:
void Remove(
   XFAListItem^ item
)

Parameters

item
The XFAListItem object to be removed from collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : RemoveAt Method

index
The index where to remove the item.
Removes an item at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index where to remove the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%% $$Properties$$

XFAListItemCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the item at the specified index (zero based index)
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Count Property

Returns the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItemCollection Class : Item Property

index
Gets the item at the specified index (zero based index)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As XFAListItem
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
Dim index As Integer
Dim value As XFAListItem

value = instance.Item(index)
C#
public XFAListItem this[
   int index
]; {get;}
Delphi
public  this: : XFAListItem;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property XFAListItem* get_Item(
   int index
);
C++/CLI
public:
property XFAListItem^ default [int] {
   XFAListItem^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Class
XFAListItemCollection Members


%%PageItemTitle%%

XFANumericEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

Defines a XFA numeric edit field.

Syntax

Visual Basic (Declaration)
Public Class XFANumericEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
C#
public class XFANumericEditField : XFAField
Delphi
public class XFANumericEditField = class(XFAField)
Managed Extensions for C++
public __gc class XFANumericEditField : public XFAField
C++/CLI
public ref class XFANumericEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFANumericEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

The following tables list the members exposed by XFANumericEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFANumericEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

For a list of all members of this type, see XFANumericEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

DecimalValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : DecimalValue Property

Gets or sets the decimal number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property DecimalValue As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Decimal

instance.DecimalValue = value

value = instance.DecimalValue
C#
public decimal DecimalValue {get; set;}
Delphi
public read-write property DecimalValue: Currency;
Managed Extensions for C++
public: __property decimal get_DecimalValue();
public: __property void set_DecimalValue(
   decimal value
);
C++/CLI
public:
property decimal DecimalValue {
   decimal get();
   void set (decimal value);
}

Return Value

A decimal value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


%%PageItemTitle%%

FloatValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : FloatValue Property

Gets or sets the float number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property FloatValue As Double
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Double

instance.FloatValue = value

value = instance.FloatValue
C#
public double FloatValue {get; set;}
Delphi
public read-write property FloatValue: Double;
Managed Extensions for C++
public: __property double get_FloatValue();
public: __property void set_FloatValue(
   double value
);
C++/CLI
public:
property double FloatValue {
   double get();
   void set (double value);
}

Return Value

A double value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


%%PageItemTitle%%

IntValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : IntValue Property

Gets or sets the integer number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property IntValue As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Integer

instance.IntValue = value

value = instance.IntValue
C#
public int IntValue {get; set;}
Delphi
public read-write property IntValue: Integer;
Managed Extensions for C++
public: __property int get_IntValue();
public: __property void set_IntValue(
   int value
);
C++/CLI
public:
property int IntValue {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


%%PageItemTitle%%

XFAPageArea Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

Defines a XFA page area.

Syntax

Visual Basic (Declaration)
Public Class XFAPageArea
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageArea
C#
public class XFAPageArea : XFAExtendedContainer
Delphi
public class XFAPageArea = class(XFAExtendedContainer)
Managed Extensions for C++
public __gc class XFAPageArea : public XFAExtendedContainer
C++/CLI
public ref class XFAPageArea : public XFAExtendedContainer

Remarks

A XFA page area is an element that describes a rendering surface.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageArea Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

The following tables list the members exposed by XFAPageArea.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAPageAreaCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

Defines a collection of XFA page areas.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAPageAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAPageAreaCollection
Delphi
public class XFAPageAreaCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAPageAreaCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAPageAreaCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageAreaCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

The following tables list the members exposed by XFAPageAreaCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAPageAreaCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%% $$Properties$$

XFAPageAreaCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Item Property

Gets the page area at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the page area at the specified index (zero based index).
Item(String) | Gets the page area with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(Int32) Property

index
Gets the page area at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageArea
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim index As Integer
Dim value As XFAPageArea

value = instance.Item(index)
C#
public XFAPageArea Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFAPageArea;
Managed Extensions for C++
public: __property XFAPageArea* get_Item(
   int index
);
C++/CLI
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(String) Property

name
Gets the page area with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageArea
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim name As String
Dim value As XFAPageArea

value = instance.Item(name)
C#
public XFAPageArea Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFAPageArea;
Managed Extensions for C++
public: __property XFAPageArea* get_Item(
   string* name
);
C++/CLI
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


%%PageItemTitle%%

XFAPageSet Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

Defines a XFA page set.

Syntax

Visual Basic (Declaration)
Public Class XFAPageSet
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
C#
public class XFAPageSet : XFABasicContainer
Delphi
public class XFAPageSet = class(XFABasicContainer)
Managed Extensions for C++
public __gc class XFAPageSet : public XFABasicContainer
C++/CLI
public ref class XFAPageSet : public XFABasicContainer

Remarks

A page set describes a set of related page areas.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageSet Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

The following tables list the members exposed by XFAPageSet.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top

See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPageSet Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

For a list of all members of this type, see XFAPageSet members.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top

See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

PageAreas Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageAreas Property

Gets the list of page areas included in this page set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageAreas As XFAPageAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
Dim value As XFAPageAreaCollection

value = instance.PageAreas
C#
public XFAPageAreaCollection PageAreas {get;}
Delphi
public read-only property PageAreas: XFAPageAreaCollection;
Managed Extensions for C++
public: __property XFAPageAreaCollection* get_PageAreas();
C++/CLI
public:
property XFAPageAreaCollection^ PageAreas {
   XFAPageAreaCollection^ get();
}

Return Value

A XFAPageAreaCollection object specifying the list of areas included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Class
XFAPageSet Members


%%PageItemTitle%%

PageSets Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageSets Property

Gets the list of page sets included in this page set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSets As XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
Dim value As XFAPageSetCollection

value = instance.PageSets
C#
public XFAPageSetCollection PageSets {get;}
Delphi
public read-only property PageSets: XFAPageSetCollection;
Managed Extensions for C++
public: __property XFAPageSetCollection* get_PageSets();
C++/CLI
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Return Value

A XFAPageSetCollection object specifying the list of page sets included in this page set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Class
XFAPageSet Members


%%PageItemTitle%%

XFAPageSetCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

Defines a collection of XFA page sets.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAPageSetCollection
Delphi
public class XFAPageSetCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAPageSetCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAPageSetCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageSetCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

The following tables list the members exposed by XFAPageSetCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAPageSetCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%% $$Properties$$

XFAPageSetCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Item Property

Gets the page set at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the page set at the specified index (zero based index).
Item(String) | Gets the page set with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(Int32) Property

index
Gets the page set at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageSet
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim index As Integer
Dim value As XFAPageSet

value = instance.Item(index)
C#
public XFAPageSet Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFAPageSet;
Managed Extensions for C++
public: __property XFAPageSet* get_Item(
   int index
);
C++/CLI
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(String) Property

name
Gets the page set with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageSet
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim name As String
Dim value As XFAPageSet

value = instance.Item(name)
C#
public XFAPageSet Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFAPageSet;
Managed Extensions for C++
public: __property XFAPageSet* get_Item(
   string* name
);
C++/CLI
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


%%PageItemTitle%%

XFAPasswordEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

Defines a XFA password edit field.

Syntax

Visual Basic (Declaration)
Public Class XFAPasswordEditField
   Inherits XFATextEditField
Visual Basic (Usage) Copy Code
Dim instance As XFAPasswordEditField
C#
public class XFAPasswordEditField : XFATextEditField
Delphi
public class XFAPasswordEditField = class(XFATextEditField)
Managed Extensions for C++
public __gc class XFAPasswordEditField : public XFATextEditField
C++/CLI
public ref class XFAPasswordEditField : public XFATextEditField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPasswordEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPasswordEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

The following tables list the members exposed by XFAPasswordEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPasswordEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

For a list of all members of this type, see XFAPasswordEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

PasswordChar Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPasswordEditField Class : PasswordChar Property

Gets the character used to mask the user input that is entered in the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PasswordChar As Char
Visual Basic (Usage) Copy Code
Dim instance As XFAPasswordEditField
Dim value As Char

value = instance.PasswordChar
C#
public char PasswordChar {get;}
Delphi
public read-only property PasswordChar: Char;
Managed Extensions for C++
public: __property char get_PasswordChar();
C++/CLI
public:
property char PasswordChar {
   char get();
}

Return Value

A char value specifying the character used to mask the user input that is entered in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPasswordEditField Class
XFAPasswordEditField Members


%%PageItemTitle%%

XFARadioButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

Defines a XFA radio button field.

Syntax

Visual Basic (Declaration)
Public Class XFARadioButtonField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonField
C#
public class XFARadioButtonField : XFAField
Delphi
public class XFARadioButtonField = class(XFAField)
Managed Extensions for C++
public __gc class XFARadioButtonField : public XFAField
C++/CLI
public ref class XFARadioButtonField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

The following tables list the members exposed by XFARadioButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFARadioButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

For a list of all members of this type, see XFARadioButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

CheckedState Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonField Class : CheckedState Property

Gets or sets the checked state of the field.

Syntax

Visual Basic (Declaration)
Public Property CheckedState As XFACheckButtonState
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonField
Dim value As XFACheckButtonState

instance.CheckedState = value

value = instance.CheckedState
C#
public XFACheckButtonState CheckedState {get; set;}
Delphi
public read-write property CheckedState: XFACheckButtonState;
Managed Extensions for C++
public: __property XFACheckButtonState get_CheckedState();
public: __property void set_CheckedState(
   XFACheckButtonState value
);
C++/CLI
public:
property XFACheckButtonState CheckedState {
   XFACheckButtonState get();
   void set (XFACheckButtonState value);
}

Return Value

A XFACheckButtonState enumeration member specifying the checked state of the field.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when trying to set Neutral state on a radio button or on a check button that does not support it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonField Class
XFARadioButtonField Members


%%PageItemTitle%%

XFARadioButtonFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

Defines a collection of exclusive radio buttons.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFARadioButtonFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
C#
[DefaultMemberAttribute("Item")]
public class XFARadioButtonFieldCollection
Delphi
public class XFARadioButtonFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFARadioButtonFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFARadioButtonFieldCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

The following tables list the members exposed by XFARadioButtonFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFARadioButtonFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%% $$Properties$$

XFARadioButtonFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Item Property

index
Gets the radio button at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim index As Integer
Dim value As XFARadioButtonField

value = instance.Item(index)
C#
public XFARadioButtonField this[
   int index
]; {get;}
Delphi
public  this: : XFARadioButtonField;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property XFARadioButtonField* get_Item(
   int index
);
C++/CLI
public:
property XFARadioButtonField^ default [int] {
   XFARadioButtonField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

XFARadioButtonListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

Defines a XFA radio buttons list field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFARadioButtonListField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
C#
public class XFARadioButtonListField : XFAField
Delphi
public class XFARadioButtonListField = class(XFAField)
Managed Extensions for C++
public __gc class XFARadioButtonListField : public XFAField
C++/CLI
public ref class XFARadioButtonListField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonListField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

The following tables list the members exposed by XFARadioButtonListField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFARadioButtonListField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

For a list of all members of this type, see XFARadioButtonListField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Items Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : Items Property

Gets the list of radio buttons included in this list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As XFARadioButtonFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonFieldCollection

value = instance.Items
C#
public XFARadioButtonFieldCollection Items {get;}
Delphi
public read-only property Items: XFARadioButtonFieldCollection;
Managed Extensions for C++
public: __property XFARadioButtonFieldCollection* get_Items();
C++/CLI
public:
property XFARadioButtonFieldCollection^ Items {
   XFARadioButtonFieldCollection^ get();
}

Return Value

A XFARadioButtonFieldCollection object specifying the list of radio buttons in this list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


%%PageItemTitle%%

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedIndex Property

Gets or sets the index of the checked radio button in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Delphi
public read-write property SelectedIndex: Integer;
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the checked radio button in the list.

Remarks

-1 means that no radio button is checked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


%%PageItemTitle%%

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedItem Property

Gets or sets the selected radio button in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonField

instance.SelectedItem = value

value = instance.SelectedItem
C#
public XFARadioButtonField SelectedItem {get; set;}
Delphi
public read-write property SelectedItem: XFARadioButtonField;
Managed Extensions for C++
public: __property XFARadioButtonField* get_SelectedItem();
public: __property void set_SelectedItem(
   XFARadioButtonField* value
);
C++/CLI
public:
property XFARadioButtonField^ SelectedItem {
   XFARadioButtonField^ get();
   void set (XFARadioButtonField^ value);
}

Return Value

A XFARadioButtonField object specifying the selected radio button.

Remarks

null (Nothing in VB.NET) means that no radio button is selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


%%PageItemTitle%%

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedValue Property

Gets or sets the selected radio button based on radio button's value.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Delphi
public read-write property SelectedValue: String;
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


%%PageItemTitle%%

XFASubform Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

Defines a XFA subform.

Syntax

Visual Basic (Declaration)
Public Class XFASubform
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
C#
public class XFASubform : XFAExtendedContainer
Delphi
public class XFASubform = class(XFAExtendedContainer)
Managed Extensions for C++
public __gc class XFASubform : public XFAExtendedContainer
C++/CLI
public ref class XFASubform : public XFAExtendedContainer

Remarks

A XFA subform is used to group in a logical manner the elements in a XFA form. A XFA subform can be included in another subform and also it ca include other subforms.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFASubform

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFASubform Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

The following tables list the members exposed by XFASubform.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top

See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFASubform Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

For a list of all members of this type, see XFASubform members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top

See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

PageSets Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : PageSets Property

Gets the list of page sets included in this subform.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSets As XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
Dim value As XFAPageSetCollection

value = instance.PageSets
C#
public XFAPageSetCollection PageSets {get;}
Delphi
public read-only property PageSets: XFAPageSetCollection;
Managed Extensions for C++
public: __property XFAPageSetCollection* get_PageSets();
C++/CLI
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Return Value

A XFAPageSetCollection object specifying the list of page sets included in this subform.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Class
XFASubform Members


%%PageItemTitle%%

Visibility Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : Visibility Property

Gets the visibility of the subform content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visibility As XFAContentVisibility
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
Dim value As XFAContentVisibility

value = instance.Visibility
C#
public XFAContentVisibility Visibility {get;}
Delphi
public read-only property Visibility: XFAContentVisibility;
Managed Extensions for C++
public: __property XFAContentVisibility get_Visibility();
C++/CLI
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Return Value

A XFAContentVisibility enumeration member specifying the visibility for subform content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Class
XFASubform Members


%%PageItemTitle%%

XFASubformCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

Defines a collection of XFA subforms.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
C#
[DefaultMemberAttribute("Item")]
public class XFASubformCollection
Delphi
public class XFASubformCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFASubformCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFASubformCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFASubformCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

The following tables list the members exposed by XFASubformCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFASubformCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%% $$Properties$$

XFASubformCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Item Property

Gets the subform at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the subform at the specified index (zero based index).
Item(String) | Gets the subform with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%%

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(Int32) Property

index
Gets the subform at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFASubform
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim index As Integer
Dim value As XFASubform

value = instance.Item(index)
C#
public XFASubform Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): XFASubform;
Managed Extensions for C++
public: __property XFASubform* get_Item(
   int index
);
C++/CLI
public:
property XFASubform^ Item {
   XFASubform^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


%%PageItemTitle%%

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(String) Property

name
Gets the subform with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFASubform
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim name As String
Dim value As XFASubform

value = instance.Item(name)
C#
public XFASubform Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): XFASubform;
Managed Extensions for C++
public: __property XFASubform* get_Item(
   string* name
);
C++/CLI
public:
property XFASubform^ Item {
   XFASubform^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


%%PageItemTitle%%

XFATextEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

Defines a XFA text edit field.

Syntax

Visual Basic (Declaration)
Public Class XFATextEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
C#
public class XFATextEditField : XFAField
Delphi
public class XFATextEditField = class(XFAField)
Managed Extensions for C++
public __gc class XFATextEditField : public XFAField
C++/CLI
public ref class XFATextEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFATextEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

The following tables list the members exposed by XFATextEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFATextEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

For a list of all members of this type, see XFATextEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

MaxLen Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : MaxLen Property

Gets or sets the maximum number of characters that can be entered in the text edit field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLen As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As Integer

value = instance.MaxLen
C#
public int MaxLen {get;}
Delphi
public read-only property MaxLen: Integer;
Managed Extensions for C++
public: __property int get_MaxLen();
C++/CLI
public:
property int MaxLen {
   int get();
}

Return Value

An non-negative integer value specifying the maximum number of characters that can be entered in the text edit field.

Remarks

If the value of this property is 0, then the length of this field is unlimited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


%%PageItemTitle%%

Multiline Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Multiline Property

Gets a value indicating whether the field is multiline.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As Boolean

value = instance.Multiline
C#
public bool Multiline {get;}
Delphi
public read-only property Multiline: Boolean;
Managed Extensions for C++
public: __property bool get_Multiline();
C++/CLI
public:
property bool Multiline {
   bool get();
}

Return Value

True if the field is multiline, false otherwise.

Remarks

For password edit fields this property is always false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Text Property

Gets or sets the text in this text edit field.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text displayed in the text edit field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


%%PageItemTitle%%

XFABarcodeType Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeType Enumeration

Specifies the available barcode types for displaying field content.

Syntax

Visual Basic (Declaration)
Public Enum XFABarcodeType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeType
C#
public enum XFABarcodeType : Enum
Delphi
public enum XFABarcodeType = class(Enum)
Managed Extensions for C++
__value public enum XFABarcodeType : public Enum
C++/CLI
public enum class XFABarcodeType : public Enum

Members

Member | Description
Codabar | Codabar, as defined in ANSI/AIM BC3-1995, USS Codabar.
Code2Of5Industrial | Code 2 of 5 Industrial; no official standard.
Code2Of5Interleaved | Code 2 of 5 Interleaved, as defined in ANSI/AIM BC2-1995.
Code2Of5Matrix | Code 2 of 5 Matrix; no official standard.
Code2Of5Standard | Code 2 of 5 Standard; no official standard.
Code3Of9 | Code 39 (also known as code 3 of 9), as defined in ANSI/AIM BC1-1995.
Code3Of9Extended | Code 39 extended; no official standard.
Code11 | Code 11 (USD-8); no official standard.
Code49 | Code 49, as defined in ANSI/AIM BC6-1995.
Code93 | Code 93, as defined in ANSI/AIM BC5-1995.
Code128 | Code 128, as defined in ANSI/AIM BC4-1995.
Code128A | Code 128 A, as defined in ANSI/AIM BC4-1995.
Code128B | Code 128 B, as defined in ANSI/AIM BC4-1995.
Code128C | Code 128 C, as defined in ANSI/AIM BC4-1995.
Code128SSCC | Code 128 serial shipping container code, as defined in ANSI/AIM BC4-1995.
Ean8 | EAN-8, as defined in ISO/EEC 15420.
Ean8Add2 | EAN-8 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean8Add5 | EAN-8 with 5-digit Addendum, as defined in ISO/EEC 15420.
Ean13 | EAN-13, as defined in ISO/EEC 15420.
Ean13Pwcd | EAN-13 with Price/Weight customer data, as defined in ISO/EEC 15420.
Ean13Add2 | EAN-13 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean13Add5 | EAN-13 with 5-digit Addendum, as defined in ISO/EEC 15420.
Fim | United States Postal Service FIM (Facing Identification Mark), as described in First-Class Mail.
Logmars | Logmars (Logistics Applications of Automated Marking and Reading Symbols) as defined by U.S. Military Standard MIL-STD-1189B
Maxicode | UPS Maxicode, as defined in ANSI/AIM BC10-ISS Maxicode.
Msi | MSI (modified Plessey).
Pdf417 | PDF417, as defined in USS PDF417.
Pdf417Macro | PDF417, but allowing the data to span multiple PDF417 bar codes.
Plessey | Plessey; no official standard.
PostAUSCust2 | Australian Postal Customer 2, as defined in Customer Barcoding Technical Specifications.
PostAUSCust3 | Australian Postal Customer 3, as defined in Customer Barcoding Technical Specifications.
PostAUSReplyPaid | Australian Postal Reply Paid, as defined in Customer Barcoding Technical Specifications.
PostAUSStandard | Australian Postal Standard, as defined in Customer Barcoding Technical Specifications.
PostUKRM4SCC | United Kingdom RM4SCC (Royal Mail 4-State Customer Code), as defined in the How to Use Mailsort Guide.
PostUSDPBC | United States Postal Service Delivery Point Bar Code, as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSStandard | United States Postal Service POSTNET bar code (Zip+4), as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSZip | United States Postal Service POSTNET bar code (5 digit Zip), as defined in DMM C840 Barcoding Standards for Letters and Flats.
QR | QR Code, as defined in ISS - QR Code.
Telepen | Telepen, as defined in USS Telepen.
Ucc128 | UCC/EAN 128, as defined in International Symbology Specification - Code 128.
Ucc128Random | UCC/EAN 128 Random Weight, as defined in International Symbology Specification - Code 128.
Ucc128SSCC | UCC/EAN 128 serial shipping container code (SSCC), as defined in International Symbology Specification - Code 128.
UpcA | UPC-A, as defined in ISO/EEC 15420.
UpcAAdd2 | UPC-A with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcAAdd5 | UPC-A with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcAPwcd | UPC-A with Price/Weight customer data, as defined in ISO/EEC 15420.
UpcE | UPC-E, as defined in ISO/EEC 15420.
UpcEAdd2 | UPC-E with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEAdd5 | UPC-E with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcEan2 | UPC/EAN with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEan5 | UPC/EAN with 5-digit Addendum, as defined in ISO/EEC 15420.
Unknown | Unknown barcode type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFACheckButtonState Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonState Enumeration

Specifies the available states for a checkbutton and radiobutton.

Syntax

Visual Basic (Declaration)
Public Enum XFACheckButtonState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonState
C#
public enum XFACheckButtonState : Enum
Delphi
public enum XFACheckButtonState = class(Enum)
Managed Extensions for C++
__value public enum XFACheckButtonState : public Enum
C++/CLI
public enum class XFACheckButtonState : public Enum

Members

Member | Description
Checked | Checked state.
Unchecked | Unchecked state.
Neutral | Neutral state, not available for radiobuttons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAChoiceListDisplayMode Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListDisplayMode Enumeration

Specifies the modes for presenting the drop down choice list in interactive applications.

Syntax

Visual Basic (Declaration)
Public Enum XFAChoiceListDisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListDisplayMode
C#
public enum XFAChoiceListDisplayMode : Enum
Delphi
public enum XFAChoiceListDisplayMode = class(Enum)
Managed Extensions for C++
__value public enum XFAChoiceListDisplayMode : public Enum
C++/CLI
public enum class XFAChoiceListDisplayMode : public Enum

Members

Member | Description
UserControl | The drop down list is displayed when the user clicks on the field or on the arrow button.
OnEntry | The drop down list is displayed when the field gets the focus.
Always | The drop down list is always displayed (the field is a list box).
Multiselect | The drop down list is always displayed and allows selection of multiple items (the field is a list box).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListDisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentAccess Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentAccess Enumeration

Specifies the access modes to the content of a container.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentAccess
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentAccess
C#
public enum XFAContentAccess : Enum
Delphi
public enum XFAContentAccess = class(Enum)
Managed Extensions for C++
__value public enum XFAContentAccess : public Enum
C++/CLI
public enum class XFAContentAccess : public Enum

Members

Member | Description
NonInteractive | Allows the content to be loaded from the data document, but not updated interactively.
Open | Allow update without restriction.
Protected | The processing application must prevent the user from making any direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate any events.
ReadOnly | The processing application must not allow the user to make direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate a subset of regular events (those that are not related to direct modification of the content).

Remarks

Fields with Protected or ReadOnly access can not be updated from code.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentAccess

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentType Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentType Enumeration

Specifies the available types of content accepted by a XFA value.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentType
C#
public enum XFAContentType : Enum
Delphi
public enum XFAContentType = class(Enum)
Managed Extensions for C++
__value public enum XFAContentType : public Enum
C++/CLI
public enum class XFAContentType : public Enum

Members

Member | Description
Arc | Arc data type
Boolean | Boolean data type.
Date | Date data type.
DateTime | DateTime data type.
Decimal | Decimal data type.
Float | Float data type.
Image | Image data type.
Integer | Integer data type.
Line | Line data type.
Null | No data.
Rectangle | Rectangle data type.
Text | String data type.
Time | Time data type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentVisibility Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentVisibility Enumeration

Specifies the visibility of the content of a container.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentVisibility
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentVisibility
C#
public enum XFAContentVisibility : Enum
Delphi
public enum XFAContentVisibility = class(Enum)
Managed Extensions for C++
__value public enum XFAContentVisibility : public Enum
C++/CLI
public enum class XFAContentVisibility : public Enum

Members

Member | Description
Visible | The container content is visible.
Invisible | The container content is not visible, but it still takes up space.
Hidden | The container content is not visible and it does not take up space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentVisibility

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFADataFormat Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADataFormat Enumeration

Specifies the available formats for data import/export for XFA Forms.

Syntax

Visual Basic (Declaration)
Public Enum XFADataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFADataFormat
C#
public enum XFADataFormat : Enum
Delphi
public enum XFADataFormat = class(Enum)
Managed Extensions for C++
__value public enum XFADataFormat : public Enum
C++/CLI
public enum class XFADataFormat : public Enum

Members

Member | Description
XML | Form data is imported or exported in XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFADataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAImageAspect Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageAspect Enumeration

Specifies the available modes for scaling the image when it is displayed in the image edit field.

Syntax

Visual Basic (Declaration)
Public Enum XFAImageAspect
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAImageAspect
C#
public enum XFAImageAspect : Enum
Delphi
public enum XFAImageAspect = class(Enum)
Managed Extensions for C++
__value public enum XFAImageAspect : public Enum
C++/CLI
public enum class XFAImageAspect : public Enum

Members

Member | Description
Fit | The image is scaled to maximum possible size while keeping the original aspect ratio.
None | The image is scaled to occupy the entire field area.
Actual | The image is not scaled, its original size is used.
Width | The image is scaled proportionally such that its width matches the field width and the original aspect ratio is kept.
Height | The image is scaled proportionally such that its height matches the field height and the original aspect ratio is kept.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageAspect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAImageStorageMode Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageStorageMode Enumeration

Specifies the available modes for storing image content in an image edit field.

Syntax

Visual Basic (Declaration)
Public Enum XFAImageStorageMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAImageStorageMode
C#
public enum XFAImageStorageMode : Enum
Delphi
public enum XFAImageStorageMode = class(Enum)
Managed Extensions for C++
__value public enum XFAImageStorageMode : public Enum
C++/CLI
public enum class XFAImageStorageMode : public Enum

Members

Member | Description
Embed | The image data is stored in the field.
Link | The path to the image file is stored in the field.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageStorageMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Functions Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFFunction | Defines the base class for PDF functions.
PDFFunctions | Defines a collection of functions.
PDFType0Function | Defines a type 0 function.
PDFType2Function | Defines a type 2 function.
PDFType3Function | Defines a type 3 function.
PDFType4Function | Defines a type 4 function.

Enumerations

Enumeration | Description
InterpolationMode | Specifies the available interpolation modes for a type 0 function values.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Functions Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType4Function
O2S.Components.PDF4NET.Functions.PDFFunctions

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFFunction Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

Defines the base class for PDF functions.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFFunction
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
C#
public abstract class PDFFunction : PDFObject
Delphi
public class PDFFunction = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFFunction : public PDFObject
C++/CLI
public ref class PDFFunction abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType4Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType0Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFFunction Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

The following tables list the members exposed by PDFFunction.

Public Constructors

 | Name | Description
Public Constructor | PDFFunction Constructor | Initilizes a new PDFFunction object.
Top

Public Properties

 | Name | Description
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFFunction Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : PDFFunction Constructor

Initilizes a new PDFFunction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction()
C#
public PDFFunction()
Delphi
public PDFFunction();
Managed Extensions for C++
public: PDFFunction();
C++/CLI
public:
PDFFunction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


%%PageItemTitle%% $$Methods$$

PDFFunction Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

For a list of all members of this type, see PDFFunction members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


%%PageItemTitle%% $$Properties$$

PDFFunction Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

For a list of all members of this type, see PDFFunction members.

Public Properties

 | Name | Description
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top

See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Domain Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Domain Property

Gets or sets the domain function domain.

Syntax

Visual Basic (Declaration)
Public Property Domain As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim value() As Single

instance.Domain = value

value = instance.Domain
C#
public float[] Domain {get; set;}
Delphi
public read-write property Domain: array of Single;
Managed Extensions for C++
public: __property float[]* get_Domain();
public: __property void set_Domain(
   float[]* value
);
C++/CLI
public:
property array<float>^ Domain {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function domain.

Remarks

The domain is an array of 2 × m numbers, where m is the number of input values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


%%PageItemTitle%%

Range Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Range Property

Gets or sets the function range.

Syntax

Visual Basic (Declaration)
Public Property Range As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim value() As Single

instance.Range = value

value = instance.Range
C#
public float[] Range {get; set;}
Delphi
public read-write property Range: array of Single;
Managed Extensions for C++
public: __property float[]* get_Range();
public: __property void set_Range(
   float[]* value
);
C++/CLI
public:
property array<float>^ Range {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function range.

Remarks

The rangle is an array of 2 × n numbers, where n is the number of output values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


%%PageItemTitle%%

PDFFunctions Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctions Class

Defines a collection of functions.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFFunctions
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFFunctions : PDFObject
Delphi
public class PDFFunctions = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFFunctions : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFFunctions sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunctions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFFunctions Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctions Class

The following tables list the members exposed by PDFFunctions.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of functions in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets or sets the function at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a function at the end of the collection.
Public Method | Clear | Clear the functions collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts a function at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the function from the collection.
Public Method | RemoveAt | Removes the function at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFFunctions Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Methods$$

PDFFunctions Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctions Class

For a list of all members of this type, see PDFFunctions members.

Public Methods

 | Name | Description
Public Method | Add | Adds a function at the end of the collection.
Public Method | Clear | Clear the functions collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Inserts a function at the given index in the collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the function from the collection.
Public Method | RemoveAt | Removes the function at the given index from the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFFunctions Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Add Method

function
a PDFFunction object to be added to the collection
Adds a function at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal function As PDFFunction _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim function As PDFFunction

instance.Add(function)
C#
public void Add(
   PDFFunction function
)
Delphi
public procedure Add(
    function: PDFFunction
);
Managed Extensions for C++
public: void Add(
   PDFFunction* function
)
C++/CLI
public:
void Add(
   PDFFunction^ function
)

Parameters

function
a PDFFunction object to be added to the collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Clear Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Clear Method

Clear the functions collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

This method removes all functions from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Insert Method

index
the index where to insert the function.
function
a PDFFunction object to be added to the collection
Inserts a function at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal function As PDFFunction _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim index As Integer
Dim function As PDFFunction

instance.Insert(index, function)
C#
public void Insert(
   int index,
   PDFFunction function
)
Delphi
public procedure Insert(
    index: Integer;
    function: PDFFunction
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFFunction* function
)
C++/CLI
public:
void Insert(
   int index,
   PDFFunction^ function
)

Parameters

index
the index where to insert the function.
function
a PDFFunction object to be added to the collection

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of functions in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Remove Method

function
The function to be removed.
Removes the function from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal function As PDFFunction _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim function As PDFFunction

instance.Remove(function)
C#
public void Remove(
   PDFFunction function
)
Delphi
public procedure Remove(
    function: PDFFunction
);
Managed Extensions for C++
public: void Remove(
   PDFFunction* function
)
C++/CLI
public:
void Remove(
   PDFFunction^ function
)

Parameters

function
The function to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : RemoveAt Method

index
the index where to remove the function.
Removes the function at the given index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
the index where to remove the function.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of functions in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%% $$Properties$$

PDFFunctions Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctions Class

For a list of all members of this type, see PDFFunctions members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of functions in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets or sets the function at the specified index (zero based index).
Top

See Also

Reference

PDFFunctions Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Count Property

Gets the number of functions in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunctions Class : Item Property

index
Gets or sets the function at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctions
Dim index As Integer
Dim value As PDFFunction

instance.Item(index) = value

value = instance.Item(index)
C#
public PDFFunction this[
   int index
]; {get; set;}
Delphi
public  this: : PDFFunction;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDFFunction* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ default [int] {
   PDFFunction^ get(int index);
   void set (int index, PDFFunction^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctions Class
PDFFunctions Members


%%PageItemTitle%%

PDFType0Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

Defines a type 0 function.

Syntax

Visual Basic (Declaration)
Public Class PDFType0Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
C#
public class PDFType0Function : PDFFunction
Delphi
public class PDFType0Function = class(PDFFunction)
Managed Extensions for C++
public __gc class PDFType0Function : public PDFFunction
C++/CLI
public ref class PDFType0Function : public PDFFunction

Remarks

Type 0 functions use a sequence of sample values (contained in a stream) to provide an approximation for functions whose domains and ranges are bounded. The samples are organized as an m-dimensional table in which each entry has n components.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType0Function Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

The following tables list the members exposed by PDFType0Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType0Function Constructor | Overloaded. Initilizes a new PDFType0Function object.
Top

Public Properties

 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Size | Gets or sets the number of samples.
Public Property | Stream | Get or sets the stream that stores the sample values.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType0Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : PDFType0Function Constructor

Initilizes a new PDFType0Function object.

Overload List

Overload | Description
PDFType0Function Constructor() | Initilizes a new PDFType0Function object.
PDFType0Function Constructor(Int32[],Int32,Int32,Single[],Single[],Byte[]) | Initializes new PDFType0Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

PDFType0Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor()

Initilizes a new PDFType0Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function()
C#
public PDFType0Function()
Delphi
public PDFType0Function();
Managed Extensions for C++
public: PDFType0Function();
C++/CLI
public:
PDFType0Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


%%PageItemTitle%%

PDFType0Function Constructor(Int32[],Int32,Int32,Single[],Single[],Byte[])
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor(Int32[],Int32,Int32,Single[],Single[],Byte[])

size
bitsPerSample
order
encode
decode
samples
Initializes new PDFType0Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size() As Integer, _
   ByVal bitsPerSample As Integer, _
   ByVal order As Integer, _
   ByVal encode() As Single, _
   ByVal decode() As Single, _
   ByVal samples() As Byte _
)
Visual Basic (Usage) Copy Code
Dim size() As Integer
Dim bitsPerSample As Integer
Dim order As Integer
Dim encode() As Single
Dim decode() As Single
Dim samples() As Byte

Dim instance As PDFType0Function(size, bitsPerSample, order, encode, decode, samples)
C#
public PDFType0Function(
   int[] size,
   int bitsPerSample,
   int order,
   float[] encode,
   float[] decode,
   byte[] samples
)
Delphi
public PDFType0Function(
    size: Integerarray of;
    bitsPerSample: Integer;
    order: Integer;
    encode: Singlearray of;
    decode: Singlearray of;
    samples: Bytearray of
);
Managed Extensions for C++
public: PDFType0Function(
   int[]* size,
   int bitsPerSample,
   int order,
   float[]* encode,
   float[]* decode,
   byte[]* samples
)
C++/CLI
public:
PDFType0Function(
   array<int>^ size,
   int bitsPerSample,
   int order,
   array<float>^ encode,
   array<float>^ decode,
   array<byte>^ samples
)

Parameters

size
bitsPerSample
order
encode
decode
samples

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFType0Function Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

For a list of all members of this type, see PDFType0Function members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%% $$Properties$$

PDFType0Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

For a list of all members of this type, see PDFType0Function members.

Public Properties

 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Size | Gets or sets the number of samples.
Public Property | Stream | Get or sets the stream that stores the sample values.
Top

See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

BitsPerSample Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : BitsPerSample Property

Gets or sets the function's bits per sample.

Syntax

Visual Basic (Declaration)
Public Property BitsPerSample As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value As Integer

instance.BitsPerSample = value

value = instance.BitsPerSample
C#
public int BitsPerSample {get; set;}
Delphi
public read-write property BitsPerSample: Integer;
Managed Extensions for C++
public: __property int get_BitsPerSample();
public: __property void set_BitsPerSample(
   int value
);
C++/CLI
public:
property int BitsPerSample {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the function's bits per sample.

Remarks

This property is the number of bits used to represent each sample. (If the function has multiple output values, each one occupies BitsPerSample bits.) Valid values are 1, 2, 4, 8, 12, 16, 24, and 32.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

Decode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Decode Property

Gets or sets the function's decoding array.

Syntax

Visual Basic (Declaration)
Public Property Decode As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Single

instance.Decode = value

value = instance.Decode
C#
public float[] Decode {get; set;}
Delphi
public read-write property Decode: array of Single;
Managed Extensions for C++
public: __property float[]* get_Decode();
public: __property void set_Decode(
   float[]* value
);
C++/CLI
public:
property array<float>^ Decode {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function's decoding array.

Remarks

The decode is an array of 2 × n numbers specifying the linear mapping of sample values into the range appropriate for the function’s output values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

Encode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Encode Property

Gets or sets the function's encoding array.

Syntax

Visual Basic (Declaration)
Public Property Encode As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Single

instance.Encode = value

value = instance.Encode
C#
public float[] Encode {get; set;}
Delphi
public read-write property Encode: array of Single;
Managed Extensions for C++
public: __property float[]* get_Encode();
public: __property void set_Encode(
   float[]* value
);
C++/CLI
public:
property array<float>^ Encode {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function's encoding array.

Remarks

The encode is an array of 2 × m numbers specifying the linear mapping of input values into the domain of the function’s sample table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

InterpolationMode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : InterpolationMode Property

Gets or sets the function's interpolation mode.

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value As InterpolationMode

instance.InterpolationMode = value

value = instance.InterpolationMode
C#
public InterpolationMode InterpolationMode {get; set;}
Delphi
public read-write property InterpolationMode: InterpolationMode;
Managed Extensions for C++
public: __property InterpolationMode get_InterpolationMode();
public: __property void set_InterpolationMode(
   InterpolationMode value
);
C++/CLI
public:
property InterpolationMode InterpolationMode {
   InterpolationMode get();
   void set (InterpolationMode value);
}

Return Value

A InterpolationMode enumeration member specifying the function's interpolation mode.

Remarks

This property specifies how the sample values are interpolated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Size Property

Gets or sets the number of samples.

Syntax

Visual Basic (Declaration)
Public Property Size As Integer()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Integer

instance.Size = value

value = instance.Size
C#
public int[] Size {get; set;}
Delphi
public read-write property Size: array of Integer;
Managed Extensions for C++
public: __property int[]* get_Size();
public: __property void set_Size(
   int[]* value
);
C++/CLI
public:
property array<int>^ Size {
   array<int>^ get();
   void set (intarray<value>^ value);
}

Return Value

An int array specifying the number of samples.

Remarks

An array of m positive integers specifying the number of samples in each input dimension of the sample table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

Stream Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Stream Property

Get or sets the stream that stores the sample values.

Syntax

Visual Basic (Declaration)
Public Property Stream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Byte

instance.Stream = value

value = instance.Stream
C#
public byte[] Stream {get; set;}
Delphi
public read-write property Stream: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that stores the sample values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

PDFType2Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

Defines a type 2 function.

Syntax

Visual Basic (Declaration)
Public Class PDFType2Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
C#
public class PDFType2Function : PDFFunction
Delphi
public class PDFType2Function = class(PDFFunction)
Managed Extensions for C++
public __gc class PDFType2Function : public PDFFunction
C++/CLI
public ref class PDFType2Function : public PDFFunction

Remarks

Type 2 functions define an exponential interpolation of one input value and n output values.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType2Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType2Function Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

The following tables list the members exposed by PDFType2Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType2Function Constructor | Overloaded. Initilizes a new PDFType2Function object.
Top

Public Properties

 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType2Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : PDFType2Function Constructor

Initilizes a new PDFType2Function object.

Overload List

Overload | Description
PDFType2Function Constructor() | Initilizes a new PDFType2Function object.
PDFType2Function Constructor(Single[],Single[],Int32) | Initializes new PDFType2Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

PDFType2Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor()

Initilizes a new PDFType2Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function()
C#
public PDFType2Function()
Delphi
public PDFType2Function();
Managed Extensions for C++
public: PDFType2Function();
C++/CLI
public:
PDFType2Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


%%PageItemTitle%%

PDFType2Function Constructor(Single[],Single[],Int32)
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor(Single[],Single[],Int32)

c0
c1
n
Initializes new PDFType2Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal c0() As Single, _
   ByVal c1() As Single, _
   ByVal n As Integer _
)
Visual Basic (Usage) Copy Code
Dim c0() As Single
Dim c1() As Single
Dim n As Integer

Dim instance As PDFType2Function(c0, c1, n)
C#
public PDFType2Function(
   float[] c0,
   float[] c1,
   int n
)
Delphi
public PDFType2Function(
    c0: Singlearray of;
    c1: Singlearray of;
    n: Integer
);
Managed Extensions for C++
public: PDFType2Function(
   float[]* c0,
   float[]* c1,
   int n
)
C++/CLI
public:
PDFType2Function(
   array<float>^ c0,
   array<float>^ c1,
   int n
)

Parameters

c0
c1
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFType2Function Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

For a list of all members of this type, see PDFType2Function members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%% $$Properties$$

PDFType2Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

For a list of all members of this type, see PDFType2Function members.

Public Properties

 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

C0 Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C0 Property

Gets or sets the function result when input value is 0.

Syntax

Visual Basic (Declaration)
Public Property C0 As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value() As Single

instance.C0 = value

value = instance.C0
C#
public float[] C0 {get; set;}
Delphi
public read-write property C0: array of Single;
Managed Extensions for C++
public: __property float[]* get_C0();
public: __property void set_C0(
   float[]* value
);
C++/CLI
public:
property array<float>^ C0 {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function result when input value is 0.

Remarks

This property is an array of n numbers defining the function result when the input value is 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

C1 Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C1 Property

Gets or sets the function result when input value is 1.

Syntax

Visual Basic (Declaration)
Public Property C1 As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value() As Single

instance.C1 = value

value = instance.C1
C#
public float[] C1 {get; set;}
Delphi
public read-write property C1: array of Single;
Managed Extensions for C++
public: __property float[]* get_C1();
public: __property void set_C1(
   float[]* value
);
C++/CLI
public:
property array<float>^ C1 {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function result when input value is 1.

Remarks

This property is an array of n numbers defining the function result when the input value is 1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

Exponent Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : Exponent Property

Gets or sets the interpolation exponent.

Syntax

Visual Basic (Declaration)
Public Property Exponent As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value As Single

instance.Exponent = value

value = instance.Exponent
C#
public float Exponent {get; set;}
Delphi
public read-write property Exponent: Single;
Managed Extensions for C++
public: __property float get_Exponent();
public: __property void set_Exponent(
   float value
);
C++/CLI
public:
property float Exponent {
   float get();
   void set (float value);
}

Return Value

A float value specifying the function's interpolation exponent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

PDFType3Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

Defines a type 3 function.

Syntax

Visual Basic (Declaration)
Public Class PDFType3Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
C#
public class PDFType3Function : PDFFunction
Delphi
public class PDFType3Function = class(PDFFunction)
Managed Extensions for C++
public __gc class PDFType3Function : public PDFFunction
C++/CLI
public ref class PDFType3Function : public PDFFunction

Remarks

Type 3 functions define a stitching of the subdomains of several 1-input functions to produce a single new 1-input function.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType3Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType3Function Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

The following tables list the members exposed by PDFType3Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType3Function Constructor | Initilizes a new PDFType3Function object.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType3Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : PDFType3Function Constructor

Initilizes a new PDFType3Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function()
C#
public PDFType3Function()
Delphi
public PDFType3Function();
Managed Extensions for C++
public: PDFType3Function();
C++/CLI
public:
PDFType3Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%% $$Methods$$

PDFType3Function Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

For a list of all members of this type, see PDFType3Function members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%% $$Properties$$

PDFType3Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

For a list of all members of this type, see PDFType3Function members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Bounds Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Bounds Property

Gets or sets the intervals to which the functions apply.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value() As Single

instance.Bounds = value

value = instance.Bounds
C#
public float[] Bounds {get; set;}
Delphi
public read-write property Bounds: array of Single;
Managed Extensions for C++
public: __property float[]* get_Bounds();
public: __property void set_Bounds(
   float[]* value
);
C++/CLI
public:
property array<float>^ Bounds {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the intervals to which the functions apply.

Remarks

This property is an An array of k - 1 numbers that, in combination with PDFFunction.Domain, define the intervals to which each function from the Functions list applies. Bounds elements must be in order of increasing value, and each value must be within the domain defined by PDFFunction.Domain.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%%

Encode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Encode Property

Gets or sets the function's encoding array.

Syntax

Visual Basic (Declaration)
Public Property Encode As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value() As Single

instance.Encode = value

value = instance.Encode
C#
public float[] Encode {get; set;}
Delphi
public read-write property Encode: array of Single;
Managed Extensions for C++
public: __property float[]* get_Encode();
public: __property void set_Encode(
   float[]* value
);
C++/CLI
public:
property array<float>^ Encode {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

A float array specifying the function's encoding array.

Remarks

The encode is an array of 2 × k numbers that, taken in pairs, map each subset of the domain defined by PDFFunction.Domain and the Bounds array to the domain of the corresponding function.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%%

Functions Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Functions Property

Gets the list of functions that make up this function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Functions As PDFFunctions
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value As PDFFunctions

value = instance.Functions
C#
public PDFFunctions Functions {get;}
Delphi
public read-only property Functions: PDFFunctions;
Managed Extensions for C++
public: __property PDFFunctions* get_Functions();
C++/CLI
public:
property PDFFunctions^ Functions {
   PDFFunctions^ get();
}

Return Value

A PDFFunctions collection specifying the list of functions that make up this function.

Remarks

An array of k 1-input functions making up the stitching function. The output dimensionality of all functions must be the same, and compatible with the value of PDFFunction.Range if PDFFunction.Range is present.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%%

PDFType4Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

Defines a type 4 function.

Syntax

Visual Basic (Declaration)
Public Class PDFType4Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function
C#
public class PDFType4Function : PDFFunction
Delphi
public class PDFType4Function = class(PDFFunction)
Managed Extensions for C++
public __gc class PDFType4Function : public PDFFunction
C++/CLI
public ref class PDFType4Function : public PDFFunction

Remarks

A type 4 function, also called a PostScript calculator function, is represented as a stream containing code written in a small subset of the PostScript language.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType4Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType4Function Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

The following tables list the members exposed by PDFType4Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType4Function Constructor | Overloaded. Initilizes a new PDFType4Function object.
Top

Public Properties

 | Name | Description
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType4Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : PDFType4Function Constructor

Initilizes a new PDFType4Function object.

Overload List

Overload | Description
PDFType4Function Constructor() | Initilizes a new PDFType4Function object.
PDFType4Function Constructor(Byte[]) | Initializes new PDFType4Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members


%%PageItemTitle%%

PDFType4Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor()

Initilizes a new PDFType4Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function()
C#
public PDFType4Function()
Delphi
public PDFType4Function();
Managed Extensions for C++
public: PDFType4Function();
C++/CLI
public:
PDFType4Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


%%PageItemTitle%%

PDFType4Function Constructor(Byte[])
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor(Byte[])

code
Postscript code for the function.
Initializes new PDFType4Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code() As Byte _
)
Visual Basic (Usage) Copy Code
Dim code() As Byte

Dim instance As PDFType4Function(code)
C#
public PDFType4Function(
   byte[] code
)
Delphi
public PDFType4Function(
    code: Bytearray of
);
Managed Extensions for C++
public: PDFType4Function(
   byte[]* code
)
C++/CLI
public:
PDFType4Function(
   array<byte>^ code
)

Parameters

code
Postscript code for the function.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFType4Function Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

For a list of all members of this type, see PDFType4Function members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Top

See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members


%%PageItemTitle%% $$Properties$$

PDFType4Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

For a list of all members of this type, see PDFType4Function members.

Public Properties

 | Name | Description
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top

See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

Stream Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : Stream Property

Get or sets the stream that represents the function's code.

Syntax

Visual Basic (Declaration)
Public Property Stream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function
Dim value() As Byte

instance.Stream = value

value = instance.Stream
C#
public byte[] Stream {get; set;}
Delphi
public read-write property Stream: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that represents the function's code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members


%%PageItemTitle%%

InterpolationMode Enumeration
[image]
O2S.Components.PDF4NET.Functions Namespace : InterpolationMode Enumeration

Specifies the available interpolation modes for a type 0 function values.

Syntax

Visual Basic (Declaration)
Public Enum InterpolationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As InterpolationMode
C#
public enum InterpolationMode : Enum
Delphi
public enum InterpolationMode = class(Enum)
Managed Extensions for C++
__value public enum InterpolationMode : public Enum
C++/CLI
public enum class InterpolationMode : public Enum

Members

Member | Description
Linear | Linear intepolation.
CubicSpline | Cubic spline interpolation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Functions.InterpolationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Functions Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFBaseColor | Base class for all PDF colors.
PDFBrush | Defines an object used to fill a closed shape with a single color. Supported by Compact .NET Edition.
PDFColor | Represents an ARGB color. Supported by Compact .NET Edition.
PDFCustomBrush | Defines a custom brush for filling closed shapes.
PDFFont | Defines a particular format for text, including font face and size. Supported by Compact .NET Edition.
PDFGradientBrush | Defines a gradient brush for filling closed shapes.
PDFGraphic | This class is the based class for all the graphic objects within the PDF file Supported by Compact .NET Edition.
PDFHatchBrush | Defines a hatch brush for filling closed shapes.
PDFHorizontalGradientBrush | Defines a horizontal gradient brush for filling closed shapes.
PDFLayer | Defines a layer on a page's canvas.
PDFLayers | Defines a collection of layers.
PDFPen | Defines an object used to draw lines and curves. This class cannot be inherited. Supported by Compact .NET Edition.
PDFPoint | Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane. Supported by Compact .NET Edition.
PDFVerticalGradientBrush | Defines a vertical gradient brush for filling closed shapes.

Enumerations

Enumeration | Description
DashStyle | Specifies the style of dashed lines drawn with a Pen object. Supported by Compact .NET Edition.
FontFace | Specifies the available fonts for drawing text on a page Supported by Compact .NET Edition.
HatchType | Specifies the available types for hatch brushes.
LineCap | Specifies the available cap styles with which a Pen object can begin or end a line. Supported by Compact .NET Edition.
LineJoin | Specifies how to join consecutive line or curve segments Supported by Compact .NET Edition.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush
O2S.Components.PDF4NET.Graphics.PDFPen
O2S.Components.PDF4NET.Graphics.PDFPoint
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.PDFLayer
O2S.Components.PDF4NET.Graphics.PDFLayers

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFBaseColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBaseColor Class

Base class for all PDF colors.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseColor
C#
public abstract class PDFBaseColor
Delphi
public class PDFBaseColor abstract;
Managed Extensions for C++
public __gc abstract class PDFBaseColor
C++/CLI
public ref class PDFBaseColor abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFBaseColor Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBaseColor Class

The following tables list the members exposed by PDFBaseColor.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color.
Top

See Also

Reference

PDFBaseColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFBaseColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBaseColor Class

For a list of all members of this type, see PDFBaseColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color.
Top

See Also

Reference

PDFBaseColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBaseColor Class : Clone Method

Clones the current color.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseColor
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Return Value

A new color object that matches this objsect.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseColor Class
PDFBaseColor Members


%%PageItemTitle%%

PDFBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

Defines an object used to fill a closed shape with a single color.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush
C#
public class PDFBrush
Delphi
public class PDFBrush
Managed Extensions for C++
public __gc class PDFBrush
C++/CLI
public ref class PDFBrush

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

The following tables list the members exposed by PDFBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFBrush Constructor | Overloaded. Initializes a new PDFBrush object of White color.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush.
Top

See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : PDFBrush Constructor

Initializes a new PDFBrush object of White color.

Overload List

Overload | Description
PDFBrush Constructor() | Initializes a new PDFBrush object of White color.
PDFBrush Constructor(PDFBaseColor) | Initializes a new PDFBrush object of the specified color. Supported by Compact .NET Edition.
PDFBrush Constructor(PDFBrush) | Initializes a new PDFBrush object based on the given brush. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members


%%PageItemTitle%%

PDFBrush Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor()

Initializes a new PDFBrush object of White color.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush()
C#
public PDFBrush()
Delphi
public PDFBrush();
Managed Extensions for C++
public: PDFBrush();
C++/CLI
public:
PDFBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%%

PDFBrush Constructor(PDFBaseColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFBaseColor)

color
a PDFColor object that represents the color of this brush
Initializes a new PDFBrush object of the specified color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFBaseColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFBaseColor

Dim instance As PDFBrush(color)
C#
public PDFBrush(
   PDFBaseColor color
)
Delphi
public PDFBrush(
    color: PDFBaseColor
);
Managed Extensions for C++
public: PDFBrush(
   PDFBaseColor* color
)
C++/CLI
public:
PDFBrush(
   PDFBaseColor^ color
)

Parameters

color
a PDFColor object that represents the color of this brush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%%

PDFBrush Constructor(PDFBrush)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFBrush)

brush
Initializes a new PDFBrush object based on the given brush.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal brush As PDFBrush _
)
Visual Basic (Usage) Copy Code
Dim brush As PDFBrush

Dim instance As PDFBrush(brush)
C#
public PDFBrush(
   PDFBrush brush
)
Delphi
public PDFBrush(
    brush: PDFBrush
);
Managed Extensions for C++
public: PDFBrush(
   PDFBrush* brush
)
C++/CLI
public:
PDFBrush(
   PDFBrush^ brush
)

Parameters

brush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

For a list of all members of this type, see PDFBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush.
Top

See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : Color Property

Gets or sets the color of this Brush object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush
Dim value As PDFBaseColor

instance.Color = value

value = instance.Color
C#
public PDFBaseColor Color {get; set;}
Delphi
public read-write property Color: PDFBaseColor;
Managed Extensions for C++
public: __property PDFBaseColor* get_Color();
public: __property void set_Color(
   PDFBaseColor* value
);
C++/CLI
public:
property PDFBaseColor^ Color {
   PDFBaseColor^ get();
   void set (PDFBaseColor^ value);
}

Return Value

The color of this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members


%%PageItemTitle%%

UseOverprint Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : UseOverprint Property

Gets or sets a value indicating whether overprint is enabled before applying the brush.

Syntax

Visual Basic (Declaration)
Public Property UseOverprint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush
Dim value As Boolean

instance.UseOverprint = value

value = instance.UseOverprint
C#
public bool UseOverprint {get; set;}
Delphi
public read-write property UseOverprint: Boolean;
Managed Extensions for C++
public: __property bool get_UseOverprint();
public: __property void set_UseOverprint(
   bool value
);
C++/CLI
public:
property bool UseOverprint {
   bool get();
   void set (bool value);
}

Return Value

True if overprint is enabled. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members


%%PageItemTitle%%

PDFColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

Represents an ARGB color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFColor
   Inherits PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
C#
public class PDFColor : PDFBaseColor
Delphi
public class PDFColor = class(PDFBaseColor)
Managed Extensions for C++
public __gc class PDFColor : public PDFBaseColor
C++/CLI
public ref class PDFColor : public PDFBaseColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.PDFColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

The following tables list the members exposed by PDFColor.

Public Constructors

 | Name | Description
Public Constructor | PDFColor Constructor | Overloaded. Initializes a new PDFColor object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of this color. Supported by Compact .NET Edition.
Public Property | C | Gets or sets the cyan component of this color. Supported by Compact .NET Edition.
Public Property | G | Gets or sets the green component of this color. Supported by Compact .NET Edition.
Public Property | Gray | Gets or sets the grayscale value of this color. Supported by Compact .NET Edition.
Public Property | K | Gets or sets the black component of this color. Supported by Compact .NET Edition.
Public Property | M | Gets or sets the magenta component of this color. Supported by Compact .NET Edition.
Public Property | R | Gets or sets the red component of this color. Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the yellow component of this color. Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from PDFBaseColor)
Public Method | Equals | Overridden. Verifies if two color objects represent the same color.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : PDFColor Constructor

Initializes a new PDFColor object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFColor Constructor() | Initializes a new PDFColor object. Supported by Compact .NET Edition.
PDFColor Constructor(Byte,Byte,Byte) | Initializes a new PDFColor object. Supported by Compact .NET Edition.
PDFColor Constructor(Color) | Initializes a new PDFColor object with the specified color Supported by Compact .NET Edition.
PDFColor Constructor(PDFColor) | Initializes a new PDFColor object from another color.
PDFColor Constructor(Single) | Initializes a new PDFColor object. Supported by Compact .NET Edition.
PDFColor Constructor(Single,Single,Single,Single) | Initializes a new PDFColor object. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

PDFColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor()

Initializes a new PDFColor object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFColor()
C#
public PDFColor()
Delphi
public PDFColor();
Managed Extensions for C++
public: PDFColor();
C++/CLI
public:
PDFColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFColor Constructor(Byte,Byte,Byte)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor(Byte,Byte,Byte)

red
the red component of this color object
green
the red component of this color object
blue
the red component of this color object
Initializes a new PDFColor object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal red As Byte, _
   ByVal green As Byte, _
   ByVal blue As Byte _
)
Visual Basic (Usage) Copy Code
Dim red As Byte
Dim green As Byte
Dim blue As Byte

Dim instance As PDFColor(red, green, blue)
C#
public PDFColor(
   byte red,
   byte green,
   byte blue
)
Delphi
public PDFColor(
    red: Byte;
    green: Byte;
    blue: Byte
);
Managed Extensions for C++
public: PDFColor(
   byte red,
   byte green,
   byte blue
)
C++/CLI
public:
PDFColor(
   byte red,
   byte green,
   byte blue
)

Parameters

red
the red component of this color object
green
the red component of this color object
blue
the red component of this color object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFColor Constructor(Color)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor(Color)

color
a Color structure specifying the color
Initializes a new PDFColor object with the specified color

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As PDFColor(color)
C#
public PDFColor(
   Color color
)
Delphi
public PDFColor(
    color: Color
);
Managed Extensions for C++
public: PDFColor(
   Color color
)
C++/CLI
public:
PDFColor(
   Color color
)

Parameters

color
a Color structure specifying the color

Remarks

This constructor initializes the RGB representation of the color. The CMYK representation is calculated based on RGB representation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFColor Constructor(PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor(PDFColor)

color
Source color.
Initializes a new PDFColor object from another color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFColor

Dim instance As PDFColor(color)
C#
public PDFColor(
   PDFColor color
)
Delphi
public PDFColor(
    color: PDFColor
);
Managed Extensions for C++
public: PDFColor(
   PDFColor* color
)
C++/CLI
public:
PDFColor(
   PDFColor^ color
)

Parameters

color
Source color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFColor Constructor(Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor(Single)

gray
the grayscale value of this color object
Initializes a new PDFColor object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gray As Single _
)
Visual Basic (Usage) Copy Code
Dim gray As Single

Dim instance As PDFColor(gray)
C#
public PDFColor(
   float gray
)
Delphi
public PDFColor(
    gray: Single
);
Managed Extensions for C++
public: PDFColor(
   float gray
)
C++/CLI
public:
PDFColor(
   float gray
)

Parameters

gray
the grayscale value of this color object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFColor Constructor(Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class > PDFColor Constructor : PDFColor Constructor(Single,Single,Single,Single)

cyan
the cyan component of this color object
magenta
the magenta component of this color object
yellow
the yellow component of this color object
black
the black component of this color object
Initializes a new PDFColor object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cyan As Single, _
   ByVal magenta As Single, _
   ByVal yellow As Single, _
   ByVal black As Single _
)
Visual Basic (Usage) Copy Code
Dim cyan As Single
Dim magenta As Single
Dim yellow As Single
Dim black As Single

Dim instance As PDFColor(cyan, magenta, yellow, black)
C#
public PDFColor(
   float cyan,
   float magenta,
   float yellow,
   float black
)
Delphi
public PDFColor(
    cyan: Single;
    magenta: Single;
    yellow: Single;
    black: Single
);
Managed Extensions for C++
public: PDFColor(
   float cyan,
   float magenta,
   float yellow,
   float black
)
C++/CLI
public:
PDFColor(
   float cyan,
   float magenta,
   float yellow,
   float black
)

Parameters

cyan
the cyan component of this color object
magenta
the magenta component of this color object
yellow
the yellow component of this color object
black
the black component of this color object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from PDFBaseColor)
Public Method | Equals | Overridden. Verifies if two color objects represent the same color.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Equals Method

obj
The object to test.
Verifies if two color objects represent the same color.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The object to test.

Return Value

True if both objects represent the same color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hash code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

This object represented as string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%% $$Properties$$

PDFColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of this color. Supported by Compact .NET Edition.
Public Property | C | Gets or sets the cyan component of this color. Supported by Compact .NET Edition.
Public Property | G | Gets or sets the green component of this color. Supported by Compact .NET Edition.
Public Property | Gray | Gets or sets the grayscale value of this color. Supported by Compact .NET Edition.
Public Property | K | Gets or sets the black component of this color. Supported by Compact .NET Edition.
Public Property | M | Gets or sets the magenta component of this color. Supported by Compact .NET Edition.
Public Property | R | Gets or sets the red component of this color. Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the yellow component of this color. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

B Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : B Property

Gets or sets the blue component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property B As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Byte

instance.B = value

value = instance.B
C#
public byte B {get; set;}
Delphi
public read-write property B: Byte;
Managed Extensions for C++
public: __property byte get_B();
public: __property void set_B(
   byte value
);
C++/CLI
public:
property byte B {
   byte get();
   void set (byte value);
}

Return Value

a byte value that represents the blue component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.RGB.

When setting this property, the CMYK representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

C Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : C Property

Gets or sets the cyan component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property C As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Single

instance.C = value

value = instance.C
C#
public float C {get; set;}
Delphi
public read-write property C: Single;
Managed Extensions for C++
public: __property float get_C();
public: __property void set_C(
   float value
);
C++/CLI
public:
property float C {
   float get();
   void set (float value);
}

Return Value

a float value that represents the cyan component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.CMYK. The value of this property can vary from 0.0 to 1.0.

When setting this property, the RGB representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

G Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : G Property

Gets or sets the green component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property G As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Byte

instance.G = value

value = instance.G
C#
public byte G {get; set;}
Delphi
public read-write property G: Byte;
Managed Extensions for C++
public: __property byte get_G();
public: __property void set_G(
   byte value
);
C++/CLI
public:
property byte G {
   byte get();
   void set (byte value);
}

Return Value

a byte value that represents the green component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.RGB.

When setting this property, the CMYK representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

Gray Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Gray Property

Gets or sets the grayscale value of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Gray As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Single

instance.Gray = value

value = instance.Gray
C#
public float Gray {get; set;}
Delphi
public read-write property Gray: Single;
Managed Extensions for C++
public: __property float get_Gray();
public: __property void set_Gray(
   float value
);
C++/CLI
public:
property float Gray {
   float get();
   void set (float value);
}

Return Value

a float value that represents the grayscale value of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.Grayscale. The value of this property can vary from 0.0 to 1.0.

When setting this property, the RGB and CMYK representations are updated automatically.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

K Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : K Property

Gets or sets the black component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property K As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Single

instance.K = value

value = instance.K
C#
public float K {get; set;}
Delphi
public read-write property K: Single;
Managed Extensions for C++
public: __property float get_K();
public: __property void set_K(
   float value
);
C++/CLI
public:
property float K {
   float get();
   void set (float value);
}

Return Value

a float value that represents the black component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.CMYK. The value of this property can vary from 0.0 to 1.0.

When setting this property, the RGB representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

M Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : M Property

Gets or sets the magenta component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property M As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Single

instance.M = value

value = instance.M
C#
public float M {get; set;}
Delphi
public read-write property M: Single;
Managed Extensions for C++
public: __property float get_M();
public: __property void set_M(
   float value
);
C++/CLI
public:
property float M {
   float get();
   void set (float value);
}

Return Value

a float value that represents the magenta component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.CMYK. The value of this property can vary from 0.0 to 1.0.

When setting this property, the RGB representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

R Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : R Property

Gets or sets the red component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property R As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Byte

instance.R = value

value = instance.R
C#
public byte R {get; set;}
Delphi
public read-write property R: Byte;
Managed Extensions for C++
public: __property byte get_R();
public: __property void set_R(
   byte value
);
C++/CLI
public:
property byte R {
   byte get();
   void set (byte value);
}

Return Value

a byte value that represents the red component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.RGB.

When setting this property, the CMYK representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Y Property

Gets or sets the yellow component of this color.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value that represents the yellow component of this color.

Remarks

The value of this property is used when the ColorSpace property of the document is set to ColorSpace.CMYK. The value of this property can vary from 0.0 to 1.0.

When setting this property, the RGB representation is updated automatically. The gray representation is not changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

PDFCustomBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCustomBrush Class

Defines a custom brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFCustomBrush
   Inherits PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomBrush
C#
public abstract class PDFCustomBrush : PDFBrush
Delphi
public class PDFCustomBrush = class(PDFBrush)abstract;
Managed Extensions for C++
public __gc abstract class PDFCustomBrush : public PDFBrush
C++/CLI
public ref class PDFCustomBrush abstract : public PDFBrush

Remarks

This is the base class for all custom brushes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush
O2S.Components.PDF4NET.Graphics.PDFGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCustomBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCustomBrush Class

The following tables list the members exposed by PDFCustomBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFCustomBrush Constructor | Initializes a new PDFCustomBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFCustomBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCustomBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCustomBrush Class : PDFCustomBrush Constructor

Initializes a new PDFCustomBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomBrush()
C#
public PDFCustomBrush()
Delphi
public PDFCustomBrush();
Managed Extensions for C++
public: PDFCustomBrush();
C++/CLI
public:
PDFCustomBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomBrush Class
PDFCustomBrush Members


%%PageItemTitle%%

PDFFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFFont Class

Defines a particular format for text, including font face and size.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFont
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
C#
public class PDFFont : PDFObject
Delphi
public class PDFFont = class(PDFObject)
Managed Extensions for C++
public __gc class PDFFont : public PDFObject
C++/CLI
public ref class PDFFont : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFFont Class

The following tables list the members exposed by PDFFont.

Public Constructors

 | Name | Description
Public Constructor | PDFFont Constructor | Overloaded. Initializes a new PDFFont object Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. Supported by Compact .NET Edition.
Public Property | FontFace | Gets or sets the font face Supported by Compact .NET Edition.
Public Property | Italic | Gets or sets whether the font object is italic or not. Supported by Compact .NET Edition.
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition.
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition.
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition.
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition.
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFFont Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : PDFFont Constructor

Initializes a new PDFFont object

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFFont Constructor() | Initializes a new PDFFont object Supported by Compact .NET Edition.
PDFFont Constructor(FontFace,Single) | Initializes a new PDFFont object of specified FontFace and size. Supported by Compact .NET Edition.
PDFFont Constructor(PDFFont) | Initializes a new PDFFont object based on an existing font. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFFont Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor()

Initializes a new PDFFont object

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFont()
C#
public PDFFont()
Delphi
public PDFFont();
Managed Extensions for C++
public: PDFFont();
C++/CLI
public:
PDFFont();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(FontFace,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(FontFace,Single)

fontFace
a FontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Initializes a new PDFFont object of specified FontFace and size.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fontFace As FontFace, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim fontFace As FontFace
Dim size As Single

Dim instance As PDFFont(fontFace, size)
C#
public PDFFont(
   FontFace fontFace,
   float size
)
Delphi
public PDFFont(
    fontFace: FontFace;
    size: Single
);
Managed Extensions for C++
public: PDFFont(
   FontFace fontFace,
   float size
)
C++/CLI
public:
PDFFont(
   FontFace fontFace,
   float size
)

Parameters

fontFace
a FontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(PDFFont)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFont)

font
a PDFFont object to be copied in the new font.
Initializes a new PDFFont object based on an existing font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As PDFFont _
)
Visual Basic (Usage) Copy Code
Dim font As PDFFont

Dim instance As PDFFont(font)
C#
public PDFFont(
   PDFFont font
)
Delphi
public PDFFont(
    font: PDFFont
);
Managed Extensions for C++
public: PDFFont(
   PDFFont* font
)
C++/CLI
public:
PDFFont(
   PDFFont^ font
)

Parameters

font
a PDFFont object to be copied in the new font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition.
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim charCode As Char
Dim value As Single

value = instance.GetCharWidth(charCode)
C#
public virtual float GetCharWidth(
   char charCode
)
Delphi
public function GetCharWidth(
    charCode: Char
): Single; virtual;
Managed Extensions for C++
public: virtual float GetCharWidth(
   char charCode
)
C++/CLI
public:
virtual float GetCharWidth(
   char charCode
)

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

MeasureString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : MeasureString Method

text
The string to measure
Measures the specified string when drawn with this font object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Overridable Function MeasureString( _
   ByVal text As String _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim text As String
Dim value As Single

value = instance.MeasureString(text)
C#
public virtual float MeasureString(
   string text
)
Delphi
public function MeasureString(
    text: String
): Single; virtual;
Managed Extensions for C++
public: virtual float MeasureString(
   string* text
)
C++/CLI
public:
virtual float MeasureString(
   String^ text
)

Parameters

text
The string to measure

Return Value

This method returns a float value that represents the size, in points, of the string specified by the text parameter as drawn with this font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%% $$Properties$$

PDFFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. Supported by Compact .NET Edition.
Public Property | FontFace | Gets or sets the font face Supported by Compact .NET Edition.
Public Property | Italic | Gets or sets whether the font object is italic or not. Supported by Compact .NET Edition.
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition.
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition.
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition.
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Bold Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Bold Property

Gets or sets whether the font object is bold or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Overridable Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public virtual bool Bold {get; set;}
Delphi
public read-write property Bold: Boolean; virtual;
Managed Extensions for C++
public: __property virtual bool get_Bold();
public: __property virtual void set_Bold(
   bool value
);
C++/CLI
public:
virtual property bool Bold {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

FontFace Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : FontFace Property

Gets or sets the font face

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FontFace As FontFace
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As FontFace

instance.FontFace = value

value = instance.FontFace
C#
public FontFace FontFace {get; set;}
Delphi
public read-write property FontFace: FontFace;
Managed Extensions for C++
public: __property FontFace get_FontFace();
public: __property void set_FontFace(
   FontFace value
);
C++/CLI
public:
property FontFace FontFace {
   FontFace get();
   void set (FontFace value);
}

Return Value

a FontFace enumeration member specifying the font face

Remarks

When creating a PDFFont object using the default constructor, the default value of this property is set to FontFace.Helvetica

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Italic Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Italic Property

Gets or sets whether the font object is italic or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Overridable Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public virtual bool Italic {get; set;}
Delphi
public read-write property Italic: Boolean; virtual;
Managed Extensions for C++
public: __property virtual bool get_Italic();
public: __property virtual void set_Italic(
   bool value
);
C++/CLI
public:
virtual property bool Italic {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Metrics Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Metrics Property

Gets the metrics of this font object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metrics As PDFFontMetrics
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As PDFFontMetrics

value = instance.Metrics
C#
public PDFFontMetrics Metrics {get;}
Delphi
public read-only property Metrics: PDFFontMetrics;
Managed Extensions for C++
public: __property PDFFontMetrics* get_Metrics();
C++/CLI
public:
property PDFFontMetrics^ Metrics {
   PDFFontMetrics^ get();
}

Return Value

A PDFFontMetrics object specifying the metrics of this font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Overline Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Overline Property

Gets or sets whether the font object is overline or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Overline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Overline = value

value = instance.Overline
C#
public bool Overline {get; set;}
Delphi
public read-write property Overline: Boolean;
Managed Extensions for C++
public: __property bool get_Overline();
public: __property void set_Overline(
   bool value
);
C++/CLI
public:
property bool Overline {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this PDFFont object is overline; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Size Property

Gets or sets the font size.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Size As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Single

instance.Size = value

value = instance.Size
C#
public float Size {get; set;}
Delphi
public read-write property Size: Single;
Managed Extensions for C++
public: __property float get_Size();
public: __property void set_Size(
   float value
);
C++/CLI
public:
property float Size {
   float get();
   void set (float value);
}

Return Value

a float value specifyig the size of the font in points (1/72 inches)

Remarks

When creating a PDFFont object using the default constructor, the default value of this property is set to 10 points.

The size of a font is always given in points, it does not matter the logical unit used for positioning the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Strikethrough Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Strikethrough Property

Gets or sets whether the font object is strikethrough or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Strikethrough As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Strikethrough = value

value = instance.Strikethrough
C#
public bool Strikethrough {get; set;}
Delphi
public read-write property Strikethrough: Boolean;
Managed Extensions for C++
public: __property bool get_Strikethrough();
public: __property void set_Strikethrough(
   bool value
);
C++/CLI
public:
property bool Strikethrough {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this PDFFont object is strikethrough; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

Underline Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFFont Class : Underline Property

Gets or sets whether the font object is underline or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Underline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Underline = value

value = instance.Underline
C#
public bool Underline {get; set;}
Delphi
public read-write property Underline: Boolean;
Managed Extensions for C++
public: __property bool get_Underline();
public: __property void set_Underline(
   bool value
);
C++/CLI
public:
property bool Underline {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this PDFFont object is underline; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGradientBrush Class

Defines a gradient brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGradientBrush
   Inherits PDFCustomBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFGradientBrush
C#
public class PDFGradientBrush : PDFCustomBrush
Delphi
public class PDFGradientBrush = class(PDFCustomBrush)
Managed Extensions for C++
public __gc class PDFGradientBrush : public PDFCustomBrush
C++/CLI
public ref class PDFGradientBrush : public PDFCustomBrush

Remarks

This is the base class for all gradient brushes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGradientBrush Class

The following tables list the members exposed by PDFGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFGradientBrush Constructor | Overloaded. Initializes a new PDFGradientBrush object.
Top

Public Properties

 | Name | Description
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGradientBrush Class : PDFGradientBrush Constructor

Initializes a new PDFGradientBrush object.

Overload List

Overload | Description
PDFGradientBrush Constructor() | Initializes a new PDFGradientBrush object.
PDFGradientBrush Constructor(PDFGradientBrush) | Initializes a new PDFGradientBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Class
PDFGradientBrush Members


%%PageItemTitle%%

PDFGradientBrush Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGradientBrush Class > PDFGradientBrush Constructor : PDFGradientBrush Constructor()

Initializes a new PDFGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGradientBrush()
C#
public PDFGradientBrush()
Delphi
public PDFGradientBrush();
Managed Extensions for C++
public: PDFGradientBrush();
C++/CLI
public:
PDFGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Class
PDFGradientBrush Members
Overload List


%%PageItemTitle%%

PDFGradientBrush Constructor(PDFGradientBrush)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGradientBrush Class > PDFGradientBrush Constructor : PDFGradientBrush Constructor(PDFGradientBrush)

gradientBrush
Initializes a new PDFGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradientBrush As PDFGradientBrush _
)
Visual Basic (Usage) Copy Code
Dim gradientBrush As PDFGradientBrush

Dim instance As PDFGradientBrush(gradientBrush)
C#
public PDFGradientBrush(
   PDFGradientBrush gradientBrush
)
Delphi
public PDFGradientBrush(
    gradientBrush: PDFGradientBrush
);
Managed Extensions for C++
public: PDFGradientBrush(
   PDFGradientBrush* gradientBrush
)
C++/CLI
public:
PDFGradientBrush(
   PDFGradientBrush^ gradientBrush
)

Parameters

gradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Class
PDFGradientBrush Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGradientBrush Class

For a list of all members of this type, see PDFGradientBrush members.

Public Properties

 | Name | Description
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

EndColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGradientBrush Class : EndColor Property

Syntax

Visual Basic (Declaration)
Public Property EndColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFGradientBrush
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
C#
public PDFColor EndColor {get; set;}
Delphi
public read-write property EndColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Class
PDFGradientBrush Members


%%PageItemTitle%%

StartColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGradientBrush Class : StartColor Property

Gets or sets the start color of the gradient.

Syntax

Visual Basic (Declaration)
Public Property StartColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFGradientBrush
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
C#
public PDFColor StartColor {get; set;}
Delphi
public read-write property StartColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the start color of the gradient.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGradientBrush Class
PDFGradientBrush Members


%%PageItemTitle%%

PDFGraphic Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGraphic Class

This class is the based class for all the graphic objects within the PDF file

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFGraphic
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphic
C#
public abstract class PDFGraphic : PDFObject
Delphi
public class PDFGraphic = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFGraphic : public PDFObject
C++/CLI
public ref class PDFGraphic abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyPolygon
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolygon
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyBezier
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath
O2S.Components.PDF4NET.Graphics.Shapes.PDFLines
O2S.Components.PDF4NET.Graphics.Shapes.PDFLine
O2S.Components.PDF4NET.Graphics.Shapes.PDFClippingRegion
O2S.Components.PDF4NET.Graphics.Shapes.PDFBezier

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphic Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGraphic Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGraphic Class

The following tables list the members exposed by PDFGraphic.

Public Constructors

 | Name | Description
Public Constructor | PDFGraphic Constructor | Initializes a new PDFGraphic object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFGraphic Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFGraphic Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGraphic Class : PDFGraphic Constructor

Initializes a new PDFGraphic object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphic()
C#
public PDFGraphic()
Delphi
public PDFGraphic();
Managed Extensions for C++
public: PDFGraphic();
C++/CLI
public:
PDFGraphic();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphic Class
PDFGraphic Members


%%PageItemTitle%% $$Properties$$

PDFGraphic Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGraphic Class

For a list of all members of this type, see PDFGraphic members.

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFGraphic Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGraphic Class : Brush Property

Gets or sets the brush used to fill the graphic object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphic
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

A PDFBrush object used to fill the interior of the graphic object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphic Class
PDFGraphic Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGraphic Class : Pen Property

Gets or sets the pen used to draw the graphic object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphic
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object used to draw the graphic object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphic Class
PDFGraphic Members


%%PageItemTitle%%

PointsCount Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGraphic Class : PointsCount Property

Gets the number of necessary points to represent the graphic object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PointsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphic
Dim value As Integer

value = instance.PointsCount
C#
public int PointsCount {get;}
Delphi
public read-only property PointsCount: Integer;
Managed Extensions for C++
public: __property int get_PointsCount();
C++/CLI
public:
property int PointsCount {
   int get();
}

Return Value

an integer value specifying the number of points composing the graphic object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphic Class
PDFGraphic Members


%%PageItemTitle%%

PDFHatchBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

Defines a hatch brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHatchBrush
   Inherits PDFCustomBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
C#
public class PDFHatchBrush : PDFCustomBrush
Delphi
public class PDFHatchBrush = class(PDFCustomBrush)
Managed Extensions for C++
public __gc class PDFHatchBrush : public PDFCustomBrush
C++/CLI
public ref class PDFHatchBrush : public PDFCustomBrush

Remarks

The type of the hatch brush is defined by the HatchType enumeration.
A hatch brush uses a hatch cell as its basic drawing unit. The hatch cells are drawn repeatedly from left to right, and top to bottom till the closed shaped is filled.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFHatchBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

The following tables list the members exposed by PDFHatchBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFHatchBrush Constructor | Initializes a new PDFHatchBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | HatchColor | Gets or sets the hatch color for this PDFHatchBrush object.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHatchBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : PDFHatchBrush Constructor

hatchType
Initializes a new PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hatchType As HatchType _
)
Visual Basic (Usage) Copy Code
Dim hatchType As HatchType

Dim instance As PDFHatchBrush(hatchType)
C#
public PDFHatchBrush(
   HatchType hatchType
)
Delphi
public PDFHatchBrush(
    hatchType: HatchType
);
Managed Extensions for C++
public: PDFHatchBrush(
   HatchType hatchType
)
C++/CLI
public:
PDFHatchBrush(
   HatchType hatchType
)

Parameters

hatchType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%% $$Properties$$

PDFHatchBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

For a list of all members of this type, see PDFHatchBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | HatchColor | Gets or sets the hatch color for this PDFHatchBrush object.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

HatchColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchColor Property

Gets or sets the hatch color for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchColor As PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As PDFBaseColor

instance.HatchColor = value

value = instance.HatchColor
C#
public PDFBaseColor HatchColor {get; set;}
Delphi
public read-write property HatchColor: PDFBaseColor;
Managed Extensions for C++
public: __property PDFBaseColor* get_HatchColor();
public: __property void set_HatchColor(
   PDFBaseColor* value
);
C++/CLI
public:
property PDFBaseColor^ HatchColor {
   PDFBaseColor^ get();
   void set (PDFBaseColor^ value);
}

Return Value

A PDFColor object specfying the hatch color for this brush. The brush PDFBrush.Color is used to fill the hatch background.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%%

HatchHorizontalSize Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchHorizontalSize Property

Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchHorizontalSize As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As Single

instance.HatchHorizontalSize = value

value = instance.HatchHorizontalSize
C#
public float HatchHorizontalSize {get; set;}
Delphi
public read-write property HatchHorizontalSize: Single;
Managed Extensions for C++
public: __property float get_HatchHorizontalSize();
public: __property void set_HatchHorizontalSize(
   float value
);
C++/CLI
public:
property float HatchHorizontalSize {
   float get();
   void set (float value);
}

Return Value

A float value specfying the size of horizontal of the hatch cell for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%%

HatchType Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchType Property

Gets or sets the hatch type for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchType As HatchType
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As HatchType

instance.HatchType = value

value = instance.HatchType
C#
public HatchType HatchType {get; set;}
Delphi
public read-write property HatchType: HatchType;
Managed Extensions for C++
public: __property HatchType get_HatchType();
public: __property void set_HatchType(
   HatchType value
);
C++/CLI
public:
property HatchType HatchType {
   HatchType get();
   void set (HatchType value);
}

Return Value

A HatchType enumeration member specfying the hatch type for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%%

HatchVerticalSize Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchVerticalSize Property

Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchVerticalSize As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As Single

instance.HatchVerticalSize = value

value = instance.HatchVerticalSize
C#
public float HatchVerticalSize {get; set;}
Delphi
public read-write property HatchVerticalSize: Single;
Managed Extensions for C++
public: __property float get_HatchVerticalSize();
public: __property void set_HatchVerticalSize(
   float value
);
C++/CLI
public:
property float HatchVerticalSize {
   float get();
   void set (float value);
}

Return Value

A float value specfying the size of horizontal of the hatch cell for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%%

PDFHorizontalGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

Defines a horizontal gradient brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHorizontalGradientBrush
   Inherits PDFGradientBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFHorizontalGradientBrush
C#
public class PDFHorizontalGradientBrush : PDFGradientBrush
Delphi
public class PDFHorizontalGradientBrush = class(PDFGradientBrush)
Managed Extensions for C++
public __gc class PDFHorizontalGradientBrush : public PDFGradientBrush
C++/CLI
public ref class PDFHorizontalGradientBrush : public PDFGradientBrush

Remarks

A horizontal gradient starts on the left and ends on the right of the filled shape.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHorizontalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFHorizontalGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

The following tables list the members exposed by PDFHorizontalGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFHorizontalGradientBrush Constructor | Initializes a new PDFHorizontalGradientBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | EndColor | (Inherited from PDFGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFGradientBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHorizontalGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHorizontalGradientBrush Class : PDFHorizontalGradientBrush Constructor

Initializes a new PDFHorizontalGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHorizontalGradientBrush()
C#
public PDFHorizontalGradientBrush()
Delphi
public PDFHorizontalGradientBrush();
Managed Extensions for C++
public: PDFHorizontalGradientBrush();
C++/CLI
public:
PDFHorizontalGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHorizontalGradientBrush Class
PDFHorizontalGradientBrush Members


%%PageItemTitle%%

PDFLayer Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

Defines a layer on a page's canvas.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLayer
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
C#
public class PDFLayer : PDFObject
Delphi
public class PDFLayer = class(PDFObject)
Managed Extensions for C++
public __gc class PDFLayer : public PDFObject
C++/CLI
public ref class PDFLayer : public PDFObject

Remarks

A layer allows to define sections of a content of a PDF document that can be selectively viewed or hidden by PDF consumers (PDF viewer aplications for example).
Regular page content, created through page's canvas, is not included in any layer and it is always visible.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFLayer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLayer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

The following tables list the members exposed by PDFLayer.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top

See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFLayer Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

For a list of all members of this type, see PDFLayer members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top

See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Canvas Property

Gets the canvas of the layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As PDFCanvas

value = instance.Canvas
C#
public PDFCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFCanvas;
Managed Extensions for C++
public: __property PDFCanvas* get_Canvas();
C++/CLI
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Return Value

A PDFCanvas object specifying the drawing surface of the layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Name Property

Gets or sets the name of this layer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of this layer.

Remarks

This name is displayed in the user interface of the viewer application, allowing the user to show/hide the layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


%%PageItemTitle%%

Visible Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Visible Property

Gets or sets whether this layer is visible when the document is opened.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Delphi
public read-write property Visible: Boolean;
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Return Value

True if this layer is visible when the document is opened, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


%%PageItemTitle%%

PDFLayers Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayers Class

Defines a collection of layers.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFLayers
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFLayers : PDFObject
Delphi
public class PDFLayers = class(PDFObject)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFLayers : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFLayers sealed : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFLayers

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLayers Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayers Class

The following tables list the members exposed by PDFLayers.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of layers in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the layer at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | Add | Creates a new layer with the given name and adds it at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Creates a new layer with the given name and inserts it at the specified index.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the first occurence of the given layer from collection.
Public Method | RemoveAt | Removes the layer at the specified index of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFLayers Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFLayers Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayers Class

For a list of all members of this type, see PDFLayers members.

Public Methods

 | Name | Description
Public Method | Add | Creates a new layer with the given name and adds it at the end of the collection.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | Insert | Creates a new layer with the given name and inserts it at the specified index.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Remove | Removes the first occurence of the given layer from collection.
Public Method | RemoveAt | Removes the layer at the specified index of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFLayers Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Add Method

name
the name of the new layer.
Creates a new layer with the given name and adds it at the end of the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal name As String _
) As PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim name As String
Dim value As PDFLayer

value = instance.Add(name)
C#
public PDFLayer Add(
   string name
)
Delphi
public function Add(
    name: String
): PDFLayer;
Managed Extensions for C++
public: PDFLayer* Add(
   string* name
)
C++/CLI
public:
PDFLayer^ Add(
   String^ name
)

Parameters

name
the name of the new layer.

Return Value

a PDFLayer object representing the new layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Insert Method

index
The zero-based index at which the new layer should be inserted.
name
The name of the new layer.
Creates a new layer with the given name and inserts it at the specified index.

Syntax

Visual Basic (Declaration)
Public Function Insert( _
   ByVal index As Integer, _
   ByVal name As String _
) As PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim index As Integer
Dim name As String
Dim value As PDFLayer

value = instance.Insert(index, name)
C#
public PDFLayer Insert(
   int index,
   string name
)
Delphi
public function Insert(
    index: Integer;
    name: String
): PDFLayer;
Managed Extensions for C++
public: PDFLayer* Insert(
   int index,
   string* name
)
C++/CLI
public:
PDFLayer^ Insert(
   int index,
   String^ name
)

Parameters

index
The zero-based index at which the new layer should be inserted.
name
The name of the new layer.

Return Value

a PDFLayer object representing the new layer.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Remove Method

layer
The PDFLayer object to be removed from collection.
Removes the first occurence of the given layer from collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal layer As PDFLayer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim layer As PDFLayer
Dim value As Boolean

value = instance.Remove(layer)
C#
public bool Remove(
   PDFLayer layer
)
Delphi
public function Remove(
    layer: PDFLayer
): Boolean;
Managed Extensions for C++
public: bool Remove(
   PDFLayer* layer
)
C++/CLI
public:
bool Remove(
   PDFLayer^ layer
)

Parameters

layer
The PDFLayer object to be removed from collection.

Return Value

true if the layer has been removed succesfully, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

RemoveAt Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : RemoveAt Method

index
The zero-based index of the layer to remove.
Removes the layer at the specified index of the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the layer to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%% $$Properties$$

PDFLayers Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayers Class

For a list of all members of this type, see PDFLayers members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of layers in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the layer at the specified index (zero based index).
Top

See Also

Reference

PDFLayers Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Count Property

Returns the number of layers in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayers Class : Item Property

index
Get the layer at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayers
Dim index As Integer
Dim value As PDFLayer

value = instance.Item(index)
C#
public PDFLayer this[
   int index
]; {get;}
Delphi
public  this: : PDFLayer;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFLayer* get_Item(
   int index
);
C++/CLI
public:
property PDFLayer^ default [int] {
   PDFLayer^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayers Class
PDFLayers Members


%%PageItemTitle%%

PDFPen Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

Defines an object used to draw lines and curves. This class cannot be inherited.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
C#
public sealed class PDFPen
Delphi
public class PDFPen sealed;
Managed Extensions for C++
public __gc __sealed class PDFPen
C++/CLI
public ref class PDFPen sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFPen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFPen Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

The following tables list the members exposed by PDFPen.

Public Constructors

 | Name | Description
Public Constructor | PDFPen Constructor | Overloaded. Initializes a new PDFPen object of the specified color and width. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object. Supported by Compact .NET Edition.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern. Supported by Compact .NET Edition.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces. Supported by Compact .NET Edition.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the pen.
Public Property | Width | Gets or sets the width of this PDFPen object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPen Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : PDFPen Constructor

Initializes a new PDFPen object of the specified color and width.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFPen Constructor() | Initializes a new PDFPen object.
PDFPen Constructor(PDFBaseColor) | Initializes a new PDFPen object of the specified color.
PDFPen Constructor(PDFBaseColor,Single) | Initializes a new PDFPen object of the specified color and width. Supported by Compact .NET Edition.
PDFPen Constructor(PDFPen) | Initializes a new PDFPen object based on the given pen. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

PDFPen Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor()

Initializes a new PDFPen object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPen()
C#
public PDFPen()
Delphi
public PDFPen();
Managed Extensions for C++
public: PDFPen();
C++/CLI
public:
PDFPen();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor(PDFBaseColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFBaseColor)

color
the color of the pen.
Initializes a new PDFPen object of the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFBaseColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFBaseColor

Dim instance As PDFPen(color)
C#
public PDFPen(
   PDFBaseColor color
)
Delphi
public PDFPen(
    color: PDFBaseColor
);
Managed Extensions for C++
public: PDFPen(
   PDFBaseColor* color
)
C++/CLI
public:
PDFPen(
   PDFBaseColor^ color
)

Parameters

color
the color of the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor(PDFBaseColor,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFBaseColor,Single)

color
the color of the pen.
width
the width of the pen.
Initializes a new PDFPen object of the specified color and width.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFBaseColor, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim color As PDFBaseColor
Dim width As Single

Dim instance As PDFPen(color, width)
C#
public PDFPen(
   PDFBaseColor color,
   float width
)
Delphi
public PDFPen(
    color: PDFBaseColor;
    width: Single
);
Managed Extensions for C++
public: PDFPen(
   PDFBaseColor* color,
   float width
)
C++/CLI
public:
PDFPen(
   PDFBaseColor^ color,
   float width
)

Parameters

color
the color of the pen.
width
the width of the pen.

Remarks

The width of the pen is always set in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor(PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFPen)

pen
the pen to copy.
Initializes a new PDFPen object based on the given pen.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen

Dim instance As PDFPen(pen)
C#
public PDFPen(
   PDFPen pen
)
Delphi
public PDFPen(
    pen: PDFPen
);
Managed Extensions for C++
public: PDFPen(
   PDFPen* pen
)
C++/CLI
public:
PDFPen(
   PDFPen^ pen
)

Parameters

pen
the pen to copy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPen Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

For a list of all members of this type, see PDFPen members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object. Supported by Compact .NET Edition.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern. Supported by Compact .NET Edition.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces. Supported by Compact .NET Edition.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object. Supported by Compact .NET Edition.
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the pen.
Public Property | Width | Gets or sets the width of this PDFPen object. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Color Property

Gets or sets the color of this PDFPen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As PDFBaseColor

instance.Color = value

value = instance.Color
C#
public PDFBaseColor Color {get; set;}
Delphi
public read-write property Color: PDFBaseColor;
Managed Extensions for C++
public: __property PDFBaseColor* get_Color();
public: __property void set_Color(
   PDFBaseColor* value
);
C++/CLI
public:
property PDFBaseColor^ Color {
   PDFBaseColor^ get();
   void set (PDFBaseColor^ value);
}

Return Value

The color of the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

DashOffset Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashOffset Property

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DashOffset As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As Single

instance.DashOffset = value

value = instance.DashOffset
C#
public float DashOffset {get; set;}
Delphi
public read-write property DashOffset: Single;
Managed Extensions for C++
public: __property float get_DashOffset();
public: __property void set_DashOffset(
   float value
);
C++/CLI
public:
property float DashOffset {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

DashPattern Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashPattern Property

Gets or sets an array of custom dashes and spaces.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DashPattern As Single()
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value() As Single

instance.DashPattern = value

value = instance.DashPattern
C#
public float[] DashPattern {get; set;}
Delphi
public read-write property DashPattern: array of Single;
Managed Extensions for C++
public: __property float[]* get_DashPattern();
public: __property void set_DashPattern(
   float[]* value
);
C++/CLI
public:
property array<float>^ DashPattern {
   array<float>^ get();
   void set (floatarray<value>^ value);
}

Return Value

an array of float values specifying custom dashes and spaces.

Remarks

A custom dashed line is drawn using a dash pattern specified as an array of float values. The odd values represent the length of the dashes in the pattern, and the even values represent the length of the spaces in the pattern. The pattern is repeated until the whole line is drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

DashStyle Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashStyle Property

Gets or sets the style used for dashed lines drawn with this Pen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DashStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As DashStyle

instance.DashStyle = value

value = instance.DashStyle
C#
public DashStyle DashStyle {get; set;}
Delphi
public read-write property DashStyle: DashStyle;
Managed Extensions for C++
public: __property DashStyle get_DashStyle();
public: __property void set_DashStyle(
   DashStyle value
);
C++/CLI
public:
property DashStyle DashStyle {
   DashStyle get();
   void set (DashStyle value);
}

Return Value

a DashStyle enumeration member specifying how dashed lines are drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

LineCap Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineCap Property

Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property LineCap As LineCap
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As LineCap

instance.LineCap = value

value = instance.LineCap
C#
public LineCap LineCap {get; set;}
Delphi
public read-write property LineCap: LineCap;
Managed Extensions for C++
public: __property LineCap get_LineCap();
public: __property void set_LineCap(
   LineCap value
);
C++/CLI
public:
property LineCap LineCap {
   LineCap get();
   void set (LineCap value);
}

Return Value

a LineCap enumeration member specifying how the lines end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

LineJoin Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineJoin Property

Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property LineJoin As LineJoin
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As LineJoin

instance.LineJoin = value

value = instance.LineJoin
C#
public LineJoin LineJoin {get; set;}
Delphi
public read-write property LineJoin: LineJoin;
Managed Extensions for C++
public: __property LineJoin get_LineJoin();
public: __property void set_LineJoin(
   LineJoin value
);
C++/CLI
public:
property LineJoin LineJoin {
   LineJoin get();
   void set (LineJoin value);
}

Return Value

a LineJoin enumeration member specifying the join style for consecutive lines.

Remarks

This join style is used by PDFLines, PDFPolygon and PDFRectangle objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

UseOverprint Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : UseOverprint Property

Gets or sets a value indicating whether overprint is enabled before applying the pen.

Syntax

Visual Basic (Declaration)
Public Property UseOverprint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As Boolean

instance.UseOverprint = value

value = instance.UseOverprint
C#
public bool UseOverprint {get; set;}
Delphi
public read-write property UseOverprint: Boolean;
Managed Extensions for C++
public: __property bool get_UseOverprint();
public: __property void set_UseOverprint(
   bool value
);
C++/CLI
public:
property bool UseOverprint {
   bool get();
   void set (bool value);
}

Return Value

True if overprint is enabled. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Width Property

Gets or sets the width of this PDFPen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

a float value specifying the width of this PDFPen object in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

PDFPoint Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPoint Class

Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFPoint
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
C#
public class PDFPoint
Delphi
public class PDFPoint
Managed Extensions for C++
public __gc class PDFPoint
C++/CLI
public ref class PDFPoint

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFPoint

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFPoint Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPoint Class

The following tables list the members exposed by PDFPoint.

Public Constructors

 | Name | Description
Public Constructor | PDFPoint Constructor | Overloaded. Initializes a new PDFPoint object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | X | Gets or set the x coordinate of this point. Supported by Compact .NET Edition.
Public Property | Y | Gets or set the y coordinate of this point. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPoint Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class : PDFPoint Constructor

Initializes a new PDFPoint object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFPoint Constructor() | Initializes a new PDFPoint object. Supported by Compact .NET Edition.
PDFPoint Constructor(Point) | Initializes a new PDFPoint object based on a Point structure. Supported by Compact .NET Edition.
PDFPoint Constructor(PointF) | Initializes a new PDFPoint object based on a PointF structure.
PDFPoint Constructor(Single,Single) | Initializes a new PDFPoint object based on the given coordinates. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%%

PDFPoint Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor()

Initializes a new PDFPoint object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint()
C#
public PDFPoint()
Delphi
public PDFPoint();
Managed Extensions for C++
public: PDFPoint();
C++/CLI
public:
PDFPoint();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(Point)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Point)

point
a Point structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a Point structure.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point As Point _
)
Visual Basic (Usage) Copy Code
Dim point As Point

Dim instance As PDFPoint(point)
C#
public PDFPoint(
   Point point
)
Delphi
public PDFPoint(
    point: Point
);
Managed Extensions for C++
public: PDFPoint(
   Point point
)
C++/CLI
public:
PDFPoint(
   Point point
)

Parameters

point
a Point structure to initialize this PDFPoint object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(PointF)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(PointF)

point
a PointF structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a PointF structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point As PointF _
)
Visual Basic (Usage) Copy Code
Dim point As PointF

Dim instance As PDFPoint(point)
C#
public PDFPoint(
   PointF point
)
Delphi
public PDFPoint(
    point: PointF
);
Managed Extensions for C++
public: PDFPoint(
   PointF point
)
C++/CLI
public:
PDFPoint(
   PointF point
)

Parameters

point
a PointF structure to initialize this PDFPoint object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Single,Single)

x
the x coordinate of the point
y
the y coordinate of the point
Initializes a new PDFPoint object based on the given coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim x As Single
Dim y As Single

Dim instance As PDFPoint(x, y)
C#
public PDFPoint(
   float x,
   float y
)
Delphi
public PDFPoint(
    x: Single;
    y: Single
);
Managed Extensions for C++
public: PDFPoint(
   float x,
   float y
)
C++/CLI
public:
PDFPoint(
   float x,
   float y
)

Parameters

x
the x coordinate of the point
y
the y coordinate of the point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPoint Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPoint Class

For a list of all members of this type, see PDFPoint members.

Public Properties

 | Name | Description
Public Property | X | Gets or set the x coordinate of this point. Supported by Compact .NET Edition.
Public Property | Y | Gets or set the y coordinate of this point. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class : X Property

Gets or set the x coordinate of this point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

A float value representing the x coordinate of this point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPoint Class : Y Property

Gets or set the y coordinate of this point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

A float value representing the y coordinate of this point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%%

PDFVerticalGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

Defines a vertical gradient brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFVerticalGradientBrush
   Inherits PDFGradientBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFVerticalGradientBrush
C#
public class PDFVerticalGradientBrush : PDFGradientBrush
Delphi
public class PDFVerticalGradientBrush = class(PDFGradientBrush)
Managed Extensions for C++
public __gc class PDFVerticalGradientBrush : public PDFGradientBrush
C++/CLI
public ref class PDFVerticalGradientBrush : public PDFGradientBrush

Remarks

A vertical gradient starts at top and ends at the bottom of the filled shape.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFCustomBrush
O2S.Components.PDF4NET.Graphics.PDFGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFVerticalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFVerticalGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

The following tables list the members exposed by PDFVerticalGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFVerticalGradientBrush Constructor | Initializes a new PDFGradientBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | EndColor | (Inherited from PDFGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFGradientBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFVerticalGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFVerticalGradientBrush Class : PDFVerticalGradientBrush Constructor

Initializes a new PDFGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFVerticalGradientBrush()
C#
public PDFVerticalGradientBrush()
Delphi
public PDFVerticalGradientBrush();
Managed Extensions for C++
public: PDFVerticalGradientBrush();
C++/CLI
public:
PDFVerticalGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFVerticalGradientBrush Class
PDFVerticalGradientBrush Members


%%PageItemTitle%%

DashStyle Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : DashStyle Enumeration

Specifies the style of dashed lines drawn with a Pen object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum DashStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DashStyle
C#
public enum DashStyle : Enum
Delphi
public enum DashStyle = class(Enum)
Managed Extensions for C++
__value public enum DashStyle : public Enum
C++/CLI
public enum class DashStyle : public Enum

Members

Member | Description
Custom | Specifies a custom dash style. The DashPattern property of the PDFPen object is used to specify the dashes and spaces pattern. Supported by Compact .NET Edition.
Dash | Specifies a line consisting of dashes. Supported by Compact .NET Edition.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot. Supported by Compact .NET Edition.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot. Supported by Compact .NET Edition.
Dot | Specifies a line consisting of dots. Supported by Compact .NET Edition.
Solid | Specifies a solid line. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.DashStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

FontFace Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : FontFace Enumeration

Specifies the available fonts for drawing text on a page

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum FontFace
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FontFace
C#
public enum FontFace : Enum
Delphi
public enum FontFace = class(Enum)
Managed Extensions for C++
__value public enum FontFace : public Enum
C++/CLI
public enum class FontFace : public Enum

Members

Member | Description
Helvetica | The Helvetica font
TimesRoman | The Times Roman font
Courier | The Courier font
Symbol | The Symbol font
ZapfDingbats | The ZapfDingbats font

Remarks

These fonts and their variations (bold, italic) are recongized and implemented by any PDF viewer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.FontFace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

HatchType Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : HatchType Enumeration

Specifies the available types for hatch brushes.

Syntax

Visual Basic (Declaration)
Public Enum HatchType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HatchType
C#
public enum HatchType : Enum
Delphi
public enum HatchType = class(Enum)
Managed Extensions for C++
__value public enum HatchType : public Enum
C++/CLI
public enum class HatchType : public Enum

Members

Member | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Cross | Specifies horizontal and vertical lines that cross.
DiagonalCross | Specifies forward diagonal and backward diagonal lines that cross
Horizontal | A pattern of horizontal lines.
Vertical | A pattern of vertical lines.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.HatchType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

LineCap Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : LineCap Enumeration

Specifies the available cap styles with which a Pen object can begin or end a line.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum LineCap
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LineCap
C#
public enum LineCap : Enum
Delphi
public enum LineCap = class(Enum)
Managed Extensions for C++
__value public enum LineCap : public Enum
C++/CLI
public enum class LineCap : public Enum

Members

Member | Description
Flat | Specifies a flat line cap. Supported by Compact .NET Edition.
Round | Specifies a round line cap. Supported by Compact .NET Edition.
Square | Specifies a square line cap. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.LineCap

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

LineJoin Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : LineJoin Enumeration

Specifies how to join consecutive line or curve segments

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum LineJoin
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LineJoin
C#
public enum LineJoin : Enum
Delphi
public enum LineJoin = class(Enum)
Managed Extensions for C++
__value public enum LineJoin : public Enum
C++/CLI
public enum class LineJoin : public Enum

Members

Member | Description
Miter | Specifies a mitered join. This produces a sharp corner. Supported by Compact .NET Edition.
Round | Specifies a round join. This produces a smooth, circular arc between the lines. Supported by Compact .NET Edition.
Bevel | Specifies a beveled join. This produces a diagonal corner. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.LineJoin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics.Barcodes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
PDF417Barcode | Defines a PDF 417 barcode.
PDFBarcode | Defines the base class for all barcode types.
PDFBasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
PDFBidimensionalBarcode | Defines the base class for all bidimensional barcodes.
PDFCodabarBarcode | Defines a Code 39 barcode.
PDFCodablockFBarcode | Defines a CODABLOCK F barcode.
PDFCode11Barcode | Defines a Code 11 barcode.
PDFCode128ABarcode | Defines a Code 128 barcode.
PDFCode128Barcode | Defines the base class for all Code 128 barcodes.
PDFCode128BBarcode | Defines a Code 128 barcode.
PDFCode128CBarcode | Defines a Code 128 barcode.
PDFCode16KBarcode | Defines a Code 16K barcode.
PDFCode25Barcode | Defines a Code 2 of 5 barcode.
PDFCode25InterleavedBarcode | Defines a Code 2 of 5 barcode.
PDFCode32Barcode | Defines a Code 32 barcode.
PDFCode39Barcode | Defines a Code 39 barcode.
PDFCode39ExtendedBarcode | Defines an extended Code 39 barcode.
PDFCode93Barcode | Defines a Code 93 barcode.
PDFCode93ExtendedBarcode | Defines an extended Code 93 barcode.
PDFCOOP25Barcode | Defines a COOP 2 of 5 barcode.
PDFDataMatrixBarcode | Defines a DataMatrix barcode.
PDFEAN128Barcode | Defines a EAN 128 barcode.
PDFEAN13Barcode | Defines the class for EAN-13 barcodes.
PDFEAN8Barcode | Defines the class for EAN-8 barcodes.
PDFEANBarcode | Defines the base class for EAN based barcodes.
PDFFedExGround96Barcode | Defines a FedEx Ground 96 barcode.
PDFHeightModulatedBarcode | Defines the base class for all height modulated barcodes.
PDFIATA25Barcode | Defines a IATA 2 of 5 barcode.
PDFIdentcodeBarcode | Defines an Identcode barcode.
PDFISBNBarcode | Defines the class for ISBN barcodes.
PDFISMNBarcode | Defines the class for ISMN barcodes.
PDFISSNBarcode | Defines the class for ISSN barcodes.
PDFJAN13Barcode | Defines the class for JAN13 barcodes.
PDFKixBarcode | Defines a Kix barcode.
PDFLeitcodeBarcode | Defines a Leitcode barcode.
PDFMatrix25Barcode | Defines a Matrix 2 of 5 barcode.
PDFMicroPDF417Barcode | Defines a Micro PDF 417 barcode.
PDFMSIPlesseyBarcode | Defines a MSI/Plessey barcode.
PDFPharmacodeBarcode | Defines a Pharmacode barcode.
PDFPlanetBarcode | Defines a Planet barcode.
PDFPostNetBarcode | Defines a PostNet barcode.
PDFPZNBarcode | Defines a PZN barcode.
PDFRM4SCCBarcode | Defines a RM4SCC barcode.
PDFSCC14Barcode | Defines a SCC-14 barcode.
PDFSingaporePostBarcode | Defines a Singapore Post barcode.
PDFSSCC18Barcode | Defines a SSCC-18 barcode.
PDFUnidimensionalBarcode | Defines the base class for 1D barcodes.
PDFUPCABarcode | Defines the class for UPC-A barcodes.
PDFUPCEBarcode | Defines the class for UPC-E barcodes.
PDFUSPSFIMBarcode | Defines a USPS FIM barcode.
PDFUSPSHorizontalBarcode | Defines a horizontal bars barcode.
PDFUSPSPICBarcode | Defines a USPS Package Identification Code barcode.

Enumerations

Enumeration | Description
BarcodeTextLocation | Specifies the available locations for displaying text on a linear barcode.
DataMatrixEncoding | Specifies the available encoding modes for a DataMatrix barcode.
DataMatrixSymbolSize | Specifies the available sizes for a DataMatrix symbol.
MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Barcodes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

BarcodeEncodingException Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.

Syntax

Visual Basic (Declaration)
Public Class BarcodeEncodingException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As BarcodeEncodingException
C#
public class BarcodeEncodingException : ApplicationException
Delphi
public class BarcodeEncodingException = class(ApplicationException)
Managed Extensions for C++
public __gc class BarcodeEncodingException : public ApplicationException
C++/CLI
public ref class BarcodeEncodingException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

BarcodeEncodingException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors

 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

BarcodeEncodingException Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor

message
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As BarcodeEncodingException(message)
C#
public BarcodeEncodingException(
   string message
)
Delphi
public BarcodeEncodingException(
    message: String
);
Managed Extensions for C++
public: BarcodeEncodingException(
   string* message
)
C++/CLI
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


%%PageItemTitle%%

PDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

Defines a PDF 417 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF417Barcode
   Inherits PDFBasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
C#
public class PDF417Barcode : PDFBasePDF417Barcode
Delphi
public class PDF417Barcode = class(PDFBasePDF417Barcode)
Managed Extensions for C++
public __gc class PDF417Barcode : public PDFBasePDF417Barcode
C++/CLI
public ref class PDF417Barcode : public PDFBasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : PDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode()
C#
public PDF417Barcode()
Delphi
public PDF417Barcode();
Managed Extensions for C++
public: PDF417Barcode();
C++/CLI
public:
PDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

ActualColumns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualColumns Property

Returns the actual number of columns used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
C#
public int ActualColumns {get;}
Delphi
public read-only property ActualColumns: Integer;
Managed Extensions for C++
public: __property int get_ActualColumns();
C++/CLI
public:
property int ActualColumns {
   int get();
}

Return Value

An integer value specifying the actual number of columns used by this barcode.

Remarks

This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

ActualRows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualRows Property

Returns the actual number of rows used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
C#
public int ActualRows {get;}
Delphi
public read-only property ActualRows: Integer;
Managed Extensions for C++
public: __property int get_ActualRows();
C++/CLI
public:
property int ActualRows {
   int get();
}

Return Value

An integer value specifying the actual number of rows used by this barcode.

Remarks

This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Delphi
public read-write property Columns: Integer;
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

ErrorCorrectionLevel Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this barcode.

Syntax

Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
Delphi
public read-write property ErrorCorrectionLevel: PDF417ErrorCorrectionLevel;
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

An PDF417ErrorCorrectionLevel enumeration member specifying the level of error correction used by this barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Delphi
public read-write property Rows: Integer;
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

PDFBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

Defines the base class for all barcode types.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBarcode
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
C#
public abstract class PDFBarcode : PDFObject
Delphi
public class PDFBarcode = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFBarcode : public PDFObject
C++/CLI
public ref class PDFBarcode abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

The following tables list the members exposed by PDFBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBarcode Constructor | Initializes a new PDFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : PDFBarcode Constructor

Initializes a new PDFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode()
C#
public PDFBarcode()
Delphi
public PDFBarcode();
Managed Extensions for C++
public: PDFBarcode();
C++/CLI
public:
PDFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%% $$Properties$$

PDFBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

For a list of all members of this type, see PDFBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

BackColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BackColor Property

Gets or sets the background color of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BackColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
C#
public PDFColor BackColor {get; set;}
Delphi
public read-write property BackColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the background color of barcode.

Remarks

If this property is null (Nothing in VB.NET), then the barcode's background will be transparent. Default barcode background color is white.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

BarColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BarColor Property

Gets or sets the bars color.

Syntax

Visual Basic (Declaration)
Public Property BarColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.BarColor = value

value = instance.BarColor
C#
public PDFColor BarColor {get; set;}
Delphi
public read-write property BarColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_BarColor();
public: __property void set_BarColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BarColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the bars color.

Remarks

If this property is null (Nothing in VB.NET), then no bars are shown. Default bars color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

BottomQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BottomQuietZone Property

Gets or sets the height of the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Delphi
public read-write property BottomQuietZone: Single;
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of the bottom quiet zone.

Remarks

The bottom quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Data Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Data Property

Gets or sets the string to be encoded as barcode.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Delphi
public read-write property Data: String;
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value to be encoded as barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Remarks

The characters allowed to be encoded are defined by each barcode type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Height Property

Gets the height in points of the barcode rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

value = instance.Height
C#
public float Height {get;}
Delphi
public read-only property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
C++/CLI
public:
property float Height {
   float get();
}

Return Value

A float value specifying the height of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Left Property

Gets or sets the X coordinate of the top left corner of the barcode's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

a float value representing the X coordinate of the top left corner of the barcode's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

LeftQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : LeftQuietZone Property

Gets or sets the width of the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Delphi
public read-write property LeftQuietZone: Single;
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the left quiet zone.

Remarks

The left quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Position Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Position Property

Gets or sets the position of this barcode object.

Syntax

Visual Basic (Declaration)
Public Property Position As PointF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PointF

instance.Position = value

value = instance.Position
C#
public PointF Position {get; set;}
Delphi
public read-write property Position: PointF;
Managed Extensions for C++
public: __property PointF get_Position();
public: __property void set_Position(
   PointF value
);
C++/CLI
public:
property PointF Position {
   PointF get();
   void set (PointF value);
}

Return Value

A PointF object specifying the position of the barcode.

Remarks

This position is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Rectangle Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Rectangle Property

Gets or sets the bounding rectangle of this barcode object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As RectangleF

value = instance.Rectangle
C#
public RectangleF Rectangle {get;}
Delphi
public read-only property Rectangle: RectangleF;
Managed Extensions for C++
public: __property RectangleF get_Rectangle();
C++/CLI
public:
property RectangleF Rectangle {
   RectangleF get();
}

Return Value

A RectangleF object specifying the position and size of the barcode.

Remarks

The bounding rectangle is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

RightQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : RightQuietZone Property

Gets or sets the width of the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Delphi
public read-write property RightQuietZone: Single;
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the right quiet zone.

Remarks

The right quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Size Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Size Property

Gets or sets the size of this barcode object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As SizeF

value = instance.Size
C#
public SizeF Size {get;}
Delphi
public read-only property Size: SizeF;
Managed Extensions for C++
public: __property SizeF get_Size();
C++/CLI
public:
property SizeF Size {
   SizeF get();
}

Return Value

A SizeF object specifying the size of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

TextColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TextColor Property

Gets or sets the color of the barcode text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.TextColor = value

value = instance.TextColor
C#
public PDFColor TextColor {get; set;}
Delphi
public read-write property TextColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_TextColor();
public: __property void set_TextColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ TextColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the text color.

Remarks

If this property is null (Nothing in VB.NET), then no text is shown. Default text color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Top Property

Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

a float value representing the Y coordinate of the top left corner of the barcode's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

TopQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TopQuietZone Property

Gets or sets the height of the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Delphi
public read-write property TopQuietZone: Single;
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of the top quiet zone.

Remarks

The top quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Width Property

Gets the width in points of the barcode rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

value = instance.Width
C#
public float Width {get;}
Delphi
public read-only property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
C++/CLI
public:
property float Width {
   float get();
}

Return Value

A float value specifying the width of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

XDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : XDimension Property

Gets or sets the width in points of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Delphi
public read-write property XDimension: Single;
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended width of a narrow bar is 0.864 points, which is 12 mils (1 mil = 0.001inches). Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public virtual float YDimension {get; set;}
Delphi
public read-write property YDimension: Single; virtual;
Managed Extensions for C++
public: __property virtual float get_YDimension();
public: __property virtual void set_YDimension(
   float value
);
C++/CLI
public:
virtual property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

PDFBasePDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

Defines the base class for all PDF 417 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBasePDF417Barcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
C#
public abstract class PDFBasePDF417Barcode : PDFBidimensionalBarcode
Delphi
public class PDFBasePDF417Barcode = class(PDFBidimensionalBarcode)abstract;
Managed Extensions for C++
public __gc abstract class PDFBasePDF417Barcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFBasePDF417Barcode abstract : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBasePDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

The following tables list the members exposed by PDFBasePDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBasePDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFBasePDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : PDFBasePDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode()
C#
public PDFBasePDF417Barcode()
Delphi
public PDFBasePDF417Barcode();
Managed Extensions for C++
public: PDFBasePDF417Barcode();
C++/CLI
public:
PDFBasePDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%% $$Methods$$

PDFBasePDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

GetMaxDataLength Method
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : GetMaxDataLength Method

Calculates the length of the maximum data section that can be encoded in the barcode.

Syntax

Visual Basic (Declaration)
Public Function GetMaxDataLength() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As Integer

value = instance.GetMaxDataLength()
C#
public int GetMaxDataLength()
Delphi
public function GetMaxDataLength(): Integer;
Managed Extensions for C++
public: int GetMaxDataLength();
C++/CLI
public:
int GetMaxDataLength();

Return Value

The maximum length of encoded data.

Remarks

This method calculates how much of the barcode data can be actually encoded in the barcode. The encoded data is considered to start at the beginning of barcode data. The maximum length is calculated based on barcode data, error correction level and barcode rows and columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFBasePDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

CompactionMode Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : CompactionMode Property

Gets or sets the data compaction mode for this barcode.

Syntax

Visual Basic (Declaration)
Public Property CompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
C#
public PDF417DataCompactionMode CompactionMode {get; set;}
Delphi
public read-write property CompactionMode: PDF417DataCompactionMode;
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%%

IsValid Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : IsValid Property

Gets a value indicating whether a valid barcode can be built.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
C#
public bool IsValid {get;}
Delphi
public read-only property IsValid: Boolean;
Managed Extensions for C++
public: __property bool get_IsValid();
C++/CLI
public:
property bool IsValid {
   bool get();
}

Return Value

True if the barcode can be built, false otherwise.

Remarks

The following items are considered when building the barcode: barcode data, rows, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%%

PDFBidimensionalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

Defines the base class for all bidimensional barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBidimensionalBarcode
   Inherits PDFBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode
C#
public abstract class PDFBidimensionalBarcode : PDFBarcode
Delphi
public class PDFBidimensionalBarcode = class(PDFBarcode)abstract;
Managed Extensions for C++
public __gc abstract class PDFBidimensionalBarcode : public PDFBarcode
C++/CLI
public ref class PDFBidimensionalBarcode abstract : public PDFBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBidimensionalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

The following tables list the members exposed by PDFBidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBidimensionalBarcode Constructor | Initializes a new PDFBidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFBidimensionalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : PDFBidimensionalBarcode Constructor

Initializes a new PDFBidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode()
C#
public PDFBidimensionalBarcode()
Delphi
public PDFBidimensionalBarcode();
Managed Extensions for C++
public: PDFBidimensionalBarcode();
C++/CLI
public:
PDFBidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


%%PageItemTitle%% $$Properties$$

PDFBidimensionalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

For a list of all members of this type, see PDFBidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

AlternateData Property
See Also Example
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : AlternateData Property

Gets or sets the alternate data to encode as a barcode.

Syntax

Visual Basic (Declaration)
Public Property AlternateData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
C#
public byte[] AlternateData {get; set;}
Delphi
public read-write property AlternateData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_AlternateData();
public: __property void set_AlternateData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ AlternateData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the data to be encoded as a barcode.

Example

The following line of code shows how to encode a Unicode string:
C# Copy Code
...<br/>
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...<br/>

Remarks

Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using Windows 1252 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both PDFBarcode.Data and AlternateData properties are specified, the AlternateData property is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

Defines a Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCodabarBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCodabarBarcode
C#
public class PDFCodabarBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFCodabarBarcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCodabarBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCodabarBarcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodabarBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

The following tables list the members exposed by PDFCodabarBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCodabarBarcode Constructor | Overloaded. Initializes a new PDFCodabarBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodabarBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class : PDFCodabarBarcode Constructor

Initializes a new PDFCodabarBarcode object.

Overload List

Overload | Description
PDFCodabarBarcode Constructor() | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String) | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String,Single,Single) | Initializes a new PDFCodabarBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor()

Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCodabarBarcode()
C#
public PDFCodabarBarcode()
Delphi
public PDFCodabarBarcode();
Managed Extensions for C++
public: PDFCodabarBarcode();
C++/CLI
public:
PDFCodabarBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCodabarBarcode(data)
C#
public PDFCodabarBarcode(
   string data
)
Delphi
public PDFCodabarBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCodabarBarcode(
   string* data
)
C++/CLI
public:
PDFCodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCodabarBarcode(data, left, top)
C#
public PDFCodabarBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCodabarBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCodabarBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCodabarBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodablockFBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

Defines a CODABLOCK F barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCodablockFBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
C#
public class PDFCodablockFBarcode : PDFBidimensionalBarcode
Delphi
public class PDFCodablockFBarcode = class(PDFBidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCodablockFBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFCodablockFBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodablockFBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

The following tables list the members exposed by PDFCodablockFBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCodablockFBarcode Constructor | Initializes a new PDFCodablockFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodablockFBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : PDFCodablockFBarcode Constructor

Initializes a new PDFCodablockFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode()
C#
public PDFCodablockFBarcode()
Delphi
public PDFCodablockFBarcode();
Managed Extensions for C++
public: PDFCodablockFBarcode();
C++/CLI
public:
PDFCodablockFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCodablockFBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

For a list of all members of this type, see PDFCodablockFBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Delphi
public read-write property Columns: Integer;
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%%

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Delphi
public read-write property Rows: Integer;
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%%

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Delphi
public read-write property YDimension: Single;
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Remarks

The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%%

PDFCode11Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

Defines a Code 11 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode11Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode11Barcode
C#
public class PDFCode11Barcode : PDFUnidimensionalBarcode
Delphi
public class PDFCode11Barcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode11Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode11Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode11Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

The following tables list the members exposed by PDFCode11Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode11Barcode Constructor | Overloaded. Initializes a new PDFCode11Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode11Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class : PDFCode11Barcode Constructor

Initializes a new PDFCode11Barcode object.

Overload List

Overload | Description
PDFCode11Barcode Constructor() | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String) | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String,Single,Single) | Initializes a new PDFCode11Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members


%%PageItemTitle%%

PDFCode11Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor()

Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode11Barcode()
C#
public PDFCode11Barcode()
Delphi
public PDFCode11Barcode();
Managed Extensions for C++
public: PDFCode11Barcode();
C++/CLI
public:
PDFCode11Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode11Barcode(data)
C#
public PDFCode11Barcode(
   string data
)
Delphi
public PDFCode11Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode11Barcode(
   string* data
)
C++/CLI
public:
PDFCode11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode11Barcode(data, left, top)
C#
public PDFCode11Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode11Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode11Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode11Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128ABarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128ABarcode
C#
public class PDFCode128ABarcode : PDFCode128Barcode
Delphi
public class PDFCode128ABarcode = class(PDFCode128Barcode)
Managed Extensions for C++
public __gc class PDFCode128ABarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128ABarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128ABarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

The following tables list the members exposed by PDFCode128ABarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128ABarcode Constructor | Overloaded. Initializes a new PDFCode128ABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128ABarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class : PDFCode128ABarcode Constructor

Initializes a new PDFCode128ABarcode object.

Overload List

Overload | Description
PDFCode128ABarcode Constructor() | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String) | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String,Single,Single) | Initializes a new PDFCode128ABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members


%%PageItemTitle%%

PDFCode128ABarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor()

Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128ABarcode()
C#
public PDFCode128ABarcode()
Delphi
public PDFCode128ABarcode();
Managed Extensions for C++
public: PDFCode128ABarcode();
C++/CLI
public:
PDFCode128ABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128ABarcode(data)
C#
public PDFCode128ABarcode(
   string data
)
Delphi
public PDFCode128ABarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode128ABarcode(
   string* data
)
C++/CLI
public:
PDFCode128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode128ABarcode(data, left, top)
C#
public PDFCode128ABarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode128ABarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode128ABarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode128ABarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

Defines the base class for all Code 128 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128Barcode
C#
public class PDFCode128Barcode : PDFUnidimensionalBarcode
Delphi
public class PDFCode128Barcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode128Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode128Barcode : public PDFUnidimensionalBarcode

Remarks

Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: PDFCode128ABarcode, PDFCode128BBarcode and PDFCode128CBarcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

The following tables list the members exposed by PDFCode128Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128Barcode Constructor | Overloaded. Initializes a new PDFCode128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class : PDFCode128Barcode Constructor

Initializes a new PDFCode128Barcode object.

Overload List

Overload | Description
PDFCode128Barcode Constructor() | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String) | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String,Single,Single) | Initializes a new PDFCode128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members


%%PageItemTitle%%

PDFCode128Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor()

Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128Barcode()
C#
public PDFCode128Barcode()
Delphi
public PDFCode128Barcode();
Managed Extensions for C++
public: PDFCode128Barcode();
C++/CLI
public:
PDFCode128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128Barcode(data)
C#
public PDFCode128Barcode(
   string data
)
Delphi
public PDFCode128Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode128Barcode(
   string* data
)
C++/CLI
public:
PDFCode128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode128Barcode(data, left, top)
C#
public PDFCode128Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode128Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode128Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode128Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128BBarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128BBarcode
C#
public class PDFCode128BBarcode : PDFCode128Barcode
Delphi
public class PDFCode128BBarcode = class(PDFCode128Barcode)
Managed Extensions for C++
public __gc class PDFCode128BBarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128BBarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128BBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

The following tables list the members exposed by PDFCode128BBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128BBarcode Constructor | Overloaded. Initializes a new PDFCode128BBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128BBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class : PDFCode128BBarcode Constructor

Initializes a new PDFCode128BBarcode object.

Overload List

Overload | Description
PDFCode128BBarcode Constructor() | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String) | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String,Single,Single) | Initializes a new PDFCode128BBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members


%%PageItemTitle%%

PDFCode128BBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor()

Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128BBarcode()
C#
public PDFCode128BBarcode()
Delphi
public PDFCode128BBarcode();
Managed Extensions for C++
public: PDFCode128BBarcode();
C++/CLI
public:
PDFCode128BBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128BBarcode(data)
C#
public PDFCode128BBarcode(
   string data
)
Delphi
public PDFCode128BBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode128BBarcode(
   string* data
)
C++/CLI
public:
PDFCode128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode128BBarcode(data, left, top)
C#
public PDFCode128BBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode128BBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode128BBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode128BBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128CBarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128CBarcode
C#
public class PDFCode128CBarcode : PDFCode128Barcode
Delphi
public class PDFCode128CBarcode = class(PDFCode128Barcode)
Managed Extensions for C++
public __gc class PDFCode128CBarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128CBarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at double density, each pair of digits is encoded using a single symbol.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128CBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

The following tables list the members exposed by PDFCode128CBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128CBarcode Constructor | Overloaded. Initializes a new PDFCode128CBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128CBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class : PDFCode128CBarcode Constructor

Initializes a new PDFCode128CBarcode object.

Overload List

Overload | Description
PDFCode128CBarcode Constructor() | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String) | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String,Single,Single) | Initializes a new PDFCode128CBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members


%%PageItemTitle%%

PDFCode128CBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor()

Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128CBarcode()
C#
public PDFCode128CBarcode()
Delphi
public PDFCode128CBarcode();
Managed Extensions for C++
public: PDFCode128CBarcode();
C++/CLI
public:
PDFCode128CBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128CBarcode(data)
C#
public PDFCode128CBarcode(
   string data
)
Delphi
public PDFCode128CBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode128CBarcode(
   string* data
)
C++/CLI
public:
PDFCode128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode128CBarcode(data, left, top)
C#
public PDFCode128CBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode128CBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode128CBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode128CBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode16KBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

Defines a Code 16K barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode16KBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
C#
public class PDFCode16KBarcode : PDFBidimensionalBarcode
Delphi
public class PDFCode16KBarcode = class(PDFBidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode16KBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFCode16KBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode16KBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

The following tables list the members exposed by PDFCode16KBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode16KBarcode Constructor | Initializes a new PDFCode16KBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode16KBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : PDFCode16KBarcode Constructor

Initializes a new PDFCode16KBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode()
C#
public PDFCode16KBarcode()
Delphi
public PDFCode16KBarcode();
Managed Extensions for C++
public: PDFCode16KBarcode();
C++/CLI
public:
PDFCode16KBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCode16KBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

For a list of all members of this type, see PDFCode16KBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Columns Property

Gets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Integer

value = instance.Columns
C#
public int Columns {get;}
Delphi
public read-only property Columns: Integer;
Managed Extensions for C++
public: __property int get_Columns();
C++/CLI
public:
property int Columns {
   int get();
}

Return Value

An integer value specifying the number of columns used by this barcode.

Remarks

A Code 16K barcode has always 5 columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%%

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Delphi
public read-write property Rows: Integer;
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%%

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Delphi
public read-write property YDimension: Single;
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Remarks

A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%%

PDFCode25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

Defines a Code 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode25Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode
C#
public class PDFCode25Barcode : PDFUnidimensionalBarcode
Delphi
public class PDFCode25Barcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode25Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode25Barcode : public PDFUnidimensionalBarcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

The following tables list the members exposed by PDFCode25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode25Barcode Constructor | Overloaded. Initializes a new PDFCode25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : PDFCode25Barcode Constructor

Initializes a new PDFCode25Barcode object.

Overload List

Overload | Description
PDFCode25Barcode Constructor() | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String) | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String,Single,Single) | Initializes a new PDFCode25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor()

Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode()
C#
public PDFCode25Barcode()
Delphi
public PDFCode25Barcode();
Managed Extensions for C++
public: PDFCode25Barcode();
C++/CLI
public:
PDFCode25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode25Barcode(data)
C#
public PDFCode25Barcode(
   string data
)
Delphi
public PDFCode25Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode25Barcode(
   string* data
)
C++/CLI
public:
PDFCode25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode25Barcode(data, left, top)
C#
public PDFCode25Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode25Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode25Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode25Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

For a list of all members of this type, see PDFCode25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode
Dim value As Single

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public float WideToNarrowRatio {get; set;}
Delphi
public read-write property WideToNarrowRatio: Single;
Managed Extensions for C++
public: __property float get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

Defines a Code 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode25InterleavedBarcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25InterleavedBarcode
C#
public class PDFCode25InterleavedBarcode : PDFCode25Barcode
Delphi
public class PDFCode25InterleavedBarcode = class(PDFCode25Barcode)
Managed Extensions for C++
public __gc class PDFCode25InterleavedBarcode : public PDFCode25Barcode
C++/CLI
public ref class PDFCode25InterleavedBarcode : public PDFCode25Barcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25InterleavedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

The following tables list the members exposed by PDFCode25InterleavedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode25InterleavedBarcode Constructor | Overloaded. Initializes a new PDFCode25InterleavedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class : PDFCode25InterleavedBarcode Constructor

Initializes a new PDFCode25InterleavedBarcode object.

Overload List

Overload | Description
PDFCode25InterleavedBarcode Constructor() | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String) | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String,Single,Single) | Initializes a new PDFCode25InterleavedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor()

Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25InterleavedBarcode()
C#
public PDFCode25InterleavedBarcode()
Delphi
public PDFCode25InterleavedBarcode();
Managed Extensions for C++
public: PDFCode25InterleavedBarcode();
C++/CLI
public:
PDFCode25InterleavedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode25InterleavedBarcode(data)
C#
public PDFCode25InterleavedBarcode(
   string data
)
Delphi
public PDFCode25InterleavedBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode25InterleavedBarcode(
   string* data
)
C++/CLI
public:
PDFCode25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode25InterleavedBarcode(data, left, top)
C#
public PDFCode25InterleavedBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode25InterleavedBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode25InterleavedBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode25InterleavedBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

Defines a Code 32 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode32Barcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode32Barcode
C#
public class PDFCode32Barcode : PDFCode39Barcode
Delphi
public class PDFCode32Barcode = class(PDFCode39Barcode)
Managed Extensions for C++
public __gc class PDFCode32Barcode : public PDFCode39Barcode
C++/CLI
public ref class PDFCode32Barcode : public PDFCode39Barcode

Remarks

Only the following symbols are allowed in a Code 32 barcode: 1 2 3 4 5 6 7 8 9 0. The barcode length is 9 digits (8 user defined digits + 1 check digit).
Code 32 barcodes are also known as Italian Pharmacode barcodes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode32Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

The following tables list the members exposed by PDFCode32Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode32Barcode Constructor | Overloaded. Initializes a new PDFCode32Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode32Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class : PDFCode32Barcode Constructor

Initializes a new PDFCode32Barcode object.

Overload List

Overload | Description
PDFCode32Barcode Constructor() | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String) | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String,Single,Single) | Initializes a new PDFCode32Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members


%%PageItemTitle%%

PDFCode32Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor()

Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode32Barcode()
C#
public PDFCode32Barcode()
Delphi
public PDFCode32Barcode();
Managed Extensions for C++
public: PDFCode32Barcode();
C++/CLI
public:
PDFCode32Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode32Barcode(data)
C#
public PDFCode32Barcode(
   string data
)
Delphi
public PDFCode32Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode32Barcode(
   string* data
)
C++/CLI
public:
PDFCode32Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode32Barcode(data, left, top)
C#
public PDFCode32Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode32Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode32Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode32Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

Defines a Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode39Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode
C#
public class PDFCode39Barcode : PDFUnidimensionalBarcode
Delphi
public class PDFCode39Barcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode39Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode39Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

The following tables list the members exposed by PDFCode39Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode39Barcode Constructor | Overloaded. Initializes a new PDFCode39Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : PDFCode39Barcode Constructor

Initializes a new PDFCode39Barcode object.

Overload List

Overload | Description
PDFCode39Barcode Constructor() | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String) | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String,Single,Single) | Initializes a new PDFCode39Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor()

Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode()
C#
public PDFCode39Barcode()
Delphi
public PDFCode39Barcode();
Managed Extensions for C++
public: PDFCode39Barcode();
C++/CLI
public:
PDFCode39Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode39Barcode(data)
C#
public PDFCode39Barcode(
   string data
)
Delphi
public PDFCode39Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode39Barcode(
   string* data
)
C++/CLI
public:
PDFCode39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode39Barcode(data, left, top)
C#
public PDFCode39Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode39Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode39Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode39Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode39Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

For a list of all members of this type, see PDFCode39Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode
Dim value As Single

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public float WideToNarrowRatio {get; set;}
Delphi
public read-write property WideToNarrowRatio: Single;
Managed Extensions for C++
public: __property float get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

Defines an extended Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode39ExtendedBarcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39ExtendedBarcode
C#
public class PDFCode39ExtendedBarcode : PDFCode39Barcode
Delphi
public class PDFCode39ExtendedBarcode = class(PDFCode39Barcode)
Managed Extensions for C++
public __gc class PDFCode39ExtendedBarcode : public PDFCode39Barcode
C++/CLI
public ref class PDFCode39ExtendedBarcode : public PDFCode39Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 39 barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39ExtendedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

The following tables list the members exposed by PDFCode39ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode39ExtendedBarcode Constructor | Overloaded. Initializes a new PDFCode39ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class : PDFCode39ExtendedBarcode Constructor

Initializes a new PDFCode39ExtendedBarcode object.

Overload List

Overload | Description
PDFCode39ExtendedBarcode Constructor() | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String) | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String,Single,Single) | Initializes a new PDFCode39ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor()

Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39ExtendedBarcode()
C#
public PDFCode39ExtendedBarcode()
Delphi
public PDFCode39ExtendedBarcode();
Managed Extensions for C++
public: PDFCode39ExtendedBarcode();
C++/CLI
public:
PDFCode39ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode39ExtendedBarcode(data)
C#
public PDFCode39ExtendedBarcode(
   string data
)
Delphi
public PDFCode39ExtendedBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode39ExtendedBarcode(
   string* data
)
C++/CLI
public:
PDFCode39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode39ExtendedBarcode(data, left, top)
C#
public PDFCode39ExtendedBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode39ExtendedBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode39ExtendedBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode39ExtendedBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

Defines a Code 93 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode93Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93Barcode
C#
public class PDFCode93Barcode : PDFUnidimensionalBarcode
Delphi
public class PDFCode93Barcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFCode93Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode93Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

The following tables list the members exposed by PDFCode93Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode93Barcode Constructor | Overloaded. Initializes a new PDFCode93Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class : PDFCode93Barcode Constructor

Initializes a new PDFCode93Barcode object.

Overload List

Overload | Description
PDFCode93Barcode Constructor() | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String) | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String,Single,Single) | Initializes a new PDFCode93Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members


%%PageItemTitle%%

PDFCode93Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor()

Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93Barcode()
C#
public PDFCode93Barcode()
Delphi
public PDFCode93Barcode();
Managed Extensions for C++
public: PDFCode93Barcode();
C++/CLI
public:
PDFCode93Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode93Barcode(data)
C#
public PDFCode93Barcode(
   string data
)
Delphi
public PDFCode93Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCode93Barcode(
   string* data
)
C++/CLI
public:
PDFCode93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode93Barcode(data, left, top)
C#
public PDFCode93Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode93Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode93Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode93Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

Defines an extended Code 93 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode93ExtendedBarcode
   Inherits PDFCode93Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93ExtendedBarcode
C#
public class PDFCode93ExtendedBarcode : PDFCode93Barcode
Delphi
public class PDFCode93ExtendedBarcode = class(PDFCode93Barcode)
Managed Extensions for C++
public __gc class PDFCode93ExtendedBarcode : public PDFCode93Barcode
C++/CLI
public ref class PDFCode93ExtendedBarcode : public PDFCode93Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 93 barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93ExtendedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

The following tables list the members exposed by PDFCode93ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode93ExtendedBarcode Constructor | Overloaded. Initializes a new PDFCode93ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class : PDFCode93ExtendedBarcode Constructor

Initializes a new PDFCode93ExtendedBarcode object.

Overload List

Overload | Description
PDFCode93ExtendedBarcode Constructor() | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String) | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String,Single,Single) | Initializes a new PDFCode93ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor()

Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93ExtendedBarcode()
C#
public PDFCode93ExtendedBarcode()
Delphi
public PDFCode93ExtendedBarcode();
Managed Extensions for C++
public: PDFCode93ExtendedBarcode();
C++/CLI
public:
PDFCode93ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode93ExtendedBarcode(data)
C#
public PDFCode93ExtendedBarcode(
   string data
)
Delphi
public PDFCode93ExtendedBarcode(
    data: String
);
Managed Extensions for C++
public: PDFCode93ExtendedBarcode(
   string* data
)
C++/CLI
public:
PDFCode93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCode93ExtendedBarcode(data, left, top)
C#
public PDFCode93ExtendedBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCode93ExtendedBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCode93ExtendedBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCode93ExtendedBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

Defines a COOP 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCOOP25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCOOP25Barcode
C#
public class PDFCOOP25Barcode : PDFCode25Barcode
Delphi
public class PDFCOOP25Barcode = class(PDFCode25Barcode)
Managed Extensions for C++
public __gc class PDFCOOP25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFCOOP25Barcode : public PDFCode25Barcode

Remarks

COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCOOP25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

The following tables list the members exposed by PDFCOOP25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCOOP25Barcode Constructor | Overloaded. Initializes a new PDFCOOP25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCOOP25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class : PDFCOOP25Barcode Constructor

Initializes a new PDFCOOP25Barcode object.

Overload List

Overload | Description
PDFCOOP25Barcode Constructor() | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String) | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String,Single,Single) | Initializes a new PDFCOOP25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members


%%PageItemTitle%%

PDFCOOP25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor()

Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCOOP25Barcode()
C#
public PDFCOOP25Barcode()
Delphi
public PDFCOOP25Barcode();
Managed Extensions for C++
public: PDFCOOP25Barcode();
C++/CLI
public:
PDFCOOP25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCOOP25Barcode(data)
C#
public PDFCOOP25Barcode(
   string data
)
Delphi
public PDFCOOP25Barcode(
    data: String
);
Managed Extensions for C++
public: PDFCOOP25Barcode(
   string* data
)
C++/CLI
public:
PDFCOOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFCOOP25Barcode(data, left, top)
C#
public PDFCOOP25Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFCOOP25Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFCOOP25Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFCOOP25Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFDataMatrixBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

Defines a DataMatrix barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDataMatrixBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
C#
public class PDFDataMatrixBarcode : PDFBidimensionalBarcode
Delphi
public class PDFDataMatrixBarcode = class(PDFBidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFDataMatrixBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFDataMatrixBarcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

The following tables list the members exposed by PDFDataMatrixBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFDataMatrixBarcode Constructor | Initializes a new PDFDataMatrixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFDataMatrixBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : PDFDataMatrixBarcode Constructor

Initializes a new PDFDataMatrixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode()
C#
public PDFDataMatrixBarcode()
Delphi
public PDFDataMatrixBarcode();
Managed Extensions for C++
public: PDFDataMatrixBarcode();
C++/CLI
public:
PDFDataMatrixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Methods$$

PDFDataMatrixBarcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Methods

 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

Randomize253State Method
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Randomize253State Method

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).
Applies the 253-state randomizing algorithm on padding values.

Syntax

Visual Basic (Declaration)
Public Function Randomize253State( _
   ByVal padCodeword As Integer, _
   ByVal position As Integer _
) As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim padCodeword As Integer
Dim position As Integer
Dim value As Byte

value = instance.Randomize253State(padCodeword, position)
C#
public byte Randomize253State(
   int padCodeword,
   int position
)
Delphi
public function Randomize253State(
    padCodeword: Integer;
    position: Integer
): Byte;
Managed Extensions for C++
public: byte Randomize253State(
   int padCodeword,
   int position
)
C++/CLI
public:
byte Randomize253State(
   int padCodeword,
   int position
)

Parameters

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).

Return Value

The randomized value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

PDFDataMatrixBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

Encoding Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Encoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property Encoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
C#
public DataMatrixEncoding Encoding {get; set;}
Delphi
public read-write property Encoding: DataMatrixEncoding;
Managed Extensions for C++
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then DataMatrixEncoding.Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both DataMatrixEncoding.ASCII and DataMatrixEncoding.Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the DataMatrixEncoding.Base256 encoding is the best option.
If the selected encoding is DataMatrixEncoding.Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%%

SymbolSize Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : SymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public DataMatrixSymbolSize SymbolSize {get; set;}
Delphi
public read-write property SymbolSize: DataMatrixSymbolSize;
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is DataMatrixSymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%%

PDFEAN128Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

Defines a EAN 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN128Barcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode
C#
public class PDFEAN128Barcode : PDFCode128Barcode
Delphi
public class PDFEAN128Barcode = class(PDFCode128Barcode)
Managed Extensions for C++
public __gc class PDFEAN128Barcode : public PDFCode128Barcode
C++/CLI
public ref class PDFEAN128Barcode : public PDFCode128Barcode

Remarks

An EAN-128 barcode is a Code 128 barcode that has specific rules for interpreting the encoded data, based on an application identifier.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN128Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

The following tables list the members exposed by PDFEAN128Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN128Barcode Constructor | Overloaded. Initializes a new PDFEAN128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN128Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : PDFEAN128Barcode Constructor

Initializes a new PDFEAN128Barcode object.

Overload List

Overload | Description
PDFEAN128Barcode Constructor() | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String) | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String,Single,Single) | Initializes a new PDFEAN128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN128Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor()

Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode()
C#
public PDFEAN128Barcode()
Delphi
public PDFEAN128Barcode();
Managed Extensions for C++
public: PDFEAN128Barcode();
C++/CLI
public:
PDFEAN128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN128Barcode(data)
C#
public PDFEAN128Barcode(
   string data
)
Delphi
public PDFEAN128Barcode(
    data: String
);
Managed Extensions for C++
public: PDFEAN128Barcode(
   string* data
)
C++/CLI
public:
PDFEAN128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFEAN128Barcode(data, left, top)
C#
public PDFEAN128Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFEAN128Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFEAN128Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFEAN128Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFEAN128Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

For a list of all members of this type, see PDFEAN128Barcode members.

Public Properties

 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

ApplicationIdentifier Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : ApplicationIdentifier Property

Gets or sets the application identifier.

Syntax

Visual Basic (Declaration)
Public Property ApplicationIdentifier As String
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode
Dim value As String

instance.ApplicationIdentifier = value

value = instance.ApplicationIdentifier
C#
public string ApplicationIdentifier {get; set;}
Delphi
public read-write property ApplicationIdentifier: String;
Managed Extensions for C++
public: __property string* get_ApplicationIdentifier();
public: __property void set_ApplicationIdentifier(
   string* value
);
C++/CLI
public:
property String^ ApplicationIdentifier {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the application identifier.

Remarks

The application identifier defines how the barcode data should be interpreted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

Defines the class for EAN-13 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN13Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN13Barcode
C#
public class PDFEAN13Barcode : PDFEANBarcode
Delphi
public class PDFEAN13Barcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFEAN13Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFEAN13Barcode : public PDFEANBarcode

Remarks

EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN13Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

The following tables list the members exposed by PDFEAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN13Barcode Constructor | Overloaded. Initializes a new PDFEAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN13Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class : PDFEAN13Barcode Constructor

Initializes a new PDFEAN13Barcode object.

Overload List

Overload | Description
PDFEAN13Barcode Constructor() | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String) | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String,Single,Single) | Initializes a new PDFEAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor()

Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN13Barcode()
C#
public PDFEAN13Barcode()
Delphi
public PDFEAN13Barcode();
Managed Extensions for C++
public: PDFEAN13Barcode();
C++/CLI
public:
PDFEAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN13Barcode(data)
C#
public PDFEAN13Barcode(
   string data
)
Delphi
public PDFEAN13Barcode(
    data: String
);
Managed Extensions for C++
public: PDFEAN13Barcode(
   string* data
)
C++/CLI
public:
PDFEAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFEAN13Barcode(data, left, top)
C#
public PDFEAN13Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFEAN13Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFEAN13Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFEAN13Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

Defines the class for EAN-8 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN8Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN8Barcode
C#
public class PDFEAN8Barcode : PDFEANBarcode
Delphi
public class PDFEAN8Barcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFEAN8Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFEAN8Barcode : public PDFEANBarcode

Remarks

EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN8Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

The following tables list the members exposed by PDFEAN8Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN8Barcode Constructor | Overloaded. Initializes a new PDFEAN8Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN8Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class : PDFEAN8Barcode Constructor

Initializes a new PDFEAN8Barcode object.

Overload List

Overload | Description
PDFEAN8Barcode Constructor() | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String) | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String,Single,Single) | Initializes a new PDFEAN8Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members


%%PageItemTitle%%

PDFEAN8Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor()

Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN8Barcode()
C#
public PDFEAN8Barcode()
Delphi
public PDFEAN8Barcode();
Managed Extensions for C++
public: PDFEAN8Barcode();
C++/CLI
public:
PDFEAN8Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN8Barcode(data)
C#
public PDFEAN8Barcode(
   string data
)
Delphi
public PDFEAN8Barcode(
    data: String
);
Managed Extensions for C++
public: PDFEAN8Barcode(
   string* data
)
C++/CLI
public:
PDFEAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFEAN8Barcode(data, left, top)
C#
public PDFEAN8Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFEAN8Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFEAN8Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFEAN8Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEANBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

Defines the base class for EAN based barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFEANBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
C#
public abstract class PDFEANBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFEANBarcode = class(PDFUnidimensionalBarcode)abstract;
Managed Extensions for C++
public __gc abstract class PDFEANBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFEANBarcode abstract : public PDFUnidimensionalBarcode

Remarks

An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEANBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

The following tables list the members exposed by PDFEANBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEANBarcode Constructor | Overloaded. Initializes a new PDFEANBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEANBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : PDFEANBarcode Constructor

Initializes a new PDFEANBarcode object.

Overload List

Overload | Description
PDFEANBarcode Constructor() | Initializes a new PDFEANBarcode object.
PDFEANBarcode Constructor(String) | Initializes a new PDFEANBarcode object.
PDFEANBarcode Constructor(String,Single,Single) | Initializes a new PDFEANBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

PDFEANBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor()

Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode()
C#
public PDFEANBarcode()
Delphi
public PDFEANBarcode();
Managed Extensions for C++
public: PDFEANBarcode();
C++/CLI
public:
PDFEANBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


%%PageItemTitle%%

PDFEANBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEANBarcode(data)
C#
public PDFEANBarcode(
   string data
)
Delphi
public PDFEANBarcode(
    data: String
);
Managed Extensions for C++
public: PDFEANBarcode(
   string* data
)
C++/CLI
public:
PDFEANBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


%%PageItemTitle%%

PDFEANBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFEANBarcode(data, left, top)
C#
public PDFEANBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFEANBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFEANBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFEANBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFEANBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

For a list of all members of this type, see PDFEANBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

Supplement Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : Supplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property Supplement As String
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
C#
public string Supplement {get; set;}
Delphi
public read-write property Supplement: String;
Managed Extensions for C++
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
C++/CLI
public:
property String^ Supplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

SupplementDisplayLocation Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementDisplayLocation Property

Gets or sets the location of the supplement text.

Syntax

Visual Basic (Declaration)
Public Property SupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
C#
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
Delphi
public read-write property SupplementDisplayLocation: BarcodeTextLocation;
Managed Extensions for C++
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. BarcodeTextLocation.AboveEmbedded has the same effect like BarcodeTextLocation.Above, and BarcodeTextLocation.BelowEmbedded has the same effect like BarcodeTextLocation.Below.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

SupplementYDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As Single

instance.SupplementYDimension = value

value = instance.SupplementYDimension
C#
public float SupplementYDimension {get; set;}
Delphi
public read-write property SupplementYDimension: Single;
Managed Extensions for C++
public: __property float get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   float value
);
C++/CLI
public:
property float SupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

Defines a FedEx Ground 96 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFedExGround96Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFFedExGround96Barcode
C#
public class PDFFedExGround96Barcode : PDFCode128CBarcode
Delphi
public class PDFFedExGround96Barcode = class(PDFCode128CBarcode)
Managed Extensions for C++
public __gc class PDFFedExGround96Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFFedExGround96Barcode : public PDFCode128CBarcode

Remarks

This class defines a FedEx Ground 96 barcode. Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits and the first 2 digits are always 96.
The structure of a FedEx Ground 96 barcode is as follows:
1-2 - Application Identifier (96)
3-4 - Two digit “Serial Container Numeric Code” - “11,12,13” identifies the carrier as “FedEx Ground”.
5-7 - Class of Service - Three-digit number used to identify the FedEx Ground class of service.
8-14 - FedEx Ground Shipper ID - Seven-digit unique shipper identification number.
15-21 - Package Number - Seven-digit package serial number.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFFedExGround96Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

The following tables list the members exposed by PDFFedExGround96Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFFedExGround96Barcode Constructor | Overloaded. Initializes a new PDFFedExGround96Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class : PDFFedExGround96Barcode Constructor

Initializes a new PDFFedExGround96Barcode object.

Overload List

Overload | Description
PDFFedExGround96Barcode Constructor() | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String) | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String,Single,Single) | Initializes a new PDFFedExGround96Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor()

Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFedExGround96Barcode()
C#
public PDFFedExGround96Barcode()
Delphi
public PDFFedExGround96Barcode();
Managed Extensions for C++
public: PDFFedExGround96Barcode();
C++/CLI
public:
PDFFedExGround96Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFFedExGround96Barcode(data)
C#
public PDFFedExGround96Barcode(
   string data
)
Delphi
public PDFFedExGround96Barcode(
    data: String
);
Managed Extensions for C++
public: PDFFedExGround96Barcode(
   string* data
)
C++/CLI
public:
PDFFedExGround96Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFFedExGround96Barcode(data, left, top)
C#
public PDFFedExGround96Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFFedExGround96Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFFedExGround96Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFFedExGround96Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFHeightModulatedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

Defines the base class for all height modulated barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFHeightModulatedBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFHeightModulatedBarcode
C#
public abstract class PDFHeightModulatedBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFHeightModulatedBarcode = class(PDFUnidimensionalBarcode)abstract;
Managed Extensions for C++
public __gc abstract class PDFHeightModulatedBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFHeightModulatedBarcode abstract : public PDFUnidimensionalBarcode

Remarks

Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFHeightModulatedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

The following tables list the members exposed by PDFHeightModulatedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFHeightModulatedBarcode Constructor | Overloaded. Initializes a new PDFHeightModulatedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFHeightModulatedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class : PDFHeightModulatedBarcode Constructor

Initializes a new PDFHeightModulatedBarcode object.

Overload List

Overload | Description
PDFHeightModulatedBarcode Constructor() | Initializes a new PDFHeightModulatedBarcode object.
PDFHeightModulatedBarcode Constructor(String) | Initializes a new PDFHeightModulatedBarcode object.
PDFHeightModulatedBarcode Constructor(String,Single,Single) | Initializes a new PDFHeightModulatedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members


%%PageItemTitle%%

PDFHeightModulatedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor()

Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHeightModulatedBarcode()
C#
public PDFHeightModulatedBarcode()
Delphi
public PDFHeightModulatedBarcode();
Managed Extensions for C++
public: PDFHeightModulatedBarcode();
C++/CLI
public:
PDFHeightModulatedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

PDFHeightModulatedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFHeightModulatedBarcode(data)
C#
public PDFHeightModulatedBarcode(
   string data
)
Delphi
public PDFHeightModulatedBarcode(
    data: String
);
Managed Extensions for C++
public: PDFHeightModulatedBarcode(
   string* data
)
C++/CLI
public:
PDFHeightModulatedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

PDFHeightModulatedBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFHeightModulatedBarcode(data, left, top)
C#
public PDFHeightModulatedBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFHeightModulatedBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFHeightModulatedBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFHeightModulatedBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

Defines a IATA 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIATA25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFIATA25Barcode
C#
public class PDFIATA25Barcode : PDFCode25Barcode
Delphi
public class PDFIATA25Barcode = class(PDFCode25Barcode)
Managed Extensions for C++
public __gc class PDFIATA25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFIATA25Barcode : public PDFCode25Barcode

Remarks

IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
IATA (International Air Transport Assosiation) uses this for the management of air cargo.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIATA25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

The following tables list the members exposed by PDFIATA25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFIATA25Barcode Constructor | Overloaded. Initializes a new PDFIATA25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIATA25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class : PDFIATA25Barcode Constructor

Initializes a new PDFIATA25Barcode object.

Overload List

Overload | Description
PDFIATA25Barcode Constructor() | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String) | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String,Single,Single) | Initializes a new PDFIATA25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members


%%PageItemTitle%%

PDFIATA25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor()

Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIATA25Barcode()
C#
public PDFIATA25Barcode()
Delphi
public PDFIATA25Barcode();
Managed Extensions for C++
public: PDFIATA25Barcode();
C++/CLI
public:
PDFIATA25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFIATA25Barcode(data)
C#
public PDFIATA25Barcode(
   string data
)
Delphi
public PDFIATA25Barcode(
    data: String
);
Managed Extensions for C++
public: PDFIATA25Barcode(
   string* data
)
C++/CLI
public:
PDFIATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFIATA25Barcode(data, left, top)
C#
public PDFIATA25Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFIATA25Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFIATA25Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFIATA25Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

Defines an Identcode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIdentcodeBarcode
   Inherits PDFCode25InterleavedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFIdentcodeBarcode
C#
public class PDFIdentcodeBarcode : PDFCode25InterleavedBarcode
Delphi
public class PDFIdentcodeBarcode = class(PDFCode25InterleavedBarcode)
Managed Extensions for C++
public __gc class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
C++/CLI
public ref class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode

Remarks

The Identcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 12 digits (11 user defined digits + 1 check digit).
The structure of Identcode barcode is:
1..2 - Mail center (outgoing)
3..5 - Customer code
6..11 - Delivery number
12 - Check digit (computed automatically)

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIdentcodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

The following tables list the members exposed by PDFIdentcodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFIdentcodeBarcode Constructor | Overloaded. Initializes a new PDFIdentcodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class : PDFIdentcodeBarcode Constructor

Initializes a new PDFIdentcodeBarcode object.

Overload List

Overload | Description
PDFIdentcodeBarcode Constructor() | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String) | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String,Single,Single) | Initializes a new PDFIdentcodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor()

Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIdentcodeBarcode()
C#
public PDFIdentcodeBarcode()
Delphi
public PDFIdentcodeBarcode();
Managed Extensions for C++
public: PDFIdentcodeBarcode();
C++/CLI
public:
PDFIdentcodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFIdentcodeBarcode(data)
C#
public PDFIdentcodeBarcode(
   string data
)
Delphi
public PDFIdentcodeBarcode(
    data: String
);
Managed Extensions for C++
public: PDFIdentcodeBarcode(
   string* data
)
C++/CLI
public:
PDFIdentcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFIdentcodeBarcode(data, left, top)
C#
public PDFIdentcodeBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFIdentcodeBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFIdentcodeBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFIdentcodeBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

Defines the class for ISBN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISBNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISBNBarcode
C#
public class PDFISBNBarcode : PDFEANBarcode
Delphi
public class PDFISBNBarcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFISBNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISBNBarcode : public PDFEANBarcode

Remarks

ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISBNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

The following tables list the members exposed by PDFISBNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISBNBarcode Constructor | Overloaded. Initializes a new PDFISBNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISBNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class : PDFISBNBarcode Constructor

Initializes a new PDFISBNBarcode object.

Overload List

Overload | Description
PDFISBNBarcode Constructor() | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String) | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String,Single,Single) | Initializes a new PDFISBNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members


%%PageItemTitle%%

PDFISBNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor()

Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISBNBarcode()
C#
public PDFISBNBarcode()
Delphi
public PDFISBNBarcode();
Managed Extensions for C++
public: PDFISBNBarcode();
C++/CLI
public:
PDFISBNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISBNBarcode(data)
C#
public PDFISBNBarcode(
   string data
)
Delphi
public PDFISBNBarcode(
    data: String
);
Managed Extensions for C++
public: PDFISBNBarcode(
   string* data
)
C++/CLI
public:
PDFISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFISBNBarcode(data, left, top)
C#
public PDFISBNBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFISBNBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFISBNBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFISBNBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

Defines the class for ISMN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISMNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISMNBarcode
C#
public class PDFISMNBarcode : PDFEANBarcode
Delphi
public class PDFISMNBarcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFISMNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISMNBarcode : public PDFEANBarcode

Remarks

ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISMNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

The following tables list the members exposed by PDFISMNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISMNBarcode Constructor | Overloaded. Initializes a new PDFISMNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISMNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class : PDFISMNBarcode Constructor

Initializes a new PDFISMNBarcode object.

Overload List

Overload | Description
PDFISMNBarcode Constructor() | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String) | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String,Single,Single) | Initializes a new PDFISMNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members


%%PageItemTitle%%

PDFISMNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor()

Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISMNBarcode()
C#
public PDFISMNBarcode()
Delphi
public PDFISMNBarcode();
Managed Extensions for C++
public: PDFISMNBarcode();
C++/CLI
public:
PDFISMNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISMNBarcode(data)
C#
public PDFISMNBarcode(
   string data
)
Delphi
public PDFISMNBarcode(
    data: String
);
Managed Extensions for C++
public: PDFISMNBarcode(
   string* data
)
C++/CLI
public:
PDFISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFISMNBarcode(data, left, top)
C#
public PDFISMNBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFISMNBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFISMNBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFISMNBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

Defines the class for ISSN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISSNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISSNBarcode
C#
public class PDFISSNBarcode : PDFEANBarcode
Delphi
public class PDFISSNBarcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFISSNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISSNBarcode : public PDFEANBarcode

Remarks

ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISSNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

The following tables list the members exposed by PDFISSNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISSNBarcode Constructor | Overloaded. Initializes a new PDFISSNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISSNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class : PDFISSNBarcode Constructor

Initializes a new PDFISSNBarcode object.

Overload List

Overload | Description
PDFISSNBarcode Constructor() | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String) | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String,Single,Single) | Initializes a new PDFISSNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members


%%PageItemTitle%%

PDFISSNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor()

Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISSNBarcode()
C#
public PDFISSNBarcode()
Delphi
public PDFISSNBarcode();
Managed Extensions for C++
public: PDFISSNBarcode();
C++/CLI
public:
PDFISSNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISSNBarcode(data)
C#
public PDFISSNBarcode(
   string data
)
Delphi
public PDFISSNBarcode(
    data: String
);
Managed Extensions for C++
public: PDFISSNBarcode(
   string* data
)
C++/CLI
public:
PDFISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFISSNBarcode(data, left, top)
C#
public PDFISSNBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFISSNBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFISSNBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFISSNBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

Defines the class for JAN13 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFJAN13Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFJAN13Barcode
C#
public class PDFJAN13Barcode : PDFEANBarcode
Delphi
public class PDFJAN13Barcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFJAN13Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFJAN13Barcode : public PDFEANBarcode

Remarks

JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFJAN13Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

The following tables list the members exposed by PDFJAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFJAN13Barcode Constructor | Overloaded. Initializes a new PDFJAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFJAN13Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class : PDFJAN13Barcode Constructor

Initializes a new PDFJAN13Barcode object.

Overload List

Overload | Description
PDFJAN13Barcode Constructor() | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String) | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String,Single,Single) | Initializes a new PDFJAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members


%%PageItemTitle%%

PDFJAN13Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor()

Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJAN13Barcode()
C#
public PDFJAN13Barcode()
Delphi
public PDFJAN13Barcode();
Managed Extensions for C++
public: PDFJAN13Barcode();
C++/CLI
public:
PDFJAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFJAN13Barcode(data)
C#
public PDFJAN13Barcode(
   string data
)
Delphi
public PDFJAN13Barcode(
    data: String
);
Managed Extensions for C++
public: PDFJAN13Barcode(
   string* data
)
C++/CLI
public:
PDFJAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFJAN13Barcode(data, left, top)
C#
public PDFJAN13Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFJAN13Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFJAN13Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFJAN13Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

Defines a Kix barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFKixBarcode
   Inherits PDFRM4SCCBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFKixBarcode
C#
public class PDFKixBarcode : PDFRM4SCCBarcode
Delphi
public class PDFKixBarcode = class(PDFRM4SCCBarcode)
Managed Extensions for C++
public __gc class PDFKixBarcode : public PDFRM4SCCBarcode
C++/CLI
public ref class PDFKixBarcode : public PDFRM4SCCBarcode

Remarks

The Kix barcode, a height-modulated barcode symbology, is used by Royal Dutch Post in automated mail sortation process.
Only the following symbols are allowed in a Kix barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFKixBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

The following tables list the members exposed by PDFKixBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFKixBarcode Constructor | Overloaded. Initializes a new PDFKixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFKixBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class : PDFKixBarcode Constructor

Initializes a new PDFKixBarcode object.

Overload List

Overload | Description
PDFKixBarcode Constructor() | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String) | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String,Single,Single) | Initializes a new PDFKixBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members


%%PageItemTitle%%

PDFKixBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor()

Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFKixBarcode()
C#
public PDFKixBarcode()
Delphi
public PDFKixBarcode();
Managed Extensions for C++
public: PDFKixBarcode();
C++/CLI
public:
PDFKixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFKixBarcode(data)
C#
public PDFKixBarcode(
   string data
)
Delphi
public PDFKixBarcode(
    data: String
);
Managed Extensions for C++
public: PDFKixBarcode(
   string* data
)
C++/CLI
public:
PDFKixBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFKixBarcode(data, left, top)
C#
public PDFKixBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFKixBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFKixBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFKixBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

Defines a Leitcode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLeitcodeBarcode
   Inherits PDFCode25InterleavedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFLeitcodeBarcode
C#
public class PDFLeitcodeBarcode : PDFCode25InterleavedBarcode
Delphi
public class PDFLeitcodeBarcode = class(PDFCode25InterleavedBarcode)
Managed Extensions for C++
public __gc class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
C++/CLI
public ref class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode

Remarks

The Leitcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 14 digits (13 user defined digits + 1 check digit).
The structure of Leitcode barcode is:
1..5 - ZIP code
6..8 - Street's code number
9..11 - House number
12..13 - Product code
14 - Check Digit

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFLeitcodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

The following tables list the members exposed by PDFLeitcodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFLeitcodeBarcode Constructor | Overloaded. Initializes a new PDFLeitcodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class : PDFLeitcodeBarcode Constructor

Initializes a new PDFLeitcodeBarcode object.

Overload List

Overload | Description
PDFLeitcodeBarcode Constructor() | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String) | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String,Single,Single) | Initializes a new PDFLeitcodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor()

Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLeitcodeBarcode()
C#
public PDFLeitcodeBarcode()
Delphi
public PDFLeitcodeBarcode();
Managed Extensions for C++
public: PDFLeitcodeBarcode();
C++/CLI
public:
PDFLeitcodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFLeitcodeBarcode(data)
C#
public PDFLeitcodeBarcode(
   string data
)
Delphi
public PDFLeitcodeBarcode(
    data: String
);
Managed Extensions for C++
public: PDFLeitcodeBarcode(
   string* data
)
C++/CLI
public:
PDFLeitcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFLeitcodeBarcode(data, left, top)
C#
public PDFLeitcodeBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFLeitcodeBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFLeitcodeBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFLeitcodeBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

Defines a Matrix 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMatrix25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMatrix25Barcode
C#
public class PDFMatrix25Barcode : PDFCode25Barcode
Delphi
public class PDFMatrix25Barcode = class(PDFCode25Barcode)
Managed Extensions for C++
public __gc class PDFMatrix25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFMatrix25Barcode : public PDFCode25Barcode

Remarks

Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMatrix25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

The following tables list the members exposed by PDFMatrix25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMatrix25Barcode Constructor | Overloaded. Initializes a new PDFMatrix25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMatrix25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class : PDFMatrix25Barcode Constructor

Initializes a new PDFMatrix25Barcode object.

Overload List

Overload | Description
PDFMatrix25Barcode Constructor() | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String) | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String,Single,Single) | Initializes a new PDFMatrix25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members


%%PageItemTitle%%

PDFMatrix25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor()

Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMatrix25Barcode()
C#
public PDFMatrix25Barcode()
Delphi
public PDFMatrix25Barcode();
Managed Extensions for C++
public: PDFMatrix25Barcode();
C++/CLI
public:
PDFMatrix25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFMatrix25Barcode(data)
C#
public PDFMatrix25Barcode(
   string data
)
Delphi
public PDFMatrix25Barcode(
    data: String
);
Managed Extensions for C++
public: PDFMatrix25Barcode(
   string* data
)
C++/CLI
public:
PDFMatrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFMatrix25Barcode(data, left, top)
C#
public PDFMatrix25Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFMatrix25Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFMatrix25Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFMatrix25Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMicroPDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

Defines a Micro PDF 417 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMicroPDF417Barcode
   Inherits PDFBasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode
C#
public class PDFMicroPDF417Barcode : PDFBasePDF417Barcode
Delphi
public class PDFMicroPDF417Barcode = class(PDFBasePDF417Barcode)
Managed Extensions for C++
public __gc class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
C++/CLI
public ref class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMicroPDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

The following tables list the members exposed by PDFMicroPDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMicroPDF417Barcode Constructor | Initializes a new PDFMicroPDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMicroPDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : PDFMicroPDF417Barcode Constructor

Initializes a new PDFMicroPDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode()
C#
public PDFMicroPDF417Barcode()
Delphi
public PDFMicroPDF417Barcode();
Managed Extensions for C++
public: PDFMicroPDF417Barcode();
C++/CLI
public:
PDFMicroPDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFMicroPDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

SymbolSize Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public MicroPDF417SymbolSize SymbolSize {get; set;}
Delphi
public read-write property SymbolSize: MicroPDF417SymbolSize;
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is MicroPDF417SymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

Defines a MSI/Plessey barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMSIPlesseyBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMSIPlesseyBarcode
C#
public class PDFMSIPlesseyBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFMSIPlesseyBarcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode

Remarks

MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMSIPlesseyBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

The following tables list the members exposed by PDFMSIPlesseyBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMSIPlesseyBarcode Constructor | Overloaded. Initializes a new PDFMSIPlesseyBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class : PDFMSIPlesseyBarcode Constructor

Initializes a new PDFMSIPlesseyBarcode object.

Overload List

Overload | Description
PDFMSIPlesseyBarcode Constructor() | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String) | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String,Single,Single) | Initializes a new PDFMSIPlesseyBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor()

Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMSIPlesseyBarcode()
C#
public PDFMSIPlesseyBarcode()
Delphi
public PDFMSIPlesseyBarcode();
Managed Extensions for C++
public: PDFMSIPlesseyBarcode();
C++/CLI
public:
PDFMSIPlesseyBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFMSIPlesseyBarcode(data)
C#
public PDFMSIPlesseyBarcode(
   string data
)
Delphi
public PDFMSIPlesseyBarcode(
    data: String
);
Managed Extensions for C++
public: PDFMSIPlesseyBarcode(
   string* data
)
C++/CLI
public:
PDFMSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFMSIPlesseyBarcode(data, left, top)
C#
public PDFMSIPlesseyBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFMSIPlesseyBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFMSIPlesseyBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFMSIPlesseyBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

Defines a Pharmacode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPharmacodeBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
C#
public class PDFPharmacodeBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFPharmacodeBarcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Pharmacode barcode: 1 2 3 4 5 6 7 8 9 0 and the PDFBarcode.Data property must represent a number between 3 and 131070.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPharmacodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

The following tables list the members exposed by PDFPharmacodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPharmacodeBarcode Constructor | Overloaded. Initializes a new PDFPharmacodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : PDFPharmacodeBarcode Constructor

Initializes a new PDFPharmacodeBarcode object.

Overload List

Overload | Description
PDFPharmacodeBarcode Constructor() | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String) | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String,Single,Single) | Initializes a new PDFPharmacodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor()

Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode()
C#
public PDFPharmacodeBarcode()
Delphi
public PDFPharmacodeBarcode();
Managed Extensions for C++
public: PDFPharmacodeBarcode();
C++/CLI
public:
PDFPharmacodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPharmacodeBarcode(data)
C#
public PDFPharmacodeBarcode(
   string data
)
Delphi
public PDFPharmacodeBarcode(
    data: String
);
Managed Extensions for C++
public: PDFPharmacodeBarcode(
   string* data
)
C++/CLI
public:
PDFPharmacodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFPharmacodeBarcode(data, left, top)
C#
public PDFPharmacodeBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFPharmacodeBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFPharmacodeBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFPharmacodeBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPharmacodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

For a list of all members of this type, see PDFPharmacodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

BarSpacing Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : BarSpacing Property

Gets or sets the space between bars.

Syntax

Visual Basic (Declaration)
Public Property BarSpacing As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
Dim value As Single

instance.BarSpacing = value

value = instance.BarSpacing
C#
public float BarSpacing {get; set;}
Delphi
public read-write property BarSpacing: Single;
Managed Extensions for C++
public: __property float get_BarSpacing();
public: __property void set_BarSpacing(
   float value
);
C++/CLI
public:
property float BarSpacing {
   float get();
   void set (float value);
}

Return Value

The distance between the bars.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
Dim value As Single

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public float WideToNarrowRatio {get; set;}
Delphi
public read-write property WideToNarrowRatio: Single;
Managed Extensions for C++
public: __property float get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

Defines a Planet barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPlanetBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPlanetBarcode
C#
public class PDFPlanetBarcode : PDFHeightModulatedBarcode
Delphi
public class PDFPlanetBarcode = class(PDFHeightModulatedBarcode)
Managed Extensions for C++
public __gc class PDFPlanetBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFPlanetBarcode : public PDFHeightModulatedBarcode

Remarks

The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPlanetBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

The following tables list the members exposed by PDFPlanetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPlanetBarcode Constructor | Overloaded. Initializes a new PDFPlanetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPlanetBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class : PDFPlanetBarcode Constructor

Initializes a new PDFPlanetBarcode object.

Overload List

Overload | Description
PDFPlanetBarcode Constructor() | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String) | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String,Single,Single) | Initializes a new PDFPlanetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor()

Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPlanetBarcode()
C#
public PDFPlanetBarcode()
Delphi
public PDFPlanetBarcode();
Managed Extensions for C++
public: PDFPlanetBarcode();
C++/CLI
public:
PDFPlanetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPlanetBarcode(data)
C#
public PDFPlanetBarcode(
   string data
)
Delphi
public PDFPlanetBarcode(
    data: String
);
Managed Extensions for C++
public: PDFPlanetBarcode(
   string* data
)
C++/CLI
public:
PDFPlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFPlanetBarcode(data, left, top)
C#
public PDFPlanetBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFPlanetBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFPlanetBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFPlanetBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

Defines a PostNet barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPostNetBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPostNetBarcode
C#
public class PDFPostNetBarcode : PDFHeightModulatedBarcode
Delphi
public class PDFPostNetBarcode = class(PDFHeightModulatedBarcode)
Managed Extensions for C++
public __gc class PDFPostNetBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFPostNetBarcode : public PDFHeightModulatedBarcode

Remarks

PostNet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPostNetBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

The following tables list the members exposed by PDFPostNetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPostNetBarcode Constructor | Overloaded. Initializes a new PDFPostNetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPostNetBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class : PDFPostNetBarcode Constructor

Initializes a new PDFPostNetBarcode object.

Overload List

Overload | Description
PDFPostNetBarcode Constructor() | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String) | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String,Single,Single) | Initializes a new PDFPostNetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members


%%PageItemTitle%%

PDFPostNetBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor()

Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPostNetBarcode()
C#
public PDFPostNetBarcode()
Delphi
public PDFPostNetBarcode();
Managed Extensions for C++
public: PDFPostNetBarcode();
C++/CLI
public:
PDFPostNetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPostNetBarcode(data)
C#
public PDFPostNetBarcode(
   string data
)
Delphi
public PDFPostNetBarcode(
    data: String
);
Managed Extensions for C++
public: PDFPostNetBarcode(
   string* data
)
C++/CLI
public:
PDFPostNetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFPostNetBarcode(data, left, top)
C#
public PDFPostNetBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFPostNetBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFPostNetBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFPostNetBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

Defines a PZN barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPZNBarcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPZNBarcode
C#
public class PDFPZNBarcode : PDFCode39Barcode
Delphi
public class PDFPZNBarcode = class(PDFCode39Barcode)
Managed Extensions for C++
public __gc class PDFPZNBarcode : public PDFCode39Barcode
C++/CLI
public ref class PDFPZNBarcode : public PDFCode39Barcode

Remarks

The PZN barcode has a fixed length, 6 digits and only the following symbols are allowed: 1 2 3 4 5 6 7 8 9 0.
PZN (Pharma-Zentral-Nummer) barcodes are used in pharmaceutical industry in Germany.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPZNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

The following tables list the members exposed by PDFPZNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPZNBarcode Constructor | Overloaded. Initializes a new PDFPZNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPZNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class : PDFPZNBarcode Constructor

Initializes a new PDFPZNBarcode object.

Overload List

Overload | Description
PDFPZNBarcode Constructor() | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String) | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String,Single,Single) | Initializes a new PDFPZNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members


%%PageItemTitle%%

PDFPZNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor()

Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPZNBarcode()
C#
public PDFPZNBarcode()
Delphi
public PDFPZNBarcode();
Managed Extensions for C++
public: PDFPZNBarcode();
C++/CLI
public:
PDFPZNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPZNBarcode(data)
C#
public PDFPZNBarcode(
   string data
)
Delphi
public PDFPZNBarcode(
    data: String
);
Managed Extensions for C++
public: PDFPZNBarcode(
   string* data
)
C++/CLI
public:
PDFPZNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFPZNBarcode(data, left, top)
C#
public PDFPZNBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFPZNBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFPZNBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFPZNBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

Defines a RM4SCC barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRM4SCCBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFRM4SCCBarcode
C#
public class PDFRM4SCCBarcode : PDFHeightModulatedBarcode
Delphi
public class PDFRM4SCCBarcode = class(PDFHeightModulatedBarcode)
Managed Extensions for C++
public __gc class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode

Remarks

The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFRM4SCCBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

The following tables list the members exposed by PDFRM4SCCBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFRM4SCCBarcode Constructor | Overloaded. Initializes a new PDFRM4SCCBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class : PDFRM4SCCBarcode Constructor

Initializes a new PDFRM4SCCBarcode object.

Overload List

Overload | Description
PDFRM4SCCBarcode Constructor() | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String) | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String,Single,Single) | Initializes a new PDFRM4SCCBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor()

Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRM4SCCBarcode()
C#
public PDFRM4SCCBarcode()
Delphi
public PDFRM4SCCBarcode();
Managed Extensions for C++
public: PDFRM4SCCBarcode();
C++/CLI
public:
PDFRM4SCCBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFRM4SCCBarcode(data)
C#
public PDFRM4SCCBarcode(
   string data
)
Delphi
public PDFRM4SCCBarcode(
    data: String
);
Managed Extensions for C++
public: PDFRM4SCCBarcode(
   string* data
)
C++/CLI
public:
PDFRM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFRM4SCCBarcode(data, left, top)
C#
public PDFRM4SCCBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFRM4SCCBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFRM4SCCBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFRM4SCCBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

Defines a SCC-14 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSCC14Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSCC14Barcode
C#
public class PDFSCC14Barcode : PDFCode128CBarcode
Delphi
public class PDFSCC14Barcode = class(PDFCode128CBarcode)
Managed Extensions for C++
public __gc class PDFSCC14Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFSCC14Barcode : public PDFCode128CBarcode

Remarks

This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSCC14Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

The following tables list the members exposed by PDFSCC14Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSCC14Barcode Constructor | Overloaded. Initializes a new PDFSCC14Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSCC14Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class : PDFSCC14Barcode Constructor

Initializes a new PDFSCC14Barcode object.

Overload List

Overload | Description
PDFSCC14Barcode Constructor() | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String) | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String,Single,Single) | Initializes a new PDFSCC14Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members


%%PageItemTitle%%

PDFSCC14Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor()

Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSCC14Barcode()
C#
public PDFSCC14Barcode()
Delphi
public PDFSCC14Barcode();
Managed Extensions for C++
public: PDFSCC14Barcode();
C++/CLI
public:
PDFSCC14Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSCC14Barcode(data)
C#
public PDFSCC14Barcode(
   string data
)
Delphi
public PDFSCC14Barcode(
    data: String
);
Managed Extensions for C++
public: PDFSCC14Barcode(
   string* data
)
C++/CLI
public:
PDFSCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFSCC14Barcode(data, left, top)
C#
public PDFSCC14Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFSCC14Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFSCC14Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFSCC14Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

Defines a Singapore Post barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSingaporePostBarcode
   Inherits PDFRM4SCCBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSingaporePostBarcode
C#
public class PDFSingaporePostBarcode : PDFRM4SCCBarcode
Delphi
public class PDFSingaporePostBarcode = class(PDFRM4SCCBarcode)
Managed Extensions for C++
public __gc class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
C++/CLI
public ref class PDFSingaporePostBarcode : public PDFRM4SCCBarcode

Remarks

The Singapore Post barcode is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a Singapore Post barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSingaporePostBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

The following tables list the members exposed by PDFSingaporePostBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSingaporePostBarcode Constructor | Overloaded. Initializes a new PDFSingaporePostBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class : PDFSingaporePostBarcode Constructor

Initializes a new PDFSingaporePostBarcode object.

Overload List

Overload | Description
PDFSingaporePostBarcode Constructor() | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String) | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String,Single,Single) | Initializes a new PDFSingaporePostBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor()

Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSingaporePostBarcode()
C#
public PDFSingaporePostBarcode()
Delphi
public PDFSingaporePostBarcode();
Managed Extensions for C++
public: PDFSingaporePostBarcode();
C++/CLI
public:
PDFSingaporePostBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSingaporePostBarcode(data)
C#
public PDFSingaporePostBarcode(
   string data
)
Delphi
public PDFSingaporePostBarcode(
    data: String
);
Managed Extensions for C++
public: PDFSingaporePostBarcode(
   string* data
)
C++/CLI
public:
PDFSingaporePostBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFSingaporePostBarcode(data, left, top)
C#
public PDFSingaporePostBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFSingaporePostBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFSingaporePostBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFSingaporePostBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

Defines a SSCC-18 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSSCC18Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSSCC18Barcode
C#
public class PDFSSCC18Barcode : PDFCode128CBarcode
Delphi
public class PDFSSCC18Barcode = class(PDFCode128CBarcode)
Managed Extensions for C++
public __gc class PDFSSCC18Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFSSCC18Barcode : public PDFCode128CBarcode

Remarks

This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSSCC18Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

The following tables list the members exposed by PDFSSCC18Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSSCC18Barcode Constructor | Overloaded. Initializes a new PDFSSCC18Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSSCC18Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class : PDFSSCC18Barcode Constructor

Initializes a new PDFSSCC18Barcode object.

Overload List

Overload | Description
PDFSSCC18Barcode Constructor() | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String) | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String,Single,Single) | Initializes a new PDFSSCC18Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members


%%PageItemTitle%%

PDFSSCC18Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor()

Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSSCC18Barcode()
C#
public PDFSSCC18Barcode()
Delphi
public PDFSSCC18Barcode();
Managed Extensions for C++
public: PDFSSCC18Barcode();
C++/CLI
public:
PDFSSCC18Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSSCC18Barcode(data)
C#
public PDFSSCC18Barcode(
   string data
)
Delphi
public PDFSSCC18Barcode(
    data: String
);
Managed Extensions for C++
public: PDFSSCC18Barcode(
   string* data
)
C++/CLI
public:
PDFSSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFSSCC18Barcode(data, left, top)
C#
public PDFSSCC18Barcode(
   string data,
   float left,
   float top
)
Delphi
public PDFSSCC18Barcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFSSCC18Barcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFSSCC18Barcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFUnidimensionalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

Defines the base class for 1D barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFUnidimensionalBarcode
   Inherits PDFBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
C#
public abstract class PDFUnidimensionalBarcode : PDFBarcode
Delphi
public class PDFUnidimensionalBarcode = class(PDFBarcode)abstract;
Managed Extensions for C++
public __gc abstract class PDFUnidimensionalBarcode : public PDFBarcode
C++/CLI
public ref class PDFUnidimensionalBarcode abstract : public PDFBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUnidimensionalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

The following tables list the members exposed by PDFUnidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUnidimensionalBarcode Constructor | Overloaded. Initializes a new PDFUnidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUnidimensionalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : PDFUnidimensionalBarcode Constructor

Initializes a new PDFUnidimensionalBarcode object.

Overload List

Overload | Description
PDFUnidimensionalBarcode Constructor() | Initializes a new PDFUnidimensionalBarcode object.
PDFUnidimensionalBarcode Constructor(String,Single,Single) | Initializes a new PDFBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

PDFUnidimensionalBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class > PDFUnidimensionalBarcode Constructor : PDFUnidimensionalBarcode Constructor()

Initializes a new PDFUnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode()
C#
public PDFUnidimensionalBarcode()
Delphi
public PDFUnidimensionalBarcode();
Managed Extensions for C++
public: PDFUnidimensionalBarcode();
C++/CLI
public:
PDFUnidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members
Overload List


%%PageItemTitle%%

PDFUnidimensionalBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class > PDFUnidimensionalBarcode Constructor : PDFUnidimensionalBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUnidimensionalBarcode(data, left, top)
C#
public PDFUnidimensionalBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUnidimensionalBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUnidimensionalBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUnidimensionalBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFUnidimensionalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

For a list of all members of this type, see PDFUnidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

DataDisplayLocation Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Delphi
public read-write property DataDisplayLocation: BarcodeTextLocation;
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the barcode data is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

DisplayCheckSum Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayCheckSum Property

Gets or sets whether the check characters should be displayed in human readable form.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Delphi
public read-write property DisplayCheckSum: Boolean;
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

DisplayStartStopSymbols Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayStartStopSymbols Property

Gets or sets a value indicating whether the start/stop symbols should be displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayStartStopSymbols As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayStartStopSymbols = value

value = instance.DisplayStartStopSymbols
C#
public bool DisplayStartStopSymbols {get; set;}
Delphi
public read-write property DisplayStartStopSymbols: Boolean;
Managed Extensions for C++
public: __property bool get_DisplayStartStopSymbols();
public: __property void set_DisplayStartStopSymbols(
   bool value
);
C++/CLI
public:
property bool DisplayStartStopSymbols {
   bool get();
   void set (bool value);
}

Return Value

True if the start/stop symbol should be displayed. Default is true.

Remarks

Hiding the start/stop symbols can generate unreadable barcodes in some situations, unless you have specialized barcode readers that are aware of missing start/stop symbols.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

EnableCheckSum Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Delphi
public read-write property EnableCheckSum: Boolean;
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.

Remarks

Not all barcodes support checksum symbols. This property is ignored for those that do not support them.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : Font Property

Gets or sets the font used to display the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

A PDFFont object used to display the barcode text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

PDFUPCABarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

Defines the class for UPC-A barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUPCABarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCABarcode
C#
public class PDFUPCABarcode : PDFEANBarcode
Delphi
public class PDFUPCABarcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFUPCABarcode : public PDFEANBarcode
C++/CLI
public ref class PDFUPCABarcode : public PDFEANBarcode

Remarks

UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCABarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

The following tables list the members exposed by PDFUPCABarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUPCABarcode Constructor | Overloaded. Initializes a new PDFUPCABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCABarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class : PDFUPCABarcode Constructor

Initializes a new PDFUPCABarcode object.

Overload List

Overload | Description
PDFUPCABarcode Constructor() | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String) | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String,Single,Single) | Initializes a new PDFUPCABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members


%%PageItemTitle%%

PDFUPCABarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor()

Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCABarcode()
C#
public PDFUPCABarcode()
Delphi
public PDFUPCABarcode();
Managed Extensions for C++
public: PDFUPCABarcode();
C++/CLI
public:
PDFUPCABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUPCABarcode(data)
C#
public PDFUPCABarcode(
   string data
)
Delphi
public PDFUPCABarcode(
    data: String
);
Managed Extensions for C++
public: PDFUPCABarcode(
   string* data
)
C++/CLI
public:
PDFUPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUPCABarcode(data, left, top)
C#
public PDFUPCABarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUPCABarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUPCABarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUPCABarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

Defines the class for UPC-E barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUPCEBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCEBarcode
C#
public class PDFUPCEBarcode : PDFEANBarcode
Delphi
public class PDFUPCEBarcode = class(PDFEANBarcode)
Managed Extensions for C++
public __gc class PDFUPCEBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFUPCEBarcode : public PDFEANBarcode

Remarks

UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCEBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

The following tables list the members exposed by PDFUPCEBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUPCEBarcode Constructor | Overloaded. Initializes a new PDFUPCEBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCEBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class : PDFUPCEBarcode Constructor

Initializes a new PDFUPCEBarcode object.

Overload List

Overload | Description
PDFUPCEBarcode Constructor() | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String) | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String,Single,Single) | Initializes a new PDFUPCEBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members


%%PageItemTitle%%

PDFUPCEBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor()

Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCEBarcode()
C#
public PDFUPCEBarcode()
Delphi
public PDFUPCEBarcode();
Managed Extensions for C++
public: PDFUPCEBarcode();
C++/CLI
public:
PDFUPCEBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUPCEBarcode(data)
C#
public PDFUPCEBarcode(
   string data
)
Delphi
public PDFUPCEBarcode(
    data: String
);
Managed Extensions for C++
public: PDFUPCEBarcode(
   string* data
)
C++/CLI
public:
PDFUPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUPCEBarcode(data, left, top)
C#
public PDFUPCEBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUPCEBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUPCEBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUPCEBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

Defines a USPS FIM barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSFIMBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSFIMBarcode
C#
public class PDFUSPSFIMBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFUSPSFIMBarcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode

Remarks

The Facing Identification Mark, or FIM, is a bar code designed by the United States Postal Service to assist in the automated processing of mail. The FIM is a set of vertical bars printed on the envelope or postcard near the upper edge, just to the left of the postage area (the area where the postage stamp or its equivalent is placed). The FIM is intended for use primarily on preprinted envelopes and postcards and is applied by the company printing the envelopes or postcards, not by the USPS.
FIM barcodes support only 4 data strings: "A", "B", "C", and "D", one string for each FIM barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSFIMBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

The following tables list the members exposed by PDFUSPSFIMBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSFIMBarcode Constructor | Overloaded. Initializes a new PDFUSPSFIMBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class : PDFUSPSFIMBarcode Constructor

Initializes a new PDFUSPSFIMBarcode object.

Overload List

Overload | Description
PDFUSPSFIMBarcode Constructor() | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String) | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String,Single,Single) | Initializes a new PDFUSPSFIMBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor()

Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSFIMBarcode()
C#
public PDFUSPSFIMBarcode()
Delphi
public PDFUSPSFIMBarcode();
Managed Extensions for C++
public: PDFUSPSFIMBarcode();
C++/CLI
public:
PDFUSPSFIMBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSFIMBarcode(data)
C#
public PDFUSPSFIMBarcode(
   string data
)
Delphi
public PDFUSPSFIMBarcode(
    data: String
);
Managed Extensions for C++
public: PDFUSPSFIMBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSFIMBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUSPSFIMBarcode(data, left, top)
C#
public PDFUSPSFIMBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUSPSFIMBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUSPSFIMBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUSPSFIMBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

Defines a horizontal bars barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSHorizontalBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSHorizontalBarcode
C#
public class PDFUSPSHorizontalBarcode : PDFUnidimensionalBarcode
Delphi
public class PDFUSPSHorizontalBarcode = class(PDFUnidimensionalBarcode)
Managed Extensions for C++
public __gc class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode

Remarks

This type of barcode is used by USPS to identify mailings as business reply mail. The PDFBarcode.Data property is a string of "1", each digit corresponding to a bar.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSHorizontalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

The following tables list the members exposed by PDFUSPSHorizontalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSHorizontalBarcode Constructor | Overloaded. Initializes a new PDFUSPSHorizontalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class : PDFUSPSHorizontalBarcode Constructor

Initializes a new PDFUSPSHorizontalBarcode object.

Overload List

Overload | Description
PDFUSPSHorizontalBarcode Constructor() | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String) | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String,Single,Single) | Initializes a new PDFUSPSHorizontalBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor()

Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSHorizontalBarcode()
C#
public PDFUSPSHorizontalBarcode()
Delphi
public PDFUSPSHorizontalBarcode();
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode();
C++/CLI
public:
PDFUSPSHorizontalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSHorizontalBarcode(data)
C#
public PDFUSPSHorizontalBarcode(
   string data
)
Delphi
public PDFUSPSHorizontalBarcode(
    data: String
);
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSHorizontalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUSPSHorizontalBarcode(data, left, top)
C#
public PDFUSPSHorizontalBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUSPSHorizontalBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUSPSHorizontalBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

Defines a USPS Package Identification Code barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSPICBarcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSPICBarcode
C#
public class PDFUSPSPICBarcode : PDFCode128CBarcode
Delphi
public class PDFUSPSPICBarcode = class(PDFCode128CBarcode)
Managed Extensions for C++
public __gc class PDFUSPSPICBarcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFUSPSPICBarcode : public PDFCode128CBarcode

Remarks

Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits for standard barcode (the first 2 digits are always 91) or 29 digits for concatenated barcode (the first 3 digits are always 420).
The structure of a USPS PIC standard barcode is as follows:
1 - 2 - Application Identifier (91)
3 - 4 - Service Type Code (STC)
5 - 13 - Customer ID: DUNS number that uniquely identifies the customer
14 - 21 - Package Sequence Number (PSN)
The structure of a USPS PIC concatenated barcode is as follows:
1 - 3 - Routing Application Identifier (420)
4 - 8 - 5-digit ZIP code
9 - 10 - Application Identifier (91)
11 - 12 - Service Type Code (STC)
13 - 21 - Customer ID: DUNS number that uniquely identifies the customer
22 - 29 - Package Sequence Number (PSN)

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSPICBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

The following tables list the members exposed by PDFUSPSPICBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSPICBarcode Constructor | Overloaded. Initializes a new PDFUSPSPICBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class : PDFUSPSPICBarcode Constructor

Initializes a new PDFUSPSPICBarcode object.

Overload List

Overload | Description
PDFUSPSPICBarcode Constructor() | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String) | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String,Single,Single) | Initializes a new PDFUSPSPICBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor()

Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSPICBarcode()
C#
public PDFUSPSPICBarcode()
Delphi
public PDFUSPSPICBarcode();
Managed Extensions for C++
public: PDFUSPSPICBarcode();
C++/CLI
public:
PDFUSPSPICBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSPICBarcode(data)
C#
public PDFUSPSPICBarcode(
   string data
)
Delphi
public PDFUSPSPICBarcode(
    data: String
);
Managed Extensions for C++
public: PDFUSPSPICBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSPICBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String,Single,Single)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Single, _
   ByVal top As Single _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Single
Dim top As Single

Dim instance As PDFUSPSPICBarcode(data, left, top)
C#
public PDFUSPSPICBarcode(
   string data,
   float left,
   float top
)
Delphi
public PDFUSPSPICBarcode(
    data: String;
    left: Single;
    top: Single
);
Managed Extensions for C++
public: PDFUSPSPICBarcode(
   string* data,
   float left,
   float top
)
C++/CLI
public:
PDFUSPSPICBarcode(
   String^ data,
   float left,
   float top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

BarcodeTextLocation Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeTextLocation Enumeration

Specifies the available locations for displaying text on a linear barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeTextLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextLocation
C#
public enum BarcodeTextLocation : Enum
Delphi
public enum BarcodeTextLocation = class(Enum)
Managed Extensions for C++
__value public enum BarcodeTextLocation : public Enum
C++/CLI
public enum class BarcodeTextLocation : public Enum

Members

Member | Description
None | Barcode text is not displayed.
Above | Barcode text is placed above the bar code.
AboveEmbedded | Barcode text is partially embedded at the top of the bar code. The top of the text is aligned with the top of the bars.
Below | Barcode text is placed below the bar code.
BelowEmbedded | Barcode text is partially embedded in the bottom of the bar code. The baseline of the text is aligned with the bottom of the bars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeTextLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

DataMatrixEncoding Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixEncoding Enumeration

Specifies the available encoding modes for a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEncoding
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixEncoding
C#
public enum DataMatrixEncoding : Enum
Delphi
public enum DataMatrixEncoding = class(Enum)
Managed Extensions for C++
__value public enum DataMatrixEncoding : public Enum
C++/CLI
public enum class DataMatrixEncoding : public Enum

Members

Member | Description
Auto | The encoding is determined automatically based on the data to encode.
ASCII | The data to encode contains ASCII characters only (0x00 - 0x7F). Extended ASCII characters (0x80 - 0xFF) are also supported.
Base256 | The data to encode is a binary stream.
Numeric | The data to encode contains only numbers (ASCII characters 0x30 - 0x39)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixEncoding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

DataMatrixSymbolSize Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixSymbolSize Enumeration

Specifies the available sizes for a DataMatrix symbol.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixSymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixSymbolSize
C#
public enum DataMatrixSymbolSize : Enum
Delphi
public enum DataMatrixSymbolSize = class(Enum)
Managed Extensions for C++
__value public enum DataMatrixSymbolSize : public Enum
C++/CLI
public enum class DataMatrixSymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x10 | Square DataMatrix symbol with 10 rows and 10 columns.
Size12x12 | Square DataMatrix symbol with 12 rows and 12 columns.
Size14x14 | Square DataMatrix symbol with 14 rows and 14 columns.
Size16x16 | Square DataMatrix symbol with 16 rows and 16 columns.
Size18x18 | Square DataMatrix symbol with 18 rows and 18 columns.
Size20x20 | Square DataMatrix symbol with 20 rows and 20 columns.
Size22x22 | Square DataMatrix symbol with 22 rows and 22 columns.
Size24x24 | Square DataMatrix symbol with 24 rows and 24 columns.
Size26x26 | Square DataMatrix symbol with 26 rows and 26 columns.
Size32x32 | Square DataMatrix symbol with 32 rows and 32 columns.
Size36x36 | Square DataMatrix symbol with 36 rows and 36 columns.
Size40x40 | Square DataMatrix symbol with 40 rows and 40 columns.
Size44x44 | Square DataMatrix symbol with 44 rows and 44 columns.
Size48x48 | Square DataMatrix symbol with 48 rows and 48 columns.
Size52x52 | Square DataMatrix symbol with 52 rows and 52 columns.
Size64x64 | Square DataMatrix symbol with 64 rows and 64 columns.
Size72x72 | Square DataMatrix symbol with 72 rows and 72 columns.
Size80x80 | Square DataMatrix symbol with 80 rows and 80 columns.
Size88x88 | Square DataMatrix symbol with 88 rows and 88 columns.
Size96x96 | Square DataMatrix symbol with 96 rows and 96 columns.
Size104x104 | Square DataMatrix symbol with 104 rows and 104 columns.
Size120x120 | Square DataMatrix symbol with 120 rows and 120 columns.
Size132x132 | Square DataMatrix symbol with 132 rows and 132 columns.
Size144x144 | Square DataMatrix symbol with 144 rows and 144 columns.
Size8x18 | Rectangular DataMatrix symbol with 8 rows and 18 columns.
Size8x32 | Rectangular DataMatrix symbol with 8 rows and 32 columns.
Size12x26 | Rectangular DataMatrix symbol with 12 rows and 26 columns.
Size12x36 | Rectangular DataMatrix symbol with 12 rows and 36 columns.
Size16x36 | Rectangular DataMatrix symbol with 16 rows and 36 columns.
Size16x48 | Rectangular DataMatrix symbol with 16 rows and 48 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixSymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

MicroPDF417SymbolSize Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : MicroPDF417SymbolSize Enumeration

Specifies the available sizes for a Micro PDF417 symbol.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417SymbolSize
C#
public enum MicroPDF417SymbolSize : Enum
Delphi
public enum MicroPDF417SymbolSize = class(Enum)
Managed Extensions for C++
__value public enum MicroPDF417SymbolSize : public Enum
C++/CLI
public enum class MicroPDF417SymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417DataCompactionMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417DataCompactionMode Enumeration

Specifies the available data compaction modes for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417DataCompactionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417DataCompactionMode
C#
public enum PDF417DataCompactionMode : Enum
Delphi
public enum PDF417DataCompactionMode = class(Enum)
Managed Extensions for C++
__value public enum PDF417DataCompactionMode : public Enum
C++/CLI
public enum class PDF417DataCompactionMode : public Enum

Members

Member | Description
Text | Text compaction mode.
Numeric | Numeric compaction mode.
Byte | Binary compaction mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417ErrorCorrectionLevel Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417ErrorCorrectionLevel Enumeration

Specifies the available error correction levels for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417ErrorCorrectionLevel
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417ErrorCorrectionLevel
C#
public enum PDF417ErrorCorrectionLevel : Enum
Delphi
public enum PDF417ErrorCorrectionLevel = class(Enum)
Managed Extensions for C++
__value public enum PDF417ErrorCorrectionLevel : public Enum
C++/CLI
public enum class PDF417ErrorCorrectionLevel : public Enum

Members

Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFCalGrayColor | Defines a calibrated gray color, based on a CalGray colorspace.
PDFCalGrayColorSpace | Defines a CalGray colorspace.
PDFCalRgbColor | Defines a calibrated RGB color, based on a CalRGB colorspace.
PDFCalRgbColorSpace | Defines a CalRGB colorspace.
PDFCmykColor | Defines a CMYK color, a color based on a CMYK device colorspace.
PDFColorSpace | Defines the base class for all colorspaces.
PDFDeviceColorSpace | Defines a device colorspace.
PDFDeviceNColor | Defines a DeviceN color, based on a DeviceN colorspace.
PDFDeviceNColorSpace | Defines a DeviceN colorspace.
PDFExtendedColor | Defines an extended color, based on a complex colorspace.
PDFGrayColor | Defines a Gray color, a color based on a Gray device colorspace.
PDFICCColor | Defines an ICC color, based on an ICC colorspace.
PDFICCColorSpace | Defines an ICC based colorspace.
PDFImportedSeparationColorSpace | Defines a separation colorspace imported from an existing PDF file.
PDFIndexedColor | Defines an indexed color, based on an indexed colorspace.
PDFIndexedColorSpace | Defines an indexed colorspace.
PDFLabColor | Defines a calibrated Lab color, based on a Lab colorspace.
PDFLabColorSpace | Defines a Lab colorspace.
PDFPantoneColor | Defines a PANTONE color.
PDFRgbColor | Defines a RGB color, a color based on a RGB device colorspace.
PDFSeparationColor | Defines an separation color, based on a separation colorspace.
PDFSeparationColorSpace | Defines a separation colorspace.
PDFSeparationColorSpaceCollection | Defines a collection of separation colorspaces.

Enumerations

Enumeration | Description
PDFDeviceColorSpaceType | Defines the available device colorspace types.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCmykColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFGrayColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFRgbColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFImportedSeparationColorSpace
System.Collections.CollectionBase
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpaceCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFCalGrayColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColor Class

Defines a calibrated gray color, based on a CalGray colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCalGrayColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
C#
public class PDFCalGrayColor : PDFExtendedColor
Delphi
public class PDFCalGrayColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFCalGrayColor : public PDFExtendedColor
C++/CLI
public ref class PDFCalGrayColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalGrayColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColor Class

The following tables list the members exposed by PDFCalGrayColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCalGrayColor Constructor | Initializes a new PDFCalGrayColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalGrayColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColor Class : PDFCalGrayColor Constructor

colorSpace
a PDFCalGrayColorSpace object the color is based on.
Initializes a new PDFCalGrayColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFCalGrayColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFCalGrayColorSpace

Dim instance As PDFCalGrayColor(colorSpace)
C#
public PDFCalGrayColor(
   PDFCalGrayColorSpace colorSpace
)
Delphi
public PDFCalGrayColor(
    colorSpace: PDFCalGrayColorSpace
);
Managed Extensions for C++
public: PDFCalGrayColor(
   PDFCalGrayColorSpace* colorSpace
)
C++/CLI
public:
PDFCalGrayColor(
   PDFCalGrayColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFCalGrayColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


%%PageItemTitle%% $$Properties$$

PDFCalGrayColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Gray Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColor Class : Gray Property

Gets or sets the gray level for this color.

Syntax

Visual Basic (Declaration)
Public Property Gray As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim value As Double

instance.Gray = value

value = instance.Gray
C#
public double Gray {get; set;}
Delphi
public read-write property Gray: Double;
Managed Extensions for C++
public: __property double get_Gray();
public: __property void set_Gray(
   double value
);
C++/CLI
public:
property double Gray {
   double get();
   void set (double value);
}

Return Value

The gray level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


%%PageItemTitle%%

PDFCalGrayColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

Defines a CalGray colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFCalGrayColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
C#
public class PDFCalGrayColorSpace : PDFColorSpace
Delphi
public class PDFCalGrayColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFCalGrayColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFCalGrayColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalGrayColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

The following tables list the members exposed by PDFCalGrayColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFCalGrayColorSpace Constructor | Initializes a new PDFCalGrayColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | WhitePoint | Gets or sets the white point.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalGrayColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : PDFCalGrayColorSpace Constructor

Initializes a new PDFCalGrayColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace()
C#
public PDFCalGrayColorSpace()
Delphi
public PDFCalGrayColorSpace();
Managed Extensions for C++
public: PDFCalGrayColorSpace();
C++/CLI
public:
PDFCalGrayColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFCalGrayColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

For a list of all members of this type, see PDFCalGrayColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFCalGrayColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

For a list of all members of this type, see PDFCalGrayColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Delphi
public read-write property BlackPoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

Gamma Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : Gamma Property

Gets or sets the gamma.

Syntax

Visual Basic (Declaration)
Public Property Gamma As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value As Double

instance.Gamma = value

value = instance.Gamma
C#
public double Gamma {get; set;}
Delphi
public read-write property Gamma: Double;
Managed Extensions for C++
public: __property double get_Gamma();
public: __property void set_Gamma(
   double value
);
C++/CLI
public:
property double Gamma {
   double get();
   void set (double value);
}

Return Value

The gamma value for the gray component.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Delphi
public read-write property WhitePoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

PDFCalRgbColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColor Class

Defines a calibrated RGB color, based on a CalRGB colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCalRgbColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
C#
public class PDFCalRgbColor : PDFExtendedColor
Delphi
public class PDFCalRgbColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFCalRgbColor : public PDFExtendedColor
C++/CLI
public ref class PDFCalRgbColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalRgbColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColor Class

The following tables list the members exposed by PDFCalRgbColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCalRgbColor Constructor | Initializes a new PDFCalRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalRgbColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColor Class : PDFCalRgbColor Constructor

colorSpace
a PDFCalRgbColorSpace object the color is based on.
Initializes a new PDFCalRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFCalRgbColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFCalRgbColorSpace

Dim instance As PDFCalRgbColor(colorSpace)
C#
public PDFCalRgbColor(
   PDFCalRgbColorSpace colorSpace
)
Delphi
public PDFCalRgbColor(
    colorSpace: PDFCalRgbColorSpace
);
Managed Extensions for C++
public: PDFCalRgbColor(
   PDFCalRgbColorSpace* colorSpace
)
C++/CLI
public:
PDFCalRgbColor(
   PDFCalRgbColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFCalRgbColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%% $$Properties$$

PDFCalRgbColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Properties

 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Blue Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColor Class : Blue Property

Gets or sets the blue level for this color.

Syntax

Visual Basic (Declaration)
Public Property Blue As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Blue = value

value = instance.Blue
C#
public double Blue {get; set;}
Delphi
public read-write property Blue: Double;
Managed Extensions for C++
public: __property double get_Blue();
public: __property void set_Blue(
   double value
);
C++/CLI
public:
property double Blue {
   double get();
   void set (double value);
}

Return Value

The blue level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%%

Green Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColor Class : Green Property

Gets or sets the green level for this color.

Syntax

Visual Basic (Declaration)
Public Property Green As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Green = value

value = instance.Green
C#
public double Green {get; set;}
Delphi
public read-write property Green: Double;
Managed Extensions for C++
public: __property double get_Green();
public: __property void set_Green(
   double value
);
C++/CLI
public:
property double Green {
   double get();
   void set (double value);
}

Return Value

The green level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%%

Red Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColor Class : Red Property

Gets or sets the red level for this color.

Syntax

Visual Basic (Declaration)
Public Property Red As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Red = value

value = instance.Red
C#
public double Red {get; set;}
Delphi
public read-write property Red: Double;
Managed Extensions for C++
public: __property double get_Red();
public: __property void set_Red(
   double value
);
C++/CLI
public:
property double Red {
   double get();
   void set (double value);
}

Return Value

The red level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%%

PDFCalRgbColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

Defines a CalRGB colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFCalRgbColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
C#
public class PDFCalRgbColorSpace : PDFColorSpace
Delphi
public class PDFCalRgbColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFCalRgbColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFCalRgbColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalRgbColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

The following tables list the members exposed by PDFCalRgbColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFCalRgbColorSpace Constructor | Initializes a new PDFCalRgbColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | WhitePoint | Gets or sets the white point.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalRgbColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : PDFCalRgbColorSpace Constructor

Initializes a new PDFCalRgbColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace()
C#
public PDFCalRgbColorSpace()
Delphi
public PDFCalRgbColorSpace();
Managed Extensions for C++
public: PDFCalRgbColorSpace();
C++/CLI
public:
PDFCalRgbColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFCalRgbColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

For a list of all members of this type, see PDFCalRgbColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFCalRgbColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

For a list of all members of this type, see PDFCalRgbColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Delphi
public read-write property BlackPoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

Gamma Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Gamma Property

Gets or sets the gamma.

Syntax

Visual Basic (Declaration)
Public Property Gamma As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Gamma = value

value = instance.Gamma
C#
public double[] Gamma {get; set;}
Delphi
public read-write property Gamma: array of Double;
Managed Extensions for C++
public: __property double[]* get_Gamma();
public: __property void set_Gamma(
   double[]* value
);
C++/CLI
public:
property array<double>^ Gamma {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [GR GG GB] specifying the gamma for the red, green, and blue components of the color space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

Matrix Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Matrix Property

Gets or sets the colorspace transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property Matrix As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
C#
public double[] Matrix {get; set;}
Delphi
public read-write property Matrix: array of Double;
Managed Extensions for C++
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
C++/CLI
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of nine numbers [XA YA ZA XB YB ZB XC YC ZC] specifying the linear interpretation of the decoded A, B, and C components of the color space with respect to the final XYZ representation..

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Delphi
public read-write property WhitePoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

PDFCmykColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCmykColor Class

Defines a CMYK color, a color based on a CMYK device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCmykColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
C#
public class PDFCmykColor : PDFExtendedColor
Delphi
public class PDFCmykColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFCmykColor : public PDFExtendedColor
C++/CLI
public ref class PDFCmykColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCmykColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCmykColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCmykColor Class

The following tables list the members exposed by PDFCmykColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCmykColor Constructor | Overloaded. Initializes a new PDFRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCmykColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : PDFCmykColor Constructor

Initializes a new PDFRgbColor object.

Overload List

Overload | Description
PDFCmykColor Constructor() | Initializes a new PDFRgbColor object.
PDFCmykColor Constructor(Double,Double,Double,Double) | Initializes a new PDFCmykColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFCmykColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor()

Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor()
C#
public PDFCmykColor()
Delphi
public PDFCmykColor();
Managed Extensions for C++
public: PDFCmykColor();
C++/CLI
public:
PDFCmykColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%%

PDFCmykColor Constructor(Double,Double,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor(Double,Double,Double,Double)

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.
Initializes a new PDFCmykColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
Visual Basic (Usage) Copy Code
Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As PDFCmykColor(c, m, y, k)
C#
public PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
Delphi
public PDFCmykColor(
    c: Double;
    m: Double;
    y: Double;
    k: Double
);
Managed Extensions for C++
public: PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
C++/CLI
public:
PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFCmykColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%% $$Properties$$

PDFCmykColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Properties

 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

C Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : C Property

Gets or sets the cyan component of the color.

Syntax

Visual Basic (Declaration)
Public Property C As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.C = value

value = instance.C
C#
public double C {get; set;}
Delphi
public read-write property C: Double;
Managed Extensions for C++
public: __property double get_C();
public: __property void set_C(
   double value
);
C++/CLI
public:
property double C {
   double get();
   void set (double value);
}

Return Value

Cyan component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

K Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : K Property

Gets or sets the black component of the color.

Syntax

Visual Basic (Declaration)
Public Property K As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.K = value

value = instance.K
C#
public double K {get; set;}
Delphi
public read-write property K: Double;
Managed Extensions for C++
public: __property double get_K();
public: __property void set_K(
   double value
);
C++/CLI
public:
property double K {
   double get();
   void set (double value);
}

Return Value

Black component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

M Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : M Property

Gets or sets the magenta component of the color.

Syntax

Visual Basic (Declaration)
Public Property M As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.M = value

value = instance.M
C#
public double M {get; set;}
Delphi
public read-write property M: Double;
Managed Extensions for C++
public: __property double get_M();
public: __property void set_M(
   double value
);
C++/CLI
public:
property double M {
   double get();
   void set (double value);
}

Return Value

Magenta component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCmykColor Class : Y Property

Gets or sets the yellow component of the color.

Syntax

Visual Basic (Declaration)
Public Property Y As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.Y = value

value = instance.Y
C#
public double Y {get; set;}
Delphi
public read-write property Y: Double;
Managed Extensions for C++
public: __property double get_Y();
public: __property void set_Y(
   double value
);
C++/CLI
public:
property double Y {
   double get();
   void set (double value);
}

Return Value

Yellow component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

Defines the base class for all colorspaces.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFColorSpace
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpace
C#
public abstract class PDFColorSpace : PDFObject
Delphi
public class PDFColorSpace = class(PDFObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFColorSpace : public PDFObject
C++/CLI
public ref class PDFColorSpace abstract : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFColorSpace Class Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

The following tables list the members exposed by PDFColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFColorSpace Constructor | Initializes a new PDFColorSpace object.
Top

See Also

Reference

PDFColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFColorSpace Class : PDFColorSpace Constructor

Initializes a new PDFColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpace()
C#
public PDFColorSpace()
Delphi
public PDFColorSpace();
Managed Extensions for C++
public: PDFColorSpace();
C++/CLI
public:
PDFColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorSpace Class
PDFColorSpace Members


%%PageItemTitle%%

PDFDeviceColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

Defines a device colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
C#
public class PDFDeviceColorSpace : PDFColorSpace
Delphi
public class PDFDeviceColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFDeviceColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFDeviceColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

The following tables list the members exposed by PDFDeviceColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | Type | Gets the type of this device colorspace.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : PDFDeviceColorSpace Constructor

type
The type of the newly created device colorspace.
Initializes a new PDFDeviceColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As PDFDeviceColorSpaceType _
)
Visual Basic (Usage) Copy Code
Dim type As PDFDeviceColorSpaceType

Dim instance As PDFDeviceColorSpace(type)
C#
public PDFDeviceColorSpace(
   PDFDeviceColorSpaceType type
)
Delphi
public PDFDeviceColorSpace(
    type: PDFDeviceColorSpaceType
);
Managed Extensions for C++
public: PDFDeviceColorSpace(
   PDFDeviceColorSpaceType type
)
C++/CLI
public:
PDFDeviceColorSpace(
   PDFDeviceColorSpaceType type
)

Parameters

type
The type of the newly created device colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFDeviceColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFDeviceColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Properties

 | Name | Description
Public Property | Type | Gets the type of this device colorspace.
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Type Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : Type Property

Gets the type of this device colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PDFDeviceColorSpaceType
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
Dim value As PDFDeviceColorSpaceType

value = instance.Type
C#
public PDFDeviceColorSpaceType Type {get;}
Delphi
public read-only property Type: PDFDeviceColorSpaceType;
Managed Extensions for C++
public: __property PDFDeviceColorSpaceType get_Type();
C++/CLI
public:
property PDFDeviceColorSpaceType Type {
   PDFDeviceColorSpaceType get();
}

Return Value

The type of the device colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%%

PDFDeviceNColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColor Class

Defines a DeviceN color, based on a DeviceN colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
C#
public class PDFDeviceNColor : PDFExtendedColor
Delphi
public class PDFDeviceNColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFDeviceNColor : public PDFExtendedColor
C++/CLI
public ref class PDFDeviceNColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColor Class

The following tables list the members exposed by PDFDeviceNColor.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNColor Constructor | Initializes a new PDFDeviceNColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColor Class : PDFDeviceNColor Constructor

colorSpace
a PDFDeviceNColorSpace object the color is based on.
Initializes a new PDFDeviceNColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFDeviceNColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFDeviceNColorSpace

Dim instance As PDFDeviceNColor(colorSpace)
C#
public PDFDeviceNColor(
   PDFDeviceNColorSpace colorSpace
)
Delphi
public PDFDeviceNColor(
    colorSpace: PDFDeviceNColorSpace
);
Managed Extensions for C++
public: PDFDeviceNColor(
   PDFDeviceNColorSpace* colorSpace
)
C++/CLI
public:
PDFDeviceNColor(
   PDFDeviceNColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFDeviceNColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


%%PageItemTitle%% $$Properties$$

PDFDeviceNColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColor Class : ColorComponents Property

Gets or sets the color components.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
C#
public double[] ColorComponents {get; set;}
Delphi
public read-write property ColorComponents: array of Double;
Managed Extensions for C++
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
C++/CLI
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of values that describe the color in the DeviceN colorspace.

Remarks

The length of this array must match the number of PDFDeviceNColorSpace.ColorantNames in the underlying DeviceN colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


%%PageItemTitle%%

PDFDeviceNColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

Defines a DeviceN colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
C#
public class PDFDeviceNColorSpace : PDFColorSpace
Delphi
public class PDFDeviceNColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFDeviceNColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFDeviceNColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

The following tables list the members exposed by PDFDeviceNColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNColorSpace Constructor | Initializes a new PDFDeviceNColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | Colorants | Gets the collection of colorants that define this colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : PDFDeviceNColorSpace Constructor

Initializes a new PDFDeviceNColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace()
C#
public PDFDeviceNColorSpace()
Delphi
public PDFDeviceNColorSpace();
Managed Extensions for C++
public: PDFDeviceNColorSpace();
C++/CLI
public:
PDFDeviceNColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFDeviceNColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

For a list of all members of this type, see PDFDeviceNColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFDeviceNColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

For a list of all members of this type, see PDFDeviceNColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | Colorants | Gets the collection of colorants that define this colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Top

See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Delphi
public read-write property AlternateColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used when the destination device does not support DeviceN colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

ColorantNames Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : ColorantNames Property

Gets the collection of colorant names included in this DeviceN colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorantNames As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As StringCollection

value = instance.ColorantNames
C#
public StringCollection ColorantNames {get;}
Delphi
public read-only property ColorantNames: StringCollection;
Managed Extensions for C++
public: __property StringCollection get_ColorantNames();
C++/CLI
public:
property StringCollection ColorantNames {
   StringCollection get();
}

Return Value

The list of colorant names.

Remarks

If this list is empty, the library will build it automatically from the names of the separation colorspaces included in this colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

Colorants Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : Colorants Property

Gets the collection of colorants that define this colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Colorants As PDFSeparationColorSpaceCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFSeparationColorSpaceCollection

value = instance.Colorants
C#
public PDFSeparationColorSpaceCollection Colorants {get;}
Delphi
public read-only property Colorants: PDFSeparationColorSpaceCollection;
Managed Extensions for C++
public: __property PDFSeparationColorSpaceCollection* get_Colorants();
C++/CLI
public:
property PDFSeparationColorSpaceCollection^ Colorants {
   PDFSeparationColorSpaceCollection^ get();
}

Return Value

A collection of colorants.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

TintTransform Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : TintTransform Property

Gets or sets the tint transform function for the this colorspace.

Syntax

Visual Basic (Declaration)
Public Property TintTransform As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
C#
public PDFFunction TintTransform {get; set;}
Delphi
public read-write property TintTransform: PDFFunction;
Managed Extensions for C++
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (PDFFunction^ value);
}

Return Value

Tint transform function for the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

PDFExtendedColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFExtendedColor Class

Defines an extended color, based on a complex colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFExtendedColor
   Inherits PDFBaseColor
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedColor
C#
public abstract class PDFExtendedColor : PDFBaseColor
Delphi
public class PDFExtendedColor = class(PDFBaseColor)abstract;
Managed Extensions for C++
public __gc abstract class PDFExtendedColor : public PDFBaseColor
C++/CLI
public ref class PDFExtendedColor abstract : public PDFBaseColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFRgbColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFGrayColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCmykColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFExtendedColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFExtendedColor Class

The following tables list the members exposed by PDFExtendedColor.

Public Constructors

 | Name | Description
Public Constructor | PDFExtendedColor Constructor | Initializes a new PDFExtendedColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFExtendedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFExtendedColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFExtendedColor Class : PDFExtendedColor Constructor

colorSpace
a PDFColorSpace object the color is based on.
Initializes a new PDFExtendedColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFColorSpace

Dim instance As PDFExtendedColor(colorSpace)
C#
public PDFExtendedColor(
   PDFColorSpace colorSpace
)
Delphi
public PDFExtendedColor(
    colorSpace: PDFColorSpace
);
Managed Extensions for C++
public: PDFExtendedColor(
   PDFColorSpace* colorSpace
)
C++/CLI
public:
PDFExtendedColor(
   PDFColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedColor Class
PDFExtendedColor Members


%%PageItemTitle%% $$Properties$$

PDFExtendedColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFExtendedColor Class

For a list of all members of this type, see PDFExtendedColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top

See Also

Reference

PDFExtendedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFExtendedColor Class : ColorSpace Property

Gets the colorspace this color is based on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedColor
Dim value As PDFColorSpace

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get;}
Delphi
public read-only property ColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
}

Return Value

A colorspace object specifying the colorspace this color was created from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedColor Class
PDFExtendedColor Members


%%PageItemTitle%%

PDFGrayColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFGrayColor Class

Defines a Gray color, a color based on a Gray device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGrayColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
C#
public class PDFGrayColor : PDFExtendedColor
Delphi
public class PDFGrayColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFGrayColor : public PDFExtendedColor
C++/CLI
public ref class PDFGrayColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFGrayColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFGrayColor Class

The following tables list the members exposed by PDFGrayColor.

Public Constructors

 | Name | Description
Public Constructor | PDFGrayColor Constructor | Overloaded. Initializes a new PDFRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | G | Gets or sets the gray level of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFGrayColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class : PDFGrayColor Constructor

Initializes a new PDFRgbColor object.

Overload List

Overload | Description
PDFGrayColor Constructor() | Initializes a new PDFRgbColor object.
PDFGrayColor Constructor(Double) | Initializes a new PDFGrayColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFGrayColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor()

Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor()
C#
public PDFGrayColor()
Delphi
public PDFGrayColor();
Managed Extensions for C++
public: PDFGrayColor();
C++/CLI
public:
PDFGrayColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%%

PDFGrayColor Constructor(Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor(Double)

g
Gray level of the color.
Initializes a new PDFGrayColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal g As Double _
)
Visual Basic (Usage) Copy Code
Dim g As Double

Dim instance As PDFGrayColor(g)
C#
public PDFGrayColor(
   double g
)
Delphi
public PDFGrayColor(
    g: Double
);
Managed Extensions for C++
public: PDFGrayColor(
   double g
)
C++/CLI
public:
PDFGrayColor(
   double g
)

Parameters

g
Gray level of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFGrayColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%% $$Properties$$

PDFGrayColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | G | Gets or sets the gray level of the color.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

G Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFGrayColor Class : G Property

Gets or sets the gray level of the color.

Syntax

Visual Basic (Declaration)
Public Property G As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As Double

instance.G = value

value = instance.G
C#
public double G {get; set;}
Delphi
public read-write property G: Double;
Managed Extensions for C++
public: __property double get_G();
public: __property void set_G(
   double value
);
C++/CLI
public:
property double G {
   double get();
   void set (double value);
}

Return Value

Gray level of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFICCColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColor Class

Defines an ICC color, based on an ICC colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFICCColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
C#
public class PDFICCColor : PDFExtendedColor
Delphi
public class PDFICCColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFICCColor : public PDFExtendedColor
C++/CLI
public ref class PDFICCColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFICCColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColor Class

The following tables list the members exposed by PDFICCColor.

Public Constructors

 | Name | Description
Public Constructor | PDFICCColor Constructor | Initializes a new PDFICCColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFICCColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColor Class : PDFICCColor Constructor

colorSpace
a PDFICCColorSpace object the color is based on.
Initializes a new PDFICCColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFICCColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFICCColorSpace

Dim instance As PDFICCColor(colorSpace)
C#
public PDFICCColor(
   PDFICCColorSpace colorSpace
)
Delphi
public PDFICCColor(
    colorSpace: PDFICCColorSpace
);
Managed Extensions for C++
public: PDFICCColor(
   PDFICCColorSpace* colorSpace
)
C++/CLI
public:
PDFICCColor(
   PDFICCColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFICCColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


%%PageItemTitle%% $$Properties$$

PDFICCColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColor Class : ColorComponents Property

Gets or sets the color components.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
C#
public double[] ColorComponents {get; set;}
Delphi
public read-write property ColorComponents: array of Double;
Managed Extensions for C++
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
C++/CLI
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of values that describe the color in the ICC colorspace.

Remarks

The length of this array must match the value of PDFICCColorSpace.ColorComponents property on the underlying ICC colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


%%PageItemTitle%%

PDFICCColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

Defines an ICC based colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFICCColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
C#
public class PDFICCColorSpace : PDFColorSpace
Delphi
public class PDFICCColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFICCColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFICCColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFICCColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

The following tables list the members exposed by PDFICCColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFICCColorSpace Constructor | Initializes a new PDFICCColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFICCColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : PDFICCColorSpace Constructor

Initializes a new PDFICCColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace()
C#
public PDFICCColorSpace()
Delphi
public PDFICCColorSpace();
Managed Extensions for C++
public: PDFICCColorSpace();
C++/CLI
public:
PDFICCColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFICCColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

For a list of all members of this type, see PDFICCColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFICCColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

For a list of all members of this type, see PDFICCColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Top

See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Delphi
public read-write property AlternateColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used in case the one specified in the stream data is not supported

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ColorComponents Property

Gets or sets the number of color components in the ICC colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value As Byte

instance.ColorComponents = value

value = instance.ColorComponents
C#
public byte ColorComponents {get; set;}
Delphi
public read-write property ColorComponents: Byte;
Managed Extensions for C++
public: __property byte get_ColorComponents();
public: __property void set_ColorComponents(
   byte value
);
C++/CLI
public:
property byte ColorComponents {
   byte get();
   void set (byte value);
}

Return Value

The number of color components in the color space described by the ICC profile data.

Remarks

This number must match the number of components actually in the ICC profile. As of PDF 1.4, this value must be 1, 3 or 4.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

ProfileData Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ProfileData Property

Gets or sets the profile data.

Syntax

Visual Basic (Declaration)
Public Property ProfileData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value() As Byte

instance.ProfileData = value

value = instance.ProfileData
C#
public byte[] ProfileData {get; set;}
Delphi
public read-write property ProfileData: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_ProfileData();
public: __property void set_ProfileData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ProfileData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The ICC profile data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

Range Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : Range Property

Gets or sets the range for color components.

Syntax

Visual Basic (Declaration)
Public Property Range As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
C#
public double[] Range {get; set;}
Delphi
public read-write property Range: array of Double;
Managed Extensions for C++
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
C++/CLI
public:
property array<double>^ Range {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of 2 × PDFICCColorSpace.ColorComponents numbers [ min0 max0 min1 max1 ... ] specifying the minimum and maximum valid values of the corresponding color components. These values must match the information in the ICC profile.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

PDFImportedSeparationColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFImportedSeparationColorSpace Class

Defines a separation colorspace imported from an existing PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedSeparationColorSpace
   Inherits PDFSeparationColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedSeparationColorSpace
C#
public class PDFImportedSeparationColorSpace : PDFSeparationColorSpace
Delphi
public class PDFImportedSeparationColorSpace = class(PDFSeparationColorSpace)
Managed Extensions for C++
public __gc class PDFImportedSeparationColorSpace : public PDFSeparationColorSpace
C++/CLI
public ref class PDFImportedSeparationColorSpace : public PDFSeparationColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFImportedSeparationColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedSeparationColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFImportedSeparationColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFImportedSeparationColorSpace Class

The following tables list the members exposed by PDFImportedSeparationColorSpace.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | Name | Gets the name of this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | TintTransformation | Gets the colorspace's tint transformation function.
Top

Public Methods

 | Name | Description
Public Method | Equals | Tests if the given object is equal to this object. (Inherited from PDFSeparationColorSpace)
Public Method | GetHashCode | Computes the object's hash code. (Inherited from PDFSeparationColorSpace)
Top

See Also

Reference

PDFImportedSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Properties$$

PDFImportedSeparationColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFImportedSeparationColorSpace Class

For a list of all members of this type, see PDFImportedSeparationColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | Name | Gets the name of this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace. (Inherited from PDFSeparationColorSpace)
Public Property | TintTransformation | Gets the colorspace's tint transformation function.
Top

See Also

Reference

PDFImportedSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFImportedSeparationColorSpace Class : Name Property

Gets the name of this separation colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedSeparationColorSpace
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Remarks

The name of the separation colorspace is equivalent to the color name defined by this separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedSeparationColorSpace Class
PDFImportedSeparationColorSpace Members


%%PageItemTitle%%

TintTransformation Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFImportedSeparationColorSpace Class : TintTransformation Property

Gets the colorspace's tint transformation function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TintTransformation As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedSeparationColorSpace
Dim value As PDFFunction

value = instance.TintTransformation
C#
public PDFFunction TintTransformation {get;}
Delphi
public read-only property TintTransformation: PDFFunction;
Managed Extensions for C++
public: __property PDFFunction* get_TintTransformation();
C++/CLI
public:
property PDFFunction^ TintTransformation {
   PDFFunction^ get();
}

Return Value

A PDFFunction descendant object specifying the tint transformation function for the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedSeparationColorSpace Class
PDFImportedSeparationColorSpace Members


%%PageItemTitle%%

PDFIndexedColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColor Class

Defines an indexed color, based on an indexed colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIndexedColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
C#
public class PDFIndexedColor : PDFExtendedColor
Delphi
public class PDFIndexedColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFIndexedColor : public PDFExtendedColor
C++/CLI
public ref class PDFIndexedColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFIndexedColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColor Class

The following tables list the members exposed by PDFIndexedColor.

Public Constructors

 | Name | Description
Public Constructor | PDFIndexedColor Constructor | Initializes a new PDFIndexedColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFIndexedColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColor Class : PDFIndexedColor Constructor

colorSpace
a PDFIndexedColorSpace object the color is based on.
Initializes a new PDFIndexedColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFIndexedColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFIndexedColorSpace

Dim instance As PDFIndexedColor(colorSpace)
C#
public PDFIndexedColor(
   PDFIndexedColorSpace colorSpace
)
Delphi
public PDFIndexedColor(
    colorSpace: PDFIndexedColorSpace
);
Managed Extensions for C++
public: PDFIndexedColor(
   PDFIndexedColorSpace* colorSpace
)
C++/CLI
public:
PDFIndexedColor(
   PDFIndexedColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFIndexedColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


%%PageItemTitle%% $$Properties$$

PDFIndexedColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Properties

 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

ColorIndex Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColor Class : ColorIndex Property

Gets or sets the color index.

Syntax

Visual Basic (Declaration)
Public Property ColorIndex As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim value As Byte

instance.ColorIndex = value

value = instance.ColorIndex
C#
public byte ColorIndex {get; set;}
Delphi
public read-write property ColorIndex: Byte;
Managed Extensions for C++
public: __property byte get_ColorIndex();
public: __property void set_ColorIndex(
   byte value
);
C++/CLI
public:
property byte ColorIndex {
   byte get();
   void set (byte value);
}

Return Value

The index of this color.

Remarks

The acceptable range for this value is 0 - PDFIndexedColorSpace.MaxIndex.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


%%PageItemTitle%%

PDFIndexedColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

Defines an indexed colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIndexedColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
C#
public class PDFIndexedColorSpace : PDFColorSpace
Delphi
public class PDFIndexedColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFIndexedColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFIndexedColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFIndexedColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

The following tables list the members exposed by PDFIndexedColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFIndexedColorSpace Constructor | Initializes a new PDFIndexedColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFIndexedColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : PDFIndexedColorSpace Constructor

Initializes a new PDFIndexedColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace()
C#
public PDFIndexedColorSpace()
Delphi
public PDFIndexedColorSpace();
Managed Extensions for C++
public: PDFIndexedColorSpace();
C++/CLI
public:
PDFIndexedColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFIndexedColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

For a list of all members of this type, see PDFIndexedColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFIndexedColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

For a list of all members of this type, see PDFIndexedColorSpace members.

Public Properties

 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Top

See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

BaseColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : BaseColorSpace Property

Gets or sets the base colorspace.

Syntax

Visual Basic (Declaration)
Public Property BaseColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value As PDFColorSpace

instance.BaseColorSpace = value

value = instance.BaseColorSpace
C#
public PDFColorSpace BaseColorSpace {get; set;}
Delphi
public read-write property BaseColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_BaseColorSpace();
public: __property void set_BaseColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ BaseColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The color space in which the values in the color table are to be interpreted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

ColorTable Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : ColorTable Property

Gets or sets the color table.

Syntax

Visual Basic (Declaration)
Public Property ColorTable As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value() As Byte

instance.ColorTable = value

value = instance.ColorTable
C#
public byte[] ColorTable {get; set;}
Delphi
public read-write property ColorTable: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_ColorTable();
public: __property void set_ColorTable(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ColorTable {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The table of color components.

Remarks

The color table data must be m * (maxIndex + 1) bytes long, where m is the number of color components in the base color space. Each byte is an unsigned integer in the range 0 to 255 that is scaled to the range of the corresponding color component in the base color space; that is, 0 corresponds to the minimum value in the range for that component, and 255 corresponds to the maximum.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

MaxIndex Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : MaxIndex Property

Gets or sets the maximum index for the colors in the color table.

Syntax

Visual Basic (Declaration)
Public Property MaxIndex As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value As Byte

instance.MaxIndex = value

value = instance.MaxIndex
C#
public byte MaxIndex {get; set;}
Delphi
public read-write property MaxIndex: Byte;
Managed Extensions for C++
public: __property byte get_MaxIndex();
public: __property void set_MaxIndex(
   byte value
);
C++/CLI
public:
property byte MaxIndex {
   byte get();
   void set (byte value);
}

Return Value

The maximum index that can be used to access the values in the color table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

PDFLabColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColor Class

Defines a calibrated Lab color, based on a Lab colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLabColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
C#
public class PDFLabColor : PDFExtendedColor
Delphi
public class PDFLabColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFLabColor : public PDFExtendedColor
C++/CLI
public ref class PDFLabColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFLabColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColor Class

The following tables list the members exposed by PDFLabColor.

Public Constructors

 | Name | Description
Public Constructor | PDFLabColor Constructor | Initializes a new PDFLabColor object.
Top

Public Properties

 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | L | Gets or sets the l component for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFLabColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColor Class : PDFLabColor Constructor

colorSpace
a PDFLabColorSpace object the color is based on.
Initializes a new PDFLabColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFLabColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFLabColorSpace

Dim instance As PDFLabColor(colorSpace)
C#
public PDFLabColor(
   PDFLabColorSpace colorSpace
)
Delphi
public PDFLabColor(
    colorSpace: PDFLabColorSpace
);
Managed Extensions for C++
public: PDFLabColor(
   PDFLabColorSpace* colorSpace
)
C++/CLI
public:
PDFLabColor(
   PDFLabColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFLabColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%% $$Properties$$

PDFLabColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Properties

 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | L | Gets or sets the l component for this color.
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

A Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColor Class : A Property

Gets or sets the a* component for this color.

Syntax

Visual Basic (Declaration)
Public Property A As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.A = value

value = instance.A
C#
public double A {get; set;}
Delphi
public read-write property A: Double;
Managed Extensions for C++
public: __property double get_A();
public: __property void set_A(
   double value
);
C++/CLI
public:
property double A {
   double get();
   void set (double value);
}

Return Value

The a* component of this color.

Remarks

The range for this value is defined by the PDFLabColorSpace.Range property of the underlying Lab colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%%

B Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColor Class : B Property

Gets or sets the b* component for this color.

Syntax

Visual Basic (Declaration)
Public Property B As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.B = value

value = instance.B
C#
public double B {get; set;}
Delphi
public read-write property B: Double;
Managed Extensions for C++
public: __property double get_B();
public: __property void set_B(
   double value
);
C++/CLI
public:
property double B {
   double get();
   void set (double value);
}

Return Value

The b* component of this color.

Remarks

The range for this value is defined by the PDFLabColorSpace.Range property of the underlying Lab colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%%

L Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColor Class : L Property

Gets or sets the l component for this color.

Syntax

Visual Basic (Declaration)
Public Property L As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.L = value

value = instance.L
C#
public double L {get; set;}
Delphi
public read-write property L: Double;
Managed Extensions for C++
public: __property double get_L();
public: __property void set_L(
   double value
);
C++/CLI
public:
property double L {
   double get();
   void set (double value);
}

Return Value

The l component of this color.

Remarks

The acceptable range for this value is [0.0 100.0].
0.0 means the darkest color that can be achieved, and 100.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%%

PDFLabColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

Defines a Lab colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFLabColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
C#
public class PDFLabColorSpace : PDFColorSpace
Delphi
public class PDFLabColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFLabColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFLabColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFLabColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

The following tables list the members exposed by PDFLabColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFLabColorSpace Constructor | Initializes a new PDFLabColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | WhitePoint | Gets or sets the white point.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFLabColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : PDFLabColorSpace Constructor

Initializes a new PDFLabColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace()
C#
public PDFLabColorSpace()
Delphi
public PDFLabColorSpace();
Managed Extensions for C++
public: PDFLabColorSpace();
C++/CLI
public:
PDFLabColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFLabColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

For a list of all members of this type, see PDFLabColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFLabColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

For a list of all members of this type, see PDFLabColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Delphi
public read-write property BlackPoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%%

Range Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : Range Property

Gets or sets the range.

Syntax

Visual Basic (Declaration)
Public Property Range As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
C#
public double[] Range {get; set;}
Delphi
public read-write property Range: array of Double;
Managed Extensions for C++
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
C++/CLI
public:
property array<double>^ Range {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of four numbers [amin amax bmin bmax] specifying the range of valid values for the a* and b* (B and C) components of the color space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%%

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Delphi
public read-write property WhitePoint: array of Double;
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%%

PDFPantoneColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

Defines a PANTONE color.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPantoneColor
   Inherits PDFSeparationColor
Visual Basic (Usage) Copy Code
Dim instance As PDFPantoneColor
C#
public class PDFPantoneColor : PDFSeparationColor
Delphi
public class PDFPantoneColor = class(PDFSeparationColor)
Managed Extensions for C++
public __gc class PDFPantoneColor : public PDFSeparationColor
C++/CLI
public ref class PDFPantoneColor : public PDFSeparationColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFPantoneColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

The following tables list the members exposed by PDFPantoneColor.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Properties$$

PDFPantoneColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Black Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black Property

Gets the PANTONE Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black
C#
public static PDFPantoneColor Black {get;}
Delphi
public read-only property Black: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black();
C++/CLI
public:
static property PDFPantoneColor^ Black {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black2 Property

Gets the PANTONE Black 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black2
C#
public static PDFPantoneColor Black2 {get;}
Delphi
public read-only property Black2: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black2();
C++/CLI
public:
static property PDFPantoneColor^ Black2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black3 Property

Gets the PANTONE Black 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black3
C#
public static PDFPantoneColor Black3 {get;}
Delphi
public read-only property Black3: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black3();
C++/CLI
public:
static property PDFPantoneColor^ Black3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black4 Property

Gets the PANTONE Black 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black4
C#
public static PDFPantoneColor Black4 {get;}
Delphi
public read-only property Black4: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black4();
C++/CLI
public:
static property PDFPantoneColor^ Black4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black5 Property

Gets the PANTONE Black 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black5
C#
public static PDFPantoneColor Black5 {get;}
Delphi
public read-only property Black5: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black5();
C++/CLI
public:
static property PDFPantoneColor^ Black5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black6 Property

Gets the PANTONE Black 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black6
C#
public static PDFPantoneColor Black6 {get;}
Delphi
public read-only property Black6: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black6();
C++/CLI
public:
static property PDFPantoneColor^ Black6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Black7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black7 Property

Gets the PANTONE Black 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black7
C#
public static PDFPantoneColor Black7 {get;}
Delphi
public read-only property Black7: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black7();
C++/CLI
public:
static property PDFPantoneColor^ Black7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Blue072 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Blue072 Property

Gets the PANTONE Blue 072 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Blue072 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Blue072
C#
public static PDFPantoneColor Blue072 {get;}
Delphi
public read-only property Blue072: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Blue072();
C++/CLI
public:
static property PDFPantoneColor^ Blue072 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Blue 072 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray1 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray1 Property

Gets the PANTONE Cool Gray 1 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray1 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray1
C#
public static PDFPantoneColor CoolGray1 {get;}
Delphi
public read-only property CoolGray1: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray1();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray1 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 1 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray10 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray10 Property

Gets the PANTONE Cool Gray 10 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray10 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray10
C#
public static PDFPantoneColor CoolGray10 {get;}
Delphi
public read-only property CoolGray10: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray10();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray10 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 10 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray11 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray11 Property

Gets the PANTONE Cool Gray 11 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray11 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray11
C#
public static PDFPantoneColor CoolGray11 {get;}
Delphi
public read-only property CoolGray11: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray11();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray11 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 11 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray2 Property

Gets the PANTONE Cool Gray 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray2
C#
public static PDFPantoneColor CoolGray2 {get;}
Delphi
public read-only property CoolGray2: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray2();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray3 Property

Gets the PANTONE Cool Gray 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray3
C#
public static PDFPantoneColor CoolGray3 {get;}
Delphi
public read-only property CoolGray3: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray3();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray4 Property

Gets the PANTONE Cool Gray 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray4
C#
public static PDFPantoneColor CoolGray4 {get;}
Delphi
public read-only property CoolGray4: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray4();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray5 Property

Gets the PANTONE Cool Gray 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray5
C#
public static PDFPantoneColor CoolGray5 {get;}
Delphi
public read-only property CoolGray5: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray5();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray6 Property

Gets the PANTONE Cool Gray 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray6
C#
public static PDFPantoneColor CoolGray6 {get;}
Delphi
public read-only property CoolGray6: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray6();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray7 Property

Gets the PANTONE Cool Gray 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray7
C#
public static PDFPantoneColor CoolGray7 {get;}
Delphi
public read-only property CoolGray7: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray7();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray8 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray8 Property

Gets the PANTONE Cool Gray 8 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray8 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray8
C#
public static PDFPantoneColor CoolGray8 {get;}
Delphi
public read-only property CoolGray8: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray8();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray8 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 8 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

CoolGray9 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray9 Property

Gets the PANTONE Cool Gray 9 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray9 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray9
C#
public static PDFPantoneColor CoolGray9 {get;}
Delphi
public read-only property CoolGray9: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray9();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray9 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 9 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Green Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Green Property

Gets the PANTONE Green color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Green As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Green
C#
public static PDFPantoneColor Green {get;}
Delphi
public read-only property Green: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Green();
C++/CLI
public:
static property PDFPantoneColor^ Green {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Green color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeBlack Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeBlack Property

Gets the PANTONE Hexachrome Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeBlack As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeBlack
C#
public static PDFPantoneColor HexachromeBlack {get;}
Delphi
public read-only property HexachromeBlack: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeBlack();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeBlack {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeCyan Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeCyan Property

Gets the PANTONE Hexachrome Cyan color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeCyan As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeCyan
C#
public static PDFPantoneColor HexachromeCyan {get;}
Delphi
public read-only property HexachromeCyan: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeCyan();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeCyan {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Cyan color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeGreen Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeGreen Property

Gets the PANTONE Hexachrome Green color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeGreen As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeGreen
C#
public static PDFPantoneColor HexachromeGreen {get;}
Delphi
public read-only property HexachromeGreen: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeGreen();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeGreen {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Green color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeMagenta Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeMagenta Property

Gets the PANTONE Hexachrome Magenta color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeMagenta As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeMagenta
C#
public static PDFPantoneColor HexachromeMagenta {get;}
Delphi
public read-only property HexachromeMagenta: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeMagenta();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeMagenta {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Magenta color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeOrange Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeOrange Property

Gets the PANTONE Hexachrome Orange color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeOrange As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeOrange
C#
public static PDFPantoneColor HexachromeOrange {get;}
Delphi
public read-only property HexachromeOrange: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeOrange();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeOrange {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Orange color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

HexachromeYellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeYellow Property

Gets the PANTONE Hexachrome Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeYellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeYellow
C#
public static PDFPantoneColor HexachromeYellow {get;}
Delphi
public read-only property HexachromeYellow: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeYellow();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeYellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Orange021 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Orange021 Property

Gets the PANTONE Orange 021 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Orange021 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Orange021
C#
public static PDFPantoneColor Orange021 {get;}
Delphi
public read-only property Orange021: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Orange021();
C++/CLI
public:
static property PDFPantoneColor^ Orange021 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Orange 021 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE100 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE100 Property

Gets the PANTONE 100 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE100 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE100
C#
public static PDFPantoneColor PANTONE100 {get;}
Delphi
public read-only property PANTONE100: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE100();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE100 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 100 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE101 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE101 Property

Gets the PANTONE 101 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE101 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE101
C#
public static PDFPantoneColor PANTONE101 {get;}
Delphi
public read-only property PANTONE101: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE101();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE101 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 101 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE102 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE102 Property

Gets the PANTONE 102 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE102 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE102
C#
public static PDFPantoneColor PANTONE102 {get;}
Delphi
public read-only property PANTONE102: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE102();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE102 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 102 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE103 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE103 Property

Gets the PANTONE 103 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE103 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE103
C#
public static PDFPantoneColor PANTONE103 {get;}
Delphi
public read-only property PANTONE103: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE103();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE103 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 103 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE104 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE104 Property

Gets the PANTONE 104 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE104 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE104
C#
public static PDFPantoneColor PANTONE104 {get;}
Delphi
public read-only property PANTONE104: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE104();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE104 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 104 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE105 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE105 Property

Gets the PANTONE 105 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE105 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE105
C#
public static PDFPantoneColor PANTONE105 {get;}
Delphi
public read-only property PANTONE105: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE105();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE105 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 105 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE106 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE106 Property

Gets the PANTONE 106 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE106 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE106
C#
public static PDFPantoneColor PANTONE106 {get;}
Delphi
public read-only property PANTONE106: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE106();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE106 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 106 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE107 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE107 Property

Gets the PANTONE 107 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE107 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE107
C#
public static PDFPantoneColor PANTONE107 {get;}
Delphi
public read-only property PANTONE107: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE107();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE107 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 107 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE108 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE108 Property

Gets the PANTONE 108 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE108 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE108
C#
public static PDFPantoneColor PANTONE108 {get;}
Delphi
public read-only property PANTONE108: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE108();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE108 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 108 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE109 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE109 Property

Gets the PANTONE 109 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE109 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE109
C#
public static PDFPantoneColor PANTONE109 {get;}
Delphi
public read-only property PANTONE109: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE109();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE109 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 109 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE110 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE110 Property

Gets the PANTONE 110 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE110 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE110
C#
public static PDFPantoneColor PANTONE110 {get;}
Delphi
public read-only property PANTONE110: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE110();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE110 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 110 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE111 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE111 Property

Gets the PANTONE 111 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE111 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE111
C#
public static PDFPantoneColor PANTONE111 {get;}
Delphi
public read-only property PANTONE111: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE111();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE111 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 111 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE112 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE112 Property

Gets the PANTONE 112 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE112 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE112
C#
public static PDFPantoneColor PANTONE112 {get;}
Delphi
public read-only property PANTONE112: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE112();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE112 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 112 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE113 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE113 Property

Gets the PANTONE 113 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE113 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE113
C#
public static PDFPantoneColor PANTONE113 {get;}
Delphi
public read-only property PANTONE113: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE113();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE113 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 113 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE114 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE114 Property

Gets the PANTONE 114 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE114 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE114
C#
public static PDFPantoneColor PANTONE114 {get;}
Delphi
public read-only property PANTONE114: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE114();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE114 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 114 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE115 Property

Gets the PANTONE 115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE115
C#
public static PDFPantoneColor PANTONE115 {get;}
Delphi
public read-only property PANTONE115: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE116 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE116 Property

Gets the PANTONE 116 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE116 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE116
C#
public static PDFPantoneColor PANTONE116 {get;}
Delphi
public read-only property PANTONE116: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE116();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE116 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 116 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE117 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE117 Property

Gets the PANTONE 117 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE117 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE117
C#
public static PDFPantoneColor PANTONE117 {get;}
Delphi
public read-only property PANTONE117: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE117();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE117 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 117 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE118 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE118 Property

Gets the PANTONE 118 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE118 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE118
C#
public static PDFPantoneColor PANTONE118 {get;}
Delphi
public read-only property PANTONE118: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE118();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE118 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 118 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE119 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE119 Property

Gets the PANTONE 119 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE119 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE119
C#
public static PDFPantoneColor PANTONE119 {get;}
Delphi
public read-only property PANTONE119: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE119();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE119 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 119 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE120 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE120 Property

Gets the PANTONE 120 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE120 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE120
C#
public static PDFPantoneColor PANTONE120 {get;}
Delphi
public read-only property PANTONE120: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE120();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE120 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 120 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1205 Property

Gets the PANTONE 1205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1205
C#
public static PDFPantoneColor PANTONE1205 {get;}
Delphi
public read-only property PANTONE1205: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE121 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE121 Property

Gets the PANTONE 121 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE121 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE121
C#
public static PDFPantoneColor PANTONE121 {get;}
Delphi
public read-only property PANTONE121: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE121();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE121 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 121 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1215 Property

Gets the PANTONE 1215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1215
C#
public static PDFPantoneColor PANTONE1215 {get;}
Delphi
public read-only property PANTONE1215: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE122 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE122 Property

Gets the PANTONE 122 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE122 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE122
C#
public static PDFPantoneColor PANTONE122 {get;}
Delphi
public read-only property PANTONE122: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE122();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE122 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 122 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1225 Property

Gets the PANTONE 1225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1225
C#
public static PDFPantoneColor PANTONE1225 {get;}
Delphi
public read-only property PANTONE1225: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE123 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE123 Property

Gets the PANTONE 123 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE123 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE123
C#
public static PDFPantoneColor PANTONE123 {get;}
Delphi
public read-only property PANTONE123: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE123();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE123 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 123 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1235 Property

Gets the PANTONE 1235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1235
C#
public static PDFPantoneColor PANTONE1235 {get;}
Delphi
public read-only property PANTONE1235: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE124 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE124 Property

Gets the PANTONE 124 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE124 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE124
C#
public static PDFPantoneColor PANTONE124 {get;}
Delphi
public read-only property PANTONE124: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE124();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE124 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 124 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1245 Property

Gets the PANTONE 1245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1245
C#
public static PDFPantoneColor PANTONE1245 {get;}
Delphi
public read-only property PANTONE1245: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE125 Property

Gets the PANTONE 125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE125
C#
public static PDFPantoneColor PANTONE125 {get;}
Delphi
public read-only property PANTONE125: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1255 Property

Gets the PANTONE 1255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1255
C#
public static PDFPantoneColor PANTONE1255 {get;}
Delphi
public read-only property PANTONE1255: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE126 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE126 Property

Gets the PANTONE 126 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE126 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE126
C#
public static PDFPantoneColor PANTONE126 {get;}
Delphi
public read-only property PANTONE126: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE126();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE126 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 126 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1265 Property

Gets the PANTONE 1265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1265
C#
public static PDFPantoneColor PANTONE1265 {get;}
Delphi
public read-only property PANTONE1265: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE127 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE127 Property

Gets the PANTONE 127 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE127 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE127
C#
public static PDFPantoneColor PANTONE127 {get;}
Delphi
public read-only property PANTONE127: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE127();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE127 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 127 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE128 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE128 Property

Gets the PANTONE 128 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE128 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE128
C#
public static PDFPantoneColor PANTONE128 {get;}
Delphi
public read-only property PANTONE128: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE128();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE128 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 128 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE129 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE129 Property

Gets the PANTONE 129 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE129 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE129
C#
public static PDFPantoneColor PANTONE129 {get;}
Delphi
public read-only property PANTONE129: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE129();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE129 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 129 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE130 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE130 Property

Gets the PANTONE 130 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE130 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE130
C#
public static PDFPantoneColor PANTONE130 {get;}
Delphi
public read-only property PANTONE130: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE130();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE130 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 130 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE131 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE131 Property

Gets the PANTONE 131 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE131 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE131
C#
public static PDFPantoneColor PANTONE131 {get;}
Delphi
public read-only property PANTONE131: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE131();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE131 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 131 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE132 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE132 Property

Gets the PANTONE 132 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE132 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE132
C#
public static PDFPantoneColor PANTONE132 {get;}
Delphi
public read-only property PANTONE132: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE132();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE132 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 132 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE133 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE133 Property

Gets the PANTONE 133 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE133 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE133
C#
public static PDFPantoneColor PANTONE133 {get;}
Delphi
public read-only property PANTONE133: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE133();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE133 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 133 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE134 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE134 Property

Gets the PANTONE 134 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE134 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE134
C#
public static PDFPantoneColor PANTONE134 {get;}
Delphi
public read-only property PANTONE134: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE134();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE134 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 134 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1345 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1345 Property

Gets the PANTONE 1345 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1345 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1345
C#
public static PDFPantoneColor PANTONE1345 {get;}
Delphi
public read-only property PANTONE1345: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1345();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1345 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1345 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE135 Property

Gets the PANTONE 135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE135
C#
public static PDFPantoneColor PANTONE135 {get;}
Delphi
public read-only property PANTONE135: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1355 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1355 Property

Gets the PANTONE 1355 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1355 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1355
C#
public static PDFPantoneColor PANTONE1355 {get;}
Delphi
public read-only property PANTONE1355: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1355();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1355 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1355 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE136 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE136 Property

Gets the PANTONE 136 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE136 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE136
C#
public static PDFPantoneColor PANTONE136 {get;}
Delphi
public read-only property PANTONE136: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE136();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE136 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 136 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1365 Property

Gets the PANTONE 1365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1365
C#
public static PDFPantoneColor PANTONE1365 {get;}
Delphi
public read-only property PANTONE1365: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE137 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE137 Property

Gets the PANTONE 137 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE137 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE137
C#
public static PDFPantoneColor PANTONE137 {get;}
Delphi
public read-only property PANTONE137: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE137();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE137 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 137 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1375 Property

Gets the PANTONE 1375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1375
C#
public static PDFPantoneColor PANTONE1375 {get;}
Delphi
public read-only property PANTONE1375: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE138 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE138 Property

Gets the PANTONE 138 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE138 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE138
C#
public static PDFPantoneColor PANTONE138 {get;}
Delphi
public read-only property PANTONE138: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE138();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE138 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 138 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1385 Property

Gets the PANTONE 1385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1385
C#
public static PDFPantoneColor PANTONE1385 {get;}
Delphi
public read-only property PANTONE1385: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE139 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE139 Property

Gets the PANTONE 139 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE139 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE139
C#
public static PDFPantoneColor PANTONE139 {get;}
Delphi
public read-only property PANTONE139: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE139();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE139 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 139 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1395 Property

Gets the PANTONE 1395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1395
C#
public static PDFPantoneColor PANTONE1395 {get;}
Delphi
public read-only property PANTONE1395: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE140 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE140 Property

Gets the PANTONE 140 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE140 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE140
C#
public static PDFPantoneColor PANTONE140 {get;}
Delphi
public read-only property PANTONE140: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE140();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE140 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 140 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1405 Property

Gets the PANTONE 1405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1405
C#
public static PDFPantoneColor PANTONE1405 {get;}
Delphi
public read-only property PANTONE1405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE141 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE141 Property

Gets the PANTONE 141 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE141 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE141
C#
public static PDFPantoneColor PANTONE141 {get;}
Delphi
public read-only property PANTONE141: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE141();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE141 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 141 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE142 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE142 Property

Gets the PANTONE 142 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE142 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE142
C#
public static PDFPantoneColor PANTONE142 {get;}
Delphi
public read-only property PANTONE142: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE142();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE142 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 142 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE143 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE143 Property

Gets the PANTONE 143 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE143 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE143
C#
public static PDFPantoneColor PANTONE143 {get;}
Delphi
public read-only property PANTONE143: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE143();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE143 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 143 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE144 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE144 Property

Gets the PANTONE 144 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE144 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE144
C#
public static PDFPantoneColor PANTONE144 {get;}
Delphi
public read-only property PANTONE144: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE144();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE144 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 144 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE145 Property

Gets the PANTONE 145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE145
C#
public static PDFPantoneColor PANTONE145 {get;}
Delphi
public read-only property PANTONE145: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE146 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE146 Property

Gets the PANTONE 146 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE146 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE146
C#
public static PDFPantoneColor PANTONE146 {get;}
Delphi
public read-only property PANTONE146: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE146();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE146 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 146 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE147 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE147 Property

Gets the PANTONE 147 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE147 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE147
C#
public static PDFPantoneColor PANTONE147 {get;}
Delphi
public read-only property PANTONE147: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE147();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE147 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 147 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE148 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE148 Property

Gets the PANTONE 148 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE148 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE148
C#
public static PDFPantoneColor PANTONE148 {get;}
Delphi
public read-only property PANTONE148: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE148();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE148 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 148 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1485 Property

Gets the PANTONE 1485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1485
C#
public static PDFPantoneColor PANTONE1485 {get;}
Delphi
public read-only property PANTONE1485: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE149 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE149 Property

Gets the PANTONE 149 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE149 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE149
C#
public static PDFPantoneColor PANTONE149 {get;}
Delphi
public read-only property PANTONE149: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE149();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE149 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 149 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1495 Property

Gets the PANTONE 1495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1495
C#
public static PDFPantoneColor PANTONE1495 {get;}
Delphi
public read-only property PANTONE1495: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE150 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE150 Property

Gets the PANTONE 150 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE150 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE150
C#
public static PDFPantoneColor PANTONE150 {get;}
Delphi
public read-only property PANTONE150: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE150();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE150 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 150 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1505 Property

Gets the PANTONE 1505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1505
C#
public static PDFPantoneColor PANTONE1505 {get;}
Delphi
public read-only property PANTONE1505: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE151 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE151 Property

Gets the PANTONE 151 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE151 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE151
C#
public static PDFPantoneColor PANTONE151 {get;}
Delphi
public read-only property PANTONE151: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE151();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE151 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 151 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE152 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE152 Property

Gets the PANTONE 152 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE152 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE152
C#
public static PDFPantoneColor PANTONE152 {get;}
Delphi
public read-only property PANTONE152: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE152();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE152 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 152 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1525 Property

Gets the PANTONE 1525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1525
C#
public static PDFPantoneColor PANTONE1525 {get;}
Delphi
public read-only property PANTONE1525: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE153 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE153 Property

Gets the PANTONE 153 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE153 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE153
C#
public static PDFPantoneColor PANTONE153 {get;}
Delphi
public read-only property PANTONE153: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE153();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE153 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 153 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1535 Property

Gets the PANTONE 1535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1535
C#
public static PDFPantoneColor PANTONE1535 {get;}
Delphi
public read-only property PANTONE1535: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE154 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE154 Property

Gets the PANTONE 154 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE154 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE154
C#
public static PDFPantoneColor PANTONE154 {get;}
Delphi
public read-only property PANTONE154: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE154();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE154 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 154 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1545 Property

Gets the PANTONE 1545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1545
C#
public static PDFPantoneColor PANTONE1545 {get;}
Delphi
public read-only property PANTONE1545: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE155 Property

Gets the PANTONE 155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE155
C#
public static PDFPantoneColor PANTONE155 {get;}
Delphi
public read-only property PANTONE155: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1555 Property

Gets the PANTONE 1555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1555
C#
public static PDFPantoneColor PANTONE1555 {get;}
Delphi
public read-only property PANTONE1555: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE156 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE156 Property

Gets the PANTONE 156 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE156 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE156
C#
public static PDFPantoneColor PANTONE156 {get;}
Delphi
public read-only property PANTONE156: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE156();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE156 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 156 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1565 Property

Gets the PANTONE 1565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1565
C#
public static PDFPantoneColor PANTONE1565 {get;}
Delphi
public read-only property PANTONE1565: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE157 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE157 Property

Gets the PANTONE 157 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE157 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE157
C#
public static PDFPantoneColor PANTONE157 {get;}
Delphi
public read-only property PANTONE157: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE157();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE157 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 157 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1575 Property

Gets the PANTONE 1575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1575
C#
public static PDFPantoneColor PANTONE1575 {get;}
Delphi
public read-only property PANTONE1575: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE158 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE158 Property

Gets the PANTONE 158 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE158 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE158
C#
public static PDFPantoneColor PANTONE158 {get;}
Delphi
public read-only property PANTONE158: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE158();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE158 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 158 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1585 Property

Gets the PANTONE 1585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1585
C#
public static PDFPantoneColor PANTONE1585 {get;}
Delphi
public read-only property PANTONE1585: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE159 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE159 Property

Gets the PANTONE 159 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE159 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE159
C#
public static PDFPantoneColor PANTONE159 {get;}
Delphi
public read-only property PANTONE159: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE159();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE159 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 159 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1595 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1595 Property

Gets the PANTONE 1595 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1595 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1595
C#
public static PDFPantoneColor PANTONE1595 {get;}
Delphi
public read-only property PANTONE1595: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1595();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1595 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1595 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE160 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE160 Property

Gets the PANTONE 160 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE160 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE160
C#
public static PDFPantoneColor PANTONE160 {get;}
Delphi
public read-only property PANTONE160: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE160();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE160 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 160 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1605 Property

Gets the PANTONE 1605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1605
C#
public static PDFPantoneColor PANTONE1605 {get;}
Delphi
public read-only property PANTONE1605: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE161 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE161 Property

Gets the PANTONE 161 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE161 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE161
C#
public static PDFPantoneColor PANTONE161 {get;}
Delphi
public read-only property PANTONE161: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE161();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE161 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 161 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1615 Property

Gets the PANTONE 1615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1615
C#
public static PDFPantoneColor PANTONE1615 {get;}
Delphi
public read-only property PANTONE1615: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE162 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE162 Property

Gets the PANTONE 162 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE162 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE162
C#
public static PDFPantoneColor PANTONE162 {get;}
Delphi
public read-only property PANTONE162: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE162();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE162 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 162 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1625 Property

Gets the PANTONE 1625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1625
C#
public static PDFPantoneColor PANTONE1625 {get;}
Delphi
public read-only property PANTONE1625: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE163 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE163 Property

Gets the PANTONE 163 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE163 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE163
C#
public static PDFPantoneColor PANTONE163 {get;}
Delphi
public read-only property PANTONE163: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE163();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE163 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 163 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1635 Property

Gets the PANTONE 1635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1635
C#
public static PDFPantoneColor PANTONE1635 {get;}
Delphi
public read-only property PANTONE1635: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE164 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE164 Property

Gets the PANTONE 164 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE164 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE164
C#
public static PDFPantoneColor PANTONE164 {get;}
Delphi
public read-only property PANTONE164: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE164();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE164 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 164 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1645 Property

Gets the PANTONE 1645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1645
C#
public static PDFPantoneColor PANTONE1645 {get;}
Delphi
public read-only property PANTONE1645: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE165 Property

Gets the PANTONE 165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE165
C#
public static PDFPantoneColor PANTONE165 {get;}
Delphi
public read-only property PANTONE165: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1655 Property

Gets the PANTONE 1655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1655
C#
public static PDFPantoneColor PANTONE1655 {get;}
Delphi
public read-only property PANTONE1655: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE166 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE166 Property

Gets the PANTONE 166 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE166 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE166
C#
public static PDFPantoneColor PANTONE166 {get;}
Delphi
public read-only property PANTONE166: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE166();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE166 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 166 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1665 Property

Gets the PANTONE 1665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1665
C#
public static PDFPantoneColor PANTONE1665 {get;}
Delphi
public read-only property PANTONE1665: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE167 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE167 Property

Gets the PANTONE 167 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE167 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE167
C#
public static PDFPantoneColor PANTONE167 {get;}
Delphi
public read-only property PANTONE167: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE167();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE167 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 167 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1675 Property

Gets the PANTONE 1675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1675
C#
public static PDFPantoneColor PANTONE1675 {get;}
Delphi
public read-only property PANTONE1675: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE168 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE168 Property

Gets the PANTONE 168 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE168 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE168
C#
public static PDFPantoneColor PANTONE168 {get;}
Delphi
public read-only property PANTONE168: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE168();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE168 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 168 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1685 Property

Gets the PANTONE 1685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1685
C#
public static PDFPantoneColor PANTONE1685 {get;}
Delphi
public read-only property PANTONE1685: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE169 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE169 Property

Gets the PANTONE 169 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE169 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE169
C#
public static PDFPantoneColor PANTONE169 {get;}
Delphi
public read-only property PANTONE169: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE169();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE169 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 169 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE170 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE170 Property

Gets the PANTONE 170 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE170 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE170
C#
public static PDFPantoneColor PANTONE170 {get;}
Delphi
public read-only property PANTONE170: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE170();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE170 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 170 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE171 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE171 Property

Gets the PANTONE 171 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE171 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE171
C#
public static PDFPantoneColor PANTONE171 {get;}
Delphi
public read-only property PANTONE171: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE171();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE171 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 171 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE172 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE172 Property

Gets the PANTONE 172 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE172 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE172
C#
public static PDFPantoneColor PANTONE172 {get;}
Delphi
public read-only property PANTONE172: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE172();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE172 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 172 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE173 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE173 Property

Gets the PANTONE 173 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE173 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE173
C#
public static PDFPantoneColor PANTONE173 {get;}
Delphi
public read-only property PANTONE173: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE173();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE173 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 173 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE174 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE174 Property

Gets the PANTONE 174 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE174 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE174
C#
public static PDFPantoneColor PANTONE174 {get;}
Delphi
public read-only property PANTONE174: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE174();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE174 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 174 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE175 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE175 Property

Gets the PANTONE 175 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE175 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE175
C#
public static PDFPantoneColor PANTONE175 {get;}
Delphi
public read-only property PANTONE175: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE175();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE175 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 175 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE176 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE176 Property

Gets the PANTONE 176 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE176 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE176
C#
public static PDFPantoneColor PANTONE176 {get;}
Delphi
public read-only property PANTONE176: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE176();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE176 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 176 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1765 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1765 Property

Gets the PANTONE 1765 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1765 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1765
C#
public static PDFPantoneColor PANTONE1765 {get;}
Delphi
public read-only property PANTONE1765: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1765();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1765 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1765 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1767 Property

Gets the PANTONE 1767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1767
C#
public static PDFPantoneColor PANTONE1767 {get;}
Delphi
public read-only property PANTONE1767: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE177 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE177 Property

Gets the PANTONE 177 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE177 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE177
C#
public static PDFPantoneColor PANTONE177 {get;}
Delphi
public read-only property PANTONE177: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE177();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE177 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 177 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1775 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1775 Property

Gets the PANTONE 1775 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1775 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1775
C#
public static PDFPantoneColor PANTONE1775 {get;}
Delphi
public read-only property PANTONE1775: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1775();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1775 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1775 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1777 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1777 Property

Gets the PANTONE 1777 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1777 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1777
C#
public static PDFPantoneColor PANTONE1777 {get;}
Delphi
public read-only property PANTONE1777: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1777();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1777 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1777 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE178 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE178 Property

Gets the PANTONE 178 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE178 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE178
C#
public static PDFPantoneColor PANTONE178 {get;}
Delphi
public read-only property PANTONE178: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE178();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE178 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 178 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1785 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1785 Property

Gets the PANTONE 1785 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1785 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1785
C#
public static PDFPantoneColor PANTONE1785 {get;}
Delphi
public read-only property PANTONE1785: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1785();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1785 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1785 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1787 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1787 Property

Gets the PANTONE 1787 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1787 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1787
C#
public static PDFPantoneColor PANTONE1787 {get;}
Delphi
public read-only property PANTONE1787: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1787();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1787 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1787 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1788 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1788 Property

Gets the PANTONE 1788 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1788 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1788
C#
public static PDFPantoneColor PANTONE1788 {get;}
Delphi
public read-only property PANTONE1788: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1788();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1788 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1788 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE179 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE179 Property

Gets the PANTONE 179 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE179 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE179
C#
public static PDFPantoneColor PANTONE179 {get;}
Delphi
public read-only property PANTONE179: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE179();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE179 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 179 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1795 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1795 Property

Gets the PANTONE 1795 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1795 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1795
C#
public static PDFPantoneColor PANTONE1795 {get;}
Delphi
public read-only property PANTONE1795: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1795();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1795 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1795 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1797 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1797 Property

Gets the PANTONE 1797 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1797 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1797
C#
public static PDFPantoneColor PANTONE1797 {get;}
Delphi
public read-only property PANTONE1797: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1797();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1797 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1797 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE180 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE180 Property

Gets the PANTONE 180 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE180 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE180
C#
public static PDFPantoneColor PANTONE180 {get;}
Delphi
public read-only property PANTONE180: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE180();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE180 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 180 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1805 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1805 Property

Gets the PANTONE 1805 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1805 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1805
C#
public static PDFPantoneColor PANTONE1805 {get;}
Delphi
public read-only property PANTONE1805: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1805();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1805 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1805 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1807 Property

Gets the PANTONE 1807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1807
C#
public static PDFPantoneColor PANTONE1807 {get;}
Delphi
public read-only property PANTONE1807: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE181 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE181 Property

Gets the PANTONE 181 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE181 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE181
C#
public static PDFPantoneColor PANTONE181 {get;}
Delphi
public read-only property PANTONE181: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE181();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE181 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 181 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1815 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1815 Property

Gets the PANTONE 1815 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1815 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1815
C#
public static PDFPantoneColor PANTONE1815 {get;}
Delphi
public read-only property PANTONE1815: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1815();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1815 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1815 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1817 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1817 Property

Gets the PANTONE 1817 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1817 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1817
C#
public static PDFPantoneColor PANTONE1817 {get;}
Delphi
public read-only property PANTONE1817: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1817();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1817 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1817 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE182 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE182 Property

Gets the PANTONE 182 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE182 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE182
C#
public static PDFPantoneColor PANTONE182 {get;}
Delphi
public read-only property PANTONE182: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE182();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE182 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 182 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE183 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE183 Property

Gets the PANTONE 183 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE183 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE183
C#
public static PDFPantoneColor PANTONE183 {get;}
Delphi
public read-only property PANTONE183: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE183();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE183 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 183 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE184 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE184 Property

Gets the PANTONE 184 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE184 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE184
C#
public static PDFPantoneColor PANTONE184 {get;}
Delphi
public read-only property PANTONE184: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE184();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE184 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 184 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE185 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE185 Property

Gets the PANTONE 185 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE185 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE185
C#
public static PDFPantoneColor PANTONE185 {get;}
Delphi
public read-only property PANTONE185: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE185();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE185 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 185 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE186 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE186 Property

Gets the PANTONE 186 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE186 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE186
C#
public static PDFPantoneColor PANTONE186 {get;}
Delphi
public read-only property PANTONE186: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE186();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE186 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 186 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE187 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE187 Property

Gets the PANTONE 187 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE187 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE187
C#
public static PDFPantoneColor PANTONE187 {get;}
Delphi
public read-only property PANTONE187: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE187();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE187 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 187 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE188 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE188 Property

Gets the PANTONE 188 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE188 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE188
C#
public static PDFPantoneColor PANTONE188 {get;}
Delphi
public read-only property PANTONE188: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE188();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE188 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 188 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE189 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE189 Property

Gets the PANTONE 189 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE189 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE189
C#
public static PDFPantoneColor PANTONE189 {get;}
Delphi
public read-only property PANTONE189: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE189();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE189 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 189 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1895 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1895 Property

Gets the PANTONE 1895 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1895 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1895
C#
public static PDFPantoneColor PANTONE1895 {get;}
Delphi
public read-only property PANTONE1895: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1895();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1895 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1895 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE190 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE190 Property

Gets the PANTONE 190 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE190 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE190
C#
public static PDFPantoneColor PANTONE190 {get;}
Delphi
public read-only property PANTONE190: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE190();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE190 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 190 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1905 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1905 Property

Gets the PANTONE 1905 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1905 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1905
C#
public static PDFPantoneColor PANTONE1905 {get;}
Delphi
public read-only property PANTONE1905: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1905();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1905 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1905 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE191 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE191 Property

Gets the PANTONE 191 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE191 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE191
C#
public static PDFPantoneColor PANTONE191 {get;}
Delphi
public read-only property PANTONE191: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE191();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE191 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 191 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1915 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1915 Property

Gets the PANTONE 1915 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1915 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1915
C#
public static PDFPantoneColor PANTONE1915 {get;}
Delphi
public read-only property PANTONE1915: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1915();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1915 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1915 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE192 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE192 Property

Gets the PANTONE 192 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE192 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE192
C#
public static PDFPantoneColor PANTONE192 {get;}
Delphi
public read-only property PANTONE192: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE192();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE192 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 192 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1925 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1925 Property

Gets the PANTONE 1925 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1925 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1925
C#
public static PDFPantoneColor PANTONE1925 {get;}
Delphi
public read-only property PANTONE1925: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1925();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1925 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1925 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE193 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE193 Property

Gets the PANTONE 193 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE193 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE193
C#
public static PDFPantoneColor PANTONE193 {get;}
Delphi
public read-only property PANTONE193: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE193();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE193 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 193 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1935 Property

Gets the PANTONE 1935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1935
C#
public static PDFPantoneColor PANTONE1935 {get;}
Delphi
public read-only property PANTONE1935: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE194 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE194 Property

Gets the PANTONE 194 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE194 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE194
C#
public static PDFPantoneColor PANTONE194 {get;}
Delphi
public read-only property PANTONE194: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE194();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE194 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 194 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1945 Property

Gets the PANTONE 1945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1945
C#
public static PDFPantoneColor PANTONE1945 {get;}
Delphi
public read-only property PANTONE1945: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE195 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE195 Property

Gets the PANTONE 195 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE195 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE195
C#
public static PDFPantoneColor PANTONE195 {get;}
Delphi
public read-only property PANTONE195: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE195();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE195 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 195 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE1955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1955 Property

Gets the PANTONE 1955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1955
C#
public static PDFPantoneColor PANTONE1955 {get;}
Delphi
public read-only property PANTONE1955: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE196 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE196 Property

Gets the PANTONE 196 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE196 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE196
C#
public static PDFPantoneColor PANTONE196 {get;}
Delphi
public read-only property PANTONE196: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE196();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE196 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 196 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE197 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE197 Property

Gets the PANTONE 197 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE197 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE197
C#
public static PDFPantoneColor PANTONE197 {get;}
Delphi
public read-only property PANTONE197: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE197();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE197 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 197 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE198 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE198 Property

Gets the PANTONE 198 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE198 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE198
C#
public static PDFPantoneColor PANTONE198 {get;}
Delphi
public read-only property PANTONE198: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE198();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE198 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 198 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE199 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE199 Property

Gets the PANTONE 199 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE199 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE199
C#
public static PDFPantoneColor PANTONE199 {get;}
Delphi
public read-only property PANTONE199: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE199();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE199 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 199 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE200 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE200 Property

Gets the PANTONE 200 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE200 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE200
C#
public static PDFPantoneColor PANTONE200 {get;}
Delphi
public read-only property PANTONE200: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE200();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE200 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 200 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE201 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE201 Property

Gets the PANTONE 201 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE201 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE201
C#
public static PDFPantoneColor PANTONE201 {get;}
Delphi
public read-only property PANTONE201: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE201();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE201 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 201 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE202 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE202 Property

Gets the PANTONE 202 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE202 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE202
C#
public static PDFPantoneColor PANTONE202 {get;}
Delphi
public read-only property PANTONE202: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE202();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE202 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 202 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE203 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE203 Property

Gets the PANTONE 203 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE203 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE203
C#
public static PDFPantoneColor PANTONE203 {get;}
Delphi
public read-only property PANTONE203: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE203();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE203 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 203 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE204 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE204 Property

Gets the PANTONE 204 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE204 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE204
C#
public static PDFPantoneColor PANTONE204 {get;}
Delphi
public read-only property PANTONE204: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE204();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE204 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 204 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE205 Property

Gets the PANTONE 205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE205
C#
public static PDFPantoneColor PANTONE205 {get;}
Delphi
public read-only property PANTONE205: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE206 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE206 Property

Gets the PANTONE 206 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE206 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE206
C#
public static PDFPantoneColor PANTONE206 {get;}
Delphi
public read-only property PANTONE206: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE206();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE206 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 206 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE207 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE207 Property

Gets the PANTONE 207 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE207 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE207
C#
public static PDFPantoneColor PANTONE207 {get;}
Delphi
public read-only property PANTONE207: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE207();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE207 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 207 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE208 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE208 Property

Gets the PANTONE 208 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE208 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE208
C#
public static PDFPantoneColor PANTONE208 {get;}
Delphi
public read-only property PANTONE208: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE208();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE208 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 208 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE209 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE209 Property

Gets the PANTONE 209 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE209 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE209
C#
public static PDFPantoneColor PANTONE209 {get;}
Delphi
public read-only property PANTONE209: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE209();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE209 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 209 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE210 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE210 Property

Gets the PANTONE 210 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE210 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE210
C#
public static PDFPantoneColor PANTONE210 {get;}
Delphi
public read-only property PANTONE210: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE210();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE210 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 210 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE211 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE211 Property

Gets the PANTONE 211 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE211 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE211
C#
public static PDFPantoneColor PANTONE211 {get;}
Delphi
public read-only property PANTONE211: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE211();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE211 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 211 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE212 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE212 Property

Gets the PANTONE 212 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE212 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE212
C#
public static PDFPantoneColor PANTONE212 {get;}
Delphi
public read-only property PANTONE212: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE212();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE212 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 212 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE213 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE213 Property

Gets the PANTONE 213 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE213 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE213
C#
public static PDFPantoneColor PANTONE213 {get;}
Delphi
public read-only property PANTONE213: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE213();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE213 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 213 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE214 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE214 Property

Gets the PANTONE 214 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE214 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE214
C#
public static PDFPantoneColor PANTONE214 {get;}
Delphi
public read-only property PANTONE214: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE214();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE214 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 214 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE215 Property

Gets the PANTONE 215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE215
C#
public static PDFPantoneColor PANTONE215 {get;}
Delphi
public read-only property PANTONE215: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE216 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE216 Property

Gets the PANTONE 216 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE216 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE216
C#
public static PDFPantoneColor PANTONE216 {get;}
Delphi
public read-only property PANTONE216: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE216();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE216 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 216 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE217 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE217 Property

Gets the PANTONE 217 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE217 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE217
C#
public static PDFPantoneColor PANTONE217 {get;}
Delphi
public read-only property PANTONE217: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE217();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE217 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 217 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE218 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE218 Property

Gets the PANTONE 218 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE218 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE218
C#
public static PDFPantoneColor PANTONE218 {get;}
Delphi
public read-only property PANTONE218: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE218();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE218 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 218 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE219 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE219 Property

Gets the PANTONE 219 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE219 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE219
C#
public static PDFPantoneColor PANTONE219 {get;}
Delphi
public read-only property PANTONE219: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE219();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE219 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 219 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE220 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE220 Property

Gets the PANTONE 220 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE220 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE220
C#
public static PDFPantoneColor PANTONE220 {get;}
Delphi
public read-only property PANTONE220: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE220();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE220 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 220 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE221 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE221 Property

Gets the PANTONE 221 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE221 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE221
C#
public static PDFPantoneColor PANTONE221 {get;}
Delphi
public read-only property PANTONE221: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE221();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE221 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 221 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE222 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE222 Property

Gets the PANTONE 222 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE222 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE222
C#
public static PDFPantoneColor PANTONE222 {get;}
Delphi
public read-only property PANTONE222: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE222();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE222 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 222 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE223 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE223 Property

Gets the PANTONE 223 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE223 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE223
C#
public static PDFPantoneColor PANTONE223 {get;}
Delphi
public read-only property PANTONE223: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE223();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE223 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 223 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE224 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE224 Property

Gets the PANTONE 224 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE224 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE224
C#
public static PDFPantoneColor PANTONE224 {get;}
Delphi
public read-only property PANTONE224: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE224();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE224 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 224 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE225 Property

Gets the PANTONE 225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE225
C#
public static PDFPantoneColor PANTONE225 {get;}
Delphi
public read-only property PANTONE225: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE226 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE226 Property

Gets the PANTONE 226 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE226 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE226
C#
public static PDFPantoneColor PANTONE226 {get;}
Delphi
public read-only property PANTONE226: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE226();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE226 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 226 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE227 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE227 Property

Gets the PANTONE 227 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE227 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE227
C#
public static PDFPantoneColor PANTONE227 {get;}
Delphi
public read-only property PANTONE227: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE227();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE227 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 227 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE228 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE228 Property

Gets the PANTONE 228 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE228 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE228
C#
public static PDFPantoneColor PANTONE228 {get;}
Delphi
public read-only property PANTONE228: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE228();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE228 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 228 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE229 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE229 Property

Gets the PANTONE 229 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE229 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE229
C#
public static PDFPantoneColor PANTONE229 {get;}
Delphi
public read-only property PANTONE229: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE229();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE229 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 229 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE230 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE230 Property

Gets the PANTONE 230 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE230 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE230
C#
public static PDFPantoneColor PANTONE230 {get;}
Delphi
public read-only property PANTONE230: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE230();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE230 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 230 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE231 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE231 Property

Gets the PANTONE 231 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE231 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE231
C#
public static PDFPantoneColor PANTONE231 {get;}
Delphi
public read-only property PANTONE231: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE231();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE231 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 231 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE232 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE232 Property

Gets the PANTONE 232 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE232 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE232
C#
public static PDFPantoneColor PANTONE232 {get;}
Delphi
public read-only property PANTONE232: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE232();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE232 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 232 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE233 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE233 Property

Gets the PANTONE 233 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE233 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE233
C#
public static PDFPantoneColor PANTONE233 {get;}
Delphi
public read-only property PANTONE233: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE233();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE233 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 233 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE234 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE234 Property

Gets the PANTONE 234 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE234 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE234
C#
public static PDFPantoneColor PANTONE234 {get;}
Delphi
public read-only property PANTONE234: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE234();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE234 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 234 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE235 Property

Gets the PANTONE 235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE235
C#
public static PDFPantoneColor PANTONE235 {get;}
Delphi
public read-only property PANTONE235: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE236 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE236 Property

Gets the PANTONE 236 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE236 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE236
C#
public static PDFPantoneColor PANTONE236 {get;}
Delphi
public read-only property PANTONE236: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE236();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE236 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 236 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2365 Property

Gets the PANTONE 2365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2365
C#
public static PDFPantoneColor PANTONE2365 {get;}
Delphi
public read-only property PANTONE2365: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE237 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE237 Property

Gets the PANTONE 237 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE237 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE237
C#
public static PDFPantoneColor PANTONE237 {get;}
Delphi
public read-only property PANTONE237: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE237();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE237 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 237 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2375 Property

Gets the PANTONE 2375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2375
C#
public static PDFPantoneColor PANTONE2375 {get;}
Delphi
public read-only property PANTONE2375: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE238 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE238 Property

Gets the PANTONE 238 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE238 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE238
C#
public static PDFPantoneColor PANTONE238 {get;}
Delphi
public read-only property PANTONE238: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE238();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE238 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 238 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2385 Property

Gets the PANTONE 2385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2385
C#
public static PDFPantoneColor PANTONE2385 {get;}
Delphi
public read-only property PANTONE2385: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE239 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE239 Property

Gets the PANTONE 239 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE239 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE239
C#
public static PDFPantoneColor PANTONE239 {get;}
Delphi
public read-only property PANTONE239: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE239();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE239 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 239 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2395 Property

Gets the PANTONE 2395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2395
C#
public static PDFPantoneColor PANTONE2395 {get;}
Delphi
public read-only property PANTONE2395: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE240 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE240 Property

Gets the PANTONE 240 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE240 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE240
C#
public static PDFPantoneColor PANTONE240 {get;}
Delphi
public read-only property PANTONE240: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE240();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE240 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 240 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2405 Property

Gets the PANTONE 2405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2405
C#
public static PDFPantoneColor PANTONE2405 {get;}
Delphi
public read-only property PANTONE2405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE241 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE241 Property

Gets the PANTONE 241 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE241 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE241
C#
public static PDFPantoneColor PANTONE241 {get;}
Delphi
public read-only property PANTONE241: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE241();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE241 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 241 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2415 Property

Gets the PANTONE 2415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2415
C#
public static PDFPantoneColor PANTONE2415 {get;}
Delphi
public read-only property PANTONE2415: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE242 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE242 Property

Gets the PANTONE 242 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE242 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE242
C#
public static PDFPantoneColor PANTONE242 {get;}
Delphi
public read-only property PANTONE242: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE242();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE242 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 242 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2425 Property

Gets the PANTONE 2425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2425
C#
public static PDFPantoneColor PANTONE2425 {get;}
Delphi
public read-only property PANTONE2425: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE243 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE243 Property

Gets the PANTONE 243 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE243 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE243
C#
public static PDFPantoneColor PANTONE243 {get;}
Delphi
public read-only property PANTONE243: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE243();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE243 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 243 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE244 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE244 Property

Gets the PANTONE 244 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE244 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE244
C#
public static PDFPantoneColor PANTONE244 {get;}
Delphi
public read-only property PANTONE244: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE244();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE244 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 244 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE245 Property

Gets the PANTONE 245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE245
C#
public static PDFPantoneColor PANTONE245 {get;}
Delphi
public read-only property PANTONE245: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE246 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE246 Property

Gets the PANTONE 246 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE246 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE246
C#
public static PDFPantoneColor PANTONE246 {get;}
Delphi
public read-only property PANTONE246: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE246();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE246 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 246 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE247 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE247 Property

Gets the PANTONE 247 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE247 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE247
C#
public static PDFPantoneColor PANTONE247 {get;}
Delphi
public read-only property PANTONE247: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE247();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE247 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 247 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE248 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE248 Property

Gets the PANTONE 248 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE248 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE248
C#
public static PDFPantoneColor PANTONE248 {get;}
Delphi
public read-only property PANTONE248: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE248();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE248 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 248 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE249 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE249 Property

Gets the PANTONE 249 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE249 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE249
C#
public static PDFPantoneColor PANTONE249 {get;}
Delphi
public read-only property PANTONE249: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE249();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE249 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 249 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE250 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE250 Property

Gets the PANTONE 250 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE250 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE250
C#
public static PDFPantoneColor PANTONE250 {get;}
Delphi
public read-only property PANTONE250: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE250();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE250 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 250 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE251 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE251 Property

Gets the PANTONE 251 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE251 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE251
C#
public static PDFPantoneColor PANTONE251 {get;}
Delphi
public read-only property PANTONE251: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE251();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE251 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 251 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE252 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE252 Property

Gets the PANTONE 252 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE252 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE252
C#
public static PDFPantoneColor PANTONE252 {get;}
Delphi
public read-only property PANTONE252: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE252();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE252 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 252 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE253 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE253 Property

Gets the PANTONE 253 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE253 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE253
C#
public static PDFPantoneColor PANTONE253 {get;}
Delphi
public read-only property PANTONE253: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE253();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE253 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 253 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE254 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE254 Property

Gets the PANTONE 254 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE254 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE254
C#
public static PDFPantoneColor PANTONE254 {get;}
Delphi
public read-only property PANTONE254: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE254();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE254 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 254 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE255 Property

Gets the PANTONE 255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE255
C#
public static PDFPantoneColor PANTONE255 {get;}
Delphi
public read-only property PANTONE255: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE256 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE256 Property

Gets the PANTONE 256 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE256 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE256
C#
public static PDFPantoneColor PANTONE256 {get;}
Delphi
public read-only property PANTONE256: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE256();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE256 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 256 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2562 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2562 Property

Gets the PANTONE 2562 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2562 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2562
C#
public static PDFPantoneColor PANTONE2562 {get;}
Delphi
public read-only property PANTONE2562: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2562();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2562 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2562 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2563 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2563 Property

Gets the PANTONE 2563 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2563 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2563
C#
public static PDFPantoneColor PANTONE2563 {get;}
Delphi
public read-only property PANTONE2563: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2563();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2563 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2563 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2567 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2567 Property

Gets the PANTONE 2567 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2567 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2567
C#
public static PDFPantoneColor PANTONE2567 {get;}
Delphi
public read-only property PANTONE2567: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2567();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2567 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2567 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE257 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE257 Property

Gets the PANTONE 257 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE257 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE257
C#
public static PDFPantoneColor PANTONE257 {get;}
Delphi
public read-only property PANTONE257: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE257();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE257 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 257 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2572 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2572 Property

Gets the PANTONE 2572 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2572 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2572
C#
public static PDFPantoneColor PANTONE2572 {get;}
Delphi
public read-only property PANTONE2572: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2572();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2572 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2572 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2573 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2573 Property

Gets the PANTONE 2573 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2573 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2573
C#
public static PDFPantoneColor PANTONE2573 {get;}
Delphi
public read-only property PANTONE2573: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2573();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2573 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2573 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2577 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2577 Property

Gets the PANTONE 2577 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2577 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2577
C#
public static PDFPantoneColor PANTONE2577 {get;}
Delphi
public read-only property PANTONE2577: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2577();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2577 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2577 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE258 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE258 Property

Gets the PANTONE 258 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE258 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE258
C#
public static PDFPantoneColor PANTONE258 {get;}
Delphi
public read-only property PANTONE258: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE258();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE258 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 258 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2582 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2582 Property

Gets the PANTONE 2582 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2582 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2582
C#
public static PDFPantoneColor PANTONE2582 {get;}
Delphi
public read-only property PANTONE2582: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2582();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2582 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2582 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2583 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2583 Property

Gets the PANTONE 2583 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2583 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2583
C#
public static PDFPantoneColor PANTONE2583 {get;}
Delphi
public read-only property PANTONE2583: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2583();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2583 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2583 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2587 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2587 Property

Gets the PANTONE 2587 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2587 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2587
C#
public static PDFPantoneColor PANTONE2587 {get;}
Delphi
public read-only property PANTONE2587: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2587();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2587 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2587 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE259 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE259 Property

Gets the PANTONE 259 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE259 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE259
C#
public static PDFPantoneColor PANTONE259 {get;}
Delphi
public read-only property PANTONE259: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE259();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE259 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 259 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2592 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2592 Property

Gets the PANTONE 2592 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2592 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2592
C#
public static PDFPantoneColor PANTONE2592 {get;}
Delphi
public read-only property PANTONE2592: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2592();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2592 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2592 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2593 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2593 Property

Gets the PANTONE 2593 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2593 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2593
C#
public static PDFPantoneColor PANTONE2593 {get;}
Delphi
public read-only property PANTONE2593: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2593();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2593 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2593 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2597 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2597 Property

Gets the PANTONE 2597 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2597 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2597
C#
public static PDFPantoneColor PANTONE2597 {get;}
Delphi
public read-only property PANTONE2597: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2597();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2597 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2597 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE260 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE260 Property

Gets the PANTONE 260 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE260 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE260
C#
public static PDFPantoneColor PANTONE260 {get;}
Delphi
public read-only property PANTONE260: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE260();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE260 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 260 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2602 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2602 Property

Gets the PANTONE 2602 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2602 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2602
C#
public static PDFPantoneColor PANTONE2602 {get;}
Delphi
public read-only property PANTONE2602: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2602();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2602 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2602 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2603 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2603 Property

Gets the PANTONE 2603 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2603 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2603
C#
public static PDFPantoneColor PANTONE2603 {get;}
Delphi
public read-only property PANTONE2603: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2603();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2603 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2603 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2607 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2607 Property

Gets the PANTONE 2607 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2607 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2607
C#
public static PDFPantoneColor PANTONE2607 {get;}
Delphi
public read-only property PANTONE2607: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2607();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2607 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2607 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE261 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE261 Property

Gets the PANTONE 261 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE261 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE261
C#
public static PDFPantoneColor PANTONE261 {get;}
Delphi
public read-only property PANTONE261: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE261();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE261 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 261 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2612 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2612 Property

Gets the PANTONE 2612 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2612 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2612
C#
public static PDFPantoneColor PANTONE2612 {get;}
Delphi
public read-only property PANTONE2612: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2612();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2612 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2612 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2613 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2613 Property

Gets the PANTONE 2613 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2613 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2613
C#
public static PDFPantoneColor PANTONE2613 {get;}
Delphi
public read-only property PANTONE2613: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2613();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2613 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2613 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2617 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2617 Property

Gets the PANTONE 2617 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2617 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2617
C#
public static PDFPantoneColor PANTONE2617 {get;}
Delphi
public read-only property PANTONE2617: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2617();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2617 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2617 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE262 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE262 Property

Gets the PANTONE 262 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE262 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE262
C#
public static PDFPantoneColor PANTONE262 {get;}
Delphi
public read-only property PANTONE262: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE262();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE262 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 262 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2622 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2622 Property

Gets the PANTONE 2622 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2622 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2622
C#
public static PDFPantoneColor PANTONE2622 {get;}
Delphi
public read-only property PANTONE2622: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2622();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2622 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2622 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2623 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2623 Property

Gets the PANTONE 2623 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2623 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2623
C#
public static PDFPantoneColor PANTONE2623 {get;}
Delphi
public read-only property PANTONE2623: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2623();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2623 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2623 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2627 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2627 Property

Gets the PANTONE 2627 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2627 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2627
C#
public static PDFPantoneColor PANTONE2627 {get;}
Delphi
public read-only property PANTONE2627: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2627();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2627 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2627 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE263 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE263 Property

Gets the PANTONE 263 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE263 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE263
C#
public static PDFPantoneColor PANTONE263 {get;}
Delphi
public read-only property PANTONE263: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE263();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE263 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 263 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2635 Property

Gets the PANTONE 2635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2635
C#
public static PDFPantoneColor PANTONE2635 {get;}
Delphi
public read-only property PANTONE2635: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE264 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE264 Property

Gets the PANTONE 264 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE264 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE264
C#
public static PDFPantoneColor PANTONE264 {get;}
Delphi
public read-only property PANTONE264: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE264();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE264 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 264 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2645 Property

Gets the PANTONE 2645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2645
C#
public static PDFPantoneColor PANTONE2645 {get;}
Delphi
public read-only property PANTONE2645: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE265 Property

Gets the PANTONE 265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE265
C#
public static PDFPantoneColor PANTONE265 {get;}
Delphi
public read-only property PANTONE265: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2655 Property

Gets the PANTONE 2655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2655
C#
public static PDFPantoneColor PANTONE2655 {get;}
Delphi
public read-only property PANTONE2655: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE266 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE266 Property

Gets the PANTONE 266 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE266 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE266
C#
public static PDFPantoneColor PANTONE266 {get;}
Delphi
public read-only property PANTONE266: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE266();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE266 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 266 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2665 Property

Gets the PANTONE 2665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2665
C#
public static PDFPantoneColor PANTONE2665 {get;}
Delphi
public read-only property PANTONE2665: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE267 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE267 Property

Gets the PANTONE 267 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE267 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE267
C#
public static PDFPantoneColor PANTONE267 {get;}
Delphi
public read-only property PANTONE267: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE267();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE267 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 267 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE268 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE268 Property

Gets the PANTONE 268 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE268 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE268
C#
public static PDFPantoneColor PANTONE268 {get;}
Delphi
public read-only property PANTONE268: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE268();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE268 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 268 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2685 Property

Gets the PANTONE 2685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2685
C#
public static PDFPantoneColor PANTONE2685 {get;}
Delphi
public read-only property PANTONE2685: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE269 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE269 Property

Gets the PANTONE 269 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE269 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE269
C#
public static PDFPantoneColor PANTONE269 {get;}
Delphi
public read-only property PANTONE269: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE269();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE269 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 269 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2695 Property

Gets the PANTONE 2695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2695
C#
public static PDFPantoneColor PANTONE2695 {get;}
Delphi
public read-only property PANTONE2695: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE270 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE270 Property

Gets the PANTONE 270 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE270 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE270
C#
public static PDFPantoneColor PANTONE270 {get;}
Delphi
public read-only property PANTONE270: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE270();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE270 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 270 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2705 Property

Gets the PANTONE 2705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2705
C#
public static PDFPantoneColor PANTONE2705 {get;}
Delphi
public read-only property PANTONE2705: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2706 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2706 Property

Gets the PANTONE 2706 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2706 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2706
C#
public static PDFPantoneColor PANTONE2706 {get;}
Delphi
public read-only property PANTONE2706: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2706();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2706 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2706 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2707 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2707 Property

Gets the PANTONE 2707 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2707 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2707
C#
public static PDFPantoneColor PANTONE2707 {get;}
Delphi
public read-only property PANTONE2707: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2707();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2707 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2707 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2708 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2708 Property

Gets the PANTONE 2708 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2708 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2708
C#
public static PDFPantoneColor PANTONE2708 {get;}
Delphi
public read-only property PANTONE2708: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2708();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2708 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2708 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE271 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE271 Property

Gets the PANTONE 271 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE271 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE271
C#
public static PDFPantoneColor PANTONE271 {get;}
Delphi
public read-only property PANTONE271: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE271();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE271 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 271 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2715 Property

Gets the PANTONE 2715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2715
C#
public static PDFPantoneColor PANTONE2715 {get;}
Delphi
public read-only property PANTONE2715: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2716 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2716 Property

Gets the PANTONE 2716 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2716 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2716
C#
public static PDFPantoneColor PANTONE2716 {get;}
Delphi
public read-only property PANTONE2716: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2716();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2716 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2716 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2717 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2717 Property

Gets the PANTONE 2717 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2717 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2717
C#
public static PDFPantoneColor PANTONE2717 {get;}
Delphi
public read-only property PANTONE2717: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2717();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2717 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2717 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2718 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2718 Property

Gets the PANTONE 2718 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2718 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2718
C#
public static PDFPantoneColor PANTONE2718 {get;}
Delphi
public read-only property PANTONE2718: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2718();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2718 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2718 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE272 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE272 Property

Gets the PANTONE 272 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE272 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE272
C#
public static PDFPantoneColor PANTONE272 {get;}
Delphi
public read-only property PANTONE272: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE272();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE272 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 272 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2725 Property

Gets the PANTONE 2725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2725
C#
public static PDFPantoneColor PANTONE2725 {get;}
Delphi
public read-only property PANTONE2725: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2726 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2726 Property

Gets the PANTONE 2726 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2726 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2726
C#
public static PDFPantoneColor PANTONE2726 {get;}
Delphi
public read-only property PANTONE2726: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2726();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2726 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2726 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2727 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2727 Property

Gets the PANTONE 2727 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2727 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2727
C#
public static PDFPantoneColor PANTONE2727 {get;}
Delphi
public read-only property PANTONE2727: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2727();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2727 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2727 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2728 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2728 Property

Gets the PANTONE 2728 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2728 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2728
C#
public static PDFPantoneColor PANTONE2728 {get;}
Delphi
public read-only property PANTONE2728: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2728();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2728 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2728 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE273 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE273 Property

Gets the PANTONE 273 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE273 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE273
C#
public static PDFPantoneColor PANTONE273 {get;}
Delphi
public read-only property PANTONE273: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE273();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE273 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 273 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2735 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2735 Property

Gets the PANTONE 2735 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2735 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2735
C#
public static PDFPantoneColor PANTONE2735 {get;}
Delphi
public read-only property PANTONE2735: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2735();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2735 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2735 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2736 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2736 Property

Gets the PANTONE 2736 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2736 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2736
C#
public static PDFPantoneColor PANTONE2736 {get;}
Delphi
public read-only property PANTONE2736: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2736();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2736 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2736 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2738 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2738 Property

Gets the PANTONE 2738 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2738 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2738
C#
public static PDFPantoneColor PANTONE2738 {get;}
Delphi
public read-only property PANTONE2738: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2738();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2738 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2738 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE274 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE274 Property

Gets the PANTONE 274 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE274 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE274
C#
public static PDFPantoneColor PANTONE274 {get;}
Delphi
public read-only property PANTONE274: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE274();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE274 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 274 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2745 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2745 Property

Gets the PANTONE 2745 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2745 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2745
C#
public static PDFPantoneColor PANTONE2745 {get;}
Delphi
public read-only property PANTONE2745: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2745();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2745 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2745 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2746 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2746 Property

Gets the PANTONE 2746 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2746 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2746
C#
public static PDFPantoneColor PANTONE2746 {get;}
Delphi
public read-only property PANTONE2746: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2746();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2746 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2746 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2747 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2747 Property

Gets the PANTONE 2747 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2747 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2747
C#
public static PDFPantoneColor PANTONE2747 {get;}
Delphi
public read-only property PANTONE2747: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2747();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2747 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2747 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2748 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2748 Property

Gets the PANTONE 2748 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2748 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2748
C#
public static PDFPantoneColor PANTONE2748 {get;}
Delphi
public read-only property PANTONE2748: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2748();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2748 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2748 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE275 Property

Gets the PANTONE 275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE275
C#
public static PDFPantoneColor PANTONE275 {get;}
Delphi
public read-only property PANTONE275: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2755 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2755 Property

Gets the PANTONE 2755 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2755 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2755
C#
public static PDFPantoneColor PANTONE2755 {get;}
Delphi
public read-only property PANTONE2755: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2755();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2755 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2755 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2756 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2756 Property

Gets the PANTONE 2756 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2756 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2756
C#
public static PDFPantoneColor PANTONE2756 {get;}
Delphi
public read-only property PANTONE2756: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2756();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2756 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2756 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2757 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2757 Property

Gets the PANTONE 2757 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2757 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2757
C#
public static PDFPantoneColor PANTONE2757 {get;}
Delphi
public read-only property PANTONE2757: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2757();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2757 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2757 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2758 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2758 Property

Gets the PANTONE 2758 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2758 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2758
C#
public static PDFPantoneColor PANTONE2758 {get;}
Delphi
public read-only property PANTONE2758: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2758();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2758 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2758 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE276 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE276 Property

Gets the PANTONE 276 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE276 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE276
C#
public static PDFPantoneColor PANTONE276 {get;}
Delphi
public read-only property PANTONE276: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE276();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE276 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 276 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2765 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2765 Property

Gets the PANTONE 2765 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2765 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2765
C#
public static PDFPantoneColor PANTONE2765 {get;}
Delphi
public read-only property PANTONE2765: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2765();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2765 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2765 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2766 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2766 Property

Gets the PANTONE 2766 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2766 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2766
C#
public static PDFPantoneColor PANTONE2766 {get;}
Delphi
public read-only property PANTONE2766: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2766();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2766 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2766 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2767 Property

Gets the PANTONE 2767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2767
C#
public static PDFPantoneColor PANTONE2767 {get;}
Delphi
public read-only property PANTONE2767: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2768 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2768 Property

Gets the PANTONE 2768 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2768 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2768
C#
public static PDFPantoneColor PANTONE2768 {get;}
Delphi
public read-only property PANTONE2768: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2768();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2768 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2768 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE277 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE277 Property

Gets the PANTONE 277 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE277 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE277
C#
public static PDFPantoneColor PANTONE277 {get;}
Delphi
public read-only property PANTONE277: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE277();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE277 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 277 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE278 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE278 Property

Gets the PANTONE 278 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE278 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE278
C#
public static PDFPantoneColor PANTONE278 {get;}
Delphi
public read-only property PANTONE278: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE278();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE278 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 278 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE279 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE279 Property

Gets the PANTONE 279 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE279 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE279
C#
public static PDFPantoneColor PANTONE279 {get;}
Delphi
public read-only property PANTONE279: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE279();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE279 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 279 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE280 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE280 Property

Gets the PANTONE 280 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE280 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE280
C#
public static PDFPantoneColor PANTONE280 {get;}
Delphi
public read-only property PANTONE280: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE280();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE280 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 280 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE281 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE281 Property

Gets the PANTONE 281 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE281 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE281
C#
public static PDFPantoneColor PANTONE281 {get;}
Delphi
public read-only property PANTONE281: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE281();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE281 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 281 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE282 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE282 Property

Gets the PANTONE 282 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE282 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE282
C#
public static PDFPantoneColor PANTONE282 {get;}
Delphi
public read-only property PANTONE282: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE282();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE282 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 282 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE283 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE283 Property

Gets the PANTONE 283 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE283 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE283
C#
public static PDFPantoneColor PANTONE283 {get;}
Delphi
public read-only property PANTONE283: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE283();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE283 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 283 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE284 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE284 Property

Gets the PANTONE 284 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE284 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE284
C#
public static PDFPantoneColor PANTONE284 {get;}
Delphi
public read-only property PANTONE284: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE284();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE284 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 284 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE285 Property

Gets the PANTONE 285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE285
C#
public static PDFPantoneColor PANTONE285 {get;}
Delphi
public read-only property PANTONE285: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE286 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE286 Property

Gets the PANTONE 286 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE286 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE286
C#
public static PDFPantoneColor PANTONE286 {get;}
Delphi
public read-only property PANTONE286: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE286();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE286 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 286 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE287 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE287 Property

Gets the PANTONE 287 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE287 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE287
C#
public static PDFPantoneColor PANTONE287 {get;}
Delphi
public read-only property PANTONE287: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE287();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE287 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 287 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE288 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE288 Property

Gets the PANTONE 288 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE288 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE288
C#
public static PDFPantoneColor PANTONE288 {get;}
Delphi
public read-only property PANTONE288: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE288();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE288 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 288 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE289 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE289 Property

Gets the PANTONE 289 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE289 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE289
C#
public static PDFPantoneColor PANTONE289 {get;}
Delphi
public read-only property PANTONE289: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE289();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE289 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 289 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE290 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE290 Property

Gets the PANTONE 290 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE290 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE290
C#
public static PDFPantoneColor PANTONE290 {get;}
Delphi
public read-only property PANTONE290: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE290();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE290 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 290 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2905 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2905 Property

Gets the PANTONE 2905 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2905 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2905
C#
public static PDFPantoneColor PANTONE2905 {get;}
Delphi
public read-only property PANTONE2905: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2905();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2905 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2905 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE291 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE291 Property

Gets the PANTONE 291 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE291 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE291
C#
public static PDFPantoneColor PANTONE291 {get;}
Delphi
public read-only property PANTONE291: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE291();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE291 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 291 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2915 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2915 Property

Gets the PANTONE 2915 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2915 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2915
C#
public static PDFPantoneColor PANTONE2915 {get;}
Delphi
public read-only property PANTONE2915: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2915();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2915 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2915 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE292 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE292 Property

Gets the PANTONE 292 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE292 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE292
C#
public static PDFPantoneColor PANTONE292 {get;}
Delphi
public read-only property PANTONE292: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE292();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE292 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 292 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2925 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2925 Property

Gets the PANTONE 2925 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2925 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2925
C#
public static PDFPantoneColor PANTONE2925 {get;}
Delphi
public read-only property PANTONE2925: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2925();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2925 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2925 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE293 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE293 Property

Gets the PANTONE 293 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE293 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE293
C#
public static PDFPantoneColor PANTONE293 {get;}
Delphi
public read-only property PANTONE293: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE293();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE293 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 293 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2935 Property

Gets the PANTONE 2935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2935
C#
public static PDFPantoneColor PANTONE2935 {get;}
Delphi
public read-only property PANTONE2935: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE294 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE294 Property

Gets the PANTONE 294 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE294 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE294
C#
public static PDFPantoneColor PANTONE294 {get;}
Delphi
public read-only property PANTONE294: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE294();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE294 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 294 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2945 Property

Gets the PANTONE 2945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2945
C#
public static PDFPantoneColor PANTONE2945 {get;}
Delphi
public read-only property PANTONE2945: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE295 Property

Gets the PANTONE 295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE295
C#
public static PDFPantoneColor PANTONE295 {get;}
Delphi
public read-only property PANTONE295: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2955 Property

Gets the PANTONE 2955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2955
C#
public static PDFPantoneColor PANTONE2955 {get;}
Delphi
public read-only property PANTONE2955: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE296 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE296 Property

Gets the PANTONE 296 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE296 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE296
C#
public static PDFPantoneColor PANTONE296 {get;}
Delphi
public read-only property PANTONE296: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE296();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE296 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 296 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2965 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2965 Property

Gets the PANTONE 2965 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2965 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2965
C#
public static PDFPantoneColor PANTONE2965 {get;}
Delphi
public read-only property PANTONE2965: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2965();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2965 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2965 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE297 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE297 Property

Gets the PANTONE 297 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE297 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE297
C#
public static PDFPantoneColor PANTONE297 {get;}
Delphi
public read-only property PANTONE297: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE297();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE297 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 297 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2975 Property

Gets the PANTONE 2975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2975
C#
public static PDFPantoneColor PANTONE2975 {get;}
Delphi
public read-only property PANTONE2975: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE298 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE298 Property

Gets the PANTONE 298 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE298 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE298
C#
public static PDFPantoneColor PANTONE298 {get;}
Delphi
public read-only property PANTONE298: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE298();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE298 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 298 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2985 Property

Gets the PANTONE 2985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2985
C#
public static PDFPantoneColor PANTONE2985 {get;}
Delphi
public read-only property PANTONE2985: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE299 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE299 Property

Gets the PANTONE 299 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE299 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE299
C#
public static PDFPantoneColor PANTONE299 {get;}
Delphi
public read-only property PANTONE299: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE299();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE299 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 299 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE2995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2995 Property

Gets the PANTONE 2995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2995
C#
public static PDFPantoneColor PANTONE2995 {get;}
Delphi
public read-only property PANTONE2995: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE300 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE300 Property

Gets the PANTONE 300 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE300 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE300
C#
public static PDFPantoneColor PANTONE300 {get;}
Delphi
public read-only property PANTONE300: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE300();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE300 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 300 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3005 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3005 Property

Gets the PANTONE 3005 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3005 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3005
C#
public static PDFPantoneColor PANTONE3005 {get;}
Delphi
public read-only property PANTONE3005: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3005();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3005 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3005 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE301 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE301 Property

Gets the PANTONE 301 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE301 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE301
C#
public static PDFPantoneColor PANTONE301 {get;}
Delphi
public read-only property PANTONE301: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE301();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE301 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 301 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3015 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3015 Property

Gets the PANTONE 3015 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3015 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3015
C#
public static PDFPantoneColor PANTONE3015 {get;}
Delphi
public read-only property PANTONE3015: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3015();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3015 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3015 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE302 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE302 Property

Gets the PANTONE 302 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE302 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE302
C#
public static PDFPantoneColor PANTONE302 {get;}
Delphi
public read-only property PANTONE302: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE302();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE302 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 302 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3025 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3025 Property

Gets the PANTONE 3025 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3025 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3025
C#
public static PDFPantoneColor PANTONE3025 {get;}
Delphi
public read-only property PANTONE3025: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3025();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3025 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3025 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE303 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE303 Property

Gets the PANTONE 303 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE303 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE303
C#
public static PDFPantoneColor PANTONE303 {get;}
Delphi
public read-only property PANTONE303: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE303();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE303 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 303 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3035 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3035 Property

Gets the PANTONE 3035 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3035 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3035
C#
public static PDFPantoneColor PANTONE3035 {get;}
Delphi
public read-only property PANTONE3035: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3035();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3035 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3035 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE304 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE304 Property

Gets the PANTONE 304 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE304 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE304
C#
public static PDFPantoneColor PANTONE304 {get;}
Delphi
public read-only property PANTONE304: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE304();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE304 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 304 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE305 Property

Gets the PANTONE 305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE305
C#
public static PDFPantoneColor PANTONE305 {get;}
Delphi
public read-only property PANTONE305: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE306 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE306 Property

Gets the PANTONE 306 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE306 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE306
C#
public static PDFPantoneColor PANTONE306 {get;}
Delphi
public read-only property PANTONE306: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE306();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE306 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 306 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE307 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE307 Property

Gets the PANTONE 307 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE307 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE307
C#
public static PDFPantoneColor PANTONE307 {get;}
Delphi
public read-only property PANTONE307: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE307();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE307 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 307 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE308 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE308 Property

Gets the PANTONE 308 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE308 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE308
C#
public static PDFPantoneColor PANTONE308 {get;}
Delphi
public read-only property PANTONE308: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE308();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE308 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 308 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE309 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE309 Property

Gets the PANTONE 309 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE309 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE309
C#
public static PDFPantoneColor PANTONE309 {get;}
Delphi
public read-only property PANTONE309: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE309();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE309 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 309 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE310 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE310 Property

Gets the PANTONE 310 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE310 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE310
C#
public static PDFPantoneColor PANTONE310 {get;}
Delphi
public read-only property PANTONE310: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE310();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE310 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 310 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3105 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3105 Property

Gets the PANTONE 3105 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3105 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3105
C#
public static PDFPantoneColor PANTONE3105 {get;}
Delphi
public read-only property PANTONE3105: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3105();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3105 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3105 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE311 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE311 Property

Gets the PANTONE 311 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE311 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE311
C#
public static PDFPantoneColor PANTONE311 {get;}
Delphi
public read-only property PANTONE311: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE311();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE311 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 311 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3115 Property

Gets the PANTONE 3115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3115
C#
public static PDFPantoneColor PANTONE3115 {get;}
Delphi
public read-only property PANTONE3115: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE312 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE312 Property

Gets the PANTONE 312 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE312 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE312
C#
public static PDFPantoneColor PANTONE312 {get;}
Delphi
public read-only property PANTONE312: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE312();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE312 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 312 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3125 Property

Gets the PANTONE 3125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3125
C#
public static PDFPantoneColor PANTONE3125 {get;}
Delphi
public read-only property PANTONE3125: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE313 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE313 Property

Gets the PANTONE 313 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE313 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE313
C#
public static PDFPantoneColor PANTONE313 {get;}
Delphi
public read-only property PANTONE313: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE313();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE313 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 313 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3135 Property

Gets the PANTONE 3135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3135
C#
public static PDFPantoneColor PANTONE3135 {get;}
Delphi
public read-only property PANTONE3135: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE314 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE314 Property

Gets the PANTONE 314 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE314 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE314
C#
public static PDFPantoneColor PANTONE314 {get;}
Delphi
public read-only property PANTONE314: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE314();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE314 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 314 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3145 Property

Gets the PANTONE 3145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3145
C#
public static PDFPantoneColor PANTONE3145 {get;}
Delphi
public read-only property PANTONE3145: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE315 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE315 Property

Gets the PANTONE 315 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE315 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE315
C#
public static PDFPantoneColor PANTONE315 {get;}
Delphi
public read-only property PANTONE315: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE315();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE315 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 315 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3155 Property

Gets the PANTONE 3155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3155
C#
public static PDFPantoneColor PANTONE3155 {get;}
Delphi
public read-only property PANTONE3155: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE316 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE316 Property

Gets the PANTONE 316 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE316 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE316
C#
public static PDFPantoneColor PANTONE316 {get;}
Delphi
public read-only property PANTONE316: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE316();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE316 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 316 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3165 Property

Gets the PANTONE 3165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3165
C#
public static PDFPantoneColor PANTONE3165 {get;}
Delphi
public read-only property PANTONE3165: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE317 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE317 Property

Gets the PANTONE 317 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE317 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE317
C#
public static PDFPantoneColor PANTONE317 {get;}
Delphi
public read-only property PANTONE317: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE317();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE317 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 317 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE318 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE318 Property

Gets the PANTONE 318 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE318 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE318
C#
public static PDFPantoneColor PANTONE318 {get;}
Delphi
public read-only property PANTONE318: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE318();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE318 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 318 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE319 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE319 Property

Gets the PANTONE 319 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE319 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE319
C#
public static PDFPantoneColor PANTONE319 {get;}
Delphi
public read-only property PANTONE319: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE319();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE319 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 319 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE320 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE320 Property

Gets the PANTONE 320 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE320 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE320
C#
public static PDFPantoneColor PANTONE320 {get;}
Delphi
public read-only property PANTONE320: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE320();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE320 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 320 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE321 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE321 Property

Gets the PANTONE 321 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE321 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE321
C#
public static PDFPantoneColor PANTONE321 {get;}
Delphi
public read-only property PANTONE321: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE321();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE321 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 321 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE322 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE322 Property

Gets the PANTONE 322 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE322 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE322
C#
public static PDFPantoneColor PANTONE322 {get;}
Delphi
public read-only property PANTONE322: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE322();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE322 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 322 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE323 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE323 Property

Gets the PANTONE 323 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE323 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE323
C#
public static PDFPantoneColor PANTONE323 {get;}
Delphi
public read-only property PANTONE323: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE323();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE323 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 323 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE324 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE324 Property

Gets the PANTONE 324 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE324 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE324
C#
public static PDFPantoneColor PANTONE324 {get;}
Delphi
public read-only property PANTONE324: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE324();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE324 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 324 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3242 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3242 Property

Gets the PANTONE 3242 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3242 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3242
C#
public static PDFPantoneColor PANTONE3242 {get;}
Delphi
public read-only property PANTONE3242: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3242();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3242 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3242 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3245 Property

Gets the PANTONE 3245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3245
C#
public static PDFPantoneColor PANTONE3245 {get;}
Delphi
public read-only property PANTONE3245: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3248 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3248 Property

Gets the PANTONE 3248 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3248 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3248
C#
public static PDFPantoneColor PANTONE3248 {get;}
Delphi
public read-only property PANTONE3248: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3248();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3248 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3248 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE325 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE325 Property

Gets the PANTONE 325 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE325 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE325
C#
public static PDFPantoneColor PANTONE325 {get;}
Delphi
public read-only property PANTONE325: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE325();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE325 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 325 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3252 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3252 Property

Gets the PANTONE 3252 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3252 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3252
C#
public static PDFPantoneColor PANTONE3252 {get;}
Delphi
public read-only property PANTONE3252: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3252();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3252 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3252 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3255 Property

Gets the PANTONE 3255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3255
C#
public static PDFPantoneColor PANTONE3255 {get;}
Delphi
public read-only property PANTONE3255: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3258 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3258 Property

Gets the PANTONE 3258 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3258 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3258
C#
public static PDFPantoneColor PANTONE3258 {get;}
Delphi
public read-only property PANTONE3258: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3258();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3258 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3258 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE326 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE326 Property

Gets the PANTONE 326 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE326 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE326
C#
public static PDFPantoneColor PANTONE326 {get;}
Delphi
public read-only property PANTONE326: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE326();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE326 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 326 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3262 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3262 Property

Gets the PANTONE 3262 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3262 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3262
C#
public static PDFPantoneColor PANTONE3262 {get;}
Delphi
public read-only property PANTONE3262: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3262();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3262 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3262 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3265 Property

Gets the PANTONE 3265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3265
C#
public static PDFPantoneColor PANTONE3265 {get;}
Delphi
public read-only property PANTONE3265: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3268 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3268 Property

Gets the PANTONE 3268 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3268 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3268
C#
public static PDFPantoneColor PANTONE3268 {get;}
Delphi
public read-only property PANTONE3268: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3268();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3268 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3268 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE327 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE327 Property

Gets the PANTONE 327 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE327 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE327
C#
public static PDFPantoneColor PANTONE327 {get;}
Delphi
public read-only property PANTONE327: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE327();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE327 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 327 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3272 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3272 Property

Gets the PANTONE 3272 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3272 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3272
C#
public static PDFPantoneColor PANTONE3272 {get;}
Delphi
public read-only property PANTONE3272: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3272();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3272 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3272 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3275 Property

Gets the PANTONE 3275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3275
C#
public static PDFPantoneColor PANTONE3275 {get;}
Delphi
public read-only property PANTONE3275: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3278 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3278 Property

Gets the PANTONE 3278 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3278 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3278
C#
public static PDFPantoneColor PANTONE3278 {get;}
Delphi
public read-only property PANTONE3278: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3278();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3278 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3278 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE328 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE328 Property

Gets the PANTONE 328 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE328 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE328
C#
public static PDFPantoneColor PANTONE328 {get;}
Delphi
public read-only property PANTONE328: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE328();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE328 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 328 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3282 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3282 Property

Gets the PANTONE 3282 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3282 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3282
C#
public static PDFPantoneColor PANTONE3282 {get;}
Delphi
public read-only property PANTONE3282: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3282();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3282 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3282 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3285 Property

Gets the PANTONE 3285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3285
C#
public static PDFPantoneColor PANTONE3285 {get;}
Delphi
public read-only property PANTONE3285: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3288 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3288 Property

Gets the PANTONE 3288 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3288 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3288
C#
public static PDFPantoneColor PANTONE3288 {get;}
Delphi
public read-only property PANTONE3288: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3288();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3288 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3288 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE329 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE329 Property

Gets the PANTONE 329 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE329 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE329
C#
public static PDFPantoneColor PANTONE329 {get;}
Delphi
public read-only property PANTONE329: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE329();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE329 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 329 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3292 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3292 Property

Gets the PANTONE 3292 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3292 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3292
C#
public static PDFPantoneColor PANTONE3292 {get;}
Delphi
public read-only property PANTONE3292: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3292();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3292 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3292 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3295 Property

Gets the PANTONE 3295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3295
C#
public static PDFPantoneColor PANTONE3295 {get;}
Delphi
public read-only property PANTONE3295: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3298 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3298 Property

Gets the PANTONE 3298 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3298 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3298
C#
public static PDFPantoneColor PANTONE3298 {get;}
Delphi
public read-only property PANTONE3298: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3298();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3298 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3298 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE330 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE330 Property

Gets the PANTONE 330 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE330 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE330
C#
public static PDFPantoneColor PANTONE330 {get;}
Delphi
public read-only property PANTONE330: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE330();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE330 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 330 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3302 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3302 Property

Gets the PANTONE 3302 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3302 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3302
C#
public static PDFPantoneColor PANTONE3302 {get;}
Delphi
public read-only property PANTONE3302: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3302();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3302 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3302 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3305 Property

Gets the PANTONE 3305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3305
C#
public static PDFPantoneColor PANTONE3305 {get;}
Delphi
public read-only property PANTONE3305: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3308 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3308 Property

Gets the PANTONE 3308 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3308 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3308
C#
public static PDFPantoneColor PANTONE3308 {get;}
Delphi
public read-only property PANTONE3308: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3308();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3308 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3308 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE331 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE331 Property

Gets the PANTONE 331 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE331 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE331
C#
public static PDFPantoneColor PANTONE331 {get;}
Delphi
public read-only property PANTONE331: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE331();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE331 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 331 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE332 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE332 Property

Gets the PANTONE 332 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE332 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE332
C#
public static PDFPantoneColor PANTONE332 {get;}
Delphi
public read-only property PANTONE332: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE332();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE332 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 332 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE333 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE333 Property

Gets the PANTONE 333 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE333 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE333
C#
public static PDFPantoneColor PANTONE333 {get;}
Delphi
public read-only property PANTONE333: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE333();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE333 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 333 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE334 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE334 Property

Gets the PANTONE 334 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE334 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE334
C#
public static PDFPantoneColor PANTONE334 {get;}
Delphi
public read-only property PANTONE334: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE334();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE334 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 334 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE335 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE335 Property

Gets the PANTONE 335 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE335 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE335
C#
public static PDFPantoneColor PANTONE335 {get;}
Delphi
public read-only property PANTONE335: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE335();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE335 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 335 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE336 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE336 Property

Gets the PANTONE 336 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE336 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE336
C#
public static PDFPantoneColor PANTONE336 {get;}
Delphi
public read-only property PANTONE336: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE336();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE336 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 336 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE337 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE337 Property

Gets the PANTONE 337 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE337 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE337
C#
public static PDFPantoneColor PANTONE337 {get;}
Delphi
public read-only property PANTONE337: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE337();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE337 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 337 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3375 Property

Gets the PANTONE 3375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3375
C#
public static PDFPantoneColor PANTONE3375 {get;}
Delphi
public read-only property PANTONE3375: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE338 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE338 Property

Gets the PANTONE 338 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE338 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE338
C#
public static PDFPantoneColor PANTONE338 {get;}
Delphi
public read-only property PANTONE338: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE338();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE338 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 338 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3385 Property

Gets the PANTONE 3385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3385
C#
public static PDFPantoneColor PANTONE3385 {get;}
Delphi
public read-only property PANTONE3385: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE339 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE339 Property

Gets the PANTONE 339 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE339 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE339
C#
public static PDFPantoneColor PANTONE339 {get;}
Delphi
public read-only property PANTONE339: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE339();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE339 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 339 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3395 Property

Gets the PANTONE 3395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3395
C#
public static PDFPantoneColor PANTONE3395 {get;}
Delphi
public read-only property PANTONE3395: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE340 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE340 Property

Gets the PANTONE 340 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE340 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE340
C#
public static PDFPantoneColor PANTONE340 {get;}
Delphi
public read-only property PANTONE340: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE340();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE340 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 340 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3405 Property

Gets the PANTONE 3405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3405
C#
public static PDFPantoneColor PANTONE3405 {get;}
Delphi
public read-only property PANTONE3405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE341 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE341 Property

Gets the PANTONE 341 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE341 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE341
C#
public static PDFPantoneColor PANTONE341 {get;}
Delphi
public read-only property PANTONE341: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE341();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE341 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 341 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3415 Property

Gets the PANTONE 3415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3415
C#
public static PDFPantoneColor PANTONE3415 {get;}
Delphi
public read-only property PANTONE3415: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE342 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE342 Property

Gets the PANTONE 342 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE342 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE342
C#
public static PDFPantoneColor PANTONE342 {get;}
Delphi
public read-only property PANTONE342: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE342();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE342 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 342 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3425 Property

Gets the PANTONE 3425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3425
C#
public static PDFPantoneColor PANTONE3425 {get;}
Delphi
public read-only property PANTONE3425: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE343 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE343 Property

Gets the PANTONE 343 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE343 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE343
C#
public static PDFPantoneColor PANTONE343 {get;}
Delphi
public read-only property PANTONE343: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE343();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE343 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 343 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3435 Property

Gets the PANTONE 3435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3435
C#
public static PDFPantoneColor PANTONE3435 {get;}
Delphi
public read-only property PANTONE3435: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE344 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE344 Property

Gets the PANTONE 344 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE344 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE344
C#
public static PDFPantoneColor PANTONE344 {get;}
Delphi
public read-only property PANTONE344: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE344();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE344 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 344 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE345 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE345 Property

Gets the PANTONE 345 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE345 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE345
C#
public static PDFPantoneColor PANTONE345 {get;}
Delphi
public read-only property PANTONE345: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE345();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE345 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 345 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE346 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE346 Property

Gets the PANTONE 346 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE346 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE346
C#
public static PDFPantoneColor PANTONE346 {get;}
Delphi
public read-only property PANTONE346: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE346();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE346 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 346 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE347 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE347 Property

Gets the PANTONE 347 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE347 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE347
C#
public static PDFPantoneColor PANTONE347 {get;}
Delphi
public read-only property PANTONE347: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE347();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE347 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 347 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE348 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE348 Property

Gets the PANTONE 348 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE348 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE348
C#
public static PDFPantoneColor PANTONE348 {get;}
Delphi
public read-only property PANTONE348: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE348();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE348 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 348 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE349 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE349 Property

Gets the PANTONE 349 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE349 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE349
C#
public static PDFPantoneColor PANTONE349 {get;}
Delphi
public read-only property PANTONE349: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE349();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE349 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 349 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE350 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE350 Property

Gets the PANTONE 350 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE350 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE350
C#
public static PDFPantoneColor PANTONE350 {get;}
Delphi
public read-only property PANTONE350: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE350();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE350 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 350 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE351 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE351 Property

Gets the PANTONE 351 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE351 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE351
C#
public static PDFPantoneColor PANTONE351 {get;}
Delphi
public read-only property PANTONE351: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE351();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE351 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 351 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE352 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE352 Property

Gets the PANTONE 352 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE352 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE352
C#
public static PDFPantoneColor PANTONE352 {get;}
Delphi
public read-only property PANTONE352: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE352();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE352 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 352 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE353 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE353 Property

Gets the PANTONE 353 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE353 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE353
C#
public static PDFPantoneColor PANTONE353 {get;}
Delphi
public read-only property PANTONE353: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE353();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE353 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 353 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE354 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE354 Property

Gets the PANTONE 354 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE354 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE354
C#
public static PDFPantoneColor PANTONE354 {get;}
Delphi
public read-only property PANTONE354: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE354();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE354 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 354 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE355 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE355 Property

Gets the PANTONE 355 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE355 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE355
C#
public static PDFPantoneColor PANTONE355 {get;}
Delphi
public read-only property PANTONE355: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE355();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE355 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 355 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE356 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE356 Property

Gets the PANTONE 356 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE356 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE356
C#
public static PDFPantoneColor PANTONE356 {get;}
Delphi
public read-only property PANTONE356: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE356();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE356 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 356 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE357 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE357 Property

Gets the PANTONE 357 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE357 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE357
C#
public static PDFPantoneColor PANTONE357 {get;}
Delphi
public read-only property PANTONE357: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE357();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE357 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 357 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE358 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE358 Property

Gets the PANTONE 358 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE358 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE358
C#
public static PDFPantoneColor PANTONE358 {get;}
Delphi
public read-only property PANTONE358: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE358();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE358 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 358 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE359 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE359 Property

Gets the PANTONE 359 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE359 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE359
C#
public static PDFPantoneColor PANTONE359 {get;}
Delphi
public read-only property PANTONE359: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE359();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE359 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 359 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE360 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE360 Property

Gets the PANTONE 360 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE360 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE360
C#
public static PDFPantoneColor PANTONE360 {get;}
Delphi
public read-only property PANTONE360: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE360();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE360 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 360 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE361 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE361 Property

Gets the PANTONE 361 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE361 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE361
C#
public static PDFPantoneColor PANTONE361 {get;}
Delphi
public read-only property PANTONE361: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE361();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE361 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 361 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE362 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE362 Property

Gets the PANTONE 362 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE362 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE362
C#
public static PDFPantoneColor PANTONE362 {get;}
Delphi
public read-only property PANTONE362: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE362();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE362 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 362 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE363 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE363 Property

Gets the PANTONE 363 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE363 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE363
C#
public static PDFPantoneColor PANTONE363 {get;}
Delphi
public read-only property PANTONE363: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE363();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE363 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 363 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE364 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE364 Property

Gets the PANTONE 364 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE364 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE364
C#
public static PDFPantoneColor PANTONE364 {get;}
Delphi
public read-only property PANTONE364: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE364();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE364 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 364 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE365 Property

Gets the PANTONE 365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE365
C#
public static PDFPantoneColor PANTONE365 {get;}
Delphi
public read-only property PANTONE365: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE366 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE366 Property

Gets the PANTONE 366 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE366 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE366
C#
public static PDFPantoneColor PANTONE366 {get;}
Delphi
public read-only property PANTONE366: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE366();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE366 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 366 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE367 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE367 Property

Gets the PANTONE 367 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE367 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE367
C#
public static PDFPantoneColor PANTONE367 {get;}
Delphi
public read-only property PANTONE367: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE367();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE367 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 367 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE368 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE368 Property

Gets the PANTONE 368 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE368 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE368
C#
public static PDFPantoneColor PANTONE368 {get;}
Delphi
public read-only property PANTONE368: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE368();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE368 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 368 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE369 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE369 Property

Gets the PANTONE 369 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE369 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE369
C#
public static PDFPantoneColor PANTONE369 {get;}
Delphi
public read-only property PANTONE369: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE369();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE369 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 369 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE370 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE370 Property

Gets the PANTONE 370 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE370 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE370
C#
public static PDFPantoneColor PANTONE370 {get;}
Delphi
public read-only property PANTONE370: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE370();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE370 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 370 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE371 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE371 Property

Gets the PANTONE 371 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE371 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE371
C#
public static PDFPantoneColor PANTONE371 {get;}
Delphi
public read-only property PANTONE371: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE371();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE371 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 371 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE372 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE372 Property

Gets the PANTONE 372 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE372 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE372
C#
public static PDFPantoneColor PANTONE372 {get;}
Delphi
public read-only property PANTONE372: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE372();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE372 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 372 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE373 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE373 Property

Gets the PANTONE 373 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE373 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE373
C#
public static PDFPantoneColor PANTONE373 {get;}
Delphi
public read-only property PANTONE373: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE373();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE373 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 373 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE374 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE374 Property

Gets the PANTONE 374 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE374 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE374
C#
public static PDFPantoneColor PANTONE374 {get;}
Delphi
public read-only property PANTONE374: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE374();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE374 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 374 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE375 Property

Gets the PANTONE 375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE375
C#
public static PDFPantoneColor PANTONE375 {get;}
Delphi
public read-only property PANTONE375: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE376 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE376 Property

Gets the PANTONE 376 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE376 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE376
C#
public static PDFPantoneColor PANTONE376 {get;}
Delphi
public read-only property PANTONE376: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE376();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE376 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 376 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE377 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE377 Property

Gets the PANTONE 377 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE377 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE377
C#
public static PDFPantoneColor PANTONE377 {get;}
Delphi
public read-only property PANTONE377: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE377();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE377 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 377 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE378 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE378 Property

Gets the PANTONE 378 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE378 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE378
C#
public static PDFPantoneColor PANTONE378 {get;}
Delphi
public read-only property PANTONE378: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE378();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE378 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 378 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE379 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE379 Property

Gets the PANTONE 379 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE379 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE379
C#
public static PDFPantoneColor PANTONE379 {get;}
Delphi
public read-only property PANTONE379: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE379();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE379 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 379 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE380 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE380 Property

Gets the PANTONE 380 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE380 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE380
C#
public static PDFPantoneColor PANTONE380 {get;}
Delphi
public read-only property PANTONE380: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE380();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE380 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 380 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE381 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE381 Property

Gets the PANTONE 381 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE381 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE381
C#
public static PDFPantoneColor PANTONE381 {get;}
Delphi
public read-only property PANTONE381: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE381();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE381 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 381 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE382 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE382 Property

Gets the PANTONE 382 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE382 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE382
C#
public static PDFPantoneColor PANTONE382 {get;}
Delphi
public read-only property PANTONE382: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE382();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE382 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 382 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE383 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE383 Property

Gets the PANTONE 383 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE383 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE383
C#
public static PDFPantoneColor PANTONE383 {get;}
Delphi
public read-only property PANTONE383: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE383();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE383 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 383 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE384 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE384 Property

Gets the PANTONE 384 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE384 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE384
C#
public static PDFPantoneColor PANTONE384 {get;}
Delphi
public read-only property PANTONE384: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE384();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE384 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 384 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE385 Property

Gets the PANTONE 385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE385
C#
public static PDFPantoneColor PANTONE385 {get;}
Delphi
public read-only property PANTONE385: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE386 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE386 Property

Gets the PANTONE 386 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE386 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE386
C#
public static PDFPantoneColor PANTONE386 {get;}
Delphi
public read-only property PANTONE386: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE386();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE386 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 386 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE387 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE387 Property

Gets the PANTONE 387 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE387 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE387
C#
public static PDFPantoneColor PANTONE387 {get;}
Delphi
public read-only property PANTONE387: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE387();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE387 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 387 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE388 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE388 Property

Gets the PANTONE 388 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE388 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE388
C#
public static PDFPantoneColor PANTONE388 {get;}
Delphi
public read-only property PANTONE388: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE388();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE388 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 388 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE389 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE389 Property

Gets the PANTONE 389 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE389 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE389
C#
public static PDFPantoneColor PANTONE389 {get;}
Delphi
public read-only property PANTONE389: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE389();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE389 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 389 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE390 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE390 Property

Gets the PANTONE 390 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE390 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE390
C#
public static PDFPantoneColor PANTONE390 {get;}
Delphi
public read-only property PANTONE390: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE390();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE390 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 390 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE391 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE391 Property

Gets the PANTONE 391 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE391 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE391
C#
public static PDFPantoneColor PANTONE391 {get;}
Delphi
public read-only property PANTONE391: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE391();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE391 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 391 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE392 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE392 Property

Gets the PANTONE 392 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE392 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE392
C#
public static PDFPantoneColor PANTONE392 {get;}
Delphi
public read-only property PANTONE392: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE392();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE392 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 392 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE393 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE393 Property

Gets the PANTONE 393 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE393 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE393
C#
public static PDFPantoneColor PANTONE393 {get;}
Delphi
public read-only property PANTONE393: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE393();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE393 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 393 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3935 Property

Gets the PANTONE 3935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3935
C#
public static PDFPantoneColor PANTONE3935 {get;}
Delphi
public read-only property PANTONE3935: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE394 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE394 Property

Gets the PANTONE 394 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE394 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE394
C#
public static PDFPantoneColor PANTONE394 {get;}
Delphi
public read-only property PANTONE394: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE394();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE394 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 394 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3945 Property

Gets the PANTONE 3945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3945
C#
public static PDFPantoneColor PANTONE3945 {get;}
Delphi
public read-only property PANTONE3945: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE395 Property

Gets the PANTONE 395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE395
C#
public static PDFPantoneColor PANTONE395 {get;}
Delphi
public read-only property PANTONE395: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3955 Property

Gets the PANTONE 3955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3955
C#
public static PDFPantoneColor PANTONE3955 {get;}
Delphi
public read-only property PANTONE3955: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE396 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE396 Property

Gets the PANTONE 396 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE396 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE396
C#
public static PDFPantoneColor PANTONE396 {get;}
Delphi
public read-only property PANTONE396: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE396();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE396 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 396 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3965 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3965 Property

Gets the PANTONE 3965 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3965 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3965
C#
public static PDFPantoneColor PANTONE3965 {get;}
Delphi
public read-only property PANTONE3965: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3965();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3965 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3965 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE397 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE397 Property

Gets the PANTONE 397 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE397 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE397
C#
public static PDFPantoneColor PANTONE397 {get;}
Delphi
public read-only property PANTONE397: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE397();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE397 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 397 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3975 Property

Gets the PANTONE 3975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3975
C#
public static PDFPantoneColor PANTONE3975 {get;}
Delphi
public read-only property PANTONE3975: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE398 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE398 Property

Gets the PANTONE 398 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE398 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE398
C#
public static PDFPantoneColor PANTONE398 {get;}
Delphi
public read-only property PANTONE398: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE398();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE398 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 398 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3985 Property

Gets the PANTONE 3985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3985
C#
public static PDFPantoneColor PANTONE3985 {get;}
Delphi
public read-only property PANTONE3985: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE399 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE399 Property

Gets the PANTONE 399 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE399 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE399
C#
public static PDFPantoneColor PANTONE399 {get;}
Delphi
public read-only property PANTONE399: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE399();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE399 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 399 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE3995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3995 Property

Gets the PANTONE 3995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3995
C#
public static PDFPantoneColor PANTONE3995 {get;}
Delphi
public read-only property PANTONE3995: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE400 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE400 Property

Gets the PANTONE 400 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE400 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE400
C#
public static PDFPantoneColor PANTONE400 {get;}
Delphi
public read-only property PANTONE400: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE400();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE400 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 400 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE401 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE401 Property

Gets the PANTONE 401 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE401 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE401
C#
public static PDFPantoneColor PANTONE401 {get;}
Delphi
public read-only property PANTONE401: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE401();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE401 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 401 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE402 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE402 Property

Gets the PANTONE 402 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE402 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE402
C#
public static PDFPantoneColor PANTONE402 {get;}
Delphi
public read-only property PANTONE402: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE402();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE402 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 402 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE403 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE403 Property

Gets the PANTONE 403 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE403 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE403
C#
public static PDFPantoneColor PANTONE403 {get;}
Delphi
public read-only property PANTONE403: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE403();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE403 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 403 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE404 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE404 Property

Gets the PANTONE 404 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE404 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE404
C#
public static PDFPantoneColor PANTONE404 {get;}
Delphi
public read-only property PANTONE404: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE404();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE404 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 404 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE405 Property

Gets the PANTONE 405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE405
C#
public static PDFPantoneColor PANTONE405 {get;}
Delphi
public read-only property PANTONE405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE406 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE406 Property

Gets the PANTONE 406 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE406 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE406
C#
public static PDFPantoneColor PANTONE406 {get;}
Delphi
public read-only property PANTONE406: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE406();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE406 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 406 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE407 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE407 Property

Gets the PANTONE 407 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE407 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE407
C#
public static PDFPantoneColor PANTONE407 {get;}
Delphi
public read-only property PANTONE407: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE407();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE407 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 407 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE408 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE408 Property

Gets the PANTONE 408 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE408 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE408
C#
public static PDFPantoneColor PANTONE408 {get;}
Delphi
public read-only property PANTONE408: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE408();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE408 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 408 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE409 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE409 Property

Gets the PANTONE 409 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE409 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE409
C#
public static PDFPantoneColor PANTONE409 {get;}
Delphi
public read-only property PANTONE409: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE409();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE409 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 409 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE410 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE410 Property

Gets the PANTONE 410 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE410 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE410
C#
public static PDFPantoneColor PANTONE410 {get;}
Delphi
public read-only property PANTONE410: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE410();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE410 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 410 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE411 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE411 Property

Gets the PANTONE 411 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE411 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE411
C#
public static PDFPantoneColor PANTONE411 {get;}
Delphi
public read-only property PANTONE411: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE411();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE411 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 411 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE412 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE412 Property

Gets the PANTONE 412 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE412 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE412
C#
public static PDFPantoneColor PANTONE412 {get;}
Delphi
public read-only property PANTONE412: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE412();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE412 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 412 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE413 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE413 Property

Gets the PANTONE 413 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE413 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE413
C#
public static PDFPantoneColor PANTONE413 {get;}
Delphi
public read-only property PANTONE413: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE413();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE413 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 413 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE414 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE414 Property

Gets the PANTONE 414 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE414 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE414
C#
public static PDFPantoneColor PANTONE414 {get;}
Delphi
public read-only property PANTONE414: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE414();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE414 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 414 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE415 Property

Gets the PANTONE 415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE415
C#
public static PDFPantoneColor PANTONE415 {get;}
Delphi
public read-only property PANTONE415: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE416 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE416 Property

Gets the PANTONE 416 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE416 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE416
C#
public static PDFPantoneColor PANTONE416 {get;}
Delphi
public read-only property PANTONE416: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE416();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE416 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 416 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE417 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE417 Property

Gets the PANTONE 417 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE417 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE417
C#
public static PDFPantoneColor PANTONE417 {get;}
Delphi
public read-only property PANTONE417: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE417();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE417 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 417 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE418 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE418 Property

Gets the PANTONE 418 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE418 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE418
C#
public static PDFPantoneColor PANTONE418 {get;}
Delphi
public read-only property PANTONE418: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE418();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE418 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 418 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE419 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE419 Property

Gets the PANTONE 419 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE419 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE419
C#
public static PDFPantoneColor PANTONE419 {get;}
Delphi
public read-only property PANTONE419: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE419();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE419 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 419 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE420 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE420 Property

Gets the PANTONE 420 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE420 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE420
C#
public static PDFPantoneColor PANTONE420 {get;}
Delphi
public read-only property PANTONE420: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE420();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE420 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 420 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE421 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE421 Property

Gets the PANTONE 421 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE421 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE421
C#
public static PDFPantoneColor PANTONE421 {get;}
Delphi
public read-only property PANTONE421: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE421();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE421 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 421 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE422 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE422 Property

Gets the PANTONE 422 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE422 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE422
C#
public static PDFPantoneColor PANTONE422 {get;}
Delphi
public read-only property PANTONE422: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE422();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE422 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 422 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE423 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE423 Property

Gets the PANTONE 423 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE423 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE423
C#
public static PDFPantoneColor PANTONE423 {get;}
Delphi
public read-only property PANTONE423: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE423();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE423 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 423 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE424 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE424 Property

Gets the PANTONE 424 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE424 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE424
C#
public static PDFPantoneColor PANTONE424 {get;}
Delphi
public read-only property PANTONE424: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE424();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE424 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 424 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE425 Property

Gets the PANTONE 425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE425
C#
public static PDFPantoneColor PANTONE425 {get;}
Delphi
public read-only property PANTONE425: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE426 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE426 Property

Gets the PANTONE 426 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE426 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE426
C#
public static PDFPantoneColor PANTONE426 {get;}
Delphi
public read-only property PANTONE426: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE426();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE426 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 426 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE427 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE427 Property

Gets the PANTONE 427 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE427 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE427
C#
public static PDFPantoneColor PANTONE427 {get;}
Delphi
public read-only property PANTONE427: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE427();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE427 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 427 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE428 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE428 Property

Gets the PANTONE 428 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE428 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE428
C#
public static PDFPantoneColor PANTONE428 {get;}
Delphi
public read-only property PANTONE428: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE428();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE428 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 428 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE429 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE429 Property

Gets the PANTONE 429 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE429 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE429
C#
public static PDFPantoneColor PANTONE429 {get;}
Delphi
public read-only property PANTONE429: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE429();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE429 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 429 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE430 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE430 Property

Gets the PANTONE 430 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE430 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE430
C#
public static PDFPantoneColor PANTONE430 {get;}
Delphi
public read-only property PANTONE430: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE430();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE430 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 430 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE431 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE431 Property

Gets the PANTONE 431 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE431 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE431
C#
public static PDFPantoneColor PANTONE431 {get;}
Delphi
public read-only property PANTONE431: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE431();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE431 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 431 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE432 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE432 Property

Gets the PANTONE 432 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE432 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE432
C#
public static PDFPantoneColor PANTONE432 {get;}
Delphi
public read-only property PANTONE432: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE432();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE432 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 432 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE433 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE433 Property

Gets the PANTONE 433 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE433 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE433
C#
public static PDFPantoneColor PANTONE433 {get;}
Delphi
public read-only property PANTONE433: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE433();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE433 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 433 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE434 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE434 Property

Gets the PANTONE 434 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE434 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE434
C#
public static PDFPantoneColor PANTONE434 {get;}
Delphi
public read-only property PANTONE434: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE434();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE434 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 434 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE435 Property

Gets the PANTONE 435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE435
C#
public static PDFPantoneColor PANTONE435 {get;}
Delphi
public read-only property PANTONE435: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE436 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE436 Property

Gets the PANTONE 436 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE436 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE436
C#
public static PDFPantoneColor PANTONE436 {get;}
Delphi
public read-only property PANTONE436: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE436();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE436 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 436 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE437 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE437 Property

Gets the PANTONE 437 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE437 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE437
C#
public static PDFPantoneColor PANTONE437 {get;}
Delphi
public read-only property PANTONE437: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE437();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE437 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 437 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE438 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE438 Property

Gets the PANTONE 438 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE438 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE438
C#
public static PDFPantoneColor PANTONE438 {get;}
Delphi
public read-only property PANTONE438: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE438();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE438 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 438 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE439 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE439 Property

Gets the PANTONE 439 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE439 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE439
C#
public static PDFPantoneColor PANTONE439 {get;}
Delphi
public read-only property PANTONE439: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE439();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE439 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 439 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE440 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE440 Property

Gets the PANTONE 440 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE440 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE440
C#
public static PDFPantoneColor PANTONE440 {get;}
Delphi
public read-only property PANTONE440: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE440();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE440 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 440 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE441 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE441 Property

Gets the PANTONE 441 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE441 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE441
C#
public static PDFPantoneColor PANTONE441 {get;}
Delphi
public read-only property PANTONE441: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE441();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE441 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 441 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE442 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE442 Property

Gets the PANTONE 442 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE442 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE442
C#
public static PDFPantoneColor PANTONE442 {get;}
Delphi
public read-only property PANTONE442: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE442();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE442 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 442 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE443 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE443 Property

Gets the PANTONE 443 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE443 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE443
C#
public static PDFPantoneColor PANTONE443 {get;}
Delphi
public read-only property PANTONE443: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE443();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE443 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 443 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE444 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE444 Property

Gets the PANTONE 444 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE444 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE444
C#
public static PDFPantoneColor PANTONE444 {get;}
Delphi
public read-only property PANTONE444: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE444();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE444 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 444 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE445 Property

Gets the PANTONE 445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE445
C#
public static PDFPantoneColor PANTONE445 {get;}
Delphi
public read-only property PANTONE445: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE446 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE446 Property

Gets the PANTONE 446 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE446 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE446
C#
public static PDFPantoneColor PANTONE446 {get;}
Delphi
public read-only property PANTONE446: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE446();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE446 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 446 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE447 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE447 Property

Gets the PANTONE 447 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE447 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE447
C#
public static PDFPantoneColor PANTONE447 {get;}
Delphi
public read-only property PANTONE447: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE447();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE447 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 447 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE448 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE448 Property

Gets the PANTONE 448 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE448 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE448
C#
public static PDFPantoneColor PANTONE448 {get;}
Delphi
public read-only property PANTONE448: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE448();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE448 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 448 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4485 Property

Gets the PANTONE 4485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4485
C#
public static PDFPantoneColor PANTONE4485 {get;}
Delphi
public read-only property PANTONE4485: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE449 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE449 Property

Gets the PANTONE 449 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE449 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE449
C#
public static PDFPantoneColor PANTONE449 {get;}
Delphi
public read-only property PANTONE449: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE449();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE449 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 449 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4495 Property

Gets the PANTONE 4495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4495
C#
public static PDFPantoneColor PANTONE4495 {get;}
Delphi
public read-only property PANTONE4495: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE450 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE450 Property

Gets the PANTONE 450 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE450 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE450
C#
public static PDFPantoneColor PANTONE450 {get;}
Delphi
public read-only property PANTONE450: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE450();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE450 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 450 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4505 Property

Gets the PANTONE 4505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4505
C#
public static PDFPantoneColor PANTONE4505 {get;}
Delphi
public read-only property PANTONE4505: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE451 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE451 Property

Gets the PANTONE 451 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE451 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE451
C#
public static PDFPantoneColor PANTONE451 {get;}
Delphi
public read-only property PANTONE451: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE451();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE451 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 451 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4515 Property

Gets the PANTONE 4515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4515
C#
public static PDFPantoneColor PANTONE4515 {get;}
Delphi
public read-only property PANTONE4515: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE452 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE452 Property

Gets the PANTONE 452 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE452 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE452
C#
public static PDFPantoneColor PANTONE452 {get;}
Delphi
public read-only property PANTONE452: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE452();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE452 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 452 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4525 Property

Gets the PANTONE 4525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4525
C#
public static PDFPantoneColor PANTONE4525 {get;}
Delphi
public read-only property PANTONE4525: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE453 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE453 Property

Gets the PANTONE 453 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE453 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE453
C#
public static PDFPantoneColor PANTONE453 {get;}
Delphi
public read-only property PANTONE453: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE453();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE453 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 453 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4535 Property

Gets the PANTONE 4535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4535
C#
public static PDFPantoneColor PANTONE4535 {get;}
Delphi
public read-only property PANTONE4535: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE454 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE454 Property

Gets the PANTONE 454 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE454 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE454
C#
public static PDFPantoneColor PANTONE454 {get;}
Delphi
public read-only property PANTONE454: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE454();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE454 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 454 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4545 Property

Gets the PANTONE 4545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4545
C#
public static PDFPantoneColor PANTONE4545 {get;}
Delphi
public read-only property PANTONE4545: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE455 Property

Gets the PANTONE 455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE455
C#
public static PDFPantoneColor PANTONE455 {get;}
Delphi
public read-only property PANTONE455: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE456 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE456 Property

Gets the PANTONE 456 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE456 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE456
C#
public static PDFPantoneColor PANTONE456 {get;}
Delphi
public read-only property PANTONE456: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE456();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE456 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 456 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE457 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE457 Property

Gets the PANTONE 457 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE457 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE457
C#
public static PDFPantoneColor PANTONE457 {get;}
Delphi
public read-only property PANTONE457: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE457();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE457 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 457 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE458 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE458 Property

Gets the PANTONE 458 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE458 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE458
C#
public static PDFPantoneColor PANTONE458 {get;}
Delphi
public read-only property PANTONE458: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE458();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE458 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 458 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE459 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE459 Property

Gets the PANTONE 459 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE459 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE459
C#
public static PDFPantoneColor PANTONE459 {get;}
Delphi
public read-only property PANTONE459: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE459();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE459 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 459 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE460 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE460 Property

Gets the PANTONE 460 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE460 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE460
C#
public static PDFPantoneColor PANTONE460 {get;}
Delphi
public read-only property PANTONE460: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE460();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE460 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 460 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE461 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE461 Property

Gets the PANTONE 461 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE461 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE461
C#
public static PDFPantoneColor PANTONE461 {get;}
Delphi
public read-only property PANTONE461: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE461();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE461 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 461 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE462 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE462 Property

Gets the PANTONE 462 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE462 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE462
C#
public static PDFPantoneColor PANTONE462 {get;}
Delphi
public read-only property PANTONE462: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE462();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE462 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 462 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4625 Property

Gets the PANTONE 4625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4625
C#
public static PDFPantoneColor PANTONE4625 {get;}
Delphi
public read-only property PANTONE4625: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE463 Property

Gets the PANTONE 463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE463
C#
public static PDFPantoneColor PANTONE463 {get;}
Delphi
public read-only property PANTONE463: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4635 Property

Gets the PANTONE 4635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4635
C#
public static PDFPantoneColor PANTONE4635 {get;}
Delphi
public read-only property PANTONE4635: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE464 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE464 Property

Gets the PANTONE 464 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE464 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE464
C#
public static PDFPantoneColor PANTONE464 {get;}
Delphi
public read-only property PANTONE464: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE464();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE464 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 464 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4645 Property

Gets the PANTONE 4645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4645
C#
public static PDFPantoneColor PANTONE4645 {get;}
Delphi
public read-only property PANTONE4645: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE465 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE465 Property

Gets the PANTONE 465 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE465 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE465
C#
public static PDFPantoneColor PANTONE465 {get;}
Delphi
public read-only property PANTONE465: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE465();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE465 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 465 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4655 Property

Gets the PANTONE 4655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4655
C#
public static PDFPantoneColor PANTONE4655 {get;}
Delphi
public read-only property PANTONE4655: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE466 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE466 Property

Gets the PANTONE 466 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE466 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE466
C#
public static PDFPantoneColor PANTONE466 {get;}
Delphi
public read-only property PANTONE466: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE466();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE466 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 466 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4665 Property

Gets the PANTONE 4665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4665
C#
public static PDFPantoneColor PANTONE4665 {get;}
Delphi
public read-only property PANTONE4665: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE467 Property

Gets the PANTONE 467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE467
C#
public static PDFPantoneColor PANTONE467 {get;}
Delphi
public read-only property PANTONE467: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4675 Property

Gets the PANTONE 4675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4675
C#
public static PDFPantoneColor PANTONE4675 {get;}
Delphi
public read-only property PANTONE4675: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE468 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE468 Property

Gets the PANTONE 468 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE468 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE468
C#
public static PDFPantoneColor PANTONE468 {get;}
Delphi
public read-only property PANTONE468: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE468();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE468 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 468 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4685 Property

Gets the PANTONE 4685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4685
C#
public static PDFPantoneColor PANTONE4685 {get;}
Delphi
public read-only property PANTONE4685: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE469 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE469 Property

Gets the PANTONE 469 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE469 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE469
C#
public static PDFPantoneColor PANTONE469 {get;}
Delphi
public read-only property PANTONE469: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE469();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE469 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 469 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4695 Property

Gets the PANTONE 4695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4695
C#
public static PDFPantoneColor PANTONE4695 {get;}
Delphi
public read-only property PANTONE4695: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE470 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE470 Property

Gets the PANTONE 470 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE470 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE470
C#
public static PDFPantoneColor PANTONE470 {get;}
Delphi
public read-only property PANTONE470: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE470();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE470 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 470 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4705 Property

Gets the PANTONE 4705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4705
C#
public static PDFPantoneColor PANTONE4705 {get;}
Delphi
public read-only property PANTONE4705: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE471 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE471 Property

Gets the PANTONE 471 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE471 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE471
C#
public static PDFPantoneColor PANTONE471 {get;}
Delphi
public read-only property PANTONE471: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE471();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE471 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 471 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4715 Property

Gets the PANTONE 4715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4715
C#
public static PDFPantoneColor PANTONE4715 {get;}
Delphi
public read-only property PANTONE4715: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE472 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE472 Property

Gets the PANTONE 472 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE472 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE472
C#
public static PDFPantoneColor PANTONE472 {get;}
Delphi
public read-only property PANTONE472: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE472();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE472 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 472 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4725 Property

Gets the PANTONE 4725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4725
C#
public static PDFPantoneColor PANTONE4725 {get;}
Delphi
public read-only property PANTONE4725: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE473 Property

Gets the PANTONE 473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE473
C#
public static PDFPantoneColor PANTONE473 {get;}
Delphi
public read-only property PANTONE473: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4735 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4735 Property

Gets the PANTONE 4735 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4735 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4735
C#
public static PDFPantoneColor PANTONE4735 {get;}
Delphi
public read-only property PANTONE4735: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4735();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4735 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4735 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE474 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE474 Property

Gets the PANTONE 474 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE474 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE474
C#
public static PDFPantoneColor PANTONE474 {get;}
Delphi
public read-only property PANTONE474: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE474();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE474 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 474 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4745 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4745 Property

Gets the PANTONE 4745 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4745 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4745
C#
public static PDFPantoneColor PANTONE4745 {get;}
Delphi
public read-only property PANTONE4745: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4745();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4745 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4745 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE475 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE475 Property

Gets the PANTONE 475 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE475 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE475
C#
public static PDFPantoneColor PANTONE475 {get;}
Delphi
public read-only property PANTONE475: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE475();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE475 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 475 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4755 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4755 Property

Gets the PANTONE 4755 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4755 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4755
C#
public static PDFPantoneColor PANTONE4755 {get;}
Delphi
public read-only property PANTONE4755: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4755();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4755 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4755 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE476 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE476 Property

Gets the PANTONE 476 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE476 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE476
C#
public static PDFPantoneColor PANTONE476 {get;}
Delphi
public read-only property PANTONE476: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE476();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE476 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 476 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE477 Property

Gets the PANTONE 477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE477
C#
public static PDFPantoneColor PANTONE477 {get;}
Delphi
public read-only property PANTONE477: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE478 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE478 Property

Gets the PANTONE 478 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE478 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE478
C#
public static PDFPantoneColor PANTONE478 {get;}
Delphi
public read-only property PANTONE478: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE478();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE478 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 478 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE479 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE479 Property

Gets the PANTONE 479 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE479 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE479
C#
public static PDFPantoneColor PANTONE479 {get;}
Delphi
public read-only property PANTONE479: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE479();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE479 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 479 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE480 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE480 Property

Gets the PANTONE 480 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE480 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE480
C#
public static PDFPantoneColor PANTONE480 {get;}
Delphi
public read-only property PANTONE480: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE480();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE480 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 480 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE481 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE481 Property

Gets the PANTONE 481 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE481 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE481
C#
public static PDFPantoneColor PANTONE481 {get;}
Delphi
public read-only property PANTONE481: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE481();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE481 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 481 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE482 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE482 Property

Gets the PANTONE 482 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE482 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE482
C#
public static PDFPantoneColor PANTONE482 {get;}
Delphi
public read-only property PANTONE482: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE482();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE482 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 482 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE483 Property

Gets the PANTONE 483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE483
C#
public static PDFPantoneColor PANTONE483 {get;}
Delphi
public read-only property PANTONE483: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE484 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE484 Property

Gets the PANTONE 484 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE484 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE484
C#
public static PDFPantoneColor PANTONE484 {get;}
Delphi
public read-only property PANTONE484: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE484();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE484 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 484 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE485 Property

Gets the PANTONE 485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE485
C#
public static PDFPantoneColor PANTONE485 {get;}
Delphi
public read-only property PANTONE485: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE486 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE486 Property

Gets the PANTONE 486 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE486 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE486
C#
public static PDFPantoneColor PANTONE486 {get;}
Delphi
public read-only property PANTONE486: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE486();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE486 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 486 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE487 Property

Gets the PANTONE 487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE487
C#
public static PDFPantoneColor PANTONE487 {get;}
Delphi
public read-only property PANTONE487: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE488 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE488 Property

Gets the PANTONE 488 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE488 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE488
C#
public static PDFPantoneColor PANTONE488 {get;}
Delphi
public read-only property PANTONE488: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE488();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE488 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 488 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE489 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE489 Property

Gets the PANTONE 489 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE489 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE489
C#
public static PDFPantoneColor PANTONE489 {get;}
Delphi
public read-only property PANTONE489: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE489();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE489 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 489 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE490 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE490 Property

Gets the PANTONE 490 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE490 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE490
C#
public static PDFPantoneColor PANTONE490 {get;}
Delphi
public read-only property PANTONE490: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE490();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE490 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 490 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE491 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE491 Property

Gets the PANTONE 491 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE491 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE491
C#
public static PDFPantoneColor PANTONE491 {get;}
Delphi
public read-only property PANTONE491: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE491();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE491 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 491 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE492 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE492 Property

Gets the PANTONE 492 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE492 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE492
C#
public static PDFPantoneColor PANTONE492 {get;}
Delphi
public read-only property PANTONE492: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE492();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE492 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 492 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE493 Property

Gets the PANTONE 493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE493
C#
public static PDFPantoneColor PANTONE493 {get;}
Delphi
public read-only property PANTONE493: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE494 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE494 Property

Gets the PANTONE 494 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE494 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE494
C#
public static PDFPantoneColor PANTONE494 {get;}
Delphi
public read-only property PANTONE494: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE494();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE494 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 494 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE495 Property

Gets the PANTONE 495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE495
C#
public static PDFPantoneColor PANTONE495 {get;}
Delphi
public read-only property PANTONE495: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE496 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE496 Property

Gets the PANTONE 496 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE496 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE496
C#
public static PDFPantoneColor PANTONE496 {get;}
Delphi
public read-only property PANTONE496: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE496();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE496 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 496 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE497 Property

Gets the PANTONE 497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE497
C#
public static PDFPantoneColor PANTONE497 {get;}
Delphi
public read-only property PANTONE497: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4975 Property

Gets the PANTONE 4975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4975
C#
public static PDFPantoneColor PANTONE4975 {get;}
Delphi
public read-only property PANTONE4975: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE498 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE498 Property

Gets the PANTONE 498 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE498 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE498
C#
public static PDFPantoneColor PANTONE498 {get;}
Delphi
public read-only property PANTONE498: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE498();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE498 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 498 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4985 Property

Gets the PANTONE 4985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4985
C#
public static PDFPantoneColor PANTONE4985 {get;}
Delphi
public read-only property PANTONE4985: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE499 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE499 Property

Gets the PANTONE 499 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE499 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE499
C#
public static PDFPantoneColor PANTONE499 {get;}
Delphi
public read-only property PANTONE499: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE499();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE499 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 499 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE4995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4995 Property

Gets the PANTONE 4995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4995
C#
public static PDFPantoneColor PANTONE4995 {get;}
Delphi
public read-only property PANTONE4995: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE500 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE500 Property

Gets the PANTONE 500 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE500 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE500
C#
public static PDFPantoneColor PANTONE500 {get;}
Delphi
public read-only property PANTONE500: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE500();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE500 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 500 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5005 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5005 Property

Gets the PANTONE 5005 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5005 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5005
C#
public static PDFPantoneColor PANTONE5005 {get;}
Delphi
public read-only property PANTONE5005: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5005();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5005 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5005 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE501 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE501 Property

Gets the PANTONE 501 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE501 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE501
C#
public static PDFPantoneColor PANTONE501 {get;}
Delphi
public read-only property PANTONE501: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE501();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE501 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 501 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5015 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5015 Property

Gets the PANTONE 5015 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5015 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5015
C#
public static PDFPantoneColor PANTONE5015 {get;}
Delphi
public read-only property PANTONE5015: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5015();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5015 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5015 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE502 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE502 Property

Gets the PANTONE 502 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE502 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE502
C#
public static PDFPantoneColor PANTONE502 {get;}
Delphi
public read-only property PANTONE502: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE502();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE502 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 502 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5025 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5025 Property

Gets the PANTONE 5025 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5025 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5025
C#
public static PDFPantoneColor PANTONE5025 {get;}
Delphi
public read-only property PANTONE5025: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5025();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5025 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5025 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE503 Property

Gets the PANTONE 503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE503
C#
public static PDFPantoneColor PANTONE503 {get;}
Delphi
public read-only property PANTONE503: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5035 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5035 Property

Gets the PANTONE 5035 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5035 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5035
C#
public static PDFPantoneColor PANTONE5035 {get;}
Delphi
public read-only property PANTONE5035: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5035();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5035 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5035 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE504 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE504 Property

Gets the PANTONE 504 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE504 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE504
C#
public static PDFPantoneColor PANTONE504 {get;}
Delphi
public read-only property PANTONE504: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE504();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE504 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 504 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE505 Property

Gets the PANTONE 505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE505
C#
public static PDFPantoneColor PANTONE505 {get;}
Delphi
public read-only property PANTONE505: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE506 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE506 Property

Gets the PANTONE 506 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE506 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE506
C#
public static PDFPantoneColor PANTONE506 {get;}
Delphi
public read-only property PANTONE506: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE506();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE506 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 506 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE507 Property

Gets the PANTONE 507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE507
C#
public static PDFPantoneColor PANTONE507 {get;}
Delphi
public read-only property PANTONE507: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE508 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE508 Property

Gets the PANTONE 508 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE508 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE508
C#
public static PDFPantoneColor PANTONE508 {get;}
Delphi
public read-only property PANTONE508: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE508();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE508 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 508 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE509 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE509 Property

Gets the PANTONE 509 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE509 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE509
C#
public static PDFPantoneColor PANTONE509 {get;}
Delphi
public read-only property PANTONE509: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE509();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE509 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 509 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE510 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE510 Property

Gets the PANTONE 510 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE510 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE510
C#
public static PDFPantoneColor PANTONE510 {get;}
Delphi
public read-only property PANTONE510: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE510();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE510 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 510 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE511 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE511 Property

Gets the PANTONE 511 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE511 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE511
C#
public static PDFPantoneColor PANTONE511 {get;}
Delphi
public read-only property PANTONE511: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE511();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE511 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 511 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5115 Property

Gets the PANTONE 5115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5115
C#
public static PDFPantoneColor PANTONE5115 {get;}
Delphi
public read-only property PANTONE5115: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE512 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE512 Property

Gets the PANTONE 512 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE512 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE512
C#
public static PDFPantoneColor PANTONE512 {get;}
Delphi
public read-only property PANTONE512: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE512();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE512 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 512 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5125 Property

Gets the PANTONE 5125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5125
C#
public static PDFPantoneColor PANTONE5125 {get;}
Delphi
public read-only property PANTONE5125: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE513 Property

Gets the PANTONE 513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE513
C#
public static PDFPantoneColor PANTONE513 {get;}
Delphi
public read-only property PANTONE513: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5135 Property

Gets the PANTONE 5135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5135
C#
public static PDFPantoneColor PANTONE5135 {get;}
Delphi
public read-only property PANTONE5135: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE514 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE514 Property

Gets the PANTONE 514 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE514 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE514
C#
public static PDFPantoneColor PANTONE514 {get;}
Delphi
public read-only property PANTONE514: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE514();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE514 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 514 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5145 Property

Gets the PANTONE 5145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5145
C#
public static PDFPantoneColor PANTONE5145 {get;}
Delphi
public read-only property PANTONE5145: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE515 Property

Gets the PANTONE 515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE515
C#
public static PDFPantoneColor PANTONE515 {get;}
Delphi
public read-only property PANTONE515: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5155 Property

Gets the PANTONE 5155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5155
C#
public static PDFPantoneColor PANTONE5155 {get;}
Delphi
public read-only property PANTONE5155: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE516 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE516 Property

Gets the PANTONE 516 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE516 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE516
C#
public static PDFPantoneColor PANTONE516 {get;}
Delphi
public read-only property PANTONE516: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE516();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE516 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 516 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5165 Property

Gets the PANTONE 5165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5165
C#
public static PDFPantoneColor PANTONE5165 {get;}
Delphi
public read-only property PANTONE5165: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE517 Property

Gets the PANTONE 517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE517
C#
public static PDFPantoneColor PANTONE517 {get;}
Delphi
public read-only property PANTONE517: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5175 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5175 Property

Gets the PANTONE 5175 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5175 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5175
C#
public static PDFPantoneColor PANTONE5175 {get;}
Delphi
public read-only property PANTONE5175: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5175();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5175 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5175 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE518 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE518 Property

Gets the PANTONE 518 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE518 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE518
C#
public static PDFPantoneColor PANTONE518 {get;}
Delphi
public read-only property PANTONE518: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE518();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE518 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 518 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5185 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5185 Property

Gets the PANTONE 5185 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5185 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5185
C#
public static PDFPantoneColor PANTONE5185 {get;}
Delphi
public read-only property PANTONE5185: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5185();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5185 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5185 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE519 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE519 Property

Gets the PANTONE 519 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE519 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE519
C#
public static PDFPantoneColor PANTONE519 {get;}
Delphi
public read-only property PANTONE519: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE519();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE519 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 519 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5195 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5195 Property

Gets the PANTONE 5195 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5195 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5195
C#
public static PDFPantoneColor PANTONE5195 {get;}
Delphi
public read-only property PANTONE5195: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5195();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5195 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5195 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE520 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE520 Property

Gets the PANTONE 520 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE520 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE520
C#
public static PDFPantoneColor PANTONE520 {get;}
Delphi
public read-only property PANTONE520: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE520();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE520 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 520 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5205 Property

Gets the PANTONE 5205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5205
C#
public static PDFPantoneColor PANTONE5205 {get;}
Delphi
public read-only property PANTONE5205: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE521 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE521 Property

Gets the PANTONE 521 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE521 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE521
C#
public static PDFPantoneColor PANTONE521 {get;}
Delphi
public read-only property PANTONE521: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE521();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE521 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 521 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5215 Property

Gets the PANTONE 5215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5215
C#
public static PDFPantoneColor PANTONE5215 {get;}
Delphi
public read-only property PANTONE5215: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE522 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE522 Property

Gets the PANTONE 522 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE522 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE522
C#
public static PDFPantoneColor PANTONE522 {get;}
Delphi
public read-only property PANTONE522: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE522();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE522 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 522 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5225 Property

Gets the PANTONE 5225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5225
C#
public static PDFPantoneColor PANTONE5225 {get;}
Delphi
public read-only property PANTONE5225: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE523 Property

Gets the PANTONE 523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE523
C#
public static PDFPantoneColor PANTONE523 {get;}
Delphi
public read-only property PANTONE523: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5235 Property

Gets the PANTONE 5235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5235
C#
public static PDFPantoneColor PANTONE5235 {get;}
Delphi
public read-only property PANTONE5235: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE524 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE524 Property

Gets the PANTONE 524 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE524 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE524
C#
public static PDFPantoneColor PANTONE524 {get;}
Delphi
public read-only property PANTONE524: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE524();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE524 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 524 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5245 Property

Gets the PANTONE 5245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5245
C#
public static PDFPantoneColor PANTONE5245 {get;}
Delphi
public read-only property PANTONE5245: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE525 Property

Gets the PANTONE 525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE525
C#
public static PDFPantoneColor PANTONE525 {get;}
Delphi
public read-only property PANTONE525: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5255 Property

Gets the PANTONE 5255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5255
C#
public static PDFPantoneColor PANTONE5255 {get;}
Delphi
public read-only property PANTONE5255: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE526 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE526 Property

Gets the PANTONE 526 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE526 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE526
C#
public static PDFPantoneColor PANTONE526 {get;}
Delphi
public read-only property PANTONE526: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE526();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE526 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 526 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5265 Property

Gets the PANTONE 5265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5265
C#
public static PDFPantoneColor PANTONE5265 {get;}
Delphi
public read-only property PANTONE5265: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE527 Property

Gets the PANTONE 527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE527
C#
public static PDFPantoneColor PANTONE527 {get;}
Delphi
public read-only property PANTONE527: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5275 Property

Gets the PANTONE 5275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5275
C#
public static PDFPantoneColor PANTONE5275 {get;}
Delphi
public read-only property PANTONE5275: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE528 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE528 Property

Gets the PANTONE 528 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE528 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE528
C#
public static PDFPantoneColor PANTONE528 {get;}
Delphi
public read-only property PANTONE528: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE528();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE528 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 528 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5285 Property

Gets the PANTONE 5285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5285
C#
public static PDFPantoneColor PANTONE5285 {get;}
Delphi
public read-only property PANTONE5285: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE529 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE529 Property

Gets the PANTONE 529 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE529 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE529
C#
public static PDFPantoneColor PANTONE529 {get;}
Delphi
public read-only property PANTONE529: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE529();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE529 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 529 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5295 Property

Gets the PANTONE 5295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5295
C#
public static PDFPantoneColor PANTONE5295 {get;}
Delphi
public read-only property PANTONE5295: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE530 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE530 Property

Gets the PANTONE 530 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE530 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE530
C#
public static PDFPantoneColor PANTONE530 {get;}
Delphi
public read-only property PANTONE530: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE530();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE530 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 530 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5305 Property

Gets the PANTONE 5305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5305
C#
public static PDFPantoneColor PANTONE5305 {get;}
Delphi
public read-only property PANTONE5305: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE531 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE531 Property

Gets the PANTONE 531 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE531 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE531
C#
public static PDFPantoneColor PANTONE531 {get;}
Delphi
public read-only property PANTONE531: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE531();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE531 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 531 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5315 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5315 Property

Gets the PANTONE 5315 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5315 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5315
C#
public static PDFPantoneColor PANTONE5315 {get;}
Delphi
public read-only property PANTONE5315: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5315();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5315 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5315 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE532 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE532 Property

Gets the PANTONE 532 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE532 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE532
C#
public static PDFPantoneColor PANTONE532 {get;}
Delphi
public read-only property PANTONE532: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE532();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE532 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 532 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE533 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE533 Property

Gets the PANTONE 533 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE533 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE533
C#
public static PDFPantoneColor PANTONE533 {get;}
Delphi
public read-only property PANTONE533: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE533();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE533 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 533 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE534 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE534 Property

Gets the PANTONE 534 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE534 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE534
C#
public static PDFPantoneColor PANTONE534 {get;}
Delphi
public read-only property PANTONE534: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE534();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE534 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 534 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE535 Property

Gets the PANTONE 535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE535
C#
public static PDFPantoneColor PANTONE535 {get;}
Delphi
public read-only property PANTONE535: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE536 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE536 Property

Gets the PANTONE 536 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE536 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE536
C#
public static PDFPantoneColor PANTONE536 {get;}
Delphi
public read-only property PANTONE536: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE536();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE536 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 536 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE537 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE537 Property

Gets the PANTONE 537 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE537 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE537
C#
public static PDFPantoneColor PANTONE537 {get;}
Delphi
public read-only property PANTONE537: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE537();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE537 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 537 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE538 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE538 Property

Gets the PANTONE 538 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE538 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE538
C#
public static PDFPantoneColor PANTONE538 {get;}
Delphi
public read-only property PANTONE538: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE538();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE538 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 538 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE539 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE539 Property

Gets the PANTONE 539 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE539 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE539
C#
public static PDFPantoneColor PANTONE539 {get;}
Delphi
public read-only property PANTONE539: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE539();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE539 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 539 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5395 Property

Gets the PANTONE 5395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5395
C#
public static PDFPantoneColor PANTONE5395 {get;}
Delphi
public read-only property PANTONE5395: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE540 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE540 Property

Gets the PANTONE 540 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE540 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE540
C#
public static PDFPantoneColor PANTONE540 {get;}
Delphi
public read-only property PANTONE540: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE540();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE540 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 540 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5405 Property

Gets the PANTONE 5405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5405
C#
public static PDFPantoneColor PANTONE5405 {get;}
Delphi
public read-only property PANTONE5405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE541 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE541 Property

Gets the PANTONE 541 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE541 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE541
C#
public static PDFPantoneColor PANTONE541 {get;}
Delphi
public read-only property PANTONE541: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE541();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE541 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 541 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5415 Property

Gets the PANTONE 5415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5415
C#
public static PDFPantoneColor PANTONE5415 {get;}
Delphi
public read-only property PANTONE5415: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE542 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE542 Property

Gets the PANTONE 542 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE542 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE542
C#
public static PDFPantoneColor PANTONE542 {get;}
Delphi
public read-only property PANTONE542: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE542();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE542 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 542 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5425 Property

Gets the PANTONE 5425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5425
C#
public static PDFPantoneColor PANTONE5425 {get;}
Delphi
public read-only property PANTONE5425: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE543 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE543 Property

Gets the PANTONE 543 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE543 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE543
C#
public static PDFPantoneColor PANTONE543 {get;}
Delphi
public read-only property PANTONE543: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE543();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE543 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 543 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5435 Property

Gets the PANTONE 5435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5435
C#
public static PDFPantoneColor PANTONE5435 {get;}
Delphi
public read-only property PANTONE5435: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE544 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE544 Property

Gets the PANTONE 544 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE544 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE544
C#
public static PDFPantoneColor PANTONE544 {get;}
Delphi
public read-only property PANTONE544: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE544();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE544 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 544 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5445 Property

Gets the PANTONE 5445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5445
C#
public static PDFPantoneColor PANTONE5445 {get;}
Delphi
public read-only property PANTONE5445: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE545 Property

Gets the PANTONE 545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE545
C#
public static PDFPantoneColor PANTONE545 {get;}
Delphi
public read-only property PANTONE545: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5455 Property

Gets the PANTONE 5455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5455
C#
public static PDFPantoneColor PANTONE5455 {get;}
Delphi
public read-only property PANTONE5455: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE546 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE546 Property

Gets the PANTONE 546 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE546 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE546
C#
public static PDFPantoneColor PANTONE546 {get;}
Delphi
public read-only property PANTONE546: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE546();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE546 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 546 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5463 Property

Gets the PANTONE 5463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5463
C#
public static PDFPantoneColor PANTONE5463 {get;}
Delphi
public read-only property PANTONE5463: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5467 Property

Gets the PANTONE 5467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5467
C#
public static PDFPantoneColor PANTONE5467 {get;}
Delphi
public read-only property PANTONE5467: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE547 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE547 Property

Gets the PANTONE 547 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE547 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE547
C#
public static PDFPantoneColor PANTONE547 {get;}
Delphi
public read-only property PANTONE547: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE547();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE547 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 547 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5473 Property

Gets the PANTONE 5473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5473
C#
public static PDFPantoneColor PANTONE5473 {get;}
Delphi
public read-only property PANTONE5473: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5477 Property

Gets the PANTONE 5477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5477
C#
public static PDFPantoneColor PANTONE5477 {get;}
Delphi
public read-only property PANTONE5477: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE548 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE548 Property

Gets the PANTONE 548 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE548 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE548
C#
public static PDFPantoneColor PANTONE548 {get;}
Delphi
public read-only property PANTONE548: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE548();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE548 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 548 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5483 Property

Gets the PANTONE 5483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5483
C#
public static PDFPantoneColor PANTONE5483 {get;}
Delphi
public read-only property PANTONE5483: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5487 Property

Gets the PANTONE 5487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5487
C#
public static PDFPantoneColor PANTONE5487 {get;}
Delphi
public read-only property PANTONE5487: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE549 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE549 Property

Gets the PANTONE 549 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE549 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE549
C#
public static PDFPantoneColor PANTONE549 {get;}
Delphi
public read-only property PANTONE549: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE549();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE549 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 549 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5493 Property

Gets the PANTONE 5493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5493
C#
public static PDFPantoneColor PANTONE5493 {get;}
Delphi
public read-only property PANTONE5493: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5497 Property

Gets the PANTONE 5497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5497
C#
public static PDFPantoneColor PANTONE5497 {get;}
Delphi
public read-only property PANTONE5497: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE550 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE550 Property

Gets the PANTONE 550 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE550 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE550
C#
public static PDFPantoneColor PANTONE550 {get;}
Delphi
public read-only property PANTONE550: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE550();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE550 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 550 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5503 Property

Gets the PANTONE 5503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5503
C#
public static PDFPantoneColor PANTONE5503 {get;}
Delphi
public read-only property PANTONE5503: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5507 Property

Gets the PANTONE 5507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5507
C#
public static PDFPantoneColor PANTONE5507 {get;}
Delphi
public read-only property PANTONE5507: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE551 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE551 Property

Gets the PANTONE 551 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE551 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE551
C#
public static PDFPantoneColor PANTONE551 {get;}
Delphi
public read-only property PANTONE551: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE551();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE551 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 551 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5513 Property

Gets the PANTONE 5513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5513
C#
public static PDFPantoneColor PANTONE5513 {get;}
Delphi
public read-only property PANTONE5513: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5517 Property

Gets the PANTONE 5517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5517
C#
public static PDFPantoneColor PANTONE5517 {get;}
Delphi
public read-only property PANTONE5517: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE552 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE552 Property

Gets the PANTONE 552 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE552 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE552
C#
public static PDFPantoneColor PANTONE552 {get;}
Delphi
public read-only property PANTONE552: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE552();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE552 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 552 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5523 Property

Gets the PANTONE 5523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5523
C#
public static PDFPantoneColor PANTONE5523 {get;}
Delphi
public read-only property PANTONE5523: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5527 Property

Gets the PANTONE 5527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5527
C#
public static PDFPantoneColor PANTONE5527 {get;}
Delphi
public read-only property PANTONE5527: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE553 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE553 Property

Gets the PANTONE 553 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE553 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE553
C#
public static PDFPantoneColor PANTONE553 {get;}
Delphi
public read-only property PANTONE553: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE553();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE553 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 553 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5535 Property

Gets the PANTONE 5535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5535
C#
public static PDFPantoneColor PANTONE5535 {get;}
Delphi
public read-only property PANTONE5535: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE554 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE554 Property

Gets the PANTONE 554 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE554 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE554
C#
public static PDFPantoneColor PANTONE554 {get;}
Delphi
public read-only property PANTONE554: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE554();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE554 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 554 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5545 Property

Gets the PANTONE 5545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5545
C#
public static PDFPantoneColor PANTONE5545 {get;}
Delphi
public read-only property PANTONE5545: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE555 Property

Gets the PANTONE 555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE555
C#
public static PDFPantoneColor PANTONE555 {get;}
Delphi
public read-only property PANTONE555: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5555 Property

Gets the PANTONE 5555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5555
C#
public static PDFPantoneColor PANTONE5555 {get;}
Delphi
public read-only property PANTONE5555: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE556 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE556 Property

Gets the PANTONE 556 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE556 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE556
C#
public static PDFPantoneColor PANTONE556 {get;}
Delphi
public read-only property PANTONE556: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE556();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE556 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 556 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5565 Property

Gets the PANTONE 5565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5565
C#
public static PDFPantoneColor PANTONE5565 {get;}
Delphi
public read-only property PANTONE5565: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE557 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE557 Property

Gets the PANTONE 557 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE557 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE557
C#
public static PDFPantoneColor PANTONE557 {get;}
Delphi
public read-only property PANTONE557: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE557();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE557 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 557 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5575 Property

Gets the PANTONE 5575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5575
C#
public static PDFPantoneColor PANTONE5575 {get;}
Delphi
public read-only property PANTONE5575: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE558 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE558 Property

Gets the PANTONE 558 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE558 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE558
C#
public static PDFPantoneColor PANTONE558 {get;}
Delphi
public read-only property PANTONE558: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE558();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE558 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 558 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5585 Property

Gets the PANTONE 5585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5585
C#
public static PDFPantoneColor PANTONE5585 {get;}
Delphi
public read-only property PANTONE5585: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE559 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE559 Property

Gets the PANTONE 559 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE559 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE559
C#
public static PDFPantoneColor PANTONE559 {get;}
Delphi
public read-only property PANTONE559: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE559();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE559 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 559 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5595 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5595 Property

Gets the PANTONE 5595 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5595 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5595
C#
public static PDFPantoneColor PANTONE5595 {get;}
Delphi
public read-only property PANTONE5595: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5595();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5595 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5595 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE560 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE560 Property

Gets the PANTONE 560 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE560 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE560
C#
public static PDFPantoneColor PANTONE560 {get;}
Delphi
public read-only property PANTONE560: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE560();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE560 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 560 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5605 Property

Gets the PANTONE 5605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5605
C#
public static PDFPantoneColor PANTONE5605 {get;}
Delphi
public read-only property PANTONE5605: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE561 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE561 Property

Gets the PANTONE 561 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE561 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE561
C#
public static PDFPantoneColor PANTONE561 {get;}
Delphi
public read-only property PANTONE561: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE561();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE561 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 561 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5615 Property

Gets the PANTONE 5615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5615
C#
public static PDFPantoneColor PANTONE5615 {get;}
Delphi
public read-only property PANTONE5615: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE562 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE562 Property

Gets the PANTONE 562 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE562 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE562
C#
public static PDFPantoneColor PANTONE562 {get;}
Delphi
public read-only property PANTONE562: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE562();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE562 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 562 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5625 Property

Gets the PANTONE 5625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5625
C#
public static PDFPantoneColor PANTONE5625 {get;}
Delphi
public read-only property PANTONE5625: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE563 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE563 Property

Gets the PANTONE 563 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE563 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE563
C#
public static PDFPantoneColor PANTONE563 {get;}
Delphi
public read-only property PANTONE563: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE563();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE563 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 563 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5635 Property

Gets the PANTONE 5635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5635
C#
public static PDFPantoneColor PANTONE5635 {get;}
Delphi
public read-only property PANTONE5635: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE564 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE564 Property

Gets the PANTONE 564 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE564 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE564
C#
public static PDFPantoneColor PANTONE564 {get;}
Delphi
public read-only property PANTONE564: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE564();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE564 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 564 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5645 Property

Gets the PANTONE 5645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5645
C#
public static PDFPantoneColor PANTONE5645 {get;}
Delphi
public read-only property PANTONE5645: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE565 Property

Gets the PANTONE 565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE565
C#
public static PDFPantoneColor PANTONE565 {get;}
Delphi
public read-only property PANTONE565: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5655 Property

Gets the PANTONE 5655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5655
C#
public static PDFPantoneColor PANTONE5655 {get;}
Delphi
public read-only property PANTONE5655: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE566 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE566 Property

Gets the PANTONE 566 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE566 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE566
C#
public static PDFPantoneColor PANTONE566 {get;}
Delphi
public read-only property PANTONE566: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE566();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE566 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 566 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5665 Property

Gets the PANTONE 5665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5665
C#
public static PDFPantoneColor PANTONE5665 {get;}
Delphi
public read-only property PANTONE5665: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE567 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE567 Property

Gets the PANTONE 567 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE567 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE567
C#
public static PDFPantoneColor PANTONE567 {get;}
Delphi
public read-only property PANTONE567: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE567();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE567 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 567 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE568 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE568 Property

Gets the PANTONE 568 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE568 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE568
C#
public static PDFPantoneColor PANTONE568 {get;}
Delphi
public read-only property PANTONE568: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE568();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE568 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 568 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE569 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE569 Property

Gets the PANTONE 569 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE569 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE569
C#
public static PDFPantoneColor PANTONE569 {get;}
Delphi
public read-only property PANTONE569: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE569();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE569 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 569 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE570 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE570 Property

Gets the PANTONE 570 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE570 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE570
C#
public static PDFPantoneColor PANTONE570 {get;}
Delphi
public read-only property PANTONE570: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE570();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE570 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 570 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE571 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE571 Property

Gets the PANTONE 571 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE571 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE571
C#
public static PDFPantoneColor PANTONE571 {get;}
Delphi
public read-only property PANTONE571: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE571();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE571 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 571 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE572 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE572 Property

Gets the PANTONE 572 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE572 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE572
C#
public static PDFPantoneColor PANTONE572 {get;}
Delphi
public read-only property PANTONE572: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE572();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE572 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 572 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE573 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE573 Property

Gets the PANTONE 573 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE573 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE573
C#
public static PDFPantoneColor PANTONE573 {get;}
Delphi
public read-only property PANTONE573: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE573();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE573 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 573 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE574 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE574 Property

Gets the PANTONE 574 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE574 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE574
C#
public static PDFPantoneColor PANTONE574 {get;}
Delphi
public read-only property PANTONE574: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE574();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE574 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 574 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5743 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5743 Property

Gets the PANTONE 5743 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5743 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5743
C#
public static PDFPantoneColor PANTONE5743 {get;}
Delphi
public read-only property PANTONE5743: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5743();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5743 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5743 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5747 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5747 Property

Gets the PANTONE 5747 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5747 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5747
C#
public static PDFPantoneColor PANTONE5747 {get;}
Delphi
public read-only property PANTONE5747: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5747();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5747 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5747 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE575 Property

Gets the PANTONE 575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE575
C#
public static PDFPantoneColor PANTONE575 {get;}
Delphi
public read-only property PANTONE575: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5753 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5753 Property

Gets the PANTONE 5753 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5753 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5753
C#
public static PDFPantoneColor PANTONE5753 {get;}
Delphi
public read-only property PANTONE5753: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5753();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5753 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5753 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5757 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5757 Property

Gets the PANTONE 5757 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5757 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5757
C#
public static PDFPantoneColor PANTONE5757 {get;}
Delphi
public read-only property PANTONE5757: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5757();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5757 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5757 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE576 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE576 Property

Gets the PANTONE 576 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE576 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE576
C#
public static PDFPantoneColor PANTONE576 {get;}
Delphi
public read-only property PANTONE576: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE576();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE576 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 576 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5763 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5763 Property

Gets the PANTONE 5763 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5763 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5763
C#
public static PDFPantoneColor PANTONE5763 {get;}
Delphi
public read-only property PANTONE5763: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5763();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5763 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5763 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5767 Property

Gets the PANTONE 5767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5767
C#
public static PDFPantoneColor PANTONE5767 {get;}
Delphi
public read-only property PANTONE5767: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE577 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE577 Property

Gets the PANTONE 577 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE577 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE577
C#
public static PDFPantoneColor PANTONE577 {get;}
Delphi
public read-only property PANTONE577: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE577();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE577 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 577 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5773 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5773 Property

Gets the PANTONE 5773 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5773 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5773
C#
public static PDFPantoneColor PANTONE5773 {get;}
Delphi
public read-only property PANTONE5773: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5773();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5773 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5773 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5777 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5777 Property

Gets the PANTONE 5777 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5777 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5777
C#
public static PDFPantoneColor PANTONE5777 {get;}
Delphi
public read-only property PANTONE5777: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5777();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5777 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5777 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE578 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE578 Property

Gets the PANTONE 578 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE578 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE578
C#
public static PDFPantoneColor PANTONE578 {get;}
Delphi
public read-only property PANTONE578: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE578();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE578 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 578 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5783 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5783 Property

Gets the PANTONE 5783 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5783 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5783
C#
public static PDFPantoneColor PANTONE5783 {get;}
Delphi
public read-only property PANTONE5783: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5783();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5783 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5783 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5787 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5787 Property

Gets the PANTONE 5787 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5787 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5787
C#
public static PDFPantoneColor PANTONE5787 {get;}
Delphi
public read-only property PANTONE5787: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5787();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5787 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5787 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE579 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE579 Property

Gets the PANTONE 579 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE579 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE579
C#
public static PDFPantoneColor PANTONE579 {get;}
Delphi
public read-only property PANTONE579: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE579();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE579 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 579 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5793 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5793 Property

Gets the PANTONE 5793 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5793 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5793
C#
public static PDFPantoneColor PANTONE5793 {get;}
Delphi
public read-only property PANTONE5793: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5793();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5793 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5793 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5797 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5797 Property

Gets the PANTONE 5797 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5797 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5797
C#
public static PDFPantoneColor PANTONE5797 {get;}
Delphi
public read-only property PANTONE5797: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5797();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5797 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5797 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE580 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE580 Property

Gets the PANTONE 580 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE580 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE580
C#
public static PDFPantoneColor PANTONE580 {get;}
Delphi
public read-only property PANTONE580: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE580();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE580 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 580 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5803 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5803 Property

Gets the PANTONE 5803 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5803 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5803
C#
public static PDFPantoneColor PANTONE5803 {get;}
Delphi
public read-only property PANTONE5803: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5803();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5803 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5803 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5807 Property

Gets the PANTONE 5807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5807
C#
public static PDFPantoneColor PANTONE5807 {get;}
Delphi
public read-only property PANTONE5807: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE581 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE581 Property

Gets the PANTONE 581 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE581 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE581
C#
public static PDFPantoneColor PANTONE581 {get;}
Delphi
public read-only property PANTONE581: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE581();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE581 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 581 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5815 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5815 Property

Gets the PANTONE 5815 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5815 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5815
C#
public static PDFPantoneColor PANTONE5815 {get;}
Delphi
public read-only property PANTONE5815: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5815();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5815 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5815 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE582 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE582 Property

Gets the PANTONE 582 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE582 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE582
C#
public static PDFPantoneColor PANTONE582 {get;}
Delphi
public read-only property PANTONE582: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE582();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE582 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 582 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5825 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5825 Property

Gets the PANTONE 5825 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5825 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5825
C#
public static PDFPantoneColor PANTONE5825 {get;}
Delphi
public read-only property PANTONE5825: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5825();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5825 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5825 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE583 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE583 Property

Gets the PANTONE 583 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE583 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE583
C#
public static PDFPantoneColor PANTONE583 {get;}
Delphi
public read-only property PANTONE583: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE583();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE583 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 583 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5835 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5835 Property

Gets the PANTONE 5835 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5835 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5835
C#
public static PDFPantoneColor PANTONE5835 {get;}
Delphi
public read-only property PANTONE5835: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5835();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5835 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5835 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE584 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE584 Property

Gets the PANTONE 584 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE584 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE584
C#
public static PDFPantoneColor PANTONE584 {get;}
Delphi
public read-only property PANTONE584: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE584();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE584 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 584 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5845 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5845 Property

Gets the PANTONE 5845 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5845 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5845
C#
public static PDFPantoneColor PANTONE5845 {get;}
Delphi
public read-only property PANTONE5845: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5845();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5845 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5845 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE585 Property

Gets the PANTONE 585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE585
C#
public static PDFPantoneColor PANTONE585 {get;}
Delphi
public read-only property PANTONE585: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5855 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5855 Property

Gets the PANTONE 5855 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5855 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5855
C#
public static PDFPantoneColor PANTONE5855 {get;}
Delphi
public read-only property PANTONE5855: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5855();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5855 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5855 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE586 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE586 Property

Gets the PANTONE 586 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE586 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE586
C#
public static PDFPantoneColor PANTONE586 {get;}
Delphi
public read-only property PANTONE586: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE586();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE586 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 586 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5865 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5865 Property

Gets the PANTONE 5865 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5865 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5865
C#
public static PDFPantoneColor PANTONE5865 {get;}
Delphi
public read-only property PANTONE5865: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5865();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5865 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5865 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE587 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE587 Property

Gets the PANTONE 587 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE587 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE587
C#
public static PDFPantoneColor PANTONE587 {get;}
Delphi
public read-only property PANTONE587: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE587();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE587 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 587 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE5875 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5875 Property

Gets the PANTONE 5875 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5875 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5875
C#
public static PDFPantoneColor PANTONE5875 {get;}
Delphi
public read-only property PANTONE5875: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5875();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5875 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5875 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE600 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE600 Property

Gets the PANTONE 600 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE600 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE600
C#
public static PDFPantoneColor PANTONE600 {get;}
Delphi
public read-only property PANTONE600: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE600();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE600 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 600 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE601 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE601 Property

Gets the PANTONE 601 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE601 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE601
C#
public static PDFPantoneColor PANTONE601 {get;}
Delphi
public read-only property PANTONE601: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE601();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE601 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 601 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE602 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE602 Property

Gets the PANTONE 602 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE602 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE602
C#
public static PDFPantoneColor PANTONE602 {get;}
Delphi
public read-only property PANTONE602: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE602();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE602 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 602 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE603 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE603 Property

Gets the PANTONE 603 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE603 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE603
C#
public static PDFPantoneColor PANTONE603 {get;}
Delphi
public read-only property PANTONE603: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE603();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE603 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 603 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE604 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE604 Property

Gets the PANTONE 604 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE604 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE604
C#
public static PDFPantoneColor PANTONE604 {get;}
Delphi
public read-only property PANTONE604: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE604();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE604 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 604 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE605 Property

Gets the PANTONE 605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE605
C#
public static PDFPantoneColor PANTONE605 {get;}
Delphi
public read-only property PANTONE605: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE606 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE606 Property

Gets the PANTONE 606 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE606 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE606
C#
public static PDFPantoneColor PANTONE606 {get;}
Delphi
public read-only property PANTONE606: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE606();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE606 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 606 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE607 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE607 Property

Gets the PANTONE 607 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE607 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE607
C#
public static PDFPantoneColor PANTONE607 {get;}
Delphi
public read-only property PANTONE607: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE607();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE607 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 607 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE608 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE608 Property

Gets the PANTONE 608 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE608 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE608
C#
public static PDFPantoneColor PANTONE608 {get;}
Delphi
public read-only property PANTONE608: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE608();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE608 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 608 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE609 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE609 Property

Gets the PANTONE 609 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE609 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE609
C#
public static PDFPantoneColor PANTONE609 {get;}
Delphi
public read-only property PANTONE609: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE609();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE609 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 609 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE610 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE610 Property

Gets the PANTONE 610 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE610 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE610
C#
public static PDFPantoneColor PANTONE610 {get;}
Delphi
public read-only property PANTONE610: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE610();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE610 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 610 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE611 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE611 Property

Gets the PANTONE 611 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE611 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE611
C#
public static PDFPantoneColor PANTONE611 {get;}
Delphi
public read-only property PANTONE611: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE611();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE611 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 611 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE612 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE612 Property

Gets the PANTONE 612 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE612 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE612
C#
public static PDFPantoneColor PANTONE612 {get;}
Delphi
public read-only property PANTONE612: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE612();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE612 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 612 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE613 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE613 Property

Gets the PANTONE 613 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE613 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE613
C#
public static PDFPantoneColor PANTONE613 {get;}
Delphi
public read-only property PANTONE613: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE613();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE613 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 613 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE614 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE614 Property

Gets the PANTONE 614 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE614 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE614
C#
public static PDFPantoneColor PANTONE614 {get;}
Delphi
public read-only property PANTONE614: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE614();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE614 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 614 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE615 Property

Gets the PANTONE 615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE615
C#
public static PDFPantoneColor PANTONE615 {get;}
Delphi
public read-only property PANTONE615: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE616 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE616 Property

Gets the PANTONE 616 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE616 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE616
C#
public static PDFPantoneColor PANTONE616 {get;}
Delphi
public read-only property PANTONE616: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE616();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE616 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 616 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE617 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE617 Property

Gets the PANTONE 617 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE617 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE617
C#
public static PDFPantoneColor PANTONE617 {get;}
Delphi
public read-only property PANTONE617: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE617();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE617 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 617 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE618 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE618 Property

Gets the PANTONE 618 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE618 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE618
C#
public static PDFPantoneColor PANTONE618 {get;}
Delphi
public read-only property PANTONE618: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE618();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE618 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 618 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE619 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE619 Property

Gets the PANTONE 619 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE619 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE619
C#
public static PDFPantoneColor PANTONE619 {get;}
Delphi
public read-only property PANTONE619: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE619();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE619 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 619 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE620 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE620 Property

Gets the PANTONE 620 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE620 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE620
C#
public static PDFPantoneColor PANTONE620 {get;}
Delphi
public read-only property PANTONE620: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE620();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE620 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 620 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE621 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE621 Property

Gets the PANTONE 621 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE621 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE621
C#
public static PDFPantoneColor PANTONE621 {get;}
Delphi
public read-only property PANTONE621: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE621();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE621 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 621 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE622 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE622 Property

Gets the PANTONE 622 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE622 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE622
C#
public static PDFPantoneColor PANTONE622 {get;}
Delphi
public read-only property PANTONE622: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE622();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE622 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 622 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE623 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE623 Property

Gets the PANTONE 623 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE623 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE623
C#
public static PDFPantoneColor PANTONE623 {get;}
Delphi
public read-only property PANTONE623: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE623();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE623 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 623 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE624 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE624 Property

Gets the PANTONE 624 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE624 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE624
C#
public static PDFPantoneColor PANTONE624 {get;}
Delphi
public read-only property PANTONE624: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE624();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE624 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 624 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE625 Property

Gets the PANTONE 625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE625
C#
public static PDFPantoneColor PANTONE625 {get;}
Delphi
public read-only property PANTONE625: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE626 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE626 Property

Gets the PANTONE 626 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE626 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE626
C#
public static PDFPantoneColor PANTONE626 {get;}
Delphi
public read-only property PANTONE626: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE626();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE626 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 626 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE627 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE627 Property

Gets the PANTONE 627 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE627 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE627
C#
public static PDFPantoneColor PANTONE627 {get;}
Delphi
public read-only property PANTONE627: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE627();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE627 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 627 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE628 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE628 Property

Gets the PANTONE 628 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE628 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE628
C#
public static PDFPantoneColor PANTONE628 {get;}
Delphi
public read-only property PANTONE628: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE628();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE628 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 628 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE629 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE629 Property

Gets the PANTONE 629 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE629 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE629
C#
public static PDFPantoneColor PANTONE629 {get;}
Delphi
public read-only property PANTONE629: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE629();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE629 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 629 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE630 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE630 Property

Gets the PANTONE 630 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE630 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE630
C#
public static PDFPantoneColor PANTONE630 {get;}
Delphi
public read-only property PANTONE630: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE630();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE630 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 630 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE631 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE631 Property

Gets the PANTONE 631 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE631 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE631
C#
public static PDFPantoneColor PANTONE631 {get;}
Delphi
public read-only property PANTONE631: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE631();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE631 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 631 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE632 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE632 Property

Gets the PANTONE 632 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE632 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE632
C#
public static PDFPantoneColor PANTONE632 {get;}
Delphi
public read-only property PANTONE632: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE632();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE632 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 632 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE633 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE633 Property

Gets the PANTONE 633 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE633 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE633
C#
public static PDFPantoneColor PANTONE633 {get;}
Delphi
public read-only property PANTONE633: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE633();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE633 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 633 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE634 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE634 Property

Gets the PANTONE 634 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE634 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE634
C#
public static PDFPantoneColor PANTONE634 {get;}
Delphi
public read-only property PANTONE634: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE634();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE634 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 634 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE635 Property

Gets the PANTONE 635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE635
C#
public static PDFPantoneColor PANTONE635 {get;}
Delphi
public read-only property PANTONE635: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE636 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE636 Property

Gets the PANTONE 636 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE636 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE636
C#
public static PDFPantoneColor PANTONE636 {get;}
Delphi
public read-only property PANTONE636: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE636();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE636 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 636 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE637 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE637 Property

Gets the PANTONE 637 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE637 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE637
C#
public static PDFPantoneColor PANTONE637 {get;}
Delphi
public read-only property PANTONE637: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE637();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE637 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 637 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE638 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE638 Property

Gets the PANTONE 638 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE638 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE638
C#
public static PDFPantoneColor PANTONE638 {get;}
Delphi
public read-only property PANTONE638: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE638();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE638 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 638 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE639 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE639 Property

Gets the PANTONE 639 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE639 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE639
C#
public static PDFPantoneColor PANTONE639 {get;}
Delphi
public read-only property PANTONE639: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE639();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE639 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 639 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE640 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE640 Property

Gets the PANTONE 640 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE640 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE640
C#
public static PDFPantoneColor PANTONE640 {get;}
Delphi
public read-only property PANTONE640: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE640();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE640 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 640 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE641 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE641 Property

Gets the PANTONE 641 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE641 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE641
C#
public static PDFPantoneColor PANTONE641 {get;}
Delphi
public read-only property PANTONE641: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE641();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE641 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 641 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE642 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE642 Property

Gets the PANTONE 642 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE642 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE642
C#
public static PDFPantoneColor PANTONE642 {get;}
Delphi
public read-only property PANTONE642: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE642();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE642 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 642 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE643 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE643 Property

Gets the PANTONE 643 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE643 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE643
C#
public static PDFPantoneColor PANTONE643 {get;}
Delphi
public read-only property PANTONE643: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE643();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE643 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 643 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE644 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE644 Property

Gets the PANTONE 644 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE644 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE644
C#
public static PDFPantoneColor PANTONE644 {get;}
Delphi
public read-only property PANTONE644: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE644();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE644 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 644 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE645 Property

Gets the PANTONE 645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE645
C#
public static PDFPantoneColor PANTONE645 {get;}
Delphi
public read-only property PANTONE645: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE646 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE646 Property

Gets the PANTONE 646 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE646 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE646
C#
public static PDFPantoneColor PANTONE646 {get;}
Delphi
public read-only property PANTONE646: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE646();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE646 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 646 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE647 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE647 Property

Gets the PANTONE 647 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE647 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE647
C#
public static PDFPantoneColor PANTONE647 {get;}
Delphi
public read-only property PANTONE647: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE647();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE647 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 647 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE648 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE648 Property

Gets the PANTONE 648 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE648 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE648
C#
public static PDFPantoneColor PANTONE648 {get;}
Delphi
public read-only property PANTONE648: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE648();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE648 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 648 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE649 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE649 Property

Gets the PANTONE 649 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE649 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE649
C#
public static PDFPantoneColor PANTONE649 {get;}
Delphi
public read-only property PANTONE649: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE649();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE649 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 649 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE650 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE650 Property

Gets the PANTONE 650 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE650 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE650
C#
public static PDFPantoneColor PANTONE650 {get;}
Delphi
public read-only property PANTONE650: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE650();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE650 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 650 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE651 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE651 Property

Gets the PANTONE 651 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE651 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE651
C#
public static PDFPantoneColor PANTONE651 {get;}
Delphi
public read-only property PANTONE651: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE651();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE651 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 651 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE652 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE652 Property

Gets the PANTONE 652 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE652 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE652
C#
public static PDFPantoneColor PANTONE652 {get;}
Delphi
public read-only property PANTONE652: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE652();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE652 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 652 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE653 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE653 Property

Gets the PANTONE 653 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE653 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE653
C#
public static PDFPantoneColor PANTONE653 {get;}
Delphi
public read-only property PANTONE653: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE653();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE653 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 653 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE654 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE654 Property

Gets the PANTONE 654 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE654 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE654
C#
public static PDFPantoneColor PANTONE654 {get;}
Delphi
public read-only property PANTONE654: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE654();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE654 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 654 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE655 Property

Gets the PANTONE 655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE655
C#
public static PDFPantoneColor PANTONE655 {get;}
Delphi
public read-only property PANTONE655: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE656 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE656 Property

Gets the PANTONE 656 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE656 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE656
C#
public static PDFPantoneColor PANTONE656 {get;}
Delphi
public read-only property PANTONE656: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE656();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE656 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 656 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE657 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE657 Property

Gets the PANTONE 657 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE657 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE657
C#
public static PDFPantoneColor PANTONE657 {get;}
Delphi
public read-only property PANTONE657: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE657();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE657 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 657 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE658 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE658 Property

Gets the PANTONE 658 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE658 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE658
C#
public static PDFPantoneColor PANTONE658 {get;}
Delphi
public read-only property PANTONE658: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE658();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE658 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 658 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE659 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE659 Property

Gets the PANTONE 659 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE659 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE659
C#
public static PDFPantoneColor PANTONE659 {get;}
Delphi
public read-only property PANTONE659: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE659();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE659 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 659 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE660 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE660 Property

Gets the PANTONE 660 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE660 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE660
C#
public static PDFPantoneColor PANTONE660 {get;}
Delphi
public read-only property PANTONE660: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE660();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE660 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 660 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE661 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE661 Property

Gets the PANTONE 661 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE661 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE661
C#
public static PDFPantoneColor PANTONE661 {get;}
Delphi
public read-only property PANTONE661: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE661();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE661 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 661 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE662 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE662 Property

Gets the PANTONE 662 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE662 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE662
C#
public static PDFPantoneColor PANTONE662 {get;}
Delphi
public read-only property PANTONE662: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE662();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE662 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 662 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE663 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE663 Property

Gets the PANTONE 663 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE663 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE663
C#
public static PDFPantoneColor PANTONE663 {get;}
Delphi
public read-only property PANTONE663: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE663();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE663 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 663 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE664 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE664 Property

Gets the PANTONE 664 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE664 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE664
C#
public static PDFPantoneColor PANTONE664 {get;}
Delphi
public read-only property PANTONE664: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE664();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE664 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 664 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE665 Property

Gets the PANTONE 665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE665
C#
public static PDFPantoneColor PANTONE665 {get;}
Delphi
public read-only property PANTONE665: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE666 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE666 Property

Gets the PANTONE 666 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE666 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE666
C#
public static PDFPantoneColor PANTONE666 {get;}
Delphi
public read-only property PANTONE666: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE666();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE666 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 666 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE667 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE667 Property

Gets the PANTONE 667 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE667 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE667
C#
public static PDFPantoneColor PANTONE667 {get;}
Delphi
public read-only property PANTONE667: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE667();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE667 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 667 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE668 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE668 Property

Gets the PANTONE 668 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE668 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE668
C#
public static PDFPantoneColor PANTONE668 {get;}
Delphi
public read-only property PANTONE668: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE668();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE668 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 668 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE669 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE669 Property

Gets the PANTONE 669 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE669 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE669
C#
public static PDFPantoneColor PANTONE669 {get;}
Delphi
public read-only property PANTONE669: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE669();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE669 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 669 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE670 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE670 Property

Gets the PANTONE 670 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE670 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE670
C#
public static PDFPantoneColor PANTONE670 {get;}
Delphi
public read-only property PANTONE670: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE670();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE670 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 670 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE671 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE671 Property

Gets the PANTONE 671 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE671 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE671
C#
public static PDFPantoneColor PANTONE671 {get;}
Delphi
public read-only property PANTONE671: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE671();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE671 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 671 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE672 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE672 Property

Gets the PANTONE 672 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE672 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE672
C#
public static PDFPantoneColor PANTONE672 {get;}
Delphi
public read-only property PANTONE672: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE672();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE672 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 672 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE673 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE673 Property

Gets the PANTONE 673 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE673 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE673
C#
public static PDFPantoneColor PANTONE673 {get;}
Delphi
public read-only property PANTONE673: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE673();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE673 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 673 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE674 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE674 Property

Gets the PANTONE 674 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE674 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE674
C#
public static PDFPantoneColor PANTONE674 {get;}
Delphi
public read-only property PANTONE674: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE674();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE674 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 674 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE675 Property

Gets the PANTONE 675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE675
C#
public static PDFPantoneColor PANTONE675 {get;}
Delphi
public read-only property PANTONE675: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE676 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE676 Property

Gets the PANTONE 676 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE676 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE676
C#
public static PDFPantoneColor PANTONE676 {get;}
Delphi
public read-only property PANTONE676: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE676();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE676 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 676 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE677 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE677 Property

Gets the PANTONE 677 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE677 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE677
C#
public static PDFPantoneColor PANTONE677 {get;}
Delphi
public read-only property PANTONE677: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE677();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE677 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 677 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE678 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE678 Property

Gets the PANTONE 678 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE678 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE678
C#
public static PDFPantoneColor PANTONE678 {get;}
Delphi
public read-only property PANTONE678: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE678();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE678 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 678 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE679 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE679 Property

Gets the PANTONE 679 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE679 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE679
C#
public static PDFPantoneColor PANTONE679 {get;}
Delphi
public read-only property PANTONE679: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE679();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE679 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 679 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE680 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE680 Property

Gets the PANTONE 680 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE680 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE680
C#
public static PDFPantoneColor PANTONE680 {get;}
Delphi
public read-only property PANTONE680: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE680();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE680 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 680 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE681 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE681 Property

Gets the PANTONE 681 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE681 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE681
C#
public static PDFPantoneColor PANTONE681 {get;}
Delphi
public read-only property PANTONE681: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE681();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE681 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 681 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE682 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE682 Property

Gets the PANTONE 682 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE682 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE682
C#
public static PDFPantoneColor PANTONE682 {get;}
Delphi
public read-only property PANTONE682: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE682();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE682 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 682 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE683 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE683 Property

Gets the PANTONE 683 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE683 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE683
C#
public static PDFPantoneColor PANTONE683 {get;}
Delphi
public read-only property PANTONE683: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE683();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE683 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 683 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE684 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE684 Property

Gets the PANTONE 684 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE684 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE684
C#
public static PDFPantoneColor PANTONE684 {get;}
Delphi
public read-only property PANTONE684: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE684();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE684 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 684 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE685 Property

Gets the PANTONE 685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE685
C#
public static PDFPantoneColor PANTONE685 {get;}
Delphi
public read-only property PANTONE685: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE686 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE686 Property

Gets the PANTONE 686 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE686 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE686
C#
public static PDFPantoneColor PANTONE686 {get;}
Delphi
public read-only property PANTONE686: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE686();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE686 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 686 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE687 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE687 Property

Gets the PANTONE 687 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE687 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE687
C#
public static PDFPantoneColor PANTONE687 {get;}
Delphi
public read-only property PANTONE687: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE687();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE687 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 687 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE688 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE688 Property

Gets the PANTONE 688 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE688 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE688
C#
public static PDFPantoneColor PANTONE688 {get;}
Delphi
public read-only property PANTONE688: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE688();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE688 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 688 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE689 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE689 Property

Gets the PANTONE 689 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE689 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE689
C#
public static PDFPantoneColor PANTONE689 {get;}
Delphi
public read-only property PANTONE689: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE689();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE689 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 689 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE690 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE690 Property

Gets the PANTONE 690 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE690 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE690
C#
public static PDFPantoneColor PANTONE690 {get;}
Delphi
public read-only property PANTONE690: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE690();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE690 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 690 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE691 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE691 Property

Gets the PANTONE 691 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE691 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE691
C#
public static PDFPantoneColor PANTONE691 {get;}
Delphi
public read-only property PANTONE691: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE691();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE691 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 691 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE692 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE692 Property

Gets the PANTONE 692 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE692 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE692
C#
public static PDFPantoneColor PANTONE692 {get;}
Delphi
public read-only property PANTONE692: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE692();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE692 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 692 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE693 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE693 Property

Gets the PANTONE 693 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE693 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE693
C#
public static PDFPantoneColor PANTONE693 {get;}
Delphi
public read-only property PANTONE693: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE693();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE693 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 693 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE694 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE694 Property

Gets the PANTONE 694 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE694 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE694
C#
public static PDFPantoneColor PANTONE694 {get;}
Delphi
public read-only property PANTONE694: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE694();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE694 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 694 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE695 Property

Gets the PANTONE 695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE695
C#
public static PDFPantoneColor PANTONE695 {get;}
Delphi
public read-only property PANTONE695: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE696 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE696 Property

Gets the PANTONE 696 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE696 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE696
C#
public static PDFPantoneColor PANTONE696 {get;}
Delphi
public read-only property PANTONE696: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE696();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE696 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 696 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE697 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE697 Property

Gets the PANTONE 697 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE697 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE697
C#
public static PDFPantoneColor PANTONE697 {get;}
Delphi
public read-only property PANTONE697: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE697();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE697 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 697 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE698 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE698 Property

Gets the PANTONE 698 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE698 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE698
C#
public static PDFPantoneColor PANTONE698 {get;}
Delphi
public read-only property PANTONE698: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE698();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE698 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 698 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE699 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE699 Property

Gets the PANTONE 699 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE699 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE699
C#
public static PDFPantoneColor PANTONE699 {get;}
Delphi
public read-only property PANTONE699: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE699();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE699 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 699 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE700 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE700 Property

Gets the PANTONE 700 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE700 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE700
C#
public static PDFPantoneColor PANTONE700 {get;}
Delphi
public read-only property PANTONE700: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE700();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE700 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 700 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE701 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE701 Property

Gets the PANTONE 701 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE701 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE701
C#
public static PDFPantoneColor PANTONE701 {get;}
Delphi
public read-only property PANTONE701: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE701();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE701 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 701 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE702 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE702 Property

Gets the PANTONE 702 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE702 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE702
C#
public static PDFPantoneColor PANTONE702 {get;}
Delphi
public read-only property PANTONE702: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE702();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE702 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 702 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE703 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE703 Property

Gets the PANTONE 703 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE703 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE703
C#
public static PDFPantoneColor PANTONE703 {get;}
Delphi
public read-only property PANTONE703: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE703();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE703 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 703 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE704 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE704 Property

Gets the PANTONE 704 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE704 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE704
C#
public static PDFPantoneColor PANTONE704 {get;}
Delphi
public read-only property PANTONE704: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE704();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE704 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 704 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE705 Property

Gets the PANTONE 705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE705
C#
public static PDFPantoneColor PANTONE705 {get;}
Delphi
public read-only property PANTONE705: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE706 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE706 Property

Gets the PANTONE 706 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE706 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE706
C#
public static PDFPantoneColor PANTONE706 {get;}
Delphi
public read-only property PANTONE706: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE706();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE706 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 706 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE707 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE707 Property

Gets the PANTONE 707 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE707 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE707
C#
public static PDFPantoneColor PANTONE707 {get;}
Delphi
public read-only property PANTONE707: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE707();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE707 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 707 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE708 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE708 Property

Gets the PANTONE 708 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE708 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE708
C#
public static PDFPantoneColor PANTONE708 {get;}
Delphi
public read-only property PANTONE708: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE708();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE708 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 708 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE709 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE709 Property

Gets the PANTONE 709 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE709 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE709
C#
public static PDFPantoneColor PANTONE709 {get;}
Delphi
public read-only property PANTONE709: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE709();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE709 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 709 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE710 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE710 Property

Gets the PANTONE 710 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE710 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE710
C#
public static PDFPantoneColor PANTONE710 {get;}
Delphi
public read-only property PANTONE710: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE710();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE710 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 710 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE711 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE711 Property

Gets the PANTONE 711 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE711 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE711
C#
public static PDFPantoneColor PANTONE711 {get;}
Delphi
public read-only property PANTONE711: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE711();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE711 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 711 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE712 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE712 Property

Gets the PANTONE 712 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE712 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE712
C#
public static PDFPantoneColor PANTONE712 {get;}
Delphi
public read-only property PANTONE712: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE712();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE712 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 712 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE713 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE713 Property

Gets the PANTONE 713 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE713 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE713
C#
public static PDFPantoneColor PANTONE713 {get;}
Delphi
public read-only property PANTONE713: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE713();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE713 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 713 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE714 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE714 Property

Gets the PANTONE 714 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE714 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE714
C#
public static PDFPantoneColor PANTONE714 {get;}
Delphi
public read-only property PANTONE714: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE714();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE714 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 714 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE715 Property

Gets the PANTONE 715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE715
C#
public static PDFPantoneColor PANTONE715 {get;}
Delphi
public read-only property PANTONE715: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE716 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE716 Property

Gets the PANTONE 716 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE716 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE716
C#
public static PDFPantoneColor PANTONE716 {get;}
Delphi
public read-only property PANTONE716: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE716();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE716 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 716 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE717 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE717 Property

Gets the PANTONE 717 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE717 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE717
C#
public static PDFPantoneColor PANTONE717 {get;}
Delphi
public read-only property PANTONE717: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE717();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE717 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 717 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE718 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE718 Property

Gets the PANTONE 718 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE718 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE718
C#
public static PDFPantoneColor PANTONE718 {get;}
Delphi
public read-only property PANTONE718: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE718();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE718 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 718 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE719 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE719 Property

Gets the PANTONE 719 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE719 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE719
C#
public static PDFPantoneColor PANTONE719 {get;}
Delphi
public read-only property PANTONE719: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE719();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE719 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 719 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE720 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE720 Property

Gets the PANTONE 720 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE720 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE720
C#
public static PDFPantoneColor PANTONE720 {get;}
Delphi
public read-only property PANTONE720: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE720();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE720 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 720 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE721 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE721 Property

Gets the PANTONE 721 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE721 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE721
C#
public static PDFPantoneColor PANTONE721 {get;}
Delphi
public read-only property PANTONE721: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE721();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE721 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 721 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE722 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE722 Property

Gets the PANTONE 722 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE722 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE722
C#
public static PDFPantoneColor PANTONE722 {get;}
Delphi
public read-only property PANTONE722: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE722();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE722 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 722 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE723 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE723 Property

Gets the PANTONE 723 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE723 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE723
C#
public static PDFPantoneColor PANTONE723 {get;}
Delphi
public read-only property PANTONE723: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE723();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE723 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 723 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE724 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE724 Property

Gets the PANTONE 724 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE724 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE724
C#
public static PDFPantoneColor PANTONE724 {get;}
Delphi
public read-only property PANTONE724: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE724();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE724 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 724 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE725 Property

Gets the PANTONE 725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE725
C#
public static PDFPantoneColor PANTONE725 {get;}
Delphi
public read-only property PANTONE725: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE726 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE726 Property

Gets the PANTONE 726 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE726 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE726
C#
public static PDFPantoneColor PANTONE726 {get;}
Delphi
public read-only property PANTONE726: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE726();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE726 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 726 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE727 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE727 Property

Gets the PANTONE 727 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE727 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE727
C#
public static PDFPantoneColor PANTONE727 {get;}
Delphi
public read-only property PANTONE727: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE727();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE727 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 727 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE728 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE728 Property

Gets the PANTONE 728 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE728 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE728
C#
public static PDFPantoneColor PANTONE728 {get;}
Delphi
public read-only property PANTONE728: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE728();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE728 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 728 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE729 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE729 Property

Gets the PANTONE 729 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE729 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE729
C#
public static PDFPantoneColor PANTONE729 {get;}
Delphi
public read-only property PANTONE729: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE729();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE729 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 729 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE730 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE730 Property

Gets the PANTONE 730 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE730 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE730
C#
public static PDFPantoneColor PANTONE730 {get;}
Delphi
public read-only property PANTONE730: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE730();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE730 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 730 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE731 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE731 Property

Gets the PANTONE 731 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE731 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE731
C#
public static PDFPantoneColor PANTONE731 {get;}
Delphi
public read-only property PANTONE731: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE731();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE731 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 731 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE732 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE732 Property

Gets the PANTONE 732 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE732 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE732
C#
public static PDFPantoneColor PANTONE732 {get;}
Delphi
public read-only property PANTONE732: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE732();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE732 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 732 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7401 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7401 Property

Gets the PANTONE 7401 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7401 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7401
C#
public static PDFPantoneColor PANTONE7401 {get;}
Delphi
public read-only property PANTONE7401: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7401();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7401 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7401 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7402 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7402 Property

Gets the PANTONE 7402 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7402 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7402
C#
public static PDFPantoneColor PANTONE7402 {get;}
Delphi
public read-only property PANTONE7402: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7402();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7402 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7402 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7403 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7403 Property

Gets the PANTONE 7403 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7403 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7403
C#
public static PDFPantoneColor PANTONE7403 {get;}
Delphi
public read-only property PANTONE7403: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7403();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7403 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7403 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7404 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7404 Property

Gets the PANTONE 7404 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7404 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7404
C#
public static PDFPantoneColor PANTONE7404 {get;}
Delphi
public read-only property PANTONE7404: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7404();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7404 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7404 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7405 Property

Gets the PANTONE 7405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7405
C#
public static PDFPantoneColor PANTONE7405 {get;}
Delphi
public read-only property PANTONE7405: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7406 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7406 Property

Gets the PANTONE 7406 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7406 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7406
C#
public static PDFPantoneColor PANTONE7406 {get;}
Delphi
public read-only property PANTONE7406: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7406();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7406 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7406 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7407 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7407 Property

Gets the PANTONE 7407 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7407 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7407
C#
public static PDFPantoneColor PANTONE7407 {get;}
Delphi
public read-only property PANTONE7407: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7407();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7407 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7407 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7408 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7408 Property

Gets the PANTONE 7408 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7408 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7408
C#
public static PDFPantoneColor PANTONE7408 {get;}
Delphi
public read-only property PANTONE7408: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7408();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7408 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7408 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7409 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7409 Property

Gets the PANTONE 7409 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7409 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7409
C#
public static PDFPantoneColor PANTONE7409 {get;}
Delphi
public read-only property PANTONE7409: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7409();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7409 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7409 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7410 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7410 Property

Gets the PANTONE 7410 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7410 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7410
C#
public static PDFPantoneColor PANTONE7410 {get;}
Delphi
public read-only property PANTONE7410: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7410();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7410 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7410 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7411 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7411 Property

Gets the PANTONE 7411 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7411 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7411
C#
public static PDFPantoneColor PANTONE7411 {get;}
Delphi
public read-only property PANTONE7411: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7411();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7411 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7411 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7412 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7412 Property

Gets the PANTONE 7412 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7412 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7412
C#
public static PDFPantoneColor PANTONE7412 {get;}
Delphi
public read-only property PANTONE7412: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7412();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7412 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7412 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7413 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7413 Property

Gets the PANTONE 7413 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7413 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7413
C#
public static PDFPantoneColor PANTONE7413 {get;}
Delphi
public read-only property PANTONE7413: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7413();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7413 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7413 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7414 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7414 Property

Gets the PANTONE 7414 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7414 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7414
C#
public static PDFPantoneColor PANTONE7414 {get;}
Delphi
public read-only property PANTONE7414: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7414();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7414 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7414 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7415 Property

Gets the PANTONE 7415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7415
C#
public static PDFPantoneColor PANTONE7415 {get;}
Delphi
public read-only property PANTONE7415: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7416 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7416 Property

Gets the PANTONE 7416 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7416 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7416
C#
public static PDFPantoneColor PANTONE7416 {get;}
Delphi
public read-only property PANTONE7416: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7416();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7416 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7416 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7417 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7417 Property

Gets the PANTONE 7417 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7417 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7417
C#
public static PDFPantoneColor PANTONE7417 {get;}
Delphi
public read-only property PANTONE7417: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7417();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7417 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7417 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7418 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7418 Property

Gets the PANTONE 7418 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7418 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7418
C#
public static PDFPantoneColor PANTONE7418 {get;}
Delphi
public read-only property PANTONE7418: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7418();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7418 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7418 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7419 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7419 Property

Gets the PANTONE 7419 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7419 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7419
C#
public static PDFPantoneColor PANTONE7419 {get;}
Delphi
public read-only property PANTONE7419: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7419();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7419 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7419 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7420 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7420 Property

Gets the PANTONE 7420 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7420 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7420
C#
public static PDFPantoneColor PANTONE7420 {get;}
Delphi
public read-only property PANTONE7420: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7420();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7420 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7420 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7421 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7421 Property

Gets the PANTONE 7421 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7421 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7421
C#
public static PDFPantoneColor PANTONE7421 {get;}
Delphi
public read-only property PANTONE7421: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7421();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7421 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7421 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7422 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7422 Property

Gets the PANTONE 7422 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7422 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7422
C#
public static PDFPantoneColor PANTONE7422 {get;}
Delphi
public read-only property PANTONE7422: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7422();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7422 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7422 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7423 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7423 Property

Gets the PANTONE 7423 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7423 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7423
C#
public static PDFPantoneColor PANTONE7423 {get;}
Delphi
public read-only property PANTONE7423: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7423();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7423 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7423 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7424 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7424 Property

Gets the PANTONE 7424 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7424 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7424
C#
public static PDFPantoneColor PANTONE7424 {get;}
Delphi
public read-only property PANTONE7424: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7424();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7424 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7424 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7425 Property

Gets the PANTONE 7425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7425
C#
public static PDFPantoneColor PANTONE7425 {get;}
Delphi
public read-only property PANTONE7425: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7426 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7426 Property

Gets the PANTONE 7426 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7426 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7426
C#
public static PDFPantoneColor PANTONE7426 {get;}
Delphi
public read-only property PANTONE7426: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7426();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7426 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7426 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7427 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7427 Property

Gets the PANTONE 7427 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7427 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7427
C#
public static PDFPantoneColor PANTONE7427 {get;}
Delphi
public read-only property PANTONE7427: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7427();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7427 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7427 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7428 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7428 Property

Gets the PANTONE 7428 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7428 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7428
C#
public static PDFPantoneColor PANTONE7428 {get;}
Delphi
public read-only property PANTONE7428: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7428();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7428 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7428 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7429 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7429 Property

Gets the PANTONE 7429 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7429 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7429
C#
public static PDFPantoneColor PANTONE7429 {get;}
Delphi
public read-only property PANTONE7429: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7429();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7429 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7429 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7430 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7430 Property

Gets the PANTONE 7430 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7430 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7430
C#
public static PDFPantoneColor PANTONE7430 {get;}
Delphi
public read-only property PANTONE7430: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7430();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7430 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7430 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7431 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7431 Property

Gets the PANTONE 7431 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7431 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7431
C#
public static PDFPantoneColor PANTONE7431 {get;}
Delphi
public read-only property PANTONE7431: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7431();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7431 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7431 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7432 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7432 Property

Gets the PANTONE 7432 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7432 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7432
C#
public static PDFPantoneColor PANTONE7432 {get;}
Delphi
public read-only property PANTONE7432: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7432();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7432 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7432 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7433 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7433 Property

Gets the PANTONE 7433 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7433 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7433
C#
public static PDFPantoneColor PANTONE7433 {get;}
Delphi
public read-only property PANTONE7433: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7433();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7433 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7433 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7434 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7434 Property

Gets the PANTONE 7434 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7434 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7434
C#
public static PDFPantoneColor PANTONE7434 {get;}
Delphi
public read-only property PANTONE7434: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7434();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7434 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7434 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7435 Property

Gets the PANTONE 7435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7435
C#
public static PDFPantoneColor PANTONE7435 {get;}
Delphi
public read-only property PANTONE7435: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7436 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7436 Property

Gets the PANTONE 7436 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7436 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7436
C#
public static PDFPantoneColor PANTONE7436 {get;}
Delphi
public read-only property PANTONE7436: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7436();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7436 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7436 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7437 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7437 Property

Gets the PANTONE 7437 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7437 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7437
C#
public static PDFPantoneColor PANTONE7437 {get;}
Delphi
public read-only property PANTONE7437: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7437();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7437 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7437 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7438 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7438 Property

Gets the PANTONE 7438 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7438 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7438
C#
public static PDFPantoneColor PANTONE7438 {get;}
Delphi
public read-only property PANTONE7438: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7438();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7438 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7438 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7439 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7439 Property

Gets the PANTONE 7439 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7439 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7439
C#
public static PDFPantoneColor PANTONE7439 {get;}
Delphi
public read-only property PANTONE7439: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7439();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7439 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7439 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7440 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7440 Property

Gets the PANTONE 7440 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7440 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7440
C#
public static PDFPantoneColor PANTONE7440 {get;}
Delphi
public read-only property PANTONE7440: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7440();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7440 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7440 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7441 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7441 Property

Gets the PANTONE 7441 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7441 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7441
C#
public static PDFPantoneColor PANTONE7441 {get;}
Delphi
public read-only property PANTONE7441: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7441();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7441 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7441 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7442 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7442 Property

Gets the PANTONE 7442 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7442 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7442
C#
public static PDFPantoneColor PANTONE7442 {get;}
Delphi
public read-only property PANTONE7442: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7442();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7442 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7442 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7443 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7443 Property

Gets the PANTONE 7443 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7443 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7443
C#
public static PDFPantoneColor PANTONE7443 {get;}
Delphi
public read-only property PANTONE7443: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7443();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7443 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7443 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7444 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7444 Property

Gets the PANTONE 7444 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7444 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7444
C#
public static PDFPantoneColor PANTONE7444 {get;}
Delphi
public read-only property PANTONE7444: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7444();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7444 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7444 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7445 Property

Gets the PANTONE 7445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7445
C#
public static PDFPantoneColor PANTONE7445 {get;}
Delphi
public read-only property PANTONE7445: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7446 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7446 Property

Gets the PANTONE 7446 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7446 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7446
C#
public static PDFPantoneColor PANTONE7446 {get;}
Delphi
public read-only property PANTONE7446: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7446();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7446 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7446 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7447 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7447 Property

Gets the PANTONE 7447 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7447 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7447
C#
public static PDFPantoneColor PANTONE7447 {get;}
Delphi
public read-only property PANTONE7447: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7447();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7447 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7447 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7448 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7448 Property

Gets the PANTONE 7448 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7448 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7448
C#
public static PDFPantoneColor PANTONE7448 {get;}
Delphi
public read-only property PANTONE7448: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7448();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7448 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7448 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7449 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7449 Property

Gets the PANTONE 7449 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7449 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7449
C#
public static PDFPantoneColor PANTONE7449 {get;}
Delphi
public read-only property PANTONE7449: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7449();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7449 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7449 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7450 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7450 Property

Gets the PANTONE 7450 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7450 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7450
C#
public static PDFPantoneColor PANTONE7450 {get;}
Delphi
public read-only property PANTONE7450: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7450();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7450 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7450 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7451 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7451 Property

Gets the PANTONE 7451 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7451 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7451
C#
public static PDFPantoneColor PANTONE7451 {get;}
Delphi
public read-only property PANTONE7451: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7451();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7451 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7451 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7452 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7452 Property

Gets the PANTONE 7452 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7452 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7452
C#
public static PDFPantoneColor PANTONE7452 {get;}
Delphi
public read-only property PANTONE7452: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7452();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7452 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7452 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7453 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7453 Property

Gets the PANTONE 7453 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7453 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7453
C#
public static PDFPantoneColor PANTONE7453 {get;}
Delphi
public read-only property PANTONE7453: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7453();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7453 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7453 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7454 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7454 Property

Gets the PANTONE 7454 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7454 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7454
C#
public static PDFPantoneColor PANTONE7454 {get;}
Delphi
public read-only property PANTONE7454: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7454();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7454 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7454 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7455 Property

Gets the PANTONE 7455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7455
C#
public static PDFPantoneColor PANTONE7455 {get;}
Delphi
public read-only property PANTONE7455: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7456 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7456 Property

Gets the PANTONE 7456 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7456 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7456
C#
public static PDFPantoneColor PANTONE7456 {get;}
Delphi
public read-only property PANTONE7456: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7456();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7456 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7456 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7457 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7457 Property

Gets the PANTONE 7457 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7457 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7457
C#
public static PDFPantoneColor PANTONE7457 {get;}
Delphi
public read-only property PANTONE7457: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7457();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7457 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7457 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7458 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7458 Property

Gets the PANTONE 7458 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7458 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7458
C#
public static PDFPantoneColor PANTONE7458 {get;}
Delphi
public read-only property PANTONE7458: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7458();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7458 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7458 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7459 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7459 Property

Gets the PANTONE 7459 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7459 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7459
C#
public static PDFPantoneColor PANTONE7459 {get;}
Delphi
public read-only property PANTONE7459: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7459();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7459 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7459 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7460 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7460 Property

Gets the PANTONE 7460 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7460 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7460
C#
public static PDFPantoneColor PANTONE7460 {get;}
Delphi
public read-only property PANTONE7460: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7460();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7460 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7460 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7461 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7461 Property

Gets the PANTONE 7461 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7461 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7461
C#
public static PDFPantoneColor PANTONE7461 {get;}
Delphi
public read-only property PANTONE7461: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7461();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7461 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7461 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7462 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7462 Property

Gets the PANTONE 7462 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7462 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7462
C#
public static PDFPantoneColor PANTONE7462 {get;}
Delphi
public read-only property PANTONE7462: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7462();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7462 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7462 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7463 Property

Gets the PANTONE 7463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7463
C#
public static PDFPantoneColor PANTONE7463 {get;}
Delphi
public read-only property PANTONE7463: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7464 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7464 Property

Gets the PANTONE 7464 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7464 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7464
C#
public static PDFPantoneColor PANTONE7464 {get;}
Delphi
public read-only property PANTONE7464: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7464();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7464 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7464 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7465 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7465 Property

Gets the PANTONE 7465 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7465 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7465
C#
public static PDFPantoneColor PANTONE7465 {get;}
Delphi
public read-only property PANTONE7465: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7465();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7465 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7465 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7466 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7466 Property

Gets the PANTONE 7466 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7466 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7466
C#
public static PDFPantoneColor PANTONE7466 {get;}
Delphi
public read-only property PANTONE7466: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7466();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7466 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7466 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7467 Property

Gets the PANTONE 7467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7467
C#
public static PDFPantoneColor PANTONE7467 {get;}
Delphi
public read-only property PANTONE7467: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7468 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7468 Property

Gets the PANTONE 7468 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7468 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7468
C#
public static PDFPantoneColor PANTONE7468 {get;}
Delphi
public read-only property PANTONE7468: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7468();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7468 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7468 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7469 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7469 Property

Gets the PANTONE 7469 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7469 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7469
C#
public static PDFPantoneColor PANTONE7469 {get;}
Delphi
public read-only property PANTONE7469: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7469();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7469 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7469 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7470 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7470 Property

Gets the PANTONE 7470 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7470 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7470
C#
public static PDFPantoneColor PANTONE7470 {get;}
Delphi
public read-only property PANTONE7470: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7470();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7470 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7470 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7471 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7471 Property

Gets the PANTONE 7471 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7471 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7471
C#
public static PDFPantoneColor PANTONE7471 {get;}
Delphi
public read-only property PANTONE7471: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7471();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7471 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7471 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7472 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7472 Property

Gets the PANTONE 7472 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7472 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7472
C#
public static PDFPantoneColor PANTONE7472 {get;}
Delphi
public read-only property PANTONE7472: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7472();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7472 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7472 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7473 Property

Gets the PANTONE 7473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7473
C#
public static PDFPantoneColor PANTONE7473 {get;}
Delphi
public read-only property PANTONE7473: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7474 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7474 Property

Gets the PANTONE 7474 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7474 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7474
C#
public static PDFPantoneColor PANTONE7474 {get;}
Delphi
public read-only property PANTONE7474: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7474();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7474 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7474 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7475 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7475 Property

Gets the PANTONE 7475 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7475 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7475
C#
public static PDFPantoneColor PANTONE7475 {get;}
Delphi
public read-only property PANTONE7475: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7475();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7475 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7475 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7476 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7476 Property

Gets the PANTONE 7476 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7476 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7476
C#
public static PDFPantoneColor PANTONE7476 {get;}
Delphi
public read-only property PANTONE7476: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7476();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7476 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7476 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7477 Property

Gets the PANTONE 7477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7477
C#
public static PDFPantoneColor PANTONE7477 {get;}
Delphi
public read-only property PANTONE7477: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7478 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7478 Property

Gets the PANTONE 7478 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7478 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7478
C#
public static PDFPantoneColor PANTONE7478 {get;}
Delphi
public read-only property PANTONE7478: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7478();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7478 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7478 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7479 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7479 Property

Gets the PANTONE 7479 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7479 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7479
C#
public static PDFPantoneColor PANTONE7479 {get;}
Delphi
public read-only property PANTONE7479: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7479();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7479 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7479 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7480 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7480 Property

Gets the PANTONE 7480 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7480 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7480
C#
public static PDFPantoneColor PANTONE7480 {get;}
Delphi
public read-only property PANTONE7480: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7480();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7480 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7480 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7481 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7481 Property

Gets the PANTONE 7481 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7481 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7481
C#
public static PDFPantoneColor PANTONE7481 {get;}
Delphi
public read-only property PANTONE7481: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7481();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7481 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7481 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7482 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7482 Property

Gets the PANTONE 7482 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7482 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7482
C#
public static PDFPantoneColor PANTONE7482 {get;}
Delphi
public read-only property PANTONE7482: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7482();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7482 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7482 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7483 Property

Gets the PANTONE 7483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7483
C#
public static PDFPantoneColor PANTONE7483 {get;}
Delphi
public read-only property PANTONE7483: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7484 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7484 Property

Gets the PANTONE 7484 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7484 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7484
C#
public static PDFPantoneColor PANTONE7484 {get;}
Delphi
public read-only property PANTONE7484: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7484();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7484 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7484 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7485 Property

Gets the PANTONE 7485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7485
C#
public static PDFPantoneColor PANTONE7485 {get;}
Delphi
public read-only property PANTONE7485: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7486 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7486 Property

Gets the PANTONE 7486 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7486 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7486
C#
public static PDFPantoneColor PANTONE7486 {get;}
Delphi
public read-only property PANTONE7486: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7486();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7486 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7486 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7487 Property

Gets the PANTONE 7487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7487
C#
public static PDFPantoneColor PANTONE7487 {get;}
Delphi
public read-only property PANTONE7487: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7488 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7488 Property

Gets the PANTONE 7488 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7488 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7488
C#
public static PDFPantoneColor PANTONE7488 {get;}
Delphi
public read-only property PANTONE7488: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7488();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7488 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7488 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7489 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7489 Property

Gets the PANTONE 7489 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7489 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7489
C#
public static PDFPantoneColor PANTONE7489 {get;}
Delphi
public read-only property PANTONE7489: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7489();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7489 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7489 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7490 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7490 Property

Gets the PANTONE 7490 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7490 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7490
C#
public static PDFPantoneColor PANTONE7490 {get;}
Delphi
public read-only property PANTONE7490: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7490();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7490 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7490 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7491 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7491 Property

Gets the PANTONE 7491 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7491 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7491
C#
public static PDFPantoneColor PANTONE7491 {get;}
Delphi
public read-only property PANTONE7491: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7491();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7491 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7491 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7492 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7492 Property

Gets the PANTONE 7492 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7492 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7492
C#
public static PDFPantoneColor PANTONE7492 {get;}
Delphi
public read-only property PANTONE7492: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7492();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7492 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7492 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7493 Property

Gets the PANTONE 7493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7493
C#
public static PDFPantoneColor PANTONE7493 {get;}
Delphi
public read-only property PANTONE7493: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7494 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7494 Property

Gets the PANTONE 7494 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7494 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7494
C#
public static PDFPantoneColor PANTONE7494 {get;}
Delphi
public read-only property PANTONE7494: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7494();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7494 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7494 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7495 Property

Gets the PANTONE 7495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7495
C#
public static PDFPantoneColor PANTONE7495 {get;}
Delphi
public read-only property PANTONE7495: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7496 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7496 Property

Gets the PANTONE 7496 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7496 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7496
C#
public static PDFPantoneColor PANTONE7496 {get;}
Delphi
public read-only property PANTONE7496: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7496();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7496 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7496 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7497 Property

Gets the PANTONE 7497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7497
C#
public static PDFPantoneColor PANTONE7497 {get;}
Delphi
public read-only property PANTONE7497: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7498 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7498 Property

Gets the PANTONE 7498 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7498 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7498
C#
public static PDFPantoneColor PANTONE7498 {get;}
Delphi
public read-only property PANTONE7498: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7498();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7498 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7498 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7499 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7499 Property

Gets the PANTONE 7499 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7499 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7499
C#
public static PDFPantoneColor PANTONE7499 {get;}
Delphi
public read-only property PANTONE7499: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7499();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7499 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7499 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7500 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7500 Property

Gets the PANTONE 7500 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7500 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7500
C#
public static PDFPantoneColor PANTONE7500 {get;}
Delphi
public read-only property PANTONE7500: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7500();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7500 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7500 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7501 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7501 Property

Gets the PANTONE 7501 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7501 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7501
C#
public static PDFPantoneColor PANTONE7501 {get;}
Delphi
public read-only property PANTONE7501: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7501();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7501 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7501 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7502 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7502 Property

Gets the PANTONE 7502 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7502 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7502
C#
public static PDFPantoneColor PANTONE7502 {get;}
Delphi
public read-only property PANTONE7502: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7502();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7502 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7502 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7503 Property

Gets the PANTONE 7503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7503
C#
public static PDFPantoneColor PANTONE7503 {get;}
Delphi
public read-only property PANTONE7503: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7504 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7504 Property

Gets the PANTONE 7504 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7504 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7504
C#
public static PDFPantoneColor PANTONE7504 {get;}
Delphi
public read-only property PANTONE7504: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7504();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7504 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7504 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7505 Property

Gets the PANTONE 7505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7505
C#
public static PDFPantoneColor PANTONE7505 {get;}
Delphi
public read-only property PANTONE7505: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7506 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7506 Property

Gets the PANTONE 7506 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7506 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7506
C#
public static PDFPantoneColor PANTONE7506 {get;}
Delphi
public read-only property PANTONE7506: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7506();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7506 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7506 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7507 Property

Gets the PANTONE 7507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7507
C#
public static PDFPantoneColor PANTONE7507 {get;}
Delphi
public read-only property PANTONE7507: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7508 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7508 Property

Gets the PANTONE 7508 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7508 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7508
C#
public static PDFPantoneColor PANTONE7508 {get;}
Delphi
public read-only property PANTONE7508: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7508();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7508 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7508 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7509 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7509 Property

Gets the PANTONE 7509 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7509 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7509
C#
public static PDFPantoneColor PANTONE7509 {get;}
Delphi
public read-only property PANTONE7509: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7509();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7509 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7509 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7510 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7510 Property

Gets the PANTONE 7510 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7510 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7510
C#
public static PDFPantoneColor PANTONE7510 {get;}
Delphi
public read-only property PANTONE7510: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7510();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7510 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7510 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7511 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7511 Property

Gets the PANTONE 7511 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7511 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7511
C#
public static PDFPantoneColor PANTONE7511 {get;}
Delphi
public read-only property PANTONE7511: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7511();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7511 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7511 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7512 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7512 Property

Gets the PANTONE 7512 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7512 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7512
C#
public static PDFPantoneColor PANTONE7512 {get;}
Delphi
public read-only property PANTONE7512: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7512();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7512 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7512 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7513 Property

Gets the PANTONE 7513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7513
C#
public static PDFPantoneColor PANTONE7513 {get;}
Delphi
public read-only property PANTONE7513: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7514 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7514 Property

Gets the PANTONE 7514 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7514 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7514
C#
public static PDFPantoneColor PANTONE7514 {get;}
Delphi
public read-only property PANTONE7514: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7514();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7514 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7514 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7515 Property

Gets the PANTONE 7515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7515
C#
public static PDFPantoneColor PANTONE7515 {get;}
Delphi
public read-only property PANTONE7515: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7516 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7516 Property

Gets the PANTONE 7516 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7516 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7516
C#
public static PDFPantoneColor PANTONE7516 {get;}
Delphi
public read-only property PANTONE7516: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7516();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7516 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7516 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7517 Property

Gets the PANTONE 7517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7517
C#
public static PDFPantoneColor PANTONE7517 {get;}
Delphi
public read-only property PANTONE7517: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7518 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7518 Property

Gets the PANTONE 7518 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7518 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7518
C#
public static PDFPantoneColor PANTONE7518 {get;}
Delphi
public read-only property PANTONE7518: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7518();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7518 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7518 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7519 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7519 Property

Gets the PANTONE 7519 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7519 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7519
C#
public static PDFPantoneColor PANTONE7519 {get;}
Delphi
public read-only property PANTONE7519: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7519();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7519 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7519 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7520 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7520 Property

Gets the PANTONE 7520 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7520 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7520
C#
public static PDFPantoneColor PANTONE7520 {get;}
Delphi
public read-only property PANTONE7520: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7520();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7520 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7520 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7521 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7521 Property

Gets the PANTONE 7521 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7521 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7521
C#
public static PDFPantoneColor PANTONE7521 {get;}
Delphi
public read-only property PANTONE7521: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7521();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7521 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7521 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7522 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7522 Property

Gets the PANTONE 7522 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7522 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7522
C#
public static PDFPantoneColor PANTONE7522 {get;}
Delphi
public read-only property PANTONE7522: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7522();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7522 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7522 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7523 Property

Gets the PANTONE 7523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7523
C#
public static PDFPantoneColor PANTONE7523 {get;}
Delphi
public read-only property PANTONE7523: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7524 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7524 Property

Gets the PANTONE 7524 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7524 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7524
C#
public static PDFPantoneColor PANTONE7524 {get;}
Delphi
public read-only property PANTONE7524: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7524();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7524 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7524 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7525 Property

Gets the PANTONE 7525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7525
C#
public static PDFPantoneColor PANTONE7525 {get;}
Delphi
public read-only property PANTONE7525: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7526 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7526 Property

Gets the PANTONE 7526 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7526 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7526
C#
public static PDFPantoneColor PANTONE7526 {get;}
Delphi
public read-only property PANTONE7526: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7526();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7526 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7526 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7527 Property

Gets the PANTONE 7527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7527
C#
public static PDFPantoneColor PANTONE7527 {get;}
Delphi
public read-only property PANTONE7527: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7528 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7528 Property

Gets the PANTONE 7528 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7528 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7528
C#
public static PDFPantoneColor PANTONE7528 {get;}
Delphi
public read-only property PANTONE7528: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7528();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7528 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7528 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7529 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7529 Property

Gets the PANTONE 7529 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7529 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7529
C#
public static PDFPantoneColor PANTONE7529 {get;}
Delphi
public read-only property PANTONE7529: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7529();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7529 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7529 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7530 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7530 Property

Gets the PANTONE 7530 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7530 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7530
C#
public static PDFPantoneColor PANTONE7530 {get;}
Delphi
public read-only property PANTONE7530: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7530();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7530 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7530 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7531 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7531 Property

Gets the PANTONE 7531 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7531 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7531
C#
public static PDFPantoneColor PANTONE7531 {get;}
Delphi
public read-only property PANTONE7531: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7531();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7531 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7531 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7532 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7532 Property

Gets the PANTONE 7532 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7532 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7532
C#
public static PDFPantoneColor PANTONE7532 {get;}
Delphi
public read-only property PANTONE7532: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7532();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7532 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7532 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7533 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7533 Property

Gets the PANTONE 7533 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7533 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7533
C#
public static PDFPantoneColor PANTONE7533 {get;}
Delphi
public read-only property PANTONE7533: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7533();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7533 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7533 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7534 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7534 Property

Gets the PANTONE 7534 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7534 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7534
C#
public static PDFPantoneColor PANTONE7534 {get;}
Delphi
public read-only property PANTONE7534: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7534();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7534 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7534 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7535 Property

Gets the PANTONE 7535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7535
C#
public static PDFPantoneColor PANTONE7535 {get;}
Delphi
public read-only property PANTONE7535: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7536 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7536 Property

Gets the PANTONE 7536 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7536 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7536
C#
public static PDFPantoneColor PANTONE7536 {get;}
Delphi
public read-only property PANTONE7536: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7536();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7536 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7536 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7537 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7537 Property

Gets the PANTONE 7537 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7537 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7537
C#
public static PDFPantoneColor PANTONE7537 {get;}
Delphi
public read-only property PANTONE7537: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7537();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7537 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7537 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7538 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7538 Property

Gets the PANTONE 7538 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7538 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7538
C#
public static PDFPantoneColor PANTONE7538 {get;}
Delphi
public read-only property PANTONE7538: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7538();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7538 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7538 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7539 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7539 Property

Gets the PANTONE 7539 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7539 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7539
C#
public static PDFPantoneColor PANTONE7539 {get;}
Delphi
public read-only property PANTONE7539: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7539();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7539 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7539 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7540 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7540 Property

Gets the PANTONE 7540 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7540 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7540
C#
public static PDFPantoneColor PANTONE7540 {get;}
Delphi
public read-only property PANTONE7540: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7540();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7540 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7540 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7541 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7541 Property

Gets the PANTONE 7541 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7541 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7541
C#
public static PDFPantoneColor PANTONE7541 {get;}
Delphi
public read-only property PANTONE7541: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7541();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7541 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7541 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7542 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7542 Property

Gets the PANTONE 7542 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7542 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7542
C#
public static PDFPantoneColor PANTONE7542 {get;}
Delphi
public read-only property PANTONE7542: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7542();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7542 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7542 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7543 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7543 Property

Gets the PANTONE 7543 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7543 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7543
C#
public static PDFPantoneColor PANTONE7543 {get;}
Delphi
public read-only property PANTONE7543: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7543();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7543 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7543 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7544 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7544 Property

Gets the PANTONE 7544 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7544 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7544
C#
public static PDFPantoneColor PANTONE7544 {get;}
Delphi
public read-only property PANTONE7544: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7544();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7544 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7544 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7545 Property

Gets the PANTONE 7545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7545
C#
public static PDFPantoneColor PANTONE7545 {get;}
Delphi
public read-only property PANTONE7545: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7546 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7546 Property

Gets the PANTONE 7546 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7546 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7546
C#
public static PDFPantoneColor PANTONE7546 {get;}
Delphi
public read-only property PANTONE7546: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7546();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7546 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7546 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE7547 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7547 Property

Gets the PANTONE 7547 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7547 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7547
C#
public static PDFPantoneColor PANTONE7547 {get;}
Delphi
public read-only property PANTONE7547: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7547();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7547 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7547 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8003 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8003 Property

Gets the PANTONE 8003 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8003 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8003
C#
public static PDFPantoneColor PANTONE8003 {get;}
Delphi
public read-only property PANTONE8003: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8003();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8003 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8003 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE801 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE801 Property

Gets the PANTONE 801 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE801 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE801
C#
public static PDFPantoneColor PANTONE801 {get;}
Delphi
public read-only property PANTONE801: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE801();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE801 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 801 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE802 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE802 Property

Gets the PANTONE 802 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE802 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE802
C#
public static PDFPantoneColor PANTONE802 {get;}
Delphi
public read-only property PANTONE802: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE802();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE802 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 802 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8021 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8021 Property

Gets the PANTONE 8021 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8021 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8021
C#
public static PDFPantoneColor PANTONE8021 {get;}
Delphi
public read-only property PANTONE8021: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8021();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8021 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8021 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE803 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE803 Property

Gets the PANTONE 803 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE803 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE803
C#
public static PDFPantoneColor PANTONE803 {get;}
Delphi
public read-only property PANTONE803: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE803();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE803 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 803 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE804 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE804 Property

Gets the PANTONE 804 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE804 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE804
C#
public static PDFPantoneColor PANTONE804 {get;}
Delphi
public read-only property PANTONE804: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE804();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE804 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 804 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE805 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE805 Property

Gets the PANTONE 805 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE805 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE805
C#
public static PDFPantoneColor PANTONE805 {get;}
Delphi
public read-only property PANTONE805: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE805();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE805 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 805 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE806 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE806 Property

Gets the PANTONE 806 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE806 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE806
C#
public static PDFPantoneColor PANTONE806 {get;}
Delphi
public read-only property PANTONE806: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE806();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE806 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 806 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8062 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8062 Property

Gets the PANTONE 8062 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8062 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8062
C#
public static PDFPantoneColor PANTONE8062 {get;}
Delphi
public read-only property PANTONE8062: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8062();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8062 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8062 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE807 Property

Gets the PANTONE 807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE807
C#
public static PDFPantoneColor PANTONE807 {get;}
Delphi
public read-only property PANTONE807: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE808 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE808 Property

Gets the PANTONE 808 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE808 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE808
C#
public static PDFPantoneColor PANTONE808 {get;}
Delphi
public read-only property PANTONE808: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE808();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE808 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 808 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE809 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE809 Property

Gets the PANTONE 809 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE809 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE809
C#
public static PDFPantoneColor PANTONE809 {get;}
Delphi
public read-only property PANTONE809: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE809();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE809 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 809 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE810 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE810 Property

Gets the PANTONE 810 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE810 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE810
C#
public static PDFPantoneColor PANTONE810 {get;}
Delphi
public read-only property PANTONE810: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE810();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE810 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 810 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8100 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8100 Property

Gets the PANTONE 8100 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8100 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8100
C#
public static PDFPantoneColor PANTONE8100 {get;}
Delphi
public read-only property PANTONE8100: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8100();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8100 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8100 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE811 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE811 Property

Gets the PANTONE 811 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE811 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE811
C#
public static PDFPantoneColor PANTONE811 {get;}
Delphi
public read-only property PANTONE811: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE811();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE811 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 811 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE812 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE812 Property

Gets the PANTONE 812 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE812 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE812
C#
public static PDFPantoneColor PANTONE812 {get;}
Delphi
public read-only property PANTONE812: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE812();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE812 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 812 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE813 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE813 Property

Gets the PANTONE 813 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE813 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE813
C#
public static PDFPantoneColor PANTONE813 {get;}
Delphi
public read-only property PANTONE813: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE813();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE813 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 813 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE814 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE814 Property

Gets the PANTONE 814 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE814 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE814
C#
public static PDFPantoneColor PANTONE814 {get;}
Delphi
public read-only property PANTONE814: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE814();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE814 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 814 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8201 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8201 Property

Gets the PANTONE 8201 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8201 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8201
C#
public static PDFPantoneColor PANTONE8201 {get;}
Delphi
public read-only property PANTONE8201: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8201();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8201 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8201 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8281 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8281 Property

Gets the PANTONE 8281 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8281 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8281
C#
public static PDFPantoneColor PANTONE8281 {get;}
Delphi
public read-only property PANTONE8281: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8281();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8281 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8281 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE8321 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8321 Property

Gets the PANTONE 8321 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8321 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8321
C#
public static PDFPantoneColor PANTONE8321 {get;}
Delphi
public read-only property PANTONE8321: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8321();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8321 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8321 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE871 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE871 Property

Gets the PANTONE 871 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE871 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE871
C#
public static PDFPantoneColor PANTONE871 {get;}
Delphi
public read-only property PANTONE871: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE871();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE871 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 871 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE872 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE872 Property

Gets the PANTONE 872 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE872 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE872
C#
public static PDFPantoneColor PANTONE872 {get;}
Delphi
public read-only property PANTONE872: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE872();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE872 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 872 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE873 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE873 Property

Gets the PANTONE 873 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE873 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE873
C#
public static PDFPantoneColor PANTONE873 {get;}
Delphi
public read-only property PANTONE873: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE873();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE873 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 873 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE874 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE874 Property

Gets the PANTONE 874 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE874 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE874
C#
public static PDFPantoneColor PANTONE874 {get;}
Delphi
public read-only property PANTONE874: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE874();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE874 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 874 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE875 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE875 Property

Gets the PANTONE 875 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE875 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE875
C#
public static PDFPantoneColor PANTONE875 {get;}
Delphi
public read-only property PANTONE875: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE875();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE875 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 875 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE876 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE876 Property

Gets the PANTONE 876 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE876 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE876
C#
public static PDFPantoneColor PANTONE876 {get;}
Delphi
public read-only property PANTONE876: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE876();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE876 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 876 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PANTONE877 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE877 Property

Gets the PANTONE 877 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE877 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE877
C#
public static PDFPantoneColor PANTONE877 {get;}
Delphi
public read-only property PANTONE877: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE877();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE877 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 877 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ProcessBlack Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlack Property

Gets the PANTONE Process Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessBlack As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlack
C#
public static PDFPantoneColor ProcessBlack {get;}
Delphi
public read-only property ProcessBlack: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessBlack();
C++/CLI
public:
static property PDFPantoneColor^ ProcessBlack {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ProcessBlue Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlue Property

Gets the PANTONE Process Blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessBlue As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlue
C#
public static PDFPantoneColor ProcessBlue {get;}
Delphi
public read-only property ProcessBlue: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessBlue();
C++/CLI
public:
static property PDFPantoneColor^ ProcessBlue {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Blue color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ProcessCyan Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessCyan Property

Gets the PANTONE Process Cyan color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessCyan As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessCyan
C#
public static PDFPantoneColor ProcessCyan {get;}
Delphi
public read-only property ProcessCyan: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessCyan();
C++/CLI
public:
static property PDFPantoneColor^ ProcessCyan {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Cyan color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ProcessMagenta Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessMagenta Property

Gets the PANTONE Process Magenta color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessMagenta As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessMagenta
C#
public static PDFPantoneColor ProcessMagenta {get;}
Delphi
public read-only property ProcessMagenta: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessMagenta();
C++/CLI
public:
static property PDFPantoneColor^ ProcessMagenta {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Magenta color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ProcessYellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessYellow Property

Gets the PANTONE Process Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessYellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessYellow
C#
public static PDFPantoneColor ProcessYellow {get;}
Delphi
public read-only property ProcessYellow: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessYellow();
C++/CLI
public:
static property PDFPantoneColor^ ProcessYellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Purple Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Purple Property

Gets the PANTONE Purple color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Purple As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Purple
C#
public static PDFPantoneColor Purple {get;}
Delphi
public read-only property Purple: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Purple();
C++/CLI
public:
static property PDFPantoneColor^ Purple {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Purple color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Red032 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Red032 Property

Gets the PANTONE Red 032 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Red032 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Red032
C#
public static PDFPantoneColor Red032 {get;}
Delphi
public read-only property Red032: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Red032();
C++/CLI
public:
static property PDFPantoneColor^ Red032 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Red 032 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

ReflexBlue Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ReflexBlue Property

Gets the PANTONE Reflex Blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ReflexBlue As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ReflexBlue
C#
public static PDFPantoneColor ReflexBlue {get;}
Delphi
public read-only property ReflexBlue: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ReflexBlue();
C++/CLI
public:
static property PDFPantoneColor^ ReflexBlue {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Reflex Blue color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

RhodamineRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RhodamineRed Property

Gets the PANTONE Rhodamine Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RhodamineRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.RhodamineRed
C#
public static PDFPantoneColor RhodamineRed {get;}
Delphi
public read-only property RhodamineRed: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_RhodamineRed();
C++/CLI
public:
static property PDFPantoneColor^ RhodamineRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Rhodamine Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

RubineRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RubineRed Property

Gets the PANTONE Rubine Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RubineRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.RubineRed
C#
public static PDFPantoneColor RubineRed {get;}
Delphi
public read-only property RubineRed: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_RubineRed();
C++/CLI
public:
static property PDFPantoneColor^ RubineRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Rubine Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Violet Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Violet Property

Gets the PANTONE Violet color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Violet As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Violet
C#
public static PDFPantoneColor Violet {get;}
Delphi
public read-only property Violet: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Violet();
C++/CLI
public:
static property PDFPantoneColor^ Violet {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Violet color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray1 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray1 Property

Gets the PANTONE Warm Gray 1 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray1 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray1
C#
public static PDFPantoneColor WarmGray1 {get;}
Delphi
public read-only property WarmGray1: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray1();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray1 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 1 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray10 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray10 Property

Gets the PANTONE Warm Gray 10 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray10 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray10
C#
public static PDFPantoneColor WarmGray10 {get;}
Delphi
public read-only property WarmGray10: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray10();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray10 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 10 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray11 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray11 Property

Gets the PANTONE Warm Gray 11 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray11 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray11
C#
public static PDFPantoneColor WarmGray11 {get;}
Delphi
public read-only property WarmGray11: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray11();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray11 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 11 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray2 Property

Gets the PANTONE Warm Gray 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray2
C#
public static PDFPantoneColor WarmGray2 {get;}
Delphi
public read-only property WarmGray2: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray2();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray3 Property

Gets the PANTONE Warm Gray 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray3
C#
public static PDFPantoneColor WarmGray3 {get;}
Delphi
public read-only property WarmGray3: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray3();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray4 Property

Gets the PANTONE Warm Gray 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray4
C#
public static PDFPantoneColor WarmGray4 {get;}
Delphi
public read-only property WarmGray4: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray4();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray5 Property

Gets the PANTONE Warm Gray 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray5
C#
public static PDFPantoneColor WarmGray5 {get;}
Delphi
public read-only property WarmGray5: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray5();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray6 Property

Gets the PANTONE Warm Gray 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray6
C#
public static PDFPantoneColor WarmGray6 {get;}
Delphi
public read-only property WarmGray6: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray6();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray7 Property

Gets the PANTONE Warm Gray 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray7
C#
public static PDFPantoneColor WarmGray7 {get;}
Delphi
public read-only property WarmGray7: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray7();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray8 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray8 Property

Gets the PANTONE Warm Gray 8 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray8 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray8
C#
public static PDFPantoneColor WarmGray8 {get;}
Delphi
public read-only property WarmGray8: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray8();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray8 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 8 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmGray9 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray9 Property

Gets the PANTONE Warm Gray 9 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray9 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray9
C#
public static PDFPantoneColor WarmGray9 {get;}
Delphi
public read-only property WarmGray9: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray9();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray9 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 9 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

WarmRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmRed Property

Gets the PANTONE Warm Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmRed
C#
public static PDFPantoneColor WarmRed {get;}
Delphi
public read-only property WarmRed: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmRed();
C++/CLI
public:
static property PDFPantoneColor^ WarmRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Yellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow Property

Gets the PANTONE Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Yellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow
C#
public static PDFPantoneColor Yellow {get;}
Delphi
public read-only property Yellow: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Yellow();
C++/CLI
public:
static property PDFPantoneColor^ Yellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

Yellow012 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow012 Property

Gets the PANTONE Yellow 012 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Yellow012 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow012
C#
public static PDFPantoneColor Yellow012 {get;}
Delphi
public read-only property Yellow012: PDFPantoneColor; static;
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Yellow012();
C++/CLI
public:
static property PDFPantoneColor^ Yellow012 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Yellow 012 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PDFRgbColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFRgbColor Class

Defines a RGB color, a color based on a RGB device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRgbColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
C#
public class PDFRgbColor : PDFExtendedColor
Delphi
public class PDFRgbColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFRgbColor : public PDFExtendedColor
C++/CLI
public ref class PDFRgbColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFRgbColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFRgbColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFRgbColor Class

The following tables list the members exposed by PDFRgbColor.

Public Constructors

 | Name | Description
Public Constructor | PDFRgbColor Constructor | Overloaded. Initializes a new PDFRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFRgbColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : PDFRgbColor Constructor

Initializes a new PDFRgbColor object.

Overload List

Overload | Description
PDFRgbColor Constructor() | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Byte,Byte,Byte) | Initializes a new PDFRgbColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

PDFRgbColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor()

Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor()
C#
public PDFRgbColor()
Delphi
public PDFRgbColor();
Managed Extensions for C++
public: PDFRgbColor();
C++/CLI
public:
PDFRgbColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%%

PDFRgbColor Constructor(Byte,Byte,Byte)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Byte,Byte,Byte)

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.
Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
)
Visual Basic (Usage) Copy Code
Dim r As Byte
Dim g As Byte
Dim b As Byte

Dim instance As PDFRgbColor(r, g, b)
C#
public PDFRgbColor(
   byte r,
   byte g,
   byte b
)
Delphi
public PDFRgbColor(
    r: Byte;
    g: Byte;
    b: Byte
);
Managed Extensions for C++
public: PDFRgbColor(
   byte r,
   byte g,
   byte b
)
C++/CLI
public:
PDFRgbColor(
   byte r,
   byte g,
   byte b
)

Parameters

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFRgbColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%% $$Properties$$

PDFRgbColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

B Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : B Property

Gets or sets the blue component of the color.

Syntax

Visual Basic (Declaration)
Public Property B As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.B = value

value = instance.B
C#
public byte B {get; set;}
Delphi
public read-write property B: Byte;
Managed Extensions for C++
public: __property byte get_B();
public: __property void set_B(
   byte value
);
C++/CLI
public:
property byte B {
   byte get();
   void set (byte value);
}

Return Value

Blue component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

G Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : G Property

Gets or sets the green component of the color.

Syntax

Visual Basic (Declaration)
Public Property G As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.G = value

value = instance.G
C#
public byte G {get; set;}
Delphi
public read-write property G: Byte;
Managed Extensions for C++
public: __property byte get_G();
public: __property void set_G(
   byte value
);
C++/CLI
public:
property byte G {
   byte get();
   void set (byte value);
}

Return Value

Green component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

R Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFRgbColor Class : R Property

Gets or sets the red component of the color.

Syntax

Visual Basic (Declaration)
Public Property R As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.R = value

value = instance.R
C#
public byte R {get; set;}
Delphi
public read-write property R: Byte;
Managed Extensions for C++
public: __property byte get_R();
public: __property void set_R(
   byte value
);
C++/CLI
public:
property byte R {
   byte get();
   void set (byte value);
}

Return Value

Red component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

PDFSeparationColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColor Class

Defines an separation color, based on a separation colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationColor
   Inherits PDFExtendedColor
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
C#
public class PDFSeparationColor : PDFExtendedColor
Delphi
public class PDFSeparationColor = class(PDFExtendedColor)
Managed Extensions for C++
public __gc class PDFSeparationColor : public PDFExtendedColor
C++/CLI
public ref class PDFSeparationColor : public PDFExtendedColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBaseColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColor Class

The following tables list the members exposed by PDFSeparationColor.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationColor Constructor | Initializes a new PDFSeparationColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Tint | Gets or sets the tint for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFSeparationColor Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColor Class : PDFSeparationColor Constructor

colorSpace
a PDFSeparationColorSpace object the color is based on.
Initializes a new PDFSeparationColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFSeparationColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFSeparationColorSpace

Dim instance As PDFSeparationColor(colorSpace)
C#
public PDFSeparationColor(
   PDFSeparationColorSpace colorSpace
)
Delphi
public PDFSeparationColor(
    colorSpace: PDFSeparationColorSpace
);
Managed Extensions for C++
public: PDFSeparationColor(
   PDFSeparationColorSpace* colorSpace
)
C++/CLI
public:
PDFSeparationColor(
   PDFSeparationColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFSeparationColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


%%PageItemTitle%% $$Properties$$

PDFSeparationColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFExtendedColor)
Public Property | Tint | Gets or sets the tint for this color.
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Tint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColor Class : Tint Property

Gets or sets the tint for this color.

Syntax

Visual Basic (Declaration)
Public Property Tint As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim value As Double

instance.Tint = value

value = instance.Tint
C#
public double Tint {get; set;}
Delphi
public read-write property Tint: Double;
Managed Extensions for C++
public: __property double get_Tint();
public: __property void set_Tint(
   double value
);
C++/CLI
public:
property double Tint {
   double get();
   void set (double value);
}

Return Value

A float value specifying the tint of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the lightest color that can be achieved, and 1.0 means the darkest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


%%PageItemTitle%%

PDFSeparationColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

Defines a separation colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
C#
public class PDFSeparationColorSpace : PDFColorSpace
Delphi
public class PDFSeparationColorSpace = class(PDFColorSpace)
Managed Extensions for C++
public __gc class PDFSeparationColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFSeparationColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFImportedSeparationColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

The following tables list the members exposed by PDFSeparationColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationColorSpace Constructor | Initializes a new PDFSeparationColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFSeparationColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : PDFSeparationColorSpace Constructor

Initializes a new PDFSeparationColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace()
C#
public PDFSeparationColorSpace()
Delphi
public PDFSeparationColorSpace();
Managed Extensions for C++
public: PDFSeparationColorSpace();
C++/CLI
public:
PDFSeparationColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFSeparationColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

For a list of all members of this type, see PDFSeparationColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Computes the object's hash code.
Top

See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : Equals Method

obj
Object to test.
Tests if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Delphi
public function Equals(
    obj: TObject
): Boolean; override;
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : GetHashCode Method

Computes the object's hash code.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFSeparationColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

For a list of all members of this type, see PDFSeparationColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Top

See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Delphi
public read-write property AlternateColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used when the destination device does not support separation colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

Colorant Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : Colorant Property

Gets or sets the colorant represented by this separation colorspace.

Syntax

Visual Basic (Declaration)
Public Property Colorant As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As String

instance.Colorant = value

value = instance.Colorant
C#
public string Colorant {get; set;}
Delphi
public read-write property Colorant: String;
Managed Extensions for C++
public: __property string* get_Colorant();
public: __property void set_Colorant(
   string* value
);
C++/CLI
public:
property String^ Colorant {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the colorant.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

TintTransform Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : TintTransform Property

Gets or sets the tint transform function for the this colorspace.

Syntax

Visual Basic (Declaration)
Public Property TintTransform As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
C#
public PDFFunction TintTransform {get; set;}
Delphi
public read-write property TintTransform: PDFFunction;
Managed Extensions for C++
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (PDFFunction^ value);
}

Return Value

Tint transform function for the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

PDFSeparationColorSpaceCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpaceCollection Class

Defines a collection of separation colorspaces.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFSeparationColorSpaceCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
C#
[DefaultMemberAttribute("Item")]
public class PDFSeparationColorSpaceCollection : CollectionBase
Delphi
public class PDFSeparationColorSpaceCollection = class(CollectionBase)
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFSeparationColorSpaceCollection : public CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFSeparationColorSpaceCollection : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpaceCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationColorSpaceCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpaceCollection Class

The following tables list the members exposed by PDFSeparationColorSpaceCollection.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationColorSpaceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the item at the given index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new colorspace to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains a specific value.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific colorspace in the collection.
Public Method | Insert | Inserts a colorspace to the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific colorspace from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDFSeparationColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFSeparationColorSpaceCollection Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : PDFSeparationColorSpaceCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection()
C#
public PDFSeparationColorSpaceCollection()
Delphi
public PDFSeparationColorSpaceCollection();
Managed Extensions for C++
public: PDFSeparationColorSpaceCollection();
C++/CLI
public:
PDFSeparationColorSpaceCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%% $$Methods$$

PDFSeparationColorSpaceCollection Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpaceCollection Class

For a list of all members of this type, see PDFSeparationColorSpaceCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new colorspace to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains a specific value.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific colorspace in the collection.
Public Method | Insert | Inserts a colorspace to the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific colorspace from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

PDFSeparationColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Add Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : Add Method

value
The colorspace to add to the collection.
Adds a new colorspace to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As PDFSeparationColorSpace _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim value As PDFSeparationColorSpace
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   PDFSeparationColorSpace value
)
Delphi
public function Add(
    value: PDFSeparationColorSpace
): Integer;
Managed Extensions for C++
public: int Add(
   PDFSeparationColorSpace* value
)
C++/CLI
public:
int Add(
   PDFSeparationColorSpace^ value
)

Parameters

value
The colorspace to add to the collection.

Return Value

The position into which the new element was inserted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%%

Contains Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : Contains Method

value
The colorspace to locate in the collection.
Determines whether the collection contains a specific value.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As PDFSeparationColorSpace _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim value As PDFSeparationColorSpace
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   PDFSeparationColorSpace value
)
Delphi
public function Contains(
    value: PDFSeparationColorSpace
): Boolean;
Managed Extensions for C++
public: bool Contains(
   PDFSeparationColorSpace* value
)
C++/CLI
public:
bool Contains(
   PDFSeparationColorSpace^ value
)

Parameters

value
The colorspace to locate in the collection.

Return Value

true if the colorspace is found in the collection; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : IndexOf Method

value
The colorspace to locate in the collection.
Determines the index of a specific colorspace in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As PDFSeparationColorSpace _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim value As PDFSeparationColorSpace
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   PDFSeparationColorSpace value
)
Delphi
public function IndexOf(
    value: PDFSeparationColorSpace
): Integer;
Managed Extensions for C++
public: int IndexOf(
   PDFSeparationColorSpace* value
)
C++/CLI
public:
int IndexOf(
   PDFSeparationColorSpace^ value
)

Parameters

value
The colorspace to locate in the collection.

Return Value

The index of value if found in the collection; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%%

Insert Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : Insert Method

index
The zero-based index at which value should be inserted.
value
The colorspace to insert into the collection.
Inserts a colorspace to the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As PDFSeparationColorSpace _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim index As Integer
Dim value As PDFSeparationColorSpace

instance.Insert(index, value)
C#
public void Insert(
   int index,
   PDFSeparationColorSpace value
)
Delphi
public procedure Insert(
    index: Integer;
    value: PDFSeparationColorSpace
);
Managed Extensions for C++
public: void Insert(
   int index,
   PDFSeparationColorSpace* value
)
C++/CLI
public:
void Insert(
   int index,
   PDFSeparationColorSpace^ value
)

Parameters

index
The zero-based index at which value should be inserted.
value
The colorspace to insert into the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%%

Remove Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : Remove Method

value
The colorspace to remove from the collection.
Removes the first occurrence of a specific colorspace from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As PDFSeparationColorSpace _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim value As PDFSeparationColorSpace

instance.Remove(value)
C#
public void Remove(
   PDFSeparationColorSpace value
)
Delphi
public procedure Remove(
    value: PDFSeparationColorSpace
);
Managed Extensions for C++
public: void Remove(
   PDFSeparationColorSpace* value
)
C++/CLI
public:
void Remove(
   PDFSeparationColorSpace^ value
)

Parameters

value
The colorspace to remove from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%% $$Properties$$

PDFSeparationColorSpaceCollection Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpaceCollection Class

For a list of all members of this type, see PDFSeparationColorSpaceCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the item at the given index.
Top

See Also

Reference

PDFSeparationColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpaceCollection Class : Item Property

index
Gets or sets the item at the given index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDFSeparationColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpaceCollection
Dim index As Integer
Dim value As PDFSeparationColorSpace

instance.Item(index) = value

value = instance.Item(index)
C#
public PDFSeparationColorSpace this[
   int index
]; {get; set;}
Delphi
public  this: : PDFSeparationColorSpace;[
    index: Integer
]; read-write
Managed Extensions for C++
public: __property PDFSeparationColorSpace* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDFSeparationColorSpace* value
);
C++/CLI
public:
property PDFSeparationColorSpace^ default [int] {
   PDFSeparationColorSpace^ get(int index);
   void set (int index, PDFSeparationColorSpace^ value);
}

Parameters

index

Return Value

A PDFSeparationColorSpace object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpaceCollection Class
PDFSeparationColorSpaceCollection Members


%%PageItemTitle%%

PDFDeviceColorSpaceType Enumeration
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpaceType Enumeration

Defines the available device colorspace types.

Syntax

Visual Basic (Declaration)
Public Enum PDFDeviceColorSpaceType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpaceType
C#
public enum PDFDeviceColorSpaceType : Enum
Delphi
public enum PDFDeviceColorSpaceType = class(Enum)
Managed Extensions for C++
__value public enum PDFDeviceColorSpaceType : public Enum
C++/CLI
public enum class PDFDeviceColorSpaceType : public Enum

Members

Member | Description
Rgb | RGB device colorspace.
Cmyk | CMYK device colorspace.
Gray | Gray device colorspace.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpaceType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics.Fonts Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
CJKFont | Defines a font for east asian languages (chinese, japanese and korean). Supported by Compact .NET Edition.
PDFFontMetrics | Defines the metrics for a font object used in the pdf file. Supported by Compact .NET Edition.
PostScriptFont | Defines a particular format for text, including font face and size.
TrueTypeFont | Defines a particular format for text, including font face and size.

Enumerations

Enumeration | Description
CJKFontFace | Defines the available CJK fonts faces. Supported by Compact .NET Edition.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Fonts Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

CJKFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

Defines a font for east asian languages (chinese, japanese and korean).

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class CJKFont
   Inherits PDFFont
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
C#
public class CJKFont : PDFFont
Delphi
public class CJKFont = class(PDFFont)
Managed Extensions for C++
public __gc class CJKFont : public PDFFont
C++/CLI
public ref class CJKFont : public PDFFont

Remarks

The fonts defined by this class are based on Asian Language Pack for Adobe Acrobat and Adobe Acrobat Reader products.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

CJKFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

The following tables list the members exposed by CJKFont.

Public Constructors

 | Name | Description
Public Constructor | CJKFont Constructor | Overloaded. Initializes a new PDFFont object with the specified CJKFontFace and size. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not. Supported by Compact .NET Edition.
Public Property | CJKFontFace | Gets of sets the cjk font face. Supported by Compact .NET Edition.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not. Supported by Compact .NET Edition.
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

CJKFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFont Constructor

Initializes a new PDFFont object with the specified CJKFontFace and size.

Supported by Compact .NET Edition.

Overload List

Overload | Description
CJKFont Constructor(CJKFont) | Initializes a new CJKFont object based on an existing font. Supported by Compact .NET Edition.
CJKFont Constructor(CJKFontFace,Single) | Initializes a new PDFFont object with the specified CJKFontFace and size. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

CJKFont Constructor(CJKFont)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFont)

font
a CJKFont object to be copied in the new font.
Initializes a new CJKFont object based on an existing font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As CJKFont _
)
Visual Basic (Usage) Copy Code
Dim font As CJKFont

Dim instance As CJKFont(font)
C#
public CJKFont(
   CJKFont font
)
Delphi
public CJKFont(
    font: CJKFont
);
Managed Extensions for C++
public: CJKFont(
   CJKFont* font
)
C++/CLI
public:
CJKFont(
   CJKFont^ font
)

Parameters

font
a CJKFont object to be copied in the new font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


%%PageItemTitle%%

CJKFont Constructor(CJKFontFace,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFontFace,Single)

cjkFontFace
a CJKFontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Initializes a new PDFFont object with the specified CJKFontFace and size.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cjkFontFace As CJKFontFace, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim cjkFontFace As CJKFontFace
Dim size As Single

Dim instance As CJKFont(cjkFontFace, size)
C#
public CJKFont(
   CJKFontFace cjkFontFace,
   float size
)
Delphi
public CJKFont(
    cjkFontFace: CJKFontFace;
    size: Single
);
Managed Extensions for C++
public: CJKFont(
   CJKFontFace cjkFontFace,
   float size
)
C++/CLI
public:
CJKFont(
   CJKFontFace cjkFontFace,
   float size
)

Parameters

cjkFontFace
a CJKFontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


%%PageItemTitle%% $$Properties$$

CJKFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not. Supported by Compact .NET Edition.
Public Property | CJKFontFace | Gets of sets the cjk font face. Supported by Compact .NET Edition.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not. Supported by Compact .NET Edition.
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Bold Property

Gets or sets whether the font object is bold or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overrides Public Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Delphi
public read-write property Bold: Boolean; override;
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

CJKFontFace Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFontFace Property

Gets of sets the cjk font face.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property CJKFontFace As CJKFontFace
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As CJKFontFace

instance.CJKFontFace = value

value = instance.CJKFontFace
C#
public CJKFontFace CJKFontFace {get; set;}
Delphi
public read-write property CJKFontFace: CJKFontFace;
Managed Extensions for C++
public: __property CJKFontFace get_CJKFontFace();
public: __property void set_CJKFontFace(
   CJKFontFace value
);
C++/CLI
public:
property CJKFontFace CJKFontFace {
   CJKFontFace get();
   void set (CJKFontFace value);
}

Return Value

a CJKFontFace enumeration member specifying the cjk font face.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Italic Property

Gets or sets whether the font object is italic or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overrides Public Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Delphi
public read-write property Italic: Boolean; override;
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

PDFFontMetrics Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

Defines the metrics for a font object used in the pdf file.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFontMetrics
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
C#
public class PDFFontMetrics
Delphi
public class PDFFontMetrics
Managed Extensions for C++
public __gc class PDFFontMetrics
C++/CLI
public ref class PDFFontMetrics

Remarks

The values of the properties of this class are given in unscaled glyph units. To convert the values to points, divide by 1000 then multiply by font size (points).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFontMetrics Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

The following tables list the members exposed by PDFFontMetrics.

Public Properties

 | Name | Description
Public Property | Ascent | Gets the ascent of the font. Supported by Compact .NET Edition.
Public Property | AverageWidth | Gets the average width of glyphs in the font. Supported by Compact .NET Edition.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font. Supported by Compact .NET Edition.
Public Property | Descent | Gets the descent of the font. Supported by Compact .NET Edition.
Public Property | Leading | Gets the leading of the font. Supported by Compact .NET Edition.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font. Supported by Compact .NET Edition.
Public Property | Name | Gets the Postscript name of the font. Supported by Compact .NET Edition.
Public Property | StemH | Gets the horizontal stem of the font. Supported by Compact .NET Edition.
Public Property | StemV | Gets the vertical stem of the font. Supported by Compact .NET Edition.
Public Property | XHeight | Gets the x height of the font. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Properties$$

PDFFontMetrics Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

For a list of all members of this type, see PDFFontMetrics members.

Public Properties

 | Name | Description
Public Property | Ascent | Gets the ascent of the font. Supported by Compact .NET Edition.
Public Property | AverageWidth | Gets the average width of glyphs in the font. Supported by Compact .NET Edition.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font. Supported by Compact .NET Edition.
Public Property | Descent | Gets the descent of the font. Supported by Compact .NET Edition.
Public Property | Leading | Gets the leading of the font. Supported by Compact .NET Edition.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font. Supported by Compact .NET Edition.
Public Property | Name | Gets the Postscript name of the font. Supported by Compact .NET Edition.
Public Property | StemH | Gets the horizontal stem of the font. Supported by Compact .NET Edition.
Public Property | StemV | Gets the vertical stem of the font. Supported by Compact .NET Edition.
Public Property | XHeight | Gets the x height of the font. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Ascent Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Ascent Property

Gets the ascent of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ascent As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.Ascent
C#
public float Ascent {get;}
Delphi
public read-only property Ascent: Single;
Managed Extensions for C++
public: __property float get_Ascent();
C++/CLI
public:
property float Ascent {
   float get();
}

Return Value

A float value specifying the maximum height above the baseline reached by glyphs in this font, excluding the height of glyphs for accented characters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

AverageWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : AverageWidth Property

Gets the average width of glyphs in the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AverageWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.AverageWidth
C#
public float AverageWidth {get;}
Delphi
public read-only property AverageWidth: Single;
Managed Extensions for C++
public: __property float get_AverageWidth();
C++/CLI
public:
property float AverageWidth {
   float get();
}

Return Value

A float value specifying the average width of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

BoundingBox Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : BoundingBox Property

Gets the font's bounding box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundingBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As PDFRect

value = instance.BoundingBox
C#
public PDFRect BoundingBox {get;}
Delphi
public read-only property BoundingBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_BoundingBox();
C++/CLI
public:
property PDFRect^ BoundingBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object specifying the font's bounding box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

CapHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : CapHeight Property

Gets the capHeight of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CapHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.CapHeight
C#
public float CapHeight {get;}
Delphi
public read-only property CapHeight: Single;
Managed Extensions for C++
public: __property float get_CapHeight();
C++/CLI
public:
property float CapHeight {
   float get();
}

Return Value

A float value specifying the vertical coordinate of the top of flat capital letters, measured from the baseline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

Descent Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Descent Property

Gets the descent of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Descent As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.Descent
C#
public float Descent {get;}
Delphi
public read-only property Descent: Single;
Managed Extensions for C++
public: __property float get_Descent();
C++/CLI
public:
property float Descent {
   float get();
}

Return Value

A float value specifying the maximum depth below the baseline reached by glyphs in this font. This value is a negative number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

Leading Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Leading Property

Gets the leading of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leading As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.Leading
C#
public float Leading {get;}
Delphi
public read-only property Leading: Single;
Managed Extensions for C++
public: __property float get_Leading();
C++/CLI
public:
property float Leading {
   float get();
}

Return Value

A float value specifying the desired spacing between baselines of consecutives lines of text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

MaxWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : MaxWidth Property

Gets the maximum width of glyphs in the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.MaxWidth
C#
public float MaxWidth {get;}
Delphi
public read-only property MaxWidth: Single;
Managed Extensions for C++
public: __property float get_MaxWidth();
C++/CLI
public:
property float MaxWidth {
   float get();
}

Return Value

A float value specifying the maximum width of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Name Property

Gets the Postscript name of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

StemH Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemH Property

Gets the horizontal stem of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StemH As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.StemH
C#
public float StemH {get;}
Delphi
public read-only property StemH: Single;
Managed Extensions for C++
public: __property float get_StemH();
C++/CLI
public:
property float StemH {
   float get();
}

Return Value

A float value specifying the thickness, measured invertically, of the dominant horizontal stems of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

StemV Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemV Property

Gets the vertical stem of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StemV As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.StemV
C#
public float StemV {get;}
Delphi
public read-only property StemV: Single;
Managed Extensions for C++
public: __property float get_StemV();
C++/CLI
public:
property float StemV {
   float get();
}

Return Value

A float value specifying the thickness, measure horizontally, of the dominant vertical stems of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

XHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : XHeight Property

Gets the x height of the font.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Single

value = instance.XHeight
C#
public float XHeight {get;}
Delphi
public read-only property XHeight: Single;
Managed Extensions for C++
public: __property float get_XHeight();
C++/CLI
public:
property float XHeight {
   float get();
}

Return Value

A float value specifying the vertical coordinate of the top of flat non-ascending lowercase letters (like letter x), measured from the baseline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

PostScriptFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

Defines a particular format for text, including font face and size.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PostScriptFont
   Inherits PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
C#
public sealed class PostScriptFont : PDFFont
Delphi
public class PostScriptFont = class(PDFFont)sealed;
Managed Extensions for C++
public __gc __sealed class PostScriptFont : public PDFFont
C++/CLI
public ref class PostScriptFont sealed : public PDFFont

Remarks

A PostScript font is always loaded from disk. The metrics of the font are specified in an .afm file (Adobe Font Metrics) and the binary representation of the font is specified in a .pfb file (Printer Font Binary).

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PostScriptFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

The following tables list the members exposed by PostScriptFont.

Public Constructors

 | Name | Description
Public Constructor | PostScriptFont Constructor | Overloaded. Initializes a new PostScriptFont object based on the given metrics and font data files.
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PostScriptFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : PostScriptFont Constructor

Initializes a new PostScriptFont object based on the given metrics and font data files.

Overload List

Overload | Description
PostScriptFont Constructor(PostScriptFont,Single) | Initializes a new PostScriptFont object based on an existing font object.
PostScriptFont Constructor(String,String,Single,Boolean) | Initializes a new PostScriptFont object based on the given metrics and font data files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

PostScriptFont Constructor(PostScriptFont,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(PostScriptFont,Single)

font
the original TrueTypeFont object
size
the size of the new font
Initializes a new PostScriptFont object based on an existing font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As PostScriptFont, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim font As PostScriptFont
Dim size As Single

Dim instance As PostScriptFont(font, size)
C#
public PostScriptFont(
   PostScriptFont font,
   float size
)
Delphi
public PostScriptFont(
    font: PostScriptFont;
    size: Single
);
Managed Extensions for C++
public: PostScriptFont(
   PostScriptFont* font,
   float size
)
C++/CLI
public:
PostScriptFont(
   PostScriptFont^ font,
   float size
)

Parameters

font
the original TrueTypeFont object
size
the size of the new font

Remarks

Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%%

PostScriptFont Constructor(String,String,Single,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(String,String,Single,Boolean)

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.
Initializes a new PostScriptFont object based on the given metrics and font data files.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal metricsFile As String, _
   ByVal fontDataFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim metricsFile As String
Dim fontDataFile As String
Dim size As Single
Dim embed As Boolean

Dim instance As PostScriptFont(metricsFile, fontDataFile, size, embed)
C#
public PostScriptFont(
   string metricsFile,
   string fontDataFile,
   float size,
   bool embed
)
Delphi
public PostScriptFont(
    metricsFile: String;
    fontDataFile: String;
    size: Single;
    embed: Boolean
);
Managed Extensions for C++
public: PostScriptFont(
   string* metricsFile,
   string* fontDataFile,
   float size,
   bool embed
)
C++/CLI
public:
PostScriptFont(
   String^ metricsFile,
   String^ fontDataFile,
   float size,
   bool embed
)

Parameters

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.

Remarks

A PostScript font is always loaded from disk. The metrics of the font are specified using an .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics). The binary representation of the font is specified using a .pfb file (Printer Font Binary).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%% $$Properties$$

PostScriptFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Bold Property

Gets of sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Delphi
public read-write property Bold: Boolean; override;
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is bold; otherwise, false.

Remarks

When the TrueType font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate weight (bold or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct weight (assuming the font is installed on the local computer). It the bold face of the font is not installed on the local machine, and only the regular face is installed, the pdf viewer will synthesize the bold appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Italic Property

Gets of sets whether the font object is italic or not

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Delphi
public read-write property Italic: Boolean; override;
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is italic; otherwise, false.

Remarks

When the TrueType font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate face (italic or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct face (assuming the font is installed on the local computer).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

TrueTypeFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

Defines a particular format for text, including font face and size.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TrueTypeFont
   Inherits PDFFont
Visual Basic (Usage) Copy Code
Dim instance As TrueTypeFont
C#
public class TrueTypeFont : PDFFont
Delphi
public class TrueTypeFont = class(PDFFont)
Managed Extensions for C++
public __gc class TrueTypeFont : public PDFFont
C++/CLI
public ref class TrueTypeFont : public PDFFont

Remarks

A TrueType font is always loaded from disk.

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

When the font is not emdedded in the pdf file, the bold and italic modifiers have the following effect: assuming that the font used for displaying text has only a regular face, these modifiers force the pdf viewer to synthesize the bold or italic appearance of the font. But the regular version of the font must be installed on the machine where the pdf file is viewed.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

TrueTypeFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

The following tables list the members exposed by TrueTypeFont.

Public Constructors

 | Name | Description
Public Constructor | TrueTypeFont Constructor | Overloaded. Initializes a new TrueTypeFont object based on the given font file and size.
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

TrueTypeFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : TrueTypeFont Constructor

Initializes a new TrueTypeFont object based on the given font file and size.

Overload List

Overload | Description
TrueTypeFont Constructor(Font,Boolean) | Initializes a new TrueTypeFont object based on a Font object.
TrueTypeFont Constructor(Font,Boolean,Boolean) | Initializes a new TrueTypeFont object based on a Font object.
TrueTypeFont Constructor(Stream,Single,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(String,Single,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Single,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(TrueTypeFont,Single) | Initializes a new TrueTypeFont object based on an existing font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean)

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on a Font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim font As Font
Dim embed As Boolean

Dim instance As TrueTypeFont(font, embed)
C#
public TrueTypeFont(
   Font font,
   bool embed
)
Delphi
public TrueTypeFont(
    font: Font;
    embed: Boolean
);
Managed Extensions for C++
public: TrueTypeFont(
   Font font,
   bool embed
)
C++/CLI
public:
TrueTypeFont(
   Font font,
   bool embed
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean,Boolean)

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on a Font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim font As Font
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(font, embed, unicode)
C#
public TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
Delphi
public TrueTypeFont(
    font: Font;
    embed: Boolean;
    unicode: Boolean
);
Managed Extensions for C++
public: TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Single,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Single,Boolean,Boolean)

trueTypeFontStream
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Single, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontStream As Stream
Dim size As Single
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(trueTypeFontStream, size, embed, unicode)
C#
public TrueTypeFont(
   Stream trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)
Delphi
public TrueTypeFont(
    trueTypeFontStream: Stream;
    size: Single;
    embed: Boolean;
    unicode: Boolean
);
Managed Extensions for C++
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontStream
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Remarks

The font is always loaded from disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Single,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Single,Boolean)

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font file and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontFile As String
Dim size As Single
Dim embed As Boolean

Dim instance As TrueTypeFont(trueTypeFontFile, size, embed)
C#
public TrueTypeFont(
   string trueTypeFontFile,
   float size,
   bool embed
)
Delphi
public TrueTypeFont(
    trueTypeFontFile: String;
    size: Single;
    embed: Boolean
);
Managed Extensions for C++
public: TrueTypeFont(
   string* trueTypeFontFile,
   float size,
   bool embed
)
C++/CLI
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   float size,
   bool embed
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.

Remarks

The font is always loaded from disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Single,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Single,Boolean,Boolean)

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontFile As String
Dim size As Single
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(trueTypeFontFile, size, embed, unicode)
C#
public TrueTypeFont(
   string trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)
Delphi
public TrueTypeFont(
    trueTypeFontFile: String;
    size: Single;
    embed: Boolean;
    unicode: Boolean
);
Managed Extensions for C++
public: TrueTypeFont(
   string* trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Remarks

The font is always loaded from disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(TrueTypeFont,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(TrueTypeFont,Single)

font
the original TrueTypeFont object
size
the size of the new font
Initializes a new TrueTypeFont object based on an existing font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As TrueTypeFont, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim font As TrueTypeFont
Dim size As Single

Dim instance As TrueTypeFont(font, size)
C#
public TrueTypeFont(
   TrueTypeFont font,
   float size
)
Delphi
public TrueTypeFont(
    font: TrueTypeFont;
    size: Single
);
Managed Extensions for C++
public: TrueTypeFont(
   TrueTypeFont* font,
   float size
)
C++/CLI
public:
TrueTypeFont(
   TrueTypeFont^ font,
   float size
)

Parameters

font
the original TrueTypeFont object
size
the size of the new font

Remarks

Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%% $$Properties$$

TrueTypeFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Overline | Gets or sets whether the font object is overline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Size | Gets or sets the font size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Property | Underline | Gets or sets whether the font object is underline or not. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Bold Property

Gets of sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Overrides Public Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TrueTypeFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Delphi
public read-write property Bold: Boolean; override;
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is bold; otherwise, false.

Remarks

When the TrueType font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate weight (bold or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct weight (assuming the font is installed on the local computer). It the bold face of the font is not installed on the local machine, and only the regular face is installed, the pdf viewer will synthesize the bold appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Italic Property

Gets of sets whether the font object is italic or not

Syntax

Visual Basic (Declaration)
Overrides Public Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TrueTypeFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Delphi
public read-write property Italic: Boolean; override;
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is italic; otherwise, false.

Remarks

When the TrueType font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate face (italic or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct face (assuming the font is installed on the local computer).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

CJKFontFace Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFontFace Enumeration

Defines the available CJK fonts faces.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum CJKFontFace
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CJKFontFace
C#
public enum CJKFontFace : Enum
Delphi
public enum CJKFontFace = class(Enum)
Managed Extensions for C++
__value public enum CJKFontFace : public Enum
C++/CLI
public enum class CJKFontFace : public Enum

Members

Member | Description
HeiseiKakuGothicW5 | The Heisei Kaku Gothic W5 japanese font face.
HeiseiMinchoW3 | The Heisei Mincho W3 japanese font face.
KozMinProVIRegular | KozMinProVI-Regular japanese font face.
HanyangSystemsGothicMedium | The Hanyang Systems Gothic Medium korean font face.
HanyangSystemsShinMyeongJoMedium | The Hanyang Systems Shin MyeongJo Medium korean font face.
MonotypeHeiMedium | The Monotype Hei Medium chinese traditional font face.
MonotypeSungLight | The Monotype Sung Light chinese traditional font face.
SinoTypeSongLight | The SinoType Song Light chinese simplified font face.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Fonts.CJKFontFace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics.Shapes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFArc | Defines an arc representing a portion of a circle specified by a pair of coordinates, a width, and a height. Supported by Compact .NET Edition.
PDFAreaDocLink | Defines a rectangular area on the page that acts a link to another page within the same document Supported by Compact .NET Edition.
PDFAreaFileLink | Defines a rectangular area on the page that acts a link to an external file Supported by Compact .NET Edition.
PDFAreaRemoteDocLink | Defines a rectangular area on the page that acts a link to another pdf file Supported by Compact .NET Edition.
PDFAreaWebLink | Defines a rectangular area on the page that acts a link to a web location. Supported by Compact .NET Edition.
PDFBezier | Defines a Bezier spline defined by four control points. Supported by Compact .NET Edition.
PDFChord | Defines a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant.
PDFClippingRegion | Defines a clipping region on the page. Supported by Compact .NET Edition.
PDFEllipse | Defines an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height. Supported by Compact .NET Edition.
PDFFormXObject | Defines a block of graphic sequences (drawing primitives, text and images) that can be painted multiple times on the same page or on different pages.
PDFHTMLText | Defines a line of text specified by a printing position and a string.
PDFHTMLTextBox | Defines a wrapped text specified by its bounding rectangle.
PDFImage | Defines an image specified by a pair of coordinates, a width, and a height. Supported by Compact .NET Edition.
PDFLine | Defines a line specified by a pair of coordinates. Supported by Compact .NET Edition.
PDFLines | Defines a series of lines specified by an array of points. Supported by Compact .NET Edition.
PDFLink | The base class for all the links within the PDF file.
PDFMetafile | Defines a Windows metafile object.
PDFPath | Represents a series of connected lines and curves.
PDFPie | Defines a pie representing a closed portion of a ellipse specified by a pair of coordinates, a width, and a height. Supported by Compact .NET Edition.
PDFPolyBezier | Defines a series of connected curves specified by an array of points.
PDFPolygon | Defines a closed polygon specified by an array of points. Supported by Compact .NET Edition.
PDFPolyPolygon | Defines a series of closed polygons.
PDFRect | Defines a rectangle as it is specified by the pdf specification.
PDFRectangle | Defines a rectangle specified by a pair of coordinates, a width, and a height. Supported by Compact .NET Edition.
PDFRectangularObject | Defines an abstract rectangular object on a page Supported by Compact .NET Edition.
PDFRoundRectangle | Defines a rectangle with rounded corners specified by a pair of coordinates, a width, and a height.
PDFText | Defines a line of text specified by a printing position and a string. Supported by Compact .NET Edition.
PDFTextBox | Defines a wrapped text specified by its bounding rectangle. Supported by Compact .NET Edition.
PDFTextDocLink | Defines a line of text on the page that acts a link to another page within the same document Supported by Compact .NET Edition.
PDFTextFileLink | Defines a line of text on the page that acts a link to an external file Supported by Compact .NET Edition.
PDFTextFormatOptions | Defines the available formatting options for a text box Supported by Compact .NET Edition.
PDFTextRemoteDocLink | Defines a line of text on the page that acts a link to another pdf file Supported by Compact .NET Edition.
PDFTextWebLink | Defines a line of text on the page that acts a link to a web location Supported by Compact .NET Edition.
XFORM |

Enumerations

Enumeration | Description
BlendMode | Specifies the available blend modes.
ClipText | Specifies the available cliping modes when displaying a text box Supported by Compact .NET Edition.
FillMode | Specifies the available fill modes for a complex shape.
ImageCompression | Specifies the available compression methods for storing an image in the PDF file.
KeepAspectRatio | Specifies the available modes to resize an image when it is drawn on the page. Supported by Compact .NET Edition.
TextAlign | Specifies the available alignments for text lines. Supported by Compact .NET Edition.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Shapes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFRect
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions
O2S.Components.PDF4NET.Graphics.Shapes.XFORM
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFBezier
O2S.Components.PDF4NET.Graphics.Shapes.PDFClippingRegion
O2S.Components.PDF4NET.Graphics.Shapes.PDFLine
O2S.Components.PDF4NET.Graphics.Shapes.PDFLines
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyBezier
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolygon
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyPolygon
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFArc
O2S.Components.PDF4NET.Graphics.Shapes.PDFChord
O2S.Components.PDF4NET.Graphics.Shapes.PDFEllipse
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFileLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextRemoteDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextWebLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFPie
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangle
O2S.Components.PDF4NET.Graphics.Shapes.PDFRoundRectangle
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLText
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLTextBox

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFArc Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFArc Class

Defines an arc representing a portion of a circle specified by a pair of coordinates, a width, and a height.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFArc
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFArc
C#
public sealed class PDFArc : PDFRectangularObject
Delphi
public class PDFArc = class(PDFRectangularObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFArc : public PDFRectangularObject
C++/CLI
public ref class PDFArc sealed : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFArc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFArc Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFArc Class

The following tables list the members exposed by PDFArc.

Public Constructors

 | Name | Description
Public Constructor | PDFArc Constructor | Overloaded. Initializes a new PDFArc object using the specified pen, a pair of coordinates and width and height. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the arc. Supported by Compact .NET Edition.
Public Property | SweepAngle | Gets or sets the sweep angle of the ellipse. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFArc Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFArc Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class : PDFArc Constructor

Initializes a new PDFArc object using the specified pen, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFArc Constructor() | Initializes a new PDFArc object.
PDFArc Constructor(PDFPen,RectangleF,Single,Single) | Initializes a new PDFArc object using the specified pen and bounding rectangle.
PDFArc Constructor(PDFPen,Single,Single,Single,Single,Single,Single) | Initializes a new PDFArc object using the specified pen, a pair of coordinates and width and height. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members


%%PageItemTitle%%

PDFArc Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class > PDFArc Constructor : PDFArc Constructor()

Initializes a new PDFArc object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFArc()
C#
public PDFArc()
Delphi
public PDFArc();
Managed Extensions for C++
public: PDFArc();
C++/CLI
public:
PDFArc();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members
Overload List


%%PageItemTitle%%

PDFArc Constructor(PDFPen,RectangleF,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class > PDFArc Constructor : PDFArc Constructor(PDFPen,RectangleF,Single,Single)

pen
a Pen object used to draw the arc
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Initializes a new PDFArc object using the specified pen and bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFArc(pen, rect, startAngle, sweepAngle)
C#
public PDFArc(
   PDFPen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFArc(
    pen: PDFPen;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFArc(
   PDFPen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFArc(
   PDFPen^ pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the arc
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members
Overload List


%%PageItemTitle%%

PDFArc Constructor(PDFPen,Single,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class > PDFArc Constructor : PDFArc Constructor(PDFPen,Single,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the arc
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Initializes a new PDFArc object using the specified pen, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFArc(pen, top, left, width, height, startAngle, sweepAngle)
C#
public PDFArc(
   PDFPen pen,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFArc(
    pen: PDFPen;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFArc(
   PDFPen* pen,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFArc(
   PDFPen^ pen,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the arc
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFArc Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFArc Class

For a list of all members of this type, see PDFArc members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the arc. Supported by Compact .NET Edition.
Public Property | SweepAngle | Gets or sets the sweep angle of the ellipse. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFArc Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

StartAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class : StartAngle Property

Gets or sets the start angle of the arc.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property StartAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFArc
Dim value As Single

instance.StartAngle = value

value = instance.StartAngle
C#
public float StartAngle {get; set;}
Delphi
public read-write property StartAngle: Single;
Managed Extensions for C++
public: __property float get_StartAngle();
public: __property void set_StartAngle(
   float value
);
C++/CLI
public:
property float StartAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members


%%PageItemTitle%%

SweepAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFArc Class : SweepAngle Property

Gets or sets the sweep angle of the ellipse.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property SweepAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFArc
Dim value As Single

instance.SweepAngle = value

value = instance.SweepAngle
C#
public float SweepAngle {get; set;}
Delphi
public read-write property SweepAngle: Single;
Managed Extensions for C++
public: __property float get_SweepAngle();
public: __property void set_SweepAngle(
   float value
);
C++/CLI
public:
property float SweepAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArc Class
PDFArc Members


%%PageItemTitle%%

PDFAreaDocLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaDocLink Class

Defines a rectangular area on the page that acts a link to another page within the same document

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAreaDocLink
   Inherits PDFLink
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaDocLink
C#
public class PDFAreaDocLink : PDFLink
Delphi
public class PDFAreaDocLink = class(PDFLink)
Managed Extensions for C++
public __gc class PDFAreaDocLink : public PDFLink
C++/CLI
public ref class PDFAreaDocLink : public PDFLink

Remarks

This class allows to defines hyperlinks within the same document. The source of the hyperlink is defined by a rectangular area. The destination of the hyperlink is defined by a destination page and a position of the destination page in the viewer.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextDocLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFAreaDocLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaDocLink Class

The following tables list the members exposed by PDFAreaDocLink.

Public Constructors

 | Name | Description
Public Constructor | PDFAreaDocLink Constructor | Overloaded. Initializes a new PDFAreaDocLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | DestinationPage | Get or sets the destination page of the link Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFAreaDocLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class : PDFAreaDocLink Constructor

Initializes a new PDFAreaDocLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFAreaDocLink Constructor() | Initializes a new PDFAreaDocLink object.
PDFAreaDocLink Constructor(PDFPage,Single,RectangleF,PDFPen) | Initializes a new PDFAreaDocLink object specifying a rectangle and a destination
PDFAreaDocLink Constructor(PDFPage,Single,Single,Single,Single,Single,PDFPen) | Initializes a new PDFAreaDocLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members


%%PageItemTitle%%

PDFAreaDocLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class > PDFAreaDocLink Constructor : PDFAreaDocLink Constructor()

Initializes a new PDFAreaDocLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaDocLink()
C#
public PDFAreaDocLink()
Delphi
public PDFAreaDocLink();
Managed Extensions for C++
public: PDFAreaDocLink();
C++/CLI
public:
PDFAreaDocLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members
Overload List


%%PageItemTitle%%

PDFAreaDocLink Constructor(PDFPage,Single,RectangleF,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class > PDFAreaDocLink Constructor : PDFAreaDocLink Constructor(PDFPage,Single,RectangleF,PDFPen)

destinationPage
a PDFPage object representing the destination of the hyperlink
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaDocLink object specifying a rectangle and a destination

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim rect As RectangleF
Dim borderPen As PDFPen

Dim instance As PDFAreaDocLink(destinationPage, topDestination, rect, borderPen)
C#
public PDFAreaDocLink(
   PDFPage destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public PDFAreaDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaDocLink(
   PDFPage* destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object representing the destination of the hyperlink
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members
Overload List


%%PageItemTitle%%

PDFAreaDocLink Constructor(PDFPage,Single,Single,Single,Single,Single,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class > PDFAreaDocLink Constructor : PDFAreaDocLink Constructor(PDFPage,Single,Single,Single,Single,Single,PDFPen)

destinationPage
a PDFPage object representing the destination of the hyperlink
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaDocLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

Dim instance As PDFAreaDocLink(destinationPage, topDestination, left, top, width, height, borderPen)
C#
public PDFAreaDocLink(
   PDFPage destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public PDFAreaDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaDocLink(
   PDFPage* destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object representing the destination of the hyperlink
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAreaDocLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaDocLink Class

For a list of all members of this type, see PDFAreaDocLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | DestinationPage | Get or sets the destination page of the link Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

DestinationPage Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class : DestinationPage Property

Get or sets the destination page of the link

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DestinationPage As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaDocLink
Dim value As PDFPage

instance.DestinationPage = value

value = instance.DestinationPage
C#
public PDFPage DestinationPage {get; set;}
Delphi
public read-write property DestinationPage: PDFPage;
Managed Extensions for C++
public: __property PDFPage* get_DestinationPage();
public: __property void set_DestinationPage(
   PDFPage* value
);
C++/CLI
public:
property PDFPage^ DestinationPage {
   PDFPage^ get();
   void set (PDFPage^ value);
}

Return Value

a PDFPage object representing the destination of the link. It must be a page within the same document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members


%%PageItemTitle%%

TopDestination Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaDocLink Class : TopDestination Property

Gets or sets the vertical position of the destination page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TopDestination As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaDocLink
Dim value As Single

instance.TopDestination = value

value = instance.TopDestination
C#
public float TopDestination {get; set;}
Delphi
public read-write property TopDestination: Single;
Managed Extensions for C++
public: __property float get_TopDestination();
public: __property void set_TopDestination(
   float value
);
C++/CLI
public:
property float TopDestination {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the destination page when it is displayed in the viewer as the result of link.

Remarks

When the destination page is displayed as the result of the link, the y coordinate of the page is positioned at the top of the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaDocLink Class
PDFAreaDocLink Members


%%PageItemTitle%%

PDFAreaFileLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaFileLink Class

Defines a rectangular area on the page that acts a link to an external file

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAreaFileLink
   Inherits PDFLink
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaFileLink
C#
public class PDFAreaFileLink : PDFLink
Delphi
public class PDFAreaFileLink = class(PDFLink)
Managed Extensions for C++
public __gc class PDFAreaFileLink : public PDFLink
C++/CLI
public ref class PDFAreaFileLink : public PDFLink

Remarks

This class allows to defines hyperlinks to external files. The source of the hyperlink is defined by a rectangular area. The destination of the hyperlink is defined by a file path.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFileLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFAreaFileLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaFileLink Class

The following tables list the members exposed by PDFAreaFileLink.

Public Constructors

 | Name | Description
Public Constructor | PDFAreaFileLink Constructor | Overloaded. Initializes a new PDFAreaFileLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FilePath | Get or sets the file path. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaFileLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFAreaFileLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaFileLink Class : PDFAreaFileLink Constructor

Initializes a new PDFAreaFileLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFAreaFileLink Constructor() | Initializes a new PDFAreaFileLink object.
PDFAreaFileLink Constructor(String,RectangleF,PDFPen) | Initializes a new PDFAreaFileLink object specifying a rectangle and a destination
PDFAreaFileLink Constructor(String,Single,Single,Single,Single,PDFPen) | Initializes a new PDFAreaFileLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Class
PDFAreaFileLink Members


%%PageItemTitle%%

PDFAreaFileLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaFileLink Class > PDFAreaFileLink Constructor : PDFAreaFileLink Constructor()

Initializes a new PDFAreaFileLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaFileLink()
C#
public PDFAreaFileLink()
Delphi
public PDFAreaFileLink();
Managed Extensions for C++
public: PDFAreaFileLink();
C++/CLI
public:
PDFAreaFileLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Class
PDFAreaFileLink Members
Overload List


%%PageItemTitle%%

PDFAreaFileLink Constructor(String,RectangleF,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaFileLink Class > PDFAreaFileLink Constructor : PDFAreaFileLink Constructor(String,RectangleF,PDFPen)

filePath
a file path representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaFileLink object specifying a rectangle and a destination

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim filePath As String
Dim rect As RectangleF
Dim borderPen As PDFPen

Dim instance As PDFAreaFileLink(filePath, rect, borderPen)
C#
public PDFAreaFileLink(
   string filePath,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public PDFAreaFileLink(
    filePath: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaFileLink(
   string* filePath,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaFileLink(
   String^ filePath,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

filePath
a file path representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Class
PDFAreaFileLink Members
Overload List


%%PageItemTitle%%

PDFAreaFileLink Constructor(String,Single,Single,Single,Single,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaFileLink Class > PDFAreaFileLink Constructor : PDFAreaFileLink Constructor(String,Single,Single,Single,Single,PDFPen)

filePath
a file path representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaFileLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim filePath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

Dim instance As PDFAreaFileLink(filePath, left, top, width, height, borderPen)
C#
public PDFAreaFileLink(
   string filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public PDFAreaFileLink(
    filePath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaFileLink(
   string* filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaFileLink(
   String^ filePath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

filePath
a file path representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Class
PDFAreaFileLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAreaFileLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaFileLink Class

For a list of all members of this type, see PDFAreaFileLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FilePath | Get or sets the file path. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaFileLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FilePath Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaFileLink Class : FilePath Property

Get or sets the file path.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FilePath As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaFileLink
Dim value As String

instance.FilePath = value

value = instance.FilePath
C#
public string FilePath {get; set;}
Delphi
public read-write property FilePath: String;
Managed Extensions for C++
public: __property string* get_FilePath();
public: __property void set_FilePath(
   string* value
);
C++/CLI
public:
property String^ FilePath {
   String^ get();
   void set (String^ value);
}

Return Value

a string value representing a file path

Remarks

The file path is considered relative to the pdf file, when it is open by the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaFileLink Class
PDFAreaFileLink Members


%%PageItemTitle%%

PDFAreaRemoteDocLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaRemoteDocLink Class

Defines a rectangular area on the page that acts a link to another pdf file

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAreaRemoteDocLink
   Inherits PDFLink
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaRemoteDocLink
C#
public class PDFAreaRemoteDocLink : PDFLink
Delphi
public class PDFAreaRemoteDocLink = class(PDFLink)
Managed Extensions for C++
public __gc class PDFAreaRemoteDocLink : public PDFLink
C++/CLI
public ref class PDFAreaRemoteDocLink : public PDFLink

Remarks

This class allows to defines hyperlinks to other pdf files. The source of the hyperlink is defined by a rectangular area. The destination of the hyperlink is defined by a file path.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextRemoteDocLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFAreaRemoteDocLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaRemoteDocLink Class

The following tables list the members exposed by PDFAreaRemoteDocLink.

Public Constructors

 | Name | Description
Public Constructor | PDFAreaRemoteDocLink Constructor | Overloaded. Initializes a new PDFAreaRemoteDocLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | DocumentPath | Get or sets the document path. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | OpenInNewWindow | Gets or sets whether the new document should be opened in a new window.
Public Property | PageNumber | Gets or sets the destination page in the remote document.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaRemoteDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFAreaRemoteDocLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class : PDFAreaRemoteDocLink Constructor

Initializes a new PDFAreaRemoteDocLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFAreaRemoteDocLink Constructor() | Initializes a new PDFAreaRemoteDocLink object.
PDFAreaRemoteDocLink Constructor(String,RectangleF,PDFPen) | Initializes a new PDFAreaRemoteDocLink object specifying a rectangle and a destination
PDFAreaRemoteDocLink Constructor(String,Single,Single,Single,Single,PDFPen) | Initializes a new PDFAreaRemoteDocLink object specifying a pair of coordinates, a width and height, and a destination Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members


%%PageItemTitle%%

PDFAreaRemoteDocLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class > PDFAreaRemoteDocLink Constructor : PDFAreaRemoteDocLink Constructor()

Initializes a new PDFAreaRemoteDocLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaRemoteDocLink()
C#
public PDFAreaRemoteDocLink()
Delphi
public PDFAreaRemoteDocLink();
Managed Extensions for C++
public: PDFAreaRemoteDocLink();
C++/CLI
public:
PDFAreaRemoteDocLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members
Overload List


%%PageItemTitle%%

PDFAreaRemoteDocLink Constructor(String,RectangleF,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class > PDFAreaRemoteDocLink Constructor : PDFAreaRemoteDocLink Constructor(String,RectangleF,PDFPen)

documentPath
a file path representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaRemoteDocLink object specifying a rectangle and a destination

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal documentPath As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim documentPath As String
Dim rect As RectangleF
Dim borderPen As PDFPen

Dim instance As PDFAreaRemoteDocLink(documentPath, rect, borderPen)
C#
public PDFAreaRemoteDocLink(
   string documentPath,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public PDFAreaRemoteDocLink(
    documentPath: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaRemoteDocLink(
   string* documentPath,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaRemoteDocLink(
   String^ documentPath,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

documentPath
a file path representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members
Overload List


%%PageItemTitle%%

PDFAreaRemoteDocLink Constructor(String,Single,Single,Single,Single,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class > PDFAreaRemoteDocLink Constructor : PDFAreaRemoteDocLink Constructor(String,Single,Single,Single,Single,PDFPen)

documentPath
a file path representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaRemoteDocLink object specifying a pair of coordinates, a width and height, and a destination

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal documentPath As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim documentPath As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

Dim instance As PDFAreaRemoteDocLink(documentPath, left, top, width, height, borderPen)
C#
public PDFAreaRemoteDocLink(
   string documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public PDFAreaRemoteDocLink(
    documentPath: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaRemoteDocLink(
   string* documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaRemoteDocLink(
   String^ documentPath,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

documentPath
a file path representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAreaRemoteDocLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaRemoteDocLink Class

For a list of all members of this type, see PDFAreaRemoteDocLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | DocumentPath | Get or sets the document path. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | OpenInNewWindow | Gets or sets whether the new document should be opened in a new window.
Public Property | PageNumber | Gets or sets the destination page in the remote document.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaRemoteDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

DocumentPath Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class : DocumentPath Property

Get or sets the document path.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property DocumentPath As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaRemoteDocLink
Dim value As String

instance.DocumentPath = value

value = instance.DocumentPath
C#
public string DocumentPath {get; set;}
Delphi
public read-write property DocumentPath: String;
Managed Extensions for C++
public: __property string* get_DocumentPath();
public: __property void set_DocumentPath(
   string* value
);
C++/CLI
public:
property String^ DocumentPath {
   String^ get();
   void set (String^ value);
}

Return Value

a string value representing a file path

Remarks

The document path is considered relative to the pdf file, when it is open by the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members


%%PageItemTitle%%

OpenInNewWindow Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class : OpenInNewWindow Property

Gets or sets whether the new document should be opened in a new window.

Syntax

Visual Basic (Declaration)
Public Property OpenInNewWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaRemoteDocLink
Dim value As Boolean

instance.OpenInNewWindow = value

value = instance.OpenInNewWindow
C#
public bool OpenInNewWindow {get; set;}
Delphi
public read-write property OpenInNewWindow: Boolean;
Managed Extensions for C++
public: __property bool get_OpenInNewWindow();
public: __property void set_OpenInNewWindow(
   bool value
);
C++/CLI
public:
property bool OpenInNewWindow {
   bool get();
   void set (bool value);
}

Return Value

True if the new document should open in a new window. Otherwise the current document is replaced.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members


%%PageItemTitle%%

PageNumber Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaRemoteDocLink Class : PageNumber Property

Gets or sets the destination page in the remote document.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaRemoteDocLink
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Delphi
public read-write property PageNumber: Integer;
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (int value);
}

Return Value

The number of destination page in the remote document.

Remarks

The pages in the remote document are numbered starting from 0 to page count - 1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaRemoteDocLink Class
PDFAreaRemoteDocLink Members


%%PageItemTitle%%

PDFAreaWebLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaWebLink Class

Defines a rectangular area on the page that acts a link to a web location.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAreaWebLink
   Inherits PDFLink
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaWebLink
C#
public class PDFAreaWebLink : PDFLink
Delphi
public class PDFAreaWebLink = class(PDFLink)
Managed Extensions for C++
public __gc class PDFAreaWebLink : public PDFLink
C++/CLI
public ref class PDFAreaWebLink : public PDFLink

Remarks

This class allows to defines hyperlinks to web locations. The source of the hyperlink is defined by a rectangular area. The destination of the hyperlink is defined by a URL.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextWebLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFAreaWebLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaWebLink Class

The following tables list the members exposed by PDFAreaWebLink.

Public Constructors

 | Name | Description
Public Constructor | PDFAreaWebLink Constructor | Overloaded. Initializes a new PDFAreaWebLink object.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | URL | Get or sets the destination web location of the link. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaWebLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFAreaWebLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaWebLink Class : PDFAreaWebLink Constructor

Initializes a new PDFAreaWebLink object.

Overload List

Overload | Description
PDFAreaWebLink Constructor() | Initializes a new PDFAreaWebLink object.
PDFAreaWebLink Constructor(String,RectangleF,PDFPen) | Initializes a new PDFAreaWebLink object specifying a rectangle and a destination
PDFAreaWebLink Constructor(String,Single,Single,Single,Single,PDFPen) | Initializes a new PDFAreaWebLink object specifying a pair of coordinates, a width and height, and a destination. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Class
PDFAreaWebLink Members


%%PageItemTitle%%

PDFAreaWebLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaWebLink Class > PDFAreaWebLink Constructor : PDFAreaWebLink Constructor()

Initializes a new PDFAreaWebLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaWebLink()
C#
public PDFAreaWebLink()
Delphi
public PDFAreaWebLink();
Managed Extensions for C++
public: PDFAreaWebLink();
C++/CLI
public:
PDFAreaWebLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Class
PDFAreaWebLink Members
Overload List


%%PageItemTitle%%

PDFAreaWebLink Constructor(String,RectangleF,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaWebLink Class > PDFAreaWebLink Constructor : PDFAreaWebLink Constructor(String,RectangleF,PDFPen)

url
a web location representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaWebLink object specifying a rectangle and a destination

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal url As String, _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim url As String
Dim rect As RectangleF
Dim borderPen As PDFPen

Dim instance As PDFAreaWebLink(url, rect, borderPen)
C#
public PDFAreaWebLink(
   string url,
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public PDFAreaWebLink(
    url: String;
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaWebLink(
   string* url,
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaWebLink(
   String^ url,
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

url
a web location representing the destination of the hyperlink
rect
a RectangleF object that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Class
PDFAreaWebLink Members
Overload List


%%PageItemTitle%%

PDFAreaWebLink Constructor(String,Single,Single,Single,Single,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaWebLink Class > PDFAreaWebLink Constructor : PDFAreaWebLink Constructor(String,Single,Single,Single,Single,PDFPen)

url
a web location representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFAreaWebLink object specifying a pair of coordinates, a width and height, and a destination.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal url As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim url As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

Dim instance As PDFAreaWebLink(url, left, top, width, height, borderPen)
C#
public PDFAreaWebLink(
   string url,
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public PDFAreaWebLink(
    url: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFAreaWebLink(
   string* url,
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
PDFAreaWebLink(
   String^ url,
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

url
a web location representing the destination of the hyperlink
left
x-coordinate of the upper-left corner of the rectangular area that defines the link.
top
y-coordinate of the upper-left corner of the rectangular area that defines the link.
width
width of the rectangular area that defines the link.
height
height of the rectangular area that defines the link.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Class
PDFAreaWebLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAreaWebLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFAreaWebLink Class

For a list of all members of this type, see PDFAreaWebLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | URL | Get or sets the destination web location of the link. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFAreaWebLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

URL Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFAreaWebLink Class : URL Property

Get or sets the destination web location of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property URL As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAreaWebLink
Dim value As String

instance.URL = value

value = instance.URL
C#
public string URL {get; set;}
Delphi
public read-write property URL: String;
Managed Extensions for C++
public: __property string* get_URL();
public: __property void set_URL(
   string* value
);
C++/CLI
public:
property String^ URL {
   String^ get();
   void set (String^ value);
}

Return Value

a string value representing a web location.

Remarks

A web location is represented by a HTTP/HTTPS URL.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAreaWebLink Class
PDFAreaWebLink Members


%%PageItemTitle%%

PDFBezier Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFBezier Class

Defines a Bezier spline defined by four control points.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFBezier
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
C#
public sealed class PDFBezier : PDFGraphic
Delphi
public class PDFBezier = class(PDFGraphic)sealed;
Managed Extensions for C++
public __gc __sealed class PDFBezier : public PDFGraphic
C++/CLI
public ref class PDFBezier sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFBezier

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFBezier Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFBezier Class

The following tables list the members exposed by PDFBezier.

Public Constructors

 | Name | Description
Public Constructor | PDFBezier Constructor | Overloaded. Initiaizes a new PDFBezier object specifying four pairs of coordinates. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | X1 | Gets or sets the x coordinate of the first control point. Supported by Compact .NET Edition.
Public Property | X2 | Gets or sets the x coordinate of the second control point. Supported by Compact .NET Edition.
Public Property | X3 | Gets or sets the x coordinate of the third control point. Supported by Compact .NET Edition.
Public Property | X4 | Gets or sets the x coordinate of the fourth control point. Supported by Compact .NET Edition.
Public Property | Y1 | Gets or sets the y coordinate of the first control point. Supported by Compact .NET Edition.
Public Property | Y2 | Gets or sets the y coordinate of the second control point. Supported by Compact .NET Edition.
Public Property | Y3 | Gets or sets the y coordinate of the third control point. Supported by Compact .NET Edition.
Public Property | Y4 | Gets or sets the y coordinate of the fourth control point. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFBezier Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFBezier Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : PDFBezier Constructor

Initiaizes a new PDFBezier object specifying four pairs of coordinates.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFBezier Constructor() | Initializes a new PDFBezier object.
PDFBezier Constructor(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) | Initiaizes a new PDFBezier object specifying four PointF structures.
PDFBezier Constructor(PDFPen,PointF,PointF,PointF,PointF) | Initiaizes a new PDFBezier object specifying four PointF structures.
PDFBezier Constructor(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single) | Initiaizes a new PDFBezier object specifying four pairs of coordinates. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

PDFBezier Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class > PDFBezier Constructor : PDFBezier Constructor()

Initializes a new PDFBezier object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier()
C#
public PDFBezier()
Delphi
public PDFBezier();
Managed Extensions for C++
public: PDFBezier();
C++/CLI
public:
PDFBezier();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members
Overload List


%%PageItemTitle%%

PDFBezier Constructor(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class > PDFBezier Constructor : PDFBezier Constructor(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint)

pen
a Pen object used to draw the Bezier spline
cp1
a PDFPoint structure specifying the coordinates of the first control point
cp2
a PDFPoint structure specifying the coordinates of the second control point
cp3
a PDFPoint structure specifying the coordinates of the third control point
cp4
a PDFPoint structure specifying the coordinates of the fourth control point
Initiaizes a new PDFBezier object specifying four PointF structures.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal cp1 As PDFPoint, _
   ByVal cp2 As PDFPoint, _
   ByVal cp3 As PDFPoint, _
   ByVal cp4 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim cp1 As PDFPoint
Dim cp2 As PDFPoint
Dim cp3 As PDFPoint
Dim cp4 As PDFPoint

Dim instance As PDFBezier(pen, cp1, cp2, cp3, cp4)
C#
public PDFBezier(
   PDFPen pen,
   PDFPoint cp1,
   PDFPoint cp2,
   PDFPoint cp3,
   PDFPoint cp4
)
Delphi
public PDFBezier(
    pen: PDFPen;
    cp1: PDFPoint;
    cp2: PDFPoint;
    cp3: PDFPoint;
    cp4: PDFPoint
);
Managed Extensions for C++
public: PDFBezier(
   PDFPen* pen,
   PDFPoint* cp1,
   PDFPoint* cp2,
   PDFPoint* cp3,
   PDFPoint* cp4
)
C++/CLI
public:
PDFBezier(
   PDFPen^ pen,
   PDFPoint^ cp1,
   PDFPoint^ cp2,
   PDFPoint^ cp3,
   PDFPoint^ cp4
)

Parameters

pen
a Pen object used to draw the Bezier spline
cp1
a PDFPoint structure specifying the coordinates of the first control point
cp2
a PDFPoint structure specifying the coordinates of the second control point
cp3
a PDFPoint structure specifying the coordinates of the third control point
cp4
a PDFPoint structure specifying the coordinates of the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members
Overload List


%%PageItemTitle%%

PDFBezier Constructor(PDFPen,PointF,PointF,PointF,PointF)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class > PDFBezier Constructor : PDFBezier Constructor(PDFPen,PointF,PointF,PointF,PointF)

pen
a Pen object used to draw the Bezier spline
cp1
a PointF structure specifying the coordinates of the first control point
cp2
a PointF structure specifying the coordinates of the second control point
cp3
a PointF structure specifying the coordinates of the third control point
cp4
a PointF structure specifying the coordinates of the fourth control point
Initiaizes a new PDFBezier object specifying four PointF structures.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal cp1 As PointF, _
   ByVal cp2 As PointF, _
   ByVal cp3 As PointF, _
   ByVal cp4 As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim cp1 As PointF
Dim cp2 As PointF
Dim cp3 As PointF
Dim cp4 As PointF

Dim instance As PDFBezier(pen, cp1, cp2, cp3, cp4)
C#
public PDFBezier(
   PDFPen pen,
   PointF cp1,
   PointF cp2,
   PointF cp3,
   PointF cp4
)
Delphi
public PDFBezier(
    pen: PDFPen;
    cp1: PointF;
    cp2: PointF;
    cp3: PointF;
    cp4: PointF
);
Managed Extensions for C++
public: PDFBezier(
   PDFPen* pen,
   PointF cp1,
   PointF cp2,
   PointF cp3,
   PointF cp4
)
C++/CLI
public:
PDFBezier(
   PDFPen^ pen,
   PointF cp1,
   PointF cp2,
   PointF cp3,
   PointF cp4
)

Parameters

pen
a Pen object used to draw the Bezier spline
cp1
a PointF structure specifying the coordinates of the first control point
cp2
a PointF structure specifying the coordinates of the second control point
cp3
a PointF structure specifying the coordinates of the third control point
cp4
a PointF structure specifying the coordinates of the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members
Overload List


%%PageItemTitle%%

PDFBezier Constructor(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class > PDFBezier Constructor : PDFBezier Constructor(PDFPen,Single,Single,Single,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the Bezier spline
cpX1
x-coordinate of the first control point
cpY1
y-coordinate of the first control point
cpX2
x-coordinate of the second control point
cpY2
y-coordinate of the second control point
cpX3
x-coordinate of the third control point
cpY3
y-coordinate of the third control point
cpX4
x-coordinate of the fourth control point
cpY4
y-coordinate of the fourth control point
Initiaizes a new PDFBezier object specifying four pairs of coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal cpX1 As Single, _
   ByVal cpY1 As Single, _
   ByVal cpX2 As Single, _
   ByVal cpY2 As Single, _
   ByVal cpX3 As Single, _
   ByVal cpY3 As Single, _
   ByVal cpX4 As Single, _
   ByVal cpY4 As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim cpX1 As Single
Dim cpY1 As Single
Dim cpX2 As Single
Dim cpY2 As Single
Dim cpX3 As Single
Dim cpY3 As Single
Dim cpX4 As Single
Dim cpY4 As Single

Dim instance As PDFBezier(pen, cpX1, cpY1, cpX2, cpY2, cpX3, cpY3, cpX4, cpY4)
C#
public PDFBezier(
   PDFPen pen,
   float cpX1,
   float cpY1,
   float cpX2,
   float cpY2,
   float cpX3,
   float cpY3,
   float cpX4,
   float cpY4
)
Delphi
public PDFBezier(
    pen: PDFPen;
    cpX1: Single;
    cpY1: Single;
    cpX2: Single;
    cpY2: Single;
    cpX3: Single;
    cpY3: Single;
    cpX4: Single;
    cpY4: Single
);
Managed Extensions for C++
public: PDFBezier(
   PDFPen* pen,
   float cpX1,
   float cpY1,
   float cpX2,
   float cpY2,
   float cpX3,
   float cpY3,
   float cpX4,
   float cpY4
)
C++/CLI
public:
PDFBezier(
   PDFPen^ pen,
   float cpX1,
   float cpY1,
   float cpX2,
   float cpY2,
   float cpX3,
   float cpY3,
   float cpX4,
   float cpY4
)

Parameters

pen
a Pen object used to draw the Bezier spline
cpX1
x-coordinate of the first control point
cpY1
y-coordinate of the first control point
cpX2
x-coordinate of the second control point
cpY2
y-coordinate of the second control point
cpX3
x-coordinate of the third control point
cpY3
y-coordinate of the third control point
cpX4
x-coordinate of the fourth control point
cpY4
y-coordinate of the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFBezier Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFBezier Class

For a list of all members of this type, see PDFBezier members.

Public Properties

 | Name | Description
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | X1 | Gets or sets the x coordinate of the first control point. Supported by Compact .NET Edition.
Public Property | X2 | Gets or sets the x coordinate of the second control point. Supported by Compact .NET Edition.
Public Property | X3 | Gets or sets the x coordinate of the third control point. Supported by Compact .NET Edition.
Public Property | X4 | Gets or sets the x coordinate of the fourth control point. Supported by Compact .NET Edition.
Public Property | Y1 | Gets or sets the y coordinate of the first control point. Supported by Compact .NET Edition.
Public Property | Y2 | Gets or sets the y coordinate of the second control point. Supported by Compact .NET Edition.
Public Property | Y3 | Gets or sets the y coordinate of the third control point. Supported by Compact .NET Edition.
Public Property | Y4 | Gets or sets the y coordinate of the fourth control point. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFBezier Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

X1 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : X1 Property

Gets or sets the x coordinate of the first control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X1 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.X1 = value

value = instance.X1
C#
public float X1 {get; set;}
Delphi
public read-write property X1: Single;
Managed Extensions for C++
public: __property float get_X1();
public: __property void set_X1(
   float value
);
C++/CLI
public:
property float X1 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the first control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

X2 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : X2 Property

Gets or sets the x coordinate of the second control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X2 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.X2 = value

value = instance.X2
C#
public float X2 {get; set;}
Delphi
public read-write property X2: Single;
Managed Extensions for C++
public: __property float get_X2();
public: __property void set_X2(
   float value
);
C++/CLI
public:
property float X2 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the second control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

X3 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : X3 Property

Gets or sets the x coordinate of the third control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X3 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.X3 = value

value = instance.X3
C#
public float X3 {get; set;}
Delphi
public read-write property X3: Single;
Managed Extensions for C++
public: __property float get_X3();
public: __property void set_X3(
   float value
);
C++/CLI
public:
property float X3 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the third control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

X4 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : X4 Property

Gets or sets the x coordinate of the fourth control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X4 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.X4 = value

value = instance.X4
C#
public float X4 {get; set;}
Delphi
public read-write property X4: Single;
Managed Extensions for C++
public: __property float get_X4();
public: __property void set_X4(
   float value
);
C++/CLI
public:
property float X4 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the fourth control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

Y1 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : Y1 Property

Gets or sets the y coordinate of the first control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y1 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.Y1 = value

value = instance.Y1
C#
public float Y1 {get; set;}
Delphi
public read-write property Y1: Single;
Managed Extensions for C++
public: __property float get_Y1();
public: __property void set_Y1(
   float value
);
C++/CLI
public:
property float Y1 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the first control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

Y2 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : Y2 Property

Gets or sets the y coordinate of the second control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y2 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.Y2 = value

value = instance.Y2
C#
public float Y2 {get; set;}
Delphi
public read-write property Y2: Single;
Managed Extensions for C++
public: __property float get_Y2();
public: __property void set_Y2(
   float value
);
C++/CLI
public:
property float Y2 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the second control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

Y3 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : Y3 Property

Gets or sets the y coordinate of the third control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y3 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.Y3 = value

value = instance.Y3
C#
public float Y3 {get; set;}
Delphi
public read-write property Y3: Single;
Managed Extensions for C++
public: __property float get_Y3();
public: __property void set_Y3(
   float value
);
C++/CLI
public:
property float Y3 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the third control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

Y4 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFBezier Class : Y4 Property

Gets or sets the y coordinate of the fourth control point.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y4 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFBezier
Dim value As Single

instance.Y4 = value

value = instance.Y4
C#
public float Y4 {get; set;}
Delphi
public read-write property Y4: Single;
Managed Extensions for C++
public: __property float get_Y4();
public: __property void set_Y4(
   float value
);
C++/CLI
public:
property float Y4 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the fourth control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBezier Class
PDFBezier Members


%%PageItemTitle%%

PDFChord Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFChord Class

Defines a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFChord
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFChord
C#
public sealed class PDFChord : PDFRectangularObject
Delphi
public class PDFChord = class(PDFRectangularObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFChord : public PDFRectangularObject
C++/CLI
public ref class PDFChord sealed : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFChord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFChord Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFChord Class

The following tables list the members exposed by PDFChord.

Public Constructors

 | Name | Description
Public Constructor | PDFChord Constructor | Overloaded. Initializes a new PDFChord object using the specified pen, a pair of coordinates and widh and height.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the chord.
Public Property | SweepAngle | Gets or sets the sweep angle of the chord.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFChord Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFChord Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class : PDFChord Constructor

Initializes a new PDFChord object using the specified pen, a pair of coordinates and widh and height.

Overload List

Overload | Description
PDFChord Constructor() | Initializes a new PDFChord object.
PDFChord Constructor(PDFPen,PDFBrush,RectangleF,Single,Single) | Initializes a new PDFChord object using the specified pen and bounding rectangle.
PDFChord Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) | Initializes a new PDFChord object using the specified pen, a pair of coordinates and widh and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members


%%PageItemTitle%%

PDFChord Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class > PDFChord Constructor : PDFChord Constructor()

Initializes a new PDFChord object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFChord()
C#
public PDFChord()
Delphi
public PDFChord();
Managed Extensions for C++
public: PDFChord();
C++/CLI
public:
PDFChord();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members
Overload List


%%PageItemTitle%%

PDFChord Constructor(PDFPen,PDFBrush,RectangleF,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class > PDFChord Constructor : PDFChord Constructor(PDFPen,PDFBrush,RectangleF,Single,Single)

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Initializes a new PDFChord object using the specified pen and bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFChord(pen, brush, rect, startAngle, sweepAngle)
C#
public PDFChord(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFChord(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFChord(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members
Overload List


%%PageItemTitle%%

PDFChord Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class > PDFChord Constructor : PDFChord Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured clockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured clockwise from the startAngle parameter to ending point of the chord.
Initializes a new PDFChord object using the specified pen, a pair of coordinates and widh and height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFChord(pen, brush, left, top, width, height, startAngle, sweepAngle)
C#
public PDFChord(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFChord(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFChord(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured clockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured clockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFChord Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFChord Class

For a list of all members of this type, see PDFChord members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the chord.
Public Property | SweepAngle | Gets or sets the sweep angle of the chord.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFChord Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

StartAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class : StartAngle Property

Gets or sets the start angle of the chord.

Syntax

Visual Basic (Declaration)
Public Property StartAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFChord
Dim value As Single

instance.StartAngle = value

value = instance.StartAngle
C#
public float StartAngle {get; set;}
Delphi
public read-write property StartAngle: Single;
Managed Extensions for C++
public: __property float get_StartAngle();
public: __property void set_StartAngle(
   float value
);
C++/CLI
public:
property float StartAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members


%%PageItemTitle%%

SweepAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFChord Class : SweepAngle Property

Gets or sets the sweep angle of the chord.

Syntax

Visual Basic (Declaration)
Public Property SweepAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFChord
Dim value As Single

instance.SweepAngle = value

value = instance.SweepAngle
C#
public float SweepAngle {get; set;}
Delphi
public read-write property SweepAngle: Single;
Managed Extensions for C++
public: __property float get_SweepAngle();
public: __property void set_SweepAngle(
   float value
);
C++/CLI
public:
property float SweepAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFChord Class
PDFChord Members


%%PageItemTitle%%

PDFClippingRegion Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFClippingRegion Class

Defines a clipping region on the page.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFClippingRegion
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFClippingRegion
C#
public class PDFClippingRegion : PDFGraphic
Delphi
public class PDFClippingRegion = class(PDFGraphic)
Managed Extensions for C++
public __gc class PDFClippingRegion : public PDFGraphic
C++/CLI
public ref class PDFClippingRegion : public PDFGraphic

Remarks

A clipping region defines an area on the page that limits the visible content to that inside the area. Content outside the area is not visible. When a clipping region is in place, the subsequent graphic operations are clipped at the border of the region until the clipping region is reset to whole page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFClippingRegion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFClippingRegion Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFClippingRegion Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFClippingRegion Class

The following tables list the members exposed by PDFClippingRegion.

Public Constructors

 | Name | Description
Public Constructor | PDFClippingRegion Constructor | Initializes a new PDFClippingRegion object with the given figure. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipGraphic | Gets the clipping graphic object that defines this region. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFClippingRegion Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFClippingRegion Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFClippingRegion Class : PDFClippingRegion Constructor

clipGraphic
the geometric figure defining the clipping region
Initializes a new PDFClippingRegion object with the given figure.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal clipGraphic As PDFGraphic _
)
Visual Basic (Usage) Copy Code
Dim clipGraphic As PDFGraphic

Dim instance As PDFClippingRegion(clipGraphic)
C#
public PDFClippingRegion(
   PDFGraphic clipGraphic
)
Delphi
public PDFClippingRegion(
    clipGraphic: PDFGraphic
);
Managed Extensions for C++
public: PDFClippingRegion(
   PDFGraphic* clipGraphic
)
C++/CLI
public:
PDFClippingRegion(
   PDFGraphic^ clipGraphic
)

Parameters

clipGraphic
the geometric figure defining the clipping region

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFClippingRegion Class
PDFClippingRegion Members


%%PageItemTitle%% $$Properties$$

PDFClippingRegion Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFClippingRegion Class

For a list of all members of this type, see PDFClippingRegion members.

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipGraphic | Gets the clipping graphic object that defines this region. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFClippingRegion Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

ClipGraphic Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFClippingRegion Class : ClipGraphic Property

Gets the clipping graphic object that defines this region.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClipGraphic As PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFClippingRegion
Dim value As PDFGraphic

value = instance.ClipGraphic
C#
public PDFGraphic ClipGraphic {get;}
Delphi
public read-only property ClipGraphic: PDFGraphic;
Managed Extensions for C++
public: __property PDFGraphic* get_ClipGraphic();
C++/CLI
public:
property PDFGraphic^ ClipGraphic {
   PDFGraphic^ get();
}

Return Value

A PDFGraphic descendant specifying the clipping region.

Remarks

Only the following shapes can be used as clipping regions: rectangles, pies, polygons and ellipses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFClippingRegion Class
PDFClippingRegion Members


%%PageItemTitle%%

PDFEllipse Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFEllipse Class

Defines an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFEllipse
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFEllipse
C#
public sealed class PDFEllipse : PDFRectangularObject
Delphi
public class PDFEllipse = class(PDFRectangularObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFEllipse : public PDFRectangularObject
C++/CLI
public ref class PDFEllipse sealed : public PDFRectangularObject

Remarks

When the width of the ellipse equals the height of the ellipse, then a circle is drawn.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFEllipse

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipse Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFEllipse Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFEllipse Class

The following tables list the members exposed by PDFEllipse.

Public Constructors

 | Name | Description
Public Constructor | PDFEllipse Constructor | Overloaded. Initializes a new PDFEllipse object using the specified pen, brush, a pair of coordinates and width and height. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFEllipse Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFEllipse Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFEllipse Class : PDFEllipse Constructor

Initializes a new PDFEllipse object using the specified pen, brush, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFEllipse Constructor() | Initializes a new PDFEllipse object.
PDFEllipse Constructor(PDFPen,PDFBrush,RectangleF) | Initializes a new PDFEllipse object using the specified pen, brush and bounding rectangle.
PDFEllipse Constructor(PDFPen,PDFBrush,Single,Single,Single,Single) | Initializes a new PDFEllipse object using the specified pen, brush, a pair of coordinates and width and height. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipse Class
PDFEllipse Members


%%PageItemTitle%%

PDFEllipse Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFEllipse Class > PDFEllipse Constructor : PDFEllipse Constructor()

Initializes a new PDFEllipse object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEllipse()
C#
public PDFEllipse()
Delphi
public PDFEllipse();
Managed Extensions for C++
public: PDFEllipse();
C++/CLI
public:
PDFEllipse();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipse Class
PDFEllipse Members
Overload List


%%PageItemTitle%%

PDFEllipse Constructor(PDFPen,PDFBrush,RectangleF)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFEllipse Class > PDFEllipse Constructor : PDFEllipse Constructor(PDFPen,PDFBrush,RectangleF)

pen
a PDFPen object used to draw the ellipse
brush
a PDFBrush object used to fill the ellipse
rect
a RectangleF object that defines the ellipse.
Initializes a new PDFEllipse object using the specified pen, brush and bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

Dim instance As PDFEllipse(pen, brush, rect)
C#
public PDFEllipse(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
Delphi
public PDFEllipse(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF
);
Managed Extensions for C++
public: PDFEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
PDFEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the ellipse
brush
a PDFBrush object used to fill the ellipse
rect
a RectangleF object that defines the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipse Class
PDFEllipse Members
Overload List


%%PageItemTitle%%

PDFEllipse Constructor(PDFPen,PDFBrush,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFEllipse Class > PDFEllipse Constructor : PDFEllipse Constructor(PDFPen,PDFBrush,Single,Single,Single,Single)

pen
a PDFPen object used to draw the ellipse
brush
a PDFBrush object used to fill the ellipse
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
Initializes a new PDFEllipse object using the specified pen, brush, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single

Dim instance As PDFEllipse(pen, brush, top, left, width, height)
C#
public PDFEllipse(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height
)
Delphi
public PDFEllipse(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: PDFEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height
)
C++/CLI
public:
PDFEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the ellipse
brush
a PDFBrush object used to fill the ellipse
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipse Class
PDFEllipse Members
Overload List


%%PageItemTitle%%

PDFFormXObject Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

Defines a block of graphic sequences (drawing primitives, text and images) that can be painted multiple times on the same page or on different pages.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFormXObject
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
C#
public class PDFFormXObject : PDFRectangularObject
Delphi
public class PDFFormXObject = class(PDFRectangularObject)
Managed Extensions for C++
public __gc class PDFFormXObject : public PDFRectangularObject
C++/CLI
public ref class PDFFormXObject : public PDFRectangularObject

Remarks

The advantage of a graphic block is that its content is stored only once in the pdf file, while it can be painted multiple times on document's pages.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFFormXObject Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

The following tables list the members exposed by PDFFormXObject.

Public Constructors

 | Name | Description
Public Constructor | PDFFormXObject Constructor | Overloaded. Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Canvas | Gets the canvas of this graphic object.
Public Property | ContentMirroring | Gets or sets the mirroring of the form XObject's content.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the graphic block.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFFormXObject Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : PDFFormXObject Constructor

Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object.

Overload List

Overload | Description
PDFFormXObject Constructor() | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object.
PDFFormXObject Constructor(PDFFormXObject) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block.
PDFFormXObject Constructor(PDFFormXObject,RectangleF,Single) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block specifying a bounding rectangle.
PDFFormXObject Constructor(PDFFormXObject,Single,Single,Single,Single,Single) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block specifying a pair of coordinates, a width and a height.
PDFFormXObject Constructor(PDFImportedContent) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object with the given content.
PDFFormXObject Constructor(PDFImportedContent,ContentMirroring) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object with the given content and a mirroring mode.
PDFFormXObject Constructor(RectangleF,Single) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying a bounding rectangle.
PDFFormXObject Constructor(Single,Single,Single,Single,Single) | Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

PDFFormXObject Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor()

Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject()
C#
public PDFFormXObject()
Delphi
public PDFFormXObject();
Managed Extensions for C++
public: PDFFormXObject();
C++/CLI
public:
PDFFormXObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFFormXObject)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFFormXObject)

block
the original graphic block
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal block As PDFFormXObject _
)
Visual Basic (Usage) Copy Code
Dim block As PDFFormXObject

Dim instance As PDFFormXObject(block)
C#
public PDFFormXObject(
   PDFFormXObject block
)
Delphi
public PDFFormXObject(
    block: PDFFormXObject
);
Managed Extensions for C++
public: PDFFormXObject(
   PDFFormXObject* block
)
C++/CLI
public:
PDFFormXObject(
   PDFFormXObject^ block
)

Parameters

block
the original graphic block

Exceptions

Exception | Description
ArgumentNullException | thrown when block is null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFFormXObject,RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFFormXObject,RectangleF,Single)

block
the original graphic block
rect
a RectangleF object that defines the graphic block.
orientation
orientation of the graphic block.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block specifying a bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal block As PDFFormXObject, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim block As PDFFormXObject
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFFormXObject(block, rect, orientation)
C#
public PDFFormXObject(
   PDFFormXObject block,
   RectangleF rect,
   float orientation
)
Delphi
public PDFFormXObject(
    block: PDFFormXObject;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFFormXObject(
   PDFFormXObject* block,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFFormXObject(
   PDFFormXObject^ block,
   RectangleF rect,
   float orientation
)

Parameters

block
the original graphic block
rect
a RectangleF object that defines the graphic block.
orientation
orientation of the graphic block.

Exceptions

Exception | Description
ArgumentNullException | thrown when block is null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFFormXObject,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFFormXObject,Single,Single,Single,Single,Single)

block
the original graphic block
left
the x-coordinate of the upper-left corner of the graphic block.
top
the y-coordinate of the upper-left corner of the graphic block.
width
width of the graphic block.
height
height of the graphic block.
orientation
orientation of the graphic block.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object based on an existing graphic block specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal block As PDFFormXObject, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim block As PDFFormXObject
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFFormXObject(block, left, top, width, height, orientation)
C#
public PDFFormXObject(
   PDFFormXObject block,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public PDFFormXObject(
    block: PDFFormXObject;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFFormXObject(
   PDFFormXObject* block,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFFormXObject(
   PDFFormXObject^ block,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

block
the original graphic block
left
the x-coordinate of the upper-left corner of the graphic block.
top
the y-coordinate of the upper-left corner of the graphic block.
width
width of the graphic block.
height
height of the graphic block.
orientation
orientation of the graphic block.

Exceptions

Exception | Description
ArgumentNullException | thrown when block is null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFImportedContent)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFImportedContent)

importedContent
The imported content extracted from an existing page.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object with the given content.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
Visual Basic (Usage) Copy Code
Dim importedContent As PDFImportedContent

Dim instance As PDFFormXObject(importedContent)
C#
public PDFFormXObject(
   PDFImportedContent importedContent
)
Delphi
public PDFFormXObject(
    importedContent: PDFImportedContent
);
Managed Extensions for C++
public: PDFFormXObject(
   PDFImportedContent* importedContent
)
C++/CLI
public:
PDFFormXObject(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
The imported content extracted from an existing page.

Exceptions

Exception | Description
ArgumentNullException | thrown when importedContent is null

Remarks

This constructor initializes the object with the content of an existing PDF page. New content can be added on top of it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFImportedContent,ContentMirroring)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFImportedContent,ContentMirroring)

importedContent
The imported content extracted from an existing page.
contentMirroring
The mirroring mode to be used when drawing the imported content.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object with the given content and a mirroring mode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal importedContent As PDFImportedContent, _
   ByVal contentMirroring As ContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim importedContent As PDFImportedContent
Dim contentMirroring As ContentMirroring

Dim instance As PDFFormXObject(importedContent, contentMirroring)
C#
public PDFFormXObject(
   PDFImportedContent importedContent,
   ContentMirroring contentMirroring
)
Delphi
public PDFFormXObject(
    importedContent: PDFImportedContent;
    contentMirroring: ContentMirroring
);
Managed Extensions for C++
public: PDFFormXObject(
   PDFImportedContent* importedContent,
   ContentMirroring contentMirroring
)
C++/CLI
public:
PDFFormXObject(
   PDFImportedContent^ importedContent,
   ContentMirroring contentMirroring
)

Parameters

importedContent
The imported content extracted from an existing page.
contentMirroring
The mirroring mode to be used when drawing the imported content.

Exceptions

Exception | Description
ArgumentNullException | thrown when importedContent is null

Remarks

This constructor initializes the object with the content of an existing PDF page. New content can be added on top of it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(RectangleF,Single)

rect
a RectangleF object that defines the graphic block.
orientation
orientation of the graphic block.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying a bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFFormXObject(rect, orientation)
C#
public PDFFormXObject(
   RectangleF rect,
   float orientation
)
Delphi
public PDFFormXObject(
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFFormXObject(
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFFormXObject(
   RectangleF rect,
   float orientation
)

Parameters

rect
a RectangleF object that defines the graphic block.
orientation
orientation of the graphic block.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(Single,Single,Single,Single,Single)

left
the x-coordinate of the upper-left corner of the graphic block.
top
the y-coordinate of the upper-left corner of the graphic block.
width
width of the graphic block.
height
height of the graphic block.
orientation
orientation of the graphic block.
Initializes a new O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFFormXObject(left, top, width, height, orientation)
C#
public PDFFormXObject(
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public PDFFormXObject(
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFFormXObject(
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFFormXObject(
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

left
the x-coordinate of the upper-left corner of the graphic block.
top
the y-coordinate of the upper-left corner of the graphic block.
width
width of the graphic block.
height
height of the graphic block.
orientation
orientation of the graphic block.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFormXObject Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

For a list of all members of this type, see PDFFormXObject members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Canvas | Gets the canvas of this graphic object.
Public Property | ContentMirroring | Gets or sets the mirroring of the form XObject's content.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the graphic block.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Canvas Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Canvas Property

Gets the canvas of this graphic object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public PDFBasicCanvas Canvas {get;}
Delphi
public read-only property Canvas: PDFBasicCanvas;
Managed Extensions for C++
public: __property PDFBasicCanvas* get_Canvas();
C++/CLI
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Return Value

A PDFBasicCanvas object specifying the drawing surface of this graphic object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

ContentMirroring Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : ContentMirroring Property

Gets or sets the mirroring of the form XObject's content.

Syntax

Visual Basic (Declaration)
Public Property ContentMirroring As ContentMirroring
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As ContentMirroring

instance.ContentMirroring = value

value = instance.ContentMirroring
C#
public ContentMirroring ContentMirroring {get; set;}
Delphi
public read-write property ContentMirroring: ContentMirroring;
Managed Extensions for C++
public: __property ContentMirroring get_ContentMirroring();
public: __property void set_ContentMirroring(
   ContentMirroring value
);
C++/CLI
public:
property ContentMirroring ContentMirroring {
   ContentMirroring get();
   void set (ContentMirroring value);
}

Return Value

The mirroring of the form XObject's content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Orientation Property

Gets or sets the orientation of the graphic block.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value representing the rotation angle of the graphic block.

Remarks

The orientation of the graphic block is used to draw the block rotated, using the top left corner as rotation center. This value is specified in degrees and the angle is measured counterclockwise from the x axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

PDFHTMLText Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLText Class

Defines a line of text specified by a printing position and a string.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHTMLText
   Inherits PDFText
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLText
C#
public class PDFHTMLText : PDFText
Delphi
public class PDFHTMLText = class(PDFText)
Managed Extensions for C++
public __gc class PDFHTMLText : public PDFText
C++/CLI
public ref class PDFHTMLText : public PDFText

Remarks

The text supports formatting options specified as HTML tags.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFHTMLText Class Members
See Also Fields Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLText Class

The following tables list the members exposed by PDFHTMLText.

Public Constructors

 | Name | Description
Public Constructor | PDFHTMLText Constructor | Overloaded. Initializes a new PDFHTMLText object.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SuperSubScriptDivider | default divider for super/sub script
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | FontsCollection | Gets or sets the collection of external fonts used by the HTML formatted text.
Public Property | Orientation | Gets or sets the text orientation. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Top

See Also

Reference

PDFHTMLText Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFHTMLText Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLText Class : PDFHTMLText Constructor

Initializes a new PDFHTMLText object.

Overload List

Overload | Description
PDFHTMLText Constructor() | Initializes a new PDFHTMLText object.
PDFHTMLText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) | Initializes a new PDFHTMLText object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Class
PDFHTMLText Members


%%PageItemTitle%%

PDFHTMLText Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLText Class > PDFHTMLText Constructor : PDFHTMLText Constructor()

Initializes a new PDFHTMLText object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLText()
C#
public PDFHTMLText()
Delphi
public PDFHTMLText();
Managed Extensions for C++
public: PDFHTMLText();
C++/CLI
public:
PDFHTMLText();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Class
PDFHTMLText Members
Overload List


%%PageItemTitle%%

PDFHTMLText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLText Class > PDFHTMLText Constructor : PDFHTMLText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign)

text
the text to be drawn.
font
a PDFFont object used to draw the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
the alignment of the text.
Initializes a new PDFHTMLText object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single
Dim align As TextAlign

Dim instance As PDFHTMLText(text, font, pen, brush, x, y, orientation, align)
C#
public PDFHTMLText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
Delphi
public PDFHTMLText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single;
    align: TextAlign
);
Managed Extensions for C++
public: PDFHTMLText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
C++/CLI
public:
PDFHTMLText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)

Parameters

text
the text to be drawn.
font
a PDFFont object used to draw the text.
pen
a PDFPen object used to draw the border of the text.
brush
a PDFBrush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
the alignment of the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Class
PDFHTMLText Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFHTMLText Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLText Class

For a list of all members of this type, see PDFHTMLText members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | FontsCollection | Gets or sets the collection of external fonts used by the HTML formatted text.
Public Property | Orientation | Gets or sets the text orientation. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Top

See Also

Reference

PDFHTMLText Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FontsCollection Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLText Class : FontsCollection Property

Gets or sets the collection of external fonts used by the HTML formatted text.

Syntax

Visual Basic (Declaration)
Public Property FontsCollection As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLText
Dim value As Hashtable

instance.FontsCollection = value

value = instance.FontsCollection
C#
public Hashtable FontsCollection {get; set;}
Delphi
public read-write property FontsCollection: Hashtable;
Managed Extensions for C++
public: __property Hashtable* get_FontsCollection();
public: __property void set_FontsCollection(
   Hashtable* value
);
C++/CLI
public:
property Hashtable^ FontsCollection {
   Hashtable^ get();
   void set (Hashtable^ value);
}

Return Value

A Hashtable collection of objects, the key is the name of the font and the object is a font object (TrueTypeFont, PostScriptFont or CJK font object).

Remarks

All the external fonts used with the HTML formatted text must be added to this collection. The value of "face" attribute of font tag is the key in this collection. The key is case sensitive.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Class
PDFHTMLText Members


%%PageItemTitle%% $$Fields$$

PDFHTMLText Class Fields
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLText Class

For a list of all members of this type, see PDFHTMLText members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SuperSubScriptDivider | default divider for super/sub script
Top

See Also

Reference

PDFHTMLText Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

SuperSubScriptDivider Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLText Class : SuperSubScriptDivider Field

default divider for super/sub script

Syntax

Visual Basic (Declaration)
Public Shared SuperSubScriptDivider As Single
Visual Basic (Usage) Copy Code
Dim value As Single

value = PDFHTMLText.SuperSubScriptDivider

PDFHTMLText.SuperSubScriptDivider = value
C#
public static float SuperSubScriptDivider
Delphi
public field SuperSubScriptDivider: Single; static;
Managed Extensions for C++
public: static float SuperSubScriptDivider
C++/CLI
public:
static float SuperSubScriptDivider

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLText Class
PDFHTMLText Members


%%PageItemTitle%%

PDFHTMLTextBox Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLTextBox Class

Defines a wrapped text specified by its bounding rectangle.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHTMLTextBox
   Inherits PDFTextBox
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
C#
public class PDFHTMLTextBox : PDFTextBox
Delphi
public class PDFHTMLTextBox = class(PDFTextBox)
Managed Extensions for C++
public __gc class PDFHTMLTextBox : public PDFTextBox
C++/CLI
public ref class PDFHTMLTextBox : public PDFTextBox

Remarks

This class is used to draw columnar text, by restricting the text to a specified rectangle. The text supports HTML formatting.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLTextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFHTMLTextBox Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLTextBox Class

The following tables list the members exposed by PDFHTMLTextBox.

Public Constructors

 | Name | Description
Public Constructor | PDFHTMLTextBox Constructor | Overloaded. Initializes a new PDFHTMLTextBox object.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the textbox. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipText | Gets or sets the clipping for the text Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | FontsCollection | Gets or sets the collection of external fonts used by the HTML formatted text.
Public Property | Height | Gets or sets the height of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | LastLineWidth | Gets the width of the last line of text.
Public Property | Left | Gets or sets the x coordinate of the top left corner Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RequiredHeight | Gets the real height of the wrapped text.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | StartDisplayFrom | Gets or sets the index within the text where the text to be displayed starts.
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | TextFormatOptions | Gets or sets the text formatting options for the text box Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Top | Gets or sets the y coordinate of the top left corner. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Width | Gets or sets the width of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Top

See Also

Reference

PDFHTMLTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFHTMLTextBox Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : PDFHTMLTextBox Constructor

Initializes a new PDFHTMLTextBox object.

Overload List

Overload | Description
PDFHTMLTextBox Constructor() | Initializes a new PDFHTMLTextBox object.
PDFHTMLTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32) | Initializes a new PDFHTMLTextBox object specified by a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

PDFHTMLTextBox Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > PDFHTMLTextBox Constructor : PDFHTMLTextBox Constructor()

Initializes a new PDFHTMLTextBox object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox()
C#
public PDFHTMLTextBox()
Delphi
public PDFHTMLTextBox();
Managed Extensions for C++
public: PDFHTMLTextBox();
C++/CLI
public:
PDFHTMLTextBox();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%%

PDFHTMLTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > PDFHTMLTextBox Constructor : PDFHTMLTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions,Int32)

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Initializes a new PDFHTMLTextBox object specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

Dim instance As PDFHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
C#
public PDFHTMLTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
Delphi
public PDFHTMLTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions;
    startDisplayFrom: Integer
);
Managed Extensions for C++
public: PDFHTMLTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
C++/CLI
public:
PDFHTMLTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.

Remarks

The text supports HTML formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFHTMLTextBox Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLTextBox Class

For a list of all members of this type, see PDFHTMLTextBox members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Top

See Also

Reference

PDFHTMLTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FitText Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : FitText Method

Calculates how much of the given text fits in the given area.

Overload List

Overload | Description
FitText(String,PDFFont,Single,Single,Single,Int32,Boolean,Hashtable) | Calculates how much of the given text fits in the given area.
FitText(String,PDFFont,Single,Single,Single,Int32,Boolean) | Calculates how much of the given text fits in the given area.
FitText(String,PDFFont,Single,Single,Single,Int32) | Calculates how much of the given text fits in the given area.
FitText() | Calculates how much of the text really fits in the box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Int32,Boolean,Hashtable) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Int32,Boolean,Hashtable) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
breakLongWords
A boolean value specifying that long words breaking should be considered when measing text to fit in the box.
externalFonts
A hashtable that contains all external fonts used in the HTML formatted text.
Calculates how much of the given text fits in the given area.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal startDisplayFrom As Integer, _
   ByVal breakLongWords As Boolean, _
   ByVal externalFonts As Hashtable _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim startDisplayFrom As Integer
Dim breakLongWords As Boolean
Dim externalFonts As Hashtable
Dim value As Integer

value = PDFHTMLTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, startDisplayFrom, breakLongWords, externalFonts)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords,
   Hashtable externalFonts
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    startDisplayFrom: Integer;
    breakLongWords: Boolean;
    externalFonts: Hashtable
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords,
   Hashtable* externalFonts
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords,
   Hashtable^ externalFonts
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
breakLongWords
A boolean value specifying that long words breaking should be considered when measing text to fit in the box.
externalFonts
A hashtable that contains all external fonts used in the HTML formatted text.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment. The alignment of the text is always considered Top on the vertical.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Int32,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Int32,Boolean) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
breakLongWords
A boolean value specifying that long words breaking should be considered when measing text to fit in the box.
Calculates how much of the given text fits in the given area.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal startDisplayFrom As Integer, _
   ByVal breakLongWords As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim startDisplayFrom As Integer
Dim breakLongWords As Boolean
Dim value As Integer

value = PDFHTMLTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, startDisplayFrom, breakLongWords)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    startDisplayFrom: Integer;
    breakLongWords: Boolean
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom,
   bool breakLongWords
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
breakLongWords
A boolean value specifying that long words breaking should be considered when measing text to fit in the box.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment. The alignment of the text is always considered Top on the vertical.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Int32) Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Int32) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Calculates how much of the given text fits in the given area.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal startDisplayFrom As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim startDisplayFrom As Integer
Dim value As Integer

value = PDFHTMLTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, startDisplayFrom)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    startDisplayFrom: Integer
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   int startDisplayFrom
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment. The alignment of the text is always considered Top on the vertical.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%%

FitText() Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class > FitText Method : FitText() Method

Calculates how much of the text really fits in the box.

Syntax

Visual Basic (Declaration)
Overloads Public Function FitText() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
Dim value As Integer

value = instance.FitText()
C#
public int FitText()
Delphi
public function FitText(): Integer;
Managed Extensions for C++
public: int FitText();
C++/CLI
public:
int FitText();

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are considered always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFHTMLTextBox Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFHTMLTextBox Class

For a list of all members of this type, see PDFHTMLTextBox members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the textbox. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipText | Gets or sets the clipping for the text Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | FontsCollection | Gets or sets the collection of external fonts used by the HTML formatted text.
Public Property | Height | Gets or sets the height of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | LastLineWidth | Gets the width of the last line of text.
Public Property | Left | Gets or sets the x coordinate of the top left corner Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RequiredHeight | Gets the real height of the wrapped text.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | StartDisplayFrom | Gets or sets the index within the text where the text to be displayed starts.
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | TextFormatOptions | Gets or sets the text formatting options for the text box Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Top | Gets or sets the y coordinate of the top left corner. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | Width | Gets or sets the width of the text box. Supported by Compact .NET Edition. (Inherited from PDFTextBox)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition. (Inherited from PDFText)
Top

See Also

Reference

PDFHTMLTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FontsCollection Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : FontsCollection Property

Gets or sets the collection of external fonts used by the HTML formatted text.

Syntax

Visual Basic (Declaration)
Public Property FontsCollection As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
Dim value As Hashtable

instance.FontsCollection = value

value = instance.FontsCollection
C#
public Hashtable FontsCollection {get; set;}
Delphi
public read-write property FontsCollection: Hashtable;
Managed Extensions for C++
public: __property Hashtable* get_FontsCollection();
public: __property void set_FontsCollection(
   Hashtable* value
);
C++/CLI
public:
property Hashtable^ FontsCollection {
   Hashtable^ get();
   void set (Hashtable^ value);
}

Return Value

A Hashtable collection of objects, the key is the name of the font and the object is a font object (TrueTypeFont, PostScriptFont or CJK font object).

Remarks

All the external fonts used with the HTML formatted text must be added to this collection. The value of "face" attribute of font tag is the key in this collection. The key is case sensitive.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

LastLineWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : LastLineWidth Property

Gets the width of the last line of text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastLineWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
Dim value As Single

value = instance.LastLineWidth
C#
public float LastLineWidth {get;}
Delphi
public read-only property LastLineWidth: Single;
Managed Extensions for C++
public: __property float get_LastLineWidth();
C++/CLI
public:
property float LastLineWidth {
   float get();
}

Return Value

a float value specifying the width of the last line of text in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

RequiredHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : RequiredHeight Property

Gets the real height of the wrapped text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RequiredHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
Dim value As Single

value = instance.RequiredHeight
C#
public float RequiredHeight {get;}
Delphi
public read-only property RequiredHeight: Single;
Managed Extensions for C++
public: __property float get_RequiredHeight();
C++/CLI
public:
property float RequiredHeight {
   float get();
}

Return Value

a float value specifying the necessary height of the text box in order to display the whole text.

Remarks

The calculation of the required height is based on current font and line spacing. If the text box is not attached to the canvas, then its width and height are considered to be points. If the text box is attached to the canvas, then its width and height are considered to be given in canvas' logical units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

StartDisplayFrom Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFHTMLTextBox Class : StartDisplayFrom Property

Gets or sets the index within the text where the text to be displayed starts.

Syntax

Visual Basic (Declaration)
Public Property StartDisplayFrom As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFHTMLTextBox
Dim value As Integer

instance.StartDisplayFrom = value

value = instance.StartDisplayFrom
C#
public int StartDisplayFrom {get; set;}
Delphi
public read-write property StartDisplayFrom: Integer;
Managed Extensions for C++
public: __property int get_StartDisplayFrom();
public: __property void set_StartDisplayFrom(
   int value
);
C++/CLI
public:
property int StartDisplayFrom {
   int get();
   void set (int value);
}

Return Value

An integer value representing the index within the text where the text to be displayed starts.

Remarks

This value is used when displaying HTML text across multiple text boxes. The HTML text must be split in multiple fragments, one for each text box. Because a separate fragment might not be well formed, it must be considered in the context of the whole text. This index specifies the start position of the fragment within the whole text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHTMLTextBox Class
PDFHTMLTextBox Members


%%PageItemTitle%%

PDFImage Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

Defines an image specified by a pair of coordinates, a width, and a height.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFImage
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
C#
public sealed class PDFImage : PDFRectangularObject
Delphi
public class PDFImage = class(PDFRectangularObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFImage : public PDFRectangularObject
C++/CLI
public ref class PDFImage sealed : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFImage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

The following tables list the members exposed by PDFImage.

Public Constructors

 | Name | Description
Public Constructor | PDFImage Constructor | Overloaded. Initializes a new PDFImage object.
Top

Public Properties

 | Name | Description
Public Property | ActiveFrame | Gets or sets the index of the frame to be drawn on the page.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Compression | Gets or sets the compression method for image data
Public Property | FileName | Gets or sets the name of the image file. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | ImageQuality | Gets or sets the image quality.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | InvertedCMYK | Gets or sets whether the CMYK image is inverted(negative) or not. Supported by Compact .NET Edition.
Public Property | KeepAspectRatio | Gets or sets the mode the images is resized when it is drawn on the page. Supported by Compact .NET Edition.
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Orientation | Gets or sets the orientation of the image. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RealHeight | Gets the real height of the image when one of the KeepAspectRatio modes is used for are used. Supported by Compact .NET Edition.
Public Property | RealWidth | Gets the real width of the image when one of the KeepAspectRatio modes is used. Supported by Compact .NET Edition.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | UseEmbeddedAlphaChannel | Gets or sets whether to enable transparency on this image based on the alpha channel available in the image data.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFImage Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : PDFImage Constructor

Initializes a new PDFImage object.

Overload List

Overload | Description
PDFImage Constructor() | Initializes a new PDFImage object.
PDFImage Constructor(Image) | Initializes a new PDFImage object from a Image.
PDFImage Constructor(Image,RectangleF,Single) | Initializes a new PDFImage object from a Image specifying a pair of coordinates, a width and a height.
PDFImage Constructor(Image,Single,Single,Single,Single,Single) | Initializes a new PDFImage object from a Image specifying a pair of coordinates, a width and a height.
PDFImage Constructor(Stream) | Initializes a new PDFImage object specifying a stream.
PDFImage Constructor(Stream,RectangleF,Single) | Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.
PDFImage Constructor(Stream,Single,Single,Single,Single,Single) | Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.
PDFImage Constructor(String) | Initializes a new PDFImage object specifying a file name.
PDFImage Constructor(String,RectangleF,Single) | Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.
PDFImage Constructor(String,Single,Single,Single,Single,Single) | Initializes a new PDFImage object specifying a pair of coordinates, a width and a height. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

PDFImage Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor()

Initializes a new PDFImage object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFImage()
C#
public PDFImage()
Delphi
public PDFImage();
Managed Extensions for C++
public: PDFImage();
C++/CLI
public:
PDFImage();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Image)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Image)

image
a Image object where to copy the image from.
Initializes a new PDFImage object from a Image.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Image _
)
Visual Basic (Usage) Copy Code
Dim image As Image

Dim instance As PDFImage(image)
C#
public PDFImage(
   Image image
)
Delphi
public PDFImage(
    image: Image
);
Managed Extensions for C++
public: PDFImage(
   Image image
)
C++/CLI
public:
PDFImage(
   Image image
)

Parameters

image
a Image object where to copy the image from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Image,RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Image,RectangleF,Single)

image
a Image object where to copy the image from.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.
Initializes a new PDFImage object from a Image specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Image, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim image As Image
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFImage(image, rect, orientation)
C#
public PDFImage(
   Image image,
   RectangleF rect,
   float orientation
)
Delphi
public PDFImage(
    image: Image;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   Image image,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFImage(
   Image image,
   RectangleF rect,
   float orientation
)

Parameters

image
a Image object where to copy the image from.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Image,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Image,Single,Single,Single,Single,Single)

image
a Image object where to copy the image from.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.
Initializes a new PDFImage object from a Image specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim image As Image
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFImage(image, left, top, width, height, orientation)
C#
public PDFImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public PDFImage(
    image: Image;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

image
a Image object where to copy the image from.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream)

stream
a Stream descendant object where to load the image from.
Initializes a new PDFImage object specifying a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFImage(stream)
C#
public PDFImage(
   Stream stream
)
Delphi
public PDFImage(
    stream: Stream
);
Managed Extensions for C++
public: PDFImage(
   Stream* stream
)
C++/CLI
public:
PDFImage(
   Stream^ stream
)

Parameters

stream
a Stream descendant object where to load the image from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream,RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,RectangleF,Single)

stream
a Stream descendant object where to load the image from.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.
Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFImage(stream, rect, orientation)
C#
public PDFImage(
   Stream stream,
   RectangleF rect,
   float orientation
)
Delphi
public PDFImage(
    stream: Stream;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   Stream* stream,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFImage(
   Stream^ stream,
   RectangleF rect,
   float orientation
)

Parameters

stream
a Stream descendant object where to load the image from.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,Single,Single,Single,Single,Single)

stream
a Stream descendant object where to load the image from.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.
Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFImage(stream, left, top, width, height, orientation)
C#
public PDFImage(
   Stream stream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public PDFImage(
    stream: Stream;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   Stream* stream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFImage(
   Stream^ stream,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

stream
a Stream descendant object where to load the image from.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String)

fileName
a string value representing a path to the image file.
Initializes a new PDFImage object specifying a file name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFImage(fileName)
C#
public PDFImage(
   string fileName
)
Delphi
public PDFImage(
    fileName: String
);
Managed Extensions for C++
public: PDFImage(
   string* fileName
)
C++/CLI
public:
PDFImage(
   String^ fileName
)

Parameters

fileName
a string value representing a path to the image file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(String,RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,RectangleF,Single)

fileName
a string value representing a path to the image file.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.
Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFImage(fileName, rect, orientation)
C#
public PDFImage(
   string fileName,
   RectangleF rect,
   float orientation
)
Delphi
public PDFImage(
    fileName: String;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   string* fileName,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFImage(
   String^ fileName,
   RectangleF rect,
   float orientation
)

Parameters

fileName
a string value representing a path to the image file.
rect
a RectangleF object that defines the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(String,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,Single,Single,Single,Single,Single)

fileName
a string value representing a path to the image file.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.
Initializes a new PDFImage object specifying a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFImage(fileName, left, top, width, height, orientation)
C#
public PDFImage(
   string fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
Delphi
public PDFImage(
    fileName: String;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFImage(
   string* fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFImage(
   String^ fileName,
   float left,
   float top,
   float width,
   float height,
   float orientation
)

Parameters

fileName
a string value representing a path to the image file.
left
the x-coordinate of the upper-left corner of the image.
top
the y-coordinate of the upper-left corner of the image.
width
width of the image.
height
height of the image.
orientation
orientation of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFImage Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

For a list of all members of this type, see PDFImage members.

Public Properties

 | Name | Description
Public Property | ActiveFrame | Gets or sets the index of the frame to be drawn on the page.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Compression | Gets or sets the compression method for image data
Public Property | FileName | Gets or sets the name of the image file. Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | ImageQuality | Gets or sets the image quality.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | InvertedCMYK | Gets or sets whether the CMYK image is inverted(negative) or not. Supported by Compact .NET Edition.
Public Property | KeepAspectRatio | Gets or sets the mode the images is resized when it is drawn on the page. Supported by Compact .NET Edition.
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Orientation | Gets or sets the orientation of the image. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RealHeight | Gets the real height of the image when one of the KeepAspectRatio modes is used for are used. Supported by Compact .NET Edition.
Public Property | RealWidth | Gets the real width of the image when one of the KeepAspectRatio modes is used. Supported by Compact .NET Edition.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | UseEmbeddedAlphaChannel | Gets or sets whether to enable transparency on this image based on the alpha channel available in the image data.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

ActiveFrame Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : ActiveFrame Property

Gets or sets the index of the frame to be drawn on the page.

Syntax

Visual Basic (Declaration)
Public Property ActiveFrame As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Integer

instance.ActiveFrame = value

value = instance.ActiveFrame
C#
public int ActiveFrame {get; set;}
Delphi
public read-write property ActiveFrame: Integer;
Managed Extensions for C++
public: __property int get_ActiveFrame();
public: __property void set_ActiveFrame(
   int value
);
C++/CLI
public:
property int ActiveFrame {
   int get();
   void set (int value);
}

Return Value

An int value specifying the the index of the frame to be drawn on the page.

Remarks

This property specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property.

This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : ColorSpace Property

Gets or sets the image colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get; set;}
Delphi
public read-write property ColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The colorspace of the image.

Exceptions

Exception | Description
ArgumentException | Thrown when the provided colorspace is not a device colorspace.

Remarks

If this property is null (Nothing in VB.NET) then the image's colorspace is considered to be the colorspace defined on the document. Only device colorspaces are supproted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

Compression Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Compression Property

Gets or sets the compression method for image data

Syntax

Visual Basic (Declaration)
Public Property Compression As ImageCompression
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As ImageCompression

instance.Compression = value

value = instance.Compression
C#
public ImageCompression Compression {get; set;}
Delphi
public read-write property Compression: ImageCompression;
Managed Extensions for C++
public: __property ImageCompression get_Compression();
public: __property void set_Compression(
   ImageCompression value
);
C++/CLI
public:
property ImageCompression Compression {
   ImageCompression get();
   void set (ImageCompression value);
}

Return Value

An ImageCompression enumeration member specifying how the image data should be stored in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

FileName Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : FileName Property

Gets or sets the name of the image file.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Delphi
public read-write property FileName: String;
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a full path to the image file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

ImageQuality Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : ImageQuality Property

Gets or sets the image quality.

Syntax

Visual Basic (Declaration)
Public Property ImageQuality As Long
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Long

instance.ImageQuality = value

value = instance.ImageQuality
C#
public long ImageQuality {get; set;}
Delphi
public read-write property ImageQuality: Int64;
Managed Extensions for C++
public: __property long get_ImageQuality();
public: __property void set_ImageQuality(
   long value
);
C++/CLI
public:
property long ImageQuality {
   long get();
   void set (long value);
}

Return Value

A long value specifying the quality for the image.

Remarks

This property specifies the level of jpeg compression to be applied on the image when it is saved to pdf file. A higher value means higher quality but lower compression, a lower value means low quality by higher compression. The possible values for this property vary from 1 to 100.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

Interpolate Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Interpolate Property

Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.

Syntax

Visual Basic (Declaration)
Public Property Interpolate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Boolean

instance.Interpolate = value

value = instance.Interpolate
C#
public bool Interpolate {get; set;}
Delphi
public read-write property Interpolate: Boolean;
Managed Extensions for C++
public: __property bool get_Interpolate();
public: __property void set_Interpolate(
   bool value
);
C++/CLI
public:
property bool Interpolate {
   bool get();
   void set (bool value);
}

Return Value

True if the image should be interpolated when the PDF viewer zooms in, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

InvertedCMYK Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : InvertedCMYK Property

Gets or sets whether the CMYK image is inverted(negative) or not.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property InvertedCMYK As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Boolean

instance.InvertedCMYK = value

value = instance.InvertedCMYK
C#
public bool InvertedCMYK {get; set;}
Delphi
public read-write property InvertedCMYK: Boolean;
Managed Extensions for C++
public: __property bool get_InvertedCMYK();
public: __property void set_InvertedCMYK(
   bool value
);
C++/CLI
public:
property bool InvertedCMYK {
   bool get();
   void set (bool value);
}

Return Value

a float value representing whether the CMYK image is inverted(negative) or not.

Remarks

Some graphic design applications save the CMYK images in inverted (negative) mode. One of these applications is Adobe Photoshop. Because there is no way to detect this, this flag if set correctly, allows the library to set up the correct decoding. The default value of this property is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

KeepAspectRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : KeepAspectRatio Property

Gets or sets the mode the images is resized when it is drawn on the page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property KeepAspectRatio As KeepAspectRatio
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As KeepAspectRatio

instance.KeepAspectRatio = value

value = instance.KeepAspectRatio
C#
public KeepAspectRatio KeepAspectRatio {get; set;}
Delphi
public read-write property KeepAspectRatio: KeepAspectRatio;
Managed Extensions for C++
public: __property KeepAspectRatio get_KeepAspectRatio();
public: __property void set_KeepAspectRatio(
   KeepAspectRatio value
);
C++/CLI
public:
property KeepAspectRatio KeepAspectRatio {
   KeepAspectRatio get();
   void set (KeepAspectRatio value);
}

Return Value

A KeepAspectRatio enumeration member specifying how the image is resized when it is drawn on the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

Mask Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Mask Property

Gets or sets the mask for this image.

Syntax

Visual Basic (Declaration)
Public Property Mask As PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As PDFBaseImageMask

instance.Mask = value

value = instance.Mask
C#
public PDFBaseImageMask Mask {get; set;}
Delphi
public read-write property Mask: PDFBaseImageMask;
Managed Extensions for C++
public: __property PDFBaseImageMask* get_Mask();
public: __property void set_Mask(
   PDFBaseImageMask* value
);
C++/CLI
public:
property PDFBaseImageMask^ Mask {
   PDFBaseImageMask^ get();
   void set (PDFBaseImageMask^ value);
}

Return Value

A PDFBaseImageMask descendant specifying the mask for this image.

Remarks

The mask allows to define areas of an image to be treated as transparent when the image is painted on the page. Note: An image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Orientation Property

Gets or sets the orientation of the image.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value representing the rotation angle of the image.

Remarks

The orientation of the image is used to draw the image rotated, using the top left corner as rotation center. This value is specified in degrees and the angle is measured counterclockwise from the x axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

RealHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : RealHeight Property

Gets the real height of the image when one of the KeepAspectRatio modes is used for are used.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RealHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Single

value = instance.RealHeight
C#
public float RealHeight {get;}
Delphi
public read-only property RealHeight: Single;
Managed Extensions for C++
public: __property float get_RealHeight();
C++/CLI
public:
property float RealHeight {
   float get();
}

Return Value

A float value specifying the calculated height of the image based on its width.

Remarks

When KeepWidth is used for keeping the aspect ratio, the height of the image is automatically calculated based on original image aspect ratio and its given width. When KeepBoth is used, the image is fitted to the given rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

RealWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : RealWidth Property

Gets the real width of the image when one of the KeepAspectRatio modes is used.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RealWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Single

value = instance.RealWidth
C#
public float RealWidth {get;}
Delphi
public read-only property RealWidth: Single;
Managed Extensions for C++
public: __property float get_RealWidth();
C++/CLI
public:
property float RealWidth {
   float get();
}

Return Value

A float value specifying the calculated width of the image based on its height.

Remarks

When KeepHeight is used for keeping the aspect ratio, the width of the image is automatically calculated based on original image aspect ratio and its given height. When KeepBoth is used, the image is fitted to the given rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

UseEmbeddedAlphaChannel Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : UseEmbeddedAlphaChannel Property

Gets or sets whether to enable transparency on this image based on the alpha channel available in the image data.

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedAlphaChannel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Boolean

instance.UseEmbeddedAlphaChannel = value

value = instance.UseEmbeddedAlphaChannel
C#
public bool UseEmbeddedAlphaChannel {get; set;}
Delphi
public read-write property UseEmbeddedAlphaChannel: Boolean;
Managed Extensions for C++
public: __property bool get_UseEmbeddedAlphaChannel();
public: __property void set_UseEmbeddedAlphaChannel(
   bool value
);
C++/CLI
public:
property bool UseEmbeddedAlphaChannel {
   bool get();
   void set (bool value);
}

Return Value

True if transparency should be enabled on this image based on the alpha channel available in the image.

Remarks

This property is ignored for images that do not include alpha channel or a mask is attached to this image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

PDFLine Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLine Class

Defines a line specified by a pair of coordinates.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFLine
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFLine
C#
public sealed class PDFLine : PDFGraphic
Delphi
public class PDFLine = class(PDFGraphic)sealed;
Managed Extensions for C++
public __gc __sealed class PDFLine : public PDFGraphic
C++/CLI
public ref class PDFLine sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFLine

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFLine Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLine Class

The following tables list the members exposed by PDFLine.

Public Constructors

 | Name | Description
Public Constructor | PDFLine Constructor | Overloaded. Initializes a new PDFLine object using the specified pen and a pair of coordinates. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | X1 | Gets or sets the x coordinate of the beginning of the line. Supported by Compact .NET Edition.
Public Property | X2 | Gets or sets the x coordinate of the end of the line. Supported by Compact .NET Edition.
Public Property | Y1 | Gets or sets the y coordinate of the beginning of the line. Supported by Compact .NET Edition.
Public Property | Y2 | Gets or sets the y coordinate of the end of the line. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFLine Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFLine Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class : PDFLine Constructor

Initializes a new PDFLine object using the specified pen and a pair of coordinates.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFLine Constructor() | Initializes a new PDFLine object.
PDFLine Constructor(PDFPen,PDFPoint,PDFPoint) | Initializes a new PDFLine object using the specified pen and two points.
PDFLine Constructor(PDFPen,PointF,PointF) | Initializes a new PDFLine object using the specified pen and two points.
PDFLine Constructor(PDFPen,Single,Single,Single,Single) | Initializes a new PDFLine object using the specified pen and a pair of coordinates. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members


%%PageItemTitle%%

PDFLine Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class > PDFLine Constructor : PDFLine Constructor()

Initializes a new PDFLine object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLine()
C#
public PDFLine()
Delphi
public PDFLine();
Managed Extensions for C++
public: PDFLine();
C++/CLI
public:
PDFLine();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members
Overload List


%%PageItemTitle%%

PDFLine Constructor(PDFPen,PDFPoint,PDFPoint)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class > PDFLine Constructor : PDFLine Constructor(PDFPen,PDFPoint,PDFPoint)

pen
a PDFPen object used to draw the line
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.
Initializes a new PDFLine object using the specified pen and two points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint

Dim instance As PDFLine(pen, pt1, pt2)
C#
public PDFLine(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2
)
Delphi
public PDFLine(
    pen: PDFPen;
    pt1: PDFPoint;
    pt2: PDFPoint
);
Managed Extensions for C++
public: PDFLine(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2
)
C++/CLI
public:
PDFLine(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2
)

Parameters

pen
a PDFPen object used to draw the line
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members
Overload List


%%PageItemTitle%%

PDFLine Constructor(PDFPen,PointF,PointF)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class > PDFLine Constructor : PDFLine Constructor(PDFPen,PointF,PointF)

pen
a PDFPen object used to draw the line
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.
Initializes a new PDFLine object using the specified pen and two points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF

Dim instance As PDFLine(pen, pt1, pt2)
C#
public PDFLine(
   PDFPen pen,
   PointF pt1,
   PointF pt2
)
Delphi
public PDFLine(
    pen: PDFPen;
    pt1: PointF;
    pt2: PointF
);
Managed Extensions for C++
public: PDFLine(
   PDFPen* pen,
   PointF pt1,
   PointF pt2
)
C++/CLI
public:
PDFLine(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2
)

Parameters

pen
a PDFPen object used to draw the line
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members
Overload List


%%PageItemTitle%%

PDFLine Constructor(PDFPen,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class > PDFLine Constructor : PDFLine Constructor(PDFPen,Single,Single,Single,Single)

pen
a PDFPen object used to draw the line
x1
x-coordinate of the beginning of the line.
y1
y-coordinate of the beginning of the line.
x2
x-coordinate of the end of the line.
y2
y-coordinate of the end of the line.
Initializes a new PDFLine object using the specified pen and a pair of coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim x1 As Single
Dim y1 As Single
Dim x2 As Single
Dim y2 As Single

Dim instance As PDFLine(pen, x1, y1, x2, y2)
C#
public PDFLine(
   PDFPen pen,
   float x1,
   float y1,
   float x2,
   float y2
)
Delphi
public PDFLine(
    pen: PDFPen;
    x1: Single;
    y1: Single;
    x2: Single;
    y2: Single
);
Managed Extensions for C++
public: PDFLine(
   PDFPen* pen,
   float x1,
   float y1,
   float x2,
   float y2
)
C++/CLI
public:
PDFLine(
   PDFPen^ pen,
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

pen
a PDFPen object used to draw the line
x1
x-coordinate of the beginning of the line.
y1
y-coordinate of the beginning of the line.
x2
x-coordinate of the end of the line.
y2
y-coordinate of the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFLine Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLine Class

For a list of all members of this type, see PDFLine members.

Public Properties

 | Name | Description
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | X1 | Gets or sets the x coordinate of the beginning of the line. Supported by Compact .NET Edition.
Public Property | X2 | Gets or sets the x coordinate of the end of the line. Supported by Compact .NET Edition.
Public Property | Y1 | Gets or sets the y coordinate of the beginning of the line. Supported by Compact .NET Edition.
Public Property | Y2 | Gets or sets the y coordinate of the end of the line. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFLine Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

X1 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class : X1 Property

Gets or sets the x coordinate of the beginning of the line.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X1 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLine
Dim value As Single

instance.X1 = value

value = instance.X1
C#
public float X1 {get; set;}
Delphi
public read-write property X1: Single;
Managed Extensions for C++
public: __property float get_X1();
public: __property void set_X1(
   float value
);
C++/CLI
public:
property float X1 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the beginning of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members


%%PageItemTitle%%

X2 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class : X2 Property

Gets or sets the x coordinate of the end of the line.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X2 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLine
Dim value As Single

instance.X2 = value

value = instance.X2
C#
public float X2 {get; set;}
Delphi
public read-write property X2: Single;
Managed Extensions for C++
public: __property float get_X2();
public: __property void set_X2(
   float value
);
C++/CLI
public:
property float X2 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members


%%PageItemTitle%%

Y1 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class : Y1 Property

Gets or sets the y coordinate of the beginning of the line.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y1 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLine
Dim value As Single

instance.Y1 = value

value = instance.Y1
C#
public float Y1 {get; set;}
Delphi
public read-write property Y1: Single;
Managed Extensions for C++
public: __property float get_Y1();
public: __property void set_Y1(
   float value
);
C++/CLI
public:
property float Y1 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the beginning of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members


%%PageItemTitle%%

Y2 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLine Class : Y2 Property

Gets or sets the y coordinate of the end of the line.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y2 As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFLine
Dim value As Single

instance.Y2 = value

value = instance.Y2
C#
public float Y2 {get; set;}
Delphi
public read-write property Y2: Single;
Managed Extensions for C++
public: __property float get_Y2();
public: __property void set_Y2(
   float value
);
C++/CLI
public:
property float Y2 {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLine Class
PDFLine Members


%%PageItemTitle%%

PDFLines Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLines Class

Defines a series of lines specified by an array of points.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFLines
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFLines
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFLines : PDFGraphic
Delphi
public class PDFLines = class(PDFGraphic)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFLines : public PDFGraphic
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFLines sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFLines

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFLines Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLines Class

The following tables list the members exposed by PDFLines.

Public Constructors

 | Name | Description
Public Constructor | PDFLines Constructor | Overloaded. Initiaizes a new PDFLines object.
Top

Public Properties

 | Name | Description
Public Property | Item | Provides indexed access to the points array representing the lines segments. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFLines Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFLines Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLines Class : PDFLines Constructor

Initiaizes a new PDFLines object.

Overload List

Overload | Description
PDFLines Constructor() | Initiaizes a new PDFLines object.
PDFLines Constructor(PDFPen,PDFPoint[]) | Initializes a new PDFLines object using the specified pen and an array of points. Supported by Compact .NET Edition.
PDFLines Constructor(PDFPen,PointF[]) | Initializes a new PDFLines object using the specified pen and an array of points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Class
PDFLines Members


%%PageItemTitle%%

PDFLines Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLines Class > PDFLines Constructor : PDFLines Constructor()

Initiaizes a new PDFLines object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLines()
C#
public PDFLines()
Delphi
public PDFLines();
Managed Extensions for C++
public: PDFLines();
C++/CLI
public:
PDFLines();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Class
PDFLines Members
Overload List


%%PageItemTitle%%

PDFLines Constructor(PDFPen,PDFPoint[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLines Class > PDFLines Constructor : PDFLines Constructor(PDFPen,PDFPoint[])

pen
a PDFPen object used to draw the line
points
an array of PDFPoint structures specifying the coordinates of the lines
Initializes a new PDFLines object using the specified pen and an array of points.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim points() As PDFPoint

Dim instance As PDFLines(pen, points)
C#
public PDFLines(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public PDFLines(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: PDFLines(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
PDFLines(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the line
points
an array of PDFPoint structures specifying the coordinates of the lines

Remarks

The lines are specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Class
PDFLines Members
Overload List


%%PageItemTitle%%

PDFLines Constructor(PDFPen,PointF[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLines Class > PDFLines Constructor : PDFLines Constructor(PDFPen,PointF[])

pen
a PDFPen object used to draw the line
points
an array of PointF structures specifying the coordinates of the lines
Initializes a new PDFLines object using the specified pen and an array of points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim points() As PointF

Dim instance As PDFLines(pen, points)
C#
public PDFLines(
   PDFPen pen,
   PointF[] points
)
Delphi
public PDFLines(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: PDFLines(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
PDFLines(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the line
points
an array of PointF structures specifying the coordinates of the lines

Remarks

The lines are specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Class
PDFLines Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFLines Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLines Class

For a list of all members of this type, see PDFLines members.

Public Properties

 | Name | Description
Public Property | Item | Provides indexed access to the points array representing the lines segments. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFLines Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLines Class : Item Property

Index
Provides indexed access to the points array representing the lines segments.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal Index As Integer _
) As PointF
Visual Basic (Usage) Copy Code
Dim instance As PDFLines
Dim Index As Integer
Dim value As PointF

instance.Item(Index) = value

value = instance.Item(Index)
C#
public PointF this[
   int Index
]; {get; set;}
Delphi
public  this: : PointF;[
    Index: Integer
]; read-write
Managed Extensions for C++
public: __property PointF get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   PointF value
);
C++/CLI
public:
property PointF default [int] {
   PointF get(int Index);
   void set (int Index, PointF value);
}

Parameters

Index

Return Value

A PointF structure specifying the coordinates of the selected point. The value of this property is a PDFPoint object for Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLines Class
PDFLines Members


%%PageItemTitle%%

PDFLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLink Class

The base class for all the links within the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFLink
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFLink
C#
public abstract class PDFLink : PDFRectangularObject
Delphi
public class PDFLink = class(PDFRectangularObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFLink : public PDFRectangularObject
C++/CLI
public ref class PDFLink abstract : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLink Class

The following tables list the members exposed by PDFLink.

Public Constructors

 | Name | Description
Public Constructor | PDFLink Constructor | Overloaded. Initializes a new PDFLink object.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLink Class : PDFLink Constructor

Initializes a new PDFLink object.

Overload List

Overload | Description
PDFLink Constructor() | Initializes a new PDFLink object.
PDFLink Constructor(RectangleF,PDFPen) | Initializes a new PDFLink object specifying a RectangleF structure.
PDFLink Constructor(Single,Single,Single,Single,PDFPen) | Initializes a new PDFLink object specifying a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Class
PDFLink Members


%%PageItemTitle%%

PDFLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLink Class > PDFLink Constructor : PDFLink Constructor()

Initializes a new PDFLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLink()
C#
public PDFLink()
Delphi
public PDFLink();
Managed Extensions for C++
public: PDFLink();
C++/CLI
public:
PDFLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Class
PDFLink Members
Overload List


%%PageItemTitle%%

PDFLink Constructor(RectangleF,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLink Class > PDFLink Constructor : PDFLink Constructor(RectangleF,PDFPen)

rect
a RectangleF structure specifying the link area.
borderPen
a PDFPen object used to draw the border of the link.
Initializes a new PDFLink object specifying a RectangleF structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim rect As RectangleF
Dim borderPen As PDFPen

Dim instance As PDFLink(rect, borderPen)
C#
public PDFLink(
   RectangleF rect,
   PDFPen borderPen
)
Delphi
public PDFLink(
    rect: RectangleF;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFLink(
   RectangleF rect,
   PDFPen* borderPen
)
C++/CLI
public:
PDFLink(
   RectangleF rect,
   PDFPen^ borderPen
)

Parameters

rect
a RectangleF structure specifying the link area.
borderPen
a PDFPen object used to draw the border of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Class
PDFLink Members
Overload List


%%PageItemTitle%%

PDFLink Constructor(Single,Single,Single,Single,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLink Class > PDFLink Constructor : PDFLink Constructor(Single,Single,Single,Single,PDFPen)

left
x-coordinate of the upper-left corner of the link area.
top
y-coordinate of the upper-left corner of the link area.
width
width of the link area.
height
height of the link area.
borderPen
a PDFPen object used to draw the border of the link.
Initializes a new PDFLink object specifying a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim borderPen As PDFPen

Dim instance As PDFLink(left, top, width, height, borderPen)
C#
public PDFLink(
   float left,
   float top,
   float width,
   float height,
   PDFPen borderPen
)
Delphi
public PDFLink(
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFLink(
   float left,
   float top,
   float width,
   float height,
   PDFPen* borderPen
)
C++/CLI
public:
PDFLink(
   float left,
   float top,
   float width,
   float height,
   PDFPen^ borderPen
)

Parameters

left
x-coordinate of the upper-left corner of the link area.
top
y-coordinate of the upper-left corner of the link area.
width
width of the link area.
height
height of the link area.
borderPen
a PDFPen object used to draw the border of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Class
PDFLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFLink Class

For a list of all members of this type, see PDFLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

BorderPen Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFLink Class : BorderPen Property

Get or sets the pen used to draw the border of the link area.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property BorderPen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFLink
Dim value As PDFPen

instance.BorderPen = value

value = instance.BorderPen
C#
public PDFPen BorderPen {get; set;}
Delphi
public read-write property BorderPen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_BorderPen();
public: __property void set_BorderPen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ BorderPen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object specifying the pen used to draw the border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLink Class
PDFLink Members


%%PageItemTitle%%

PDFMetafile Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

Defines a Windows metafile object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMetafile
   Inherits PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFMetafile
C#
public class PDFMetafile : PDFFormXObject
Delphi
public class PDFMetafile = class(PDFFormXObject)
Managed Extensions for C++
public __gc class PDFMetafile : public PDFFormXObject
C++/CLI
public ref class PDFMetafile : public PDFFormXObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFMetafile Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

The following tables list the members exposed by PDFMetafile.

Public Constructors

 | Name | Description
Public Constructor | PDFMetafile Constructor | Overloaded. Initializes a new PDFMetafile object with the specified metafile file.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ContentMirroring | Gets or sets the mirroring of the form XObject's content. (Inherited from PDFFormXObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the graphic block. (Inherited from PDFFormXObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFMetafile Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class : PDFMetafile Constructor

Initializes a new PDFMetafile object with the specified metafile file.

Overload List

Overload | Description
PDFMetafile Constructor(PDFMetafile) | Initializes a new PDFMetafile object based on an existing metafile.
PDFMetafile Constructor(Stream) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(Stream,Boolean) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(String) | Initializes a new PDFMetafile object with the specified metafile file.
PDFMetafile Constructor(String,Boolean) | Initializes a new PDFMetafile object with the specified metafile file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members


%%PageItemTitle%%

PDFMetafile Constructor(PDFMetafile)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(PDFMetafile)

metafile
the original metafile
Initializes a new PDFMetafile object based on an existing metafile.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal metafile As PDFMetafile _
)
Visual Basic (Usage) Copy Code
Dim metafile As PDFMetafile

Dim instance As PDFMetafile(metafile)
C#
public PDFMetafile(
   PDFMetafile metafile
)
Delphi
public PDFMetafile(
    metafile: PDFMetafile
);
Managed Extensions for C++
public: PDFMetafile(
   PDFMetafile* metafile
)
C++/CLI
public:
PDFMetafile(
   PDFMetafile^ metafile
)

Parameters

metafile
the original metafile

Exceptions

Exception | Description
ArgumentNullException | thrown when metafile is null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream)

stream
the stream with metafile content.
Initializes a new PDFMetafile object with the specified metafile stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFMetafile(stream)
C#
public PDFMetafile(
   Stream stream
)
Delphi
public PDFMetafile(
    stream: Stream
);
Managed Extensions for C++
public: PDFMetafile(
   Stream* stream
)
C++/CLI
public:
PDFMetafile(
   Stream^ stream
)

Parameters

stream
the stream with metafile content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Stream,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream,Boolean)

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal useUnicodeFonts As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim useUnicodeFonts As Boolean

Dim instance As PDFMetafile(stream, useUnicodeFonts)
C#
public PDFMetafile(
   Stream stream,
   bool useUnicodeFonts
)
Delphi
public PDFMetafile(
    stream: Stream;
    useUnicodeFonts: Boolean
);
Managed Extensions for C++
public: PDFMetafile(
   Stream* stream,
   bool useUnicodeFonts
)
C++/CLI
public:
PDFMetafile(
   Stream^ stream,
   bool useUnicodeFonts
)

Parameters

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.

Remarks

When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String)

fileName
the full path to the metafile on disk.
Initializes a new PDFMetafile object with the specified metafile file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFMetafile(fileName)
C#
public PDFMetafile(
   string fileName
)
Delphi
public PDFMetafile(
    fileName: String
);
Managed Extensions for C++
public: PDFMetafile(
   string* fileName
)
C++/CLI
public:
PDFMetafile(
   String^ fileName
)

Parameters

fileName
the full path to the metafile on disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(String,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String,Boolean)

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal useUnicodeFonts As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim useUnicodeFonts As Boolean

Dim instance As PDFMetafile(fileName, useUnicodeFonts)
C#
public PDFMetafile(
   string fileName,
   bool useUnicodeFonts
)
Delphi
public PDFMetafile(
    fileName: String;
    useUnicodeFonts: Boolean
);
Managed Extensions for C++
public: PDFMetafile(
   string* fileName,
   bool useUnicodeFonts
)
C++/CLI
public:
PDFMetafile(
   String^ fileName,
   bool useUnicodeFonts
)

Parameters

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.

Remarks

When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFPath Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

Represents a series of connected lines and curves.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPath
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
C#
public class PDFPath : PDFGraphic
Delphi
public class PDFPath = class(PDFGraphic)
Managed Extensions for C++
public __gc class PDFPath : public PDFGraphic
C++/CLI
public ref class PDFPath : public PDFGraphic

Remarks

A path can be used to create complex geometric shapes that are not available in PDF4NET library as basic drawing primitives.
A path consists of one or more subpaths that can be connected or not. All the points of a subpath are connected through lines and/or curves. A subpath can be open or it can be explicitly closed. When a subpath is explicitly closed, a new subpath is automatically opened and its starting point is (0,0). When the path is filled, its subpaths, that are not explicitly closed, are automatically closed.
Each drawing primitive in a subpath updates the current drawing point. If the current drawing point is explicitly moved using MoveTo, the current subpath is ended and a new subpath is started.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPath Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

The following tables list the members exposed by PDFPath.

Public Constructors

 | Name | Description
Public Constructor | PDFPath Constructor | Overloaded. Initializes a new PDFPath object.
Top

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this path.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

Public Methods

 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Public Method | ToString | Overridden.
Top

See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPath Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PDFPath Constructor

Initializes a new PDFPath object.

Overload List

Overload | Description
PDFPath Constructor() | Initializes a new PDFPath object.
PDFPath Constructor(Single,Single) | Initializes a new PDFPath object with the given coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

PDFPath Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class > PDFPath Constructor : PDFPath Constructor()

Initializes a new PDFPath object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPath()
C#
public PDFPath()
Delphi
public PDFPath();
Managed Extensions for C++
public: PDFPath();
C++/CLI
public:
PDFPath();

Remarks

The starting point of the path is (0,0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members
Overload List


%%PageItemTitle%%

PDFPath Constructor(Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class > PDFPath Constructor : PDFPath Constructor(Single,Single)

x
The x coordinate of the starting point of the path.
y
The y coordinate of the starting point of the path.
Initializes a new PDFPath object with the given coordinates.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim x As Single
Dim y As Single

Dim instance As PDFPath(x, y)
C#
public PDFPath(
   float x,
   float y
)
Delphi
public PDFPath(
    x: Single;
    y: Single
);
Managed Extensions for C++
public: PDFPath(
   float x,
   float y
)
C++/CLI
public:
PDFPath(
   float x,
   float y
)

Parameters

x
The x coordinate of the starting point of the path.
y
The y coordinate of the starting point of the path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFPath Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

For a list of all members of this type, see PDFPath members.

Public Methods

 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Public Method | ToString | Overridden.
Top

See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

BezierTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : BezierTo Method

x1
The x coordinate of the first control point.
y1
The y coordinate of the first control point.
x2
The x coordinate of the second control point.
y2
The y coordinate of the second control point.
x3
The x coordinate of the third control point.
y3
The y coordinate of the third control point.
Appends a Berzier curve to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub BezierTo( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal x3 As Single, _
   ByVal y3 As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x1 As Single
Dim y1 As Single
Dim x2 As Single
Dim y2 As Single
Dim x3 As Single
Dim y3 As Single

instance.BezierTo(x1, y1, x2, y2, x3, y3)
C#
public void BezierTo(
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3
)
Delphi
public procedure BezierTo(
    x1: Single;
    y1: Single;
    x2: Single;
    y2: Single;
    x3: Single;
    y3: Single
);
Managed Extensions for C++
public: void BezierTo(
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3
)
C++/CLI
public:
void BezierTo(
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3
)

Parameters

x1
The x coordinate of the first control point.
y1
The y coordinate of the first control point.
x2
The x coordinate of the second control point.
y2
The y coordinate of the second control point.
x3
The x coordinate of the third control point.
y3
The y coordinate of the third control point.

Remarks

The new point (x3,y3) becomes the path current point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

CloseSubpath Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : CloseSubpath Method

Closes the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub CloseSubpath()
Visual Basic (Usage) Copy Code
Dim instance As PDFPath

instance.CloseSubpath()
C#
public void CloseSubpath()
Delphi
public procedure CloseSubpath();
Managed Extensions for C++
public: void CloseSubpath();
C++/CLI
public:
void CloseSubpath();

Remarks

Current subpath is closed. A new subpath is automatically started and the new current point is (0,0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

Ellipse Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Ellipse Method

left
The x coordinate of the top left corner of the bounding rectangle.
top
The y coordinate of the top left corner of the bounding rectangle.
width
The width of the bounding rectangle.
height
The height of the bounding rectangle.
Add an ellipse to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Ellipse( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.Ellipse(left, top, width, height)
C#
public void Ellipse(
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure Ellipse(
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void Ellipse(
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void Ellipse(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The x coordinate of the top left corner of the bounding rectangle.
top
The y coordinate of the top left corner of the bounding rectangle.
width
The width of the bounding rectangle.
height
The height of the bounding rectangle.

Remarks

The ellipse defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

LineTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : LineTo Method

x
The x coordinate of the line ending point.
y
The y coordinate of the line ending point.
Appends a line segment to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub LineTo( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x As Single
Dim y As Single

instance.LineTo(x, y)
C#
public void LineTo(
   float x,
   float y
)
Delphi
public procedure LineTo(
    x: Single;
    y: Single
);
Managed Extensions for C++
public: void LineTo(
   float x,
   float y
)
C++/CLI
public:
void LineTo(
   float x,
   float y
)

Parameters

x
The x coordinate of the line ending point.
y
The y coordinate of the line ending point.

Remarks

The new point (x,y) becomes the path current point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

MoveTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : MoveTo Method

x
The x coordinate of the new current point.
y
The y coordinate of the new current point.
Moves the current point in the path to a new position.

Syntax

Visual Basic (Declaration)
Public Sub MoveTo( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x As Single
Dim y As Single

instance.MoveTo(x, y)
C#
public void MoveTo(
   float x,
   float y
)
Delphi
public procedure MoveTo(
    x: Single;
    y: Single
);
Managed Extensions for C++
public: void MoveTo(
   float x,
   float y
)
C++/CLI
public:
void MoveTo(
   float x,
   float y
)

Parameters

x
The x coordinate of the new current point.
y
The y coordinate of the new current point.

Remarks

The previous path, if exists, is ended and a new subpath is automatically started.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

PolyBezierTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyBezierTo Method

points
An array of PDFPoint objects that represents the control points that define the Bezier curves to add.
Appends a series of connected Bezier curves to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub PolyBezierTo( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyBezierTo(points)
C#
public void PolyBezierTo(
   PDFPoint[] points
)
Delphi
public procedure PolyBezierTo(
    points: PDFPointarray of
);
Managed Extensions for C++
public: void PolyBezierTo(
   PDFPoint*[]* points
)
C++/CLI
public:
void PolyBezierTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the control points that define the Bezier curves to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.
ArgumentException | Thrown when the last Bezier curve in the array is incomplete.

Remarks

Each Bezier curve is defined by 4 points. The first curve uses the current point as its first control point and each following curve uses the last point of the previous curve as its first control point.
The last point in the array becomes the new current point in the path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

Polygon Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Polygon Method

points
An array of PDFPoint objects that represents the points that define the polygon to add.
Add a polygon to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Polygon( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.Polygon(points)
C#
public void Polygon(
   PDFPoint[] points
)
Delphi
public procedure Polygon(
    points: PDFPointarray of
);
Managed Extensions for C++
public: void Polygon(
   PDFPoint*[]* points
)
C++/CLI
public:
void Polygon(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the points that define the polygon to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.

Remarks

The polygon defines a closed subpath within the path. The first point in the array is considered as the starting point for the polygon. A new subpath is automatically started and the new current point is the first point of the polygon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

PolyLineTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyLineTo Method

points
An array of PDFPoint objects that represents the points that define the line segments to add.
Appends a series of connected line segments to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub PolyLineTo( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyLineTo(points)
C#
public void PolyLineTo(
   PDFPoint[] points
)
Delphi
public procedure PolyLineTo(
    points: PDFPointarray of
);
Managed Extensions for C++
public: void PolyLineTo(
   PDFPoint*[]* points
)
C++/CLI
public:
void PolyLineTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the points that define the line segments to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.

Remarks

The last point in the array becomes the new current point in the path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

Rectangle Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Rectangle Method

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Add a rectangle to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Rectangle( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

instance.Rectangle(left, top, width, height)
C#
public void Rectangle(
   float left,
   float top,
   float width,
   float height
)
Delphi
public procedure Rectangle(
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: void Rectangle(
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
void Rectangle(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Remarks

The rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

RoundRectangle Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : RoundRectangle Method

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
ellipseWidth
The width of the ellipse used to draw the rounded corners.
ellipseHeight
The height of the ellipse used to draw the rounded corners.
Add a rounded rectangle to this path object.

Syntax

Visual Basic (Declaration)
Public Sub RoundRectangle( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single

instance.RoundRectangle(left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void RoundRectangle(
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
Delphi
public procedure RoundRectangle(
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single
);
Managed Extensions for C++
public: void RoundRectangle(
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)
C++/CLI
public:
void RoundRectangle(
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
ellipseWidth
The width of the ellipse used to draw the rounded corners.
ellipseHeight
The height of the ellipse used to draw the rounded corners.

Remarks

The rounded rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

ToString Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : ToString Method

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%% $$Properties$$

PDFPath Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

For a list of all members of this type, see PDFPath members.

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this path.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FillMode Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : FillMode Property

Gets or sets the filling mode for this path.

Syntax

Visual Basic (Declaration)
Public Property FillMode As FillMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim value As FillMode

instance.FillMode = value

value = instance.FillMode
C#
public FillMode FillMode {get; set;}
Delphi
public read-write property FillMode: FillMode;
Managed Extensions for C++
public: __property FillMode get_FillMode();
public: __property void set_FillMode(
   FillMode value
);
C++/CLI
public:
property FillMode FillMode {
   FillMode get();
   void set (FillMode value);
}

Return Value

A FillMode enumeration member specifying the filling mode for this path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

PDFPie Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPie Class

Defines a pie representing a closed portion of a ellipse specified by a pair of coordinates, a width, and a height.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPie
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPie
C#
public sealed class PDFPie : PDFRectangularObject
Delphi
public class PDFPie = class(PDFRectangularObject)sealed;
Managed Extensions for C++
public __gc __sealed class PDFPie : public PDFRectangularObject
C++/CLI
public ref class PDFPie sealed : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFPie

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPie Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPie Class

The following tables list the members exposed by PDFPie.

Public Constructors

 | Name | Description
Public Constructor | PDFPie Constructor | Overloaded. Initializes a new PDFPie object using the specified pen, a pair of coordinates and widh and height. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the arc. Supported by Compact .NET Edition.
Public Property | SweepAngle | Gets or sets the sweep angle of the ellipse. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFPie Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPie Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class : PDFPie Constructor

Initializes a new PDFPie object using the specified pen, a pair of coordinates and widh and height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFPie Constructor() | Initializes a new PDFPie object.
PDFPie Constructor(PDFPen,PDFBrush,RectangleF,Single,Single) | Initializes a new PDFPie object using the specified pen and bounding rectangle.
PDFPie Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single) | Initializes a new PDFPie object using the specified pen, a pair of coordinates and widh and height. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members


%%PageItemTitle%%

PDFPie Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class > PDFPie Constructor : PDFPie Constructor()

Initializes a new PDFPie object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPie()
C#
public PDFPie()
Delphi
public PDFPie();
Managed Extensions for C++
public: PDFPie();
C++/CLI
public:
PDFPie();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members
Overload List


%%PageItemTitle%%

PDFPie Constructor(PDFPen,PDFBrush,RectangleF,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class > PDFPie Constructor : PDFPie Constructor(PDFPen,PDFBrush,RectangleF,Single,Single)

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Initializes a new PDFPie object using the specified pen and bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFPie(pen, brush, rect, startAngle, sweepAngle)
C#
public PDFPie(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFPie(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFPie(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
rect
a rectangle object that defines the ellipse.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members
Overload List


%%PageItemTitle%%

PDFPie Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class > PDFPie Constructor : PDFPie Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Initializes a new PDFPie object using the specified pen, a pair of coordinates and widh and height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim startAngle As Single
Dim sweepAngle As Single

Dim instance As PDFPie(pen, brush, top, left, width, height, startAngle, sweepAngle)
C#
public PDFPie(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
Delphi
public PDFPie(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    startAngle: Single;
    sweepAngle: Single
);
Managed Extensions for C++
public: PDFPie(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)
C++/CLI
public:
PDFPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

pen
a Pen object used to draw the pie
brush
a Brush object used to fill the pie
top
y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
left
x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
width of the rectangle that defines the ellipse.
height
height of the rectangle that defines the ellipse.
startAngle
angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPie Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPie Class

For a list of all members of this type, see PDFPie members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | StartAngle | Gets or sets the start angle of the arc. Supported by Compact .NET Edition.
Public Property | SweepAngle | Gets or sets the sweep angle of the ellipse. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFPie Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

StartAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class : StartAngle Property

Gets or sets the start angle of the arc.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property StartAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPie
Dim value As Single

instance.StartAngle = value

value = instance.StartAngle
C#
public float StartAngle {get; set;}
Delphi
public read-write property StartAngle: Single;
Managed Extensions for C++
public: __property float get_StartAngle();
public: __property void set_StartAngle(
   float value
);
C++/CLI
public:
property float StartAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members


%%PageItemTitle%%

SweepAngle Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPie Class : SweepAngle Property

Gets or sets the sweep angle of the ellipse.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property SweepAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFPie
Dim value As Single

instance.SweepAngle = value

value = instance.SweepAngle
C#
public float SweepAngle {get; set;}
Delphi
public read-write property SweepAngle: Single;
Managed Extensions for C++
public: __property float get_SweepAngle();
public: __property void set_SweepAngle(
   float value
);
C++/CLI
public:
property float SweepAngle {
   float get();
   void set (float value);
}

Return Value

a float value representing the angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPie Class
PDFPie Members


%%PageItemTitle%%

PDFPolyBezier Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyBezier Class

Defines a series of connected curves specified by an array of points.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFPolyBezier
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyBezier
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFPolyBezier : PDFGraphic
Delphi
public class PDFPolyBezier = class(PDFGraphic)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFPolyBezier : public PDFGraphic
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFPolyBezier sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyBezier

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPolyBezier Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyBezier Class

The following tables list the members exposed by PDFPolyBezier.

Public Constructors

 | Name | Description
Public Constructor | PDFPolyBezier Constructor | Overloaded. Initiaizes a new PDFPolyBezier object.
Top

Public Properties

 | Name | Description
Public Property | Item | Provides indexed access to the points array representing the curves.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolyBezier Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPolyBezier Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyBezier Class : PDFPolyBezier Constructor

Initiaizes a new PDFPolyBezier object.

Overload List

Overload | Description
PDFPolyBezier Constructor() | Initiaizes a new PDFPolyBezier object.
PDFPolyBezier Constructor(PDFPen,PDFPoint[]) | Initializes a new PDFPolyBezier object using the specified pen and an array of control points.
PDFPolyBezier Constructor(PDFPen,PointF[]) | Initializes a new PDFPolyBezier object using the specified pen and an array of points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Class
PDFPolyBezier Members


%%PageItemTitle%%

PDFPolyBezier Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyBezier Class > PDFPolyBezier Constructor : PDFPolyBezier Constructor()

Initiaizes a new PDFPolyBezier object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyBezier()
C#
public PDFPolyBezier()
Delphi
public PDFPolyBezier();
Managed Extensions for C++
public: PDFPolyBezier();
C++/CLI
public:
PDFPolyBezier();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Class
PDFPolyBezier Members
Overload List


%%PageItemTitle%%

PDFPolyBezier Constructor(PDFPen,PDFPoint[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyBezier Class > PDFPolyBezier Constructor : PDFPolyBezier Constructor(PDFPen,PDFPoint[])

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points
Initializes a new PDFPolyBezier object using the specified pen and an array of control points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim points() As PDFPoint

Dim instance As PDFPolyBezier(pen, points)
C#
public PDFPolyBezier(
   PDFPen pen,
   PDFPoint[] points
)
Delphi
public PDFPolyBezier(
    pen: PDFPen;
    points: PDFPointarray of
);
Managed Extensions for C++
public: PDFPolyBezier(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
PDFPolyBezier(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points

Remarks

The curves are specified using and array of control points. The first point in the array represents the beginning of the first curve. The end point of each curve represents the beginning of the next one.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Class
PDFPolyBezier Members
Overload List


%%PageItemTitle%%

PDFPolyBezier Constructor(PDFPen,PointF[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyBezier Class > PDFPolyBezier Constructor : PDFPolyBezier Constructor(PDFPen,PointF[])

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.
Initializes a new PDFPolyBezier object using the specified pen and an array of points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim points() As PointF

Dim instance As PDFPolyBezier(pen, points)
C#
public PDFPolyBezier(
   PDFPen pen,
   PointF[] points
)
Delphi
public PDFPolyBezier(
    pen: PDFPen;
    points: PointFarray of
);
Managed Extensions for C++
public: PDFPolyBezier(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
PDFPolyBezier(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.

Remarks

The curves are specified using and array of control points. The first point in the array represents the beginning of the first curve. The end point of each curve represents the beginning of the next one.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Class
PDFPolyBezier Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPolyBezier Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyBezier Class

For a list of all members of this type, see PDFPolyBezier members.

Public Properties

 | Name | Description
Public Property | Item | Provides indexed access to the points array representing the curves.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolyBezier Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyBezier Class : Item Property

Index
Provides indexed access to the points array representing the curves.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal Index As Integer _
) As PointF
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyBezier
Dim Index As Integer
Dim value As PointF

instance.Item(Index) = value

value = instance.Item(Index)
C#
public PointF this[
   int Index
]; {get; set;}
Delphi
public  this: : PointF;[
    Index: Integer
]; read-write
Managed Extensions for C++
public: __property PointF get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   PointF value
);
C++/CLI
public:
property PointF default [int] {
   PointF get(int Index);
   void set (int Index, PointF value);
}

Parameters

Index

Return Value

A PointF structure specifying the coordinates of the selected point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyBezier Class
PDFPolyBezier Members


%%PageItemTitle%%

PDFPolygon Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolygon Class

Defines a closed polygon specified by an array of points.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class PDFPolygon
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFPolygon
C#
[DefaultMemberAttribute("Item")]
public sealed class PDFPolygon : PDFGraphic
Delphi
public class PDFPolygon = class(PDFGraphic)sealed;
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class PDFPolygon : public PDFGraphic
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFPolygon sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolygon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPolygon Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolygon Class

The following tables list the members exposed by PDFPolygon.

Public Constructors

 | Name | Description
Public Constructor | PDFPolygon Constructor | Overloaded. Initiaizes a new PDFPolygon object.
Top

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this object.
Public Property | Item | Provides indexed access to the points array representing the polygon. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolygon Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPolygon Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class : PDFPolygon Constructor

Initiaizes a new PDFPolygon object.

Overload List

Overload | Description
PDFPolygon Constructor() | Initiaizes a new PDFPolygon object.
PDFPolygon Constructor(PDFPen,PDFBrush,PDFPoint[]) | Initializes a new PDFPolygon object using the specified pen, brush and an array of points. Supported by Compact .NET Edition.
PDFPolygon Constructor(PDFPen,PDFBrush,PointF[]) | Initializes a new PDFPolygon object using the specified pen, brush and an array of points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members


%%PageItemTitle%%

PDFPolygon Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class > PDFPolygon Constructor : PDFPolygon Constructor()

Initiaizes a new PDFPolygon object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPolygon()
C#
public PDFPolygon()
Delphi
public PDFPolygon();
Managed Extensions for C++
public: PDFPolygon();
C++/CLI
public:
PDFPolygon();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members
Overload List


%%PageItemTitle%%

PDFPolygon Constructor(PDFPen,PDFBrush,PDFPoint[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class > PDFPolygon Constructor : PDFPolygon Constructor(PDFPen,PDFBrush,PDFPoint[])

pen
a Pen object used to draw the polygon
brush
a Brush object used to fill the polygon
points
an array of PDFPoint objects specifying the coordinates of the corners of the polygon.
Initializes a new PDFPolygon object using the specified pen, brush and an array of points.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

Dim instance As PDFPolygon(pen, brush, points)
C#
public PDFPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public PDFPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: PDFPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
PDFPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a Pen object used to draw the polygon
brush
a Brush object used to fill the polygon
points
an array of PDFPoint objects specifying the coordinates of the corners of the polygon.

Remarks

The polygon is specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line. The polygon is automatically closed, there is no need for the last point in the array to have the same position like the first point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members
Overload List


%%PageItemTitle%%

PDFPolygon Constructor(PDFPen,PDFBrush,PointF[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class > PDFPolygon Constructor : PDFPolygon Constructor(PDFPen,PDFBrush,PointF[])

pen
a Pen object used to draw the polygon
brush
a Brush object used to fill the polygon
points
an array of PointF structures specifying the coordinates of the corners of the polygon.
Initializes a new PDFPolygon object using the specified pen, brush and an array of points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

Dim instance As PDFPolygon(pen, brush, points)
C#
public PDFPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Delphi
public PDFPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: PDFPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
PDFPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a Pen object used to draw the polygon
brush
a Brush object used to fill the polygon
points
an array of PointF structures specifying the coordinates of the corners of the polygon.

Remarks

The polygon is specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line. The polygon is automatically closed, there is no need for the last point in the array to have the same position like the first point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPolygon Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolygon Class

For a list of all members of this type, see PDFPolygon members.

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this object.
Public Property | Item | Provides indexed access to the points array representing the polygon. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolygon Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FillMode Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class : FillMode Property

Gets or sets the filling mode for this object.

Syntax

Visual Basic (Declaration)
Public Property FillMode As FillMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPolygon
Dim value As FillMode

instance.FillMode = value

value = instance.FillMode
C#
public FillMode FillMode {get; set;}
Delphi
public read-write property FillMode: FillMode;
Managed Extensions for C++
public: __property FillMode get_FillMode();
public: __property void set_FillMode(
   FillMode value
);
C++/CLI
public:
property FillMode FillMode {
   FillMode get();
   void set (FillMode value);
}

Return Value

A FillMode enumeration member specifying the filling mode for this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolygon Class : Item Property

Index
Provides indexed access to the points array representing the polygon.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal Index As Integer _
) As PointF
Visual Basic (Usage) Copy Code
Dim instance As PDFPolygon
Dim Index As Integer
Dim value As PointF

instance.Item(Index) = value

value = instance.Item(Index)
C#
public PointF this[
   int Index
]; {get; set;}
Delphi
public  this: : PointF;[
    Index: Integer
]; read-write
Managed Extensions for C++
public: __property PointF get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   PointF value
);
C++/CLI
public:
property PointF default [int] {
   PointF get(int Index);
   void set (int Index, PointF value);
}

Parameters

Index

Return Value

A PointF structure specifying the coordinates of the selected point. The value of this property is a PDFPoint object for Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolygon Class
PDFPolygon Members


%%PageItemTitle%%

PDFPolyPolygon Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyPolygon Class

Defines a series of closed polygons.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPolyPolygon
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyPolygon
C#
public sealed class PDFPolyPolygon : PDFGraphic
Delphi
public class PDFPolyPolygon = class(PDFGraphic)sealed;
Managed Extensions for C++
public __gc __sealed class PDFPolyPolygon : public PDFGraphic
C++/CLI
public ref class PDFPolyPolygon sealed : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyPolygon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPolyPolygon Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyPolygon Class

The following tables list the members exposed by PDFPolyPolygon.

Public Constructors

 | Name | Description
Public Constructor | PDFPolyPolygon Constructor | Overloaded. Initiaizes a new PDFPolyPolygon object.
Top

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this object.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolyPolygon Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPolyPolygon Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyPolygon Class : PDFPolyPolygon Constructor

Initiaizes a new PDFPolyPolygon object.

Overload List

Overload | Description
PDFPolyPolygon Constructor() | Initiaizes a new PDFPolyPolygon object.
PDFPolyPolygon Constructor(PDFPen,PDFBrush,PDFPoint[][]) | Initializes a new PDFPolyPolygon object using the specified pen, brush and an array of polygons.
PDFPolyPolygon Constructor(PDFPen,PDFBrush,PointF[][]) | Initializes a new PDFPolyPolygon object using the specified pen, brush and an array of polygons.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Class
PDFPolyPolygon Members


%%PageItemTitle%%

PDFPolyPolygon Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyPolygon Class > PDFPolyPolygon Constructor : PDFPolyPolygon Constructor()

Initiaizes a new PDFPolyPolygon object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyPolygon()
C#
public PDFPolyPolygon()
Delphi
public PDFPolyPolygon();
Managed Extensions for C++
public: PDFPolyPolygon();
C++/CLI
public:
PDFPolyPolygon();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Class
PDFPolyPolygon Members
Overload List


%%PageItemTitle%%

PDFPolyPolygon Constructor(PDFPen,PDFBrush,PDFPoint[][])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyPolygon Class > PDFPolyPolygon Constructor : PDFPolyPolygon Constructor(PDFPen,PDFBrush,PDFPoint[][])

pen
a Pen object used to draw the polygons
brush
a Brush object used to fill the polygons
points
an array of PointF arrays specifying the coordinates of each polygon's vertices.
Initializes a new PDFPolyPolygon object using the specified pen, brush and an array of polygons.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

Dim instance As PDFPolyPolygon(pen, brush, points)
C#
public PDFPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Delphi
public PDFPolyPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PDFPointarray of
);
Managed Extensions for C++
public: PDFPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
PDFPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a Pen object used to draw the polygons
brush
a Brush object used to fill the polygons
points
an array of PointF arrays specifying the coordinates of each polygon's vertices.

Remarks

Each polygon is specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line. The polygon is automatically closed, there is no need for the last point in the array to have the same position like the first point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Class
PDFPolyPolygon Members
Overload List


%%PageItemTitle%%

PDFPolyPolygon Constructor(PDFPen,PDFBrush,PointF[][])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyPolygon Class > PDFPolyPolygon Constructor : PDFPolyPolygon Constructor(PDFPen,PDFBrush,PointF[][])

pen
a Pen object used to draw the polygons
brush
a Brush object used to fill the polygons
points
an array of PointF arrays specifying the coordinates of each polygon's vertices.
Initializes a new PDFPolyPolygon object using the specified pen, brush and an array of polygons.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

Dim instance As PDFPolyPolygon(pen, brush, points)
C#
public PDFPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Delphi
public PDFPolyPolygon(
    pen: PDFPen;
    brush: PDFBrush;
    points: PointFarray of
);
Managed Extensions for C++
public: PDFPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
PDFPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a Pen object used to draw the polygons
brush
a Brush object used to fill the polygons
points
an array of PointF arrays specifying the coordinates of each polygon's vertices.

Remarks

Each polygon is specified using and array of points. The first point in the array represents the beginning of the first line. The end point of each line represents the beginning of the next line. The polygon is automatically closed, there is no need for the last point in the array to have the same position like the first point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Class
PDFPolyPolygon Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPolyPolygon Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPolyPolygon Class

For a list of all members of this type, see PDFPolyPolygon members.

Public Properties

 | Name | Description
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | FillMode | Gets or sets the filling mode for this object.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Top

See Also

Reference

PDFPolyPolygon Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FillMode Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPolyPolygon Class : FillMode Property

Gets or sets the filling mode for this object.

Syntax

Visual Basic (Declaration)
Public Property FillMode As FillMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPolyPolygon
Dim value As FillMode

instance.FillMode = value

value = instance.FillMode
C#
public FillMode FillMode {get; set;}
Delphi
public read-write property FillMode: FillMode;
Managed Extensions for C++
public: __property FillMode get_FillMode();
public: __property void set_FillMode(
   FillMode value
);
C++/CLI
public:
property FillMode FillMode {
   FillMode get();
   void set (FillMode value);
}

Return Value

A FillMode enumeration member specifying the filling mode for this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPolyPolygon Class
PDFPolyPolygon Members


%%PageItemTitle%%

PDFRect Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRect Class

Defines a rectangle as it is specified by the pdf specification.

Syntax

Visual Basic (Declaration)
Public Class PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
C#
public class PDFRect
Delphi
public class PDFRect
Managed Extensions for C++
public __gc class PDFRect
C++/CLI
public ref class PDFRect

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFRect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFRect Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRect Class

The following tables list the members exposed by PDFRect.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the rectangle.
Public Property | LLX | Gets or sets the x-coordinate of the lower left corner.
Public Property | LLY | Gets or sets the y-coordinate of the lower left corner.
Public Property | URX | Gets or sets the x-coordinate of the upper right corner.
Public Property | URY | Gets or sets the y-coordinate of the upper right corner.
Public Property | Width | Gets the width of the rectangle.
Top

See Also

Reference

PDFRect Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Properties$$

PDFRect Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRect Class

For a list of all members of this type, see PDFRect members.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the rectangle.
Public Property | LLX | Gets or sets the x-coordinate of the lower left corner.
Public Property | LLY | Gets or sets the y-coordinate of the lower left corner.
Public Property | URX | Gets or sets the x-coordinate of the upper right corner.
Public Property | URY | Gets or sets the y-coordinate of the upper right corner.
Public Property | Width | Gets the width of the rectangle.
Top

See Also

Reference

PDFRect Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : Height Property

Gets the height of the rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

value = instance.Height
C#
public float Height {get;}
Delphi
public read-only property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
C++/CLI
public:
property float Height {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

LLX Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : LLX Property

Gets or sets the x-coordinate of the lower left corner.

Syntax

Visual Basic (Declaration)
Public Property LLX As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

instance.LLX = value

value = instance.LLX
C#
public float LLX {get; set;}
Delphi
public read-write property LLX: Single;
Managed Extensions for C++
public: __property float get_LLX();
public: __property void set_LLX(
   float value
);
C++/CLI
public:
property float LLX {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

LLY Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : LLY Property

Gets or sets the y-coordinate of the lower left corner.

Syntax

Visual Basic (Declaration)
Public Property LLY As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

instance.LLY = value

value = instance.LLY
C#
public float LLY {get; set;}
Delphi
public read-write property LLY: Single;
Managed Extensions for C++
public: __property float get_LLY();
public: __property void set_LLY(
   float value
);
C++/CLI
public:
property float LLY {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

URX Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : URX Property

Gets or sets the x-coordinate of the upper right corner.

Syntax

Visual Basic (Declaration)
Public Property URX As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

instance.URX = value

value = instance.URX
C#
public float URX {get; set;}
Delphi
public read-write property URX: Single;
Managed Extensions for C++
public: __property float get_URX();
public: __property void set_URX(
   float value
);
C++/CLI
public:
property float URX {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

URY Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : URY Property

Gets or sets the y-coordinate of the upper right corner.

Syntax

Visual Basic (Declaration)
Public Property URY As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

instance.URY = value

value = instance.URY
C#
public float URY {get; set;}
Delphi
public read-write property URY: Single;
Managed Extensions for C++
public: __property float get_URY();
public: __property void set_URY(
   float value
);
C++/CLI
public:
property float URY {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRect Class : Width Property

Gets the width of the rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRect
Dim value As Single

value = instance.Width
C#
public float Width {get;}
Delphi
public read-only property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
C++/CLI
public:
property float Width {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRect Class
PDFRect Members


%%PageItemTitle%%

PDFRectangle Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangle Class

Defines a rectangle specified by a pair of coordinates, a width, and a height.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRectangle
   Inherits PDFRectangularObject
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
C#
public class PDFRectangle : PDFRectangularObject
Delphi
public class PDFRectangle = class(PDFRectangularObject)
Managed Extensions for C++
public __gc class PDFRectangle : public PDFRectangularObject
C++/CLI
public ref class PDFRectangle : public PDFRectangularObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangle
O2S.Components.PDF4NET.Graphics.Shapes.PDFRoundRectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFRectangle Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangle Class

The following tables list the members exposed by PDFRectangle.

Public Constructors

 | Name | Description
Public Constructor | PDFRectangle Constructor | Overloaded. Initializes a new PDFRectangle object using the specified pen, brush, a pair of coordinates and width and height. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the rectangle. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFRectangle Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangle Class : PDFRectangle Constructor

Initializes a new PDFRectangle object using the specified pen, brush, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFRectangle Constructor() | Initializes a new PDFRectangle object.
PDFRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single) | Initializes a new PDFRectangle object using the specified pen, brush and rectangle object.
PDFRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single) | Initializes a new PDFRectangle object using the specified pen, brush, a pair of coordinates and width and height. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRectangle Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor()

Initializes a new PDFRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle()
C#
public PDFRectangle()
Delphi
public PDFRectangle();
Managed Extensions for C++
public: PDFRectangle();
C++/CLI
public:
PDFRectangle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single)

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
rect
a RectangleF object that defines the rectangle.
orientation
orientation of the rectangle.
Initializes a new PDFRectangle object using the specified pen, brush and rectangle object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Single

Dim instance As PDFRectangle(pen, brush, rect, orientation)
C#
public PDFRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float orientation
)
Delphi
public PDFRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    orientation: Single
);
Managed Extensions for C++
public: PDFRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float orientation
)
C++/CLI
public:
PDFRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float orientation
)

Parameters

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
rect
a RectangleF object that defines the rectangle.
orientation
orientation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
top
y-coordinate of the upper-left corner of the rectangle.
left
x-coordinate of the upper-left corner of the rectangle.
width
width of the rectangle.
height
height of the rectangle.
orientation
orientation of the rectangle.
Initializes a new PDFRectangle object using the specified pen, brush, a pair of coordinates and width and height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal top As Single, _
   ByVal left As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim top As Single
Dim left As Single
Dim width As Single
Dim height As Single
Dim orientation As Single

Dim instance As PDFRectangle(pen, brush, top, left, width, height, orientation)
C#
public PDFRectangle(
   PDFPen pen,
   PDFBrush brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
Delphi
public PDFRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    top: Single;
    left: Single;
    width: Single;
    height: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)
C++/CLI
public:
PDFRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float top,
   float left,
   float width,
   float height,
   float orientation
)

Parameters

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
top
y-coordinate of the upper-left corner of the rectangle.
left
x-coordinate of the upper-left corner of the rectangle.
width
width of the rectangle.
height
height of the rectangle.
orientation
orientation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFRectangle Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the rectangle. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangle Class : Orientation Property

Gets or sets the orientation of the rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value representing the rotation angle of the rectangle.

Remarks

The orientation of the rectangle is used to draw the rectangle rotated, using the top left corner as rotation center. This value is specified in degrees and the angle is measured counterclockwise from the x axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRectangularObject Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangularObject Class

Defines an abstract rectangular object on a page

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFRectangularObject
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
C#
public abstract class PDFRectangularObject : PDFGraphic
Delphi
public class PDFRectangularObject = class(PDFGraphic)abstract;
Managed Extensions for C++
public __gc abstract class PDFRectangularObject : public PDFGraphic
C++/CLI
public ref class PDFRectangularObject abstract : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangle
O2S.Components.PDF4NET.Graphics.Shapes.PDFPie
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFEllipse
O2S.Components.PDF4NET.Graphics.Shapes.PDFChord
O2S.Components.PDF4NET.Graphics.Shapes.PDFArc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFRectangularObject Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangularObject Class

The following tables list the members exposed by PDFRectangularObject.

Public Constructors

 | Name | Description
Public Constructor | PDFRectangularObject Constructor | Overloaded. Initializes a new PDFRectangularObject object.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFRectangularObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFRectangularObject Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : PDFRectangularObject Constructor

Initializes a new PDFRectangularObject object.

Overload List

Overload | Description
PDFRectangularObject Constructor() | Initializes a new PDFRectangularObject object.
PDFRectangularObject Constructor(PDFPen,PDFBrush,Single,Single,Single,Single) | Initializes a new PDFRectangularObject object with the specified values. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

PDFRectangularObject Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class > PDFRectangularObject Constructor : PDFRectangularObject Constructor()

Initializes a new PDFRectangularObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject()
C#
public PDFRectangularObject()
Delphi
public PDFRectangularObject();
Managed Extensions for C++
public: PDFRectangularObject();
C++/CLI
public:
PDFRectangularObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members
Overload List


%%PageItemTitle%%

PDFRectangularObject Constructor(PDFPen,PDFBrush,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class > PDFRectangularObject Constructor : PDFRectangularObject Constructor(PDFPen,PDFBrush,Single,Single,Single,Single)

pen
a PDFPen object used to draw the border of the object.
brush
a PDFBrush object used to fill the interior of the object.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the bounding rectangle.
height
the height of the bounding rectangle.
Initializes a new PDFRectangularObject object with the specified values.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single

Dim instance As PDFRectangularObject(pen, brush, left, top, width, height)
C#
public PDFRectangularObject(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height
)
Delphi
public PDFRectangularObject(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single
);
Managed Extensions for C++
public: PDFRectangularObject(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height
)
C++/CLI
public:
PDFRectangularObject(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height
)

Parameters

pen
a PDFPen object used to draw the border of the object.
brush
a PDFBrush object used to fill the interior of the object.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the bounding rectangle.
height
the height of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFRectangularObject Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRectangularObject Class

For a list of all members of this type, see PDFRectangularObject members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFRectangularObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Bottom Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Bottom Property

Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Bottom = value

value = instance.Bottom
C#
public float Bottom {get; set;}
Delphi
public read-write property Bottom: Single;
Managed Extensions for C++
public: __property float get_Bottom();
public: __property void set_Bottom(
   float value
);
C++/CLI
public:
property float Bottom {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the bottom right corner of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Height Property

Gets or sets the height of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

a float value representing the height of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Left Property

Gets or sets the x-coordinate of the top left corner of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the top left corner of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

Right Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Right Property

Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Right = value

value = instance.Right
C#
public float Right {get; set;}
Delphi
public read-write property Right: Single;
Managed Extensions for C++
public: __property float get_Right();
public: __property void set_Right(
   float value
);
C++/CLI
public:
property float Right {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the bottom right corner of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Top Property

Gets or sets the y cordinate of the top left corner of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the top left corner of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRectangularObject Class : Width Property

Gets or sets the width of the bounding rectangle.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangularObject
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

a float value representing the width of the bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangularObject Class
PDFRectangularObject Members


%%PageItemTitle%%

PDFRoundRectangle Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRoundRectangle Class

Defines a rectangle with rounded corners specified by a pair of coordinates, a width, and a height.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRoundRectangle
   Inherits PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFRoundRectangle
C#
public class PDFRoundRectangle : PDFRectangle
Delphi
public class PDFRoundRectangle = class(PDFRectangle)
Managed Extensions for C++
public __gc class PDFRoundRectangle : public PDFRectangle
C++/CLI
public ref class PDFRoundRectangle : public PDFRectangle

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangle
O2S.Components.PDF4NET.Graphics.Shapes.PDFRoundRectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFRoundRectangle Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRoundRectangle Class

The following tables list the members exposed by PDFRoundRectangle.

Public Constructors

 | Name | Description
Public Constructor | PDFRoundRectangle Constructor | Overloaded. Initializes a new PDFRoundRectangle object using the specified pen, brush, a pair of coordinates and width and height.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | EllipseHeight | Gets or sets the height of the ellipse that defines the rectangle's corners.
Public Property | EllipseWidth | Gets or sets the width of the ellipse that defines the rectangle's corners.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangle)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFRoundRectangle Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFRoundRectangle Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class : PDFRoundRectangle Constructor

Initializes a new PDFRoundRectangle object using the specified pen, brush, a pair of coordinates and width and height.

Overload List

Overload | Description
PDFRoundRectangle Constructor() | Initializes a new PDFRoundRectangle object.
PDFRoundRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single,Single,Single) | Initializes a new PDFRoundRectangle object using the specified pen, brush and rectangle object.
PDFRoundRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single) | Initializes a new PDFRoundRectangle object using the specified pen, brush, a pair of coordinates and width and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members


%%PageItemTitle%%

PDFRoundRectangle Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class > PDFRoundRectangle Constructor : PDFRoundRectangle Constructor()

Initializes a new PDFRoundRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRoundRectangle()
C#
public PDFRoundRectangle()
Delphi
public PDFRoundRectangle();
Managed Extensions for C++
public: PDFRoundRectangle();
C++/CLI
public:
PDFRoundRectangle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members
Overload List


%%PageItemTitle%%

PDFRoundRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class > PDFRoundRectangle Constructor : PDFRoundRectangle Constructor(PDFPen,PDFBrush,RectangleF,Single,Single,Single)

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
rect
a RectangleF object that defines the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
orientation of the rectangle.
Initializes a new PDFRoundRectangle object using the specified pen, brush and rectangle object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim ellipseWidth As Single
Dim ellipseHeight As Single
Dim orientation As Single

Dim instance As PDFRoundRectangle(pen, brush, rect, ellipseWidth, ellipseHeight, orientation)
C#
public PDFRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
Delphi
public PDFRoundRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    rect: RectangleF;
    ellipseWidth: Single;
    ellipseHeight: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
C++/CLI
public:
PDFRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)

Parameters

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
rect
a RectangleF object that defines the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
orientation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members
Overload List


%%PageItemTitle%%

PDFRoundRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class > PDFRoundRectangle Constructor : PDFRoundRectangle Constructor(PDFPen,PDFBrush,Single,Single,Single,Single,Single,Single,Single)

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
left
x-coordinate of the upper-left corner of the rectangle.
top
y-coordinate of the upper-left corner of the rectangle.
width
width of the rectangle.
height
height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
orientation of the rectangle.
Initializes a new PDFRoundRectangle object using the specified pen, brush, a pair of coordinates and width and height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal ellipseWidth As Single, _
   ByVal ellipseHeight As Single, _
   ByVal orientation As Single _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim ellipseWidth As Single
Dim ellipseHeight As Single
Dim orientation As Single

Dim instance As PDFRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public PDFRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
Delphi
public PDFRoundRectangle(
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    ellipseWidth: Single;
    ellipseHeight: Single;
    orientation: Single
);
Managed Extensions for C++
public: PDFRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)
C++/CLI
public:
PDFRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float ellipseWidth,
   float ellipseHeight,
   float orientation
)

Parameters

pen
a Pen object used to draw the rectangle
brush
a Brush object used to fill the rectangle
left
x-coordinate of the upper-left corner of the rectangle.
top
y-coordinate of the upper-left corner of the rectangle.
width
width of the rectangle.
height
height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
orientation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFRoundRectangle Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRoundRectangle Class

For a list of all members of this type, see PDFRoundRectangle members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | EllipseHeight | Gets or sets the height of the ellipse that defines the rectangle's corners.
Public Property | EllipseWidth | Gets or sets the width of the ellipse that defines the rectangle's corners.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangle)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFRoundRectangle Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

EllipseHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class : EllipseHeight Property

Gets or sets the height of the ellipse that defines the rectangle's corners.

Syntax

Visual Basic (Declaration)
Public Property EllipseHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRoundRectangle
Dim value As Single

instance.EllipseHeight = value

value = instance.EllipseHeight
C#
public float EllipseHeight {get; set;}
Delphi
public read-write property EllipseHeight: Single;
Managed Extensions for C++
public: __property float get_EllipseHeight();
public: __property void set_EllipseHeight(
   float value
);
C++/CLI
public:
property float EllipseHeight {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of the ellipse that defines the rectangle's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members


%%PageItemTitle%%

EllipseWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRoundRectangle Class : EllipseWidth Property

Gets or sets the width of the ellipse that defines the rectangle's corners.

Syntax

Visual Basic (Declaration)
Public Property EllipseWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFRoundRectangle
Dim value As Single

instance.EllipseWidth = value

value = instance.EllipseWidth
C#
public float EllipseWidth {get; set;}
Delphi
public read-write property EllipseWidth: Single;
Managed Extensions for C++
public: __property float get_EllipseWidth();
public: __property void set_EllipseWidth(
   float value
);
C++/CLI
public:
property float EllipseWidth {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of the ellipse that defines the rectangle's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRoundRectangle Class
PDFRoundRectangle Members


%%PageItemTitle%%

PDFText Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFText Class

Defines a line of text specified by a printing position and a string.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFText
   Inherits PDFGraphic
Visual Basic (Usage) Copy Code
Dim instance As PDFText
C#
public class PDFText : PDFGraphic
Delphi
public class PDFText = class(PDFGraphic)
Managed Extensions for C++
public __gc class PDFText : public PDFGraphic
C++/CLI
public ref class PDFText : public PDFGraphic

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFText Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFText Class

The following tables list the members exposed by PDFText.

Public Constructors

 | Name | Description
Public Constructor | PDFText Constructor | Overloaded. Initializes a new PDFText object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text orientation. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFText Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFText Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : PDFText Constructor

Initializes a new PDFText object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFText Constructor() | Initializes a new PDFText object.
PDFText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign) | Initializes a new PDFText object. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

PDFText Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class > PDFText Constructor : PDFText Constructor()

Initializes a new PDFText object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFText()
C#
public PDFText()
Delphi
public PDFText();
Managed Extensions for C++
public: PDFText();
C++/CLI
public:
PDFText();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members
Overload List


%%PageItemTitle%%

PDFText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class > PDFText Constructor : PDFText Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,TextAlign)

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
the alignment of the text.
Initializes a new PDFText object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim orientation As Single
Dim align As TextAlign

Dim instance As PDFText(text, font, pen, brush, x, y, orientation, align)
C#
public PDFText(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
Delphi
public PDFText(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    orientation: Single;
    align: TextAlign
);
Managed Extensions for C++
public: PDFText(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)
C++/CLI
public:
PDFText(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   float orientation,
   TextAlign align
)

Parameters

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
the alignment of the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFText Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFText Class

For a list of all members of this type, see PDFText members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text orientation. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFText Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : Align Property

Gets or sets the text alignment

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Align As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As TextAlign

instance.Align = value

value = instance.Align
C#
public TextAlign Align {get; set;}
Delphi
public read-write property Align: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_Align();
public: __property void set_Align(
   TextAlign value
);
C++/CLI
public:
property TextAlign Align {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : Font Property

Gets or sets the font used to draw the text.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : Orientation Property

Gets or sets the text orientation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value specifying the rotation angle of the text.

Remarks

The text is displayed rotated by the angle specified by the property. The value of the property is expressed in degrees and the text is rotated counterclockwise from the x axis. The rotation is done around the printing point, as specified by X and Y properties. The text boxes are always rotated around the top left corner.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : Text Property

Gets or sets the text to be drawn.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the text to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : X Property

Gets or sets the x coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the printing point.

Remarks

The text is aligned on horizontal relative to this value. If the text is left aligned, then this property specifies the x coordinate of the left corner of the text bounding rectangle. If the text is center aligned, then this property specifies the x coordinate of the center of the text bounding rectangle. If the text is right aligned, then this property specifies the x coordinate of the right corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFText Class : Y Property

Gets or sets the y coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFText
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the printing point.

Remarks

The text is aligned on vertical relative to this value. If the text is top aligned, then this property specifies the y coordinate of the top corner of the text bounding rectangle. If the text is middle aligned, then this property specifies the y coordinate of the middle of the text bounding rectangle. If the text is bottom aligned, then this property specifies the y coordinate of the bottom corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFText Class
PDFText Members


%%PageItemTitle%%

PDFTextBox Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextBox Class

Defines a wrapped text specified by its bounding rectangle.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextBox
   Inherits PDFText
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
C#
public class PDFTextBox : PDFText
Delphi
public class PDFTextBox = class(PDFText)
Managed Extensions for C++
public __gc class PDFTextBox : public PDFText
C++/CLI
public ref class PDFTextBox : public PDFText

Remarks

This class is used to draw columnar text, by confining the text to a specified rectangle.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFText
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLTextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextBox Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextBox Class

The following tables list the members exposed by PDFTextBox.

Public Constructors

 | Name | Description
Public Constructor | PDFTextBox Constructor | Overloaded. Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the textbox. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipText | Gets or sets the clipping for the text Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Height | Gets or sets the height of the text box. Supported by Compact .NET Edition.
Public Property | LastLineWidth | Gets the width of the last line of text.
Public Property | Left | Gets or sets the x coordinate of the top left corner Supported by Compact .NET Edition.
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RequiredHeight | Gets the real height of the wrapped text. Supported by Compact .NET Edition.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the text box. Supported by Compact .NET Edition.
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | TextFormatOptions | Gets or sets the text formatting options for the text box Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y coordinate of the top left corner. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the text box. Supported by Compact .NET Edition.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FitText | Overloaded. Calculates how much of the given text fits in the given area. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextBox Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : PDFTextBox Constructor

Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFTextBox Constructor() | Initializes a new PDFTextBox object.
PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions) | Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height. Supported by Compact .NET Edition.
PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single) | Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

PDFTextBox Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > PDFTextBox Constructor : PDFTextBox Constructor()

Initializes a new PDFTextBox object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox()
C#
public PDFTextBox()
Delphi
public PDFTextBox();
Managed Extensions for C++
public: PDFTextBox();
C++/CLI
public:
PDFTextBox();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%%

PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > PDFTextBox Constructor : PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,PDFTextFormatOptions)

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
textFormatOptions
a PDFTextFormatOptions object specyfing how the text in the box should be formatted.
Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim textFormatOptions As PDFTextFormatOptions

Dim instance As PDFTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
C#
public PDFTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions textFormatOptions
)
Delphi
public PDFTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    textFormatOptions: PDFTextFormatOptions
);
Managed Extensions for C++
public: PDFTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
PDFTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
textFormatOptions
a PDFTextFormatOptions object specyfing how the text in the box should be formatted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%%

PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > PDFTextBox Constructor : PDFTextBox Constructor(String,PDFFont,PDFPen,PDFBrush,Single,Single,Single,Single,Single,TextAlign,Boolean,Single)

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
orientation
the orientation of the text box. The text box is always rotated around the top left corner.
align
the alignment of the text inside the text box.
clip
the cliping of the text.
lineSpacing
the additional space between lines of text.
Initializes a new PDFTextBox object specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal orientation As Single, _
   ByVal align As TextAlign, _
   ByVal clip As Boolean, _
   ByVal lineSpacing As Single _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Single
Dim top As Single
Dim width As Single
Dim height As Single
Dim orientation As Single
Dim align As TextAlign
Dim clip As Boolean
Dim lineSpacing As Single

Dim instance As PDFTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clip, lineSpacing)
C#
public PDFTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clip,
   float lineSpacing
)
Delphi
public PDFTextBox(
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    left: Single;
    top: Single;
    width: Single;
    height: Single;
    orientation: Single;
    align: TextAlign;
    clip: Boolean;
    lineSpacing: Single
);
Managed Extensions for C++
public: PDFTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clip,
   float lineSpacing
)
C++/CLI
public:
PDFTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float left,
   float top,
   float width,
   float height,
   float orientation,
   TextAlign align,
   bool clip,
   float lineSpacing
)

Parameters

text
the text to be drawn.
font
a Font object used to draw the text.
pen
a Pen used to draw the border of the text.
brush
a Brush object used to fill the interior of the text.
left
the x coordinate of the top left corner of the bounding box.
top
the y coordinate of the top left corner of the bounding box.
width
the width of the bounding box.
height
the height of the bounding box.
orientation
the orientation of the text box. The text box is always rotated around the top left corner.
align
the alignment of the text inside the text box.
clip
the cliping of the text.
lineSpacing
the additional space between lines of text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFTextBox Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextBox Class

For a list of all members of this type, see PDFTextBox members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FitText | Overloaded. Calculates how much of the given text fits in the given area. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FitText Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : FitText Method

Calculates how much of the given text fits in the given area.

Supported by Compact .NET Edition.

Overload List

Overload | Description
FitText(String,PDFFont,Single,Single,Single,Single) | Calculates how much of the given text fits in the given area. Supported by Compact .NET Edition.
FitText(String,PDFFont,Single,Single,Single,Single,Boolean) | Calculates how much of the given text fits in the given area. Supported by Compact .NET Edition.
FitText(String,PDFFont,Single,Single,Single,Single,Boolean,Boolean) | Calculates how much of the given text fits in the given area. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Single) Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Single) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.
Calculates how much of the given text fits in the given area.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal firstLineIndent As Single _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim firstLineIndent As Single
Dim value As Integer

value = PDFTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, firstLineIndent)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    firstLineIndent: Single
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Single,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Single,Boolean) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.
keepWhiteSpaces
a flag specifying whether the word wrapping should keep or not the white spaces.
Calculates how much of the given text fits in the given area.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal firstLineIndent As Single, _
   ByVal keepWhiteSpaces As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim firstLineIndent As Single
Dim keepWhiteSpaces As Boolean
Dim value As Integer

value = PDFTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, firstLineIndent, keepWhiteSpaces)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    firstLineIndent: Single;
    keepWhiteSpaces: Boolean
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.
keepWhiteSpaces
a flag specifying whether the word wrapping should keep or not the white spaces.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%%

FitText(String,PDFFont,Single,Single,Single,Single,Boolean,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class > FitText Method : FitText(String,PDFFont,Single,Single,Single,Single,Boolean,Boolean) Method

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.
keepWhiteSpaces
a flag specifying whether the word wrapping should keep or not the white spaces.
breakLongWords
a flag specifying whether to consider long words breaking when measuring text to fit in the box.
Calculates how much of the given text fits in the given area.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FitText( _
   ByVal textToFit As String, _
   ByVal displayFont As PDFFont, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal lineSpacing As Single, _
   ByVal firstLineIndent As Single, _
   ByVal keepWhiteSpaces As Boolean, _
   ByVal breakLongWords As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim textToFit As String
Dim displayFont As PDFFont
Dim width As Single
Dim height As Single
Dim lineSpacing As Single
Dim firstLineIndent As Single
Dim keepWhiteSpaces As Boolean
Dim breakLongWords As Boolean
Dim value As Integer

value = PDFTextBox.FitText(textToFit, displayFont, width, height, lineSpacing, firstLineIndent, keepWhiteSpaces, breakLongWords)
C#
public static int FitText(
   string textToFit,
   PDFFont displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces,
   bool breakLongWords
)
Delphi
public function FitText(
    textToFit: String;
    displayFont: PDFFont;
    width: Single;
    height: Single;
    lineSpacing: Single;
    firstLineIndent: Single;
    keepWhiteSpaces: Boolean;
    breakLongWords: Boolean
): Integer; static;
Managed Extensions for C++
public: static int FitText(
   string* textToFit,
   PDFFont* displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces,
   bool breakLongWords
)
C++/CLI
public:
static int FitText(
   String^ textToFit,
   PDFFont^ displayFont,
   float width,
   float height,
   float lineSpacing,
   float firstLineIndent,
   bool keepWhiteSpaces,
   bool breakLongWords
)

Parameters

textToFit
the text to fit in the given area.
displayFont
the font used to display the text.
width
the width of the area.
height
the height of the area.
lineSpacing
the additional space between lines.
firstLineIndent
the indentation of the first line.
keepWhiteSpaces
a flag specifying whether the word wrapping should keep or not the white spaces.
breakLongWords
a flag specifying whether to consider long words breaking when measuring text to fit in the box.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextBox Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextBox Class

For a list of all members of this type, see PDFTextBox members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition.
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the textbox. Supported by Compact .NET Edition.
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ClipText | Gets or sets the clipping for the text Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the text. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | Height | Gets or sets the height of the text box. Supported by Compact .NET Edition.
Public Property | LastLineWidth | Gets the width of the last line of text.
Public Property | Left | Gets or sets the x coordinate of the top left corner Supported by Compact .NET Edition.
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition.
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | RequiredHeight | Gets the real height of the wrapped text. Supported by Compact .NET Edition.
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the text box. Supported by Compact .NET Edition.
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition. (Inherited from PDFText)
Public Property | TextFormatOptions | Gets or sets the text formatting options for the text box Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y coordinate of the top left corner. Supported by Compact .NET Edition.
Public Property | Width | Gets or sets the width of the text box. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextBox Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Align Property

Gets or sets the text alignment within the text box.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Align As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As TextAlign

instance.Align = value

value = instance.Align
C#
public TextAlign Align {get; set;}
Delphi
public read-write property Align: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_Align();
public: __property void set_Align(
   TextAlign value
);
C++/CLI
public:
property TextAlign Align {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text within the text box.

This property is obsolete and it is provided only for backwards compatibility. Use instead Align.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Bottom Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Bottom Property

Gets or sets the y-coordinate of the bottom right corner of the textbox.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Bottom = value

value = instance.Bottom
C#
public float Bottom {get; set;}
Delphi
public read-write property Bottom: Single;
Managed Extensions for C++
public: __property float get_Bottom();
public: __property void set_Bottom(
   float value
);
C++/CLI
public:
property float Bottom {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the bottom right corner of the textbox.

Exceptions

Exception | Description
ArgumentException | Thrown when Bottom is less than Top and Y axis direction is TopToBottom, or when Bottom is greater than Top and Y axis direction is BottomToTop.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

ClipText Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : ClipText Property

Gets or sets the clipping for the text

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property ClipText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Boolean

instance.ClipText = value

value = instance.ClipText
C#
public bool ClipText {get; set;}
Delphi
public read-write property ClipText: Boolean;
Managed Extensions for C++
public: __property bool get_ClipText();
public: __property void set_ClipText(
   bool value
);
C++/CLI
public:
property bool ClipText {
   bool get();
   void set (bool value);
}

Return Value

a boolean value specifying whether the text is clipped by the bounding rectangle or it can flow outside the text box.

Remarks

This property is obsolete and it is provided only for backwards compatibility. Use instead ClipText.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Height Property

Gets or sets the height of the text box.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Delphi
public read-write property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (float value);
}

Return Value

a float value representing the height of the text box.

Exceptions

Exception | Description
ArgumentException | Thrown when assigned value is less than 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

LastLineWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : LastLineWidth Property

Gets the width of the last line of text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastLineWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

value = instance.LastLineWidth
C#
public float LastLineWidth {get;}
Delphi
public read-only property LastLineWidth: Single;
Managed Extensions for C++
public: __property float get_LastLineWidth();
C++/CLI
public:
property float LastLineWidth {
   float get();
}

Return Value

a float value specifying the width of the last line of text in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Left Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Left Property

Gets or sets the x coordinate of the top left corner

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}
Delphi
public read-write property Left: Single;
Managed Extensions for C++
public: __property float get_Left();
public: __property void set_Left(
   float value
);
C++/CLI
public:
property float Left {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the top left corner of the text box.

Exceptions

Exception | Description
ArgumentException | Thrown when Left is greater than Right and X axis direction is LeftToRight, or when Left is less than Right and X axis direction is RightToLeft.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

LineSpacing Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : LineSpacing Property

Gets or sets the line spacing.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.LineSpacing = value

value = instance.LineSpacing
C#
public float LineSpacing {get; set;}
Delphi
public read-write property LineSpacing: Single;
Managed Extensions for C++
public: __property float get_LineSpacing();
public: __property void set_LineSpacing(
   float value
);
C++/CLI
public:
property float LineSpacing {
   float get();
   void set (float value);
}

Return Value

a float value specifying the additional space to be added between lines of text.

Remarks

If this value is negative, then the lines of text will be drawn closer. The value of this property is expressed in points.

This property is obsolete and it is provided only for backwards compatibility. Use instead LineSpacing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Orientation Property

Gets or sets the text box orientation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value specifying the rotation angle of the text box.

Remarks

The text boxes are always rotated around the top left corner.

This property is obsolete and it is provided only for backwards compatibility. Use instead Orientation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

RequiredHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : RequiredHeight Property

Gets the real height of the wrapped text.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RequiredHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

value = instance.RequiredHeight
C#
public float RequiredHeight {get;}
Delphi
public read-only property RequiredHeight: Single;
Managed Extensions for C++
public: __property float get_RequiredHeight();
C++/CLI
public:
property float RequiredHeight {
   float get();
}

Return Value

a float value specifying the necessary height of the text box in order to display the whole text.

Remarks

The calculation of the required height is based on current font and line spacing. If the text box is not attached to the canvas, then its width and height are considered to be points. If the text box is attached to the canvas, then its width and height are considered to be given in canvas' logical units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Right Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Right Property

Gets or sets the x-coordinate of the bottom right corner of the text box.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Right = value

value = instance.Right
C#
public float Right {get; set;}
Delphi
public read-write property Right: Single;
Managed Extensions for C++
public: __property float get_Right();
public: __property void set_Right(
   float value
);
C++/CLI
public:
property float Right {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the bottom right corner of the text box.

Exceptions

Exception | Description
ArgumentException | Thrown when Right is less than Left and X axis direction is LeftToRight, or when Right is greater than Left and X axis direction is RightToLeft.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

TextFormatOptions Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : TextFormatOptions Property

Gets or sets the text formatting options for the text box

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TextFormatOptions As PDFTextFormatOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As PDFTextFormatOptions

instance.TextFormatOptions = value

value = instance.TextFormatOptions
C#
public PDFTextFormatOptions TextFormatOptions {get; set;}
Delphi
public read-write property TextFormatOptions: PDFTextFormatOptions;
Managed Extensions for C++
public: __property PDFTextFormatOptions* get_TextFormatOptions();
public: __property void set_TextFormatOptions(
   PDFTextFormatOptions* value
);
C++/CLI
public:
property PDFTextFormatOptions^ TextFormatOptions {
   PDFTextFormatOptions^ get();
   void set (PDFTextFormatOptions^ value);
}

Return Value

A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Top Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Top Property

Gets or sets the y coordinate of the top left corner.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}
Delphi
public read-write property Top: Single;
Managed Extensions for C++
public: __property float get_Top();
public: __property void set_Top(
   float value
);
C++/CLI
public:
property float Top {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the top left corner of the text box.

Exceptions

Exception | Description
ArgumentException | Thrown when Top is greater than Bottom and Y axis direction is TopToBottom, or when Top is less than Bottom and Y axis direction is BottomToTop.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextBox Class : Width Property

Gets or sets the width of the text box.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBox
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Delphi
public read-write property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (float value);
}

Return Value

a float value representing the width of the text box.

Exceptions

Exception | Description
ArgumentException | Thrown when assigned value is less than 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBox Class
PDFTextBox Members


%%PageItemTitle%%

PDFTextDocLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextDocLink Class

Defines a line of text on the page that acts a link to another page within the same document

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextDocLink
   Inherits PDFAreaDocLink
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
C#
public class PDFTextDocLink : PDFAreaDocLink
Delphi
public class PDFTextDocLink = class(PDFAreaDocLink)
Managed Extensions for C++
public __gc class PDFTextDocLink : public PDFAreaDocLink
C++/CLI
public ref class PDFTextDocLink : public PDFAreaDocLink

Remarks

This class allows to defines text hyperlinks within the same document. The source of the hyperlink is defined by the bounding rectangle of the text. The destination of the hyperlink is defined by a destination page and a position of the destination page in the viewer.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextDocLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextDocLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextDocLink Class

The following tables list the members exposed by PDFTextDocLink.

Public Constructors

 | Name | Description
Public Constructor | PDFTextDocLink Constructor | Overloaded. Initializes a new PDFTextDocLink object specifying a printing point, a text and a destination Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | DestinationPage | Get or sets the destination page of the link Supported by Compact .NET Edition. (Inherited from PDFAreaDocLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition. (Inherited from PDFAreaDocLink)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextDocLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : PDFTextDocLink Constructor

Initializes a new PDFTextDocLink object specifying a printing point, a text and a destination

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFTextDocLink Constructor() | Initializes a new PDFTextDocLink object.
PDFTextDocLink Constructor(PDFPage,Single,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) | Initializes a new PDFTextDocLink object specifying a printing point, a text and a destination Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

PDFTextDocLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class > PDFTextDocLink Constructor : PDFTextDocLink Constructor()

Initializes a new PDFTextDocLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink()
C#
public PDFTextDocLink()
Delphi
public PDFTextDocLink();
Managed Extensions for C++
public: PDFTextDocLink();
C++/CLI
public:
PDFTextDocLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members
Overload List


%%PageItemTitle%%

PDFTextDocLink Constructor(PDFPage,Single,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class > PDFTextDocLink Constructor : PDFTextDocLink Constructor(PDFPage,Single,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)

destinationPage
a PDFPage object representing the destination of the hyperlink.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link.
text
the line of text representing the link.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFTextDocLink object specifying a printing point, a text and a destination

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Single, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim destinationPage As PDFPage
Dim topDestination As Single
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

Dim instance As PDFTextDocLink(destinationPage, topDestination, text, font, pen, brush, x, y, align, borderPen)
C#
public PDFTextDocLink(
   PDFPage destinationPage,
   float topDestination,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public PDFTextDocLink(
    destinationPage: PDFPage;
    topDestination: Single;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFTextDocLink(
   PDFPage* destinationPage,
   float topDestination,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
PDFTextDocLink(
   PDFPage^ destinationPage,
   float topDestination,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

destinationPage
a PDFPage object representing the destination of the hyperlink.
topDestination
a float value specifying the vertical position of the destination page when it is displayed as the result of using the link.
text
the line of text representing the link.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextDocLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextDocLink Class

For a list of all members of this type, see PDFTextDocLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | DestinationPage | Get or sets the destination page of the link Supported by Compact .NET Edition. (Inherited from PDFAreaDocLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | TopDestination | Gets or sets the vertical position of the destination page. Supported by Compact .NET Edition. (Inherited from PDFAreaDocLink)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : Brush Property

Gets or sets the brush used to fill the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

A PDFBrush object used to fill the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : Font Property

Gets or sets the font used to draw the text

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : Pen Property

Gets or sets the pen used to draw the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object used to draw the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : Text Property

Gets or sets the text to be drawn.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the text to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

TextAlign Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : TextAlign Property

Gets or sets the text alignment

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As TextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public TextAlign TextAlign {get; set;}
Delphi
public read-write property TextAlign: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_TextAlign();
public: __property void set_TextAlign(
   TextAlign value
);
C++/CLI
public:
property TextAlign TextAlign {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : X Property

Gets or sets the x coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the printing point.

Remarks

The text is aligned on horizontal relative to this value. If the text is left aligned, then this property specifies the x coordinate of the left corner of the text bounding rectangle. If the text is center aligned, then this property specifies the x coordinate of the center of the text bounding rectangle. If the text is right aligned, then this property specifies the x coordinate of the right corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextDocLink Class : Y Property

Gets or sets the y coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextDocLink
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the printing point.

Remarks

The text is aligned on vertical relative to this value. If the text is top aligned, then this property specifies the y coordinate of the top corner of the text bounding rectangle. If the text is middle aligned, then this property specifies the y coordinate of the middle of the text bounding rectangle. If the text is bottom aligned, then this property specifies the y coordinate of the bottom corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextDocLink Class
PDFTextDocLink Members


%%PageItemTitle%%

PDFTextFileLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFileLink Class

Defines a line of text on the page that acts a link to an external file

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextFileLink
   Inherits PDFAreaFileLink
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
C#
public class PDFTextFileLink : PDFAreaFileLink
Delphi
public class PDFTextFileLink = class(PDFAreaFileLink)
Managed Extensions for C++
public __gc class PDFTextFileLink : public PDFAreaFileLink
C++/CLI
public ref class PDFTextFileLink : public PDFAreaFileLink

Remarks

This class allows to defines text hyperlinks to external files. The source of the hyperlink is defined by the bounding rectangle of the text. The destination of the hyperlink is defined by a file path.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFileLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextFileLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFileLink Class

The following tables list the members exposed by PDFTextFileLink.

Public Constructors

 | Name | Description
Public Constructor | PDFTextFileLink Constructor | Overloaded. Initializes a new PDFTextFileLink object.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | FilePath | Get or sets the file path. Supported by Compact .NET Edition. (Inherited from PDFAreaFileLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextFileLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextFileLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : PDFTextFileLink Constructor

Initializes a new PDFTextFileLink object.

Overload List

Overload | Description
PDFTextFileLink Constructor() | Initializes a new PDFTextFileLink object.
PDFTextFileLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) | Initializes a new PDFTextFileLink object specifying a printing point, a text and a destination. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

PDFTextFileLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class > PDFTextFileLink Constructor : PDFTextFileLink Constructor()

Initializes a new PDFTextFileLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink()
C#
public PDFTextFileLink()
Delphi
public PDFTextFileLink();
Managed Extensions for C++
public: PDFTextFileLink();
C++/CLI
public:
PDFTextFileLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members
Overload List


%%PageItemTitle%%

PDFTextFileLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class > PDFTextFileLink Constructor : PDFTextFileLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)

filePath
a file path representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFTextFileLink object specifying a printing point, a text and a destination.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim filePath As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

Dim instance As PDFTextFileLink(filePath, text, font, pen, brush, x, y, align, borderPen)
C#
public PDFTextFileLink(
   string filePath,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public PDFTextFileLink(
    filePath: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFTextFileLink(
   string* filePath,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
PDFTextFileLink(
   String^ filePath,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

filePath
a file path representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextFileLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFileLink Class

For a list of all members of this type, see PDFTextFileLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | FilePath | Get or sets the file path. Supported by Compact .NET Edition. (Inherited from PDFAreaFileLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextFileLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : Brush Property

Gets or sets the brush used to fill the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

A PDFBrush object used to fill the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : Font Property

Gets or sets the font used to draw the text

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : Pen Property

Gets or sets the pen used to draw the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object used to draw the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : Text Property

Gets or sets the text to be drawn.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the text to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

TextAlign Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : TextAlign Property

Gets or sets the text alignment

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As TextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public TextAlign TextAlign {get; set;}
Delphi
public read-write property TextAlign: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_TextAlign();
public: __property void set_TextAlign(
   TextAlign value
);
C++/CLI
public:
property TextAlign TextAlign {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : X Property

Gets or sets the x coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the printing point.

Remarks

The text is aligned on horizontal relative to this value. If the text is left aligned, then this property specifies the x coordinate of the left corner of the text bounding rectangle. If the text is center aligned, then this property specifies the x coordinate of the center of the text bounding rectangle. If the text is right aligned, then this property specifies the x coordinate of the right corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFileLink Class : Y Property

Gets or sets the y coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFileLink
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the printing point.

Remarks

The text is aligned on vertical relative to this value. If the text is top aligned, then this property specifies the y coordinate of the top corner of the text bounding rectangle. If the text is middle aligned, then this property specifies the y coordinate of the middle of the text bounding rectangle. If the text is bottom aligned, then this property specifies the y coordinate of the bottom corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFileLink Class
PDFTextFileLink Members


%%PageItemTitle%%

PDFTextFormatOptions Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

Defines the available formatting options for a text box

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFTextFormatOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
C#
public class PDFTextFormatOptions
Delphi
public class PDFTextFormatOptions
Managed Extensions for C++
public __gc class PDFTextFormatOptions
C++/CLI
public ref class PDFTextFormatOptions

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextFormatOptions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

The following tables list the members exposed by PDFTextFormatOptions.

Public Constructors

 | Name | Description
Public Constructor | PDFTextFormatOptions Constructor | Initializes a new PDFTextFormatOptions object.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box Supported by Compact .NET Edition.
Public Property | FirstLineIndent | Gets or sets the first line indentation. Supported by Compact .NET Edition.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text. Supported by Compact .NET Edition.
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextFormatOptions Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : PDFTextFormatOptions Constructor

Initializes a new PDFTextFormatOptions object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions()
C#
public PDFTextFormatOptions()
Delphi
public PDFTextFormatOptions();
Managed Extensions for C++
public: PDFTextFormatOptions();
C++/CLI
public:
PDFTextFormatOptions();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%% $$Properties$$

PDFTextFormatOptions Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

For a list of all members of this type, see PDFTextFormatOptions members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box. Supported by Compact .NET Edition.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box Supported by Compact .NET Edition.
Public Property | FirstLineIndent | Gets or sets the first line indentation. Supported by Compact .NET Edition.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text. Supported by Compact .NET Edition.
Public Property | LineSpacing | Gets or sets the line spacing. Supported by Compact .NET Edition.
Public Property | Orientation | Gets or sets the text box orientation. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Align Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Align Property

Gets or sets the text alignment within the text box.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Align As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As TextAlign

instance.Align = value

value = instance.Align
C#
public TextAlign Align {get; set;}
Delphi
public read-write property Align: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_Align();
public: __property void set_Align(
   TextAlign value
);
C++/CLI
public:
property TextAlign Align {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text within the text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

BreakLongWords Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : BreakLongWords Property

Gets or sets whether to break no spaced text at character level.

Syntax

Visual Basic (Declaration)
Public Property BreakLongWords As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.BreakLongWords = value

value = instance.BreakLongWords
C#
public bool BreakLongWords {get; set;}
Delphi
public read-write property BreakLongWords: Boolean;
Managed Extensions for C++
public: __property bool get_BreakLongWords();
public: __property void set_BreakLongWords(
   bool value
);
C++/CLI
public:
property bool BreakLongWords {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying whether to break no spaced text at character level.

Remarks

This property allows to perform text wrapping at character level, not only at word level. It applies only if the first word in a line is longer than the available width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

ClipText Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : ClipText Property

Gets or sets the text clipping mode for the text box

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property ClipText As ClipText
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As ClipText

instance.ClipText = value

value = instance.ClipText
C#
public ClipText ClipText {get; set;}
Delphi
public read-write property ClipText: ClipText;
Managed Extensions for C++
public: __property ClipText get_ClipText();
public: __property void set_ClipText(
   ClipText value
);
C++/CLI
public:
property ClipText ClipText {
   ClipText get();
   void set (ClipText value);
}

Return Value

a ClipText enumeration member specifying how the text within the text box should be clipped at box boundary.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

FirstLineIndent Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : FirstLineIndent Property

Gets or sets the first line indentation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FirstLineIndent As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Single

instance.FirstLineIndent = value

value = instance.FirstLineIndent
C#
public float FirstLineIndent {get; set;}
Delphi
public read-write property FirstLineIndent: Single;
Managed Extensions for C++
public: __property float get_FirstLineIndent();
public: __property void set_FirstLineIndent(
   float value
);
C++/CLI
public:
property float FirstLineIndent {
   float get();
   void set (float value);
}

Return Value

a float value specifying the indentation of the first line.

Remarks

This value allows the indent the first line of a text box. Also, this value is used to indent the next line when a new line has been requested by the \n character, or <br/> tag in a HTML text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

KeepWhiteSpaces Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : KeepWhiteSpaces Property

Gets or sets whether the white spaces are kept within the text.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property KeepWhiteSpaces As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.KeepWhiteSpaces = value

value = instance.KeepWhiteSpaces
C#
public bool KeepWhiteSpaces {get; set;}
Delphi
public read-write property KeepWhiteSpaces: Boolean;
Managed Extensions for C++
public: __property bool get_KeepWhiteSpaces();
public: __property void set_KeepWhiteSpaces(
   bool value
);
C++/CLI
public:
property bool KeepWhiteSpaces {
   bool get();
   void set (bool value);
}

Return Value

a bool value specifying whether the white spaces are kept within the text.

Remarks

This property allows to align text using whitespaces (blanks or tabs). It is useful when using a monospaced font like Courier.

This property has effect only on regular text boxes when using left, center or right alignments. Justified text ignores the value of this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

LineSpacing Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : LineSpacing Property

Gets or sets the line spacing.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Single

instance.LineSpacing = value

value = instance.LineSpacing
C#
public float LineSpacing {get; set;}
Delphi
public read-write property LineSpacing: Single;
Managed Extensions for C++
public: __property float get_LineSpacing();
public: __property void set_LineSpacing(
   float value
);
C++/CLI
public:
property float LineSpacing {
   float get();
   void set (float value);
}

Return Value

a float value specifying the additional space to be added between lines of text.

Remarks

If this value is negative, then the lines of text will be drawn closer. The value of this property is given in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Orientation Property

Gets or sets the text box orientation.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Single

instance.Orientation = value

value = instance.Orientation
C#
public float Orientation {get; set;}
Delphi
public read-write property Orientation: Single;
Managed Extensions for C++
public: __property float get_Orientation();
public: __property void set_Orientation(
   float value
);
C++/CLI
public:
property float Orientation {
   float get();
   void set (float value);
}

Return Value

a float value specifying the rotation angle of the text box.

Remarks

The text boxes are always rotated around the top left corner.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

PDFTextRemoteDocLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextRemoteDocLink Class

Defines a line of text on the page that acts a link to another pdf file

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextRemoteDocLink
   Inherits PDFAreaRemoteDocLink
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
C#
public class PDFTextRemoteDocLink : PDFAreaRemoteDocLink
Delphi
public class PDFTextRemoteDocLink = class(PDFAreaRemoteDocLink)
Managed Extensions for C++
public __gc class PDFTextRemoteDocLink : public PDFAreaRemoteDocLink
C++/CLI
public ref class PDFTextRemoteDocLink : public PDFAreaRemoteDocLink

Remarks

This class allows to defines text hyperlinks to other pdf files. The source of the hyperlink is defined by the bounding rectangle of the text. The destination of the hyperlink is defined by a document path.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextRemoteDocLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextRemoteDocLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextRemoteDocLink Class

The following tables list the members exposed by PDFTextRemoteDocLink.

Public Constructors

 | Name | Description
Public Constructor | PDFTextRemoteDocLink Constructor | Overloaded. Initializes a new PDFTextRemoteDocLink object specifying a printing point, a text and a destination. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | DocumentPath | Get or sets the document path. Supported by Compact .NET Edition. (Inherited from PDFAreaRemoteDocLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | OpenInNewWindow | Gets or sets whether the new document should be opened in a new window. (Inherited from PDFAreaRemoteDocLink)
Public Property | PageNumber | Gets or sets the destination page in the remote document. (Inherited from PDFAreaRemoteDocLink)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextRemoteDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextRemoteDocLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : PDFTextRemoteDocLink Constructor

Initializes a new PDFTextRemoteDocLink object specifying a printing point, a text and a destination.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFTextRemoteDocLink Constructor() | Initializes a new PDFTextRemoteDocLink object.
PDFTextRemoteDocLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) | Initializes a new PDFTextRemoteDocLink object specifying a printing point, a text and a destination. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

PDFTextRemoteDocLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class > PDFTextRemoteDocLink Constructor : PDFTextRemoteDocLink Constructor()

Initializes a new PDFTextRemoteDocLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink()
C#
public PDFTextRemoteDocLink()
Delphi
public PDFTextRemoteDocLink();
Managed Extensions for C++
public: PDFTextRemoteDocLink();
C++/CLI
public:
PDFTextRemoteDocLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members
Overload List


%%PageItemTitle%%

PDFTextRemoteDocLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class > PDFTextRemoteDocLink Constructor : PDFTextRemoteDocLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)

documentPath
a document path representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFTextRemoteDocLink object specifying a printing point, a text and a destination.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal documentPath As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim documentPath As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

Dim instance As PDFTextRemoteDocLink(documentPath, text, font, pen, brush, x, y, align, borderPen)
C#
public PDFTextRemoteDocLink(
   string documentPath,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public PDFTextRemoteDocLink(
    documentPath: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFTextRemoteDocLink(
   string* documentPath,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
PDFTextRemoteDocLink(
   String^ documentPath,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

documentPath
a document path representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextRemoteDocLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextRemoteDocLink Class

For a list of all members of this type, see PDFTextRemoteDocLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | DocumentPath | Get or sets the document path. Supported by Compact .NET Edition. (Inherited from PDFAreaRemoteDocLink)
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | OpenInNewWindow | Gets or sets whether the new document should be opened in a new window. (Inherited from PDFAreaRemoteDocLink)
Public Property | PageNumber | Gets or sets the destination page in the remote document. (Inherited from PDFAreaRemoteDocLink)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextRemoteDocLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : Brush Property

Gets or sets the brush used to fill the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

A PDFBrush object used to fill the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : Font Property

Gets or sets the font used to draw the text

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : Pen Property

Gets or sets the pen used to draw the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object used to draw the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : Text Property

Gets or sets the text to be drawn.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the text to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

TextAlign Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : TextAlign Property

Gets or sets the text alignment

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As TextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public TextAlign TextAlign {get; set;}
Delphi
public read-write property TextAlign: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_TextAlign();
public: __property void set_TextAlign(
   TextAlign value
);
C++/CLI
public:
property TextAlign TextAlign {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : X Property

Gets or sets the x coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the printing point.

Remarks

The text is aligned on horizontal relative to this value. If the text is left aligned, then this property specifies the x coordinate of the left corner of the text bounding rectangle. If the text is center aligned, then this property specifies the x coordinate of the center of the text bounding rectangle. If the text is right aligned, then this property specifies the x coordinate of the right corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextRemoteDocLink Class : Y Property

Gets or sets the y coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRemoteDocLink
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the printing point.

Remarks

The text is aligned on vertical relative to this value. If the text is top aligned, then this property specifies the y coordinate of the top corner of the text bounding rectangle. If the text is middle aligned, then this property specifies the y coordinate of the middle of the text bounding rectangle. If the text is bottom aligned, then this property specifies the y coordinate of the bottom corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRemoteDocLink Class
PDFTextRemoteDocLink Members


%%PageItemTitle%%

PDFTextWebLink Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextWebLink Class

Defines a line of text on the page that acts a link to a web location

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextWebLink
   Inherits PDFAreaWebLink
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
C#
public class PDFTextWebLink : PDFAreaWebLink
Delphi
public class PDFTextWebLink = class(PDFAreaWebLink)
Managed Extensions for C++
public __gc class PDFTextWebLink : public PDFAreaWebLink
C++/CLI
public ref class PDFTextWebLink : public PDFAreaWebLink

Remarks

This class allows to defines text hyperlinks to web locations. The source of the hyperlink is defined by a rectangular area. The destination of the hyperlink is defined by a URL.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Graphics.PDFGraphic
O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextWebLink

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextWebLink Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextWebLink Class

The following tables list the members exposed by PDFTextWebLink.

Public Constructors

 | Name | Description
Public Constructor | PDFTextWebLink Constructor | Overloaded. Initializes a new PDFTextWebLink object.
Top

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | URL | Get or sets the destination web location of the link. Supported by Compact .NET Edition. (Inherited from PDFAreaWebLink)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextWebLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextWebLink Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : PDFTextWebLink Constructor

Initializes a new PDFTextWebLink object.

Overload List

Overload | Description
PDFTextWebLink Constructor() | Initializes a new PDFTextWebLink object.
PDFTextWebLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen) | Initializes a new PDFTextWebLink object specifying a printing point, a text and a destination. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

PDFTextWebLink Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class > PDFTextWebLink Constructor : PDFTextWebLink Constructor()

Initializes a new PDFTextWebLink object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink()
C#
public PDFTextWebLink()
Delphi
public PDFTextWebLink();
Managed Extensions for C++
public: PDFTextWebLink();
C++/CLI
public:
PDFTextWebLink();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members
Overload List


%%PageItemTitle%%

PDFTextWebLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class > PDFTextWebLink Constructor : PDFTextWebLink Constructor(String,String,PDFFont,PDFPen,PDFBrush,Single,Single,TextAlign,PDFPen)

url
a web location (HTTP/HTTPS URL) representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link
Initializes a new PDFTextWebLink object specifying a printing point, a text and a destination.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal url As String, _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal align As TextAlign, _
   ByVal borderPen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim url As String
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Single
Dim y As Single
Dim align As TextAlign
Dim borderPen As PDFPen

Dim instance As PDFTextWebLink(url, text, font, pen, brush, x, y, align, borderPen)
C#
public PDFTextWebLink(
   string url,
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   float x,
   float y,
   TextAlign align,
   PDFPen borderPen
)
Delphi
public PDFTextWebLink(
    url: String;
    text: String;
    font: PDFFont;
    pen: PDFPen;
    brush: PDFBrush;
    x: Single;
    y: Single;
    align: TextAlign;
    borderPen: PDFPen
);
Managed Extensions for C++
public: PDFTextWebLink(
   string* url,
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   float x,
   float y,
   TextAlign align,
   PDFPen* borderPen
)
C++/CLI
public:
PDFTextWebLink(
   String^ url,
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   float x,
   float y,
   TextAlign align,
   PDFPen^ borderPen
)

Parameters

url
a web location (HTTP/HTTPS URL) representing the destination of the hyperlink
text
the line of text representing the hyperlink.
font
a Font object used to draw the text.
pen
a Pen object used to draw the border of the text.
brush
a Brush object used to fill the text.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
align
the alignment of the text.
borderPen
the PDFPen object used to draw the border of the link

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextWebLink Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextWebLink Class

For a list of all members of this type, see PDFTextWebLink members.

Public Properties

 | Name | Description
Public Property | BorderPen | Get or sets the pen used to draw the border of the link area. Supported by Compact .NET Edition. (Inherited from PDFLink)
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the text of the link. Supported by Compact .NET Edition.
Public Property | Font | Gets or sets the font used to draw the text Supported by Compact .NET Edition.
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the text of the link. Supported by Compact .NET Edition.
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Text | Gets or sets the text to be drawn. Supported by Compact .NET Edition.
Public Property | TextAlign | Gets or sets the text alignment Supported by Compact .NET Edition.
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | URL | Get or sets the destination web location of the link. Supported by Compact .NET Edition. (Inherited from PDFAreaWebLink)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | X | Gets or sets the x coordinate of the printing point Supported by Compact .NET Edition.
Public Property | Y | Gets or sets the y coordinate of the printing point Supported by Compact .NET Edition.
Top

See Also

Reference

PDFTextWebLink Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

Brush Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : Brush Property

Gets or sets the brush used to fill the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Delphi
public read-write property Brush: PDFBrush;
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

A PDFBrush object used to fill the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : Font Property

Gets or sets the font used to draw the text

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFont
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As PDFFont

instance.Font = value

value = instance.Font
C#
public PDFFont Font {get; set;}
Delphi
public read-write property Font: PDFFont;
Managed Extensions for C++
public: __property PDFFont* get_Font();
public: __property void set_Font(
   PDFFont* value
);
C++/CLI
public:
property PDFFont^ Font {
   PDFFont^ get();
   void set (PDFFont^ value);
}

Return Value

a Font object used to draw the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

Pen Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : Pen Property

Gets or sets the pen used to draw the text of the link.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Delphi
public read-write property Pen: PDFPen;
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

A PDFPen object used to draw the text of the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

Text Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : Text Property

Gets or sets the text to be drawn.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Delphi
public read-write property Text: String;
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

a string value specifying the text to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

TextAlign Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : TextAlign Property

Gets or sets the text alignment

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As TextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As TextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public TextAlign TextAlign {get; set;}
Delphi
public read-write property TextAlign: TextAlign;
Managed Extensions for C++
public: __property TextAlign get_TextAlign();
public: __property void set_TextAlign(
   TextAlign value
);
C++/CLI
public:
property TextAlign TextAlign {
   TextAlign get();
   void set (TextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : X Property

Gets or sets the x coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As Single

instance.X = value

value = instance.X
C#
public float X {get; set;}
Delphi
public read-write property X: Single;
Managed Extensions for C++
public: __property float get_X();
public: __property void set_X(
   float value
);
C++/CLI
public:
property float X {
   float get();
   void set (float value);
}

Return Value

a float value specifying the x coordinate of the printing point.

Remarks

The text is aligned on horizontal relative to this value. If the text is left aligned, then this property specifies the x coordinate of the left corner of the text bounding rectangle. If the text is center aligned, then this property specifies the x coordinate of the center of the text bounding rectangle. If the text is right aligned, then this property specifies the x coordinate of the right corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextWebLink Class : Y Property

Gets or sets the y coordinate of the printing point

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFTextWebLink
Dim value As Single

instance.Y = value

value = instance.Y
C#
public float Y {get; set;}
Delphi
public read-write property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
public: __property void set_Y(
   float value
);
C++/CLI
public:
property float Y {
   float get();
   void set (float value);
}

Return Value

a float value specifying the y coordinate of the printing point.

Remarks

The text is aligned on vertical relative to this value. If the text is top aligned, then this property specifies the y coordinate of the top corner of the text bounding rectangle. If the text is middle aligned, then this property specifies the y coordinate of the middle of the text bounding rectangle. If the text is bottom aligned, then this property specifies the y coordinate of the bottom corner of the text bounding rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextWebLink Class
PDFTextWebLink Members


%%PageItemTitle%%

XFORM Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : XFORM Class

Syntax

Visual Basic (Declaration)
Public Class XFORM
Visual Basic (Usage) Copy Code
Dim instance As XFORM
C#
public class XFORM
Delphi
public class XFORM
Managed Extensions for C++
public __gc class XFORM
C++/CLI
public ref class XFORM

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.XFORM

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

XFORM Class Members
See Also Fields
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : XFORM Class

The following tables list the members exposed by XFORM.

Public Constructors

 | Name | Description
Public Constructor | XFORM Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | eDx |
Public Field | eDy |
Public Field | eM11 |
Public Field | eM12 |
Public Field | eM21 |
Public Field | eM22 |
Top

See Also

Reference

XFORM Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

XFORM Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : XFORM Constructor

Overload List

Overload | Description
XFORM Constructor() |
XFORM Constructor(Single[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

XFORM Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class > XFORM Constructor : XFORM Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As XFORM()
C#
public XFORM()
Delphi
public XFORM();
Managed Extensions for C++
public: XFORM();
C++/CLI
public:
XFORM();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members
Overload List


%%PageItemTitle%%

XFORM Constructor(Single[])
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class > XFORM Constructor : XFORM Constructor(Single[])

elements

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal elements() As Single _
)
Visual Basic (Usage) Copy Code
Dim elements() As Single

Dim instance As XFORM(elements)
C#
public XFORM(
   float[] elements
)
Delphi
public XFORM(
    elements: Singlearray of
);
Managed Extensions for C++
public: XFORM(
   float[]* elements
)
C++/CLI
public:
XFORM(
   array<float>^ elements
)

Parameters

elements

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members
Overload List


%%PageItemTitle%% $$Fields$$

XFORM Class Fields
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : XFORM Class

For a list of all members of this type, see XFORM members.

Public Fields

 | Name | Description
Public Field | eDx |
Public Field | eDy |
Public Field | eM11 |
Public Field | eM12 |
Public Field | eM21 |
Public Field | eM22 |
Top

See Also

Reference

XFORM Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

eDx Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eDx Field

Syntax

Visual Basic (Declaration)
Public eDx As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eDx

instance.eDx = value
C#
public float eDx
Delphi
public field eDx: Single;
Managed Extensions for C++
public: float eDx
C++/CLI
public:
float eDx

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

eDy Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eDy Field

Syntax

Visual Basic (Declaration)
Public eDy As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eDy

instance.eDy = value
C#
public float eDy
Delphi
public field eDy: Single;
Managed Extensions for C++
public: float eDy
C++/CLI
public:
float eDy

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

eM11 Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eM11 Field

Syntax

Visual Basic (Declaration)
Public eM11 As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eM11

instance.eM11 = value
C#
public float eM11
Delphi
public field eM11: Single;
Managed Extensions for C++
public: float eM11
C++/CLI
public:
float eM11

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

eM12 Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eM12 Field

Syntax

Visual Basic (Declaration)
Public eM12 As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eM12

instance.eM12 = value
C#
public float eM12
Delphi
public field eM12: Single;
Managed Extensions for C++
public: float eM12
C++/CLI
public:
float eM12

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

eM21 Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eM21 Field

Syntax

Visual Basic (Declaration)
Public eM21 As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eM21

instance.eM21 = value
C#
public float eM21
Delphi
public field eM21: Single;
Managed Extensions for C++
public: float eM21
C++/CLI
public:
float eM21

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

eM22 Field
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > XFORM Class : eM22 Field

Syntax

Visual Basic (Declaration)
Public eM22 As Single
Visual Basic (Usage) Copy Code
Dim instance As XFORM
Dim value As Single

value = instance.eM22

instance.eM22 = value
C#
public float eM22
Delphi
public field eM22: Single;
Managed Extensions for C++
public: float eM22
C++/CLI
public:
float eM22

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFORM Class
XFORM Members


%%PageItemTitle%%

BlendMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : BlendMode Enumeration

Specifies the available blend modes.

Syntax

Visual Basic (Declaration)
Public Enum BlendMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BlendMode
C#
public enum BlendMode : Enum
Delphi
public enum BlendMode = class(Enum)
Managed Extensions for C++
__value public enum BlendMode : public Enum
C++/CLI
public enum class BlendMode : public Enum

Members

Member | Description
None | Same as Normal, but for internal library use.
Normal | Selects the source color.
Multiply | Multiplies the backdrop and source color.
Screen | Multiplies the complements of backdrop and source color values, and then complements the result.
Overlay | Multiplies or screens the colors depending on the backdrop color.
Darken | Selects the darker of the backdrop and source colors.
Lighten | Selects the lighter of the backdrop and source colors.
ColorDodge | Brightens the backdrop color to reflect the source color.
ColorBurn | Darkens the backdrop color to reflect the source color.
HardLight | Multiplies or screens the colors depending on the source color.
SoftLight | Darkens or lightens the colors depending on the source color.
Difference | Subtracts the darker of the two constituents colors from the lighter.
Exclusion | Same as Difference, but lower in contrast.
Hue | Creates a color with the hue of the source color and the saturation and luminance of the backdrop color.
Saturation | Creates a color with the saturation of the source color and the hue and luminance of the backdrop color.
Color | Creates a color with the saturation and hue of the source color and the luminance of the backdrop color.
Luminosity | Creates a color with the luminance of the source color and the saturation and hue of the backdrop color.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.BlendMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

ClipText Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : ClipText Enumeration

Specifies the available cliping modes when displaying a text box

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum ClipText
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ClipText
C#
public enum ClipText : Enum
Delphi
public enum ClipText = class(Enum)
Managed Extensions for C++
__value public enum ClipText : public Enum
C++/CLI
public enum class ClipText : public Enum

Members

Member | Description
ClipNone | The text is not clipped, it can flow outside the text box when text lines height is greater than text box height. Supported by Compact .NET Edition.
ClipGlyphs | The text is clipped at text box boundary allowing partial text lines to be displayed within the text box. Supported by Compact .NET Edition.
ClipWords | The text is logically clipped at word level, only the fully visible lines of text are displayed within the text box. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.ClipText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

FillMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : FillMode Enumeration

Specifies the available fill modes for a complex shape.

Syntax

Visual Basic (Declaration)
Public Enum FillMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FillMode
C#
public enum FillMode : Enum
Delphi
public enum FillMode = class(Enum)
Managed Extensions for C++
__value public enum FillMode : public Enum
C++/CLI
public enum class FillMode : public Enum

Members

Member | Description
NonZeroWinding | Non zero winding rule for filling the polygons.
EvenOdd | Even-odd rule for filling the polygons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.FillMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

ImageCompression Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : ImageCompression Enumeration

Specifies the available compression methods for storing an image in the PDF file.

Syntax

Visual Basic (Declaration)
Public Enum ImageCompression
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageCompression
C#
public enum ImageCompression : Enum
Delphi
public enum ImageCompression = class(Enum)
Managed Extensions for C++
__value public enum ImageCompression : public Enum
C++/CLI
public enum class ImageCompression : public Enum

Members

Member | Description
Deflate | The image data is compressed using DEFLATE method.
JPEG | The image data is compressed using JPEG (DCT) method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.ImageCompression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

KeepAspectRatio Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : KeepAspectRatio Enumeration

Specifies the available modes to resize an image when it is drawn on the page.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum KeepAspectRatio
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As KeepAspectRatio
C#
public enum KeepAspectRatio : Enum
Delphi
public enum KeepAspectRatio = class(Enum)
Managed Extensions for C++
__value public enum KeepAspectRatio : public Enum
C++/CLI
public enum class KeepAspectRatio : public Enum

Members

Member | Description
KeepNone | The image is drawn on the page using the specified Width and Height values. Supported by Compact .NET Edition.
KeepWidth | The image is drawn on the page using the specified Width. The Height is automatically computed in order to keep the original aspect ratio of the image. Supported by Compact .NET Edition.
KeepHeight | The image is drawn on the page using the specified Height. The Width is automatically computed in order to keep the original aspect ratio of the image. Supported by Compact .NET Edition.
KeepBoth | The image is drawn inside the given rectangle while keeping the original aspect ratio. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.KeepAspectRatio

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

TextAlign Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : TextAlign Enumeration

Specifies the available alignments for text lines.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum TextAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextAlign
C#
public enum TextAlign : Enum
Delphi
public enum TextAlign = class(Enum)
Managed Extensions for C++
__value public enum TextAlign : public Enum
C++/CLI
public enum class TextAlign : public Enum

Members

Member | Description
TopLeft | The text is top left aligned Supported by Compact .NET Edition.
TopCenter | The text is top center aligned Supported by Compact .NET Edition.
TopRight | The text is top right aligned Supported by Compact .NET Edition.
MiddleLeft | The text is middle left aligned Supported by Compact .NET Edition.
MiddleCenter | The text is middle center aligned Supported by Compact .NET Edition.
MiddleRight | The text is middle right aligned Supported by Compact .NET Edition.
BottomLeft | The text is bottom left aligned Supported by Compact .NET Edition.
BottomCenter | The text is bottom center aligned Supported by Compact .NET Edition.
BottomRight | The text is bottom right aligned Supported by Compact .NET Edition.
TopJustified | The text is top justified aligned. This alignment is used only by text boxes. Supported by Compact .NET Edition.
MiddleJustified | The text is middle justified aligned. This alignment is used only by text boxes. Supported by Compact .NET Edition.
BottomJustified | The text is bottom justified aligned. This alignment is used only by text boxes. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.TextAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFAlphaChannelMask | Defines an image based mask for an image.
PDFBaseImageMask | Defines a base class for all image masks.
PDFColorImageMask | Defines a color-key mask for an image.
PDFImageMask | Defines an image based mask for an image.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAlphaChannelMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

Defines an image based mask for an image.

Syntax

Visual Basic (Declaration)
Public Class PDFAlphaChannelMask
   Inherits PDFImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFAlphaChannelMask
C#
public class PDFAlphaChannelMask : PDFImageMask
Delphi
public class PDFAlphaChannelMask = class(PDFImageMask)
Managed Extensions for C++
public __gc class PDFAlphaChannelMask : public PDFImageMask
C++/CLI
public ref class PDFAlphaChannelMask : public PDFImageMask

Remarks

An alpha channel mask allows to specify a grayscale bitmap that defines the alpha channel values for the image. Only grayscale images are allowed as alpha channel masks.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFAlphaChannelMask Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

The following tables list the members exposed by PDFAlphaChannelMask.

Public Constructors

 | Name | Description
Public Constructor | PDFAlphaChannelMask Constructor | Overloaded. Initializes a new PDFImageMask object based on a file.
Top

Public Properties

 | Name | Description
Public Property | FileName | Gets or sets the name of the file representing the mask. (Inherited from PDFImageMask)
Public Property | Image | Gets or sets the image object representing mask. (Inherited from PDFImageMask)
Public Property | Stream | Gets or sets the stream storing the image mask. (Inherited from PDFImageMask)
Top

See Also

Reference

PDFAlphaChannelMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFAlphaChannelMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class : PDFAlphaChannelMask Constructor

Initializes a new PDFImageMask object based on a file.

Overload List

Overload | Description
PDFAlphaChannelMask Constructor(Image) | Initializes a new PDFImageMask object based on a Image object.
PDFAlphaChannelMask Constructor(Stream) | Initializes a new PDFImageMask object based on a stream.
PDFAlphaChannelMask Constructor(String) | Initializes a new PDFImageMask object based on a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(Image)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Image)

image
the image representing the mask
Initializes a new PDFImageMask object based on a Image object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Image _
)
Visual Basic (Usage) Copy Code
Dim image As Image

Dim instance As PDFAlphaChannelMask(image)
C#
public PDFAlphaChannelMask(
   Image image
)
Delphi
public PDFAlphaChannelMask(
    image: Image
);
Managed Extensions for C++
public: PDFAlphaChannelMask(
   Image image
)
C++/CLI
public:
PDFAlphaChannelMask(
   Image image
)

Parameters

image
the image representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Stream)

stream
the stream representing the mask
Initializes a new PDFImageMask object based on a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFAlphaChannelMask(stream)
C#
public PDFAlphaChannelMask(
   Stream stream
)
Delphi
public PDFAlphaChannelMask(
    stream: Stream
);
Managed Extensions for C++
public: PDFAlphaChannelMask(
   Stream* stream
)
C++/CLI
public:
PDFAlphaChannelMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(String)

fileName
the file representing the mask
Initializes a new PDFImageMask object based on a file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFAlphaChannelMask(fileName)
C#
public PDFAlphaChannelMask(
   string fileName
)
Delphi
public PDFAlphaChannelMask(
    fileName: String
);
Managed Extensions for C++
public: PDFAlphaChannelMask(
   string* fileName
)
C++/CLI
public:
PDFAlphaChannelMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFBaseImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class

Defines a base class for all image masks.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBaseImageMask
   Inherits PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseImageMask
C#
public abstract class PDFBaseImageMask : PDFBaseObject
Delphi
public class PDFBaseImageMask = class(PDFBaseObject)abstract;
Managed Extensions for C++
public __gc abstract class PDFBaseImageMask : public PDFBaseObject
C++/CLI
public ref class PDFBaseImageMask abstract : public PDFBaseObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFBaseImageMask Class Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class

The following tables list the members exposed by PDFBaseImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFBaseImageMask Constructor | Initializes a new PDFBaseImageMask object.
Top

See Also

Reference

PDFBaseImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFBaseImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFBaseImageMask Class : PDFBaseImageMask Constructor

Initializes a new PDFBaseImageMask object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseImageMask()
C#
public PDFBaseImageMask()
Delphi
public PDFBaseImageMask();
Managed Extensions for C++
public: PDFBaseImageMask();
C++/CLI
public:
PDFBaseImageMask();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseImageMask Class
PDFBaseImageMask Members


%%PageItemTitle%%

PDFColorImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

Defines a color-key mask for an image.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFColorImageMask
   Inherits PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
C#
public sealed class PDFColorImageMask : PDFBaseImageMask
Delphi
public class PDFColorImageMask = class(PDFBaseImageMask)sealed;
Managed Extensions for C++
public __gc __sealed class PDFColorImageMask : public PDFBaseImageMask
C++/CLI
public ref class PDFColorImageMask sealed : public PDFBaseImageMask

Remarks

A color-key mask allows to specify a range of colors within an image to be treated as transparent when the image is painted on the page. All the colors between startColor and endColor will be treated as transparent.
A color is considered higher than startColor and lower than endColor when all its components meet this considition individually. For example, in RGB colorspace, being given the color C with its components (Cr, Cg, Cb), then startColor (SC) <= C <= endColor (EC) when:
SCr <= Cr <= ECr AND SCg <= Cg <= ECg AND SCb <= Cb <= ECb.
Note: A color image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFColorImageMask Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

The following tables list the members exposed by PDFColorImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFColorImageMask Constructor | Overloaded. Initializes a new PDFColorImageMask object considering white as transparent color.
Top

Public Properties

 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top

See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFColorImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : PDFColorImageMask Constructor

Initializes a new PDFColorImageMask object considering white as transparent color.

Overload List

Overload | Description
PDFColorImageMask Constructor() | Initializes a new PDFColorImageMask object considering white as transparent color.
PDFColorImageMask Constructor(PDFColor,PDFColor) | Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


%%PageItemTitle%%

PDFColorImageMask Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor()

Initializes a new PDFColorImageMask object considering white as transparent color.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask()
C#
public PDFColorImageMask()
Delphi
public PDFColorImageMask();
Managed Extensions for C++
public: PDFColorImageMask();
C++/CLI
public:
PDFColorImageMask();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


%%PageItemTitle%%

PDFColorImageMask Constructor(PDFColor,PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor(PDFColor,PDFColor)

startColor
the start color for the image mask.
endColor
the end color for the image mask.
Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal startColor As PDFColor, _
   ByVal endColor As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim startColor As PDFColor
Dim endColor As PDFColor

Dim instance As PDFColorImageMask(startColor, endColor)
C#
public PDFColorImageMask(
   PDFColor startColor,
   PDFColor endColor
)
Delphi
public PDFColorImageMask(
    startColor: PDFColor;
    endColor: PDFColor
);
Managed Extensions for C++
public: PDFColorImageMask(
   PDFColor* startColor,
   PDFColor* endColor
)
C++/CLI
public:
PDFColorImageMask(
   PDFColor^ startColor,
   PDFColor^ endColor
)

Parameters

startColor
the start color for the image mask.
endColor
the end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFColorImageMask Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

For a list of all members of this type, see PDFColorImageMask members.

Public Properties

 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top

See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

EndColor Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : EndColor Property

Gets or sets the end color for image mask.

Syntax

Visual Basic (Declaration)
Public Property EndColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
C#
public PDFColor EndColor {get; set;}
Delphi
public read-write property EndColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


%%PageItemTitle%%

StartColor Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : StartColor Property

Gets or sets the start color for image mask.

Syntax

Visual Basic (Declaration)
Public Property StartColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
C#
public PDFColor StartColor {get; set;}
Delphi
public read-write property StartColor: PDFColor;
Managed Extensions for C++
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A PDFColor object specifying the start color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


%%PageItemTitle%%

PDFImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

Defines an image based mask for an image.

Syntax

Visual Basic (Declaration)
Public Class PDFImageMask
   Inherits PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFImageMask
C#
public class PDFImageMask : PDFBaseImageMask
Delphi
public class PDFImageMask = class(PDFBaseImageMask)
Managed Extensions for C++
public __gc class PDFImageMask : public PDFBaseImageMask
C++/CLI
public ref class PDFImageMask : public PDFBaseImageMask

Remarks

An image based mask allows to specify a monochrome bitmap that defines what regions of the base image will be painted or not on the page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFImageMask Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

The following tables list the members exposed by PDFImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFImageMask Constructor | Overloaded. Initializes a new PDFImageMask object based on a file.
Top

Public Properties

 | Name | Description
Public Property | FileName | Gets or sets the name of the file representing the mask.
Public Property | Image | Gets or sets the image object representing mask.
Public Property | Stream | Gets or sets the stream storing the image mask.
Top

See Also

Reference

PDFImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : PDFImageMask Constructor

Initializes a new PDFImageMask object based on a file.

Overload List

Overload | Description
PDFImageMask Constructor(Image) | Initializes a new PDFImageMask object based on a Image object.
PDFImageMask Constructor(Stream) | Initializes a new PDFImageMask object based on a stream.
PDFImageMask Constructor(String) | Initializes a new PDFImageMask object based on a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members


%%PageItemTitle%%

PDFImageMask Constructor(Image)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Image)

image
the image representing the mask
Initializes a new PDFImageMask object based on a Image object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Image _
)
Visual Basic (Usage) Copy Code
Dim image As Image

Dim instance As PDFImageMask(image)
C#
public PDFImageMask(
   Image image
)
Delphi
public PDFImageMask(
    image: Image
);
Managed Extensions for C++
public: PDFImageMask(
   Image image
)
C++/CLI
public:
PDFImageMask(
   Image image
)

Parameters

image
the image representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


%%PageItemTitle%%

PDFImageMask Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Stream)

stream
the stream representing the mask
Initializes a new PDFImageMask object based on a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFImageMask(stream)
C#
public PDFImageMask(
   Stream stream
)
Delphi
public PDFImageMask(
    stream: Stream
);
Managed Extensions for C++
public: PDFImageMask(
   Stream* stream
)
C++/CLI
public:
PDFImageMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


%%PageItemTitle%%

PDFImageMask Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(String)

fileName
the file representing the mask
Initializes a new PDFImageMask object based on a file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFImageMask(fileName)
C#
public PDFImageMask(
   string fileName
)
Delphi
public PDFImageMask(
    fileName: String
);
Managed Extensions for C++
public: PDFImageMask(
   string* fileName
)
C++/CLI
public:
PDFImageMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFImageMask Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

For a list of all members of this type, see PDFImageMask members.

Public Properties

 | Name | Description
Public Property | FileName | Gets or sets the name of the file representing the mask.
Public Property | Image | Gets or sets the image object representing mask.
Public Property | Stream | Gets or sets the stream storing the image mask.
Top

See Also

Reference

PDFImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

FileName Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : FileName Property

Gets or sets the name of the file representing the mask.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFImageMask
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Delphi
public read-write property FileName: String;
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of the file representing the mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members


%%PageItemTitle%%

Image Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : Image Property

Gets or sets the image object representing mask.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As PDFImageMask
Dim value As Image

instance.Image = value

value = instance.Image
C#
public Image Image {get; set;}
Delphi
public read-write property Image: Image;
Managed Extensions for C++
public: __property Image get_Image();
public: __property void set_Image(
   Image value
);
C++/CLI
public:
property Image Image {
   Image get();
   void set (Image value);
}

Return Value

A Image object representing the mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members


%%PageItemTitle%%

Stream Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : Stream Property

Gets or sets the stream storing the image mask.

Syntax

Visual Basic (Declaration)
Public Property Stream As Stream
Visual Basic (Usage) Copy Code
Dim instance As PDFImageMask
Dim value As Stream

instance.Stream = value

value = instance.Stream
C#
public Stream Stream {get; set;}
Delphi
public read-write property Stream: Stream;
Managed Extensions for C++
public: __property Stream* get_Stream();
public: __property void set_Stream(
   Stream* value
);
C++/CLI
public:
property Stream^ Stream {
   Stream^ get();
   void set (Stream^ value);
}

Return Value

A Stream object storing the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members


%%ItemTitle%%

O2S.Components.PDF4NET.PDFFile Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFFile | Represents a pdf file on disk.
PDFHwep | Summary description for PDFHwep.
PDFImportedContent | Represents the binary content of a page in a pdf file.
PDFImportedObject | Base class for all objects imported from a pdf file.
PDFImportedPage | Represents a page in a pdf file.
PDFImportedPageInfo | Represents the properties of an imported page, but without actual page content.
PDFSeparationInfo | Defines the separation information for an existing PDF page.

Enumerations

Enumeration | Description
ContentMirroring | Specifies the available mirroring options when displaying imported content.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.PDFFile Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.PDFFile.PDFHwep
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFFile.PDFSeparationInfo
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage
O2S.Components.PDF4NET.PDFFile.PDFFile
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

Represents a pdf file on disk.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFile
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
C#
public class PDFFile
Delphi
public class PDFFile
Managed Extensions for C++
public __gc class PDFFile
C++/CLI
public ref class PDFFile

Remarks

This class defines an existing pdf file. Its methods allows to perform various operations on pdf files. It allows to merge multiple pdf files, split pdf files to individual pages, apply security to existing pdf files, extract full pages or their content from pdf files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

The following tables list the members exposed by PDFFile.

Public Constructors

 | Name | Description
Public Constructor | PDFFile Constructor |
Top

Public Properties

 | Name | Description
Public Property | DocumentInformation | Gets the document information for this PDF file.
Public Property | IsRepaired | Gets whether the PDF file was repaired or not before it has been loaded.
Public Property | PageNumberingRanges | Gets the collection of page numbering ranges defined for this document.
Public Property | PagesCount | Gets the number of pages in the pdf file.
Public Property | SecurityManager | Gets the security manager for this PDF file.
Public Property | Version | Gets the version of the PDF file.
Public Property | ViewerPreferences | Gets the viewer preferences for this PDF file.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Extracts the specified page from the current file.
Public Method | ExtractPageContent | Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetObjectFromCache | Gets a cached object.
Public Method | GetPDFObjectFromObjectStream |
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
Public Method | SaveObjectToCache |
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

PDFFile Constructor
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PDFFile Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile()
C#
public PDFFile()
Delphi
public PDFFile();
Managed Extensions for C++
public: PDFFile();
C++/CLI
public:
PDFFile();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%% $$Methods$$

PDFFile Class Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Extracts the specified page from the current file.
Public Method | ExtractPageContent | Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetObjectFromCache | Gets a cached object.
Public Method | GetPDFObjectFromObjectStream |
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
Public Method | SaveObjectToCache |
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

Close Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

Dispose Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Dispose Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

EncryptFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : EncryptFile Method

Encrypts the given pdf file with the security settings specified by securityManager parameter.

Overload List

Overload | Description
EncryptFile(PDFSecurityManager,String,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.
EncryptFile(PDFSecurityManager,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

EncryptFile(PDFSecurityManager,String,String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String,String) Method

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
destFileName
the destination pdf file where the encrypted docment will be saved.
Encrypts the given pdf file with the security settings specified by securityManager parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
Visual Basic (Usage) Copy Code
Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim destFileName As String

PDFFile.EncryptFile(securityManager, srcFileName, destFileName)
C#
public static void EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName,
   string destFileName
)
Delphi
public procedure EncryptFile(
    securityManager: PDFSecurityManager;
    srcFileName: String;
    destFileName: String
); static;
Managed Extensions for C++
public: static void EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName,
   string* destFileName
)
C++/CLI
public:
static void EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName,
   String^ destFileName
)

Parameters

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
destFileName
the destination pdf file where the encrypted docment will be saved.

Exceptions

Exception | Description
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

EncryptFile(PDFSecurityManager,String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String) Method

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
Encrypts the given pdf file with the security settings specified by securityManager parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim value As PDFDocument

value = PDFFile.EncryptFile(securityManager, srcFileName)
C#
public static PDFDocument EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName
)
Delphi
public function EncryptFile(
    securityManager: PDFSecurityManager;
    srcFileName: String
): PDFDocument; static;
Managed Extensions for C++
public: static PDFDocument* EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName
)
C++/CLI
public:
static PDFDocument^ EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName
)

Parameters

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.

Return Value

a PDFDocument object representing the encrypted source pdf file

Exceptions

Exception | Description
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPage Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPage Method

pageNumber
the number of the page tha will be extracted.
Extracts the specified page from the current file.

Syntax

Visual Basic (Declaration)
Public Function ExtractPage( _
   ByVal pageNumber As Integer _
) As PDFImportedPage
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPage

value = instance.ExtractPage(pageNumber)
C#
public PDFImportedPage ExtractPage(
   int pageNumber
)
Delphi
public function ExtractPage(
    pageNumber: Integer
): PDFImportedPage;
Managed Extensions for C++
public: PDFImportedPage* ExtractPage(
   int pageNumber
)
C++/CLI
public:
PDFImportedPage^ ExtractPage(
   int pageNumber
)

Parameters

pageNumber
the number of the page tha will be extracted.

Return Value

a PDFImportedPage object representing the extracted page.

Exceptions

Exception | Description
PDFParserException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts a full page from the current pdf file. This page can be later inserted in any new document keeping all the attributes it had in the old document. Use PDFDocument.AddPage(PDFPage) method to insert the extracted page into a new document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ExtractPageContent Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageContent Method

pageNumber
the number of the page whose binary content should be retireved.
Gets the binary content of the specified page.

Syntax

Visual Basic (Declaration)
Public Function ExtractPageContent( _
   ByVal pageNumber As Integer _
) As PDFImportedContent
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedContent

value = instance.ExtractPageContent(pageNumber)
C#
public PDFImportedContent ExtractPageContent(
   int pageNumber
)
Delphi
public function ExtractPageContent(
    pageNumber: Integer
): PDFImportedContent;
Managed Extensions for C++
public: PDFImportedContent* ExtractPageContent(
   int pageNumber
)
C++/CLI
public:
PDFImportedContent^ ExtractPageContent(
   int pageNumber
)

Parameters

pageNumber
the number of the page whose binary content should be retireved.

Return Value

a PDFImportedContent object representing the binary representation of the page.

Exceptions

Exception | Description
PDFParserException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the binary content of the given page. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use PDFCanvas.DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) method to draw the imported content on a new page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ExtractPageInfo Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageInfo Method

pageNumber
the number of the page whose information will be extracted.
Extracts the specified page information from the current file.

Syntax

Visual Basic (Declaration)
Public Function ExtractPageInfo( _
   ByVal pageNumber As Integer _
) As PDFImportedPageInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPageInfo

value = instance.ExtractPageInfo(pageNumber)
C#
public PDFImportedPageInfo ExtractPageInfo(
   int pageNumber
)
Delphi
public function ExtractPageInfo(
    pageNumber: Integer
): PDFImportedPageInfo;
Managed Extensions for C++
public: PDFImportedPageInfo* ExtractPageInfo(
   int pageNumber
)
C++/CLI
public:
PDFImportedPageInfo^ ExtractPageInfo(
   int pageNumber
)

Parameters

pageNumber
the number of the page whose information will be extracted.

Return Value

a PDFImportedPageInfo object representing the page information.

Exceptions

Exception | Description
PDFParserException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts a only the page information from the current pdf file, no page content is extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ExtractPages Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPages Method

Gets an array of imported page objects representing the pages given as parameter.

Overload List

Overload | Description
ExtractPages(String) | Gets an array of imported page objects representing the pages given as parameter.
ExtractPages() | Gets an array of imported page objects representing all the pages in the file.
ExtractPages(String,Int32,Int32) | Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ExtractPages(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String) Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.
Gets an array of imported page objects representing the pages given as parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPages( _
   ByVal pageNumbers As String _
) As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPage

value = instance.ExtractPages(pageNumbers)
C#
public PDFImportedPage[] ExtractPages(
   string pageNumbers
)
Delphi
public function ExtractPages(
    pageNumbers: String
): array of PDFImportedPage;
Managed Extensions for C++
public: PDFImportedPage*[]* ExtractPages(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedPage^>^ ExtractPages(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.

Return Value

an array of PDFImportedPage objects representing the pages given as paramter.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the given set of pages. These pages can be inserted in any new document. Use PDFDocument.AddPage(PDFPage) method to add imported page to current document.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPages() Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages() Method

Gets an array of imported page objects representing all the pages in the file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPages() As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value() As PDFImportedPage

value = instance.ExtractPages()
C#
public PDFImportedPage[] ExtractPages()
Delphi
public function ExtractPages(): array of PDFImportedPage;
Managed Extensions for C++
public: PDFImportedPage*[]* ExtractPages();
C++/CLI
public:
array<PDFImportedPage^>^ ExtractPages();

Return Value

an array of PDFImportedPage objects representing all the pages in the file.

Exceptions

Exception | Description
PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.

Remarks

This method extracts all the pages in the file. These pages can be inserted in any new document. Use PDFDocument.AddPage(PDFPage) method to add imported page to current document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPages(String,Int32,Int32) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String,Int32,Int32) Method

fileName
the PDF file from which the pages are extracted.
startPage
the zero based index of the first page in the range.
endPage
the zero based index of the last page in the range.
Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function ExtractPages( _
   ByVal fileName As String, _
   ByVal startPage As Integer, _
   ByVal endPage As Integer _
) As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim startPage As Integer
Dim endPage As Integer
Dim value() As PDFImportedPage

value = PDFFile.ExtractPages(fileName, startPage, endPage)
C#
public static PDFImportedPage[] ExtractPages(
   string fileName,
   int startPage,
   int endPage
)
Delphi
public function ExtractPages(
    fileName: String;
    startPage: Integer;
    endPage: Integer
): array of PDFImportedPage; static;
Managed Extensions for C++
public: static PDFImportedPage*[]* ExtractPages(
   string* fileName,
   int startPage,
   int endPage
)
C++/CLI
public:
static array<PDFImportedPage^>^ ExtractPages(
   String^ fileName,
   int startPage,
   int endPage
)

Parameters

fileName
the PDF file from which the pages are extracted.
startPage
the zero based index of the first page in the range.
endPage
the zero based index of the last page in the range.

Return Value

an array of PDFImportedPage objects representing the requested range of consecutive pages.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the given pdf file.

Remarks

This method extracts a consecutive range of pages from the given PDF file. These pages can be inserted in any new document. Use PDFDocument.AddPage(PDFPage) method to add imported page to current document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPagesContent Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesContent Method

Gets an array of imported content objects representing the binary content of the pages given as parameter.

Overload List

Overload | Description
ExtractPagesContent(String) | Gets an array of imported content objects representing the binary content of the pages given as parameter.
ExtractPagesContent() | Gets an array of imported content objects representing the binary content of all the pages in the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ExtractPagesContent(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent(String) Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.
Gets an array of imported content objects representing the binary content of the pages given as parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPagesContent( _
   ByVal pageNumbers As String _
) As PDFImportedContent()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent(pageNumbers)
C#
public PDFImportedContent[] ExtractPagesContent(
   string pageNumbers
)
Delphi
public function ExtractPagesContent(
    pageNumbers: String
): array of PDFImportedContent;
Managed Extensions for C++
public: PDFImportedContent*[]* ExtractPagesContent(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedContent^>^ ExtractPagesContent(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.

Return Value

an array of PDFImportedContent objects representing the binary content of the pages given as parameter.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the binary content of the given set of pages. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use PDFCanvas.DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) method to draw the imported content on a new page.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPagesContent() Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent() Method

Gets an array of imported content objects representing the binary content of all the pages in the file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPagesContent() As PDFImportedContent()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent()
C#
public PDFImportedContent[] ExtractPagesContent()
Delphi
public function ExtractPagesContent(): array of PDFImportedContent;
Managed Extensions for C++
public: PDFImportedContent*[]* ExtractPagesContent();
C++/CLI
public:
array<PDFImportedContent^>^ ExtractPagesContent();

Return Value

an array of PDFImportedContent objects representing the binary content of all the pages in the file.

Exceptions

Exception | Description
PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.

Remarks

This method extracts the binary content of all the pages in the file. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use PDFCanvas.DrawImportedContent(PDFImportedContent,Single,Single,Single,Single) method to draw the imported content on a new page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

ExtractPagesInfo Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesInfo Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.
Gets an array of imported page info objects representing the pages given as parameter.

Syntax

Visual Basic (Declaration)
Public Function ExtractPagesInfo( _
   ByVal pageNumbers As String _
) As PDFImportedPageInfo()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPageInfo

value = instance.ExtractPagesInfo(pageNumbers)
C#
public PDFImportedPageInfo[] ExtractPagesInfo(
   string pageNumbers
)
Delphi
public function ExtractPagesInfo(
    pageNumbers: String
): array of PDFImportedPageInfo;
Managed Extensions for C++
public: PDFImportedPageInfo*[]* ExtractPagesInfo(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedPageInfo^>^ ExtractPagesInfo(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.

Return Value

an array of PDFImportedPageInfo objects representing the pages given as paramter.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the information for the given set of pages without extracting the whole page content.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

FromFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromFile Method

Creates a PDFFile object from the given pdf file.

Overload List

Overload | Description
FromFile(String) | Creates a PDFFile object from the given pdf file.
FromFile(String,Byte[]) | Creates a PDFFile object from the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

FromFile(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String) Method

fileName
the full path to a pdf file used as source for this PDFFile object.
Creates a PDFFile object from the given pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromFile( _
   ByVal fileName As String _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As PDFFile

value = PDFFile.FromFile(fileName)
C#
public static PDFFile FromFile(
   string fileName
)
Delphi
public function FromFile(
    fileName: String
): PDFFile; static;
Managed Extensions for C++
public: static PDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static PDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

FromFile(String,Byte[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,Byte[]) Method

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal userPassword() As Byte _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromFile(fileName, userPassword)
C#
public static PDFFile FromFile(
   string fileName,
   byte[] userPassword
)
Delphi
public function FromFile(
    fileName: String;
    userPassword: Bytearray of
): PDFFile; static;
Managed Extensions for C++
public: static PDFFile* FromFile(
   string* fileName,
   byte[]* userPassword
)
C++/CLI
public:
static PDFFile^ FromFile(
   String^ fileName,
   array<byte>^ userPassword
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

FromStream Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromStream Method

Creates a PDFFile object from the given stream object.

Overload List

Overload | Description
FromStream(Stream) | Creates a PDFFile object from the given stream object.
FromStream(Stream,Byte[]) | Creates a PDFFile object from the given stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

FromStream(Stream) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream) Method

stream
the stream object used as source for this PDFFile object.
Creates a PDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromStream( _
   ByVal stream As Stream _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As PDFFile

value = PDFFile.FromStream(stream)
C#
public static PDFFile FromStream(
   Stream stream
)
Delphi
public function FromStream(
    stream: Stream
): PDFFile; static;
Managed Extensions for C++
public: static PDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static PDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given stream object.

Remarks

The stream must contain a valid pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

FromStream(Stream,Byte[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,Byte[]) Method

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal userPassword() As Byte _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromStream(stream, userPassword)
C#
public static PDFFile FromStream(
   Stream stream,
   byte[] userPassword
)
Delphi
public function FromStream(
    stream: Stream;
    userPassword: Bytearray of
): PDFFile; static;
Managed Extensions for C++
public: static PDFFile* FromStream(
   Stream* stream,
   byte[]* userPassword
)
C++/CLI
public:
static PDFFile^ FromStream(
   Stream^ stream,
   array<byte>^ userPassword
)

Parameters

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given stream object.

Remarks

The stream must contain a valid pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

GetObjectFromCache Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetObjectFromCache Method

indirectReference
The key to look in cache for the object.
t
The expected object type to be found in cache.
Gets a cached object.

Syntax

Visual Basic (Declaration)
Public Function GetObjectFromCache( _
   ByVal indirectReference() As Byte, _
   ByVal t As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim indirectReference() As Byte
Dim t As Type
Dim value As Object

value = instance.GetObjectFromCache(indirectReference, t)
C#
public object GetObjectFromCache(
   byte[] indirectReference,
   Type t
)
Delphi
public function GetObjectFromCache(
    indirectReference: Bytearray of;
    t: Type
): TObject;
Managed Extensions for C++
public: Object* GetObjectFromCache(
   byte[]* indirectReference,
   Type* t
)
C++/CLI
public:
Object^ GetObjectFromCache(
   array<byte>^ indirectReference,
   Type^ t
)

Parameters

indirectReference
The key to look in cache for the object.
t
The expected object type to be found in cache.

Return Value

The cached object if found.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

GetPDFObjectFromObjectStream Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetPDFObjectFromObjectStream Method

objectID
objectIndex

Syntax

Visual Basic (Declaration)
Public Function GetPDFObjectFromObjectStream( _
   ByVal objectID As Integer, _
   ByVal objectIndex As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim objectID As Integer
Dim objectIndex As Integer
Dim value() As Byte

value = instance.GetPDFObjectFromObjectStream(objectID, objectIndex)
C#
public byte[] GetPDFObjectFromObjectStream(
   int objectID,
   int objectIndex
)
Delphi
public function GetPDFObjectFromObjectStream(
    objectID: Integer;
    objectIndex: Integer
): array of Byte;
Managed Extensions for C++
public: byte[]* GetPDFObjectFromObjectStream(
   int objectID,
   int objectIndex
)
C++/CLI
public:
array<byte>^ GetPDFObjectFromObjectStream(
   int objectID,
   int objectIndex
)

Parameters

objectID
objectIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

MergeFiles Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : MergeFiles Method

Merges multiple pdf files into a single pdf file.

Overload List

Overload | Description
MergeFiles(String,String[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(String,String[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(String[]) | Merges multiple pdf files into a single PDFDocument object.
MergeFiles(Stream,Stream[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream,Stream[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream[]) | Merges multiple pdf files into a single PDFDocument object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

MergeFiles(String,String[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[]) Method

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String _
)
Visual Basic (Usage) Copy Code
Dim destFileName As String
Dim srcFileNames() As String

PDFFile.MergeFiles(destFileName, srcFileNames)
C#
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames
)
Delphi
public procedure MergeFiles(
    destFileName: String;
    srcFileNames: Stringarray of
); static;
Managed Extensions for C++
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames
)
C++/CLI
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

MergeFiles(String,String[],Boolean) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[],Boolean) Method

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String, _
   ByVal enableFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim destFileName As String
Dim srcFileNames() As String
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFileName, srcFileNames, enableFastWebView)
C#
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames,
   bool enableFastWebView
)
Delphi
public procedure MergeFiles(
    destFileName: String;
    srcFileNames: Stringarray of;
    enableFastWebView: Boolean
); static;
Managed Extensions for C++
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames,
   bool enableFastWebView
)
C++/CLI
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames,
   bool enableFastWebView
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

MergeFiles(String[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String[]) Method

srcFileNames
an array of pdf files that will be merged
Merges multiple pdf files into a single PDFDocument object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function MergeFiles( _
   ByVal srcFileNames() As String _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim srcFileNames() As String
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFileNames)
C#
public static PDFDocument MergeFiles(
   string[] srcFileNames
)
Delphi
public function MergeFiles(
    srcFileNames: Stringarray of
): PDFDocument; static;
Managed Extensions for C++
public: static PDFDocument* MergeFiles(
   string*[]* srcFileNames
)
C++/CLI
public:
static PDFDocument^ MergeFiles(
   array<String^>^ srcFileNames
)

Parameters

srcFileNames
an array of pdf files that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and returns the new PDFDocument object, so new content and new pages can be added. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

MergeFiles(Stream,Stream[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[]) Method

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream _
)
Visual Basic (Usage) Copy Code
Dim destFile As Stream
Dim srcFiles() As Stream

PDFFile.MergeFiles(destFile, srcFiles)
C#
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles
)
Delphi
public procedure MergeFiles(
    destFile: Stream;
    srcFiles: Streamarray of
); static;
Managed Extensions for C++
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles
)
C++/CLI
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files are given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

MergeFiles(Stream,Stream[],Boolean) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[],Boolean) Method

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream, _
   ByVal enableFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim destFile As Stream
Dim srcFiles() As Stream
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFile, srcFiles, enableFastWebView)
C#
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles,
   bool enableFastWebView
)
Delphi
public procedure MergeFiles(
    destFile: Stream;
    srcFiles: Streamarray of;
    enableFastWebView: Boolean
); static;
Managed Extensions for C++
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles,
   bool enableFastWebView
)
C++/CLI
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles,
   bool enableFastWebView
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files are given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

MergeFiles(Stream[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream[]) Method

srcFiles
an array of pdf file streams that will be merged
Merges multiple pdf files into a single PDFDocument object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function MergeFiles( _
   ByVal srcFiles() As Stream _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim srcFiles() As Stream
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFiles)
C#
public static PDFDocument MergeFiles(
   Stream[] srcFiles
)
Delphi
public function MergeFiles(
    srcFiles: Streamarray of
): PDFDocument; static;
Managed Extensions for C++
public: static PDFDocument* MergeFiles(
   Stream*[]* srcFiles
)
C++/CLI
public:
static PDFDocument^ MergeFiles(
   array<Stream^>^ srcFiles
)

Parameters

srcFiles
an array of pdf file streams that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf streams as given as parameter.
PDFParserException | thrown when input pdf streams can not be parsed.

Remarks

This method merges several pdf streams into a single one and returns the new PDFDocument object, to allow new content and new pages to be added. The method accepts an array of pdf streams, so multiple pdf streams can be appended at once. The streams will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%%

SaveObjectToCache Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SaveObjectToCache Method

indirectReference
importedObject

Syntax

Visual Basic (Declaration)
Public Sub SaveObjectToCache( _
   ByVal indirectReference() As Byte, _
   ByVal importedObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim indirectReference() As Byte
Dim importedObject As Object

instance.SaveObjectToCache(indirectReference, importedObject)
C#
public void SaveObjectToCache(
   byte[] indirectReference,
   object importedObject
)
Delphi
public procedure SaveObjectToCache(
    indirectReference: Bytearray of;
    importedObject: TObject
);
Managed Extensions for C++
public: void SaveObjectToCache(
   byte[]* indirectReference,
   Object* importedObject
)
C++/CLI
public:
void SaveObjectToCache(
   array<byte>^ indirectReference,
   Object^ importedObject
)

Parameters

indirectReference
importedObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

SplitFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SplitFile Method

srcFileName
the full path of the pdf file to split.
destFileName
the name of destiantion individual pages file.
Splits the given pdf file to individual pages.

Syntax

Visual Basic (Declaration)
Public Shared Sub SplitFile( _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
Visual Basic (Usage) Copy Code
Dim srcFileName As String
Dim destFileName As String

PDFFile.SplitFile(srcFileName, destFileName)
C#
public static void SplitFile(
   string srcFileName,
   string destFileName
)
Delphi
public procedure SplitFile(
    srcFileName: String;
    destFileName: String
); static;
Managed Extensions for C++
public: static void SplitFile(
   string* srcFileName,
   string* destFileName
)
C++/CLI
public:
static void SplitFile(
   String^ srcFileName,
   String^ destFileName
)

Parameters

srcFileName
the full path of the pdf file to split.
destFileName
the name of destiantion individual pages file.

Remarks

This method splits a pdf file to individual pages. Each page is named using destFileName parameter after which a numeric index is appended, eg: destfileName001.pdf, destfileName002.pdf, destfileName003.pdf, etc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%% $$Properties$$

PDFFile Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Properties

 | Name | Description
Public Property | DocumentInformation | Gets the document information for this PDF file.
Public Property | IsRepaired | Gets whether the PDF file was repaired or not before it has been loaded.
Public Property | PageNumberingRanges | Gets the collection of page numbering ranges defined for this document.
Public Property | PagesCount | Gets the number of pages in the pdf file.
Public Property | SecurityManager | Gets the security manager for this PDF file.
Public Property | Version | Gets the version of the PDF file.
Public Property | ViewerPreferences | Gets the viewer preferences for this PDF file.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

DocumentInformation Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : DocumentInformation Property

Gets the document information for this PDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DocumentInformation As PDFDocumentInformation
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFDocumentInformation

value = instance.DocumentInformation
C#
public PDFDocumentInformation DocumentInformation {get;}
Delphi
public read-only property DocumentInformation: PDFDocumentInformation;
Managed Extensions for C++
public: __property PDFDocumentInformation* get_DocumentInformation();
C++/CLI
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
}

Return Value

A PDFDocumentInformation object storing the document information for this PDF file.

Remarks

The document information is created automatically when a PDF file is imported. If the PDF file does not contain any document information, this property returns null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

IsRepaired Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : IsRepaired Property

Gets whether the PDF file was repaired or not before it has been loaded.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRepaired As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As Boolean

value = instance.IsRepaired
C#
public bool IsRepaired {get;}
Delphi
public read-only property IsRepaired: Boolean;
Managed Extensions for C++
public: __property bool get_IsRepaired();
C++/CLI
public:
property bool IsRepaired {
   bool get();
}

Return Value

True if the file has been repaired before it has been loaded, false otherwise.

Remarks

The file is repaired in memory, the original file on disk is not affected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

PageNumberingRanges Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PageNumberingRanges Property

Gets the collection of page numbering ranges defined for this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumberingRanges As PageNumberingRangeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PageNumberingRangeCollection

value = instance.PageNumberingRanges
C#
public PageNumberingRangeCollection PageNumberingRanges {get;}
Delphi
public read-only property PageNumberingRanges: PageNumberingRangeCollection;
Managed Extensions for C++
public: __property PageNumberingRangeCollection* get_PageNumberingRanges();
C++/CLI
public:
property PageNumberingRangeCollection^ PageNumberingRanges {
   PageNumberingRangeCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

PagesCount Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PagesCount Property

Gets the number of pages in the pdf file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PagesCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As Integer

value = instance.PagesCount
C#
public int PagesCount {get;}
Delphi
public read-only property PagesCount: Integer;
Managed Extensions for C++
public: __property int get_PagesCount();
C++/CLI
public:
property int PagesCount {
   int get();
}

Return Value

an integer value specifying the number of pages of the pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

SecurityManager Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SecurityManager Property

Gets the security manager for this PDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SecurityManager As PDFSecurityManager
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFSecurityManager

value = instance.SecurityManager
C#
public PDFSecurityManager SecurityManager {get;}
Delphi
public read-only property SecurityManager: PDFSecurityManager;
Managed Extensions for C++
public: __property PDFSecurityManager* get_SecurityManager();
C++/CLI
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
}

Return Value

A PDFSecurityManager object storing the security settings for this PDF file.

Remarks

The security manager is created automatically when an encrypted PDF file is processed. If the PDF file is not encrypted, then this property returns null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

Version Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Version Property

Gets the version of the PDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As PDFVersion
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFVersion

value = instance.Version
C#
public PDFVersion Version {get;}
Delphi
public read-only property Version: PDFVersion;
Managed Extensions for C++
public: __property PDFVersion get_Version();
C++/CLI
public:
property PDFVersion Version {
   PDFVersion get();
}

Return Value

A PDFVersion enumeration member specifying the version of the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

ViewerPreferences Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ViewerPreferences Property

Gets the viewer preferences for this PDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ViewerPreferences As PDFViewerPreferences
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFViewerPreferences

value = instance.ViewerPreferences
C#
public PDFViewerPreferences ViewerPreferences {get;}
Delphi
public read-only property ViewerPreferences: PDFViewerPreferences;
Managed Extensions for C++
public: __property PDFViewerPreferences* get_ViewerPreferences();
C++/CLI
public:
property PDFViewerPreferences^ ViewerPreferences {
   PDFViewerPreferences^ get();
}

Return Value

A PDFViewerPreferences object storing the viewer preferences for this PDF file.

Remarks

The viewer preferences object is created automatically when a PDF file is imported.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

PDFHwep Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFHwep Class

Summary description for PDFHwep.

Syntax

Visual Basic (Declaration)
Private Class PDFHwep
   Inherits PDFImportedObject
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
C#
private class PDFHwep : PDFImportedObject
Delphi
private class PDFHwep = class(PDFImportedObject)
Managed Extensions for C++
private __gc class PDFHwep : public PDFImportedObject
C++/CLI
private ref class PDFHwep : public PDFImportedObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.PDFFile.PDFHwep

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFHwep Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFHwep Class

The following tables list the members exposed by PDFHwep.

Public Constructors

 | Name | Description
Public Constructor | PDFHwep Constructor |
Top

Public Properties

 | Name | Description
Public Property | Build | Gets or sets the buils
Public Property | FormID | Gets or sets the form id
Public Property | Lic | Gets or sets the lic
Public Property | Mobile | Gets or sets the mobile
Public Property | PadArray | Gets or sets the pad
Public Property | PadString | Gets or sets the pad
Public Property | Ver | Gets or sets the ver
Top

See Also

Reference

PDFHwep Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

PDFHwep Constructor
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : PDFHwep Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep()
C#
public PDFHwep()
Delphi
public PDFHwep();
Managed Extensions for C++
public: PDFHwep();
C++/CLI
public:
PDFHwep();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%% $$Properties$$

PDFHwep Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFHwep Class

For a list of all members of this type, see PDFHwep members.

Public Properties

 | Name | Description
Public Property | Build | Gets or sets the buils
Public Property | FormID | Gets or sets the form id
Public Property | Lic | Gets or sets the lic
Public Property | Mobile | Gets or sets the mobile
Public Property | PadArray | Gets or sets the pad
Public Property | PadString | Gets or sets the pad
Public Property | Ver | Gets or sets the ver
Top

See Also

Reference

PDFHwep Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

Build Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : Build Property

Gets or sets the buils

Syntax

Visual Basic (Declaration)
Public Property Build As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As String

instance.Build = value

value = instance.Build
C#
public string Build {get; set;}
Delphi
public read-write property Build: String;
Managed Extensions for C++
public: __property string* get_Build();
public: __property void set_Build(
   string* value
);
C++/CLI
public:
property String^ Build {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

FormID Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : FormID Property

Gets or sets the form id

Syntax

Visual Basic (Declaration)
Public Property FormID As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As String

instance.FormID = value

value = instance.FormID
C#
public string FormID {get; set;}
Delphi
public read-write property FormID: String;
Managed Extensions for C++
public: __property string* get_FormID();
public: __property void set_FormID(
   string* value
);
C++/CLI
public:
property String^ FormID {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

Lic Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : Lic Property

Gets or sets the lic

Syntax

Visual Basic (Declaration)
Public Property Lic As PDFStream
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As PDFStream

instance.Lic = value

value = instance.Lic
C#
public PDFStream Lic {get; set;}
Delphi
public read-write property Lic: PDFStream;
Managed Extensions for C++
public: __property PDFStream* get_Lic();
public: __property void set_Lic(
   PDFStream* value
);
C++/CLI
public:
property PDFStream^ Lic {
   PDFStream^ get();
   void set (PDFStream^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

Mobile Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : Mobile Property

Gets or sets the mobile

Syntax

Visual Basic (Declaration)
Public Property Mobile As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As String

instance.Mobile = value

value = instance.Mobile
C#
public string Mobile {get; set;}
Delphi
public read-write property Mobile: String;
Managed Extensions for C++
public: __property string* get_Mobile();
public: __property void set_Mobile(
   string* value
);
C++/CLI
public:
property String^ Mobile {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

PadArray Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : PadArray Property

Gets or sets the pad

Syntax

Visual Basic (Declaration)
Public Property PadArray As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As ArrayList

instance.PadArray = value

value = instance.PadArray
C#
public ArrayList PadArray {get; set;}
Delphi
public read-write property PadArray: ArrayList;
Managed Extensions for C++
public: __property ArrayList* get_PadArray();
public: __property void set_PadArray(
   ArrayList* value
);
C++/CLI
public:
property ArrayList^ PadArray {
   ArrayList^ get();
   void set (ArrayList^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

PadString Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : PadString Property

Gets or sets the pad

Syntax

Visual Basic (Declaration)
Public Property PadString As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As String

instance.PadString = value

value = instance.PadString
C#
public string PadString {get; set;}
Delphi
public read-write property PadString: String;
Managed Extensions for C++
public: __property string* get_PadString();
public: __property void set_PadString(
   string* value
);
C++/CLI
public:
property String^ PadString {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

Ver Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFHwep Class : Ver Property

Gets or sets the ver

Syntax

Visual Basic (Declaration)
Public Property Ver As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHwep
Dim value As String

instance.Ver = value

value = instance.Ver
C#
public string Ver {get; set;}
Delphi
public read-write property Ver: String;
Managed Extensions for C++
public: __property string* get_Ver();
public: __property void set_Ver(
   string* value
);
C++/CLI
public:
property String^ Ver {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHwep Class
PDFHwep Members


%%PageItemTitle%%

PDFImportedContent Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

Represents the binary content of a page in a pdf file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedContent
   Inherits PDFImportedObject
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
C#
public class PDFImportedContent : PDFImportedObject
Delphi
public class PDFImportedContent = class(PDFImportedObject)
Managed Extensions for C++
public __gc class PDFImportedContent : public PDFImportedObject
C++/CLI
public ref class PDFImportedContent : public PDFImportedObject

Remarks

This class represents the binary content of a page in a pdf file. This binary content creates the visual appearance of the page. It contains instructions for drawing text, images, etc. This binary content can be extracted and drawn on a new page. When it is drawn, it can be rotated. The content is automatically scaled to fit the given destination rectangle. To draw only a section of the imported content to the destination rectangle, set the ClipLeft, ClipTop, ClipWidth and ClipHeight properties to desired values. These values define the clipping rectangle, only the content inside the clipping rectangle will be displayed in the destination rectangle.
Links, form fields and annotations are not part of page content, so when the content is extracted, these items are not included.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.PDFFile.PDFImportedContent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedContent Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

The following tables list the members exposed by PDFImportedContent.

Public Properties

 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | ContentStream | Gets the page's content stream.
Public Property | Height | Gets the height of the imported page content.
Public Property | ResourceManager | Gets the imported resources manager for this page content object.
Public Property | Rotate | Gets the rotation angle of the page that includes this content.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the width of the imported page content.
Public Property | X | Gets the x of the imported page content.
Public Property | Y | Gets the y of the imported page content.
Top

Public Methods

 | Name | Description
Public Method | ExtractLayer | Extracts a layer from the page content.
Public Method | GetLayerNames | Gets the names of the layers in this page content.
Top

See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedContent Class Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

For a list of all members of this type, see PDFImportedContent members.

Public Methods

 | Name | Description
Public Method | ExtractLayer | Extracts a layer from the page content.
Public Method | GetLayerNames | Gets the names of the layers in this page content.
Top

See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

ExtractLayer Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ExtractLayer Method

layerName
The name of the layer to extract.
Extracts a layer from the page content.

Syntax

Visual Basic (Declaration)
Public Function ExtractLayer( _
   ByVal layerName As String _
) As PDFImportedContent
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim layerName As String
Dim value As PDFImportedContent

value = instance.ExtractLayer(layerName)
C#
public PDFImportedContent ExtractLayer(
   string layerName
)
Delphi
public function ExtractLayer(
    layerName: String
): PDFImportedContent;
Managed Extensions for C++
public: PDFImportedContent* ExtractLayer(
   string* layerName
)
C++/CLI
public:
PDFImportedContent^ ExtractLayer(
   String^ layerName
)

Parameters

layerName
The name of the layer to extract.

Return Value

The layer as a PDFImportedContent object.

Remarks

If the layer does not exist, null (Nothing in VB.NET) is returned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

GetLayerNames Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : GetLayerNames Method

Gets the names of the layers in this page content.

Syntax

Visual Basic (Declaration)
Public Function GetLayerNames() As String()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value() As String

value = instance.GetLayerNames()
C#
public string[] GetLayerNames()
Delphi
public function GetLayerNames(): array of String;
Managed Extensions for C++
public: string*[]* GetLayerNames();
C++/CLI
public:
array<String^>^ GetLayerNames();

Return Value

List of layer names in this page content or null if no layers exist.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%% $$Properties$$

PDFImportedContent Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

For a list of all members of this type, see PDFImportedContent members.

Public Properties

 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | ContentStream | Gets the page's content stream.
Public Property | Height | Gets the height of the imported page content.
Public Property | ResourceManager | Gets the imported resources manager for this page content object.
Public Property | Rotate | Gets the rotation angle of the page that includes this content.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the width of the imported page content.
Public Property | X | Gets the x of the imported page content.
Public Property | Y | Gets the y of the imported page content.
Top

See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

ClipHeight Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipHeight Property

Gets or sets the visible height of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

instance.ClipHeight = value

value = instance.ClipHeight
C#
public float ClipHeight {get; set;}
Delphi
public read-write property ClipHeight: Single;
Managed Extensions for C++
public: __property float get_ClipHeight();
public: __property void set_ClipHeight(
   float value
);
C++/CLI
public:
property float ClipHeight {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

ClipLeft Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipLeft Property

Gets or sets the left coordinate of the visible part of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipLeft As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

instance.ClipLeft = value

value = instance.ClipLeft
C#
public float ClipLeft {get; set;}
Delphi
public read-write property ClipLeft: Single;
Managed Extensions for C++
public: __property float get_ClipLeft();
public: __property void set_ClipLeft(
   float value
);
C++/CLI
public:
property float ClipLeft {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

ClipTop Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipTop Property

Gets or sets the top coordinate of the visible part of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipTop As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

instance.ClipTop = value

value = instance.ClipTop
C#
public float ClipTop {get; set;}
Delphi
public read-write property ClipTop: Single;
Managed Extensions for C++
public: __property float get_ClipTop();
public: __property void set_ClipTop(
   float value
);
C++/CLI
public:
property float ClipTop {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

ClipWidth Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipWidth Property

Gets or sets the visible width of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

instance.ClipWidth = value

value = instance.ClipWidth
C#
public float ClipWidth {get; set;}
Delphi
public read-write property ClipWidth: Single;
Managed Extensions for C++
public: __property float get_ClipWidth();
public: __property void set_ClipWidth(
   float value
);
C++/CLI
public:
property float ClipWidth {
   float get();
   void set (float value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

ContentStream Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ContentStream Property

Gets the page's content stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentStream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value() As Byte

value = instance.ContentStream
C#
public byte[] ContentStream {get;}
Delphi
public read-only property ContentStream: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_ContentStream();
C++/CLI
public:
property array<byte>^ ContentStream {
   array<byte>^ get();
}

Return Value

A byte array representing the page's content stream.

Remarks

This property returns the page's content stream after it has decrpyted and decompressed. It contains the stream of raw PDF instructions used to create the page visual appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

Height Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Height Property

Gets the height of the imported page content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

value = instance.Height
C#
public float Height {get;}
Delphi
public read-only property Height: Single;
Managed Extensions for C++
public: __property float get_Height();
C++/CLI
public:
property float Height {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

ResourceManager Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ResourceManager Property

Gets the imported resources manager for this page content object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResourceManager As PDFResourceManager
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As PDFResourceManager

value = instance.ResourceManager
C#
public PDFResourceManager ResourceManager {get;}
Delphi
public read-only property ResourceManager: PDFResourceManager;
Managed Extensions for C++
public: __property PDFResourceManager* get_ResourceManager();
C++/CLI
public:
property PDFResourceManager^ ResourceManager {
   PDFResourceManager^ get();
}

Return Value

A PDFResourceManager object specifying the resource manager for this page content object.

Remarks

The resource manager object stores all the resources (fonts, images, colorspaces, shadings, patterns) used by the page to create its content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

Rotate Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Rotate Property

Gets the rotation angle of the page that includes this content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rotate As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Integer

value = instance.Rotate
C#
public int Rotate {get;}
Delphi
public read-only property Rotate: Integer;
Managed Extensions for C++
public: __property int get_Rotate();
C++/CLI
public:
property int Rotate {
   int get();
}

Return Value

An integer value specifying the rotation angle of the page that includes the content.

Remarks

The page is rotated clockwise around the bottom left corner when the value of this property is positive.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

SeparationInfo Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get;}
Delphi
public read-only property SeparationInfo: PDFSeparationInfo;
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

Width Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Width Property

Gets the width of the imported page content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

value = instance.Width
C#
public float Width {get;}
Delphi
public read-only property Width: Single;
Managed Extensions for C++
public: __property float get_Width();
C++/CLI
public:
property float Width {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

X Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : X Property

Gets the x of the imported page content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

value = instance.X
C#
public float X {get;}
Delphi
public read-only property X: Single;
Managed Extensions for C++
public: __property float get_X();
C++/CLI
public:
property float X {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

Y Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Y Property

Gets the y of the imported page content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Single

value = instance.Y
C#
public float Y {get;}
Delphi
public read-only property Y: Single;
Managed Extensions for C++
public: __property float get_Y();
C++/CLI
public:
property float Y {
   float get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

PDFImportedObject Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedObject Class

Base class for all objects imported from a pdf file.

Syntax

Visual Basic (Declaration)
Public Class PDFImportedObject
   Inherits PDFBaseObject
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedObject
C#
public class PDFImportedObject : PDFBaseObject
Delphi
public class PDFImportedObject = class(PDFBaseObject)
Managed Extensions for C++
public __gc class PDFImportedObject : public PDFBaseObject
C++/CLI
public ref class PDFImportedObject : public PDFBaseObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.PDFFile.PDFSeparationInfo
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFFile.PDFHwep
O2S.Components.PDF4NET.Forms.FDFField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedObject Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedObject Class Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedObject Class

The following tables list the members exposed by PDFImportedObject.

See Also

Reference

PDFImportedObject Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

PDFImportedPage Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

Represents a page in a pdf file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedPage
   Inherits PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
C#
public class PDFImportedPage : PDFPage
Delphi
public class PDFImportedPage = class(PDFPage)
Managed Extensions for C++
public __gc class PDFImportedPage : public PDFPage
C++/CLI
public ref class PDFImportedPage : public PDFPage

Remarks

This class represents a single page in a pdf file. A page can be extracted from a pdf document and included anywhere in a new one.
Links, form fields and annotations are part of the page, so when the page is extracted, these items are extracted too.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedPage Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

The following tables list the members exposed by PDFImportedPage.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ApplyTemplate | Gets of sets the template usage. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ByteCount | Gets the approximate size in bytes of the imported page.
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CustomProperties | Gets the collection of custom properties of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields included in this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Template | Gets of sets the template to be printed on the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Transition | Gets of sets the presentation effect of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top

Public Methods

 | Name | Description
Public Method | GetImages | Gets the lists on images on the page as bitmap objects.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SetFontFile | This method embeds a font in the PDF file.
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedPage Class Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Methods

 | Name | Description
Public Method | GetImages | Gets the lists on images on the page as bitmap objects.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SetFontFile | This method embeds a font in the PDF file.
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

GetImages Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : GetImages Method

Gets the lists on images on the page as bitmap objects.

Syntax

Visual Basic (Declaration)
Public Function GetImages() As Bitmap()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value() As Bitmap

value = instance.GetImages()
C#
public Bitmap[] GetImages()
Delphi
public function GetImages(): array of Bitmap;
Managed Extensions for C++
public: Bitmap[]* GetImages();
C++/CLI
public:
array<Bitmap>^ GetImages();

Return Value

An array of Bitmap objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

ReplaceImage Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ReplaceImage Method

Replaces an existing image with a new image.

Overload List

Overload | Description
ReplaceImage(String,PDFImage) | Replaces an existing image with a new image.
ReplaceImage(Int32,PDFImage) | Replaces an existing image with a new image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

ReplaceImage(String,PDFImage) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(String,PDFImage) Method

imageID
The image ID that identifies the image in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ReplaceImage( _
   ByVal imageID As String, _
   ByVal newImage As PDFImage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim imageID As String
Dim newImage As PDFImage

instance.ReplaceImage(imageID, newImage)
C#
public void ReplaceImage(
   string imageID,
   PDFImage newImage
)
Delphi
public procedure ReplaceImage(
    imageID: String;
    newImage: PDFImage
);
Managed Extensions for C++
public: void ReplaceImage(
   string* imageID,
   PDFImage* newImage
)
C++/CLI
public:
void ReplaceImage(
   String^ imageID,
   PDFImage^ newImage
)

Parameters

imageID
The image ID that identifies the image in the resources dictionary.
newImage
The new image to be embedded in the PDF file.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the image ID is invalid and the specified image does not exist in the resources dictionary.

Remarks

This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


%%PageItemTitle%%

ReplaceImage(Int32,PDFImage) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(Int32,PDFImage) Method

imageIndex
The image index in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ReplaceImage( _
   ByVal imageIndex As Integer, _
   ByVal newImage As PDFImage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim imageIndex As Integer
Dim newImage As PDFImage

instance.ReplaceImage(imageIndex, newImage)
C#
public void ReplaceImage(
   int imageIndex,
   PDFImage newImage
)
Delphi
public procedure ReplaceImage(
    imageIndex: Integer;
    newImage: PDFImage
);
Managed Extensions for C++
public: void ReplaceImage(
   int imageIndex,
   PDFImage* newImage
)
C++/CLI
public:
void ReplaceImage(
   int imageIndex,
   PDFImage^ newImage
)

Parameters

imageIndex
The image index in the resources dictionary.
newImage
The new image to be embedded in the PDF file.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the image index is lower than 0 or greater than number of images on the page.

Remarks

This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


%%PageItemTitle%%

SetFontFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : SetFontFile Method

fontName
the font that will be embedded.
fontFile
the font file to be embedded.
overrideExistingData
a flag specifying whether to override existing embedded data.
This method embeds a font in the PDF file.

Syntax

Visual Basic (Declaration)
Public Function SetFontFile( _
   ByVal fontName As String, _
   ByVal fontFile() As Byte, _
   ByVal overrideExistingData As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim fontName As String
Dim fontFile() As Byte
Dim overrideExistingData As Boolean
Dim value As Boolean

value = instance.SetFontFile(fontName, fontFile, overrideExistingData)
C#
public bool SetFontFile(
   string fontName,
   byte[] fontFile,
   bool overrideExistingData
)
Delphi
public function SetFontFile(
    fontName: String;
    fontFile: Bytearray of;
    overrideExistingData: Boolean
): Boolean;
Managed Extensions for C++
public: bool SetFontFile(
   string* fontName,
   byte[]* fontFile,
   bool overrideExistingData
)
C++/CLI
public:
bool SetFontFile(
   String^ fontName,
   array<byte>^ fontFile,
   bool overrideExistingData
)

Parameters

fontName
the font that will be embedded.
fontFile
the font file to be embedded.
overrideExistingData
a flag specifying whether to override existing embedded data.

Return Value

true if the font file was embedded with success, otherwise false.

Remarks

This method works only with TrueType fonts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%% $$Properties$$

PDFImportedPage Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ApplyTemplate | Gets of sets the template usage. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ByteCount | Gets the approximate size in bytes of the imported page.
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CustomProperties | Gets the collection of custom properties of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields included in this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Template | Gets of sets the template to be printed on the page. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Transition | Gets of sets the presentation effect of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

ByteCount Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ByteCount Property

Gets the approximate size in bytes of the imported page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ByteCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Integer

value = instance.ByteCount
C#
public int ByteCount {get;}
Delphi
public read-only property ByteCount: Integer;
Managed Extensions for C++
public: __property int get_ByteCount();
C++/CLI
public:
property int ByteCount {
   int get();
}

Return Value

an integer value specifying the approximate size, in bytes, of the imported page.

Remarks

This property returns an approximate value representing the size on disk of the imported page. This size includes only the binary streams associated with the page (images, embedded fonts, page content).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

ContentStream Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ContentStream Property

Gets the page's content stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentStream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value() As Byte

value = instance.ContentStream
C#
public byte[] ContentStream {get;}
Delphi
public read-only property ContentStream: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_ContentStream();
C++/CLI
public:
property array<byte>^ ContentStream {
   array<byte>^ get();
}

Return Value

A byte array representing the page's content stream.

Remarks

This property returns the page's content stream after it has decrpyted and decompressed. It contains the stream of raw PDF instructions used to create the page visual appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

SeparationInfo Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get;}
Delphi
public read-only property SeparationInfo: PDFSeparationInfo;
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

UnderCanvas Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : UnderCanvas Property

Gets the canvas of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnderCanvas As PDFCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As PDFCanvas

value = instance.UnderCanvas
C#
public PDFCanvas UnderCanvas {get;}
Delphi
public read-only property UnderCanvas: PDFCanvas;
Managed Extensions for C++
public: __property PDFCanvas* get_UnderCanvas();
C++/CLI
public:
property PDFCanvas^ UnderCanvas {
   PDFCanvas^ get();
}

Return Value

A PDFCanvas object specifying the drawing surface located under actual page content.

Remarks

The under canvas allows to draw directly under existing page content. The regular Canvas draws on top of existing content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

VisibleHeight Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleHeight Property

Gets the height of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Single

value = instance.VisibleHeight
C#
public float VisibleHeight {get;}
Delphi
public read-only property VisibleHeight: Single;
Managed Extensions for C++
public: __property float get_VisibleHeight();
C++/CLI
public:
property float VisibleHeight {
   float get();
}

Return Value

A float value specifying the height of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

VisibleLeft Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleLeft Property

Gets the X coordinate of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleLeft As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Single

value = instance.VisibleLeft
C#
public float VisibleLeft {get;}
Delphi
public read-only property VisibleLeft: Single;
Managed Extensions for C++
public: __property float get_VisibleLeft();
C++/CLI
public:
property float VisibleLeft {
   float get();
}

Return Value

A float value specifying the X coordinate of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

VisibleTop Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleTop Property

Gets the Y coordinate of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleTop As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Single

value = instance.VisibleTop
C#
public float VisibleTop {get;}
Delphi
public read-only property VisibleTop: Single;
Managed Extensions for C++
public: __property float get_VisibleTop();
C++/CLI
public:
property float VisibleTop {
   float get();
}

Return Value

A float value specifying the Y coordinate of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

VisibleWidth Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleWidth Property

Gets the width of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Single

value = instance.VisibleWidth
C#
public float VisibleWidth {get;}
Delphi
public read-only property VisibleWidth: Single;
Managed Extensions for C++
public: __property float get_VisibleWidth();
C++/CLI
public:
property float VisibleWidth {
   float get();
}

Return Value

A float value specifying the width of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

PDFImportedPageInfo Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

Represents the properties of an imported page, but without actual page content.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedPageInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
C#
public class PDFImportedPageInfo
Delphi
public class PDFImportedPageInfo
Managed Extensions for C++
public __gc class PDFImportedPageInfo
C++/CLI
public ref class PDFImportedPageInfo

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedPageInfo Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

The following tables list the members exposed by PDFImportedPageInfo.

Public Properties

 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | ResourceManager | Gets the imported resources manager for this page.
Public Property | Rotate | Gets the rotation angle of the corresponding page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top

See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Properties$$

PDFImportedPageInfo Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

For a list of all members of this type, see PDFImportedPageInfo members.

Public Properties

 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | ResourceManager | Gets the imported resources manager for this page.
Public Property | Rotate | Gets the rotation angle of the corresponding page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top

See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

ArtBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : ArtBox Property

Gets the dimensions of the page's art box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArtBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRect

value = instance.ArtBox
C#
public PDFRect ArtBox {get;}
Delphi
public read-only property ArtBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_ArtBox();
C++/CLI
public:
property PDFRect^ ArtBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object representing the page's art box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

BleedBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : BleedBox Property

Gets the dimensions of the page's bleed box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BleedBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRect

value = instance.BleedBox
C#
public PDFRect BleedBox {get;}
Delphi
public read-only property BleedBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_BleedBox();
C++/CLI
public:
property PDFRect^ BleedBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object representing the page's bleed box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

CropBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : CropBox Property

Gets the dimensions of the page's crop box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CropBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRect

value = instance.CropBox
C#
public PDFRect CropBox {get;}
Delphi
public read-only property CropBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_CropBox();
C++/CLI
public:
property PDFRect^ CropBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object representing the page's crop box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

MediaBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : MediaBox Property

Gets the dimensions of the page's media box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MediaBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRect

value = instance.MediaBox
C#
public PDFRect MediaBox {get;}
Delphi
public read-only property MediaBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_MediaBox();
C++/CLI
public:
property PDFRect^ MediaBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object representing the page's media box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

ResourceManager Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : ResourceManager Property

Gets the imported resources manager for this page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResourceManager As PDFResourceManager
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFResourceManager

value = instance.ResourceManager
C#
public PDFResourceManager ResourceManager {get;}
Delphi
public read-only property ResourceManager: PDFResourceManager;
Managed Extensions for C++
public: __property PDFResourceManager* get_ResourceManager();
C++/CLI
public:
property PDFResourceManager^ ResourceManager {
   PDFResourceManager^ get();
}

Return Value

A PDFResourceManager object specifying the resource manager for this page.

Remarks

The resource manager object stores all the resources (fonts, images, colorspaces, shadings, patterns) used by the page to create its content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

Rotate Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : Rotate Property

Gets the rotation angle of the corresponding page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rotate As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As Integer

value = instance.Rotate
C#
public int Rotate {get;}
Delphi
public read-only property Rotate: Integer;
Managed Extensions for C++
public: __property int get_Rotate();
C++/CLI
public:
property int Rotate {
   int get();
}

Return Value

An integer value representing the rotation angle of the corresponding page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

SeparationInfo Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get;}
Delphi
public read-only property SeparationInfo: PDFSeparationInfo;
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

TrimBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : TrimBox Property

Gets the dimensions of the page's trim box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TrimBox As PDFRect
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRect

value = instance.TrimBox
C#
public PDFRect TrimBox {get;}
Delphi
public read-only property TrimBox: PDFRect;
Managed Extensions for C++
public: __property PDFRect* get_TrimBox();
C++/CLI
public:
property PDFRect^ TrimBox {
   PDFRect^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFRect object representing the page's trim box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


%%PageItemTitle%%

PDFSeparationInfo Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFSeparationInfo Class

Defines the separation information for an existing PDF page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationInfo
   Inherits PDFImportedObject
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
C#
public class PDFSeparationInfo : PDFImportedObject
Delphi
public class PDFSeparationInfo = class(PDFImportedObject)
Managed Extensions for C++
public __gc class PDFSeparationInfo : public PDFImportedObject
C++/CLI
public ref class PDFSeparationInfo : public PDFImportedObject

Remarks

All pages that represent the separations of the master page have the same SeparationID.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFFile.PDFImportedObject
O2S.Components.PDF4NET.PDFFile.PDFSeparationInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationInfo Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFSeparationInfo Class

The following tables list the members exposed by PDFSeparationInfo.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets the list of pages included in the same separation group.
Public Property | SeparationID | Gets or sets the id of the separation group.
Top

See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Properties$$

PDFSeparationInfo Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFSeparationInfo Class

For a list of all members of this type, see PDFSeparationInfo members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets the list of pages included in the same separation group.
Public Property | SeparationID | Gets or sets the id of the separation group.
Top

See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%%

ColorSpace Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFSeparationInfo Class : ColorSpace Property

Gets the colorspace for this separation object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value As PDFColorSpace

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get;}
Delphi
public read-only property ColorSpace: PDFColorSpace;
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
}

Return Value

A PDFBaseColorSpace object specifying the colorspace used by this separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

DeviceColorant Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFSeparationInfo Class : DeviceColorant Property

Gets the name of the device colorant used in rendering this separation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceColorant As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value As String

value = instance.DeviceColorant
C#
public string DeviceColorant {get;}
Delphi
public read-only property DeviceColorant: String;
Managed Extensions for C++
public: __property string* get_DeviceColorant();
C++/CLI
public:
property String^ DeviceColorant {
   String^ get();
}

Return Value

A string value representing the name of the device colorant used in rendering this separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

Pages Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFSeparationInfo Class : Pages Property

Gets the list of pages included in the same separation group.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As Integer()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value() As Integer

value = instance.Pages
C#
public int[] Pages {get;}
Delphi
public read-only property Pages: array of Integer;
Managed Extensions for C++
public: __property int[]* get_Pages();
C++/CLI
public:
property array<int>^ Pages {
   array<int>^ get();
}

Return Value

An array of integer values representing the page indexes.

Remarks

All pages in this array have the same SeparationID.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

SeparationID Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFSeparationInfo Class : SeparationID Property

Gets or sets the id of the separation group.

Syntax

Visual Basic (Declaration)
Public Property SeparationID As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value As String

instance.SeparationID = value

value = instance.SeparationID
C#
public string SeparationID {get; set;}
Delphi
public read-write property SeparationID: String;
Managed Extensions for C++
public: __property string* get_SeparationID();
public: __property void set_SeparationID(
   string* value
);
C++/CLI
public:
property String^ SeparationID {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the id of the separation group this separation object belongs to.

Remarks

All pages that represent the separations of the same master page are grouped into a separation group using this property. All separations with the same ID form a group.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

ContentMirroring Enumeration
[image]
O2S.Components.PDF4NET.PDFFile Namespace : ContentMirroring Enumeration

Specifies the available mirroring options when displaying imported content.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum ContentMirroring
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ContentMirroring
C#
[FlagsAttribute()]
public enum ContentMirroring : Enum
Delphi
public enum ContentMirroring = class(Enum)
Managed Extensions for C++
[FlagsAttribute()]
__value public enum ContentMirroring : public Enum
C++/CLI
[FlagsAttribute()]
public enum class ContentMirroring : public Enum

Members

Member | Description
NoMirroring | The imported content is drawn as it is.
XAxisMirroring | The imported content is mirrored about X axis.
YAxisMirroring | The imported content is mirrored about Y axis.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFFile.ContentMirroring

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.PDFFile Namespace


%%ItemTitle%%

O2S.Components.PDF4NET.PDFFile.Resources Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFImportedColorSpacesCollection | Defines the list of imported color spaces from an existing PDF file.
PDFResourceManager | Defines the pool of resources used to create the page content.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.PDFFile.Resources Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.Resources.PDFImportedColorSpacesCollection
O2S.Components.PDF4NET.PDFFile.Resources.PDFResourceManager

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFImportedColorSpacesCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFImportedColorSpacesCollection Class

Defines the list of imported color spaces from an existing PDF file.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFImportedColorSpacesCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
C#
[DefaultMemberAttribute("Item")]
public class PDFImportedColorSpacesCollection
Delphi
public class PDFImportedColorSpacesCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFImportedColorSpacesCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFImportedColorSpacesCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.Resources.PDFImportedColorSpacesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Members
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%% $$Members$$

PDFImportedColorSpacesCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFImportedColorSpacesCollection Class

The following tables list the members exposed by PDFImportedColorSpacesCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of colorspaces in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the colorspace at the specified index.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFImportedColorSpacesCollection Class
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedColorSpacesCollection Class Methods
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFImportedColorSpacesCollection Class

For a list of all members of this type, see PDFImportedColorSpacesCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

PDFImportedColorSpacesCollection Class
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%%

MoveNext Method
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Delphi
public function MoveNext(): Boolean;
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%%

Reset Method
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%% $$Properties$$

PDFImportedColorSpacesCollection Class Properties
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFImportedColorSpacesCollection Class

For a list of all members of this type, see PDFImportedColorSpacesCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of colorspaces in the collection.
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Get the colorspace at the specified index.
Top

See Also

Reference

PDFImportedColorSpacesCollection Class
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%%

Count Property
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : Count Property

Returns the number of colorspaces in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%%

Current Property
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Delphi
public read-only property Current: TObject;
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%%

Item Property
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFImportedColorSpacesCollection Class : Item Property

index
Get the colorspace at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedColorSpacesCollection
Dim index As Integer
Dim value As PDFColorSpace

value = instance.Item(index)
C#
public PDFColorSpace this[
   int index
]; {get;}
Delphi
public  this: : PDFColorSpace;[
    index: Integer
]; read-only
Managed Extensions for C++
public: __property PDFColorSpace* get_Item(
   int index
);
C++/CLI
public:
property PDFColorSpace^ default [int] {
   PDFColorSpace^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedColorSpacesCollection Class
PDFImportedColorSpacesCollection Members


%%PageItemTitle%%

PDFResourceManager Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFResourceManager Class

Defines the pool of resources used to create the page content.

Syntax

Visual Basic (Declaration)
Public Class PDFResourceManager
Visual Basic (Usage) Copy Code
Dim instance As PDFResourceManager
C#
public class PDFResourceManager
Delphi
public class PDFResourceManager
Managed Extensions for C++
public __gc class PDFResourceManager
C++/CLI
public ref class PDFResourceManager

Remarks

When a PDF file is imported, the PDFResourceManager of each page is automatically poulated with the resources used by the page.
The resource manager stores all the resources (fonts, images, colorspaces, shadings, patterns) used by the page to create its content.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.Resources.PDFResourceManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResourceManager Members
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%% $$Members$$

PDFResourceManager Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFResourceManager Class

The following tables list the members exposed by PDFResourceManager.

Public Properties

 | Name | Description
Public Property | ColorSpaces | Gets the available colorspace resources.
Top

See Also

Reference

PDFResourceManager Class
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%% $$Properties$$

PDFResourceManager Class Properties
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace : PDFResourceManager Class

For a list of all members of this type, see PDFResourceManager members.

Public Properties

 | Name | Description
Public Property | ColorSpaces | Gets the available colorspace resources.
Top

See Also

Reference

PDFResourceManager Class
O2S.Components.PDF4NET.PDFFile.Resources Namespace


%%PageItemTitle%%

ColorSpaces Property
[image]
O2S.Components.PDF4NET.PDFFile.Resources Namespace > PDFResourceManager Class : ColorSpaces Property

Gets the available colorspace resources.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorSpaces As PDFImportedColorSpacesCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFResourceManager
Dim value As PDFImportedColorSpacesCollection

value = instance.ColorSpaces
C#
public PDFImportedColorSpacesCollection ColorSpaces {get;}
Delphi
public read-only property ColorSpaces: PDFImportedColorSpacesCollection;
Managed Extensions for C++
public: __property PDFImportedColorSpacesCollection* get_ColorSpaces();
C++/CLI
public:
property PDFImportedColorSpacesCollection^ ColorSpaces {
   PDFImportedColorSpacesCollection^ get();
}

Return Value

An PDFImportedColorSpacesCollection object storing a heterogeneous list of colorspace objects, like PDFImportedSeparationColorSpace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResourceManager Class
PDFResourceManager Members


%%ItemTitle%%

O2S.Components.PDF4NET.Security Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFDigitalSignature | Defines a digital signature used for signing a PDF file.
PDFSecurityManager | Manages the security settings for a pdf document. Supported by Compact .NET Edition.

Enumerations

Enumeration | Description
EncryptionAlgorithm | Specifies the available encryption algorithms.
EncryptionKeySize | Specifies the available key sizes when encrypting a pdf document. Supported by Compact .NET Edition.

See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Security Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature
O2S.Components.PDF4NET.Security.PDFSecurityManager

See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFDigitalSignature Class
See Also Members
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

Defines a digital signature used for signing a PDF file.

Syntax

Visual Basic (Declaration)
Public Class PDFDigitalSignature
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
C#
public class PDFDigitalSignature : PDFObject
Delphi
public class PDFDigitalSignature = class(PDFObject)
Managed Extensions for C++
public __gc class PDFDigitalSignature : public PDFObject
C++/CLI
public ref class PDFDigitalSignature : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Members
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%% $$Members$$

PDFDigitalSignature Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

The following tables list the members exposed by PDFDigitalSignature.

Public Constructors

 | Name | Description
Public Constructor | PDFDigitalSignature Constructor | Initializes a new O2S.Components.PDF4NET.Security.PDFDigitalSignature object.
Top

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top

See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

PDFDigitalSignature Constructor
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor

Initializes a new O2S.Components.PDF4NET.Security.PDFDigitalSignature object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature()
C#
public PDFDigitalSignature()
Delphi
public PDFDigitalSignature();
Managed Extensions for C++
public: PDFDigitalSignature();
C++/CLI
public:
PDFDigitalSignature();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%% $$Properties$$

PDFDigitalSignature Class Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

For a list of all members of this type, see PDFDigitalSignature members.

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top

See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

Certificate Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Certificate Property

Gets or sets the certificate for signing the PDF document.

Syntax

Visual Basic (Declaration)
Public Property Certificate As X509Certificate2
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
C#
public X509Certificate2 Certificate {get; set;}
Delphi
public read-write property Certificate: X509Certificate2;
Managed Extensions for C++
public: __property X509Certificate2 get_Certificate();
public: __property void set_Certificate(
   X509Certificate2 value
);
C++/CLI
public:
property X509Certificate2 Certificate {
   X509Certificate2 get();
   void set (X509Certificate2 value);
}

Return Value

A X509Certificate2 object specifying the certificate for signing.

Remarks

This property also sets the Name property to the name in the certificate.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

ContactInfo Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : ContactInfo Property

Gets or sets the signer's contact information.

Syntax

Visual Basic (Declaration)
Public Property ContactInfo As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.ContactInfo = value

value = instance.ContactInfo
C#
public string ContactInfo {get; set;}
Delphi
public read-write property ContactInfo: String;
Managed Extensions for C++
public: __property string* get_ContactInfo();
public: __property void set_ContactInfo(
   string* value
);
C++/CLI
public:
property String^ ContactInfo {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the signer's contact information.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

Location Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Location Property

Gets or sets the location of the signer.

Syntax

Visual Basic (Declaration)
Public Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Location = value

value = instance.Location
C#
public string Location {get; set;}
Delphi
public read-write property Location: String;
Managed Extensions for C++
public: __property string* get_Location();
public: __property void set_Location(
   string* value
);
C++/CLI
public:
property String^ Location {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the location of the signer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

Name Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Name Property

Gets or sets the name of the signer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of the signer.

Remarks

The Certificate property overwrites the value of this property with the name stored in the certificate. If you want to set the Name to another value, set this property after the Certificate property has been set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

Reason Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Reason Property

Gets or sets the reason for signing the document.

Syntax

Visual Basic (Declaration)
Public Property Reason As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Reason = value

value = instance.Reason
C#
public string Reason {get; set;}
Delphi
public read-write property Reason: String;
Managed Extensions for C++
public: __property string* get_Reason();
public: __property void set_Reason(
   string* value
);
C++/CLI
public:
property String^ Reason {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the reason for signing the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

PDFSecurityManager Class
See Also Members
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

Manages the security settings for a pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Class PDFSecurityManager
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
C#
public class PDFSecurityManager : PDFObject
Delphi
public class PDFSecurityManager = class(PDFObject)
Managed Extensions for C++
public __gc class PDFSecurityManager : public PDFObject
C++/CLI
public ref class PDFSecurityManager : public PDFObject

Remarks

A PDFSecurityManager object manages the security associated with a pdf document. It allows to set user and owner passwords, set encryption strength (40 or 128 bit) or set the access rights over the document.
When a PDFSecurityManager object is attached to a PDFDocument object, the resulted pdf file is automatically encrypted.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBaseObject
O2S.Components.PDF4NET.PDFObject
O2S.Components.PDF4NET.Security.PDFSecurityManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Members
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%% $$Members$$

PDFSecurityManager Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

The following tables list the members exposed by PDFSecurityManager.

Public Constructors

 | Name | Description
Public Constructor | PDFSecurityManager Constructor | Initializes a new PDFSecurityManager object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key. Supported by Compact .NET Edition.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

PDFSecurityManager Constructor
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : PDFSecurityManager Constructor

Initializes a new PDFSecurityManager object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager()
C#
public PDFSecurityManager()
Delphi
public PDFSecurityManager();
Managed Extensions for C++
public: PDFSecurityManager();
C++/CLI
public:
PDFSecurityManager();

Remarks

When a PDFSecurityManager object is created, all the public properties are set to true, the user and owner passwords are null, and the encryption strength is set to 128 bit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%% $$Properties$$

PDFSecurityManager Class Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

For a list of all members of this type, see PDFSecurityManager members.

Public Properties

 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key. Supported by Compact .NET Edition.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

AllowAccessibilityExtractContent Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAccessibilityExtractContent Property

Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowAccessibilityExtractContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAccessibilityExtractContent = value

value = instance.AllowAccessibilityExtractContent
C#
public bool AllowAccessibilityExtractContent {get; set;}
Delphi
public read-write property AllowAccessibilityExtractContent: Boolean;
Managed Extensions for C++
public: __property bool get_AllowAccessibilityExtractContent();
public: __property void set_AllowAccessibilityExtractContent(
   bool value
);
C++/CLI
public:
property bool AllowAccessibilityExtractContent {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to extract the content of the document in support of accessibility.

Remarks

This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other purposes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowAssembleDocument Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAssembleDocument Property

Gets or sets whether the user is allowed to assemble the pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowAssembleDocument As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAssembleDocument = value

value = instance.AllowAssembleDocument
C#
public bool AllowAssembleDocument {get; set;}
Delphi
public read-write property AllowAssembleDocument: Boolean;
Managed Extensions for C++
public: __property bool get_AllowAssembleDocument();
public: __property void set_AllowAssembleDocument(
   bool value
);
C++/CLI
public:
property bool AllowAssembleDocument {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to assemble the pdf document or not.

Remarks

This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), event property AllowModifyDocument is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowExtractContent Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowExtractContent Property

Gets or sets whether the user is allowed to extract the content of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowExtractContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowExtractContent = value

value = instance.AllowExtractContent
C#
public bool AllowExtractContent {get; set;}
Delphi
public read-write property AllowExtractContent: Boolean;
Managed Extensions for C++
public: __property bool get_AllowExtractContent();
public: __property void set_AllowExtractContent(
   bool value
);
C++/CLI
public:
property bool AllowExtractContent {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to extract the content of the document.

Remarks

When using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey), this property, if true, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by property AllowAccessibilityExtractContent. When using 40 bit encryption (KeySize property is set to EncryptionKeySize.Use40BitKey), then this property also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowFormsFill Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowFormsFill Property

Gets or sets whether the user is allowed to fill the form fields in the pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowFormsFill As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowFormsFill = value

value = instance.AllowFormsFill
C#
public bool AllowFormsFill {get; set;}
Delphi
public read-write property AllowFormsFill: Boolean;
Managed Extensions for C++
public: __property bool get_AllowFormsFill();
public: __property void set_AllowFormsFill(
   bool value
);
C++/CLI
public:
property bool AllowFormsFill {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to fill the form fields in the pdf document.

Remarks

This property has effect only when using 128 bit encryption. (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to fill in existing interactive form fields (including signature fields), event property AllowInteractiveEdit is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowInteractiveEdit Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowInteractiveEdit Property

Gets or sets whether the user is allowed to perform interactive edit operations on the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowInteractiveEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowInteractiveEdit = value

value = instance.AllowInteractiveEdit
C#
public bool AllowInteractiveEdit {get; set;}
Delphi
public read-write property AllowInteractiveEdit: Boolean;
Managed Extensions for C++
public: __property bool get_AllowInteractiveEdit();
public: __property void set_AllowInteractiveEdit(
   bool value
);
C++/CLI
public:
property bool AllowInteractiveEdit {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to perform interactive edit operations on the document.

Remarks

This property, if true, allows a user to add or modify text annotations, fill in interactive forms fields, and, if property AllowModifyDocument is true, create or modify interactive form fields (including signature fields).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowModifyDocument Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowModifyDocument Property

Gets or sets whether the user is allowed to modify the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowModifyDocument As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowModifyDocument = value

value = instance.AllowModifyDocument
C#
public bool AllowModifyDocument {get; set;}
Delphi
public read-write property AllowModifyDocument: Boolean;
Managed Extensions for C++
public: __property bool get_AllowModifyDocument();
public: __property void set_AllowModifyDocument(
   bool value
);
C++/CLI
public:
property bool AllowModifyDocument {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to modify the document or not.

Remarks

This property, if true, allows a user to modify the content of pdf document by operations other than those controlled by the following properties: AllowInteractiveEdit, AllowFormsFill, AllowAssembleDocument.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

AllowPrint Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowPrint Property

Gets or sets whether the user is allowed to print the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowPrint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowPrint = value

value = instance.AllowPrint
C#
public bool AllowPrint {get; set;}
Delphi
public read-write property AllowPrint: Boolean;
Managed Extensions for C++
public: __property bool get_AllowPrint();
public: __property void set_AllowPrint(
   bool value
);
C++/CLI
public:
property bool AllowPrint {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed or not to print the document.

Remarks

This property, together with FullQualityPrint and KeySize properties, controls the printing of the document. If this property is false, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint and KeySize properties. If KeySize is EncryptionKeySize.Use40BitKey then FullQualityPrint property is ignored. If KeySize is EncryptionKeySize.Use128BitKey then if FullQualityPrint is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

EncryptionAlgorithm Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptionAlgorithm Property

Gets or sets the encryption algorithm used to encrypt the PDF file.

Syntax

Visual Basic (Declaration)
Public Property EncryptionAlgorithm As EncryptionAlgorithm
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As EncryptionAlgorithm

instance.EncryptionAlgorithm = value

value = instance.EncryptionAlgorithm
C#
public EncryptionAlgorithm EncryptionAlgorithm {get; set;}
Delphi
public read-write property EncryptionAlgorithm: EncryptionAlgorithm;
Managed Extensions for C++
public: __property EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property void set_EncryptionAlgorithm(
   EncryptionAlgorithm value
);
C++/CLI
public:
property EncryptionAlgorithm EncryptionAlgorithm {
   EncryptionAlgorithm get();
   void set (EncryptionAlgorithm value);
}

Remarks

When using AES encrpytion the key size is always 128 bit and the KeySize property is set automatically to 128 bit and it can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

EncryptMetadata Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptMetadata Property

Gets or sets a value indicatig whether document level metadata should be encrypted.

Syntax

Visual Basic (Declaration)
Public Property EncryptMetadata As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
C#
public bool EncryptMetadata {get; set;}
Delphi
public read-write property EncryptMetadata: Boolean;
Managed Extensions for C++
public: __property bool get_EncryptMetadata();
public: __property void set_EncryptMetadata(
   bool value
);
C++/CLI
public:
property bool EncryptMetadata {
   bool get();
   void set (bool value);
}

Return Value

True if the document metadata is encrypted (default), false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

FullQualityPrint Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : FullQualityPrint Property

Gets or sets the quality of the document printing.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FullQualityPrint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.FullQualityPrint = value

value = instance.FullQualityPrint
C#
public bool FullQualityPrint {get; set;}
Delphi
public read-write property FullQualityPrint: Boolean;
Managed Extensions for C++
public: __property bool get_FullQualityPrint();
public: __property void set_FullQualityPrint(
   bool value
);
C++/CLI
public:
property bool FullQualityPrint {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the document is printed in full quality or not.

Remarks

This property has effect only when AllowPrint property is true and KeySize property is set to EncryptionKeySize.Use128BitKey. If this property is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

KeySize Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : KeySize Property

Gets or sets the length of the encryption key.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property KeySize As EncryptionKeySize
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As EncryptionKeySize

instance.KeySize = value

value = instance.KeySize
C#
public EncryptionKeySize KeySize {get; set;}
Delphi
public read-write property KeySize: EncryptionKeySize;
Managed Extensions for C++
public: __property EncryptionKeySize get_KeySize();
public: __property void set_KeySize(
   EncryptionKeySize value
);
C++/CLI
public:
property EncryptionKeySize KeySize {
   EncryptionKeySize get();
   void set (EncryptionKeySize value);
}

Return Value

A EncryptionKeySize enumeration member specifying the length of the encryption key. If the EncryptionAlgorithm property is EncryptionAlgorithm.Aes, then this property is EncryptionKeySize.Use128BitKey and it can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

OwnerPassword Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : OwnerPassword Property

Gets or sets the owner password for the pdf document this security manager object is attached to.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value() As Byte

instance.OwnerPassword = value

value = instance.OwnerPassword
C#
public byte[] OwnerPassword {get; set;}
Delphi
public read-write property OwnerPassword: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_OwnerPassword();
public: __property void set_OwnerPassword(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ OwnerPassword {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the owner password for the pdf file.

Remarks

An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

UserPassword Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : UserPassword Property

Gets or sets the user password for the pdf document this security manager object is attached to.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property UserPassword As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value() As Byte

instance.UserPassword = value

value = instance.UserPassword
C#
public byte[] UserPassword {get; set;}
Delphi
public read-write property UserPassword: array of Byte;
Managed Extensions for C++
public: __property byte[]* get_UserPassword();
public: __property void set_UserPassword(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ UserPassword {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the user password for the pdf file.

Remarks

A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

EncryptionAlgorithm Enumeration
[image]
O2S.Components.PDF4NET.Security Namespace : EncryptionAlgorithm Enumeration

Specifies the available encryption algorithms.

Syntax

Visual Basic (Declaration)
Public Enum EncryptionAlgorithm
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EncryptionAlgorithm
C#
public enum EncryptionAlgorithm : Enum
Delphi
public enum EncryptionAlgorithm = class(Enum)
Managed Extensions for C++
__value public enum EncryptionAlgorithm : public Enum
C++/CLI
public enum class EncryptionAlgorithm : public Enum

Members

Member | Description
Aes | 128 bit AES encryption. Supported in PDF 1.6 or higher.
RC4 | 40 bit or 128 bit RC4 encryption.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionAlgorithm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

EncryptionKeySize Enumeration
[image]
O2S.Components.PDF4NET.Security Namespace : EncryptionKeySize Enumeration

Specifies the available key sizes when encrypting a pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum EncryptionKeySize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EncryptionKeySize
C#
public enum EncryptionKeySize : Enum
Delphi
public enum EncryptionKeySize = class(Enum)
Managed Extensions for C++
__value public enum EncryptionKeySize : public Enum
C++/CLI
public enum class EncryptionKeySize : public Enum

Members

Member | Description
Use40BitKey | A 40 bit encryption key will be used to encrypt the pdf document. Supported by Compact .NET Edition.
Use128BitKey | A 128 bit encryption key will be used to encrypt the pdf document. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionKeySize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%% $$Properties$$

PDFCheckBoxAppearance Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxAppearance Class

For a list of all members of this type, see PDFCheckBoxAppearance members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFCheckBoxAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFCheckBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFDropDownListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFPushbuttonField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushbuttonField Class

For a list of all members of this type, see PDFPushbuttonField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFPushbuttonField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFRadioButtonAppearance Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonAppearance Class

For a list of all members of this type, see PDFRadioButtonAppearance members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the actions to be performed by this field widget in response to widget events. (Inherited from PDFFieldAppearance)
Public Property | Align | Gets or sets the text alignment in a text box. (Inherited from PDFFieldAppearance)
Public Property | BackColor | Gets or sets the background color of the field. (Inherited from PDFFieldAppearance)
Public Property | Border | Gets or sets the border of this field. (Inherited from PDFFieldAppearance)
Public Property | Canvas | Gets the canvas of the form field. (Inherited from PDFFieldAppearance)
Public Property | Font | Gets or sets the font used by this field. (Inherited from PDFFieldAppearance)
Public Property | ForeColor | Gets or sets the foreground color of the field. (Inherited from PDFFieldAppearance)
Public Property | Height | Gets or sets the height of the field rectangle. (Inherited from PDFFieldAppearance)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the fields's rectangle. (Inherited from PDFFieldAppearance)
Public Property | OverrideExistingAppearance | Gets or sets whether existing field appearance should be overriden with new content. (Inherited from PDFFieldAppearance)
Public Property | Page | Gets the page that includes this field appearance. (Inherited from PDFFieldAppearance)
Public Property | Position | Gets or sets the position of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rectangle | Gets or sets the bounding rectangle of this field object. (Inherited from PDFFieldAppearance)
Public Property | Rotation | Gets or sets the field rotation angle. (Inherited from PDFFieldAppearance)
Public Property | Size | Gets or sets the size of this field object. (Inherited from PDFFieldAppearance)
Public Property | TabOrderIndex | Gets or sets the tab order for this field. (Inherited from PDFFieldAppearance)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the field's rectangle. (Inherited from PDFFieldAppearance)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field. (Inherited from PDFFieldAppearance)
Public Property | Width | Gets or sets the width of the field rectangle. (Inherited from PDFFieldAppearance)
Top

See Also

Reference

PDFRadioButtonAppearance Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFRadioButtonListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFSignatureField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFTextBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Methods

 | Name | Description
Public Method | ActivateFirstWidget | Activates the first field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateLastWidget | Activates the last field widget within the page or document. (Inherited from PDFField)
Public Method | ActivateNextWidget | Activates the next field widget within the page or document. (Inherited from PDFField)
Public Method | ActivatePreviousWidget | Activates the previous field widget within the page. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFWidgetAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFWidgetAnnotation Class

For a list of all members of this type, see PDFWidgetAnnotation members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border of this field. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | BorderColor | Gets or sets the color of this annotation's border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Caption | Gets or sets the caption of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the contents of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the flags associated with this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Height | Gets or sets the height of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the id of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | LastModified | Gets or sets the date and time when the annotation was most recently modified. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the opacity of the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Position | Gets or sets the position of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the bounding rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets or sets the size of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the annotation's rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Width | Gets or sets the width of the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top

See Also

Reference

PDFWidgetAnnotation Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFAArea Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

For a list of all members of this type, see XFAArea members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

For a list of all members of this type, see XFAButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPageArea Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

For a list of all members of this type, see XFAPageArea members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

BarcodeEncodingException Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

BarcodeEncodingException Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCodabarBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

For a list of all members of this type, see PDFCodabarBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode11Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

For a list of all members of this type, see PDFCode11Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode25InterleavedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

For a list of all members of this type, see PDFCode25InterleavedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode32Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

For a list of all members of this type, see PDFCode32Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode39ExtendedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

For a list of all members of this type, see PDFCode39ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

For a list of all members of this type, see PDFCode93Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93ExtendedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

For a list of all members of this type, see PDFCode93ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128ABarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

For a list of all members of this type, see PDFCode128ABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

For a list of all members of this type, see PDFCode128Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128BBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

For a list of all members of this type, see PDFCode128BBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128CBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

For a list of all members of this type, see PDFCode128CBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCOOP25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

For a list of all members of this type, see PDFCOOP25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN8Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

For a list of all members of this type, see PDFEAN8Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN13Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

For a list of all members of this type, see PDFEAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFFedExGround96Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

For a list of all members of this type, see PDFFedExGround96Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFHeightModulatedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

For a list of all members of this type, see PDFHeightModulatedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIATA25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

For a list of all members of this type, see PDFIATA25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIdentcodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

For a list of all members of this type, see PDFIdentcodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISBNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

For a list of all members of this type, see PDFISBNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISMNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

For a list of all members of this type, see PDFISMNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISSNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

For a list of all members of this type, see PDFISSNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFJAN13Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

For a list of all members of this type, see PDFJAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFKixBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

For a list of all members of this type, see PDFKixBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFLeitcodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

For a list of all members of this type, see PDFLeitcodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMatrix25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

For a list of all members of this type, see PDFMatrix25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFMicroPDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMSIPlesseyBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

For a list of all members of this type, see PDFMSIPlesseyBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPlanetBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

For a list of all members of this type, see PDFPlanetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPostNetBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

For a list of all members of this type, see PDFPostNetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPZNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

For a list of all members of this type, see PDFPZNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFRM4SCCBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

For a list of all members of this type, see PDFRM4SCCBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSCC14Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

For a list of all members of this type, see PDFSCC14Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSingaporePostBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

For a list of all members of this type, see PDFSingaporePostBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSSCC18Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

For a list of all members of this type, see PDFSSCC18Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCABarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

For a list of all members of this type, see PDFUPCABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCEBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

For a list of all members of this type, see PDFUPCEBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSFIMBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

For a list of all members of this type, see PDFUSPSFIMBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSHorizontalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

For a list of all members of this type, see PDFUSPSHorizontalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSPICBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

For a list of all members of this type, see PDFUSPSPICBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFCalGrayColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFCalRgbColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFDeviceNColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFExtendedColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFExtendedColor Class

For a list of all members of this type, see PDFExtendedColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFExtendedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFICCColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedSeparationColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFImportedSeparationColorSpace Class

For a list of all members of this type, see PDFImportedSeparationColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Tests if the given object is equal to this object. (Inherited from PDFSeparationColorSpace)
Public Method | GetHashCode | Computes the object's hash code. (Inherited from PDFSeparationColorSpace)
Top

See Also

Reference

PDFImportedSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFIndexedColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFLabColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFPantoneColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFSeparationColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones the current color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBaseColor)
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

CJKFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

PostScriptFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

TrueTypeFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Public Method | MeasureString | Measures the specified string when drawn with this font object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFFont)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Properties$$

PDFCustomBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCustomBrush Class

For a list of all members of this type, see PDFCustomBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFCustomBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFHorizontalGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

For a list of all members of this type, see PDFHorizontalGradientBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | EndColor | (Inherited from PDFGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFGradientBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFVerticalGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

For a list of all members of this type, see PDFVerticalGradientBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. Supported by Compact .NET Edition. (Inherited from PDFBrush)
Public Property | EndColor | (Inherited from PDFGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFGradientBrush)
Public Property | UseOverprint | Gets or sets a value indicating whether overprint is enabled before applying the brush. (Inherited from PDFBrush)
Top

See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFEllipse Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFEllipse Class

For a list of all members of this type, see PDFEllipse members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFEllipse Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Properties$$

PDFMetafile Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

For a list of all members of this type, see PDFMetafile members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the y-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Brush | Gets or sets the brush used to fill the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | ContentMirroring | Gets or sets the mirroring of the form XObject's content. (Inherited from PDFFormXObject)
Public Property | Height | Gets or sets the height of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Left | Gets or sets the x-coordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Orientation | Gets or sets the orientation of the graphic block. (Inherited from PDFFormXObject)
Public Property | Pen | Gets or sets the pen used to draw the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | PointsCount | Gets the number of necessary points to represent the graphic object. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphic)
Public Property | Right | Gets or sets the x-coordinate of the bottom right corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Top | Gets or sets the y cordinate of the top left corner of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Public Property | Width | Gets or sets the width of the bounding rectangle. Supported by Compact .NET Edition. (Inherited from PDFRectangularObject)
Top

See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Properties$$

PDFAlphaChannelMask Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

For a list of all members of this type, see PDFAlphaChannelMask members.

Public Properties

 | Name | Description
Public Property | FileName | Gets or sets the name of the file representing the mask. (Inherited from PDFImageMask)
Public Property | Image | Gets or sets the image object representing mask. (Inherited from PDFImageMask)
Public Property | Stream | Gets or sets the stream storing the image mask. (Inherited from PDFImageMask)
Top

See Also

Reference

PDFAlphaChannelMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Methods$$

PDFException Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFException Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageTemplate Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageTemplate Class

For a list of all members of this type, see PDFPageTemplate members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of annotations included in this page. (Inherited from PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from PDFPage)
Public Property | Canvas | Gets the canvas of the page. Supported by Compact .NET Edition. (Inherited from PDFPage)
Public Property | CloseAction | Gets or sets the javascript action to execute when the page is closed. (Inherited from PDFPage)
Public Property | CustomProperties | Gets the collection of custom properties of the page. (Inherited from PDFPage)
Public Property | Document | Gets the owner document of the page. Supported by Compact .NET Edition. (Inherited from PDFPage)
Public Property | Fields | Gets the list of fields included in this page. (Inherited from PDFPage)
Public Property | LogicalUnit | Gets or sets the logical unit for positioning the graphic objects in the page. (Inherited from PDFPage)
Public Property | OpenAction | Gets or sets the javascript action to execute when the page is opened. (Inherited from PDFPage)
Top

See Also

Reference

PDFPageTemplate Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFParserException Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFParserException Class

For a list of all members of this type, see PDFParserException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFParserException Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFParserException Class

For a list of all members of this type, see PDFParserException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace